OcNOS-DC 6.4.2 : Quality of Service Guide : Quality of Service Configuration Guide : Hierarchical Queuing Configuration
Hierarchical Queuing Configuration
This chapter contains a complete sample of configuring hierarchical queuing.
Topology
Simple configuration of Hierarchical Queuing
Configuring Hierarchical Queuing
Do the following to configure 3-level hierarchical queuing on an interface.
 
#configure terminal
Enter configure mode.
(config)#qos enable
Enable QoS globally.
(config)#qos statistics
Enable QoS statistics.
(config)#class-map type qos match-any C_QOS1
Configure class-map C_QOS1 of type qos and enter into class-map mode
(config-cmap-qos)#match cos 0
Configure match criteria as cos 0
(config-cmap-qos)#match dscp 0-7
Configure match criteria as dscp 0-7
(config-cmap-qos)#exit
Exit out of cmap mode
(config)#class-map type qos match-any C_QOS2
Configure class-map C_QOS2 of type qos and enter into class-map mode
(config-cmap-qos)#match cos 1
Configure match criteria as cos 1
(config-cmap-qos)#match dscp 8-15
Configure match criteria as dscp 8-15
(config-cmap-qos)#exit
Exit out of cmap mode
(config)#class-map type qos match-any C_QOS3
Configure class-map C_QOS3 of type qos and enter into class-map mode
(config-cmap-qos)#match cos 2
Configure match criteria as cos 2
(config-cmap-qos)#match dscp 16-23
Configure match criteria as dscp 16-23
(config-cmap-qos)#exit
Exit out of cmap mode
(config)#class-map type qos match-any C_QOS4
Configure class-map C_QOS4 of type qos and enter into class-map mode
(config-cmap-qos)#match cos 3
Configure match criteria as cos 3
(config-cmap-qos)#match dscp 24-31
Configure match criteria as dscp 24-31
(config-cmap-qos)#exit
Exit out of cmap mode
(config)#class-map type qos match-any C_QOS5
Configure class-map C_QOS5 of type qos and enter into class-map mode
(config-cmap-qos)#match cos 4
Configure match criteria as cos 4
(config-cmap-qos)#match dscp 32-39
Configure match criteria as dscp 32-39
(config-cmap-qos)#exit
Exit out of cmap mode
(config)#class-map type qos match-any C_QOS6
Configure class-map C_QOS6 of type qos and enter into class-map mode
(config-cmap-qos)#match cos 5
Configure match criteria as cos 5
(config-cmap-qos)#match dscp 40-47
Configure match criteria as dscp 40-47
(config-cmap-qos)#exit
Exit out of cmap mode
(config)#class-map type qos match-any C_QOS7
Configure class-map C_QOS7 of type qos and enter into class-map mode
(config-cmap-qos)#match cos 6
Configure match criteria as cos 6
(config-cmap-qos)#match dscp 48-55
Configure match criteria as dscp 48-55
(config-cmap-qos)#exit
Exit out of cmap mode
(config)#class-map type qos match-any C_QOS8
Configure class-map C_QOS8 of type qos and enter into class-map mode
(config-cmap-qos)#match cos 7
Configure match criteria as cos 7
(config-cmap-qos)#match dscp 56-63
Configure match criteria as dscp 56-63
(config-cmap-qos)#exit
Exit out of cmap mode
(config)#class-map type queuing match-any cq1
Configure class-map cq1 of type queuing and enter into class-map mode.
(config-cmap-que)#match qos-group 1
Configure match criteria as qos-group 1
(config-cmap-que)#exit
Exit out of cmap mode.
(config)#class-map type queuing match-any cq2
Configure class-map cq2 of type queuing and enter into class-map mode.
(config-cmap-que)#match qos-group 2
Configure match criteria as qos-group 2
(config-cmap-que)#exit
Exit out of cmap mode.
(config)#class-map type queuing match-any cq3
Configure class-map cq3 of type queuing and enter into class-map mode.
(config-cmap-que)#match qos-group 3
Configure match criteria as qos-group 3
(config-cmap-que)#exit
Exit out of cmap mode.
(config)#class-map type queuing match-any cq4
Configure class-map cq4 of type queuing and enter into class-map mode.
(config-cmap-que)#match qos-group 4
Configure match criteria as qos-group 4
(config-cmap-que)#exit
Exit out of cmap mode.
(config)#class-map type queuing match-any cq5
Configure class-map cq5 of type queuing and enter into class-map mode.
(config-cmap-que)#match qos-group 5
Configure match criteria as qos-group 5
(config-cmap-que)#exit
Exit out of cmap mode.
(config)#class-map type queuing match-any cq6
Configure class-map cq6 of type queuing and enter into class-map mode.
(config-cmap-que)#match qos-group 6
Configure match criteria as qos-group 6
(config-cmap-que)#exit
Exit out of cmap mode.
(config)#class-map type queuing match-any cq7
Configure class-map cq7 of type queuing and enter into class-map mode.
(config-cmap-que)#match qos-group 7
Configure match criteria as qos-group 7
(config-cmap-que)#exit
Exit out of cmap mode.
(config)#class-map type queuing match-any cq8
Configure class-map cq8 of type queuing and enter into class-map mode.
(config-cmap-que)#match qos-group 8
Configure match criteria as qos-group 8
(config-cmap-que)#exit
Exit out of cmap mode.
(config)#policy-map type qos pmap1
Configure policy-map pmap1 og type qos and enter into policy-map mode.
(config-pmap-qos)#class type qos C_QOS1
Assign class C-QOS1 to pmap1 and enter into policy-class-map mode.
(config-pmap-c-qos)#set qos-group 1
Remark matched traffic to qos-group 1
(config-pmap-c-qos)#exit
Exit out of policy-class-map mode
(config-pmap-qos)#class type qos C_QOS2
Assign class C-QOS2 to pmap1 and enter into policy-class-map mode.
(config-pmap-c-qos)#set qos-group 2
Remark matched traffic to qos-group 2
(config-pmap-c-qos)#exit
Exit out of policy-class-map mode
(config-pmap-qos)#class type qos C_QOS3
Assign class C-QOS3 to pmap1 and enter into policy-class-map mode.
(config-pmap-c-qos)#set qos-group 3
Remark matched traffic to qos-group 3
(config-pmap-c-qos)#exit
Exit out of policy-class-map mode
(config-pmap-qos)#class type qos C_QOS4
Assign class C-QOS4 to pmap1 and enter into policy-class-map mode.
(config-pmap-c-qos)#set qos-group 4
Remark matched traffic to qos-group 4
(config-pmap-c-qos)#exit
Exit out of policy-class-map mode
(config-pmap-qos)#class type qos C_QOS5
Assign class C-QOS5 to pmap1 and enter into policy-class-map mode.
(config-pmap-c-qos)#set qos-group 5
Remark matched traffic to qos-group 5
(config-pmap-c-qos)#exit
Exit out of policy-class-map mode
(config-pmap-qos)#class type qos C_QOS6
Assign class C-QOS6 to pmap1 and enter into policy-class-map mode.
(config-pmap-c-qos)#set qos-group 6
Remark matched traffic to qos-group 6
(config-pmap-c-qos)#exit
Exit out of policy-class-map mode
(config-pmap-qos)#class type qos C_QOS7
Assign class C-QOS7 to pmap1 and enter into policy-class-map mode.
(config-pmap-c-qos)#set qos-group 7
Remark matched traffic to qos-group 7
(config-pmap-c-qos)#exit
Exit out of policy-class-map mode
(config-pmap-qos)#class type qos C_QOS8
Assign class C-QOS8 to pmap1 and enter into policy-class-map mode.
(config-pmap-c-qos)#set qos-group 8
Remark matched traffic to qos-group 8
(config-pmap-c-qos)#exit
Exit out of policy-class-map mode
(config-pmap-qos)#exit
Exit out of policy-map mode
(config)#policy-map type queuing P1P1
Configure policy-map of type queuing P1P1 and enter into policy-map mode.
(config-pmap-que)#class type queuing cq1
Assign class cq1 to policy-map P1 and enter into policy-class-map mode.
(config-pmap-c-que)#shape average percent 20
Shape the matched traffic to percent 20
(config-pmap-c-que)#queue-limit 70 packets
Configure tail-drop on q1 to 70 packets.
(config-pmap-c-que)#bandwidth percent 18
Configure minimum bandwidth to 18 percent on q1.
(config-pmap-c-que)#exit
Exit out of policy-class-map mode.
(config-pmap-que)#class type queuing cq2
Assign class cq2 to policy-map P1 and enter into policy-class-map mode.
(config-pmap-c-que)#shape average percent 80
Shape the matched traffic to percent 80
(config-pmap-c-que)#queue-limit 70 packets
Configure tail-drop on q2 to 70 packets.
(config-pmap-c-que)#bandwidth percent 75
Configure minimum bandwidth to 75 percent on q2.
(config-pmap-c-que)#exit
Exit out of policy-class-map mode.
(config-pmap-que)#exit
Exit out of policy-map mode.
(config)#policy-map type queuing P2
Configure policy-map of type queuing P2 and enter into policy-map mode.
(config-pmap-que)#class type queuing cq3
Assign class cq3 to policy-map P2 and enter into policy-class-map mode.
(config-pmap-c-que)#shape average percent 25
Shape the matched traffic to percent 25
(config-pmap-c-que)#random-detect min-threshold 50 max-threshold 75 kbytes
Configure WRED on q3 to minimum threshold 50 and maximum threshold 75 packets.
(config-pmap-c-que)#bandwidth percent 20
Configure minimum bandwidth to 20 percent on q3.
(config-pmap-c-que)#exit
Exit out of policy-class-map mode.
(config-pmap-que)#class type queuing cq4
Assign class cq4 to policy-map P2 and enter into policy-class-map mode.
(config-pmap-c-que)#shape average percent 75
Shape the matched traffic to percent 75
(config-pmap-c-que)#random-detect min-threshold 50 max-threshold 75 kbytes
Configure WRED on q4 to minimum threshold 50 and maximum threshold 75 kbytes.
(config-pmap-c-que)#bandwidth percent 65
Configure minimum bandwidth to 65 percent on q4.
(config-pmap-c-que)#exit
Exit out of policy-class-map mode.
(config-pmap-que)#exit
Exit out of policy-map mode.
(config)#policy-map type queuing P3
Configure policy-map of type queuing P3 and enter into policy-map mode.
(config-pmap-que)#class type queuing cq5
Assign class cq5 to policy-map P3 and enter into policy-class-map mode.
(config-pmap-c-que)#shape average percent 40
Shape the matched traffic to percent 40
(config-pmap-c-que)#queue-limit 100 packets
Configure Tail-Drop on q5 to 100 packets.
(config-pmap-c-que)#bandwidth percent 35
Configure minimum bandwidth to 35 percent on q5.
(config-pmap-c-que)#exit
Exit out of policy-class-map mode.
(config-pmap-que)#class type queuing cq6
Assign class cq6 to policy-map P3 and enter into policy-class-map mode.
(config-pmap-c-que)#shape average percent 60
Shape the matched traffic to percent 60
(config-pmap-c-que)#queue-limit 100 packets
Configure Tail-Drop on q6 to 100 packets.
(config-pmap-c-que)#bandwidth percent 55
Configure minimum bandwidth to 55 percent on q6.
(config-pmap-c-que)#exit
Exit out of policy-class-map mode.
(config-pmap-que)#exit
Exit out of policy-map mode.
(config)#policy-map type queuing P4
Configure policy-map of type queuing P4 and enter into policy-map mode.
(config-pmap-que)#class type queuing cq7
Assign class cq7 to policy-map P4 and enter into policy-class-map mode.
(config-pmap-c-que)#shape average percent 40
Shape the matched traffic to percent 40
(config-pmap-c-que)#random-detect min-threshold 80 packets max-threshold 100 packets
Configure WRED on q7 to maximum threshold of 80 packets and maximum threshold of 100 packets..
(config-pmap-c-que)#bandwidth percent 35
Configure minimum bandwidth to 35 percent on q7.
(config-pmap-c-que)#exit
Exit out of policy-class-map mode.
(config-pmap-que)#class type queuing cq8
Assign class cq8 to policy-map P4 and enter into policy-class-map mode.
(config-pmap-c-que)#shape average percent 60
Shape the matched traffic to percent 60
(config-pmap-c-que)#random-detect min-threshold 80 packets max-threshold 100 packets
Configure WRED on q8 to minimum threshold of 80 packets and maximum threshold of 100 packets..
(config-pmap-c-que)#bandwidth percent 55
Configure minimum bandwidth to 55 percent on q8.
(config-pmap-c-que)#exit
Exit out of policy-class-map mode.
(config-pmap-que)#exit
Exit out of policy-map mode.
(config)#class-map type queuing match-any empty1
Configure class-map of type queuing empty1
(config-cmap-que)#exit
Exit out of cmap mode
(config)#class-map type queuing match-any empty2
Configure class-map of type queuing empty2
(config-cmap-que)#exit
Exit out of cmap mode
(config)#class-map type queuing match-any empty3
Configure class-map of type queuing empty3
(config-cmap-que)#exit
Exit out of cmap mode
(config)#class-map type queuing match-any empty4
Configure class-map of type queuing empty4
(config-cmap-que)#exit
Exit out of cmap mode
(config)#class-map type queuing match-any empty5
Configure class-map of type queuing empty5
(config-cmap-que)#exit
Exit out of cmap mode
(config)#class-map type queuing match-any empty6
Configure class-map of type queuing empty6
(config-cmap-que)#exit
Exit out of cmap mode
(config)#policy-map type queuing P1P2
Configure policy-map of type queuing P1P2 and enter into policy-map mode.
(config-pmap-que)#class type queuing empty1
Assign class-map of type queuing empty1 to P1P2 and enter into policy-class-map mode.
(config-pmap-c-que)#shape average percent 40
Shape the matched traffic to 40 percent
(config-pmap-c-que)#bandwidth percent 30
Configure minimum bandwidth to 30 percent on empty1.
(config-pmap-c-que)#service-policy P1P1
Assign service-policy P1P1
(config-pmap-c-que)#exit
Exit out of policy-class-map mode.
(config-pmap-que)#class type queuing empty2
Assign class-map of type queuing empty2 to P1P2 and enter into policy-class-map mode.
(config-pmap-c-que)#shape average percent 60
Shape the matched traffic to 60 percent
(config-pmap-c-que)#bandwidth percent 55
Configure minimum bandwidth to 55 percent on empty2.
(config-pmap-c-que)#service-policy P2
Assign service-policy P2
(config-pmap-c-que)#exit
Exit out of policy-class-map mode.
(config-pmap-que)#exit
Exit out of policy-map mode.
(config)#policy-map type queuing P3P4
Configure policy-map of type queuing P3P4 and enter into policy-map mode.
(config-pmap-que)#class type queuing empty3
Assign class-map of type queuing empty3 to P3P4 and enter into policy-class-map mode.
(config-pmap-c-que)#shape average percent 40
Shape the matched traffic to 40 percent
(config-pmap-c-que)#bandwidth percent 35
Configure minimum bandwidth to 35 percent on empty3.
(config-pmap-c-que)#service-policy P3
Assign service-policy P3
(config-pmap-c-que)#exit
Exit out of policy-class-map mode.
(config-pmap-que)#class type queuing empty4
Assign class-map of type queuing empty4 to P3P4 and enter into policy-class-map mode.
(config-pmap-c-que)#shape average percent 60
Shape the matched traffic to 60 percent
(config-pmap-c-que)#bandwidth percent 50
Configure minimum bandwidth to 50 percent on empty4.
(config-pmap-c-que)#service-policy P4
Assign service-policy P4
(config-pmap-c-que)#exit
Exit out of policy-class-map mode.
(config-pmap-que)#exit
Exit out of policy-map mode.
(config)#policy-map type queuing Pend
Configure policy-map of type queuing Pend and enter into policy-map mode.
(config-pmap-que)#class type queuing empty5
Assign class-map of type queuing empty5 to Pend and enter into policy-class-map mode.
(config-pmap-c-que)#shape average 400 mbps
Shape the matched traffic to 400 mbps
(config-pmap-c-que)#bandwidth 350 mbps
Configure minimum bandwidth to 350 mbps.
(config-pmap-c-que)#service-policy P1P1
Assign service-policy P1P1
(config-pmap-c-que)#exit
Exit out of policy-class-map mode.
(config-pmap-que)#class type queuing empty6
Assign class-map of type queuing empty6 to Pend and enter into policy-class-map mode.
(config-pmap-c-que)#shape average 500 mbps
Shape the matched traffic to 500 mbps
(config-pmap-c-que)#bandwidth 450 mbps
Configure minimum bandwidth to 450 mbps.
(config-pmap-c-que)#service-policy P3P4
Assign service-policy P3P4
(config-pmap-c-que)#exit
Exit out of policy-class-map mode.
(config-pmap-que)#exit
Exit out of policy-map mode.
(config)#interface xe2
Enter into interface mode
(config-if)#service-policy type qos input pmap1
Assign service-policy of type qos policy-map1.
(config-if)#exit
Exit out of intf mode
(config)#interface xe3
Enter into interface mode
(config-if)#service-policy type queuing output Pend
Assign service-policy of type queing pend on out direction.
(config-if)#exit
Exit out of interface mode.
Configuring one of the scheduler modes implicitly un-configures other modes, only one scheduler mode can be configured at a time.
(config)#set qos wrr uc 1 non-uc 2
Schedule unicast and multicast traffic in 1:2
(config)#set qos sp
Set strict priority between unicast and multicast traffic, with higher priority to multicast traffic
(config)#interface xe49/2
Enter interface mode
(config-if)#exit
Exit interface mode
(config)#bridge 1 protocol rstp vlan-bridge
Specify VLAN for bridge 1.
(config)#vlan database
Enter the VLAN configuration mode.
(config-vlan)#vlan 2-3 bridge 1 state enable
Enable VLAN (2-3) on bridge 1. Specifying the enable state.
(config-vlan)#exit
Exit the VLAN configuration mode.
(config)#interface vlan1.2
Enter interface mode.
(config-if)# ip address 10.1.1.2/24
Configure the IP address.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.3
Enter interface mode.
(config-if)# ip address 20.1.1.1/24
Configure the IP address.
(config-if)#exit
Exit the interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#switchport
Configure xe2 as a Layer 2 port.
(config-if)#bridge-group 1
Associate the interface with bridge group 1.
(config-if)#switchport mode trunk
Configure port as a trunk.
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the xe3 interface.
(config-if)#exit
Exit the interface mode.
(config)#interface xe3
Enter interface mode.
(config-if)#switchport
Configure xe3 as a Layer 2 port.
(config-if)#bridge-group 1
Associate the interface with bridge group 1.
(config-if)#switchport mode trunk
Configure port as a trunk.
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the xe3 interface.
(config-if)#exit
Exit the interface mode.
Validation
Enter the commands listed in the sections below to confirm the configurations.
#show running-config qos
qos enable
!
set qos wrr uc 1 non-uc 2
qos statistics
!
class-map type qos match-any C_QOS1
match dscp 0-7
match cos 0
!
class-map type qos match-any C_QOS2
match dscp 8-15
match cos 1
!
class-map type qos match-any C_QOS3
match dscp 16-23
match cos 2
!
class-map type qos match-any C_QOS4
match dscp 24-31
match cos 3
!
class-map type qos match-any C_QOS5
match dscp 32-39
match cos 4
!
class-map type qos match-any C_QOS6
match dscp 40-47
match cos 5
!
class-map type qos match-any C_QOS7
match dscp 48-55
match cos 6
!
class-map type qos match-any C_QOS8
match dscp 56-63
match cos 7
!
class-map type queuing match-any cq1
match qos-group 1
!
class-map type queuing match-any cq2
match qos-group 2
!
class-map type queuing match-any cq3
match qos-group 3
!
class-map type queuing match-any cq4
match qos-group 4
!
class-map type queuing match-any cq5
!
class-map type queuing match-any cq6
match qos-group 6
!
class-map type queuing match-any cq7
match qos-group 7
!
class-map type queuing match-any cq8
match qos-group 8
!
class-map type queuing match-any empty1
!
class-map type queuing match-any empty2
!
class-map type queuing match-any empty3
!
class-map type queuing match-any empty4
!
class-map type queuing match-any empty5
!
class-map type queuing match-any empty6
!
policy-map type qos pmap1
class type qos C_QOS1
set qos-group 1
exit
class type qos C_QOS2
set qos-group 2
exit
class type qos C_QOS3
set qos-group 3
exit
class type qos C_QOS4
set qos-group 4
exit
class type qos C_QOS5
set qos-group 5
exit
class type qos C_QOS6
set qos-group 6
exit
class type qos C_QOS7
set qos-group 7
exit
class type qos C_QOS8
set qos-group 8
exit
!
policy-map type queuing P1P1
class type queuing cq1
shape average percent 20
wrr-queue weight 1
queue-limit 70 packets
bandwidth percent 18
exit
class type queuing cq2
shape average percent 80
wrr-queue weight 1
queue-limit 70 packets
bandwidth percent 75
exit
!
policy-map type queuing P2
class type queuing cq3
shape average percent 25
wrr-queue weight 1
random-detect min-threshold 50 max-threshold 75 kbytes
bandwidth percent 20
exit
class type queuing cq4
shape average percent 75
wrr-queue weight 1
random-detect min-threshold 50 max-threshold 75 kbytes
bandwidth percent 65
exit
!
policy-map type queuing P3
class type queuing cq5
shape average percent 40
wrr-queue weight 1
queue-limit 100 packets
bandwidth percent 35
exit
class type queuing cq6
shape average percent 60
wrr-queue weight 1
queue-limit 100 packets
bandwidth percent 55
exit
!
policy-map type queuing P4
class type queuing cq7
shape average percent 40
wrr-queue weight 1
random-detect min-threshold 80 max-threshold 100 packets
bandwidth percent 35
exit
class type queuing cq8
shape average percent 60
wrr-queue weight 1
random-detect min-threshold 80 max-threshold 100 packets
bandwidth percent 55
exit
!
!
policy-map type queuing P3P4
class type queuing empty3
shape average percent 40
wrr-queue weight 1
bandwidth percent 35
service-policy P3
exit
class type queuing empty4
shape average percent 60
wrr-queue weight 1
bandwidth percent 50
service-policy P4
exit
!
policy-map type queuing P1P2
class type queuing empty1
shape average percent 40
wrr-queue weight 1
bandwidth percent 30
service-policy P1P1
exit
class type queuing empty2
shape average percent 60
wrr-queue weight 1
bandwidth percent 55
service-policy P2
exit
!
policy-map type queuing Pend
class type queuing empty5
shape average 400 mbps
wrr-queue weight 1
bandwidth 350 mbps
service-policy P1P1
exit
class type queuing empty6
shape average 500 mbps
wrr-queue weight 1
bandwidth 450 mbps
service-policy P3P4
exit
!
!
interface xe2
service-policy type qos input pmap1
!
interface xe3
service-policy type queuing output Pend
!
 
 
 
#sh class-map
 
Type qos class-maps
===================
class-map type qos match-any C_QOS1
match cos 0
match dscp 0-7
 
class-map type qos match-any C_QOS2
match cos 1
match dscp 8-15
 
class-map type qos match-any C_QOS3
match cos 2
match dscp 16-23
 
class-map type qos match-any C_QOS4
match cos 3
match dscp 24-31
 
class-map type qos match-any C_QOS5
match cos 4
match dscp 32-39
 
class-map type qos match-any C_QOS6
match cos 5
match dscp 40-47
 
class-map type qos match-any C_QOS7
match cos 6
match dscp 48-55
 
class-map type qos match-any C_QOS8
match cos 7
match dscp 56-63
 
class-map type qos match-any class-default
 
 
Type queuing class-maps
=======================
class-map type queuing match-any cq1
match qos-group 1
 
class-map type queuing match-any cq2
match qos-group 2
 
class-map type queuing match-any cq3
match qos-group 3
 
class-map type queuing match-any cq4
match qos-group 4
 
class-map type queuing match-any cq5
 
class-map type queuing match-any cq6
match qos-group 6
 
class-map type queuing match-any cq7
match qos-group 7
 
class-map type queuing match-any cq8
match qos-group 8
 
class-map type queuing match-any empty1
 
class-map type queuing match-any empty2
 
class-map type queuing match-any empty3
 
class-map type queuing match-any empty4
 
class-map type queuing match-any empty5
 
class-map type queuing match-any empty6
 
class-map match-any q0
 
class-map match-any q1
 
class-map match-any q2
 
class-map match-any q3
 
class-map match-any q4
 
class-map match-any q5
 
class-map match-any q6
 
class-map match-any q7
 
 
Type Vlan-Queuing class-maps
============================
 
#show policy-map
 
Type qos policy-maps
====================
 
policy-map type qos pmap1
class type qos C_QOS1
set qos-group 1
exit
class type qos C_QOS2
set qos-group 2
exit
class type qos C_QOS3
set qos-group 3
exit
class type qos C_QOS4
set qos-group 4
exit
class type qos C_QOS5
set qos-group 5
exit
class type qos C_QOS6
set qos-group 6
exit
class type qos C_QOS7
set qos-group 7
exit
class type qos C_QOS8
set qos-group 8
exit
 
 
Type queuing policy-maps
========================
 
policy-map type queuing P1P1
class type queuing cq1
shape average percent 20
wrr-queue weight 1
queue-limit 70 packets
bandwidth percent 18
exit
class type queuing cq2
shape average percent 80
wrr-queue weight 1
queue-limit 70 packets
bandwidth percent 75
exit
 
policy-map type queuing P1P2
class type queuing empty1
shape average percent 40
wrr-queue weight 1
bandwidth percent 30
service-policy P1P1
exit
class type queuing empty2
shape average percent 60
wrr-queue weight 1
bandwidth percent 55
service-policy P2
exit
 
policy-map type queuing P2
class type queuing cq3
shape average percent 25
wrr-queue weight 1
random-detect min-threshold 50 max-threshold 75 kbytes
bandwidth percent 20
exit
class type queuing cq4
shape average percent 75
wrr-queue weight 1
random-detect min-threshold 50 max-threshold 75 kbytes
bandwidth percent 65
exit
 
policy-map type queuing P3
class type queuing cq5
shape average percent 40
wrr-queue weight 1
queue-limit 100 packets
bandwidth percent 35
exit
class type queuing cq6
shape average percent 60
wrr-queue weight 1
queue-limit 100 packets
bandwidth percent 55
exit
 
policy-map type queuing P3P4
class type queuing empty3
shape average percent 40
wrr-queue weight 1
bandwidth percent 35
service-policy P3
exit
class type queuing empty4
shape average percent 60
wrr-queue weight 1
bandwidth percent 50
service-policy P4
exit
 
policy-map type queuing P4
class type queuing cq7
shape average percent 40
wrr-queue weight 1
random-detect min-threshold 80 max-threshold 100 packets
bandwidth percent 35
exit
class type queuing cq8
shape average percent 60
wrr-queue weight 1
random-detect min-threshold 80 max-threshold 100 packets
bandwidth percent 55
exit
 
policy-map type queuing Pend
class type queuing empty5
shape average 400 mbps
wrr-queue weight 1
bandwidth 350 mbps
service-policy P1P1
exit
class type queuing empty6
shape average 500 mbps
wrr-queue weight 1
bandwidth 450 mbps
service-policy P3P4
exit
 
policy-map type queuing default default-out-policy
class type queuing default q0
priority level 1
exit
class type queuing default q1
priority level 1
exit
class type queuing default q2
priority level 1
exit
class type queuing default q3
priority level 1
exit
class type queuing default q4
priority level 1
exit
class type queuing default q5
priority level 1
exit
class type queuing default q6
priority level 1
exit
class type queuing default q7
priority level 1
exit
 
 
#show policy-map interface xe2
 
Interface xe2
Global statistics status : enabled
 
Service-policy (qos) input : pmap1
--------------------------------
Class-map (qos): C_QOS1 (match any)
match dscp 0-7
match cos 0
set qos-group 1
matched : 2 packets, 128 bytes
transmitted : 2 packets, 128 bytes
 
Class-map (qos): C_QOS2 (match any)
match dscp 8-15
match cos 1
set qos-group 2
matched : 23751790 packets, 1520114560 bytes
transmitted : 23751790 packets, 1520114560 bytes
 
Class-map (qos): C_QOS3 (match any)
match dscp 16-23
match cos 2
set qos-group 3
matched : 5412521 packets, 346401344 bytes
transmitted : 5412521 packets, 346401344 bytes
 
Class-map (qos): C_QOS4 (match any)
match dscp 24-31
match cos 3
set qos-group 4
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
Class-map (qos): C_QOS5 (match any)
match dscp 32-39
match cos 4
set qos-group 5
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
Class-map (qos): C_QOS6 (match any)
match dscp 40-47
match cos 5
set qos-group 6
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
Class-map (qos): C_QOS7 (match any)
match dscp 48-55
match cos 6
set qos-group 7
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
Class-map (qos): C_QOS8 (match any)
match dscp 56-63
match cos 7
set qos-group 8
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
 
Service-policy (queuing) output: default-out-policy
-----------------------------------
Class-map (queuing): q0
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q1
priority level 1
output : 1 packets, 64 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q2
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q3
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q4
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q5
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q6
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q7
priority level 1
output : 2058 packets, 131912 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q0
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q2
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q3
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q4
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q5
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q6
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q7
output : 4 packets, 272 bytes
dropped : 0 packets, 0 bytes
 
Wred Drop Statistics :
----------------------
green : 0 packets
yellow : 0 packets
red : 0 packets
 
 
#show policy-map interface xe3
 
Interface xe3
Global statistics status : enabled
 
Service-policy (queuing) output: Pend
-----------------------------------
Class-map (queuing): empty5
shape average 400 mbps
wrr-queue weight 1
bandwidth 350 mbps
 
Service-policy (queuing) output: P1P1
-----------------------------------
Class-map (queuing): cq1
match qos-group 1
shape percent 20
wrr-queue weight 1
queue-limit 70 packets
bandwidth percent 18
output : 1 packets, 64 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): cq2
match qos-group 2
shape percent 80
wrr-queue weight 1
queue-limit 70 packets
bandwidth percent 75
output : 10290336 packets, 658581504 bytes
dropped : 13382099 packets, 856454336 bytes
 
Class-map (queuing): empty6
shape average 500 mbps
wrr-queue weight 1
bandwidth 450 mbps
 
Service-policy (queuing) output: P3P4
-----------------------------------
Class-map (queuing): empty3
shape percent 40
wrr-queue weight 1
bandwidth percent 35
 
Service-policy (queuing) output: P3
-----------------------------------
Class-map (queuing): cq5
shape percent 40
wrr-queue weight 1
queue-limit 100 packets
bandwidth percent 35
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): cq6
match qos-group 6
shape percent 60
wrr-queue weight 1
queue-limit 100 packets
bandwidth percent 55
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): empty4
shape percent 60
wrr-queue weight 1
bandwidth percent 50
 
Service-policy (queuing) output: P4
-----------------------------------
Class-map (queuing): cq7
match qos-group 7
shape percent 40
wrr-queue weight 1
random-detect min-threshold 80 max-threshold 100 packets
bytes
kbytes
percent
bandwidth percent 35
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): cq8
match qos-group 8
shape percent 60
wrr-queue weight 1
random-detect min-threshold 80 max-threshold 100 packets
bytes
kbytes
percent
bandwidth percent 55
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Service-policy (queuing) output: default-out-policy
-----------------------------------
Class-map (queuing): q0
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q1
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q2
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q3
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q4
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q5
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q6
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q7
priority level 1
output : 2011 packets, 128964 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q0
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q2
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q3
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q4
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q5
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q6
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q7
output : 11 packets, 748 bytes
dropped : 0 packets, 0 bytes
 
Wred Drop Statistics :
----------------------
green : 13382099 packets
yellow : 0 packets
red : 0 packets
 
 
#show queuing interface xe2
 
Egress Queuing for Ethernet xe2 [System]
------------------------------------------------------------------------------
L0 L1 L2 Group PrioLevel Shape
Bandwidth
------------------------------------------------------------------------------
q0 - High -
-
q1 - High -
-
q2 - High -
-
q3 - High -
-
q4 - High -
-
q5 - High -
-
q6 - High -
-
q7 - High -
 
 
#show queuing interface xe3
 
Egress Queuing for Ethernet xe3 [System]
------------------------------------------------------------------------------
L0 L1 L2 Group PrioLevel Shape
Bandwidth
------------------------------------------------------------------------------
empty5 - - 400 mbps
350 mbps
cq1 1 - 20 percent
18 percent
cq2 2 - 80 percent
75 percent
empty6 - - 500 mbps
450 mbps
empty3 - - 40 percent
35 percent
cq5 - - 40 percent
35 percent
cq6 6 - 60 percent
55 percent
empty4 - - 60 percent
50 percent
cq7 7 - 40 percent
35 percent
cq8 8 - 60 percent
55 percent
 
 
(config)#set qos wrr uc 1 non-uc 127
(config)#exit
 
#show policy-map interface xe2
 
Interface xe2
Global statistics status : enabled
 
Service-policy (qos) input : pmap1
--------------------------------
Class-map (qos): C_QOS1 (match any)
match dscp 0-7
match cos 0
set qos-group 1
matched : 2 packets, 128 bytes
transmitted : 2 packets, 128 bytes
 
Class-map (qos): C_QOS2 (match any)
match dscp 8-15
match cos 1
set qos-group 2
matched : 24126931 packets, 1544123584 bytes
transmitted : 24126931 packets, 1544123584 bytes
 
Class-map (qos): C_QOS3 (match any)
match dscp 16-23
match cos 2
set qos-group 3
matched : 5412521 packets, 346401344 bytes
transmitted : 5412521 packets, 346401344 bytes
 
Class-map (qos): C_QOS4 (match any)
match dscp 24-31
match cos 3
set qos-group 4
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
Class-map (qos): C_QOS5 (match any)
match dscp 32-39
match cos 4
set qos-group 5
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
Class-map (qos): C_QOS6 (match any)
match dscp 40-47
match cos 5
set qos-group 6
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
Class-map (qos): C_QOS7 (match any)
match dscp 48-55
match cos 6
set qos-group 7
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
Class-map (qos): C_QOS8 (match any)
match dscp 56-63
match cos 7
set qos-group 8
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
 
Service-policy (queuing) output: default-out-policy
-----------------------------------
Class-map (queuing): q0
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q1
priority level 1
output : 1 packets, 64 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q2
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q3
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q4
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q5
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q6
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q7
priority level 1
output : 2245 packets, 143880 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q0
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q2
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q3
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q4
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q5
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q6
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q7
output : 4 packets, 272 bytes
dropped : 0 packets, 0 bytes
 
Wred Drop Statistics :
----------------------
green : 0 packets
yellow : 0 packets
red : 0 packets
 
 
#show policy-map interface xe3
 
Interface xe3
Global statistics status : enabled
 
Service-policy (queuing) output: Pend
-----------------------------------
Class-map (queuing): empty5
shape average 400 mbps
wrr-queue weight 1
bandwidth 350 mbps
 
Service-policy (queuing) output: P1P1
-----------------------------------
Class-map (queuing): cq1
match qos-group 1
shape percent 20
wrr-queue weight 1
queue-limit 70 packets
bandwidth percent 18
output : 1 packets, 64 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): cq2
match qos-group 2
shape percent 80
wrr-queue weight 1
queue-limit 70 packets
bandwidth percent 75
output : 10761532 packets, 688738048 bytes
dropped : 13382100 packets, 856454400 bytes
 
Class-map (queuing): empty6
shape average 500 mbps
wrr-queue weight 1
bandwidth 450 mbps
 
Service-policy (queuing) output: P3P4
-----------------------------------
Class-map (queuing): empty3
shape percent 40
wrr-queue weight 1
bandwidth percent 35
 
Service-policy (queuing) output: P3
-----------------------------------
Class-map (queuing): cq5
shape percent 40
wrr-queue weight 1
queue-limit 100 packets
bandwidth percent 35
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): cq6
match qos-group 6
shape percent 60
wrr-queue weight 1
queue-limit 100 packets
bandwidth percent 55
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): empty4
shape percent 60
wrr-queue weight 1
bandwidth percent 50
 
Service-policy (queuing) output: P4
-----------------------------------
Class-map (queuing): cq7
match qos-group 7
shape percent 40
wrr-queue weight 1
random-detect min-threshold 80 max-threshold 100 packets
bytes
kbytes
percent
bandwidth percent 35
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): cq8
match qos-group 8
shape percent 60
wrr-queue weight 1
random-detect min-threshold 80 max-threshold 100 packets
bytes
kbytes
percent
bandwidth percent 55
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Service-policy (queuing) output: default-out-policy
-----------------------------------
Class-map (queuing): q0
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q1
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q2
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q3
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q4
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q5
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q6
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q7
priority level 1
output : 2246 packets, 144004 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q0
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q2
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q3
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q4
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q5
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q6
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q7
output : 12 packets, 816 bytes
dropped : 0 packets, 0 bytes
 
Wred Drop Statistics :
----------------------
green : 13382099 packets
yellow : 0 packets
red : 0 packets
 
 
(config)#set qos wrr uc 1 non-uc 2
(config)#exit
 
#show policy-map interface xe2
 
Interface xe2
Global statistics status : enabled
 
Service-policy (qos) input : pmap1
--------------------------------
Class-map (qos): C_QOS1 (match any)
match dscp 0-7
match cos 0
set qos-group 1
matched : 2 packets, 128 bytes
transmitted : 2 packets, 128 bytes
 
Class-map (qos): C_QOS2 (match any)
match dscp 8-15
match cos 1
set qos-group 2
matched : 24459636 packets, 1565416704 bytes
transmitted : 24459636 packets, 1565416704 bytes
 
Class-map (qos): C_QOS3 (match any)
match dscp 16-23
match cos 2
set qos-group 3
matched : 5412521 packets, 346401344 bytes
transmitted : 5412521 packets, 346401344 bytes
 
Class-map (qos): C_QOS4 (match any)
match dscp 24-31
match cos 3
set qos-group 4
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
Class-map (qos): C_QOS5 (match any)
match dscp 32-39
match cos 4
set qos-group 5
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
Class-map (qos): C_QOS6 (match any)
match dscp 40-47
match cos 5
set qos-group 6
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
Class-map (qos): C_QOS7 (match any)
match dscp 48-55
match cos 6
set qos-group 7
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
Class-map (qos): C_QOS8 (match any)
match dscp 56-63
match cos 7
set qos-group 8
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
 
Service-policy (queuing) output: default-out-policy
-----------------------------------
Class-map (queuing): q0
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q1
priority level 1
output : 1 packets, 64 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q2
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q3
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q4
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q5
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q6
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q7
priority level 1
output : 2412 packets, 154568 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q0
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q2
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q3
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q4
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q5
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q6
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q7
output : 4 packets, 272 bytes
dropped : 0 packets, 0 bytes
 
Wred Drop Statistics :
----------------------
green : 0 packets
yellow : 0 packets
red : 0 packets
 
 
#show policy-map interface xe3
 
Interface xe3
Global statistics status : enabled
 
Service-policy (queuing) output: Pend
-----------------------------------
Class-map (queuing): empty5
shape average 400 mbps
wrr-queue weight 1
bandwidth 350 mbps
 
Service-policy (queuing) output: P1P1
-----------------------------------
Class-map (queuing): cq1
match qos-group 1
shape percent 20
wrr-queue weight 1
queue-limit 70 packets
bandwidth percent 18
output : 1 packets, 64 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): cq2
match qos-group 2
shape percent 80
wrr-queue weight 1
queue-limit 70 packets
bandwidth percent 75
output : 10871860 packets, 695799040 bytes
dropped : 13598654 packets, 870313856 bytes
 
Class-map (queuing): empty6
shape average 500 mbps
wrr-queue weight 1
bandwidth 450 mbps
 
Service-policy (queuing) output: P3P4
-----------------------------------
Class-map (queuing): empty3
shape percent 40
wrr-queue weight 1
bandwidth percent 35
 
Service-policy (queuing) output: P3
-----------------------------------
Class-map (queuing): cq5
shape percent 40
wrr-queue weight 1
queue-limit 100 packets
bandwidth percent 35
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): cq6
match qos-group 6
shape percent 60
wrr-queue weight 1
queue-limit 100 packets
bandwidth percent 55
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): empty4
shape percent 60
wrr-queue weight 1
bandwidth percent 50
 
Service-policy (queuing) output: P4
-----------------------------------
Class-map (queuing): cq7
match qos-group 7
shape percent 40
wrr-queue weight 1
random-detect min-threshold 80 max-threshold 100 packets
bytes
kbytes
percent
bandwidth percent 35
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): cq8
match qos-group 8
shape percent 60
wrr-queue weight 1
random-detect min-threshold 80 max-threshold 100 packets
bytes
kbytes
percent
bandwidth percent 55
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Service-policy (queuing) output: default-out-policy
-----------------------------------
Class-map (queuing): q0
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q1
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q2
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q3
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q4
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q5
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q6
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q7
priority level 1
output : 2410 packets, 154500 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q0
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q2
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q3
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q4
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q5
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q6
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q7
output : 13 packets, 884 bytes
dropped : 0 packets, 0 bytes
 
Wred Drop Statistics :
----------------------
green : 13598643 packets
yellow : 0 packets
red : 0 packets
 
 
(config)#set qos sp
(config)#exit
 
 
#show policy-map interface xe2
 
Interface xe2
Global statistics status : enabled
 
Service-policy (qos) input : pmap1
--------------------------------
Class-map (qos): C_QOS1 (match any)
match dscp 0-7
match cos 0
set qos-group 1
matched : 2 packets, 128 bytes
transmitted : 2 packets, 128 bytes
 
Class-map (qos): C_QOS2 (match any)
match dscp 8-15
match cos 1
set qos-group 2
matched : 24622849 packets, 1575862336 bytes
transmitted : 24622849 packets, 1575862336 bytes
 
Class-map (qos): C_QOS3 (match any)
match dscp 16-23
match cos 2
set qos-group 3
matched : 5412521 packets, 346401344 bytes
transmitted : 5412521 packets, 346401344 bytes
 
Class-map (qos): C_QOS4 (match any)
match dscp 24-31
match cos 3
set qos-group 4
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
Class-map (qos): C_QOS5 (match any)
match dscp 32-39
match cos 4
set qos-group 5
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
Class-map (qos): C_QOS6 (match any)
match dscp 40-47
match cos 5
set qos-group 6
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
Class-map (qos): C_QOS7 (match any)
match dscp 48-55
match cos 6
set qos-group 7
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
Class-map (qos): C_QOS8 (match any)
match dscp 56-63
match cos 7
set qos-group 8
matched : 0 packets, 0 bytes
transmitted : 0 packets, 0 bytes
 
 
Service-policy (queuing) output: default-out-policy
-----------------------------------
Class-map (queuing): q0
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q1
priority level 1
output : 1 packets, 64 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q2
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q3
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q4
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q5
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q6
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q7
priority level 1
output : 2493 packets, 159752 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q0
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q2
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q3
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q4
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q5
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q6
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q7
output : 4 packets, 272 bytes
dropped : 0 packets, 0 bytes
 
Wred Drop Statistics :
----------------------
green : 0 packets
yellow : 0 packets
red : 0 packets
 
 
#show policy-map interface xe3
 
Interface xe3
Global statistics status : enabled
 
Service-policy (queuing) output: Pend
-----------------------------------
Class-map (queuing): empty5
shape average 400 mbps
wrr-queue weight 1
bandwidth 350 mbps
 
Service-policy (queuing) output: P1P1
-----------------------------------
Class-map (queuing): cq1
match qos-group 1
shape percent 20
wrr-queue weight 1
queue-limit 70 packets
bandwidth percent 18
output : 1 packets, 64 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): cq2
match qos-group 2
shape percent 80
wrr-queue weight 1
queue-limit 70 packets
bandwidth percent 75
output : 10871860 packets, 695799040 bytes
dropped : 13743831 packets, 879605184 bytes
 
Class-map (queuing): empty6
shape average 500 mbps
wrr-queue weight 1
bandwidth 450 mbps
 
Service-policy (queuing) output: P3P4
-----------------------------------
Class-map (queuing): empty3
shape percent 40
wrr-queue weight 1
bandwidth percent 35
 
Service-policy (queuing) output: P3
-----------------------------------
Class-map (queuing): cq5
shape percent 40
wrr-queue weight 1
queue-limit 100 packets
bandwidth percent 35
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): cq6
match qos-group 6
shape percent 60
wrr-queue weight 1
queue-limit 100 packets
bandwidth percent 55
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): empty4
shape percent 60
wrr-queue weight 1
bandwidth percent 50
 
Service-policy (queuing) output: P4
-----------------------------------
Class-map (queuing): cq7
match qos-group 7
shape percent 40
wrr-queue weight 1
random-detect min-threshold 80 max-threshold 100 packets
bytes
kbytes
percent
bandwidth percent 35
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): cq8
match qos-group 8
shape percent 60
wrr-queue weight 1
random-detect min-threshold 80 max-threshold 100 packets
bytes
kbytes
percent
bandwidth percent 55
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Service-policy (queuing) output: default-out-policy
-----------------------------------
Class-map (queuing): q0
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q1
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q2
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q3
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q4
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q5
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q6
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q7
priority level 1
output : 2488 packets, 159492 bytes
dropped : 3 packets, 192 bytes
 
Class-map (queuing): mc-q0
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q2
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q3
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q4
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q5
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q6
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q7
output : 13 packets, 884 bytes
dropped : 0 packets, 0 bytes
 
Wred Drop Statistics :
----------------------
green : 13743818 packets
yellow : 0 packets
red : 0 packets