OcNOS-DC 6.4.2 : Quality of Service Guide : Quality of Service Configuration Guide : Tail-Drop Configuration
Tail-Drop Configuration
Topology
Simple configuration of Tail-Drop
Configuring Tail-Drop
The following steps describe how to configure Tail-Drop.
Configuration on L2/L3 Interfaces
Do the following to configure Tail-Drop on a queue.
 
#configure terminal
Enter configure mode.
(config)#qos enable
Enable QoS globally.
(config)#qos statistics
Enable QoS statistics.
(config)#class-map type qos match-all C1
Configure class-map of type qos with name C1, and enter into class-map mode
(config-cmap-que)#match cos 1
match cos value 1
(OcNOS(config-cmap-qos)#exit
Exit out of class-map
(config)#policy-map type qos p1
Enter policy-map configuration mode of type qos
(config-cmap-que)#class type qos C1
Enter class-map configuration mode
(config-cmap-que)# police cir 100 mbps pir 200 mbps
Configure police rate of cir 100 mbps and pir 200 mbps
(config-pmap-c-que)#exit
Exit out of policy-class mode
(config-pmap-qos)#exit
Exit out of policy-class mode
(config)#policy-map type queuing default p3
Configure policy-map of type queuing with name p3 and enter into policy-map mode
(config-cmap-que)#class type queuing default q1
Enter class type of type queuing default configuration mode for q1
(config-pmap-c-que)#shape percent 20
Configure shaping to 20 percent of bandwidth available on interface
(config-pmap-c-que)#exit
Exit out of policy-class mode
(config-pmap-que)#class type queuing default q2
Enter class type of type queuing default configuration mode for q2
(config-pmap-c-que)#bandwidth 25000 kbps
Configure bandwidth to 25000 kbps
(config-pmap-c-que)#queue-limit 99 packets
Configure tail-drop to 99 packets
(config-pmap-c-que)#exit
Exit out of policy-class mode
(config-pmap-que)#class type queuing default q3
Enter class type of type queuing default configuration mode for q3
(config-pmap-c-que)#queue-limit 101 packets
Configure tail-drop to 101 packets
(config-pmap-c-que)#exit
Exit out of policy-class mode
(config-pmap-que)#exit
Exit out of policy-map mode
(config)#interface xe2
Enter interface mode
(config-if)#service-policy type queuing output p3
Attach service-policy p3 of type queuing on out direction
(config-if)#exit
Exit out of interface mode
(config)#interface xe3
Enter interface mode
(config-if)#service-policy type qos input p1
Attach service-policy p1 of type qos on in direction
(config-if)#exit
Exit out of interface mode
(config)#bridge 1 protocol rstp vlan-bridge
Specify VLAN for bridge 1.
(config)#vlan database
Enter the VLAN configuration mode.
(config-vlan)#vlan 2-3 bridge 1 state enable
Enable VLAN (2-3) on bridge 1. Specifying the enable state.
(config-vlan)#exit
Exit the VLAN configuration mode.
(config)#interface vlan1.2
Enter interface mode.
(config-if)# ip address 10.1.1.2/24
Configure the IP address.
(config-if)#exit
Exit the interface mode.
(config)#interface vlan1.3
Enter interface mode.
(config-if)# ip address 20.1.1.1/24
Configure the IP address.
(config-if)#exit
Exit the interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#switchport
Configure xe2 as a Layer 2 port.
(config-if)#bridge-group 1
Associate the interface with bridge group 1.
(config-if)#switchport mode trunk
Configure port as a trunk.
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the xe3 interface.
(config-if)#exit
Exit the interface mode.
(config)#interface xe3
Enter interface mode.
(config-if)#switchport
Configure xe3 as a Layer 2 port.
(config-if)#bridge-group 1
Associate the interface with bridge group 1.
(config-if)#switchport mode trunk
Configure port as a trunk.
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the xe3 interface.
(config-if)#exit
Exit the interface mode.
Validation
Enter the commands below to confirm the configurations.
#show running-config qos
qos enable
!
qos statistics
!
class-map type qos match-all C1
match cos 1
!
policy-map type qos p1
class type qos C1
police cir 100 mbps pir 200 mbps
exit
!
!
policy-map type queuing default p3
class type queuing default q1
shape percent 20
priority
exit
class type queuing default q2
priority
queue-limit 99 packets
bandwidth 25000 kbps
exit
class type queuing default q3
priority
queue-limit 101 packets
exit
 
#show class-map
Type qos class-maps
===================
class-map type qos match-all C1
match cos 1
 
class-map type qos match-any class-default
 
 
Type queuing class-maps
=======================
class-map type queuing q0
 
class-map type queuing q1
 
class-map type queuing q2
 
class-map type queuing q3
 
class-map type queuing q4
 
class-map type queuing q5
 
class-map type queuing q6
 
class-map type queuing q7
 
 
Type Vlan-Queuing class-maps
 
 
#show policy-map
 
Type qos policy-maps
====================
 
policy-map type qos p1
class type qos C1
police cir 100 mbps pir 200 mbps
 
 
Type queuing policy-maps
========================
 
policy-map type queuing default default-out-policy
class type queuing default q0
priority
class type queuing default q1
priority
class type queuing default q2
priority
class type queuing default q3
priority
class type queuing default q4
priority
class type queuing default q5
priority
class type queuing default q6
priority
class type queuing default q7
priority
 
policy-map type queuing default p3
class type queuing default q0
priority
class type queuing default q1
shape percent 20
priority
class type queuing default q2
priority
queue-limit 99 packets
bandwidth 25000 kbps
class type queuing default q3
priority
queue-limit 101 packets
class type queuing default q4
priority
class type queuing default q5
priority
class type queuing default q6
priority
class type queuing default q7
priority
 
#show policy-map interface xe2
 
QoS statistics status : enabled
 
Class-map (qos): C1 (match all)
match cos 1
police cir 100 mbps pir 200 mbps
 
 
Type Queuing policy-map : default-out-policy
 
Class-map (queuing): q0
priority
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q1
priority
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q2
priority
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q3
priority
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q4
priority
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q5
priority
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q6
priority
output : 6 packets, 724 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q7
priority
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q0
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q2
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q3
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q4
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q5
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q6
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q7
output : 1 packets, 90 bytes
dropped : 0 packets, 0 bytes
 
Wred/Tail Drop Statistics :
----------------------
green : 0 packets
yellow : 0 packets
red : 0 packets
 
#show policy-map interface xe3
 
Type Queuing policy-map : p3
 
Class-map (queuing): q0
priority
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q1
shape percent 20
priority
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q2
priority
queue-limit 99 packets
bandwidth 25000 kbps
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q3
priority
queue-limit 101 packets
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q4
priority
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q5
priority
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q6
priority
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q7
priority
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q0
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q2
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q3
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q4
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q5
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q6
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q7
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Wred/Tail Drop Statistics :
----------------------
green : 0 packets
yellow : 0 packets
red : 0 packets
 
OcNOS#show queuing interface xe2
 
Egress Queuing for Ethernet xe2 [System]
L0 L1 L2 Group PrioLevel Shape Bandwidth
----------------------------------------------------------------------------------------------------
q0 - High - -
q1 - High - -
q2 - High - -
q3 - High - -
q4 - High - -
q5 - High - -
q6 - High - -
q7 - High - -
 
OcNOS#show queuing interface xe3
 
Egress Queuing for Ethernet xe3 [System]
---------------------------------------------------------------------------------------
L0 L1 L2 Group PrioLevel Shape Bandwidth
---------------------------------------------------------------------------------------
q0 - High - -
q1 - High 20 percent -
q2 - High - 25000 kbps
q3 - High - -
q4 - High - -
q5 - High - -
q6 - High - -
q7 - High - -