OcNOS-DC 6.4.2 : Key Features : Improved Routing : BGP Additional Path
BGP Additional Path
Overview
The Border Gateway Protocol (BGP) ADDPATH allows the advertisement of multiple paths through the same peer session for a given prefix without the new paths implicitly replacing any previous paths. This behavior promotes path diversity and reduces the severity of a network failure, thereby improving the control plane convergence in case of network failures.
Feature Characteristics
The advertisement of multiple paths in BGP is made possible by sending a BGP OPEN message to the neighbor with a BGP capability code of 69, which identifies the BGP ADD-PATH capability.
Feature
Characteristics
Address Family Identifier (AFI)
2 octets
Subsequent Address Family Identifier (SAFI)
1 octet
Send/Receive
1 octet
For a given <AFI, SAFI>, the send/receive field in the BGP TLV indicates, the sender is able to:
Receive multiple paths from its peer (value 1).
Send multiple paths to its peer (value 2)
Receive and send multiple paths to its peer (value 3)
Each alternate path is identified by a Path Identifier in addition to the address prefix
Feature
Characteristics
Path Identifier
4 octets
Length
1 octet
Prefix
variable
Benefits
This feature enables BGP add-path in the vrf address-family. In the event of a next-hop failure, BGP Add-Path improves the BGP control plane convergence time.
Prerequisites
Before configuring BGP additional paths ensure be sure of the following:
The supported OcNOS router running a compatible release.
Provide access to the management interface of the router.
Understand BGP well enough to enable it BGP on an interface.
Configuration
The following sessions displays the detailed information about bgp additional paths topology, configurations, and validations.
Topology
The following topology visually represents how BGP additional paths are configured.
BGP Additional Path
R1
Here is the detailed configuration of router R1.
R1#configure terminal
Enter the Configure mode.
R1(config)#interface eth2
Enter the Interface mode to configure interface eth2
R1(config-if)#ipv6 address 1001::1/64
Configure an IPv6 address for Interface eth2
R1(config-if)#exit
Exit the Interface mode
R1(config)#interface eth3
Enter the Interface mode to configure for Interface eth3
R1(config-if)#ipv6 address 1002::1/64
Configure an IPv6 address for Interface eth3
R1(config-if)#exit
Exit the Interface mode
R1(config)#interface eth4
Enter the Interface mode to configure Interface eth4
R1(config-if)#ipv6 address 1003::1/64
Configure an IPv6 address for interface eth4
R1(config-if)#exit
Exit the Interface mode
R1(config)#interface eth5
Enter the Interface mode to configure Interface eth5
R1(config-if)#ipv6 address 1004::1/64
Configure an IPv6 address for Interface eth5
R1(config-if)#exit
Exit the Interface mode
R1(config)#interface lo
Enter Interface mode for loopback lo
R1(config-if)#ipv6 address 1090::1/64
Configure IPv6 address for Loopback interface lo
R1(config-if)#exit
Exit the Interface mode
R1(config)#router bgp 200
Enter the Router BGP mode
R1(config-router)#neighbor 1001::2 remote-as 100
Specify a neighbor router with a peer address and remote-as for BGP peering.
R1(config-router)#neighbor 1002::2 remote-as 100
Specify a neighbor router with a peer address and remote-as for BGP peering.
R1(config-router)#neighbor 1003::2 remote-as 100
Specify a neighbor router with a peer address and remote-as for BGP peering.
R1(config-router)#neighbor 1004::2 remote-as 100
Specify a neighbor router with a peer address and remote-as for BGP peering.
R1(config-router)#address-family ipv6 unicast
Enter address-family mode for the neighbor router session to activate.
R1(config-router-af)#neighbor 1001::2 activate
Activate the neighbor router with a peer address.
R1(config-router-af)#neighbor 1002::2 activate
Activate the neighbor router with a peer address.
R1(config-router-af)#neighbor 1003::2 activate
Activate the neighbor router with a peer address.
R1(config-router-af)#neighbor 1004::2 activate
Activate the neighbor router with a peer address.
R1(config-router-af)#network 1090::/64
Activate the neighbor router with a peer address.
R1(config-router-af)#exit-address-family
Exit the Address Family mode and return to Router mode.
R1(config-router)#exit
Exit the Router BGP mode and enter the Configure mode
R1(config)#commit
Apply commit
R1(config)#exit
Exit the Configure mode
 
R2
Here is the detailed configuration of router R2.
R2#configure terminal
Enter the Configure mode.
R2(config)#interface eth1
Enter Interface mode for interface eth1
R2(config-if)#ipv6 address 3001::1/64
Configure IPv6 address for the interface eth1
R2(config-if)#ipv6 router ospf area 0
Enable OSPFv3 routing on an interface, and assign the Area ID 0.
R2(config-if)#exit
Exit the Interface mode
R2(config)#interface eth2
Enter Interface mode for interface eth2
R2(config-if)#ipv6 address 1001::2/64
Configure IPv6 address for the Interface eth2
R2(config-if)#exit
Exit the interface mode
R2(config)#interface eth3
Enter interface mode for Interface eth3
R2(config-if)#ipv6 address 1002::2/64
Configure IPv6 address for the Interface eth3
R2(config-if)#exit
Exit the interface mode
R2(config)#interface eth4
Enter interface mode for Interface eth4
R2(config-if)#ipv6 address 1003::2/64
Configure IPv6 address for the Interface eth4
R2(config-if)#exit
Exit the Interface mode
R2(config)#interface eth5
Enter interface mode for Interface eth5
R2(config-if)#ipv6 address 1004::2/64
Configure IPv6 address for the interface eth5
R2(config-if)#exit
Exit the interface mode
R2(config)#router bgp 100
Enter the router bgp mode
R2(config-router)#neighbor 3001::2 remote-as 100
Specify a neighbor router with peer address and remote-as for BGP peering.
R2(config-router)#neighbor 1001::1 remote-as 200
Specify a neighbor router with peer address and remote-as for BGP peering.
R2(config-router)#neighbor 1002::1 remote-as 200
Specify a neighbor router with peer address and remote-as for BGP peering.
R2(config-router)#neighbor 1003::1 remote-as 200
Specify a neighbor router with peer address and remote-as for BGP peering.
R2(config-router)#neighbor 1004::1 remote-as 200
Specify a neighbor router with peer address and remote-as for BGP peering.
R2(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
R2(config-router-af)#neighbor 1001::1 activate
Activate the neighbor router with peer address.
R2(config-router-af)#neighbor 1002::1 activate
Activate the neighbor router with peer address.
R2(config-router-af)#neighbor 1003::1 activate
Activate the neighbor router with peer address.
R2(config-router-af)#neighbor 1004::1 activate
Activate the neighbor router with peer address.
R2(config-router-af)#neighbor 3001::2 activate
Activate the neighbor router with peer address.
R2(config-router-af)#exit-address-family
Exit address family mode.
R2(config-router)#exit
Exit the router BGP mode and enter the config mode
R2(config)#router ipv6 ospf
Enter Router OSPFv3 mode.
R2(config-router)#redistribute connected
Configure Redistribution of Connected networks into OSPF
R2(config-router)#exit
Exit the router OSPF mode and enter the configure mode
R2(config)#commit
Apply commit
R2(config)#exit
Exit the configure mode
R3
Here is the detailed configuration of router R3.
R3#configure terminal
Enter the Configure mode.
R3(config)#interface eth1
Enter Interface mode for Interface eth1
R3(config-if)#ipv6 address 3001::2/64
Configure IPv6 address for the Interface eth1
R3(config-if)#ipv6 router ospf area 0
Enable OSPFv3 routing on an interface, and assign the Area ID 0.
R3(config-if)#exit
Exit the Interface mode
R3(config)#interface eth2
Enter interface mode for Interface eth2
R3(config-if)#ipv6 address 2001::2/64
Configure IPv6 address for the Interface eth2
R3(config-if)#exit
Exit the Interface mode
R3(config)#interface eth3
Enter Interface mode for the Interface eth3
R3(config-if)#ipv6 address 2002::2/64
Configure IPv6 address for the Interface eth3
R3(config-if)#exit
Exit the Interface mode
R3(config)#interface eth4
Enter Interface mode for the Interface eth4
R3(config-if)#ipv6 address 2003::2/64
Configure IPv6 address for the Interface eth4
R3(config-if)#exit
Exit the interface mode
R3(config)#interface eth5
Enter Interface mode for Interface eth5
R3(config-if)#ipv6 address 2004::2/64
Configure IPv6 address for the Interface eth5
R3(config-if)#exit
Exit the Interface mode
R3(config)#router bgp 100
Enter the router bgp mode
R3(config-router)#neighbor 3001::1 remote-as 100
Specify a neighbor router with peer address and remote-as for BGP peering.
R3(config-router)#neighbor 2001::1 remote-as 300
Specify a neighbor router with peer address and remote-as for BGP peering.
R3(config-router)#neighbor 2002::1 remote-as 300
Specify a neighbor router with peer address and remote-as for BGP peering.
R3(config-router)#neighbor 2003::1 remote-as 300
Specify a neighbor router with peer address and remote-as for BGP peering.
R3(config-router)#neighbor 2004::1 remote-as 300
Specify a neighbor router with peer address and remote-as for BGP peering.
R3(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
R3(config-router-af)#neighbor 2001::1 activate
Activate the neighbor router with peer address.
R3(config-router-af)#neighbor 2002::1 activate
Activate the neighbor router with peer address.
R3(config-router-af)#neighbor 2003::1 activate
Activate the neighbor router with peer address.
R3(config-router-af)#neighbor 2004::1 activate
Activate the neighbor router with peer address.
R3(config-router-af)#neighbor 3001::1 activate
Activate the neighbor router with peer address.
R3(config-router-af)#exit-address-family
Exit address family mode.
R3(config-router)#exit
Exit Router BGP mode
R3(config)#router ipv6 ospf
Enter Router OSPFv3 mode.
R3(config-router)#redistribute connected
Configure Redistribution of Connected networks into OSPF
R3(config-router)#exit
Exit the router OSPF mode and enter theconfigure mode
R3(config)#commit
Apply commit
R3(config)#exit
Exit the configure mode
 
R4
Here is the detailed configuration of router R4.
R4#configure terminal
Enter the Configure mode.
R4(config)#interface eth2
Enter interface mode for the Interface eth2
R4(config-if)#ipv6 address 2001::1/64
Configure IPv6 address for the Interface eth2
R4(config-if)#exit
Exit the Interface mode
R4(config)#interface eth3
Enter interface mode for Interface eth3
R4(config-if)#ipv6 address 2002::1/64
Configure IPv6 address for the Interface eth3
R4(config-if)#exit
Exit the Interface mode
R4(config)#interface eth4
Enter Interface mode for the Interface eth4
R4(config-if)#ipv6 address 2003::1/64
Configure IPv6 address for the Interface eth4
R4(config-if)#exit
Exit the Interface mode
R4(config)#interface eth5
Enter Interface mode for the Interface eth5
R4(config-if)#ipv6 address 2004::1/64
Configure IPv6 address for the Interface eth5
R4(config-if)#exit
Exit the Interface mode
R4(config)#interface lo
Enter interface mode for loopback lo
R4(config-if)#ipv6 address 9999::1/64
Configure IPv6 address for Loopback Interface lo
R4(config-if)#exit
Exit the interface mode
R4(config)#router bgp 300
Enter the router BGP mode
R4(config-router)#neighbor 2001::2 remote-as 100
Specify a neighbor router with peer address and remote-as for BGP peering.
R4(config-router)#neighbor 2002::2 remote-as 100
Specify a neighbor router with peer address and remote-as for BGP peering.
R4(config-router)#neighbor 2003::2 remote-as 100
Specify a neighbor router with peer address and remote-as for BGP peering.
R4(config-router)#neighbor 2004::2 remote-as 100
Specify a neighbor router with peer address and remote-as for BGP peering.
R4(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
R4(config-router-af)#neighbor 2001::2 activate
Activate the neighbor router with peer address.
R4(config-router-af)#neighbor 2002::2 activate
Activate the neighbor router with peer address.
R4(config-router-af)#neighbor 2003::2 activate
Activate the neighbor router with peer address.
R4(config-router-af)#neighbor 2004::2 activate
Activate the neighbor router with peer address.
R4(config-router-af)#network 9999::/64
Activate the neighbor router with peer address.
R4(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
R4(config-router)#exit
Exit the router BGP mode and enter the configure mode
R4(config)#commit
Commit the transaction
R4(config)#exit
Exit the configure mode
 
Additional Paths at the Global Level
In the following sessions additional paths at the global level is illustrated.
R2
Here is the detailed configuration of router R2.
R2#configure terminal
Enter the Configure mode.
R2(config)#router bgp 100
Enter BGP router mode
R2(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
R2(config-router-af)#bgp additional-paths send
Configure R2 to send additional paths to all iBGP neighbors
R2(config-router-af)#bgp additional-paths select all
Configure R2 to select all available paths to send to all iBGP neighbors
R2(config-router-af)#exit-address-family
Exit Address Family mode and return to the Router mode.
R2(config-router)#exit
Exit the router BGP mode and enter the configure mode
R2(config)#commit
Commit the transaction
R2(config)#exit
Exit the configure mode
R3
Here is the detailed configuration of router R3.
R3#configure terminal
Enter the Configure mode.
R3(config)#router bgp 100
Enter BGP router mode
R3(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
R3(config-router-af)#bgp additional-paths receive
Configure R3 to receive additional paths from all iBGP neighbors
R3(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
R3(config-router)#exit
Exit the router BGP mode and enter the configure mode
R3(config)#commit
Commit the transaction
R3(config)#exit
Exit the configure mode
Validation
The following is the validations for routers R2 and R3.
R2
The following is the validation for router.
#show bgp ipv6 neighbors 3001::2
BGP neighbor is 3001::2, remote AS 100, local AS 100, internal link
BGP version 4, remote router ID 10.12.5.92
BGP state = Established, up for 00:14:55
Last read 00:14:55, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family IPv6 Unicast: advertised and received
Received 536 messages, 50 notifications, 0 in queue
Sent 611 messages, 3 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 5, Offset 0, Mask 0x20
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: IPv6 Unicast
BGP table version 38, neighbor version 38
Index 5, Offset 0, Mask 0x20
AF-dependant capabilities:
Add-Path Send Capability : advertised
Add-Path Receive Capability : received
Community attribute sent to this neighbor (both)
1 accepted prefixes
4 announced prefixes
 
Connections established 3; dropped 2
Local host: 3001::1, Local port: 38451
Foreign host: 3001::2, Foreign port: 179
Nexthop: 10.12.5.93
Nexthop global: 3001::1
Nexthop local: fe80::5054:ff:fe19:1758
BGP connection: shared network
Last Reset: 00:15:00, due to BGP Notification received
Notification Error Message: (Cease/Other Configuration Change.)
 
#show bgp ipv6 summary
BGP router identifier 10.12.5.93, local AS number 100
BGP table version is 38
2 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
1001::1 4 200 517 532 38 0 0 04:13:51 1
1002::1 4 200 520 533 38 0 0 04:13:51 1
1003::1 4 200 519 532 38 0 0 04:13:51 1
1004::1 4 200 518 532 38 0 0 04:13:51 1
3001::2 4 100 588 616 38 0 0 00:15:42 1
 
Total number of neighbors 5
 
Total number of Established sessions 5
 
#show bgp ipv6
BGP table version is 38, local router ID is 10.12.5.93
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
*> 1090::/64 1001::1(fe80::5054:ff:fe9c:b7e6)
0 100 0 200 i
* 1002::1(fe80::5054:ff:fe0d:f5e)
0 100 0 200 i
* 1003::1(fe80::5054:ff:fec7:1940)
0 100 0 200 i
* 1004::1(fe80::5054:ff:fe62:70d8)
0 100 0 200 i
*>i 9999::/64 2001::1 0 100 0 300 i
 
Total number of prefixes 2
 
#show bgp ipv6 1090::/64
BGP routing table entry for 1090::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
1002::1 1003::1 1004::1
200
1001::1(fe80::5054:ff:fe9c:b7e6) from 1001::1 (10.12.5.144)
(fe80::5054:ff:fe9c:b7e6)
Origin IGP, metric 0, localpref 100, valid, external, best
rx path_id: -1 tx path_id: 0
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:53:54 2017
 
200
1002::1(fe80::5054:ff:fe0d:f5e) from 1002::1 (10.12.5.144)
(fe80::5054:ff:fe0d:f5e)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 1
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:54:01 2017
 
200
1003::1(fe80::5054:ff:fec7:1940) from 1003::1 (10.12.5.144)
(fe80::5054:ff:fec7:1940)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 2
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:53:52 2017
 
200
1004::1(fe80::5054:ff:fe62:70d8) from 1004::1 (10.12.5.144)
(fe80::5054:ff:fe62:70d8)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 3
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:53:48 2017
 
R3
The following is the validation for router R3.
#show bgp ipv6 neighbors 3001::1
BGP neighbor is 3001::1, remote AS 100, local AS 100, internal link
BGP version 4, remote router ID 10.12.5.93
BGP state = Established, up for 00:29:37
Last read 00:29:37, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family IPv6 Unicast: advertised and received
Received 518 messages, 2 notifications, 0 in queue
Sent 520 messages, 1 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 5, Offset 0, Mask 0x20
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: IPv6 Unicast
BGP table version 268, neighbor version 268
Index 1, Offset 0, Mask 0x2
AF-dependant capabilities:
Add-Path Send Capability : received
Add-Path Receive Capability : advertised
Community attribute sent to this neighbor (both)
4 accepted prefixes
1 announced prefixes
 
Connections established 4; dropped 3
Local host: 3001::2, Local port: 179
Foreign host: 3001::1, Foreign port: 38451
Nexthop: 10.12.5.92
Nexthop global: 3001::2
Nexthop local: fe80::5054:ff:fe5d:bb79
BGP connection: shared network
Last Reset: 00:29:37, due to BGP Notification sent
Notification Error Message: (Cease/Other Configuration Change.)
#show bgp ipv6 summary
BGP router identifier 10.12.5.92, local AS number 100
BGP table version is 268
2 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
2001::1 4 300 533 537 268 0 0 04:16:42 1
2002::1 4 300 533 536 268 0 0 04:16:42 1
2003::1 4 300 537 538 268 0 0 04:16:42 1
2004::1 4 300 520 521 268 0 0 04:16:38 1
3001::1 4 100 520 521 268 0 0 00:29:41 4
 
Total number of neighbors 5
 
Total number of Established sessions 5
 
#show bgp ipv6
BGP table version is 268, local router ID is 10.12.5.92
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
*>i 1090::/64 1001::1 0 100 0 200 i
* i 1004::1 0 100 0 200 i
* i 1003::1 0 100 0 200 i
* i 1002::1 0 100 0 200 i
*> 9999::/64 2001::1(fe80::5054:ff:fe46:f549)
0 100 0 300 i
* 2004::1(fe80::5054:ff:feb5:9a71)
0 100 0 300 i
* 2003::1(fe80::5054:ff:fe0d:b565)
0 100 0 300 i
* 2002::1(fe80::5054:ff:fed2:4666)
0 100 0 300 i
 
Total number of prefixes 2
 
R3#show bgp ipv6 1090::/64
BGP routing table entry for 1090::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
2001::1 2002::1 2003::1 2004::1
200
1001::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal, best
rx path_id: 0 tx path_id: 0
Not advertised to any peer
Last update: Wed Jan 11 04:08:51 2017
 
200
1004::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 3 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 04:09:43 2017
 
200
1003::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 2 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 04:09:43 2017
 
200
1002::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 1 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 04:09:43 2017
Additional Paths Send and Receive at Address-family level
The following session displays the additional paths Send and Receive at Address-family level.
R2
Here is the detailed configuration of router R2.
R2#configure terminal
Enter the Configure mode.
R2(config)#router bgp 100
Enter BGP router mode
R2(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
R2(config-router-af)#bgp additional-paths send-receive
Configure R2 to send additional paths to and receive additional paths from all iBGP neighbors
R2(config-router-af)#bgp additional-paths select all
Configure R2 to select all available paths to send to all iBGP neighbors
R2(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
R2(config-router)#exit
Exit the router BGP mode and enter the configure mode
R2(config)#commit
Apply commit
R2(config)#exit
Exit the configure mode
R3
Here is the detailed configuration of router R3.
R3#configure terminal
Enter the Configure mode.
R3(config)#router bgp 100
Enter BGP router mode
R3(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
R3(config-router-af)#bgp additional-paths send-receive
Configure R3 to send additional paths to and receive additional paths from all the iBGP neighbors
R3(config-router-af)#bgp additional-paths select all
Configure R3 to select all available paths to send to all iBGP neighbors
R3(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
R3(config-router)#exit
Exit the router BGP mode and enter the configure mode
R3(config)#commit
Apply commit
R3(config)#exit
Exit the configure mode
Additional Paths at the Neighbor Level
The following session displays the additional paths at the neighbor level.
R2
Here is the detailed configuration of router R2.
R2#configure terminal
Enter the Configure mode.
R2(config)#router bgp 100
Enter BGP router mode
R2(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
R2(config-router-af)#neighbor 3001::2 additional-paths send-receive
Configure R2 to send-receive additional paths to the iBGP neighbor R3
R2(config-router-af)#neighbor 3001::2 advertise additional-paths all
Configure R2 to advertise all available paths to the iBGP neighbor R3
R2(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
R2(config-router)#exit
Exit the router BGP mode and enter the config mode
R2(config)#commit
Apply commit
R2(config)#exit
Exit the configure mode
R3
Here is the detailed configuration of router R3.
R3#configure terminal
Enter the Configure mode.
R3(config)#router bgp 100
Enter BGP router mode
R3(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
R3(config-router-af)#neighbor 3001::1 additional-paths send-receive
Configure R3 to receive additional paths from the iBGP neighbor R2
R3(config-router-af)#neighbor 3001::1 advertise additional-paths all
Configure R2 to advertise all available paths to the iBGP neighbor R3
R3(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
R3(config-router)#exit
Exit the router BGP mode and enter the configure mode
R3(config)#commit
Apply commit
R3(config)#exit
Exit the configure mode
Validation
The following validation for router R2 and R3 is shown below.
R2
The following validation is for router R2.
#show bgp ipv6 neighbors 3001::2
BGP neighbor is 3001::2, remote AS 100, local AS 100, internal link
BGP version 4, remote router ID 10.12.5.92
BGP state = Established, up for 00:00:29
Last read 00:00:29, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family IPv6 Unicast: advertised and received
Received 588 messages, 51 notifications, 0 in queue
Sent 664 messages, 4 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 5, Offset 0, Mask 0x20
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: IPv6 Unicast
BGP table version 64, neighbor version 64
Index 5, Offset 0, Mask 0x20
AF-dependant capabilities:
Add-Path Send Capability : advertised and received
Add-Path Receive Capability : advertised and received
Community attribute sent to this neighbor (both)
4 accepted prefixes
4 announced prefixes
 
Connections established 5; dropped 4
Local host: 3001::1, Local port: 179
Foreign host: 3001::2, Foreign port: 39326
Nexthop: 10.12.5.93
Nexthop global: 3001::1
Nexthop local: fe80::5054:ff:fe19:1758
BGP connection: shared network
Last Reset: 00:00:29, due to BGP Notification sent
Notification Error Message: (Cease/Other Configuration Change.)
 
#show bgp ipv6 summary
BGP router identifier 10.12.5.93, local AS number 100
BGP table version is 64
2 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
1001::1 4 200 561 578 64 0 0 04:35:32 1
1002::1 4 200 564 579 64 0 0 04:35:32 1
1003::1 4 200 563 578 64 0 0 04:35:32 1
1004::1 4 200 562 578 64 0 0 04:35:32 1
3001::2 4 100 640 669 64 0 0 00:00:35 4
 
Total number of neighbors 5
 
Total number of Established sessions 5
 
#show bgp ipv6
BGP table version is 64, local router ID is 10.12.5.93
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
*> 1090::/64 1001::1(fe80::5054:ff:fe9c:b7e6)
0 100 0 200 i
* 1002::1(fe80::5054:ff:fe0d:f5e)
0 100 0 200 i
* 1003::1(fe80::5054:ff:fec7:1940)
0 100 0 200 i
* 1004::1(fe80::5054:ff:fe62:70d8)
0 100 0 200 i
*>i 9999::/64 2001::1 0 100 0 300 i
* i 2002::1 0 100 0 300 i
* i 2003::1 0 100 0 300 i
* i 2004::1 0 100 0 300 i
 
Total number of prefixes 2
 
#show bgp ipv6 1090::/64
BGP routing table entry for 1090::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
1002::1 1003::1 1004::1
200
1001::1(fe80::5054:ff:fe9c:b7e6) from 1001::1 (10.12.5.144)
(fe80::5054:ff:fe9c:b7e6)
Origin IGP, metric 0, localpref 100, valid, external, best
rx path_id: -1 tx path_id: 0
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:53:54 2017
 
200
1002::1(fe80::5054:ff:fe0d:f5e) from 1002::1 (10.12.5.144)
(fe80::5054:ff:fe0d:f5e)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 1
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:54:01 2017
 
200
1003::1(fe80::5054:ff:fec7:1940) from 1003::1 (10.12.5.144)
(fe80::5054:ff:fec7:1940)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 2
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:53:52 2017
 
200
1004::1(fe80::5054:ff:fe62:70d8) from 1004::1 (10.12.5.144)
(fe80::5054:ff:fe62:70d8)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 3
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:53:48 2017
 
#show bgp ipv6 9999::/64
BGP routing table entry for 9999::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
1001::1 1002::1 1003::1 1004::1
300
2001::1 (metric 20) from 3001::2 (10.12.5.92)
Origin IGP, metric 0, localpref 100, valid, internal, best
rx path_id: 0 tx path_id: 0
Not advertised to any peer
Last update: Wed Jan 11 04:45:39 2017
 
300
2002::1 (metric 20) from 3001::2 (10.12.5.92)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 1 tx path_id: 1
Not advertised to any peer
Last update: Wed Jan 11 04:45:53 2017
 
300
2003::1 (metric 20) from 3001::2 (10.12.5.92)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 2 tx path_id: 2
Not advertised to any peer
Last update: Wed Jan 11 04:45:53 2017
 
300
2004::1 (metric 20) from 3001::2 (10.12.5.92)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 3 tx path_id: 3
Not advertised to any peer
Last update: Wed Jan 11 04:45:53 2017
R3
The following validation is for router R3.
#show bgp ipv6 1090::/64
BGP routing table entry for 1090::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
2001::1 2002::1 2003::1 2004::1
200
1001::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal, best
rx path_id: 0 tx path_id: 0
Not advertised to any peer
Last update: Wed Jan 11 04:45:39 2017
 
200
1002::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 1 tx path_id: 1
Not advertised to any peer
Last update: Wed Jan 11 04:45:42 2017
 
200
1003::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 2 tx path_id: 2
Not advertised to any peer
Last update: Wed Jan 11 04:45:42 2017
 
200
1004::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 3 tx path_id: 3
Not advertised to any peer
Last update: Wed Jan 11 04:45:42 2017
 
R3#show bgp ipv6 9999::/64
BGP routing table entry for 9999::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
2002::1 2003::1 2004::1
300
2001::1(fe80::5054:ff:fe46:f549) from 2001::1 (10.12.5.90)
(fe80::5054:ff:fe46:f549)
Origin IGP, metric 0, localpref 100, valid, external, best
rx path_id: -1 tx path_id: 0
Advertised to non peer-group peers:
3001::1
Last update: Wed Jan 11 03:52:32 2017
 
300
2002::1(fe80::5054:ff:fed2:4666) from 2002::1 (10.12.5.90)
(fe80::5054:ff:fed2:4666)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 1
Advertised to non peer-group peers:
3001::1
Last update: Wed Jan 11 03:52:27 2017
 
300
2003::1(fe80::5054:ff:fe0d:b565) from 2003::1 (10.12.5.90)
(fe80::5054:ff:fe0d:b565)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 2
Advertised to non peer-group peers:
3001::1
Last update: Wed Jan 11 03:52:37 2017
 
300
2004::1(fe80::5054:ff:feb5:9a71) from 2004::1 (10.12.5.90)
(fe80::5054:ff:feb5:9a71)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 3
Advertised to non peer-group peers:
3001::1
Last update: Wed Jan 11 03:52:44 2017
 
#show bgp ipv6
BGP table version is 283, local router ID is 10.12.5.92
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
*>i 1090::/64 1001::1 0 100 0 200 i
* i 1002::1 0 100 0 200 i
* i 1003::1 0 100 0 200 i
* i 1004::1 0 100 0 200 i
*> 9999::/64 2001::1(fe80::5054:ff:fe46:f549)
0 100 0 300 i
* 2002::1(fe80::5054:ff:fed2:4666)
0 100 0 300 i
* 2003::1(fe80::5054:ff:fe0d:b565)
0 100 0 300 i
* 2004::1(fe80::5054:ff:feb5:9a71)
0 100 0 300 i
 
Total number of prefixes 2
 
#show bgp ipv6 summary
BGP router identifier 10.12.5.92, local AS number 100
BGP table version is 283
2 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
2001::1 4 300 556 562 282 0 0 04:28:07 1
2002::1 4 300 556 560 283 0 0 04:28:07 1
2003::1 4 300 560 563 282 0 0 04:28:07 1
2004::1 4 300 543 546 283 0 0 04:28:03 1
3001::1 4 100 551 553 283 0 0 00:04:18 4
 
Total number of neighbors 5
 
Total number of Established sessions 5
 
#show bgp ipv6 neighbors 3001::1
BGP neighbor is 3001::1, remote AS 100, local AS 100, internal link
BGP version 4, remote router ID 10.12.5.93
BGP state = Established, up for 00:05:02
Last read 00:05:02, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family IPv6 Unicast: advertised and received
Received 550 messages, 3 notifications, 0 in queue
Sent 553 messages, 2 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 5, Offset 0, Mask 0x20
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: IPv6 Unicast
BGP table version 283, neighbor version 283
Index 1, Offset 0, Mask 0x2
AF-dependant capabilities:
Add-Path Send Capability : advertised and received
Add-Path Receive Capability : advertised and received
Community attribute sent to this neighbor (both)
4 accepted prefixes
4 announced prefixes
 
Connections established 6; dropped 5
Local host: 3001::2, Local port: 39326
Foreign host: 3001::1, Foreign port: 179
Nexthop: 10.12.5.92
Nexthop global: 3001::2
Nexthop local: fe80::5054:ff:fe5d:bb79
BGP connection: shared network
Last Reset: 00:05:07, due to BGP Notification received
Notification Error Message: (Cease/Other Configuration Change.)
Selection of all Additional Paths at the Address-family Level
The following are the configurations and validations for additional paths at the address-family level.
R2
Here is the detailed configuration of router R2.
#configure terminal
Enter the Configure mode.
(config)#router bgp 100
Enter BGP router mode
(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
(config-router-af)#bgp additional-paths send-receive
Configure R2 to send additional paths to and receive additional paths from all iBGP neighbors
(config-router-af)#bgp additional-paths select all
Configure R2 to select all available paths to send to all iBGP neighbors
(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
(config-router)#exit
Exit the router BGP mode and enter the configure mode
(config)#commit
Apply the commit
(config)#exit
Exit the configure mode
Selection of all Additional Paths at the Neighbor Level
The following are the configurations and validations for additional paths at the neighbor level.
R2
Here is the detailed configuration of router R2.
R2#configure terminal
Enter the Configure mode.
R2(config)#router bgp 100
Enter the BGP router mode
R2(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
R2(config-router-af)#neighbor 3001::2 additional-paths send
Configure R2 to send additional paths to and receive additional paths from all iBGP neighbors
R2(config-router-af)#neighbor 3001::2 advertise additional-paths all
Configure R2 to select all available paths to send to all iBGP neighbors
R2(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
R2(config-router)#exit
Exit the router BGP mode and enter the config mode
R2(config)#commit
Apply the commit
R2(config)#exit
Exit the configure mode
Validation
The following is the validations for routers R2 and R3.
R2
The following is the validation for router R2.
#show bgp ipv6 1090::/64
BGP routing table entry for 1090::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
1002::1 1003::1 1004::1
200
1001::1(fe80::5054:ff:fe9c:b7e6) from 1001::1 (10.12.5.144)
(fe80::5054:ff:fe9c:b7e6)
Origin IGP, metric 0, localpref 100, valid, external, best
rx path_id: -1 tx path_id: 0
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:53:54 2017
 
200
1002::1(fe80::5054:ff:fe0d:f5e) from 1002::1 (10.12.5.144)
(fe80::5054:ff:fe0d:f5e)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 1
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:54:01 2017
 
200
1003::1(fe80::5054:ff:fec7:1940) from 1003::1 (10.12.5.144)
(fe80::5054:ff:fec7:1940)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 2
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:53:52 2017
 
200
1004::1(fe80::5054:ff:fe62:70d8) from 1004::1 (10.12.5.144)
(fe80::5054:ff:fe62:70d8)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 3
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:53:48 2017
R3
The following is the validation for router R3.
#show bgp ipv6 1090::
BGP routing table entry for 1090::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
2001::1 2002::1 2003::1 2004::1
200
1001::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal, best
rx path_id: 0 tx path_id: 0
Not advertised to any peer
Last update: Wed Jan 11 05:52:01 2017
 
200
1004::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 3 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 05:52:43 2017
 
200
1003::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 2 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 05:52:43 2017
 
200
1002::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 1 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 05:52:43 2017
Selection of Best 2 Additional Paths at AF Level
The following are the configurations and validations for best 2 additional paths at AF level.
R2
Here is the detailed configuration of router R2.
R2#configure terminal
Enter the Configure mode.
R2(config)#router bgp 100
Enter the BGP router mode
R2(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
R2(config-router-af)#bgp additional-paths send
Configure R2 to send additional paths to the iBGP neighbor R3
R2(config-router-af)#bgp additional-paths select best 2
Configure R2 to select best 2 out of all available paths to all iBGP neighbors
R2(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
R2(config-router)#exit
Exit the router BGP mode and enter the config mode
R2(config)#commit
Apply the commit
R2(config)#exit
Exit the configure mode
Selection of Best 2 Additional Paths at the Neighbor Level
The following are the configurations and validations for best 2 additional paths at neighbor level.
R2
Here is the detailed configuration of router R2.
R2#configure terminal
Enter the Configure mode.
R2(config)#router bgp 100
Enter the BGP router mode
R2(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
R2(config-router-af)#neighbor 3001::2 additional-paths send
Configure R2 to send additional paths to the iBGP neighbor R3
R2(config-router-af)#neighbor 3001::2 advertise additional-paths best 2
Configure R2 to advertise best 2 out of all available paths to R3
R2(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
R2(config-router)#exit
Exit the router BGP mode and enter the config mode
R2(config)#commit
Apply the commit
R2(config)#exit
Exit the configure mode
Validation
The following is the validations for routers R2 and R3.
 
R2
The following is the validation for router R2.
#show bgp ipv6 1090::/64
BGP routing table entry for 1090::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
1002::1 1003::1 1004::1
200
1001::1(fe80::5054:ff:fe9c:b7e6) from 1001::1 (10.12.5.144)
(fe80::5054:ff:fe9c:b7e6)
Origin IGP, metric 0, localpref 100, valid, external, best
rx path_id: -1 tx path_id: 0
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 06:34:49 2017
 
200
1002::1(fe80::5054:ff:fe0d:f5e) from 1002::1 (10.12.5.144)
(fe80::5054:ff:fe0d:f5e)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 1
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 06:34:49 2017
 
200
1003::1(fe80::5054:ff:fec7:1940) from 1003::1 (10.12.5.144)
(fe80::5054:ff:fec7:1940)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 06:34:49 2017
 
200
1004::1(fe80::5054:ff:fe62:70d8) from 1004::1 (10.12.5.144)
(fe80::5054:ff:fe62:70d8)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 06:34:49 2017
 
R3
The following is the validation for router R3.
#show bgp ipv6 1090::
BGP routing table entry for 1090::/64
Paths: (2 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
2001::1 2002::1 2003::1 2004::1
200
1001::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal, best
rx path_id: 0 tx path_id: 0
Not advertised to any peer
Last update: Wed Jan 11 06:34:49 2017
 
200
1002::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 1 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 06:34:49 2017
#show bgp ipv6
BGP table version is 407, local router ID is 10.12.5.92
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
*>i 1090::/64 1001::1 0 100 0 200 i
* i 1002::1 0 100 0 200 i
*> 9999::/64 2001::1(fe80::5054:ff:fe46:f549)
0 100 0 300 i
* 2002::1(fe80::5054:ff:fed2:4666)
0 100 0 300 i
* 2003::1(fe80::5054:ff:fe0d:b565)
0 100 0 300 i
* 2004::1(fe80::5054:ff:feb5:9a71)
0 100 0 300 i
 
Total number of prefixes 2
Selection of Best 3 Additional Paths at the AF Level
The following are the configurations and validations for best 3 additional paths at the AF level.
R2
THere is the detailed configuration of router R2.
R2#configure terminal
Enter the Configure mode.
R2(config)#router bgp 100
Enter the BGP router mode
R2(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
R2(config-router-af)#bgp additional-paths send
Configure R2 to send additional paths to the iBGP neighbor R3
R2(config-router-af)#bgp additional-paths select best 3
Configure R2 to select best 3 out of all available paths to all iBGP neighbors
R2(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
R2(config-router)#exit
Exit the router BGP mode and enter the configure mode
R2(config)#commit
Apply the commit
R2(config)#exit
Exit the configure mode
Selection of Best 3 Additional Paths at the Neighbor Level
The following are the configurations and validations for best 3 additional paths at neighbor level.
R2
Here is the detailed configuration of router R2.
R2#configure terminal
Enter the Configure mode.
R2(config)#router bgp 100
Enter the BGP router mode
R2(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
R2(config-router-af)#neighbor 3001::2 additional-paths send
Configure R2 to send additional paths to the iBGP neighbor R3
R2(config-router-af)#neighbor 3001::2 advertise additional-paths best 3
Configure R2 to advertise best 3 out of all available paths to R3
R2(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
R2(config-router)#exit
Exit the router BGP mode and enter the configure mode
R2(config)#commit
Apply the commit
R2(config)#exit
Exit the configure mode
Validation
The following is the validations for routers R2 and R3.
R2
The following is the validation for router R2.
#show bgp ipv6 1090::/64
BGP routing table entry for 1090::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
1002::1 1003::1 1004::1
200
1001::1(fe80::5054:ff:fe9c:b7e6) from 1001::1 (10.12.5.144)
(fe80::5054:ff:fe9c:b7e6)
Origin IGP, metric 0, localpref 100, valid, external, best
rx path_id: -1 tx path_id: 0
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 06:34:49 2017
 
200
1002::1(fe80::5054:ff:fe0d:f5e) from 1002::1 (10.12.5.144)
(fe80::5054:ff:fe0d:f5e)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 1
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 06:34:49 2017
 
200
1003::1(fe80::5054:ff:fec7:1940) from 1003::1 (10.12.5.144)
(fe80::5054:ff:fec7:1940)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 2
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 06:34:49 2017
 
200
1004::1(fe80::5054:ff:fe62:70d8) from 1004::1 (10.12.5.144)
(fe80::5054:ff:fe62:70d8)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 06:34:49 2017
R3
The following is the validation for router R3.
#show bgp ipv6 1090::/64
BGP routing table entry for 1090::/64
Paths: (3 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
2001::1 2002::1 2003::1 2004::1
200
1001::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal, best
rx path_id: 0 tx path_id: 0
Not advertised to any peer
Last update: Wed Jan 11 06:36:11 2017
 
200
1003::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 2 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 06:36:53 2017
 
200
1002::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 1 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 06:36:53 2017
 
#show bgp ipv6
BGP table version is 410, local router ID is 10.12.5.92
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
*>i 1090::/64 1001::1 0 100 0 200 i
* i 1003::1 0 100 0 200 i
* i 1002::1 0 100 0 200 i
*> 9999::/64 2001::1(fe80::5054:ff:fe46:f549)
0 100 0 300 i
* 2002::1(fe80::5054:ff:fed2:4666)
0 100 0 300 i
* 2003::1(fe80::5054:ff:fe0d:b565)
0 100 0 300 i
* 2004::1(fe80::5054:ff:feb5:9a71)
0 100 0 300 i
 
Total number of prefixes 2
Implementation Examples
The following examples shows the bgp additional path entries.
OcNOS#show ip bg summary
BGP router identifier 33.33.33.1, local AS number 400
BGP table version is 2
1 BGP AS-PATH entries
0 BGP community entries
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
1.1.1.2 4 100 19 17 2 0 0 00:06:35 0
Total number of neighbors 1
Total number of Established sessions 1
CLI Commands
The BGP additional path introduces the following configuration commands.
bgp additional-paths send-receive
Use this command is to enable BGP additional paths send and receive global mode commands in ipv4 vrf address-family.
Use the no parameter with this command to disable BGP add-path send and receive global mode commands in ipv4 vrf address-family.
Command Syntax
bgp additional-paths (send-receive)
no bgp additional-paths (send-receive)
Parameters
send
Send additional paths to neighbors.
receive
Receive additional paths from neighbors.
send-receive
Send and receive additional paths from neighbors.
select
Selection criteria to pick the paths.
Default
By default, BGP additional paths is disabled.
Command Mode
Address Family IPV4 VRF Mode.
Applicability
This command was introduced before OcNOS version 6.4.1.
Examples
OcNOS#configure terminal
(config)#router bgp 2
(config-router)#address-family ipv4 vrf ip1
(config-router-af)#bgp additional-paths send
(config-router-af)#no bgp additional-paths send
bgp additional-paths select best 3
Use this command is to enable BGP additional best 3 paths in global mode ipv4 vrf address-family.
Use the no parameter with this command to disable BGP add-path select best 3 paths in global mode ipv4 vrf address-family.
Command Syntax
bgp additional-paths(select best 3)
no bgp additional-paths(select best 3)
Parameters
best
Select best N paths.
3
Number of best paths in additional paths to be selected.
select
Selection criteria to pick the paths.
 
 
Default
By default, BGP additional paths is disabled.
Command Mode
Address Family IPV4 VRF Mode.
Applicability
This command was introduced before OcNOS version 6.4.1.
Examples
OcNOS#configure terminal
(config)#router bgp 2
(config-router)#address-family ipv4 vrf ip1
(config-router-af)#bgp additional-paths send
(config-router-af)#no bgp additional-paths send
bgp additional-paths select all
Use this command to enable BGP additional paths select all in global mode commands in ipv4 vrf address-family.
Use the no parameter with this command to disable all selected BGP add-paths in global mode commands in ipv4 vrf address-family..
Command Syntax
bgp additional-paths(select all)
no bgp additional-paths(select all)
Parameters
all
Select all available paths.
select
Selection criteria to pick the paths.
 
 
Default
By default, BGP additional paths is disabled.
Command Mode
Address Family IPV4 VRF Mode.
Applicability
This command was introduced before OcNOS version 6.4.1.
Examples
OcNOS#configure terminal
(config)#router bgp 2
(config-router)#address-family ipv4 vrf ip1
(config-router-af)#bgp additional-paths send
(config-router-af)#no bgp additional-paths send
neighbor A.B.C.D additional-paths send | receive | send-receive
Use this command to enable BGP add-path at neighbor level to send and receive neighbor level commands added in ipv4 vrf address-family.
Use the no parameter with this command to disable BGP add-path at neighbor level to send and receive neighbor level commands added in ipv4 vrf address-family.
Command Syntax
neighbor A.B.C.D additional-paths (send|receive|send-receive|)
no neighbor A.B.C.D additional-paths (send|receive|send-receive|)
Parameters
send
Send additional paths to neighbors.
receive
Receive additional paths from neighbors.
send-receive
Send and receive additional paths from neighbors.
Default
By default, neighbor advertise additional path is disabled.
Command Mode
Address Family IPV4 VRF Mode.
Applicability
This command was introduced before OcNOS version 6.4.1.
Examples
OcNOS#configure terminal
(config)#router bgp 2
(config-router)#address-family ipv4 vrf ip1
(config-router-af)#neighbor 1.1.1.2 advertise additional-paths all
(config-router-af)#no neighbor 1.1.1.2 advertise additional-paths all
neighbor A.B.C.D additional-paths all
Use this command to enable BGP add-path at all neighbor level commands added in ipv4 vrf address-family.
Use the no parameter with this command to disable BGP add-path at neighbor level commands added in ipv4 vrf address-family.
Command Syntax
neighbor A.B.C.D additional-paths all
no neighbor A.B.C.D additional-paths all
Parameters
all
Select all available paths
Default
By default, neighbor advertise additional path is disabled.
Command Mode
Address Family IPV4 VRF Mode.
Applicability
This command was introduced before OcNOS version 6.4.1.
Examples
OcNOS#configure terminal
(config)#router bgp 2
(config-router)#address-family ipv4 vrf ip1
(config-router-af)#neighbor 1.1.1.2 advertise additional-paths all
(config-router-af)#no neighbor 1.1.1.2 advertise additional-paths all
neighbor A.B.C.D additional-paths best <2-3>
Use this command to enable BGP add-path at all neighbor level commands added in ipv4 vrf address-family.
Use the no parameter with this command to disable BGP add-path at neighbor level commands added in ipv4 vrf address-family.
Command Syntax
neighbor A.B.C.D additional-paths all
no neighbor A.B.C.D additional-paths all
Parameters
best
Select best N paths.
<2-3>
Number of best paths in additional paths to be selected.
Default
By default, neighbor advertise additional path is disabled.
Command Mode
Address Family IPV4 VRF Mode.
Applicability
This command was introduced before OcNOS version 6.4.1.
Examples
OcNOS#configure terminal
(config)#router bgp 2
(config-router)#address-family ipv4 vrf ip1
(config-router-af)#neighbor 1.1.1.2 advertise additional-paths all
(config-router-af)#no neighbor 1.1.1.2 advertise additional-paths all
Troubleshooting
BGP additional paths for DC is a new feature when it is configured neighbour level resets only the particular peer and global level resets all the peers.
Abbreviations
List key terms used in this document and add the term and explanation to our existing Glossary.
 
Acronym
Description
BGP
Border Gateway Protocol
CLI
Command Line Interface
TLV
Type Length Values