OcNOS-DC 6.4.2 : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : Understanding Label Space
Understanding Label Space
This chapter contains configurations for Label Space. It also provides an overview of Label Space concepts.
Overview
The Label space refers to the scope of labels in a given LSR. It determines assignment and distribution of labels to a given peer. During data flow, it decides the key for looking up MPLS table and takes appropriate action based on the entry. Label space is designated either as platform label space or per-interface label space.
Per-platform label space
In this implementation, a label must be unique for the entire platform. A label will be interpreted the same way at all the interfaces. The FIB entry in the router does not contain incoming interface related information. Thus the incoming traffic will be matched only with the label.
Per-interface label space
In this implementation, a label must be unique for a given input interface. A label will be interpreted Uniquely at different interface which allows us to re-use label for different entries. The FIB entry in router must contain incoming interface information along with label. Thus the incoming traffic will be matched with label and incoming interface.
Topology
 
LDP Topology
Configuration
Per-Platform Label Space
PE1
 
PE1#configure terminal
Enter the configure mode
PE1(config)#interface lo
Enter the interface mode
PE1(config-if)#ip address 1.1.1.1/32
Configure the IP address for the loopback address
PE1(config-if)#exit
Exit the interface mode
PE1(config)#interface xe6
Specify the interface (xe6)to be configured
PE1(config-if)#ip address 10.10.10.1/24
Configure the IP address for the interface
PE1(config-if)#no shutdown
Administratively bringing up the interface
PE1(config-if)#exit
Exit the interface mode
PE1(config)#router ospf 100
Configure the routing process and specify the Process ID (100)
PE1(config-router)#ospf router-id 1.1.1.1
Configure the OSPF router id same as loopback IP address
PE1(config-router)#network 10.10.10.0/
24 area 0
PE1(config-router)#network 1.1.1.1/32 area 0
Define the interface on which OSPF runs and associate the area ID(0)with the interface
PE1(config-router)#exit
Exit the configure mode
PE1(config)#router ldp
Enter the router mode for LDP
PE1(config-router)#router-id 1.1.1.1
Set the router ID to IP address 1.1.1.1
PE1(config-router)#transport-address ipv4 1.1.1.1
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface
PE1(config-router)# targeted-peer ipv4
Configure targeted peer
PE1(config-router-targeted-peer)#exit
Exit from router target peer and LDP mode
PE1(config)#interface xe6
Specify the interface (xe6) to be configured
PE1(config-if)#label-switching
Enabling label switching capability on router
PE1(config-if)#enable-ldp ipv4
Enabling LDP on the interface
PE1(config-if)#exit
Exit the interface mode
PE1(config)#exit
Exit the configure mode
P
 
P#configure terminal
Enter the configure mode
P(config)#interface lo
Enter the interface mode.
P(config-if)#ip address 2.2.2.2/32
Configure the IP address for the loopback address
P(config-if)#exit
Exit the interface mode
P(config)#interface xe6
Specify the interface (xe6)to be configured
P(config-if)#ip address 10.10.10.2/24
Configure IP address for the interface
P(config-if)#no shutdown
Administratively bringing up the interface
P(config)#interface xe1
Specify the interface (xe1)to be configured
P(config-if)#ip address 20.20.20.1/24
Configure the IP address for the interface
P(config)#router ospf 100
Configure the routing process and specify the Process ID(100)
P(config-router)#ospf router-id 2.2.2.2
Configure the OSPF router id same as loopback IP address
P(config-router)#network 10.10.10.0/24 area 0
P(config-router)#network 20.20.20.0/24 area 0
P(config-router)#network 2.2.2.2/32 area 0
Define the interface on which OSPF runs and associate the area ID (0)with the interface
P(config-router)#transport-address ipv4 2.2.2.2
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface
P(config)#router ldp
Enter the router mode for LDP
P(config-router)#router-id 2.2.2.2
Set the router ID to IP address 2.2.2.2
P(config-router)#exit
Exit router mode for LDP
P(config)#mpls min-label-value 1000 max-label-value 50000 label-space 0
Configure the minimum label value and maximum label value to be used by Platform label space (Label space 0)
P(config)#interface xe6
Specify the interface (xe6) to be configured
P(config-if)#label-switching
Enable label switching capability on the router
P(config-if)#enable-ldp ipv4
Enable DP on the interface
P(config-if)#exit
Exit the interface mode
P(config)#interface xe1
Specify the interface (xe1)to be configured
P(config-if)#label-switching
Enable label switching capability on the router
P(config-if)#enable-ldp ipv4
Enable LDP on the interface
P(config-if)#exit
Exit the interface mode
P(config)#exit
Exit the configure mode
PE2
 
PE2#configure terminal
Enter the configure mode.
PE2(config)#interface lo
Enter the interface mode.
PE2(config-if)#ip address 3.3.3.3/32
Configure the IP address for the loopback address
PE2(config-if)#exit
Exit the interface mode
PE2(config)#interface xe1
Specify the interface (xe1)to be configured
PE2(config-if)#ip address 20.20.20.2/24
Configure IP address for the interface
PE2(config-if)#no shutdown
Administratively bring up the interface
PE2(config-if)#exit
Exit the interface mode
PE2(config)#router ospf 100
Configure the routing process and specify the Process ID (100)
PE2(config-router)#ospf router-id 3.3.3.3
Configure the OSPF router id same as loopback IP address
(config-router)#transport-address ipv4 3.3.3.3
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface
PE2(config-router)# targeted-peer ipv4 1.1.1.1
Configure the targeted peer
PE1(config-router-targeted-peer)#exit
Exit from the router target peer and LDP mode
PE2(config-router)#network 20.20.20.0/24 area 0
PE2(config-router)#network 3.3.3.3/32 area 0
Define the interface on which OSPF runs and associate the area ID (0)with the interface
PE2(config-router)#exit
Exit the router mode
PE2(config)#router ldp
Enter the router mode for LDP
PE2(config-router)#router-id 3.3.3.3
Set the router ID to IP address 3.3.3.3
PE2(config-router)#exit
Exit the router mode for LDP
PE2(config)#interface xe1
Specify the interface (xe1) to be configured
PE2(config-if)#label-switching
Enable label switching capability on the router
PE2(config-if)#enable-ldp ipv4
Enable LDP on the interface
PE2(config-if)#exit
Exit the interface mode
Validation
 
PE1#show ldp
Router ID : 1.1.1.1
LDP Version : 1
Fast-reroute Per-prefix : Disabled
Global Merge Capability : Merge Capable
Label Advertisement Mode : Downstream Unsolicited
Label Retention Mode : Liberal
Label Control Mode : Independent
Instance Loop Detection : Off
Request Retry : Off
Propagate Release : Disabled
Graceful Restart : Disabled
Hello Interval : 5
Targeted Hello Interval : 15
Hold time : 15
Targeted Hold time : 45
Keepalive Interval : 10
Keepalive Timeout : 30
Request retry Timeout : 5
Auto Targeted Hello Receipt : Enabled
Transport Address data :
Labelspace 0 : 1.1.1.1 (in use)
Import BGP routes : No
 
PE1#show ip ospf neighbor
 
Total number of full neighbors: 1
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
2.2.2.2 1 Full/Backup 00:00:30 10.10.10.2 xe1 0
 
 
P#show ldp
Router ID : 2.2.2.2
LDP Version : 1
Global Merge Capability : Merge Capable
Label Advertisement Mode : Downstream Unsolicited
Label Retention Mode : Liberal
Label Control Mode : Independent
Instance Loop Detection : Off
Request Retry : Off
Propagate Release : Disabled
Graceful Restart : Disabled
Hello Interval : 5
Targeted Hello Interval : 15
Hold time : 15
Targeted Hold time : 45
Keepalive Interval : 10
Keepalive Timeout : 30
Request retry Timeout : 5
Transport Address data :
Labelspace 0 : 2.2.2.2 (in use)
Import BGP routes : No
 
P#show mpls label-space 0
Min-label-value : 1000
Max-label-value : 50000
 
module-static min-label-value : 1000
max-label-value : 15999
module-srgb min-label-value : 16000
max-label-value : 24319
module-rsvp min-label-value : 0
max-label-value : 0
module-ldp min-label-value : 0
max-label-value : 0
module-bgp min-label-value : 0
max-label-value : 0
module-ospf min-label-value : 0
max-label-value : 0
 
P#sh mpls ilm-table
Codes: > - selected ILM, p - stale ILM, K - CLI ILM, T - MPLS-TP
 
Code FEC ILM-ID In-Label Out-Label In-Intf Out-Intf Nexthop LSP-Type
> 1.1.1.1/32 1 3840 3 N/A xe1 172.168.25.56 LSP_DEFAULT
> 3.3.3.3/32 2 3841 3 N/A xe2 10.10.20.51 LSP_DEFAULT
 
P#show ip ospf neighbor
 
Total number of full neighbors: 2
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
10.12.49.142 1 Full/DR 00:00:34 10.10.10.1 xe1 0
10.12.49.158 1 Full/Backup 00:00:36 20.20.20.2 xe6 0
PE2#show ldp
Router ID : 3.3.3.3
LDP Version : 1
Fast-reroute Per-prefix : Disabled
Global Merge Capability : Merge Capable
Label Advertisement Mode : Downstream Unsolicited
Label Retention Mode : Liberal
Label Control Mode : Independent
Instance Loop Detection : Off
Request Retry : Off
Propagate Release : Disabled
Graceful Restart : Disabled
Hello Interval : 5
Targeted Hello Interval : 15
Hold time : 15
Targeted Hold time : 45
Keepalive Interval : 10
Keepalive Timeout : 30
Request retry Timeout : 5
Auto Targeted Hello Receipt : Enabled
Transport Address data :
Labelspace 0 : 3.3.3.3 (in use)
Import BGP routes : No
 
PE2#show ip ospf neighbor
 
Total number of full neighbors: 1
OSPF process 100 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
2.2.2.2 1 Full/Backup 00:00:29 20.20.20.1 xe1 0
 
 
Per-Interface Label Space
PE1
 
PE1#configure terminal
Enter the configure mode
PE1(config)#interface lo
Enter the interface mode.
PE1(config-if)#ip address 1.1.1.1/32
Configure IP address for the loopback address
PE1(config-if)#exit
Exit the interface mode
PE1(config)#interface xe6
Specify the interface (xe6)to be configured
PE1(config-if)#ip address 10.10.10.1/24
Configure IP address for the interface
PE1(config-if)#no shutdown
Administratively bring up the interface
PE1(config-if)#exit
Exit the interface mode
PE1(config)#router ospf 100
Configure the routing process and specify the Process ID(100)
PE1(config-router)#network 10.10.10.0/
24 area 0
PE1(config-router)#network 1.1.1.1/32 area 0
Define the interface on which OSPF runs and associate the area ID(0)with the interface
PE1(config-router)#exit
Exit the configure mode
PE1(config)#router ldp
Enter the router mode for LDP
PE1(config-router)#exit
Exit the router mode for LDP
PE1(config)#mpls min-label-value 60000 max-label-value 80000 label-space 1
Configure the minimum label value and maximum label value to be used by interface label space (Label space 1 in this case)
PE1(config)#interface xe6
Specify the interface (xe6)to be configured
PE1(config-if)#label-switching
Enable label switching capability on router
PE1(config-if)#enable-ldp ipv4
Enable LDP on the interface
PE1(config-if)#exit
Exit the interface mode
PE1(config)#exit
Exit the configure mode
 
P
 
P#configure terminal
Enter the configure mode.
P(config)#interface lo
Enter the interface mode.
P(config-if)#ip address 2.2.2.2/32
Configure IP address for the loopback address
P(config-if)#exit
Exit the interface mode
P(config)#interface xe6
Specify the interface (xe6)to be configured
P(config-if)#ip address 10.10.10.2/24
Configure IP address for the interface
P(config-if)#no shutdown
Administratively bringing up the interface
P(config)#interface xe1
Specify the interface (xe1)to be configured
P(config-if)#ip address 20.20.20.1/24
Configure IP address for the interface
P(config)#router ospf 100
Configure the routing process and specify the Process ID (100)
P(config-router)#network 10.10.10.0/24 area 0
P(config-router)#network 20.20.20.0/24 area 0
P(config-router)#network 2.2.2.2/32 area 0
Define the interface on which OSPF runs and associate the area ID (0)with the interface
P(config-router)#exit
Exit the router mode
P(config)#router ldp
Enter the router mode for LDP
P(config-router)#exit
Exit the router mode for LDP
P(config)#mpls min-label-value 60000 max-label-value 80000 label-space 1
Configure the minimum label value and maximum label value to be used by Interface label space (Label space 1)
P(config)#interface xe6
Specify the interface (xe6)to be configured
P(config-if)#label-switching 1
Enabling label switching capability on router
P(config-if)#enable-ldp ipv4
Enabling LDP on the interface
P(config)#interface xe1
Specify the interface (xe1) to be configured
P(config-if)#label-switching 1
Enabling label switching capability on router
P(config-if)#enable-ldp ipv4
Enabling LDP on the interface
P(config-if)#exit
Exit the interface mode
P(config)#exit
Exit the configure mode
 
PE2
 
PE2#configure terminal
Enter the configure mode.
PE2(config)#interface lo
Enter the interface mode.
PE2(config-if)#ip address 3.3.3.3/32
Configure the IP address for the loopback address
PE2(config-if)#exit
Exit the interface mode
PE2(config)#interface xe1
Specify the interface (xe1)to be configured
PE2(config-if)#ip address 20.20.20.2/24
Configure IP address for the interface
PE2(config-if)#no shutdown
Administratively bring up the interface
PE2(config-if)#exit
Exit the interface mode
PE2(config)#router ospf 100
Configure the routing process and specify the Process ID (100)
PE2(config-router)#network 20.20.20.0/24 area 0
PE2(config-router)#network 3.3.3.3/32 area 0
Define the interface on which OSPF runs and associate the area ID (0)with the interface
PE2(config-router)#exit
Exit the router mode
PE2(config)#router ldp
Enter the router mode for LDP
PE2(config-router)#exit
Exit the router mode for LDP
PE2(config)#mpls min-label-value 60000 max-label-value 80000 label-space 1
Configure the minimum label value and maximum label value to be used by interface label space (Label space 1)
PE2(config)#interface xe1
Specify the interface (xe1)to be configured
PE2(config-if)#label-switching
Enable label switching capability on router
PE2(config-if)#enable-ldp ipv4
Enable LDP on interface
PE2(config-if)#exit
Exit the interface mode
 
Validation
P#show ldp
 
Router ID : 2.2.2.2
LDP Version : 1
Global Merge Capability : Merge Capable
Label Advertisement Mode : Downstream Unsolicited
Label Retention Mode : Liberal
Label Control Mode : Independent
Instance Loop Detection : Off
Request Retry : Off
Propagate Release : Disabled
Graceful Restart : Disabled
Hello Interval : 5
Targeted Hello Interval : 15
Hold time : 15
Targeted Hold time : 45
Keepalive Interval : 10
Keepalive Timeout : 30
Request retry Timeout : 5
Transport Address data :
Labelspace 1 : 2.2.2.2 (in use)
Import BGP routes : No
 
P#show mpls label-space 1
Min-label-value : 60000
Max-label-value : 80000
 
module-static min-label-value : 60000
max-label-value : 61000
module-rsvp min-label-value : 0
max-label-value : 0
module-ldp min-label-value : 0
max-label-value : 0
module-bgp min-label-value : 0
max-label-value : 0
module-ospf min-label-value : 0
max-label-value : 0
P#show mpls ilm
Codes: > - selected ILM, p - stale ILM, K - CLI ILM, T - MPLS-TP
 
Code FEC ILM-ID In-Label Out-Label In-Intf Out-Intf Nexthop LSP-Type
> 3.3.3.3/32 3 61441 3 xe1 xe2
 
10.10.20.51 LSP_DEFAULT
> 1.1.1.1/32 4 61440 3 xe2 xe1 172.168.25.56 LSP_DEFAULT