OcNOS-DC 6.4.2 : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : Signaled LLSP Configuration
Signaled LLSP Configuration
This chapter contains a complete sample of configuring Signaled LLSP Configuration.
Note: Signaled LLSP is only supported in RSVP-TE.
Configure Signaled LLSP Using RSVP-TE
Note: The following configuration for establishing a trunk is required on all routers participating in label-switching. Based on the assumption that minimal configurations exist on all participating routers, other examples do not repeat this configuration
Enable Label Switching - Minimal Configuration
To establish a Signaled LLSP trunk on a system:
Enable QoS on All LSR's.
Configure llsp-signal map under Router RSVP on ingress LSR.
Enable label-switching and RSVP-TE on all participating interfaces.
Configure a trunk on the ingress router to use the best available IGP path.
Topology
In this example, the Label Switched Path (LSP) is configured using minimal configuration and is setup using the best IP nexthop available. Each router along the path is chosen by the previous router by looking up the best nexthop available in its IP routing table.
Minimal configuration Topology
R1
NSM
 
#configure terminal
Enter the configure mode
(config)#interface xe2
Specify the interface (xe2) to be configured
(config-if)#ip address 10.10.23.63/24
Configure the IP address for the interface
(config-if)#label-switching
Enable label switching on the interface xe2
(config-if)#exit
Exit the interface mode
(config)#interface lo
Specify the loopback (lo) interface to be configured
(config-if)#ip address 192.168.0.63/32 secondary
Set the IP address of the loopback interface to
192.168.0.63/32
(config-if)#exit
Exit the interface mode
(config)#qos enable
Enable the QoS
(config)#qos statistics
Enable the QoS statistics
OSPF
 
#configure terminal
Enter the configure mode
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process
(config-router)#network 10.10.23.0/24 area 0
(config-router)#network 192.168.0.63/32 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface
(config-router)#exit
Exit the from router mode
RSVP-TE
#configure terminal
Enter the configure mode
(config)#router rsvp
Enter the configure router mode
(config-router)#elsp-signal-map class 1 exp 0
Enable the ELSP
(config-router)#exit
Exit the router Mode
(config)#interface xe2
Enter the interface mode
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface
(config-if)#exit
Exit the interface mode
(config)#rsvp-trunk T1
Create an RSVP trunk T1 and enter the Trunk mode
(config-trunk)# map-route 90.90.90.0/24
Specify the destination prefix that needs to mapped to this trunk
(config-trunk)#to 192.168.0.90
Specify the IPv4 egress (destination point) for the LSP
(config-trunk)#primary llsp class
Enable LLSP-Signaling for this trunk
DiffServ Traffic Engineering
(
config)#dste enable
Enable the DSTE
(config)#mpls class-type ct0 def
Configure class-type ct0 with name default
(config)#mpls class-type ct1 voice
Configure class-type ct1 with name voice
(config)#mpls te-class te1 voice 6
Configure te-class te1 with name voice
Trunk Configuration
 
(config-trunk)#primary setup-priority 6
Setup priority value for a trunk
(config-trunk)#primary hold-priority 6
Configure hold priority value for the selected trunk
(config-trunk)# primary class-type voice
Configure a primary Class-Type
R2
NSM
 
#configure terminal
Enter the configure mode
(config)#interface xe2
Specify the interface (xe2) to be configured
(config-if)#ip address 10.10.23.60/24
Configure IP address for the interface
(config-if)#label-switching
Enable label switching on interface xe2
(config-if)#exit
Exit interface mode
(config)#interface xe1
Specify the interface (xe2) to be configured.
(config-if)#ip address 10.10.21.60/24
Configure IP address for the interface
(config-if)#label-switching
Enable label switching on interface xe1
(config-if)#exit
Exit the interface mode
(config)#interface lo
Specify the loopback (lo) interface to be configured
(config-if)#ip address 192.168.0.60/32 secondary
Set the IP address of the loopback interface to
192.168.0.60/32
(config-if)#exit
Exit the interface mode
(config)#qos enable
Enable the QoS
(config)#qos statistics
Enable the QoS statistics
RSVP-TE
 
#configure terminal
Enter the configure mode
(config)#router rsvp
Enter the configure router mode
(config-router)#elsp-signal-map class 1 exp 0
Enable the ELSP
(config-router)#exit
Exit the router mode
(config)#interface xe2
Enter the interface mode
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface.
(config-if)#exit
Exit the interface mode
(config)#interface xe1
Enter the interface mode
(config-if)#enable-rsvp
Enable RSVP message exchange on this interface
(config-if)#exit
Exit the interface mode
OSPF
 
#configure terminal
Enter the configure mode
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process
(config-router)#network 10.10.23.0/24 area 0
(config-router)#network 192.168.0.63/32 area 0
(config-router)#network 10.10.21.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface
(config-router)#exit
Exit from the router mode
DiffServ Traffic Engineering
(
config)#dste enable
Enable the DSTE
(config)#mpls class-type ct0 def
Configure class-type ct0 with name default
(config)#mpls class-type ct1 voice
Configure class-type ct1 with name voice
(config)#mpls te-class te1 voice 6
Configure te-class te1 with name voice
Trunk Configuration
 
(config-trunk)#primary setup-priority 6
Setup priority value for a trunk
(config-trunk)#primary hold-priority 6
Configure hold priority value for the selected trunk
(config-trunk)# primary class-type voice
Configure a primary Class-Type
R3
NSM
 
#configure terminal
Enter the configure mode
(config)#interface xe2
Specify the interface (xe2) to be configured
(config-if)#ip address 10.10.21.90/24
Configure the IP address for the interface
(config-if)#label-switching
Enable label switching on interface xe2
(config-if)#exit
Exit the interface mode
(config)#interface lo
Specify the loopback (lo) interface to be configured
(config-if)#ip address 192.168.0.90/32 secondary
Set the IP address of the loopback interface to
192.168.0.90/32
(config-if)#exit
Exit the interface mode
(config)#qos enable
Enable the QoS
(config)#qos statistics
Enable the QoS statistics
RSVP-TE
 
#configure terminal
Enter the configure mode
(config)#router rsvp
Enter the configure router mode
(config-router)#elsp-signal-map class 1 exp 0
Enable the ELSP
(config-router)#exit
Exit the router mode
(config)#interface xe2
Enter the interface mode
(config-if)#enable-rsvp
Enable the RSVP message exchange on this interface
(config-if)#exit
Exit the interface mode
OSPF
 
#configure terminal
Enter the configure mode
(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process
(config-router)#network 192.168.0.90/32 area 0
(config-router)#network 10.10.21.0/24 area 0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
(config-router)#exit
Exit from the router mode
DiffServ Traffic Engineering
(
config)#dste enable
Enable the DSTE
(config)#mpls class-type ct0 def
Configure class-type ct0 with name default
(config)#mpls class-type ct1 voice
Configure class-type ct1 with name voice
(config)#mpls te-class te1 voice 6
Configure te-class te1 with name voice
Trunk Configuration
 
(config-trunk)#primary setup-priority 6
Setup priority value for a trunk
(config-trunk)#primary hold-priority 6
Configure hold priority value for the selected trunk
(config-trunk)# primary class-type voice
Configure a primary Class-Type
Validation
#show rsvp session
Ingress RSVP:
To From State Pri Rt Style Labelin Labelout LSPName Uptime Est.time DSType
192.168.0.90 192.168.0.63 Up Yes 1 1 SE - 24321 T1-Primary 00:11:41 0s 5ms LLSP
Total 1 displayed, Up 1, Down 0.
 
 
 
#show rsvp session detail
Ingress (Primary)
192.168.0.90
From: 192.168.0.63, LSPstate: Up, LSPname: T1-Primary
Ingress FSM state: Operational
Setup priority: 6, Hold priority: 6
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
IGP-Shortcut: Disabled, LSP metric: 2
LSP Protection: None
Label in: -, Label out: 24321
Tspec rate: 0, Fspec rate: 0
Policer: Not Configured
Tunnel Id: 5001, LSP Id: 2201, Ext-Tunnel Id: 192.168.0.63
Downstream: 10.10.23.60, xe10/1
Path refresh: 30 seconds (RR enabled) (due in 29 seconds)
Resv lifetime: 157 seconds (due in 143 seconds)
Retry count: 0, intrvl: 30 seconds
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: none
Configured Path: none
Session Explicit Route Detail :
10.10.23.60/32 strict
10.10.21.90/32 strict
Record route: <self> 10.10.23.60 10.10.21.90
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: L-LSP
LLSP CLASS: 6
DSTE Class Type Number: 1, Class Type name: voice
Last Recorded Error Code: None
Last Recorded Error Value: None
Node where Last Recorded Error originated: None
Trunk Type: mpls
 
 
#show policy-map in xe2
 
Interface xe2
Global statistics status : enabled
 
Service-policy (queuing) output: default-out-policy
-----------------------------------
Class-map (queuing): q0
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q1
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q2
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q3
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q4
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q5
priority level 1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q6
priority level 1
output : 530026 packets, 33921664 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): q7
priority level 1
output : 17 packets, 1088 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q0
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q1
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q2
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q3
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q4
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q5
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q6
output : 0 packets, 0 bytes
dropped : 0 packets, 0 bytes
 
Class-map (queuing): mc-q7
output : 25 packets, 2146 bytes
dropped : 0 packets, 0 bytes
 
Wred Drop Statistics :
----------------------
green : 0 packets
yellow : 0 packets
red : 0 packets