OcNOS-DC 6.4.2 : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : Static VPLS Configuration
Static VPLS Configuration
This chapter includes step-by-step configurations for Static VPLS. It also contains an overview of the concepts of Static VPLS.
Overview
Virtual Private LAN Service (VPLS) is a way to provide Ethernet-based multipoint-to-multipoint communication over IP- MPLS networks. It allows geographically-dispersed sites to share an Ethernet broadcast domain by connecting sites through pseudowires. A set of Martini circuits is grouped by a common VPLS identifier to achieve this service objective.
The VPLS identifier is exchanged with the labels, so that both PWs can be linked and be associated with a particular VPLS instance.
Configure Static VPLS
In the following examples, VPLS (v1) is configured on PE-2 with Static VPLS-Peers PE-1 and PE-3 using static LSPs.
Static Virtual Private LAN Service Topology
PE-1
 
#configure terminal
Enter the configure mode
(config)#mpls ftn-entry tunnel-id 11 2.2.2.2/32 102 10.10.1.2 xe1 primary
Configure the MPLS FTN entry for the creation of a static LSP to PE-2
(config)#mpls ftn-entry tunnel-id 22 3.3.3.3/32 103 10.10.1.2 xe1 primary
Configure the MPLS FTN entry for the creation of a static LSP to PE-3
(config)#mpls ilm-entry 201 pop
Configure the MPLS ILM entry for the creation of a static LSP to PE-2
(config)#mpls ilm-entry 301 pop
Configure the MPLS ILM entry for the creation of a static LSP to PE-3
(config)#mpls vpls v1 100
Configure the VPLS v1 with ID 100 on PE-1
(config-vpls)#vpls-peer 2.2.2.2 tunnel-id 11 manual
Configure the PE-2 as a manual VPLS peer using the static LSP tunnel ID 11
(config-vpls)#vpls-peer 3.3.3.3 tunnel-id 22 manual
Configure the PE-3 as a manual VPLS peer using the static LSP tunnel ID 22
(config-vpls)#exit
Exit the configure VPLS mode
(config)#interface xe1
Enter the interface mode
(config-if)#ip address 10.10.1.1/24
Configure the IP address for the interface
(config-if)#label-switching
Enable the label switching capability on the interface
(config-if)#exit
Exit the interface mode
(config)#interface lo
Enter interface mode
(config-if)#ip address 1.1.1.1/32 secondary
Configure the IP address for the loopback interface
(config-if)#exit
Exit the interface mode
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100)
(config-router)#ospf router-id 1.1.1.1
Configure the OSPF router id same as loopback ip address
(config-router)#transport-address ipv4 1.1.1.1
Configure the transport address as loopback address
(config-router)# targeted-peer ipv4 3.3.3.3
Configure the targeted peer
(config-router-targeted-peer)#exit
Exit targeted peer mode
(config-router)#network 10.10.1.0/24 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address
(config-router)#network 1.1.1.1/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address
(config-router)#exit
Exit the router mode
(config-if)#label-switching
Configure the label switching
(config-if)#exit
Exit the interface mode.
(config)#service-template st1
Template configuration
(config-svc)#exit
Exit the service template mode
(config)#interface xe2
Enter the interface mode
(config-if)#switchport
Switch to Layer-2 mode
(config-if)#mpls-vpls v1 service-template st1
Bind the VPLS to the Access Interface.
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)#exit
Exit the interface mode.
(config)#vpls fib-entry 100 peer 2.2.2.2 1000 xe1 2000
Configure VPLS FIB entry for VPLS peer PE-2.
(config)#vpls fib-entry 100 peer 3.3.3.3 3000 xe1 4000
Configure VPLS FIB entry for VPLS peer PE-3.
P
 
#configure terminal
Enter the configure mode
(config)#interface lo
Enter the interface mode
(config-if)#ip address 9.9.9.9/32 secondary
Configure IP address for the loopback interface
(config-if)#exit
Exit the interface mode
(config)#interface xe1
Specify the interface to be configured
(config-if)#ip address 10.10.1.2/24
Configure the IP address for the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#exit
Exit the interface mode
(config)#interface xe2
Enter the interface mode
(config-if)#ip address 20.20.1.1/24
Configure the IP address for the interface
(config-if)#label-switching
Enable the label switching capability on the interface.
(config-if)#exit
Exit the interface mode
(config)#interface xe3
Enter the interface mode
(config-if)#ip address 30.30.1.1/24
Configure IP address for the interface
(config-if)#label-switching
Enable label switching capability on the interface
(config-if)#exit Exit
Exit the interface mode
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100)
(config-router)#ospf router-id 9.9.9.9
Configure the OSPF router id same as loopback ip address
(config-router)#transport-address ipv4 9.9.9.9
Configure the transport address as loopback address
(config-router)#network 10.1.1.0/24 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the Interface address
(config-router)#network 20.20.1.0/24 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the Interface address
(config-router)#network 30.30.1.0/24 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the Interface address.
(config-router)#network 9.9.9.9/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the Interface address
(config-router)#exit
Exit the router mode
PE-2
 
#configure terminal
Enter the Configure mode
(config)# mpls ftn-entry tunnel-id 11 1.1.1.1/32 201 20.20.1.2 xe1 primary
Configure the MPLS FTN entry for the creation of a static LSP to PE-1, and designate xe1 as primary
(config)# mpls ftn-entry tunnel-id 33 3.3.3.3/32 301 20.20.1.2 xe1 primary
Configure the MPLS FTN entry for the creation of a static LSP to PE-3, and designate xe1 as primary.
(config)#mpls ilm-entry 102 pop
Configure the MPLS ILM entry for the creation of a static LSP to PE-1.
(config)#mpls ilm-entry 302 pop
Configure the MPLS ILM entry for the creation of a static LSP to PE-3
(config)#mpls vpls v1 100
Configure the VPLS v1 with ID 100 on PE-2.
(config-vpls)#vpls-peer 1.1.1.1 tunnel-id 11 manual
Configure the PE-1 as a manual VPLS peer using static LSP tunnel ID
(config-vpls)#vpls-peer 3.3.3.3 tunnel-id 33 manual
Configure the PE-3 as a manual VPLS peer using static LSP tunnel ID
(config-vpls)#exit
Exit the Configure VPLS mode
(config)#interface lo
Enter the interface mode
(config-if)#ip address 2.2.2.2/32 secondary
Configure the IP address for the loopback interface.
(config-if)#exit
Exit the interface mode
(config)#interface xe1
Enter the interface mode
(config-if)#ip address 20.20.1.2/24
Configure the IP address for the interface
(config-if)#label-switching
Configure the label switching
(config-if)#exit
Exit the interface mode
(config)#service-template st1
Template configuration
(config-svc)#exit
Exit the service template mode
(config)#interface xe2
Enter the interface mode
(config-if)#switchport Switch to Layer-2 mode
Make port Layer-2
(config-if)#mpls-vpls v1 service-template st1
Bind the VPLS to the Access Interface
(config-if-vpls)#exit
Exit the VPLS attachment-circuit mode
(config-if)#exit
Exit the interface mode
(config)# vpls fib-entry 100 peer 1.1.1.1 2500 xe1 1500
Configure VPLS FIB entry for VPLS peer PE-1
(config)# vpls fib-entry 100 peer 3.3.3.3 3500 xe1 4500
Configure VPLS FIB entry for VPLS peer PE-3
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100)
(config-router)#ospf router-id 2.2.2.2
Configure OSPF router id same as loopback ip address
(config-router)#transport-address ipv4 2.2.2.2
Configure transport address as loopback address
(config-router)# targeted-peer ipv4 1.1.1.1
Configure the targeted peer
(config-router-targeted-peer)#exit
Exit targeted peer mode
(config-router)#network 20.20.1.0/24 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address
(config-router)#network 2.2.2.2/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address
(config-router)#exit
Exit the router mode
(config)#exit
Exit the configure mode
PE-3
 
#configure terminal
Enter the Configure mode
(config)#mpls ftn-entry tunnel-id 11 1.1.1.1/32 301 30.30.1.2 xe1 primary
Configure the MPLS FTN entry for the creation of a static LSP to PE-1
(config)# mpls ftn-entry tunnel-id 22 2.2.2.2/32 302 30.30.1.2 xe1 primary
Configure the MPLS FTN entry for the creation of a static LSP to PE-2
(config)#mpls ilm-entry 103 pop
Configure the MPLS ILM entry for the creation of a static LSP to PE-1
(config)#mpls ilm-entry 203 pop
Configure the MPLS ILM entry for the creation of a static LSP to PE-2
(config)#mpls vpls v1 100
Configure the VPLS v1 with ID 100 on PE-3
(config-vpls)#vpls-peer 1.1.1.1 tunnel-id 11 manual
Configure the PE-1 as a manual VPLS peer using static LSP tunnel ID 11.
(config-vpls)#vpls-peer 2.2.2.2 tunnel-id 22 manual
Configure the PE-2 as a manual VPLS peer using static LSP tunnel ID 22.
(config-vpls)#exit
Exit the Configure VPLS mode
(config)#interface lo
Enter the interface mode
(config-if)#ip address 3.3.3.3/32 secondary
Configure the IP address for the loopback interface
(config-if)#exit
Exit the interface mode
(config)#interface xe1
Enter the interface mode
(config-if)#ip address 30.30.1.1/24
Configure the IP address for the interface
(config-if)#label-switching
Configure the label switching
(config-if)#exit
Exit the interface mode
(config)#service-template st1
Template configuration
(config-svc)#exit
Exit the service template mode
(config)#interface xe2
Enter the interface mode
(config-if)#switchport
Switch to Layer-2 mode
(config-if)#mpls-vpls v1 service-template st1
Bind the VPLS to the Access Interface
(config-if-vpls)#exit
Exit the VPLS attachment-circuit mode
(config-if)#exit
Exit the interface mode.
(config)#vpls fib-entry 100 peer 1.1.1.1 4000 xe1 3000
Configure the VPLS FIB entry for VPLS peer PE-1.
(config)#vpls fib-entry 100 peer 2.2.2.2 4500 xe1 3500
Configure the VPLS FIB entry for VPLS peer PE-2.
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
config-router)#ospf router-id 3.3.3.3
Configure the OSPF router id same as loopback ip address
(config-router)#transport-address ipv4 3.3.3.3
 
Configure the transport address as loopback address
(config-router)# targeted-peer ipv4 1.1.1.1
Configure the targeted peer
(config-router-targeted-peer)#exit
Exit targeted peer mode
(config-router)#network 30.30.1.0/24 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address
(config-router)#network 3.3.3.3/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address
(config-router)#exit
Exit the router mode
Validation
Enter the commands listed in the sections below to confirm the configurations.
Verify VPLS Session on PE-1
#show mpls vpls detail
Virtual Private LAN Service Instance: vpls3100, ID: 3100
SIG-Protocol: BGP
Route-Distinguisher :65010:3100
Route-Target :65010:3100
VE-ID :31
Attachment-Circuit :UP
Learning: Enabled
Group ID: 0, Configured MTU: 9216
Description: none
service-tpid: dot1.q
Operating mode: Raw
Configured interfaces:
Interface: xe26
Service-template : vpls3100_3100_13100
Match criteria : 3100
Action type : Translate
Action value : 4075
Outgoing tpid : dot1.q
Mesh Peers:
2.2.2.2 (Up)
Mesh Peers:
3.3.3.3 (Up)
PE1#
 
 
Verify VPLS Peer
#show mpls vpls mesh
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status Ecmp-Group
100 2.2.2.2 24320 24320 xe1 24321 2/Up 1 LDP Active N/A
100 3.3.3.3 24321 24321 xe1 24320 2/Up 2 LDP Active N/A
PE1#
Remove Configurations
Follow these steps to remove VPLS peer and VPLS spoke FIB entries from router PE-2.
 
#configure terminal
Enter the configure mode
(config)#no vpls fib-entry 100 peer 1.1.1.1
Remove the VPLS FIB for VPLS peer PE-1
(config)#no vpls fib-entry 100 peer 3.3.3.3
Remove the VPLS FIB for VPLS peer PE-3
(config)#exit
Exit the configure mode