OcNOS-DC 6.4.2 : System Management Guide : System Management Configuration Guide : LAG with RTAG7 Hashing
LAG with RTAG7 Hashing
Overview
Traffic can be load balanced within an LACP trunk group and within an ECMP in a controlled manner using the RTAG7 hashing algorithm.
Topology
LACP with RTAG7 Configuration
Dynamic LAG with RTAG7
SW1
 
#configure terminal
Enter configure mode.
(config)#bridge 1 protocol mstp
Configure bridge 1 as MSTP bridge.
(config)#vlan 2-10 bridge 1
Configure VLANS.
(config)#load-balance rtag7
Enable load-balance for rtag7 globally.
(config)#load-balance rtag7 l2 src-mac dest-mac ether-type vlan
Enabling load-balance rtag7 for l2 with all options.
(config)#load-balance rtag7 ipv4 dest-ipv4 src-ipv4 destl4-port srcl4-port protocol-id
Enabling load-balance rtag7 for ipv4 with all options.
(config)#interface po1
Enter into port channel interface po1.
(config-if)#switchport
Configure po1 as a layer 2 port.
(config-if)#bridge-group 1
Associate bridge to an interface.
(config-if)#switchport mode trunk
Configure port as a trunk.
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the xe1 interface.
(config-if)#port-channel load-balance rtag7
Enable rtag7 load-balancing method.
(config-if)#exit
Exit the po1 interface mode.
(config)#interface xe1
Enter interface mode.
(config-if)#switchport
Configure xe1 as a layer 2 port.
(config-if)#bridge-group 1
Associate bridge to an interface.
(config-if)#switchport mode trunk
Configure port as a trunk.
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the xe1 interface.
(config-if)#channel-group 1 mode active
Make port as part of port channel
(config-if)#exit
Exit the xe1 interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#switchport
Configure xe2 as a layer 2 port.
(config-if)#bridge-group 1
Associate bridge to an interface.
(config-if)#switchport mode trunk
Configure port as a trunk.
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the xe2 interface.
(config-if)#channel-group 1 mode active
Make port as part of port channel..
(config-if)#exit
Exit the xe2 interface mode.
(config)#interface xe3
Enter interface mode.
(config-if)#switchport
Configure xe3 as a layer 2 port .
(config-if)#bridge-group 1
Associate bridge to an interface.
(config-if)#switchport mode trunk
Configure port as a trunk.
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the xe3 interface.
(config-if)#channel-group 1 mode active
Make port as part of port channel.
(config-if)#exit
Exit the xe3 interface mode.
SW2
 
#configure terminal
Enter configure mode.
(config)#bridge 1 protocol mstp
Configure bridge 1 as MSTP bridge.
(config)#vlan 2-10 bridge 1
Configure VLANS.
(config)#interface po1
Enter interface mode
(config-if)#switchport
Configure po1 as a layer 2 port
(config-if)#bridge-group 1
Associate bridge to an interface
(config-if)#switchport mode trunk
Configure port as a trunk
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the po1 interface
(config-if)#exit
Exit the interface mode
(config)#interface xe1
Enter interface mode.
(config-if)#switchport
Configure xe1 as a layer 2 port.
(config-if)#bridge-group 1
Associate bridge to an interface.
(config-if)#switchport mode trunk
Configure port as a trunk.
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the xe1 interface.
(config-if)#channel-group 1 mode active
Make port as part of port channel.
(config-if)#exit
Exit the xe1 interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#switchport
Configure xe2 as a layer 2 port.
(config-if)#bridge-group 1
Associate bridge to an interface.
(config-if)#switchport mode trunk
Configure port as a trunk.
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the xe2 interface.
(config-if)#channel-group 1 mode active
Make port as part of port channel.
(config-if)#exit
Exit the xe2 interface mode.
(config)#interface xe3
Enter interface mode.
(config-if)#switchport
Configure xe3 as a layer 2 port.
(config-if)#bridge-group 1
Associate bridge to an interface.
(config-if)#switchport mode trunk
Configure port as a trunk.
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the xe3 interface.
(config-if)#channel-group 1 mode active
Make port as part of port channel.
Validation
SW1#show etherchannel summary
Aggregator po1 100010
Aggregator Type: Layer2
Admin Key: 0010 - Oper Key 0010
Link: xe1 (5061) sync: 1
Link: xe2 (5062) sync: 1
Link: xe3 (5063) sync: 1
 
SW2#show etherchannel summary
Aggregator po1 7
Aggregator Type: Layer2
Admin Key: 0010 - Oper Key 0010
Link: xe1 (5013) sync: 1
Link: xe2 (5014) sync: 1
Link: xe3 (5015) sync: 1
 
SW1#show etherchannel detail
Aggregator po1 100001
Aggregator Type: Layer2
Mac address: 3c:2c:99:28:52:1e
Admin Key: 0001 - Oper Key 0001
Actor LAG ID- 0x8000,3c-2c-99-7a-b2-e0,0x0001
Receive link count: 3 - Transmit link count: 3
Individual: 0 - Ready: 1
Partner LAG ID- 0x8000,00-18-23-30-20-ce,0x0001
Link: xe1 (5061) sync: 1
Link: xe2 (5062) sync: 1
Link: xe3 (5063) sync: 1
Collector max delay: 5
Static LAG with RTAG7
SW1
 
#configure terminal
Enter configure mode.
(config)#bridge 1 protocol mstp
Configure bridge 1 as MSTP bridge.
(config)#vlan 2-10 bridge 1
Configure VLANS
(config)#load-balance rtag7
Enable load-balance for rtag7 globally.
(config)#load-balance rtag7 l2 src-mac dest-mac ether-type vlan
Enabling load-balance rtag7 for l2 with all options.
(config)#load-balance rtag7 ipv4 dest-ipv4 src-ipv4 destl4-port srcl4-port protocol-id
Enabling load-balance rtag7 for ipv4 with all options .
(config)#interface sa1
Enter into port channel interface sa1.
(config-if)#switchport
Configuresa1 as a layer 2 port.
(config-if)#bridge-group 1
Associate bridge to an interface.
(config-if)#switchport mode trunk
Configure port as a trunk.
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the sa1 interface.
(config-if)#port-channel load-balance rtag7
Enable rtag7 load-balancing method.
(config)#interface xe1
Enter interface mode.
(config-if)#switchport
Configure xe1 as a layer 2 port.
(config-if)#bridge-group 1
Associate bridge to an interface.
(config-if)#switchport mode trunk
Configure port as a trunk.
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the xe1 interface.
(config-if)#static-channel-group 1
Make port as part of Static port channel.
(config-if)#exit
Exit the xe1 interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#switchport
Configure xe2 as a layer 2 port.
(config-if)#bridge-group 1
Associate bridge to an interface.
(config-if)#switchport mode trunk
Configure port as a trunk.
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the xe2 interface.
(config-if)#static-channel-group 1
Make port as part of Static port channel.
(config-if)#exit
Exit the xe2 interface mode.
(config)#interface xe3
Enter interface mode.
(config-if)#switchport
Configure xe3 as a layer 2 port.
(config-if)#bridge-group 1
Associate bridge to an interface.
(config-if)#switchport mode trunk
Configure port as a trunk.
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the xe3 interface.
(config-if)#static-channel-group 1
Make port as part of Static port channel.
(config-if)#exit
Exit the xe3 interface mode.
SW2
 
#configure terminal
Enter configure mode.
(config)#bridge 1 protocol mstp
Configure bridge 1 as MSTP bridge.
(config)#vlan 2-10 bridge 1
Configure VLANS.
(config)#interface sa1
Enter interface mode
(config-if)#switchport
Configure sa1 as a layer 2 port
(config-if)#bridge-group 1
Associate bridge to an interface
(config-if)#switchport mode trunk
Configure port as a trunk
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the sa1 interface.
(config-if)#exit
Exit interface mode
(config)#interface xe1
Enter interface mode.
(config-if)#switchport
Configure xe1 as a layer 2 port.
(config-if)#bridge-group 1
Associate bridge to an interface.
(config-if)#switchport mode trunk
Configure port as a trunk.
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the xe1 interface.
(config-if)#static-channel-group 1
Make port as part of Static port channel.
(config-if)#exit
Exit the xe1 interface mode.
(config)#interface xe2
Enter interface mode.
(config-if)#switchport
Configure xe2 as a layer 2 port.
(config-if)#bridge-group 1
Associate bridge to an interface.
(config-if)#switchport mode trunk
Configure port as a trunk.
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the xe2 interface.
(config-if)#static-channel-group 1
Make port as part of Static port channel.
(config-if)#exit
Exit the xe2 interface mode.
(config)#interface xe3
Enter interface mode.
(config-if)#switchport
Configure xe3 as a layer 2 port.
(config-if)#bridge-group 1
Associate bridge to an interface.
(config-if)#switchport mode trunk
Configure port as a trunk.
(config-if)#switchport trunk allowed vlan all
Allow all the VLANs on the xe3 interface.
(config-if)#static-channel-group 1
Make port as part of Static port channel.
(config-if)#exit
Exit the xe3 interface mode.
Validation
SW1#show static-channel-group
Static Aggregator: sa1
Member Status
xe1 up
xe2 up
xe3 up
SW1#
 
#show running-config interface sa1
!
interface sa1
load-interval 30
ip address 14.4.1.2/24
mtu 1600
port-channel load-balance rtag7
port-channel min-links 4
ip ospf network point-to-point
ip ospf cost 1000