#configure terminal | Enter the configuration mode |
(config)#interface xe1 | Specify the interface (xe1) to be configured |
(config-if)#ip address 10.10.1.1/24 | Set the IP address of the interface to 10.10.1.1/24 |
(config-if)#label-switching | Enable the label switching on interface xe1 |
(config-if)#exit | Exit the interface mode. |
(config)#interface lo | Specify the loopback address |
(config-if)#ip address 1.1.1.1/32 | Set the IP address of the loopback interface to 1.1.1.1/32 |
(config-if)#exit | Exit the interface mode |
(config)#mpls vpls v1 25 | Create an instance of VPLS, and switch to the VPLS command mode, by specifying the VPLS name (v1) and VPLS ID (25) |
(config-vpls)#vpls-mtu 1400 | Configure the MTU for the VPLS. (Default is 1500; range is <576 - 65535> |
(config-vpls)#signaling bgp | Enter the Signaling bgp mode for BGP VPLS. |
(config-vpls-sig)#ve-id 1 | Configure VE ID, which is mandatory for BGP VPLS, otherwise, Signaling does not take place. VE ID should be unique per VPLS instance |
(config-vpls-sig)#exit | Exit is a mandatory command for signaling BGP configuration to take affect. If exit is not given BGP signaling does not take place |
(config-vpls)#exit | Exit the VPLS mode |
(config)#service-template v1 | Configure the service template |
(config-svc)#match all | Configure the match condition |
(config-svc)#exit | Exit the interface mode |
(config)#interface xe3 | Specify the interface (xe3) to be configured. |
(config-if)#switchport | Switch to Layer-2 mode. (VPLS can be bound only on the Layer-2 port.) |
(config-if)#mpls-vpls v1 service-template v1 | Bind the VPLS to the access interface |
(config-if-vpls)#exit | Exit the VPLS attachment-circuit mode |
(config-if)#exit | Exit the interface mode |
#configure terminal | Enter the configuration mode |
(config)#router ldp | Enter the router LDP mode |
(config-router)#router-id 1.1.1.1 | Configure the router ID |
(config-router)#transport-address ipv4 1.1.1.1 | Configure the transport address for a label space by binding the address to a loopback address |
(config-router)#exit | Exit the router mode |
(config)#interface xe1 | Specify the interface (xe1) to be configured |
(config-if)#enable-ldp ipv4 | Enable LDP on the interface xe1 |
(config-if)#exit | Exit the interface mode |
#configure terminal | Enter the configure mode |
(config)#router ospf 1 | Configure the OSPF routing process, and specify the process ID |
(config-router)#network 10.10.1.0/24 area 0 | Define the interfaces on which OSPF runs, and specify the backbone area 0 |
(config-router)#network 1.1.1.1/32 area 0 | |
(config-router)#exit | Exit the router mode. |
#configure terminal | Enter the configuration mode |
(config)#router bgp 100 | Enter the BGP Configure mode |
(config-router)#neighbor 2.2.2.2 remote-as 100 | Configure the PE2 as an iBGP peer |
(config-router)#neighbor 2.2.2.2 update-source lo | Update the source as loopback for iBGP peering with the remote PE2 router |
(config-router)#neighbor 3.3.3.3 remote-as 100 | Configure the PE3 as an iBGP peer |
(config-router)#neighbor 3.3.3.3 update-source lo | Update the source as loopback for iBGP peering with the remote PE3 router |
(config-router)#address-family l2vpn vpls | Configure the address-family l2vpn VPLS |
(config-router-af)#neighbor 2.2.2.2 activate | Activate the PE2 in the VPLS address family |
(config-router-af)#neighbor 3.3.3.3 activate | Activate the PE3 in the VPLS address family |
#configure terminal | Enter the configuration mode |
(config)#interface xe3 | Specify the interface (xe3) to be configured |
(config-if)#ip address 20.20.1.3/24 | Set the IP address of the interface to 20.20.1.3/24. |
(config-if)#label-switching | Enable label switching on the interface xe3 |
(config-if)#exit | Exit the interface mode |
(config)#interface lo | Specify the loopback address |
(config-if)#ip address 2.2.2.2/32 | Set the IP address of the loopback interface to 2.2.2.2/32 |
(config-if)#exit | Exit the interface mode |
(config)#mpls vpls v1 25 | Create an instance of VPLS, and switch to the VPLS command mode, by specifying the VPLS name (v1) and VPLS ID (25) |
(config-vpls)#vpls-mtu 1400 | Configure the MTU for the VPLS. (Default is 1500; range is <576 - 65535>.) |
(config-vpls)#signaling bgp | Enter the Signaling BGP mode for BGP VPLS |
(config-vpls-sig)#ve-id 2 | Configure ve-id, which is mandatory for BGP VPLS. Without a ve-id Signaling does not take place. VE ID should be unique per VPLS instance |
(config-vpls-sig)#exit | Exit is a mandatory command for signaling BGP configuration to take affect. If exit is done, BGP signaling does not take place |
(config-vpls)#exit | Exit the VPLS mode |
(config)#service-template v1 | Configure the service template |
(config-svc)#match all | Configure the match condition |
(config-svc)#exit | Exit the interface mode |
(config)#interface xe1 | Specify the interface (xe1) to be configured |
(config-if)#switchport | Switch to Layer-2 mode. (VPLS can only be bound on the Layer-2 port.) |
(config-if)#mpls-vpls service-template v1 | Bind the VPLS to the Access Interface |
(config-if-vpls)#exit | Exit the VPLS attachment-circuit mode |
(config-if)#exit | Exit the interface mode |
#configure terminal | Enter the configuration mode |
(config)#router ldp | Enter the router LDP mode |
(config-router)# router-id 2.2.2.2 | Configure the router-id |
(config-router)#transport-address ipv4 2.2.2.2 | Configure the transport address for a label space by binding the address to a loopback address |
(config-router)#exit | Exit the router mode |
(config)#interface xe3 | Specify the interface (xe3) to be configured |
(config-if)#enable-ldp ipv4 | Enable the LDP on the specified interface (xe3) |
(config-if)#exit | Exit the interface mode |
#configure terminal | Enter the configuration mode. |
(config)#router ospf 1 | Configure the OSPF routing process, and specify the process ID |
(config-router)#network 20.20.1.0/24 area 0 | Define the interfaces on which OSPF runs, and specify the backbone area 0 |
(config-router)#network 2.2.2.2/32 area 0 | |
(config-router)#exit | Exit the router mode |
#configure terminal | Enter the configuration mode |
(config)#router bgp 100 | Enter the BGP router mode |
(config-router)#neighbor 1.1.1.1 remote-as 100 | Configure the PE1 as an iBGP peer |
(config-router)#neighbor 1.1.1.1 update-source lo | Update the source as loopback for iBGP peering with the remote PE1 router |
(config-router)#neighbor 3.3.3.3 remote-as 100 | Configure PE3 as an iBGP peer |
(config-router)#neighbor 3.3.3.3 update-source lo | Update the source as loopback for iBGP peering with the remote PE3 router |
(config-router)#address-family l2vpn vpls | Configure address-family l2vpn vpls |
(config-router-af)#neighbor 1.1.1.1 activate | Activate the PE1 in the VPLS address family |
(config-router-af)#neighbor 3.3.3.3 activate | Activate the PE3 in the VPLS address family |
#configure terminal | Enter the configuration mode |
(config)#interface xe3 | Specify the interface (xe3)to be configured |
(config-if)#ip address 40.40.1.5/24 | Set the IP address of the interface to 40.40.1.5/24 |
(config-if)#label-switching | Enable label switching on interface xe3 |
(config-if)#exit | Exit the interface mode |
(config)#interface lo | Specify the loopback address |
(config-if)#ip address 3.3.3.3/32 | Set the IP address of the loopback interface to 3.3.3.3/32 |
(config-if)#exit | Exit the interface mode |
(config)#mpls vpls v1 25 | Create an instance of VPLS, and switch to the VPLS command mode, by indicating the VPLS name (v1) and VPLS ID (25) |
(config-vpls)#vpls-mtu 1400 | Configure the MTU for the VPLS. Default is 1500; range is <576 - 65535> |
(config-vpls)#signaling bgp | Enter the Signaling BGP mode, for BGP VPLS |
(config-vpls-sig)#exit | Exit is a mandatory command for signaling BGP configuration to take affect. If exit is not done, BGP signaling does not take place. |
(config-vpls)#exit | Exit the VPLS mode. |
(config)#service-template v1 | Configure the service template |
(config-svc)#match all | Configure the match condition |
(config-svc)#exit | Exit the interface mode |
(config)#interface xe6 | Specify the interface (xe6) to be configured. |
(config-if)#switchport | Switch to Layer-2 mode. (VPLS can be bound only on the Layer-2 port.) |
(config-if)#mpls-vpls v1 service-template v1 | Bind the VPLS to the Access Interface. |
(config-if-vpls)#exit | Exit the VPLS attachment-circuit mode |
(config-if)#exit | Exit the interface mode. |
#configure terminal | Enter the configuration mode |
(config)#router ldp | Enter the router LDP mode |
(config-router)# router-id 3.3.3.3 | Configure the router ID |
(config-router)#transport-address ipv4 3.3.3.3 | Configure the transport address for a label space by binding the address to a loopback address. |
(config-router)#exit | Exit the router mode |
(config)#interface xe3 | Specify the interface (xe3) to be configured. |
(config-if)#enable-ldp ipv4 | Enable the LDP on the interface |
(config-if)#exit | Exit the interface mode |
#configure terminal | Enter the configuration mode. |
(config)#router ospf 1 | Configure the OSPF routing process, and specify the process ID |
(config-router)#network 40.40.1.0/24 area 0 | Define the interfaces on which OSPF runs, and specify the backbone area 0 |
(config-router)#network 3.3.3.3/32 area 0 | |
(config-router)#exit | Exit the router mode |
#configure terminal | Enter the configuration mode |
(config)#router bgp 100 | Enter the BGP Router mode |
(config-router)#neighbor 1.1.1.1 remote-as 100 | Configure the PE1 as an iBGP peer |
(config-router)#neighbor 1.1.1.1 update-source lo | Update the source as loopback for iBGP peering with the remote PE1 router. |
(config-router)#neighbor 2.2.2.2 remote-as 100 | Configure the PE2 as an iBGP peer |
(config-router)#neighbor 2.2.2.2 update-source lo | Update the source as loopback for iBGP peering with the remote PE2 router |
(config-router)#address-family l2vpn vpls | Configure the address-family l2vpn VPLS |
(config-router-af)#neighbor 1.1.1.1 activate | Activate the PE1 in the VPLS address family |
(config-router-af)#neighbor 2.2.2.2 activate | Activate the PE2 in the VPLS address family |
#configure terminal | Enter the configuration mode |
(config)#interface xe1 | Specify the interface (xe1) to be configured |
(config-if)#ip address 10.10.1.2/24 | Set the IP address of the interface to 10.10.1.2/24 |
(config-if)#label-switching | Enable the label switching on interface xe1 |
(config-if)#exit | Exit the interface mode |
(config)#interface xe2 | Specify the interface (xe2) to be configured |
(config-if)#ip address 40.40.1.2/24 | Set the IP address of the interface to 40.40.1.2/24 |
(config-if)#label-switching | Enable the label switching on interface eth2 |
(config-if)#exit | Exit the interface mode |
(config)#interface xe3 | Specify the interface (xe3) to be configured |
(config-if)#ip address 20.20.1.2/24 | Set the IP address of the loopback interface to 20.20.1.2/24 |
(config-if)#label-switching | Enable the label switching on interface xe3 |
(config-if)#exit | Exit the interface mode |
#configure terminal | Enter the configuration mode |
(config)#router ldp | Enter the router LDP mode |
(config-router)#exit | Exit the router mode |
(config)#interface xe1 | Specify the interface (xe1) to be configured |
(config-if)#enable-ldp ipv4 | Enable LDP on the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe2 | Specify the interface (xe2) to be configured |
(config-if)#enable-ldp ipv4 | Enable the LDP on the interface. |
(config-if)#exit | Exit the interface mode |
(config)#interface xe3 | Specify the interface (xe3) to be configured. |
(config-if)#enable-ldp ipv4 | Enable the LDP on the interface |
(config-if)#exit | Exit the interface mode |
#configure terminal | Enter the configuration mode. |
(config)#router ospf 1 | Configure the OSPF routing process, and specify the process ID. |
(config-router)#network 10.10.1.0/24 area 0 | Define the interfaces on which OSPF runs, and specify the backbone area 0. |
(config-router)#network 20.20.1.0/24 area 0 | |
(config-router)#network 40.40.1.0/24 area 0 | |
(config-router)#exit | Exit the router mode |