#configure terminal | Enter the configuration mode |
(config)#interface lo | Enter the Interface mode for the loopback interface |
(config-if)#ip address 21.21.21.21/32 secondary | Configure the IP address on loopback interface |
(config-if)#exit | Exit the interface mode |
(config)#router ldp | Enter the Router LDP mode. |
config-router)#router-id 21.21.21.21 | Set the router ID to IP address 21.21.21.21 |
(config-router)#transport-address ipv4 21.21.21.21 | Configure the transport address |
(config-router)#targeted-peer ipv4 23.23.23.23 | Configure the targeted peer |
(config-router-targeted-peer)#end | Exit from the router target peer and LDP mode |
(config)#interface xe2 | Enter the Interface mode for xe2 |
(config-if)# ip address 10.10.23.21/24 | Configure the IP address on the interface |
(config-if)#enable-ldp ipv4 | Enable the LDP on the physical interface |
(config-if)# label-switching | Enable the label switching on the interface |
(config-if)#exit | Exit the interface mode |
(config)#router ospf 100 | Enter the router OSPF mode |
(config-router)#ospf router-id 21.21.21.21 | Router-id configurations |
(config-router)#network 21.21.21.21/32 area 0 | Advertise loopback address in OSPF |
(config-router)#network 10.10.23.0/24 area 0 | Advertise network address in OSPF |
(config-router)#exit | Exit router OSPF mode and return to configure mode |
(config)#mpls vpls v1 25 | Enter VPLS configure mode |
(config-vpls)#service-tpid dot1.ad | Service tp-id configuration. |
(config-vpls)#signaling ldp | Define signaling as LDP |
(config-vpls-sig)#vpls-type vlan | Type VLAN configuration for VPLS |
(config-vpls-sig)#vpls-peer 23.23.23.23 | Configure the VPLS Peer |
(config-vpls-sig)#exit-signaling | Exit signaling LDP mode |
(config-vpls)#exit | Exit the VPLS mode |
(config)#mpls vpls v2 26 | Enter the VPLS configure mode |
(config-vpls)#service-tpid dot1.ad | Service tp-id configuration |
(config-vpls)#signaling ldp | Define signaling as LDP |
(config-vpls-sig)#vpls-type vlan | Type VLAN configuration for VPLS |
(config-vpls-sig)#vpls-peer 23.23.23.23 | Configure VPLS Peer |
(config-vpls-sig)#exit-signaling | Exit signaling LDP mode |
(config-vpls)#exit | Exit the VPLS mode |
(config)#mpls vpls v3 27 | Enter the VPLS config mode |
(config-vpls)#signaling ldp | Define the Signaling as LDP |
(config-vpls-sig)#vpls-type vlan | Type VLAN configuration for VPLS |
(config-vpls-sig)#vpls-peer 23.23.23.23 | Configure VPLS Peer |
(config-vpls-sig)# exit-signaling | Exit the signaling LDP mode |
(config-vpls)#exit | Exit the VPLS mode |
#configure terminal | Enter the configuration mode. |
(config)#interface lo | Enter the Interface mode for the loopback interface. |
(config-if)#ip address 22.22.22.22/32 secondary | Configure the IP address on loopback interface. |
(config-if)#exit | Exit the interface mode |
(config)#router ldp | Enter the router LDP mode |
(config-router)#router-id 22.22.22.22 | Set the router ID to IP address 22.22.22.22 |
(config-router)#transport-address ipv4 22.22.22.22 | Configure the transport address |
(config-router-targeted-peer)#end | Exit the from router target peer and LDP mode |
(config)#interface xe1 | Enter the Interface mode for xe1 |
(config-if)# ip address 10.10.23.22/24 | Configure IP address on the interface |
(config-if)#enable-ldp ipv4 | Enable the LDP on the physical interface |
(config-if)# label-switching | Enable the label switching on the interface. |
(config-if)#exit | Exit the interface mode |
(config)#interface xe2 | Enter the Interface mode for xe2 |
(config-if)# ip address 10.10.21.22/24 | Configure IP address on the interface |
(config-if)#enable-ldp ipv4 | Enable LDP on the physical interface |
(config-if)# label-switching | Enable label switching on the interface |
(config-if)#exit | Exit interface mode |
(config)#router ospf 100 | Enter the Router OSPF mode |
(config-router)#network 22.22.22.22/32 area 0 | Advertise loopback address in OSPF |
(config-router)#network 10.10.23.0/24 area 0 | Advertise network address in OSPF |
(config-router)#network 10.10.21.0/24 area 0 | Advertise network address in OSPF |
(config-router)#exit | Exit the router OSPF mode and return to Configure mode |
#configure terminal | Enter the configuration mode |
(config)#interface lo | Enter the Interface mode for the loopback interface |
(config-if)#ip address 23.23.23.23/32 secondary | Configure the IP address on loopback interface |
(config-if)#exit | Exit the interface mode |
(config)#router ldp | Enter the Router LDP mode |
(config-router)#router-id 23.23.23.23 | Set the router ID to IP address 23.23.23.23 |
(config-router)#transport-address ipv4 23.23.23.23 | Configure transport address |
(config-router)#targeted-peer ipv4 21.21.21.21 | Configure the targeted peer |
(config-router-targeted-peer)#end | Exit from the router target peer and LDP mode |
(config)#interface xe1 | Enter the Interface mode for xe1 |
(config-if)# ip address 10.10.21.23/24 | Configure the IP address on the interface |
(config-if)#enable-ldp ipv4 | Enable the LDP on the physical interface |
(config-if)# label-switching | Enable the label switching on the interface |
(config-if)#exit | Exit the interface mode |
(config)#router ospf 100 | Enter the Router OSPF mode |
(config-router)#network 23.23.23.23/32 area 0 | Advertise loopback address in OSPF |
(config-router)#network 10.10.21.0/24 area 0 | Advertise network address in OSPF |
(config-router)#exit | Exit the router OSPF mode and return to Configure mode |
(config)#mpls vpls v1 25 | Enter VPLS configure mode |
(config-vpls)#service-tpid dot1.ad | Service tp-id configuration |
(config-vpls)#signaling ldp | Define Signaling as LDP |
(config-vpls-sig)#vpls-type vlan | Type VLAN configuration for VPLS |
(config-vpls-sig)#vpls-peer 21.21.21.21 | Configure the VPLS Peer |
(config-vpls-sig)# exit-signaling | Exit signaling LDP mode |
(config-vpls)#exit | Exit the VPLS mode |
(config)#mpls vpls v2 26 | Enter VPLS config mode |
(config-vpls)#service-tpid dot1.ad | Service tp-id configuration. |
(config-vpls)#signaling ldp | Define Signaling as LDP |
(config-vpls-sig)#vpls-type vlan | Type VLAN configuration for VPLS |
(config-vpls-sig)#vpls-peer 21.21.21.21 | Configure VPLS Peer |
(config-vpls-sig)# exit-signaling | Exit Signaling LDP mode |
(config-vpls)#exit | Exit VPLS mode |
(config)#mpls vpls v3 27 | Enter VPLS config mode |
(config-vpls)#signaling ldp | Define Signaling as LDP |
(config-vpls-sig)#vpls-type vlan | Type VLAN configuration for VPLS |
(config-vpls-sig)#vpls-peer 21.21.21.21 | Configure VPLS Peer |
(config-vpls-sig)# exit-signaling | Exit Signaling LDP mode |
(config-vpls)#exit | Exit VPLS mode |
#configure terminal | Configure the mode |
(config)#service-template template1 | Template configuration |
(config-svc)# match double-tag outer-vlan 2024 inner-vlan 2023 | Match the criteria under template configuration |
(config-svc)# rewrite ingress pop outgoing-tpid dot1.q | Action to be performed for the match |
(config-svc)#exit | Exit the template configuration mode |
(config)#service-template template2 | Template configuration |
(config-svc)# match double-tag outer-vlan 2030 inner-vlan 2024 | Match the criteria under template configuration |
(config-svc)# rewrite ingress translate 2026 outgoing-tpid dot1.q | Action to be performed for the match |
(config-svc)#exit | Exit the template configuration mode |
(config)#service-template template3 | Template configuration |
(config-svc)# rewrite ingress push 300 | Action to be performed for the default match . |
(config-svc)#exit | Exit the template configuration mode |
(config)#interface xe1 | Enter the Interface mode for xe1 |
(config-if)#switchport | Configure the interface as a layer 2 port |
(config-if)#mpls-vpls v1 service-template template1 | Bind the VPLS to the Access Interface |
(config-if-vpls)#exit | Exit the VPLS attachment-circuit mode |
(config-if)#mpls-vpls v2 service-template template2 | Bind the VPLS to the Access Interface |
(config-if-vpls)#exit | Exit the VPLS attachment-circuit mode |
(config-if)#mpls-vpls v3 service-template template3 | Bind the VPLS to the Access Interface |
(config-if-vpls)#exit | Exit the VPLS attachment circuit mode |
(config-if)#exit | Exit the Interface mode and return to configure mode |
#configure terminal | Enter the configure mode |
(config)#service-template template1 | Template configuration |
(config-svc)# match double-tag outer-vlan 2024 inner-vlan 2023 | Match the criteria under template configuration |
(config-svc)# rewrite ingress pop outgoing-tpid dot1.q | Action to be performed for the match. |
(config-svc)#exit | Exit the template configuration mode |
(config)#service-template template2 | Template configuration |
(config-svc)# match double-tag outer-vlan 2030 inner-vlan 2024 | Match the criteria under template configuration |
(config-svc)# rewrite ingress translate 2026 outgoing-tpid dot1.q | Action to be performed for the match |
(config-svc)#exit | Exit the template configuration mode |
(config)#service-template template3 | Template configuration |
(config-svc)# rewrite ingress push 300 | Action to be performed for the default match . |
(config-svc)#exit | Exit the template configuration mode |
(config)#interface xe2 | Enter the Interface mode for xe2 |
(config-if)#switchport | Configure interface as a layer 2 port |
(config-if)#mpls-vpls v1 service-template template1 | Bind the VPLS to the Access Interface |
(config-if-vpls)#exit | Exit the VPLS attachment-circuit mode |
(config-if)#mpls-vpls v2 service-template template2 | Bind the VPLS to the Access Interface |
(config-if-vpls)#exit | Exit the VPLS attachment-circuit mode |
(config-if)#mpls-vpls v3 service-template template3 | Bind the VPLS to the Access Interface |
(config-if-vpls)#exit | Exit the VPLS attachment-circuit mode |
(config-if)#exit | Exit the Interface mode and return to Configure mode |