#configure terminal | Enter the configure mode |
(config)#interface lo | Specify the interface (lo) to be configured |
(config-if)#ip address 11.11.11.11/32 secondary | Configure IP address on loopback interface |
(config-if)#exit | Exit the interface mode |
(config)#router ldp | Enter router mode for LDP |
(config-router)#router-id 11.11.11.11 | Configure the router id |
(config-router)#transport-address ipv4 11.11.11.11 | Configure the loopback address as transport-address |
(config-router)#targeted-peer ipv4 44.44.44.44 | Configure the loopback address of RTR4 as targeted peer |
(config-router-targeted-peer)#exit | Exit the router-targeted-peer mode and enter config-router mode |
(config-router)#end | Exit the router and configure mode |
#configure terminal | Enter the configure mode |
(config)#interface xe2 | Enter interface mode for xe2 |
(config-if)#enable-ldp ipv4 | Enable the LDP on the interface |
(config-if)#label-switching | Enable label switching on the interface |
(config-if)#ip address 10.10.10.1/24 | Configure IP address on the interface |
(config-if)#exit | Exit the interface mode |
(config)#router ospf 100 | Enter the router OSPF mode |
(config-router)#network 11.11.11.11/32 area 0 | Advertise loopback address in OSPF |
(config-router)#network 10.10.10.0/24 area 0 | Advertise network address (xe2) in OSPF |
(config-router)#exit | Exit the router OSPF mode and return to Configure mode |
#configure terminal | Enter the configure mode. |
(config)#interface lo | Specify the interface (lo) to be configured |
(config-if)#ip address 22.22.22.22/32 secondary | Configure the router id |
(config-if)#exit | Exit the interface mode |
(config)#router ldp | Enter router mode for LDP |
(config-router)#transport-address ipv4 22.22.22.22 | Configure the loopback address as transport-address |
(config-router)#end | Exit the router and configure mode |
#configure terminal | Enter the configure mode |
(config)#interface xe1 | Enter the interface mode for xe1 |
(config-if)#enable-ldp ipv4 | Enable LDP on the interface |
(config-if)#label-switching | Enable label switching on the interface |
(config-if)#ip address 10.10.10.2/24 | Configure IP address on the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe2 | Enter interface mode for xe2 |
(config-if)#enable-ldp ipv4 | Enable LDP on the interface |
(config-if)#label-switching | Enable Label switching on the interface |
(config-if)#ip address 20.20.20.1/24 | Configure IP address on the interface |
(config-if)#exit | Exit the interface mode |
(config)#router ospf 100 | Enter the Router OSPF mode |
(config-router)#network 22.22.22.22/32 area 0.0.0.0 | Advertise loopback address in OSPF |
(config-router)#network 10.10.10.2/24 area 0.0.0.0 | Advertise network address (xe1) in OSPF |
(config-router)#network 20.20.20.1/24 area 0.0.0.0 | Advertise network address (xe2) in OSPF |
(config-router)#exit | Exit OSPF router configuration mode |
#configure terminal | Enter the configure mode. |
(config)#interface lo | Specify the interface (lo) to be configured |
(config-if)#ip address 33.33.33.33/32 secondary | Configure the router id |
(config-if)#exit | Exit the interface mode. |
(config)#router ldp | Enter router mode for LDP |
(config-router)#transport-address ipv4 33.33.33.33 | Configure the loopback address as transport address |
(config-router)#end | Exit the router and configure mode |
#configure terminal | Enter configure mode |
(config)#interface xe1 | Enter the interface mode for xe1 |
(config-if)#enable-ldp ipv4 | Enable LDP on the interface |
(config-if)#label-switching | Enable Label switching on the interface |
(config-if)#ip address 20.20.20.2/24 | Configure IP address on the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe2 | Enter the interface mode for xe2 |
(config-if)#enable-ldp ipv4 | Enable LDP on the interface |
(config-if)#label-switching | Enable label switching on the interface |
(config-if)#ip address 30.30.30.1/24 | Configure IP address on the interface |
(config-if)#exit | Exit the interface mode |
(config)#router ospf 100 | Enter the router OSPF mode |
(config-router)#network 33.33.33.33/32 area 0.0.0.0 | Advertise loopback address in OSPF |
(config-router)#network 20.20.20.2/24 area 0.0.0.0 | Advertise network address (xe1) in OSPF |
(config-router)#network 30.30.30.1/24 area 0.0.0.0 | Advertise network address (xe2) in OSPF |
(config-router)#exit | Exit the OSPF router configuration mode |
#configure terminal | Enter the configure mode |
(config)#interface lo | Specify the interface (lo) to be configured |
(config-if)#ip address 44.44.44.44/32 secondary | Configure the router id |
(config-if)#exit | Exit the interface mode |
(config)#router ldp | Enter the router mode for LDP |
(config-router)#transport-address ipv4 44.44.44.44 | Configure the loopback address as transport-address |
(config-router)#targeted-peer ipv4 11.11.11.11 | Configure the loopback address of RTR1 as targeted peer |
(config-router-targeted-peer)#exit | Exit the router targeted peer mode and enter config-router mode |
(config-router)#end | Exit the router and configure mode |
#configure terminal | Enter the configure mode |
(config)#interface xe1 | Enter the interface mode for xe1 |
(config-if)#enable-ldp ipv4 | Enable LDP on the interface |
(config-if)#label-switching | Enable label switching on the interface |
(config-if)#ip address 30.30.30.2/24 | Configure IP address on the interface |
(config-if)#exit | Exit the interface mode |
(config)#router ospf 100 | Enter the router OSPF mode |
(config-router)#network 44.44.44.44/32 area 0.0.0.0 | Advertise loopback address in OSPF |
(config-router)#network 30.30.30.2/24 area 0.0.0.0 | Advertise network address (xe1) in OSPF |
(config-router)#exit | Exit the OSPF router configuration mode. |
(config)#mpls vpls vpls1 1 | Enter the VPLS configuration mode |
(config-vpls)# signaling ldp | Use LDP signaling for VPLS |
(config-vpls-sig)#vpls-type ethernet | Configure the VPLS as Ethernet |
(config-vpls-sig)#vpls-peer 44.44.44.44 | Configure RTR4 as VPLS peer for RTR1 |
(config-vpls-sig)#exit-signaling | Exit the signaling mode |
(config-vpls)# exit-vpls | Exit VPLS config mode and return to Configure mode |
(config-vpls)#commit | Commit the transaction |
(config)#service-template st1 | Template configuration |
(config-svc)#exit | Exit service template mode |
(config)#interface xe1 | Enter the Interface mode for xe1 |
(config-if)#switchport | Enable switchport on the interface |
(config-if)#mpls-vpls vpls vpls1 service-template st1 | Bind the VPLS to the Access Interface |
(config-if)#commit | Commit the transaction |
(config)#mpls vpls vpls1 1 | Enter the VPLS configuration mode |
(config-vpls)#signaling ldp | Use LDP signaling for VPLS |
(config-vpls-sig)#vpls-type ethernet | Configure the VPLS as Ethernet |
(config-vpls-sig)#vpls-peer 11.11.11.11 | Enable switchport on the interface |
(config-vpls-sig)#exit-signaling | Exit the signaling mode |
(config-vpls)#commit | Commit the transaction |
(config)#service-template st1 | Template configuration |
(config-svc)#exit | Exit the service template mode |
(config)#interface xe2 | Enter the Interface mode for xe2 |
(config-if)#switchport | Enable switchport on the interface |
(config-if)#mpls-vpls vpls1 service template st1 | Bind the VPLS to the Access Interface |
(config-if-vpls)#commit | Commit the transaction |
(config)#mpls l2-circuit t1 100 44.44.44.44 | Enter the VC configuration command in router mode |
(config)#bridge 1 protocol ieee vlan-bridge | Create a VLAN bridge in the router mode |
(config)#service-template st1 | Template configuration |
(config-svc)#exit | Exit the service template configuration |
(config)#interface xe1 | Enter the interface mode for xe1 |
(config-if)#switchport | Enable switchport on the interface |
(config-if)#mpls-l2-circuit t1 service-template st1 | Bind the interface to VC created in ethernet mode |
(config-if)#exit | Exit the interface mode |
(config)#mpls l2-circuit t1 100 11.11.11.11 | Enter the VC configuration command in router mode |
(config)#bridge 1 protocol ieee vlan-bridge | Create a VLAN-bridge in router mode |
(config)#service-template st1 | Template configuration |
(config-svc)#exit | Exit service template mode |
(config)#interface xe2 | Enter the interface mode for xe2 |
(config-if)#switchport | Enable switchport on the interface |
(config-if)#mpls-l2-circuit t1 service-template st1 | Bind the interface to VC created in ethernet mode. |
(config-if)#exit | Exit the interface mode. |
(config)#mpls vpls vpls1 1 | Enter the VPLS configuration mode |
(config-vpls)#signaling ldp | Use LDP signaling for VPLS |
(config-vpls-sig)#vpls-peer 44.44.44.44 | Configure RTR4 as VPLS peer for RTR1 |
(config-vpls-sig)#exit-signaling | Exit the signaling mode |
(config-vpls)#commit | Commit the transaction |
(config)#service-template st1 | Template configuration |
(config-svc)#exit | Exit the service template mode |
(config)#interface xe1 | Enter the interface mode for xe1 |
(config-if)#switchport | Enable switchport on the interface |
(config-if)#mpls-vpls vpls1 service-template st1 | Bind the interface to VPLS |
(config-if-vpls)#commit | Commit the transaction |
(config)#mpls vpls vpls1 1 | Enter the VPLS configuration mode |
(config-vpls)#signaling ldp | Use LDP signaling for VPLS |
(config-vpls-sig)#vpls-peer 11.11.11.11 | Configure RTR4 as VPLS peer for RTR1 |
(config-vpls-sig)#exit-signaling | Exit the signaling mode |
(config-vpls)#commit | Commit the transaction |
(config)#service-template st1 | Template configuration |
(config-svc)#exit | Exit service template mode |
(config)#interface xe2 | Enter interface mode for xe2 |
(config-if)#switchport | Enable switchport on the interface |
(config-if)#mpls-vpls vpls1 service-template st1 | Bind the interface to VPLS |
(config-if-vpls)#exit | Exit VPLS mode and return to interface mode |
(config-if)#commit | Commit the transaction |
#configure terminal | Enter the configure mode |
(config)#router rsvp | Enter RSVP configuration mode for the router |
(config-router)#commit | Commit the transaction |
(config)#interface xe2 | Enter interface mode for xe2 |
(config-if)#enable-rsvp | Enable RSVP on the interface |
(config-if)#label-switching | Enable label switching on the interface |
(config-if)#commit | Commit the transaction |
(config)#rsvp-trunk t1 | Configure RSVP trunk t1 |
(config-trunk)#to 44.44.44.44 | Configure RTR4 as the end of trunk |
(config-trunk)#commit | Commit the transaction |
(config)#rsvp rsvp | Enter RSVP configuration mode for the router |
(config-router)#php | Configure PHP on the end node |
(config-trunk)#commit | Commit the transaction |
(config)#interface xe1 | Enter the interface mode for xe1 |
(config-if)#enable-rsvp | Enable RSVP on the interface |
(config-if)#label-switching | Enable Label switching on the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe2 | Enter the interface mode for xe1 |
(config-if)#enable-rsvp | Enable RSVP on the interface |
(config-if)#label-switching | Enable Label switching on the interface |
(config-if)#commit | Commit the transaction |
#configure terminal | Enter the configure mode |
(config)#router rsvp | Enter RSVP configuration mode for the router |
(config-router)#php | Configure PHP on the end node |
(config-router)#commit | Commit the transaction |
(config)#interface xe1 | Enter the interface mode for xe1 |
(config-if)#enable-rsvp | Enable RSVP on the interface |
(config-if)#label-switching | Enable Label switching on the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe3 | Enter the interface mode for xe3 |
(config-if)#enable-rsvp | Enable RSVP on the interface |
(config-if)#label-switching | Enable label switching on the interface |
(config-if)#commit | Commit the transaction |
#configure terminal | Enter the configure mode |
(config)#router rsvp | Enter RSVP configuration mode for the router |
(config-if)#commit | Commit the transaction |
(config)#interface xe1 | Enter the interface mode for xe1 |
(config-if)#enable-rsvp | Enable RSVP on the interface |
(config-if)#label-switching | Enable label switching on the interface |
(config-if)#commit | Commit the transaction |
(config)#rsvp-trunk t2 | Configure RSVP trunk t2 |
(config-trunk)#to 11.11.11.11 | Configure RTR1 as the end of trunk |
(config-if)#commit | Commit the transaction |
(config)#mpls ftn-entry 44.44.44.44/32 100 10.10.10.2 eth2 | Configure FTN entry for rtr4 loopback |
(config)#mpls ilm-entry 900 pop | Pop the incoming label |
(config)#interface xe2 | Enter the interface mode for xe2 |
(config-if)#label-switching | Enable label switching on the interface |
(config-if)#exit | Exit the interface mode |
mpls ilm-entry 100 swap 200 xe2 20.20.20.2 44.44.44.44/32 | Swap the incoming label |
mpls ilm-entry 800 swap 900 xe1 10.10.10.1 11.11.11.11/32 | Swap the incoming label |
(config)#interface xe1 | Enter the interface mode for xe1 |
(config-if)#label-switching | Enable Label switching on the interface |
(config-if)#exit | Exit interface mode |
(config)#interface xe2 | Enter the interface mode for xe2 |
(config-if)#label-switching | Enable Label switching on the interface |
(config-if)#exit | Exit the interface mode |
(config)#mpls ilm-entry 200 swap 300 xe2 30.30.30.2 44.44.44.44/32 | Swap the incoming label |
(config)#mpls ilm-entry 700 swap 800 xe1 20.20.20.1 11.11.11.11/32 | Swap the incoming label |
(config)#interface xe1 | Enter interface mode for xe1 |
(config-if)#label-switching | Enable Label switching on the interface |
(config-if)#exit | Exit the interface mode |
(config)#interface xe2 | Enter the interface mode for xe2 |
(config-if)#label-switching | Enable Label switching on the interface |
(config-if)#exit | Exit the interface mode |
(config)#mpls ftn-entry 11.11.11.11/32 700 30.30.30.1 xe1 | Configure FTN entry for RTR1 loopback |
(config)mpls ilm-entry 300 pop | Pop the incoming label |
(config)#interface xe1 | Enter the interface mode for xe1 |
(config-if)#label-switching | Enable Label switching on the interface |
(config-if)#exit | Exit the interface mode |