#configure terminal | Enter the configure mode |
(config)#interface lo | Specify the loopback interface (lo) to be configured |
(config-if)#ip address 1.1.1.1/32 secondary | Set the IP address of the loopback interface to 1.1.1.1/32 |
(config-if)#exit | Exit the interface mode |
(config)#interface xe1 | Specify the interface (xe1) to be configured |
(config-if)#label-switching | Enable label switching on interface xe1 |
(config-if)#ip address 10.1.1.1/24 | Set the IP address of the interface to 10.1.1.1/24 |
(config-if)#exit | Exit the interface mode |
(config)#router ospf 100 | Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process |
(config-router)#network 10.1.1.0/24 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface |
(config-router)#network 1.1.1.1/32 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface |
#configure terminal | Enter the configure mode |
(config)#interface lo | Specify the loopback interface (lo0) to be configured |
(config-if)#ip address 9.9.9.9/32 secondary | Set the IP address of the loopback interface to 9.9.9.9/32 |
(config-if)#exit | Exit the interface mode |
(config)#interface xe1 | Specify the interface (xe1) to be configured |
(config-if)#label-switching | Enable label switching on interface xe1 |
(config-if)#ip address 10.1.1.2/24 | Set the IP address of the interface to 10.1.1.2/24 |
(config-if)#exit | Exit the interface mode |
(config)#interface xe13 | Specify the interface (xe13) to be configured. |
(config-if)#label-switching | Enable label switching on the interface xe13 |
(config-if)#ip address 20.1.1.1/24 | Set the IP address of the interface to 20.1.1.1/24 |
(config-if)#exit | Exit the interface mode |
(config)#router ospf 100 | Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process |
(config-router)#network 10.1.1.0/24 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface |
(config-router)#network 20.1.1.0/24 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface |
(config-router)#network 9.9.9.9/32 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface |
#configure terminal | Enter the configure mode. |
(config)#interface lo | Specify the loopback interface (lo0) to be configured |
(config-if)#ip address 2.2.2.2/32 secondary | Set the IP address of the loopback interface to 2.2.2.2/32 |
(config-if)#exit | Exit the interface mode |
(config)#interface xe13 | Specify the interface (xe13) to be configured |
(config-if)#label-switching | Enable the label switching on interface xe13 |
(config-if)#ip address 20.1.1.2/24 | Set the IP address of the interface to 20.1.1.2/24 |
(config-if)#exit | Exit the interface mode |
(config)#router ospf 100 | Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process |
(config-router)#network 20.1.1.0/24 area 0 | Define the interface on which OSPF runs, and associate the area ID (0) with the interface |
(config-router)#network 2.2.2.2/32 area 0 | Define the interface on which OSPF runs, and associate the area ID (0) with the interface |
#configure terminal | Enter the configure mode |
(config)#router ldp | Enter the router mode |
(config-router)#router-id 1.1.1.1 | Configure the router id |
(config-router)#transport-address ipv4 1.1.1.1 | Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface |
(config-router)#targeted-peer ipv4 2.2.2.2 | Specify the targeted LDP peer on PE-1 |
(config-router-targeted-peer)# exit | Exit the router targeted peer mode |
(config-router)#exit | Exit the router mode |
(config)#router rsvp | Enter RSVP configuration mode for the router |
(config-router)#exit | Exit the configuration mode of the router |
(config)#interface xe1 | Specify the interface (xe1) to be configured |
(config-if)#enable-ldp ipv4 | Enable LDP on the interface xe1 |
(config-if)#enable-rsvp | Enable RSVP on the interface |
(config-if)#exit | Exit the interface mode |
(config)#rsvp-trunk t2 | Configure RSVP trunk t2 |
(config-trunk)#to 2.2.2.2 | Configure PE2 as the end of trunk |
(config-trunk)#end | Exit the configuration mode |
#configure terminal | Enter the configure mode. |
(config)#router rsvp | Enter the RSVP configuration mode for the router |
(config-router)#exit | Exit the configuration mode of the router |
(config)#interface xe1 | Specify the interface (xe1) to be configured |
(config-if)#enable-rsvp | Enable RSVP on the interface. |
(config-if)#exit | Exit the interface mode |
(config)#interface xe13 | Specify the interface (xe13) to be configured |
(config-if)#enable-rsvp | Enable RSVP on the interface |
(config-if)#exit | Exit the interface mode |
(config)#rsvp-trunk t5 | Configure RSVP trunk t5 |
(config-trunk)#to 2.2.2.2 | Configure PE2 as the end of trunk |
(config-trunk)#exit | Exit configuration mode |
(config)#rsvp-trunk t6 | Configure RSVP trunk t6 |
(config-trunk)#to 1.1.1.1 | Configure PE2 as the end of trunk |
(config-trunk)#exit | Exit the configuration mode |
#configure terminal | Enter configure mode. |
(config)#router ldp | Enter the Router mode. |
(config-router)#router-id 2.2.2.2 | Configure the router-id |
(config-router)#transport-address ipv4 2.2.2.2 | Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. |
(config-router)#targeted-peer ipv4 1.1.1.1 | Specify the targeted LDP peer on PE-2. |
(config-router-targeted-peer)# exit | Exit the Router targeted peer mode. |
(config-router)#exit | Exit the Router mode. |
(config)#router rsvp | Enter RSVP configuration mode for the router |
(config-router)#exit | Exit the configuration mode of the router. |
(config)#interface xe13 | Specify the interface(xe13) to be configured |
(config-if)#enable-ldp ipv4 | Enable LDP on interface xe13 |
(config-if)#enable-rsvp | Enable RSVP on the interface |
(config-if)#exit | Exit the interface mode |
(config)#rsvp-trunk t3 | Configure RSVP trunk t3 |
(config-trunk)#to 1.1.1.1 | Configure PE1 as the end of trunk |
(config-trunk)#exit | Exit the configuration mode |
#configure terminal | Enter the configure mode. |
(config)#mpls l2-circuit t2 100 2.2.2.2 | Configure the VC for PE-2. In this example, t2 is the VC name, 200 is the VC ID, and 2.2.2.2 is the VC endpoint IP address |
(config-pseudowire)#tunnel-name t2 | Configure the RSVP Trunk name as t2 |
(config-pseudowire)#exit | Exit the pseudowire config mode. |
(config)#mpls l2-circuit t3 300 2.2.2.2 mode raw | Configure the VC for PE-2. In this example, t3 is the VC-name, 300 is the VC ID and 2.2.2.2 is the VC endpoint IP address |
(config-pseudowire)#tunnel-name t2 | Configure RSVP Trunk name as t2 |
(config-pseudowire)#exit | Exit the pseudowire config mode. |
#configure terminal | Enter the configure mode. |
(config)#mpls l2-circuit t2 100 1.1.1.1 | Configure the VC for PE-1. In this example, t2 is the VC name, 200 is the VC ID, and 1.1.1.1 is the VC endpoint IP address |
(config-pseudowire)#tunnel-name t2 | Configure RSVP Tunnel name as t2 |
(config-pseudowire)#exit | Exit the pseudowire config mode. |
(config)#mpls l2-circuit t3 300 1.1.1.1 mode raw | Configure the VC for PE-1. In this example, t3 is the VC name, 300 is the VC ID, and 1.1.1.1 is the VC endpoint IP address |
(config-pseudowire)#tunnel-name t3 | Configure RSVP Tunnel name as t3 |
(config-pseudowire)#exit | Exit the pseudowire config mode. |
(config)#service-template ST1 | Create a service template ST1 |
(config-svc)#match outer-vlan 2 | Allow VLAN 2 traffic on this VC |
(config-svc)#exit | Exit the service template mode |
(config)#service-template ST2 | Create a service template ST2 |
(config-svc)#match outer-vlan 3 | Allow VLAN 3 traffic on this VC |
(config-svc)#exit | Exit the service template mode |
(config)#interface xe15 | Specify the interface (xe15) to be configured |
(config-if)#switchport | Switch to Layer-2 mode |
(config-if)#mpls-l2-circuit t2 service-template ST1 | Bind the interface to the VC with service template |
(config-if)#mpls-l2-circuit t3 service-template ST2 | Bind the interface to the VC with service template |
(config)#service-template ST1 | Create a service template ST1 |
(config-svc)#match outer-vlan 2 | Allow VLAN 2 traffic on this VC |
(config-svc)#exit | Exit the service template mode |
(config)#service-template ST2 | Create a service template ST2 |
(config-svc)#match outer-vlan 3 | Allow VLAN 3 traffic on this VC |
(config-svc)#exit | Exit the service template mode |
(config)#interface xe12 | Specify the interface (xe12) to be configured |
(config-if)#switchport | Switch to Layer-2 mode |
(config-if)#mpls-l2-circuit t2 service-template ST1 | Bind the interface to the VC with service template |
(config-if)#mpls-l2-circuit t3 service-template ST2 | Bind the interface to the VC with service template |
#configure terminal | Enter the configure mode |
PE1(config)#mpls l2-circuit t5 500 2.2.2.2 | Configure the VC for PE1 |
PE1(config-pseudowire)#tunnel-name t2 | Configure the RSVP Tunnel name as t2 |
PE1(config-pseudowire)#manual-pseudowire | Configure the VC as manual (no signaling is used) |
PE1(config-pseudowire)#exit | Exit the pseudowire config mode |
PE1(config)#service-template ST5 | Create a service template ST5 |
PE1(config-svc)#match outer-vlan 5 | Configure single match criteria VLAN 5 |
PE1(config-svc)#exit | Exit the service template mode |
PE1(config)#interface xe15 | Access interface xe15 |
(config-if)#switchport | Switch to Layer-2 mode |
PE1(config-if)#mpls-l2-circuit t5 service-template ST5 | Bind the interface to the VC with service template. |
PE1(config-if)#exit | Exit the interface mode |
PE1(config)#mpls l2-circuit-fib-entry 500 1000 2000 2.2.2.2 xe1 xe15 | Add an FTN entry; where 1000 is the incoming label, 2000 is the outgoing label, 2.2.2.2 is the endpoint, xe1 is the Provider facing interface name, and xe15 is access interface name |
#configure terminal | Enter the configure mode. |
PE2(config)#mpls l2-circuit t5 500 1.1.1.1 | Configure the VC for PE2 |
PE2(config-pseudowire)#tunnel-name t3 | Configure RSVP Tunnel name as t3 |
PE2(config-pseudowire)#manual-pseudowire | Configure VC as manual (no signaling used) |
PE2(config-pseudowire)#exit | Exit the pseudowire config mode |
PE2(config)#service-template ST5 | Create a service template ST5 |
PE2(config-svc)#match outer-vlan 5 | Configure single match criteria VLAN 5 |
PE2(config-svc)#exit | Exit the service template mode |
PE2(config)#interface xe12 | Access interface xe12 |
(config-if)#switchport | Switch to Layer-2 mode |
PE2(config-if)#mpls-l2-circuit t5 service-template ST5 | Bind the interface to the VC with service template. |
PE2(config-if)#exit | Exit the interface mode. |
PE1(config)#mpls l2-circuit-fib-entry 500 2000 1000 1.1.1.1 xe13 xe12 | Add an FTN entry; where 2000 is the incoming label, 1000 is the outgoing label, 1.1.1.1 is the endpoint, xe12 is the Provider facing interface name, and xe13 access interface name |
PE2(config)#exit | Exit the configure mode |
(config)#mpls vpls v1 25 | Enter the VPLS config mode |
(config-vpls)#service-tpid dot1.ad | Service tp-id configuration. |
(config-vpls)#signaling ldp | Define Signaling as LDP |
(config-vpls-sig)#vpls-type vlan | Type VLAN configuration for VPLS |
(config-vpls-sig)#vpls-peer 2.2.2.2 tunnel-name t2 | Configure VPLS Peer with trunk-name t2 |
(config-vpls-sig)#exit-signaling | Exit the signaling LDP mode |
(config-vpls)#exit | Exit the VPLS mode |
(config)#mpls vpls v2 26 | Enter the VPLS config mode |
(config-vpls)#service-tpid dot1.ad | Service tp-id configuration |
(config-vpls)#signaling ldp | Define Signaling as LDP |
(config-vpls-sig)#vpls-type ethernet | Type ethernet configuration for VPLS |
(config-vpls-sig)#vpls-peer 2.2.2.2 tunnel-name t2 | Configure VPLS Peer |
(config-vpls-sig)#exit-signaling | Exit Signaling LDP mode |
(config-vpls)#exit | Exit VPLS mode |
(config)#mpls vpls v1 25 | Enter VPLS config mode |
(config-vpls)#service-tpid dot1.ad | Service tp-id configuration |
(config-vpls)#signaling ldp | Define Signaling as LDP |
(config-vpls-sig)#vpls-type vlan | Type VLAN configuration for VPLS |
(config-vpls-sig)#vpls-peer 1.1.1.1 tunnel-name t3 | Configure VPLS Peer |
(config-vpls-sig)# exit-signaling | Exit the signaling LDP mode |
(config-vpls)#exit | Exit the VPLS mode |
(config)#mpls vpls v2 26 | Enter the VPLS config mode |
(config-vpls)#service-tpid dot1.ad | Service tp-id configuration |
(config-vpls)#signaling ldp | Define the signaling as LDP |
(config-vpls-sig)#vpls-type ethernet | Type ethernet configuration for VPLS |
(config-vpls-sig)#vpls-peer 1.1.1.1 tunnel-name t3 | Configure VPLS Peer with tunnel-name t2 |
(config-vpls-sig)#exit-signaling | Exit Signaling LDP mode |
(config-vpls)#exit | Exit VPLS mode |
#configure terminal | Configure the mode |
(config)#service-template template1 | Template configuration |
(config-svc)# match double-tag outer-vlan 2024 inner-vlan 2023 | Match criteria under template configuration |
(config-svc)# rewrite ingress pop outgoing-tpid dot1.q | Action to be performed for the match |
(config-svc)#exit | Exit the template configuration mode |
(config)#service-template template4 | Template configuration |
(config-svc)# match outer-vlan 700 | Allow VLAN 700 traffic on this VC |
(config-svc)# match double-tag outer-vlan 1200 inner-vlan 3200 | Allow double tag match with s+c tags |
(config-svc)# match untagged | Allow untagged traffic |
(config-svc)# rewrite ingress push 300 | Push Action performed for service template |
(config-svc)#exit | Exit the configure SVC mode |
(config)#interface xe15 | Enter the access interface xe15 |
(config-if)#switchport | Configure interface as a layer 2 port |
(config-if)#mpls-vpls v1 service-template template1 | Bind the VPLS to the Access Interface |
(config-if-vpls)#exit-if-vpls | Exit VPLS attachment-circuit mode |
(config-if)#mpls-vpls v2 service-template template4 | Bind the VPLS to the Access Interface |
(config-if-vpls)# exit-if-vpls | Exit the VPLS attachment-circuit mode |
(config-if)#exit | Exit the Interface mode and return to Configure mode |
#configure terminal | Configure mode |
(config)#service-template template1 | Template configuration |
(config-svc)# match double-tag outer-vlan 2024 inner-vlan 2023 | Match criteria under template configuration |
(config-svc)# rewrite ingress pop outgoing-tpid dot1.q | Action to be performed for the match |
(config-svc)#exit | Exit the template configuration mode |
(config)#service-template template4 | Template configuration |
(config-svc)# match outer-vlan 700 | Allow VLAN 700 traffic on this VC |
(config-svc)# match double-tag outer-vlan 1200 inner-vlan 3200 | Allow double tag match with s+c tags |
(config-svc)# match untagged | Allow untagged traffic |
(config-svc)# rewrite ingress push 300 | Push Action performed for service template |
(config-svc)#exit | Exit the configure SVC mode |
(config)#interface xe12 | Enter access Interface xe12 |
(config-if)#switchport | Configure interface as a layer 2 port. |
(config-if)#mpls-vpls v1 service-template template1 | Bind the VPLS to the Access Interface. |
(config-if-vpls)#exit-if-vpls | Exit the VPLS attachment-circuit mode |
(config-if)#mpls-vpls v2 service-template template4 | Bind the VPLS to the Access Interface |
(config-if-vpls)#exit-if-vpls | Exit the VPLS attachment-circuit mode |
(config-if)#exit | Exit the Interface mode and return to configure mode |
VPLS-ID | Peer Addr | Tunnel-Label | In-Label | Network-Intf | Out-Label | Lkps/St | PW-INDEX | SIG-Protocol | Status |
25 | 2.2.2.2 | 24321 | 24322 | Xe1 | 24322 | 2/Up | 4 | LDP | Active |
26 | 2.2.2.2 | 24321 | 24323 | Xe1 | 24323 | 2/Up | 5 | LDP | Active |
(config)#mpls vpls v3 27 | Enter the VPLS config mode |
(config-vpls)#vpls-peer 2.2.2.2 tunnel-name t2 manual | Configure VPLS Peer with trunk-name t2 with manual option |
(config-vpls)#exit | Exit the VPLS mode |
(config)#service-template vpls1 | Template configuration |
(config-svc)# match outer-vlan 1000 | Allow VLAN 1000 traffic on this VC |
(config-svc)#exit | Exit the service template mode |
(config)#interface xe15 | Enter the access Interface xe15 |
(config-if)#switchport | Configure interface as a layer 2 port |
(config-if)#mpls-vpls v3 service-template vpls1 | Bind the VPLS to the Access Interface. |
(config-if-vpls)#exit-if-vpls | Exit the VPLS attachment-circuit mode |
(config-if)#exit | Exit from the interface mode |
(config)#vpls fib-entry 27 peer 2.2.2.2 3000 xe1 4000 | Configure VPLS FIB entry for VPLS peer PE-2 |
(config)#mpls vpls v3 27 | Enter the VPLS config mode |
(config-vpls)#vpls-peer 1.1.1.1 tunnel-name t3 manual | Configure static VPLS Peer with tunnel-name t3 |
(config-vpls)#exit | Exit the VPLS mode |
(config)#service-template vpls1 | Template configuration |
(config-svc)# match outer-vlan 1000 | Allow VLAN 1000 traffic on this VC |
(config-svc)#exit | Exit the service template mode |
(config)#interface xe12 | Enter the access interface xe12 |
(config-if)#switchport | Configure interface as a layer 2 port. |
(config-if)#mpls-vpls v3 service-template vpls1 | Bind the VPLS to the Access Interface |
(config-if-vpls)#exit-if-vpls | Exit VPLS attachment-circuit mode |
(config-if)#exit | Exit interface mode |
(config)#vpls fib-entry 27 peer 1.1.1.1 4000 xe13 3000 | Configure VPLS FIB entry for VPLS peer PE-1 |
VPLS-ID | Peer Addr | Tunnel-Label | In-Label | Network-Intf | Out-Label | Lkps/St | PW-INDEX | SIG-Protocol | Status |
25 | 2.2.2.2 | 24321 | 24322 | xe1 | 24322 | 2/Up | 4 | LDP | Active |
26 | 2.2.2.2 | 24321 | 24323 | xe1 | 24323 | 2/Up | 5 | LDP | Active |
27 | 2.2.2.2 | 24321 | 3000 | xe1 | 4000 | 2/Up | 6 | STATIC | Active |
PE2# |