PE1(config)#vlan database | Enter the VLAN configuration mode. |
PE1(config-vlan)# vlan 200-201 bridge 1 state enable | Enable VLAN (200-201) on bridge 1. Specifying the enable state allows forwarding of frames on this VLAN-aware bridge. |
PE1(config-vlan)#interface sa1 | Enter sa1 interface mode. |
PE1(config-if)# switchport | Configure port as L2. |
PE1(config-if)# bridge-group 1 | Associate the interface with bridge group 1. |
PE1(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
PE1(config-if)# switchport trunk allowed vlan add 200-201 | Enable VLAN ID 200-201 on this port. |
PE1(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the sa1 interface. |
PE1(config-if)# exit | Exit from sa1 interface configuration mode. |
PE1(config)#interface ce0 | Enter ce0 interface mode. |
PE1(config-if)# static-channel-group 1 | Make it member port of sa1 |
PE1(config-if)#interface lo | Configures the loopback (lo) interface. |
PE1(config-if)# ip address 1.1.1.1/32 secondary | Assigns a secondary the IP address 1.1.1.1/32 to the loopback interface. |
PE1(config-if)# ipv6 address ::1/128 | Assigns the IPv6 address ::1/128 to the loopback interface. |
PE1(config-if)#interface vlan1.200 | Enter interface VLAN1.200 configuration mode. |
PE1(config-if)# ip address 101.11.11.1/24 | Assigns the primary IP address. |
PE1(config-if)# ip address 16.16.16.1/24 secondary | Assigns the secondary IP address. |
PE1(config-if)# ip address 17.17.17.1/24 secondary | Assigns the secondary IP address. |
PE1(config-if)# exit | Exit from VLAN interface configuration mode. |
PE1(config)#interface xe2 | Enter xe2 interface configuration mode. |
PE1(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the xe2 interface. |
PE1(config-if)#interface xe2.103 | Enter VLAN ID 103 interface config mode. |
PE1(config-if)# encapsulation dot1q 103 | Setting Encapsulation to dot1q with VLAN ID 103. |
PE1(config-if)# ip address 20.1.1.1/24 | Assigns the primary IP address. |
PE1(config-if)# exit | Exit from xe2 VLAN interface configuration mode. |
PE1(config)#interface xe23 | Enter xe23 interface configuration mode. |
PE1(config-if)# static-channel-group 1 | Configure static channel 1 member port |
PE1(config)#router ospf 1 | Enters the OSPF configuration mode for OSPF process 1. |
PE1(config-router)# network 16.16.16.0/24 area 0.0.0.0 | Advertises the network 16.16.16.0/24 into OSPF area 0.0.0.0. |
PE1(config-router)# network 17.17.17.0/24 area 0.0.0.0 | Advertises the network 17.17.17.0/24 into OSPF area 0.0.0.0. |
PE1(config-router)# network 20.1.1.0/24 area 0.0.0.0 | Advertises the network 20.1.1.0/24 into OSPF area 0.0.0.0. |
PE2(config)#vlan database | Enter the VLAN configuration mode. |
PE2(config-vlan)# vlan 100-101 bridge 1 state enable | Enable VLAN (100-101) on bridge 1. Specifying the enable state allows forwarding of frames on this VLAN-aware bridge |
PE2(config-vlan)#interface po1 | Enter po1 interface mode. |
PE2(config-if)# switchport | Configure port as L2. |
PE2(config-if)# bridge-group 1 | Associate the interface with bridge group 1. |
PE2(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
PE2(config-if)# switchport trunk allowed vlan add 100-101 | Enable VLAN ID 100-101 on this port. |
PE2(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the po1 interface. |
PE2(config-if)#interface lo | Configure loopback interface |
PE2(config-if)# ip address 2.2.2.2/32 secondary | Assign the secondary ip address to lo |
PE2(config-if)#interface vlan1.100 | Enter interface VLAN1.100 configuration mode. |
PE2(config-if)# ip address 11.11.11.1/24 | Assign primary IP address |
PE2(config-if)# ip address 12.1.1.1/24 secondary | Assign secondary IP address towards MH node. |
PE2(config-if)# ip address 13.1.1.1/24 secondary | Assign secondary address towards MH node |
PE2(config-if)# ip router isis 1 | Configure the isis |
PE2(config-if)# exit | Exit from VLAN interface configuration mode. |
PE2(config)#interface xe11 | Enter xe11 interface configuration mode. |
PE2(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the xe11 interface. |
PE2(config-if)#interface xe11.105 | Configure subinterface xe11.105. |
PE2(config-if)# encapsulation dot1q 105 | Setting Encapsulation to dot1q with VLAN ID 105. |
PE2(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the xe11 interface. |
PE2(config-if)# ip address 10.1.1.1/24 | Assign an IP address |
PE2(config-if)# ip router isis 1 | Configure interface as ISIS router |
PE2(config-if)# exit | Exit from xe11 interface configuration mode. |
PE2(config)#interface xe24 | Enter xe24 interface configuration mode. |
PE2(config-if)# channel-group 1 mode active | Configure the member port for po1 interface |
PE2(config-if)# exit | Exit from xe24 interface configuration mode. |
PE2(config-if)#interface xe26 | Enter xe26 interface configuration mode. |
PE2(config-if)# channel-group 1 mode active | Configure the member port for po1 interface |
PE2(config)#router isis 1 | Configure the ISIS router. |
PE2(config-router)# is-type level-1-2 | Configure level1-2 ISIS mode. |
PE2(config-router)# metric-style wide | Configure metric style as wide. |
PE2(config-router)# dynamic-hostname | Configure the hostname to be advertised for an ISIS 1 instance. |
PE2(config-router)# bfd all-interfaces | Enable the Bidirectional Forwarding Detection (BFD) feature on all the interfaces enabled with this ISIS instance. |
PE2(config-router)# net 49.0000.0000.0001.00 | Set a Network Entity Title for this instance, specifying the area address and the system ID. |
PE2(config-router)# redistribute connected | Redistribute the connected routes. |
PE7(config)#nvo vxlan enable | Enable VxLAN. |
PE7(config)#nvo vxlan irb | Enable VxLAN IRB |
PE7(config)#evpn esi hold-time 60 | Configure hold time for the tunnels to come up during VxLAN initialization before making the esi up. |
PE7(config)#evpn vxlan multihoming enable | Enable VxLAN multihome |
PE7(config)#ip vrf management | Enter into VRF configuration mode. |
PE7(config-vrf)#ip vrf L3VRF3 | Create a VRF routing information base called L3VRF3 for OSPF router. |
PE7(config-vrf)# rd 7100:11 | Specify a route distinguisher for the VRF. |
PE7(config-vrf)# route-target both 100:100 | Add import and export route-target extended communities to the VRF. |
PE7(config-vrf)# l3vni 1000 | Configure the L3 Virtual Network Identifier for an IP VRF. |
PE7(config-vrf)#ip vrf L3VRF4 | Create a VRF routing information base called L3VRF4 for ISIS router. |
PE7(config-vrf)# rd 7400:11 | Specify a route distinguisher for the VRF. |
PE7(config-vrf)# route-target both 101:101 | Add import and export route-target extended communities to the VRF. |
PE7(config-vrf)# l3vni 2000 | Configure the L3 Virtual Network Identifier for an IP VRF. |
PE7(config-vrf)#mac vrf L2VRF1 | Create a L2 MAC VRF to use in EVPN routes. |
PE7(config-vrf)# rd 7.7.7.7:11 | Specify a route distinguisher for the MAC VRF. |
PE7(config-vrf)# route-target both 7.7.7.7:100 | Add import and export route-target extended communities to the VRF. |
PE7(config-vrf)#mac vrf L2VRF2 | Create a L2 MAC VRF to use in EVPN routes. |
PE7(config-vrf)# rd 7.7.7.7:12 | Specify a route distinguisher for the VRF. |
PE7(config-vrf)# route-target both 7.7.7.7:101 | Add import and export route-target extended communities to the VRF |
PE7(config-vrf)#exit | Exit the VRF configuration mode. |
PE7(config)#evpn irb-forwarding anycast-gateway-mac 0000.0000.1111 | Configure common Anycast MAC address for all the IRB interfaces. |
PE7(config)#interface irb701 | Enter into IRB interface configuration mode to configure IRB interfaces for OSPF router. |
PE7(config-irb-if)# ip vrf forwarding L3VRF3 | Associate IRB interface with L3VRF3. |
PE7(config-irb-if)# evpn irb-if-forwarding anycast-gateway-mac | Map the global anycast IRB MAC address with L3VRF3. |
PE7(config-irb-if)# ip address 17.12.13.1/24 anycast | Configure an Anycast IP address. |
PE7(config-irb-if)# ip address 16.16.16.2/24 secondary | Configure a secondary IP address. |
PE7(config-irb-if)#exit | Exit from the IRB interface. |
PE7(config-irb-if)#interface irb801 | Enter into IRB interface configuration mode to configure IRB interfaces for ISIS router. |
PE7(config-irb-if)# ip vrf forwarding L3VRF4 | Associate IRB interface with L3VRF4. |
PE7(config-irb-if)# evpn irb-if-forwarding anycast-gateway-mac | Map the global anycast IRB MAC address with L3VRF4. |
PE7(config-irb-if)# ip address 12.13.14.2/24 anycast | Configure an Anycast IP address. |
PE7(config-irb-if)# ip address 13.1.1.2/24 secondary | Configure a secondary IP address. |
PE7(config-irb-if)# ip router isis 2 | Configure ISIS router on IRB interface. |
PE7(config-irb-if)#exit | Exit from the IRB interface. |
PE7(config)#nvo vxlan vtep-ip-global 7.7.7.7 | Configure the source VTEP IP address of the VxLAN tunnel. |
PE7(config)#nvo vxlan id 701 ingress-replication inner-vid-disabled | Add a tenant L2 VNID to the VxLAN. Specify • ingress-replication to use head end replication for forwarding BUM traffic • inner-vid-disabled to not carry VID out of network port. |
PE7(config-nvo)# vxlan host-reachability-protocol evpn-bgp L2VRF1 | Associate the L2VRF1reachable protocol to Ethernet-VPN over BGP |
PE7(config-nvo)# evpn irb701 | Configure default gateway behavior for IRB interface irb701. |
PE7(config-nvo)# vni-name VNI-701 | Configure VNI name. |
PE7(config-nvo)#exit | Exit from NVO mode. |
PE7(config-nvo)#nvo vxlan id 801 ingress-replication inner-vid-disabled | Add a tenant L2 VNID to the VxLAN. Specify • ingress-replication to use head end replication for forwarding BUM traffic • inner-vid-disabled to not carry VID out of network port |
PE7(config-nvo)# vxlan host-reachability-protocol evpn-bgp L2VRF2 | Associate the L2VRF2reachable protocol to Ethernet-VPN over BGP |
PE7(config-nvo)# evpn irb801 | Configure default gateway behavior for IRB interface irb801. |
PE7(config-nvo)# vni-name VNI-101 | Configure VNI name. |
PE7(config-nvo)#qos enable | Enable QoS. |
PE7(config-nvo)#exit | Exit from NVO mode. |
PE7(config)#interface po1 | Configure po1 interface. |
PE7(config-if)# switchport | Configure port as L2. |
PE7(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the po1 interface. |
PE7(config-if)# evpn multi-homed system-mac 0000.0000.7782 | Configure system MAC as ESI value for po1 interface. VTEP1 and VTEP2 should have same ESI value. |
PE7(config-if)#interface sa1 | Configure sa1 interface. |
PE7(config-if)# switchport | Configure port as L2. |
PE7(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the po1 interface. |
PE7(config-if)# evpn multi-homed esi 00:01:02:03:04:05:06:07:08 | Configure 9-octet ESI value for sa1 interface. |
PE7(config-if-es)#interface sa2 | Configure sa2 interface. |
PE7(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the sa2 interface. |
PE7(config-if)# ip address 80.1.1.1/24 | Configure IP address. |
PE7(config-if)# mtu 9000 | Configure the Maximum Transmission Unit (MTU). |
PE7(config-if)# ip router isis 1 | Configure ISIS router on sa2 interface. |
PE7(config-if)#exit | Exit from the sa2 interface. |
PE7(config)#interface sa3 | Configure sa3 interface. |
PE7(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the sa3 interface. |
PE7(config-if)# ip address 22.1.1.1/24 | Configure IP address. |
PE7(config-if)# mtu 9000 | Configure the Maximum Transmission Unit (MTU). |
PE7(config-if)#interface ce50 | Configure ce50 interface. |
PE7(config-if)# static-channel-group 1 | Configure member port for sa3 |
PE7(config-if)#exit | Exit from ce50 interface configuration mode. |
PE7(config)#interface lo | Configure loopback interface. |
PE7(config-if)# ip address 7.7.7.7/32 secondary | Configure secondary IP address |
PE7(config-if)#exit | Exit from the lo interface. |
PE7(config)#interface xe1 | Configure xe1 interface. |
PE7(config-if)# channel-group 1 mode active | Configure member port of po1 interface. |
PE7(config-if)#interface xe39 | Configure xe39 interface. |
PE7(config-if)# static-channel-group 3 | Configure member port of sa3 interface. |
PE7(config-if)#interface xe40 | Configure xe40 interface. |
PE7(config-if)# static-channel-group 2 | Configure member port of sa2 interface. |
PE7(config-if)#exit | Exit from the xe40 interface. |
PE7(config)#router ospf 1 | Configure OSPF router. |
PE7(config-router)# ospf router-id 7.7.7.7 | Configure router id for OSPF. |
PE7(config-router)# network 7.7.7.7/32 area 0.0.0.0 | Enable OSPF routing with area ID 0.0.0.0 on IRB interface with IP address that match the network address 7.7.7.7/32 |
PE7(config-router)# network 22.1.1.0/24 area 0.0.0.0 | Enable OSPF routing with area ID 0.0.0.0 on interface with IP address that match the network address 22.1.1.0/24 . |
PE7(config-router)#router ospf 2 L3VRF3 | Configure OSPF on IRB L3VRF3. |
PE7(config-router)# redistribute bgp | Redistribute BGP routes. |
PE7(config-router)# network 16.16.16.0/24 area 0.0.0.0 | Enable OSPF routing with area ID 0.0.0.0 on IRB interface with IP address that match the network address 16.16.16.0/24. |
PE7(config-router)#router isis 1 | Configure ISIS router. |
PE7(config-router)# is-type level-1-2 | Configure IS type as level 1 and level 2. |
PE7(config-router)# metric-style wide | Configure metric-style as wide. |
PE7(config-router)# dynamic-hostname | Configure the hostname to advertise for the ISIS router. |
PE7(config-router)# bfd all-interfaces | Enable the Bidirectional Forwarding Detection (BFD) feature on all the interfaces enabled with this ISIS instance. |
PE7(config-router)# net 49.0000.0007.0001.00 | Set a Network Entity Title for this instance, specifying the area address and the system ID. |
PE7(config-router)# redistribute connected | Redistribute connected routes. |
PE7(config-router)#router isis 2 L3VRF4 | Configure ISIS on IRB L3VRF4. |
PE7(config-router)# is-type level-1-2 | Configure IS type as level 1 and level 2. |
PE7(config-router)# metric-style wide | Configure metric-style as wide. |
PE7(config-router)# dynamic-hostname | Configure the hostname to advertise for the ISIS router. |
PE7(config-router)# bfd all-interfaces | Enable the Bidirectional Forwarding Detection (BFD) feature on all the interfaces enabled with this ISIS instance. |
PE7(config-router)# net 49.0000.0000.0475.00 | Set a Network Entity Title for this instance, specifying the area address and the system ID. |
PE7(config-router)# redistribute bgp | Redistribute connected routes. |
PE7(config-router)#router bgp 700 | Start the eBGP router. |
PE7(config-router)# bgp router-id 7.7.7.7 | Configure BGP router id. |
PE7(config-router)# no bgp inbound-route-filter | Disable the MPLS (Multiprotocol Label Switching) VPN/BGP inbound route-target filter. |
PE7(config-router)# neighbor 5.5.5.5 remote-as 500 | Configure BGP peering relationship with a customer edge router. |
PE7(config-router)# neighbor 6.6.6.6 remote-as 600 | Configure BGP peering relationship with a customer edge router. |
PE7(config-router)# neighbor 6.6.6.6 advertisement-interval 0 | Configure a minimum advertisement interval between the sending of BGP routing updates. |
PE7(config-router)# address-family l2vpn evpn | Enter to the L2 VPN address family mode to configure the address-family specific parameters. |
PE7(config-router-af)# neighbor 5.5.5.5 activate | Enable the exchange of specific address family routes with a neighboring router 5.5.5.5. |
PE7(config-router-af)# neighbor 6.6.6.6 activate | Enable the exchange of specific address family routes with a neighboring router 6.6.6.6. |
PE7(config-router-af)# exit-address-family | Exit from address family mode. |
PE7(config-router)# address-family ipv4 vrf L3VRF3 | Enter to the IRB IPv4 VRF address family mode to configure the address-family specific parameters. |
PE7(config-router-af)# network 16.16.16.0/24 | Enable OSPF routing on IRB interface with IP address that match the network address 16.16.16.0/24. |
PE7(config-router-af)# redistribute ospf | Redistribute OSPF routes. |
PE7(config-router-af)# exit-address-family | Exit from address family mode. |
PE7(config-router)# address-family ipv4 vrf L3VRF4 | Enter to the IRB IPv4 VRF address family mode to configure the address-family specific parameters. |
PE7(config-router-af)# network 12.1.1.0/24 | Enable OSPF routing on IRB interface with IP address that match the network address 12.1.1.0/24. |
PE7(config-router-af)# redistribute isis | Redistribute ISIS routes. |
PE7(config-router-af)# exit-address-family | Exit address family mode. |
PE7(config)#nvo vxlan access-if port-vlan po1 100 | Map the VLAN port for ISIS switch on po1 interface to identify the VxLAN traffic and to enter NVO access interface mode. |
PE7(config-nvo-acc-if)# map vnid 801 | Map the l2vnid to an access-port. |
PE7(config-nvo-acc-if)#nvo vxlan access-if port-vlan sa1 200 | Configure access-if port for OSPF switch. |
PE7(config-nvo-acc-if)# map vnid 701 | Map the l2vnid to an access-port. |
PE8(config)#nvo vxlan enable | Enable VxLAN |
PE8(config)#nvo vxlan irb | Enable VxLAN IRB |
PE8(config)#evpn esi hold-time 60 | Configure hold time for the tunnels to come up during VxLAN initialization before making the esi up. |
PE8(config)#evpn vxlan multihoming enable | Enable VxLAN multihome |
PE8(config)#ip vrf managemen | Enter into VRF configuration mode. |
PE8(config-vrf)#ip vrf L3VRF3 | Create a VRF routing information base called L3VRF3 for OSPF router. |
PE8(config-vrf)# rd 8100:11 | Specify a route distinguisher for the VRF. |
PE8(config-vrf)# route-target both 100:100 | Add import and export route-target extended communities to the VRF. |
PE8(config-vrf)# l3vni 1000 | Configure the L3 Virtual Network Identifier for an IP VRF. |
PE8(config-vrf)#ip vrf L3VRF4 | Create a VRF routing information base called L3VRF4 for ISIS router. |
PE8(config-vrf)# rd 8400:11 | Specify a route distinguisher for the VRF. |
PE8(config-vrf)# route-target both 101:101 | Add import and export route-target extended communities to the VRF. |
PE8(config-vrf)# l3vni 2000 | Configure the L3 Virtual Network Identifier for an IP VRF. |
PE8(config-vrf)#mac vrf L2VRF1 | Create a L2 MAC VRF to use in EVPN routes. |
PE8(config-vrf)# rd 8.8.8.8:11 | Specify a route distinguisher for the MAC VRF. |
PE8(config-vrf)# route-target both 7.7.7.7:100 | Add import and export route-target extended communities to the VRF. |
PE8(config-vrf)#mac vrf L2VRF2 | Create a L2 MAC VRF to use in EVPN routes. |
PE8(config-vrf)# rd 8.8.8.8:12 | Specify a route distinguisher for the VRF. |
PE8(config-vrf)# route-target both 7.7.7.7:101 | Add import and export route-target extended communities to the VRF. |
PE7(config-vrf)#exit | Exit the VRF configuration mode. |
PE8(config)#evpn irb-forwarding anycast-gateway-mac 0000.0000.1111 | Configure common Anycast MAC address for all the IRB interfaces. |
PE8(config-if)#interface irb701 | Enter into IRB interface configuration mode to configure IRB interfaces for OSPF router. |
PE8(config-irb-if)# ip vrf forwarding L3VRF3 | Associate IRB interface with L3VRF3. |
PE8(config-irb-if)# evpn irb-if-forwarding anycast-gateway-mac | Map the global anycast IRB MAC address with L3VRF3. |
PE8(config-irb-if)# ip address 17.12.13.1/24 anycast | Configure an Anycast IP address. |
PE8(config-irb-if)# ip address 17.17.17.2/24 secondary | Configure a secondary IP address. PE7(config-irb-if)#exit Exit from the IRB interface. |
PE8(config-irb-if)#interface irb801 | Enter into IRB interface configuration mode to configure IRB interfaces for ISIS router. |
PE8(config-irb-if)# ip vrf forwarding L3VRF4 | Associate IRB interface with L3VRF4. |
PE8(config-irb-if)# evpn irb-if-forwarding anycast-gateway-mac | Map the global anycast IRB MAC address with L3VRF4. |
PE8(config-irb-if)# ip address 12.13.14.2/24 anycast | Configure an Anycast IP address. |
PE8(config-irb-if)# ip address 12.1.1.2/24 secondary | Configure an Anycast IP address. |
PE8(config-irb-if)# ip router isis 2 | Configure ISIS router on IRB interface. |
PE7(config-irb-if)#exit | Exit from the IRB interface. |
PE8(config)#nvo vxlan vtep-ip-global 8.8.8.8 | Configure the source VTEP IP address of the VxLAN tunnel. |
PE8(config)#nvo vxlan id 701 ingress-replication inner-vid-disabled | Add a tenant L2 VNID to the VxLAN. Specify ingress-replication to use head end replication for forwarding BUM traffic inner-vid-disabled to not carry VID out of network port |
PE8(config-nvo)# vxlan host-reachability-protocol evpn-bgp L2VRF1 | Associate the L2VRF1reachable protocol to Ethernet-VPN over BGP |
PE8(config-nvo)# evpn irb701 | Configure default gateway behavior for IRB interface irb701. |
PE8(config-nvo)# vni-name VNI-701 | Configure VNI name. |
PE7(config-nvo)#exit | Exit from NVO mode. |
PE8(config-nvo)#nvo vxlan id 801 ingress-replication inner-vid-disabled | Add a tenant L2 VNID to the VxLAN. Specify ingress-replication to use head end replication for forwarding BUM traffic inner-vid-disabled to not carry VID out of network port |
PE8(config-nvo)# vxlan host-reachability-protocol evpn-bgp L2VRF2 | Associate the L2VRF2reachable protocol to Ethernet-VPN over BGP |
PE8(config-nvo)# evpn irb801 | Configure default gateway behavior for IRB interface irb801. |
PE8(config-nvo)# vni-name VNI-101 | Configure VNI name. |
PE8(config-nvo)#qos enable | Enable QoS. |
PE8(config-nvo)#exit | Exit from NVO mode. |
PE8(config-vlan)#interface po1 | Configure po1 interface. |
PE8(config-if)# switchport | Configure port as L2. |
PE8(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the po1 interface. |
PE8(config-if)# evpn multi-homed system-mac 0000.0000.7782 | Configure system MAC as ESI value for po1 interface. VTEP1 and VTEP2 should have same ESI value. |
PE8(config-if-es)#interface sa1 | Configure sa1 interface. |
PE8(config-if)# switchport | Configure port as L2. |
PE8(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the po1 interface. |
PE8(config-if)# evpn multi-homed esi 00:01:02:03:04:05:06:07:08 | Configure 9-octet ESI value for sa1 interface. |
PE8(config-irb-if)#interface lo | Configure loopback interface |
PE8(config-if)# ip address 8.8.8.8/32 secondary | Configure secondary IP address |
PE8(config-if)#exit | Exit from the lo interface. |
PE8(config)#interface xe1 | Configure xe1 interface. |
PE8(config-if)# static-channel-group 1 | Configure member port of sa3 interface. |
PE8(config-if)#interface xe2 | Configure xe2 interface. |
PE8(config-if)# ip address 90.1.1.1/24 | Configure IP address |
PE8(config-if)# mtu 9000 | Configure the Maximum Transmission Unit (MTU). |
PE8(config-if)# ip router isis 1 | Configure ISIS router on IRB interface. |
PE8(config-if)#exit | Exit from the lo interface. |
PE8(config)#interface xe12 | Configure xe1 interface. |
PE8(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the po1 interface. |
PE8(config-if)# ip address 21.1.1.1/24 | Configure IP address |
PE8(config-if)# mtu 9000 | Configure the Maximum Transmission Unit (MTU). |
PE8(config-if)#exit | Exit from the lo interface. |
PE8(config-if)#interface xe26 | Configure xe26 interface. |
PE8(config-if)# channel-group 1 mode active | Configure member port of xe26 interface. |
PE8(config)#router ospf 1 | Configure OSPF router. |
PE8(config-router)# ospf router-id 8.8.8.8 | Configure router id for OSPF. |
PE8(config-router)# network 8.8.8.8/32 area 0.0.0.0 | Enable OSPF routing with area ID 0.0.0.0 on IRB interface with IP address that match the network address 8.8.8.8/32. |
PE8(config-router)# network 21.1.1.0/24 area 0.0.0.0 | Enable OSPF routing with area ID 0.0.0.0 on IRB interface with IP address that match the network address 21.1.1.0/24. |
PE8(config-router)#router ospf 2 L3VRF3 | Configure OSPF on IRB L3VRF3. |
PE8(config-router)# redistribute bgp | Redistribute BGP routes. |
PE8(config-router)# network 17.17.17.0/24 area 0.0.0.0 | Enable OSPF routing with area ID 0.0.0.0 on IRB interface with IP address that match the network address 17.17.17.0/24 |
PE8(config-router)#router isis 1 | Configure ISIS router. |
PE8(config-router)# is-type level-1-2 | Configure IS type as level 1 and level 2. |
PE8(config-router)# metric-style wide | Configure metric-style as wide. |
PE8(config-router)# dynamic-hostname | Configure the hostname to advertise for the ISIS router. |
PE8(config-router)# bfd all-interfaces | Enable the Bidirectional Forwarding Detection (BFD) feature on all the interfaces enabled with this ISIS instance. |
PE8(config-router)# net 49.0000.0008.0001.00 | Set a Network Entity Title for this instance, specifying the area address and the system ID. |
PE8(config-router)# redistribute connected | Redistribute connected routes. |
PE8(config-router)#router isis 2 L3VRF4 | Configure ISIS on IRB L3VRF4. |
PE8(config-router)# is-type level-1-2 | Configure IS type as level 1 and level 2. |
PE8(config-router)# metric-style wide | Configure metric-style as wide. |
PE8(config-router)# dynamic-hostname | Configure the hostname to advertise for the ISIS router. |
PE8(config-router)# bfd all-interfaces | Enable the Bidirectional Forwarding Detection (BFD) feature on all the interfaces enabled with this ISIS instance. |
PE8(config-router)# net 49.0000.0000.0485.00 | Set a Network Entity Title for this instance, specifying the area address and the system ID. |
PE8(config-router)# redistribute bgp | Redistribute connected routes. |
PE8(config-router)#router bgp 800 | Start the eBGP router. |
PE8(config-router)# bgp router-id 8.8.8.8 | Configure BGP router id. |
PE8(config-router)# no bgp inbound-route-filter | Disable the MPLS (Multiprotocol Label Switching) VPN/BGP inbound route-target filter. |
PE8(config-router)# neighbor 5.5.5.5 remote-as 500 | Configure BGP peering relationship with a customer edge router. |
PE8(config-router)# neighbor 6.6.6.6 remote-as 600 | Configure BGP peering relationship with a customer edge router. |
PE8(config-router)# neighbor 6.6.6.6 update-source lo | Configure a minimum advertisement interval between the sending of BGP routing updates. |
PE8(config-router)# address-family l2vpn evpn | Enter to the L2 VPN address family mode to configure the address-family specific parameters. |
PE8(config-router-af)# neighbor 5.5.5.5 activate | Enable the exchange of specific address family routes with a neighboring router 5.5.5.5. |
PE8(config-router-af)# neighbor 6.6.6.6 activate | Enable the exchange of specific address family routes with a neighboring router 6.6.6.6. |
PE8(config-router-af)# exit-address-family | Exit from address family mode. |
PE8(config-router)# address-family ipv4 vrf L3VRF3 | Enter to the IRB IPv4 VRF address family mode to configure the address-family specific parameters. |
PE8(config-router-af)# network 16.16.16.0/24 | Enable OSPF routing on IRB interface with IP address that match the network address 16.16.16.0/24. |
PE8(config-router-af)# redistribute ospf | Redistribute OSPF routes. |
PE8(config-router-af)# exit-address-family | Exit from address family mode. |
PE8(config-router)# address-family ipv4 vrf L3VRF4 | Enter to the IRB IPv4 VRF address family mode to configure the address-family specific parameters. |
PE8(config-router-af)# network 12.1.1.0/24 | Enable OSPF routing on IRB interface with IP address that match the network address 12.1.1.0/24. |
PE8(config-router-af)# redistribute isis | Redistribute ISIS routes. |
PE8(config-router-af)# exit-address-family | Exit address family mode. |
PE8(config-router)# exit | Exit from router mode configuration. |
PE8(config)#nvo vxlan access-if port-vlan po1 100 | Map the VLAN port for ISIS switch on po1 interface to identify the VxLAN traffic and to enter NVO access interface mode. |
PE8(config-nvo-acc-if)# map vnid 801 | Map the l2vnid to an access-port. |
PE8(config-nvo-acc-if)#nvo vxlan access-if port-vlan sa1 200 | Configure access-if port for OSPF switch. |
PE8(config-nvo-acc-if)# map vnid 701 | Map the l2vnid to an access-port. |
PE8(config-nvo-acc-if)#end | End global configuration. |
PE5(config-if)#interface sa3 | Configure sa3 interface. |
PE5(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the sa3 interface. |
PE5(config-if)# ip address 22.1.1.2/24 | Configure IP address |
PE5(config-if)# mtu 9000 | Configure the Maximum Transmission Unit (MTU). |
PE5(config-if)#interface lo | Configure loopback interface |
PE5(config-if)# ip address 5.5.5.5/32 secondary | Configure secondary IP address. |
PE7(config-if)#exit | Exit from the lo interface. |
PE5(config-if)#interface xe8 | Configure xe8 interface. |
PE5(config-if)# static-channel-group 3 | Configure member port of sa3 interface. |
PE5(config-if)#interface xe12 | Configure xe12 interface. |
PE5(config-if)# ip address 21.1.1.2/24 | Configure IP address |
PE5(config-if)# mtu 9000 | Configure the Maximum Transmission Unit (MTU). |
PE5(config-if)#interface xe14 | Configure xe14 interface. |
PE5(config-if)# ip address 23.1.1.2/24 | Configure IP address |
PE5(config-if)# mtu 9000 | Configure the Maximum Transmission Unit (MTU). |
PE5(config-if)#interface xe25 | Configure xe25 interface. |
PE5(config-if)# ip address 24.1.1.2/24 | Configure IP address |
PE5(config-if)# mtu 9000 | Configure the Maximum Transmission Unit (MTU). |
PE5(config)#router ospf 1 | Configure OSPF router. |
PE5(config-router)# network 5.5.5.5/32 area 0.0.0.0 | Enable OSPF routing with area ID 0.0.0.0 on IRB interface with IP address that match the network address 5.5.5.5/32. |
PE5(config-router)# network 21.1.1.0/24 area 0.0.0.0 | Enable OSPF routing with area ID 0.0.0.0 on IRB interface with IP address that match the network address 21.1.1.0/24. |
PE5(config-router)# network 22.1.1.0/24 area 0.0.0.0 | Enable OSPF routing with area ID 0.0.0.0 on IRB interface with IP address that match the network address 22.1.1.0/24. |
PE5(config-router)# network 23.1.1.0/24 area 0.0.0.0 | Enable OSPF routing with area ID 0.0.0.0 on IRB interface with IP address that match the network address 23.1.1.0/24. |
PE5(config-router)# network 24.1.1.0/24 area 0.0.0.0 | Enable OSPF routing with area ID 0.0.0.0 on IRB interface with IP address that match the network address 24.1.1.0/24. |
PE5(config-router)#router bgp 500 | Start the eBGP router 500. |
PE5(config-router)# bgp router-id 5.5.5.5 | Configure BGP router id 5.5.5.5. |
PE5(config-router)# no bgp inbound-route-filter | Disable the MPLS (Multiprotocol Label Switching) VPN/BGP inbound route-target filter. |
PE5(config-router)# neighbor 3.3.3.3 remote-as 300 | Configure BGP 3.3.3.3 peering relationship with a customer edge router. |
PE5(config-router)# neighbor 4.4.4.4 remote-as 400 | Configure BGP 4.4.4.4 peering relationship with a customer edge router. |
PE5(config-router)# neighbor 7.7.7.7 remote-as 700 | Configure BGP 7.7.7.7 peering relationship with a customer edge router. |
PE5(config-router)# neighbor 8.8.8.8 remote-as 800 | Configure BGP 8.8.8.8 peering relationship with a customer edge router. |
PE5(config-router)# neighbor 3.3.3.3 update-source lo | Specifies that loopback interface (lo) is the source for the BGP 3.3.3.3 to establish the TCP connections. |
PE5(config-router)# neighbor 4.4.4.4 update-source lo | Specifies that loopback interface (lo) is the source for the BGP 4.4.4.4 to establish the TCP connections. |
PE5(config-router)# neighbor 7.7.7.7 update-source lo | Specifies that loopback interface (lo) is the source for the BGP 7.7.7.7 to establish the TCP connections. |
PE5(config-router)# neighbor 8.8.8.8 update-source lo | Specifies that loopback interface (lo) is the source for the BGP 8.8.8.8 to establish the TCP connections. |
PE5(config-router)# address-family l2vpn evpn | Enter to the L2 VPN address family mode to configure the address-family specific parameters. |
PE5(config-router-af)# neighbor 3.3.3.3 activate | Enable the exchange of specific address family routes with a neighboring router 3.3.3.3. |
PE5(config-router-af)# neighbor 4.4.4.4 activate | Enable the exchange of specific address family routes with a neighboring router 4.4.4.4. |
PE5(config-router-af)# neighbor 7.7.7.7 activate | Enable the exchange of specific address family routes with a neighboring router 7.7.7.7. |
PE5(config-router-af)# neighbor 8.8.8.8 activate | Enable the exchange of specific address family routes with a neighboring router 8.8.8.8. |
PE5(config-router-af)# exit-address-family | Exit address family configuration mode. |
PE5(config-router)# exit | Exit router configuration mode. |
PE5(config)#end | Exit global configuration mode. |
PE6(config-if)#interface sa2 | Configure sa2 interface. |
PE6(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the sa2 interface. |
PE6(config-if)# ip address 80.1.1.2/24 | Configure IP address. |
PE6(config-if)# mtu 9000 | Configure the Maximum Transmission Unit (MTU). |
PE6(config-if)# ip router isis 1 | Configure ISIS router on sa2 interface. |
PE6(config-if)#interface ce2 | Configure ce2 interface. |
PE6(config-if)# ip address 101.1.1.1/24 | Configure IP address |
PE6(config-if)# mtu 9000 | Configure the Maximum Transmission Unit (MTU). |
PE6(config-if)# ip router isis 1 | Configure ISIS router on sa2 interface. |
PE6(config-if)#interface lo | Configure loopback interface |
PE6(config-if)# ip address 6.6.6.6/32 secondary | Configure secondary IP address. |
PE6(config-if)# ip router isis 1 | Configure ISIS router on sa2 interface. |
PE6(config-if)#interface xe5 | Configure xe5 interface. |
PE6(config-if)# ip address 102.1.1.1/24 | Configure IP address |
PE6(config-if)# mtu 9000 | Configure the Maximum Transmission Unit (MTU). |
PE6(config-if)# ip router isis 1 | Configure ISIS router on xe5 interface. |
PE6(config-if)#interface xe9 | Configure xe9 interface. |
PE6(config-if)# static-channel-group 2 | Configure member port of sa2 interface. |
PE6(config-if)#interface xe24 | Configure xe24 interface. |
PE6(config-if)# ip address 90.1.1.2/24 | Configure IP address |
PE6(config-if)# mtu 9000 | Configure the Maximum Transmission Unit (MTU). |
PE6(config-if)# ip router isis 1 | Configure ISIS router on xe24 interface. |
PE6(config)#router isis 1 | Configure ISIS router on xe24 interface. |
PE6(config-router)# is-type level-1-2 | Configure IS type as level 1 and level 2. |
PE6(config-router)# metric-style wide | Configure metric-style as wide. |
PE6(config-router)# dynamic-hostname | Configure the hostname to advertise for the ISIS router. |
PE6(config-router)# bfd all-interfaces | Enable the Bidirectional Forwarding Detection (BFD) feature on all the interfaces enabled with this ISIS instance. |
PE6(config-router)# net 49.0000.0006.0001.00 | Set a Network Entity Title for this instance, specifying the area address and the system ID. |
PE6(config-router)#router bgp 600 | Start the eBGP router. |
PE6(config-router)# bgp router-id 6.6.6.6 | Configure BGP router id. |
PE6(config-router)# no bgp inbound-route-filter | Disable the MPLS (Multiprotocol Label Switching) VPN/BGP inbound route-target filter. |
PE6(config-router)# neighbor 3.3.3.3 remote-as 300 | Configure BGP peering relationship with a customer edge router. |
PE6(config-router)# neighbor 4.4.4.4 remote-as 400 | Configure BGP peering relationship with a customer edge router. |
PE6(config-router)# neighbor 7.7.7.7 remote-as 700 | Configure BGP peering relationship with a customer edge router. |
PE6(config-router)# neighbor 8.8.8.8 remote-as 800 | Configure BGP peering relationship with a customer edge router. |
PE6(config-router)# neighbor 3.3.3.3 update-source lo | Specifies that loopback interface (lo) is the source for the BGP 3.3.3.3 to establish the TCP connections |
PE6(config-router)# neighbor 4.4.4.4 update-source lo | Specifies that loopback interface (lo) is the source for the BGP 4.4.4.4 to establish the TCP connections |
PE6(config-router)# neighbor 7.7.7.7 update-source lo | Specifies that loopback interface (lo) is the source for the BGP 7.7.7.7 to establish the TCP connections |
PE6(config-router)# neighbor 8.8.8.8 update-source lo | Specifies that loopback interface (lo) is the source for the BGP 8.8.8.8 to establish the TCP connections |
PE6(config-router)# address-family l2vpn evpn | Enter to the L2 VPN address family mode to configure the address-family specific parameters. |
PE6(config-router-af)# neighbor 3.3.3.3 activate | Enable the exchange of specific address family routes with a neighboring router 3.3.3.3. |
PE6(config-router-af)# neighbor 4.4.4.4 activate | Enable the exchange of specific address family routes with a neighboring router 4.4.4.4. |
PE6(config-router-af)# neighbor 7.7.7.7 activate | Enable the exchange of specific address family routes with a neighboring router 7.7.7.7. |
PE6(config-router-af)# neighbor 8.8.8.8 activate | Enable the exchange of specific address family routes with a neighboring router 8.8.8.8. |
PE6(config-router-af)# exit-address-family | Exit address family configuration mode. |
PE6(config-router)# exit | Exit router configuration mode. |
PE6(config)#end | Exit global configuration mode. |
PE3(config)#nvo vxlan enable | Enable VxLAN. |
PE3(config)#nvo vxlan irb | Enable VxLAN IRB |
PE3(config)#ip vrf management | Enter into VRF configuration mode. |
PE3(config-vrf)#ip vrf L3VRF1 | Create a VRF routing information base called L3VRF3 for OSPF router. |
PE3(config-vrf)# rd 56000:11 | Specify a route distinguisher for the VRF. |
PE3(config-vrf)# route-target both 100:100 | Add import and export route-target extended communities to the VRF. |
PE3(config-vrf)# l3vni 1000 | Configure the L3 Virtual Network Identifier for an IP VRF. |
PE3(config-vrf)#mac vrf L2VRF1 | Create a L2 MAC VRF to use in EVPN routes. |
PE3(config-vrf)# rd 4.4.4.4:11 | Specify a route distinguisher for the MAC VRF. |
PE3(config-vrf)# route-target both 9.9.9.9:100 | Add import and export route-target extended communities to the VRF. |
PE3(config-if)#interface irb1001 | Enter into IRB interface configuration mode to configure IRB interfaces for OSPF router. |
PE3(config-irb-if)# ip vrf forwarding L3VRF1 | Associate IRB interface with L3VRF3. |
PE3(config-irb-if)# ip address 40.1.1.1/24 | Configure an Anycast IP address. |
PE3(config-irb-if)# ip ospf cost 1 | Specify the cost of the link-state metric in a router-LSA. |
PE3(config-vrf)#nvo vxlan vtep-ip-global 3.3.3.3 | Configure the source VTEP IP address of the VxLAN tunnel. |
PE3(config)#nvo vxlan id 102 ingress-replication | Add a tenant L2 VNID to the VxLAN. Specify ingress-replication to use head end replication for forwarding BUM traffic inner-vid-disabled to not carry VID out of network port |
PE3(config-nvo)# vxlan host-reachability-protocol evpn-bgp L2VRF1 | Associate the L2VRF1 reachable protocol to Ethernet-VPN over BGP |
PE3(config-nvo)# evpn irb1001 | Configure default gateway behavior for IRB interface irb1001. |
PE3(config-nvo)# vni-name VNI-102 | Configure VNI name. |
PE3(config-nvo)#nvo vxlan id 2002 ingress-replication | Add a tenant L2 VNID to the VxLAN. Specify ingress-replication to use head end replication for forwarding BUM traffic inner-vid-disabled to not carry VID out of network port |
PE3(config-nvo)# vxlan host-reachability-protocol evpn-bgp L2VRF1 | Associate the L2VRF1 reachable protocol to Ethernet-VPN over BGP |
PE3(config-nvo)# evpn irb2002 | Configure default gateway behavior for IRB interface irb72002. |
PE3(config-nvo)#qos enable | Enable QoS. |
PE3(config)#interface sa4 | Configure sa4 interface. |
PE3(config-if)# switchport | Configure port as L2. |
PE3(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the po1 interface. |
PE3(config)#nvo vxlan access-if port-vlan sa4 100 | Map the VLAN port for ISIS switch on sa4 interface to identify the VxLAN traffic and to enter NVO access interface mode. |
PE3(config-acc-if-evpn)#map vpn-id 102 | Map the l2vnid to an access-port. |
PE3(config-if)#interface ce3 | Configure ce3 interface. |
PE3(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the ce3 interface. |
PE3(config-if)# ip address 101.1.1.2/24 | Configure IP address. |
PE3(config-if)# mtu 9000 | Configure the Maximum Transmission Unit (MTU). |
PE3(config-if)# ip router isis 1 | Configure ISIS router on ce3 interface. |
PE3(config-irb-if)#interface lo | Configure loopback interface |
PE3(config-if)# ip address 3.3.3.3/32 secondary | Configure secondary IP address |
PE3(config-if)# ip router isis 1 | Configure ISIS router on ce3 interface. |
PE3(config-if)#interface xe10 | Configure xe10 interface. |
PE3(config-if)# static-channel-group 4 | Configure member port of ce3 interface. |
PE3(config-if)#interface xe14 | Configure xe14 interface. |
PE3(config-if)# speed 10g | Set the link speed of the xe14 interface. |
PE3(config-if)# ip address 23.1.1.1/24 | Configure IP address. |
PE3(config-if)# mtu 9000 | Configure the Maximum Transmission Unit (MTU). |
PE3(config)#router ospf 1 | Configure OSPF router. |
PE3(config-router)# ospf router-id 3.3.3.3 | Configure router id for OSPF. |
PE3(config-router)# network 3.3.3.3/32 area 0.0.0.0 | Enable OSPF routing with area ID 0.0.0.0 on IRB interface with IP address that match the network address 3.3.3.3/32. |
PE3(config-router)# network 23.1.1.0/24 area 0.0.0.0 | Enable OSPF routing with area ID 0.0.0.0 on IRB interface with IP address that match the network address 23.1.1.0/24. |
PE3(config-router)# network 101.1.1.0/24 area 0.0.0.0 | Enable OSPF routing with area ID 0.0.0.0 on IRB interface with IP address that match the network address 101.1.1.0/24. |
PE3(config-router)#router ospf 2 L3VRF1 | Configure OSPF on IRB L3VRF1. |
PE3(config-router)# redistribute bgp | Redistribute BGP into OSPF. |
PE3(config-router)# network 40.1.1.0/24 area 0.0.0.0 | Enable OSPF routing with area ID 0.0.0.0 on IRB interface with IP address that match the network address 40.1.1.0/24. |
PE3(config-router)#router isis 1 | Configure ISIS router on xe24 interface. |
PE3(config-router)# is-type level-1-2 | Configure IS type as level 1 and level 2. |
PE3(config-router)# metric-style wide | Configure metric-style as wide. |
PE3(config-router)# dynamic-hostname | Configure the hostname to advertise for the ISIS router. |
PE3(config-router)# bfd all-interfaces | Enable the Bidirectional Forwarding Detection (BFD) feature on all the interfaces enabled with this ISIS instance. |
PE3(config-router)# net 49.0000.0003.0001.00 | Set a Network Entity Title for this instance, specifying the area address and the system ID. |
PE3(config-router)# redistribute connected | Redistribute connected routes. |
PE3(config-router)#router bgp 300 | Start the eBGP router. |
PE3(config-router)# bgp router-id 3.3.3.3 | Configure BGP router id. |
PE3(config-router)# no bgp inbound-route-filter | Disable the MPLS (Multiprotocol Label Switching) VPN/BGP inbound route-target filter. |
PE3(config-router)# neighbor 5.5.5.5 remote-as 500 | Configure BGP peering relationship with a customer edge router. |
PE3(config-router)# neighbor 6.6.6.6 remote-as 600 | Configure BGP peering relationship with a customer edge router. |
PE3(config-router)# neighbor 5.5.5.5 update-source lo | Specifies that loopback interface (lo) is the source for the BGP 5.5.5.5 to establish the TCP connections |
PE3(config-router)# neighbor 6.6.6.6 advertisement-interval 0 | Configure a minimum advertisement interval between the sending of BGP routing updates. |
PE3(config-router)# address-family l2vpn evpn | Enter to the L2 VPN address family mode to configure the address-family specific parameters. |
PE3(config-router-af)# neighbor 5.5.5.5 activate | Enable the exchange of specific address family routes with a neighboring router 5.5.5.5. |
PE3(config-router-af)# neighbor 6.6.6.6 activate | Enable the exchange of specific address family routes with a neighboring router 6.6.6.6. |
PE3(config-router-af)# exit-address-family | Exit address family configuration mode. |
PE3(config-router)# address-family ipv4 vrf L3VRF1 | Enter to the IRB IPv4 VRF address family mode to configure the address-family specific parameters. |
PE3(config-router-af)# redistribute connected | Redistribute connected routes. |
PE3(config-router-af)# redistribute ospf | Redistribute OSPF routes. |
PE3(config-router-af)# exit-address-family | Exit address family configuration mode. |
PE3(config-router)# exit | Exit router configuration mode. |
PE3(config)#end | Exit global configuration mode. |
PE4(config)#nvo vxlan enable | Enable VxLAN. |
PE4(config)#nvo vxlan irb | Enable VxLAN IRB |
PE4(config)#ip vrf management | Enter into VRF configuration mode. |
PE4(config-vrf)#ip vrf L3VRF2 | reate a VRF routing information base called L3VRF2 for OSPF router. |
PE4(config-vrf)# rd 63000:11 | Specify a route distinguisher for the VRF. |
PE4(config-vrf)# route-target both 101:101 | dd import and export route-target extended communities to the VRF. |
PE4(config-vrf)# l3vni 2000 | Configure the L3 Virtual Network Identifier for an IP VRF. |
PE4(config-vrf)#mac vrf L2VRF2 | Create a L2 MAC VRF to use in EVPN routes. |
PE4(config-vrf)# rd 3.3.3.3:11 | Specify a route distinguisher for the MAC VRF. |
PE4(config-vrf)# route-target both 10.10.10.10:100 | Add import and export route-target extended communities to the VRF. |
PE4(config-if)#interface irb2001 | Enter into IRB interface configuration mode to configure IRB interfaces for OSPF router. |
PE4(config-irb-if)# ip vrf forwarding L3VRF2 | Associate IRB interface with L3VRF3. |
PE4(config-irb-if)# ip address 50.50.50.1/24 | Configure an Anycast IP address. |
PE4(config-irb-if)# ip router isis 2 | Configure ISIS router on IRB interface. |
PE4(config-vrf)#nvo vxlan vtep-ip-global 4.4.4.4 | Configure the source VTEP IP address of the VxLAN tunnel. |
PE4(config)#nvo vxlan id 201 ingress-replication | Add a tenant L2 VNID to the VxLAN. Specify ingress-replication to use head end replication for forwarding BUM traffic |
PE4(config-nvo)# vxlan host-reachability-protocol evpn-bgp L2VRF2 | Associate the L2VRF1 reachable protocol to Ethernet-VPN over BGP |
PE4(config-nvo)# evpn irb2001 | Configure default gateway behavior for IRB interface irb2001. |
PE4(config-nvo)# vni-name VNI-201 | Configure VNI name. |
PE4(config-nvo)#nvo vxlan id 3002 ingress-replication | Add a tenant L2 VNID to the VxLAN. Specify ingress-replication to use head end replication for forwarding BUM traffic. |
PE4(config-nvo)# vxlan host-reachability-protocol evpn-bgp L2VRF2 | Associate the L2VRF2 reachable protocol to Ethernet-VPN over BGP. |
PE4(config-nvo)# evpn irb3002 | Configure default gateway behavior for IRB interface irb3002. |
PE4(config-nvo)#nvo vxlan id 3003 ingress-replication | Add a tenant L2 VNID to the VxLAN. Specify ingress-replication to use head end replication for forwarding BUM traffic. |
PE4(config-nvo)#qos enable | Enable QoS. |
PE4(config-irb-if)#interface lo | Configure loopback interface |
PE4(config-if)# ip address 4.4.4.4/32 secondary | Configure secondary IP address |
PE4(config-if)# ip router isis 1 | Configure ISIS router on lo interface. |
PE4(config-if)#interface xe5 | Configure xe5 interface. |
PE4(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the xe5 interface. |
PE4(config-if)# ip address 102.1.1.2/24 | Configure IP address. |
PE4(config-if)# mtu 9000 | Configure the Maximum Transmission Unit (MTU). |
PE4(config-if)# ip router isis 1 | Configure ISIS router on ce3 interface. |
PE4(config-if)#interface xe25 | Configure xe25 interface. |
PE4(config-if)# ip address 24.1.1.1/24 | Configure IP address. |
PE4(config-if)# mtu 9000 | Configure the Maximum Transmission Unit (MTU). |
PE4(config-if)#interface xe26 | Configure xe26 interface. |
PE4(config-if)# switchport | Configure port as L2. |
PE4(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the xe26 interface. |
PE4(config)#nvo vxlan access-if port-vlan xe26 200 | Map the VLAN port for ISIS switch on xe26 interface to identify the VxLAN traffic and to enter NVO access interface mode. |
PE4(config-acc-if-evpn)# map vpn-id 201 | Map the l2vnid to an access-port. |
PE4(config-if)# exit | Exit the interface configuration mode. |
PE4(config)#router ospf 1 | Configure OSPF router. |
PE4(config-router)# network 4.4.4.4/32 area 0.0.0.0 | Enable OSPF routing with area ID 0.0.0.0 on IRB interface with IP address that match the network address 4.4.4.4/32. |
PE4(config-router)# network 24.1.1.0/24 area 0.0.0.0 | Enable OSPF routing with area ID 0.0.0.0 on IRB interface with IP address that match the network address 24.1.1.0/24. |
PE4(config-router)#router isis 1 | Configure ISIS router on xe24 interface. |
PE4(config-router)# is-type level-1-2 | Configure IS type as level 1 and level 2. |
PE4(config-router)# metric-style wide | Configure metric-style as wide. |
PE4(config-router)# dynamic-hostname | Configure the hostname to advertise for the ISIS router. |
PE4(config-router)# bfd all-interfaces | Enable the Bidirectional Forwarding Detection (BFD) feature on all the interfaces enabled with this ISIS instance. |
PE4(config-router)# net 49.0000.0004.0001.00 | Set a Network Entity Title for this instance, specifying the area address and the system ID. |
PE4(config-router)# redistribute connected | Redistribute connected routes. |
PE4(config-router)#! | |
PE4(config-router)#router isis 2 L3VRF2 | Configure ISIS on IRB L3VRF2. |
PE4(config-router)# is-type level-1-2 | Configure IS type as level 1 and level 2. |
PE4(config-router)# metric-style wide | Configure metric-style as wide. |
PE4(config-router)# dynamic-hostname | Configure the hostname to advertise for the ISIS router. |
PE4(config-router)# bfd all-interfaces | Enable the Bidirectional Forwarding Detection (BFD) feature on all the interfaces enabled with this ISIS instance. |
PE4(config-router)# net 49.0000.0000.0441.00 | Set a Network Entity Title for this instance, specifying the area address and the system ID. |
PE4(config-router)#router bgp 400 | Start the eBGP router. |
PE4(config-router)# bgp router-id 4.4.4.4 | Configure BGP router id. |
PE4(config-router)# no bgp inbound-route-filter | Disable the MPLS (Multiprotocol Label Switching) VPN/BGP inbound route-target filter. |
PE4(config-router)# neighbor 5.5.5.5 remote-as 500 | Configure BGP peering relationship with a customer edge router. |
PE4(config-router)# neighbor 6.6.6.6 remote-as 600 | Configure BGP peering relationship with a customer edge router. |
PE4(config-router)# neighbor 5.5.5.5 update-source lo | Specifies that loopback interface (lo) is the source for the BGP 5.5.5.5 to establish the TCP connections |
PE4(config-router)# neighbor 6.6.6.6 advertisement-interval 0 | Configure a minimum advertisement interval between the sending of BGP routing updates. |
PE4(config-router)# address-family l2vpn evpn | Enter to the L2 VPN address family mode to configure the address-family specific parameters. |
PE4(config-router-af)# neighbor 5.5.5.5 activate | Enable the exchange of specific address family routes with a neighboring router 5.5.5.5. |
PE4(config-router-af)# neighbor 6.6.6.6 activate | Enable the exchange of specific address family routes with a neighboring router 6.6.6.6. |
PE4(config-router-af)# exit-address-family | Exit address family configuration mode. |
PE4(config-router)# address-family ipv4 vrf L3VRF2 | Enter to the IRB IPv4 VRF address family mode to configure the address-family specific parameters. |
PE4(config-router-af)# redistribute connected | Redistribute connected routes. |
PE4(config-router-af)# exit-address-family | Exit address family configuration mode. |
PE4(config-router)# exit | Exit router configuration mode. |
PE4(config)#end | Exit global configuration mode. |
Acronym | Description |
ECMP | Equal-Cost Multipath |
EVPN | Ethernet Virtual Private Netwrok |
MPLS | Multiprotocol Label Switching |
VxLAN | Virtual Extensible LAN |
SR | Segment Routing |
IRB | Integrated Routing |
OSPF | Open Shortest Path First |
ISIS | Intermediate System to Intermediate System |
Multi Home VxLAN | This refers to a Virtual Extensible LAN (VxLAN) deployment where a Multi data center or network site is connected to a Multi external network (usually the internet) for connectivity. |
IRB | A networking feature that enables the integration of Layer 3 IP routing and Layer 2 MAC address bridging within the same interface, simplifying network management and resource utilization. |
OSPF | A dynamic and efficient link-state routing protocol used to determine the best path for data packets in an IP network. It is characterized by rapid convergence and adaptability, making it suitable for large and dynamic networks. |
ISIS | A routing protocol designed for scalability and stability in computer networks, commonly used in large Service Provider networks. It provides a robust framework for routing information exchange. |
Layer 3 Routing | Network routing operations at the Network Layer (Layer 3) of the OSI model, focusing on routing IP packets between different subnets or networks. |
Layer 2 Bridging | Network bridging operations at the Data Link Layer (Layer 2) of the OSI model, handling the forwarding of data frames based on MAC addresses within the same network segment. |
EVPN | Ethernet VPN, a technology that provides advanced and efficient methods for Layer 2 and Layer 3 services in Ethernet networks, often used in data centers and service provider environments. |