PE1#configure terminal | Enter configure mode |
PE1(config)#interface lo | Enter interface mode. |
PE1(config-if)#ip address 1.1.1.1/32 | Configure IP address for the loopback address |
PE1(config-if)#exit | Exit interface mode |
PE1(config)#interface xe6 | Specify the interface (xe6)to be configured |
PE1(config-if)#ip address 10.10.10.1/24 | Configure IP address for the interface |
PE1(config-if)#no shutdown | Administratively bringing up the interface |
PE1(config-if)#exit | Exit interface mode |
PE1(config)#router ospf 100 | Configure the routing process and specify the Process ID (100) |
PE1(config-router)#network 10.10.10.0/ 24 area 0 PE1(config-router)#network 1.1.1.1/32 area 0 | Define the interface on which OSPF runs and associate the area ID(0)with the interface |
PE1(config-router)#exit | Exit configure mode |
PE1(config)#router ldp | Enter router mode for LDP |
PE1(config-router)#exit | Exit router mode for LDP |
PE1(config)#interface xe6 | Specify the interface (xe6)to be configured |
PE1(config-if)#label-switching | Enabling label switching capability on router |
PE1(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
PE1(config-if)#exit | Exit interface mode |
PE1(config)#exit | Exit configure mode |
P#configure terminal | Enter configure mode. |
P(config)#interface lo | Enter interface mode. |
P(config-if)#ip address 2.2.2.2/32 | Configure IP address for the loopback address |
P(config-if)#exit | Exit interface mode |
P(config)#interface xe6 | Specify the interface (xe6)to be configured |
P(config-if)#ip address 10.10.10.2/24 | Configure IP address for the interface |
P(config-if)#no shutdown | Administratively bringing up the interface |
P(config)#interface xe1 | Specify the interface (xe1)to be configured |
P(config-if)#ip address 20.20.20.1/24 | Configure IP address for the interface |
P(config)#router ospf 100 | Configure the routing process and specify the Process ID (100) |
P(config-router)#network 10.10.10.0/24 area 0 P(config-router)#network 20.20.20.0/24 area 0 P(config-router)#network 2.2.2.2/32 area 0 | Define the interface on which OSPF runs and associate the area ID (0)with the interface |
P(config-router)#exit | Exit router mode |
P(config)#router ldp | Enter router mode for LDP |
P(config-router)#exit | Exit router mode for LDP |
P(config)#mpls min-label-value 1000 max-label-value 50000 label-space 0 | Configure the minimum label value and maximum label value to be used by Platform label space (Label space 0) |
P(config)#interface xe6 | Specify the interface (xe6)to be configured |
P(config-if)#label-switching | Enabling label switching capability on router |
P(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
P(config-if)#exit | Exit interface mode |
P(config)#interface xe1 | Specify the interface (xe1)to be configured |
P(config-if)#label-switching | Enabling label switching capability on router |
P(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
P(config-if)#exit | Exit interface mode |
P(config)#exit | Exit configure mode |
PE2#configure terminal | Enter configure mode. |
PE2(config)#interface lo | Enter interface mode. |
PE2(config-if)#ip address 3.3.3.3/32 | Configure IP address for the loopback address |
PE2(config-if)#exit | Exit interface mode |
PE2(config)#interface xe1 | Specify the interface (xe1)to be configured |
PE2(config-if)#ip address 20.20.20.2/24 | Configure IP address for the interface |
PE2(config-if)#no shutdown | Administratively bringing up the interface |
PE2(config-if)#exit | Exit interface mode |
PE2(config)#router ospf 100 | Configure the routing process and specify the Process ID (100) |
PE2(config-router)#network 20.20.20.0/24 area 0 PE2(config-router)#network 3.3.3.3/32 area 0 | Define the interface on which OSPF runs and associate the area ID (0)with the interface |
PE2(config-router)#exit | Exit router mode |
PE2(config)#router ldp | Enter router mode for LDP |
PE2(config-router)#exit | Exit router mode for LDP |
PE2(config)#interface xe1 | Specify the interface (xe1)to be configured |
PE2(config-if)#label-switching | Enabling label switching capability on router |
PE2(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
PE2(config-if)#exit | Exit interface mode |
PE1#configure terminal | Enter configure mode |
PE1(config)#interface lo | Enter interface mode. |
PE1(config-if)#ip address 1.1.1.1/32 | Configure IP address for the loopback address |
PE1(config-if)#exit | Exit interface mode |
PE1(config)#interface xe6 | Specify the interface (xe6)to be configured |
PE1(config-if)#ip address 10.10.10.1/24 | Configure IP address for the interface |
PE1(config-if)#no shutdown | Administratively bringing up the interface |
PE1(config-if)#exit | Exit interface mode |
PE1(config)#router ospf 100 | Configure the routing process and specify the Process ID (100) |
PE1(config-router)#network 10.10.10.0/ 24 area 0 PE1(config-router)#network 1.1.1.1/32 area 0 | Define the interface on which OSPF runs and associate the area ID(0)with the interface |
PE1(config-router)#exit | Exit configure mode |
PE1(config)#router ldp | Enter router mode for LDP |
PE1(config-router)#exit | Exit router mode for LDP |
PE1(config)#mpls min-label-value 60000 max-label-value 80000 label-space 1 | Configure the minimum label value and maximum label value to be used by interface label space (Label space 1 in this case) |
PE1(config)#interface xe6 | Specify the interface (xe6)to be configured |
PE1(config-if)#label-switching | Enabling label switching capability on router |
PE1(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
PE1(config-if)#exit | Exit interface mode |
PE1(config)#exit | Exit configure mode |
P#configure terminal | Enter configure mode. |
P(config)#interface lo | Enter interface mode. |
P(config-if)#ip address 2.2.2.2/32 | Configure IP address for the loopback address |
P(config-if)#exit | Exit interface mode |
P(config)#interface xe6 | Specify the interface (xe6)to be configured |
P(config-if)#ip address 10.10.10.2/24 | Configure IP address for the interface |
P(config-if)#no shutdown | Administratively bringing up the interface |
P(config)#interface xe1 | Specify the interface (xe1)to be configured |
P(config-if)#ip address 20.20.20.1/24 | Configure IP address for the interface |
P(config)#router ospf 100 | Configure the routing process and specify the Process ID (100) |
P(config-router)#network 10.10.10.0/24 area 0 P(config-router)#network 20.20.20.0/24 area 0 P(config-router)#network 2.2.2.2/32 area 0 | Define the interface on which OSPF runs and associate the area ID (0)with the interface |
P(config-router)#exit | Exit router mode |
P(config)#router ldp | Enter router mode for LDP |
P(config-router)#exit | Exit router mode for LDP |
P(config)#mpls min-label-value 60000 max-label-value 80000 label-space 1 | Configure the minimum label value and maximum label value to be used by Interface label space (Label space 1) |
P(config)#interface xe6 | Specify the interface (xe6)to be configured |
P(config-if)#label-switching 1 | Enabling label switching capability on router |
P(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
P(config)#interface xe1 | Specify the interface (xe1)to be configured |
P(config-if)#label-switching 1 | Enabling label switching capability on router |
P(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
P(config-if)#exit | Exit interface mode |
P(config)#exit | Exit configure mode |
PE2#configure terminal | Enter configure mode. |
PE2(config)#interface lo | Enter interface mode. |
PE2(config-if)#ip address 3.3.3.3/32 | Configure IP address for the loopback address |
PE2(config-if)#exit | Exit interface mode |
PE2(config)#interface xe1 | Specify the interface (xe1)to be configured |
PE2(config-if)#ip address 20.20.20.2/24 | Configure IP address for the interface |
PE2(config-if)#no shutdown | Administratively bringing up the interface |
PE2(config-if)#exit | Exit interface mode |
PE2(config)#router ospf 100 | Configure the routing process and specify the Process ID (100) |
PE2(config-router)#network 20.20.20.0/24 area 0 PE2(config-router)#network 3.3.3.3/32 area 0 | Define the interface on which OSPF runs and associate the area ID (0)with the interface |
PE2(config-router)#exit | Exit router mode |
PE2(config)#router ldp | Enter router mode for LDP |
PE2(config-router)#exit | Exit router mode for LDP |
PE2(config)#mpls min-label-value 60000 max-label-value 80000 label-space 1 | Configure the minimum label value and maximum label value to be used by interface label space (Label space 1) |
PE2(config)#interface xe1 | Specify the interface (xe1)to be configured |
PE2(config-if)#label-switching | Enabling label switching capability on router |
PE2(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
PE2(config-if)#exit | Exit interface mode |