#configure terminal | Enter configure mode. |
(config)#interface eth2 | Specify the interface (eth2) to be configured. |
(config-if)#ip address 10.10.23.63/24 | Configure IP address for the interface |
(config-if)#label-switching | Enable label switching on interface eth2. |
(config-if)#exit | Exit interface mode. |
(config)#interface lo | Specify the loopback (lo) interface to be configured. |
(config-if)#ip address 192.168.0.63/32 secondary | Set the IP address of the loopback interface to 192.168.0.63/32 |
(config-if)#exit | Exit interface mode. |
(config)#qos enable | Enable QoS |
(config)#qos statistics | Enable QoS statistics |
#configure terminal | Enter configure mode. |
(config)#router ospf 100 | Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process. |
(config-router)#network 10.10.23.0/24 area 0 (config-router)#network 192.168.0.63/32 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface. |
(config-router)#exit | Exit from router mode |
#configure terminal | Enter configure mode. |
(config)#router rsvp | Enter Configure Router mode. |
(config-router)#elsp-signal-map class 1 exp 0 | Enabling ELSP |
(config-router)#exit | Exit Router Mode |
(config)#interface eth2 | Enter interface mode. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#rsvp-trunk T1 | Create an RSVP trunk T1 and enter the Trunk mode. |
(config-trunk)# map-route 90.90.90.0/24 | Specify the destination prefix that needs to mapped to this trunk |
(config-trunk)#to 192.168.0.90 | Specify the IPv4 egress (destination point) for the LSP. |
(config-trunk)#primary llsp class | Enable LLSP-Signaling for this trunk |
config)#dste enable | Enable DSTE |
(config)#mpls class-type ct0 def | Configure class-type ct0 with name default |
(config)#mpls class-type ct1 voice | Configure class-type ct1 with name voice |
(config)#mpls te-class te1 voice 6 | Configure te-class te1 with name voice |
(config-trunk)#primary setup-priority 6 | Setup priority value for a trunk |
(config-trunk)#primary hold-priority 6 | Configure hold priority value for the selected trunk |
(config-trunk)# primary class-type voice | Configure a primary Class-Type |
#configure terminal | Enter configure mode. |
(config)#interface eth2 | Specify the interface (eth2) to be configured. |
(config-if)#ip address 10.10.23.60/24 | Configure IP address for the interface |
(config-if)#label-switching | Enable label switching on interface eth2. |
(config-if)#exit | Exit interface mode. |
(config)#interface eth1 | Specify the interface (eth1) to be configured. |
(config-if)#ip address 10.10.21.60/24 | Configure IP address for the interface |
(config-if)#label-switching | Enable label switching on interface eth1. |
(config-if)#exit | Exit interface mode. |
(config)#interface lo | Specify the loopback (lo) interface to be configured. |
(config-if)#ip address 192.168.0.60/32 secondary | Set the IP address of the loopback interface to 192.168.0.60/32 |
(config-if)#exit | Exit interface mode. |
(config)#qos enable | Enable QoS |
(config)#qos statistics | Enable QoS statistics |
#configure terminal | Enter configure mode. |
(config)#router rsvp | Enter Configure Router mode. |
(config-router)#elsp-signal-map class 1 exp 0 | Enabling ELSP |
(config-router)#exit | Exit Router mode. |
(config)#interface eth2 | Enter interface mode. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface eth1 | Enter interface mode. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
#configure terminal | Enter configure mode. |
(config)#router ospf 100 | Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process. |
(config-router)#network 10.10.23.0/24 area 0 (config-router)#network 192.168.0.63/32 area 0 (config-router)#network 10.10.21.0/24 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface. |
(config-router)#exit | Exit from router mode |
config)#dste enable | Enable DSTE |
(config)#mpls class-type ct0 def | Configure class-type ct0 with name default |
(config)#mpls class-type ct1 voice | Configure class-type ct1 with name voice |
(config)#mpls te-class te1 voice 6 | Configure te-class te1 with name voice |
(config-trunk)#primary setup-priority 6 | Setup priority value for a trunk |
(config-trunk)#primary hold-priority 6 | Configure hold priority value for the selected trunk |
(config-trunk)# primary class-type voice | Configure a primary Class-Type |
#configure terminal | Enter configure mode. |
(config)#interface eth2 | Specify the interface (eth2) to be configured. |
(config-if)#ip address 10.10.21.90/24 | Configure IP address for the interface |
(config-if)#label-switching | Enable label switching on interface eth2. |
(config-if)#exit | Exit interface mode. |
(config)#interface lo | Specify the loopback (lo) interface to be configured. |
(config-if)#ip address 192.168.0.90/32 secondary | Set the IP address of the loopback interface to 192.168.0.90/32 |
(config-if)#exit | Exit interface mode. |
(config)#qos enable | Enable QoS |
(config)#qos statistics | Enable QoS statistics |
#configure terminal | Enter configure mode. |
(config)#router rsvp | Enter Configure Router mode. |
(config-router)#elsp-signal-map class 1 exp 0 | Enabling ELSP |
(config-router)#exit | Exit Router mode. |
(config)#interface eth2 | Enter interface mode. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
#configure terminal | Enter configure mode. |
(config)#router ospf 100 | Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process. |
(config-router)#network 192.168.0.90/32 area 0 (config-router)#network 10.10.21.0/24 area 0 | Define the interface on which OSPF runs and associate the area ID (0) with the interface. |
(config-router)#exit | Exit from router mode |
config)#dste enable | Enable DSTE |
(config)#mpls class-type ct0 def | Configure class-type ct0 with name default |
(config)#mpls class-type ct1 voice | Configure class-type ct1 with name voice |
(config)#mpls te-class te1 voice 6 | Configure te-class te1 with name voice |
(config-trunk)#primary setup-priority 6 | Setup priority value for a trunk |
(config-trunk)#primary hold-priority 6 | Configure hold priority value for the selected trunk |
(config-trunk)# primary class-type voice | Configure a primary Class-Type |