OcNOS-DC : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : Virtual Private LAN Service Configuration
Virtual Private LAN Service Configuration
This chapter contains configurations for Virtual Private LAN Service (VPLS).
VPLS Raw Mode
The examples show the minimum configuration required for enabling a VPLS Mesh peer between PE-1, PE-2, and PE-3 in raw mode.
VPLS Mesh Peers Raw Mode
Configuration
PE-1
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 1.1.1.1/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface eth1
Specify the Interface (eth1) to be configured.
(config-if)#ip address 10.10.1.1/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively brining up the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
(config-router)#network 10.1.1.0/24 area 0
(config-router)#network 1.1.1.1/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address.
(config-router)#exit
Exit router mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)#targeted-peer ipv4 2.2.2.2
Configuring targeted LDP sessions to PE-2
(config-router-targeted-peer)#exi
Exit config-router-targeted-peer mode
(config-router)#targeted-peer ipv4 3.3.3.3
Enter targeted-peer-mode and PE-3
(config-router-targeted-peer)#exit
Exit config-router-targeted-peer mode
(config-router)#exit
Exit router configuration mode.
(config)#interface eth1
Enter interface mode.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)#mpls vpls VPLS1 100
Configuring VPLS instance with name and VPLS ID.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance.
(config-vpls-sig)#vpls-peer 2.2.2.2
(config-vpls-sig)#vpls-peer 3.3.3.3
Configuring VPLS mesh peers.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#service-template st1
Template configuration
(config-svc)# exit
Exit service template mode
(config)#interface eth2
Specify the attachment circuit interface.
(config-if)#switchport
Configuring the attachment circuit interface as Layer-2.
(config-if)mpls-vpls VPLS1 service-template st1
Associating the VPLS Instance to the attachment circuit interface.
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)exit
Exit interface mode.
(config)#exit
Exit configure mode.
#copy running-config startup-config
Save the configuration.
P
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 9.9.9.9/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface eth1
Specify the interface to be configured.
(config-if)#ip address 10.10.1.2/24
Configure IP address for the interface.
(config-if)#exit
Exit interface mode.
(config)#interface eth2
Enter interface mode.
(config-if)#ip address 20.20.1.2/24
Configure IP address for the interface.
(config-if)#exit
Exit interface mode.
(config)#interface eth3
Enter interface mode.
(config-if)#ip address 30.30.1.2/24
Configure IP address for the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
(config-router)#network 10.1.1.0/24 area 0
(config-router)#network 20.20.1.0/24 area 0
(config-router)#network 30.30.1.0/24 area 0
(config-router)#network 9.9.9.9/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the Interface address.
(config-router)#exit
Exit router mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)#exit
Exit router mode.
(config)#interface eth1
Enter interface mode.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(congig-if)#exit
Exit interface configuration mode.
(config)#interface eth2
Specify the interface to be configured.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(congig-if)#exit
Exit interface mode.
(config)#interface eth3
Enter interface mode.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(congig-if)#exit
Exit interface mode.
(config)#exit
Exit configure mode.
#copy running-config startup-config
Save the configuration.
PE-2
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 2.2.2.2/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface eth1
Specify the Interface (eth1) to be configured.
(config-if)#ip address 20.20.1.1/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively brining up the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
(config-router)#network 20.20.1.0/24 area 0
(config-router)#network 2.2.2.2/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address.
(config-router)#exit
Exit router mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)#targeted-peer ipv4 1.1.1.1
 
Configuring targeted LDP sessions to PE-2.
(config-router-targeted-peer)#exit
 
Exit targeted-peer-mode
(config-router)#targeted-peer ipv4 3.3.3.3
Configuring targeted LDP sessions to PE-3
(config-router-targeted-peer)#exit
 
Exit targeted-peer-mode
(config-router)#exit
Exit router configuration mode.
(config)#interface eth1
Enter interface mode.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)#mpls vpls VPLS1 100
Configuring VPLS instance with name and VPLS ID.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance.
(config-vpls-sig)#vpls-peer 1.1.1.1
(config-vpls-sig)#vpls-peer 3.3.3.3
Configuring VPLS mesh peers.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#service-template st1
Template configuration.
(config-svc)# exit
Exit service template mode.
(config)#interface eth2
Specify the attachment circuit interface.
(config-if)#switchport
Configuring the attachment circuit interface as Layer-2.
(config-if)mpls-vpls VPLS1 service-template st1
Associating the VPLS Instance to the attachment circuit interface.
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)exit
Exit interface mode.
(config)#exit
Exit configure mode.
#copy running-config startup-config
Save the configuration.
PE-3
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 3.3.3.3/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface eth1
Specify the Interface (eth1) to be configured.
(config-if)#ip address 30.30.1.1/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively brining up the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
(config-router)#network 30.30.1.0/24 area 0
(config-router)#network 3.3.3.3/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address.
(config-router)#exit
Exit router mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)#targeted-peer ipv4 1.1.1.1
Configuring targeted LDP sessions to PE-2
(config-router-targeted-peer)#exit
Exit targeted-peer-mode
(config-router)#targeted-peer ipv4 2.2.2.2
Configuring targeted LDP sessions to PE-3
(config-router-targeted-peer)#exit
Exit targeted-peer-mode
(config-router)#exit
Exit router configuration mode.
(config)#interface eth1
Enter interface mode.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)#mpls vpls VPLS1 100
Configuring VPLS instance with name and VPLS ID.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance.
(config-vpls-sig)#vpls-peer 1.1.1.1
(config-vpls-sig)#vpls-peer 2.2.2.2
Configuring VPLS mesh peers.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#service-template st1
Template configuration.
(config-svc)# exit
Exit service template mode.
(config)#interface eth2
Specify the attachment circuit interface.
(config-if)#switchport
Configuring the attachment circuit interface as Layer-2.
(config-if)mpls-vpls VPLS1 service-template st1
Associating the VPLS Instance to the attachment circuit interface.
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)exit
Exit interface mode.
(config)#exit
Exit configure mode.
#copy running-config startup-config
Save the configuration.
Validation
PE-1
Verify VPLS Session
PE1#show mpls vpls detail
Virtual Private LAN Service Instance: VPLS1, ID: 100
SIG-Protocol: LDP
Attachment-Circuit :UP
Learning: Enabled
Group ID: 0, VPLS Type: Ethernet, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Raw
Configured interfaces:
Interface: xe17
Service-template : s1
Match criteria : Accept all
 
Mesh Peers:
2.2.2.2 (Up)
3.3.3.3 (Up)
 
PE1#
 
Verify VPLS Mesh Peer
PE1#sh mpls vpls mesh
 
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status Ecmp-Group100 1.1.1.1 301 4000 eth6 3000 2/Up 1 STATIC Active N/A100 2.2.2.2 302 4500 eth6 3500 2/Up 2 STATIC Active N/A
 
VPLS Tagged Mode
The examples show the minimum configuration required for enabling a VPLS Mesh peer between PE-1, PE-2, and PE-3 in Tagged Mode. In the below example PE-1 and PE-2 uses VLAN 10 for binding the VPLS instance to the attachment circuit and PE-3 used VLAN 20 where it shows that VLAN swapping is supported.
 
VPLS Mesh Peers Tagged Mode
Configuration
PE-1
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 1.1.1.1/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface eth1
Specify the Interface (eth1) to be configured.
(config-if)#ip address 10.10.1.1/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively brining up the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
(config-router)#network 10.1.1.0/24 area 0
(config-router)#network 1.1.1.1/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address.
(config-router)#exit
Exit router mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)#targeted-peer ipv4 2.2.2.2
Configuring targeted LDP sessions to PE-2
(config-router-targeted-peer)#exit
Exit targeted peer mode
(config-router-targeted-peer)#targeted-peer ipv4 3.3.3.3
 
Configuring targeted LDP sessions to PE-3
(config-router-targeted-peer)#exit
Exit targeted peer mode
(config-router)#exit
Exit router configuration mode
(config)#interface eth1
Enter interface mode
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)#mpls vpls VPLS1 100
Configuring VPLS instance with name and VPLS ID.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance.
(config-vpls-sig)#vpls-type vlan
Configuring VPLS type as VLAN mode.
(config-vpls-sig)#vpls-peer 2.2.2.2
(config-vpls-sig)#vpls-peer 3.3.3.3
Configuring VPLS mesh peers.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#mpls vpls v4 28
Enter VPLS config mode
(config-vpls)#signaling ldp
Define Signaling as LDP
(config-vpls-sig)#vpls-type vlan
Type VLAN configuration for VPLS
(config-vpls-sig)#vpls-peer 2.2.2.2
Configure VPLS Peers
config-vpls-sig)#vpls-peer 3.3.3.3
Configure VPLS Peers
(config-vpls-sig)# exit-signaling
Exit Signaling LDP mode
(config-vpls)#exit
Exit VPLS mode
(config)#service-template st1
Template configuration.
(config-svc)# match outer-vlan 10
Match criteria under template configuration
(config-svc)# exit
Exit service template mode.
(config)#interface eth2
Specify the attachment circuit interface.
(config-if)#switchport
Configuring the attachment circuit interface as Layer-2.
(config-if)mpls-vpls VPLS1 service-template st1
Associating the VPLS Instance to the attachment circuit interface to match service template st1.
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)exit
Exit interface mode.
(config)#exit
Exit configure mode.
#copy running-config startup-config
Save the configuration.
service-template with multiple match support
This is to validate the multiple match criteria support in a service template. When multiple match statements are configured only rewrite push is supported, rewrite translate and pop are not supported.
 
(config)#service-template template4
Template configuration
(config-svc)# match outer-vlan 700
Allow VLAN 700 traffic on this VC
(config-svc)# match double-tag outer-vlan 1200 inner-vlan 3200
Allow double tag match with s+c tags
(config-svc)# match untagged
Allow untagged traffic
(config-svc)# rewrite ingress push 300
Push Action performed for service template
(config-svc)#exit
Exit configure SVC mode
(config)#interface eth2
Specify the attachment circuit interface.
(config-if)#switchport
Configuring the attachment circuit interface as Layer-2.
(config-if)mpls-vpls v4 service-template template4
Associating the VPLS Instance to the attachment circuit interface.
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
P
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 9.9.9.9/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface eth1
Specify the interface to be configured.
(config-if)#ip address 10.10.1.2/24
Configure IP address for the interface.
(config-if)#exit
Exit interface mode.
(config)#interface eth2
Enter interface mode.
(config-if)#ip address 20.20.1.2/24
Configure IP address for the interface.
(config-if)#exit
Exit interface mode.
(config)#interface eth3
Enter interface mode.
(config-if)#ip address 30.30.1.2/24
Configure IP address for the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
(config-router)#network 10.1.1.0/24 area 0
(config-router)#network 20.20.1.0/24 area 0
(config-router)#network 30.30.1.0/24 area 0
(config-router)#network 9.9.9.9/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the Interface address.
(config-router)#exit
Exit router mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)#exit
Exit router mode.
(config)#interface eth1
Enter interface mode.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(congig-if)#exit
Exit interface configuration mode.
(config)#interface eth2
Specify the interface to be configured.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(congig-if)#exit
Exit interface mode.
(config)#interface eth3
Enter interface mode.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(congig-if)#exit
Exit interface mode.
(config)#exit
Exit configure mode.
#copy running-config startup-config
Save the configuration.
PE-2
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 2.2.2.2/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface eth1
Specify the Interface (eth1) to be configured.
(config-if)#ip address 20.20.1.1/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively brining up the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
(config-router)#network 20.20.1.0/24 area 0
(config-router)#network 2.2.2.2/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address.
(config-router)#exit
Exit router mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)#targeted-peer ipv4 1.1.1.1
Configuring targeted LDP sessions to PE-2
(config-router-targeted-peer)#exit
Exit targeted peer mode
(config-router-targeted-peer)#targeted-peer ipv4 3.3.3.3
Configuring targeted LDP sessions to PE-3
(config-router-targeted-peer)#exit
Exit targeted peer mode
(config-router-targeted-peer)#exit-targeted-peer-mode
Exit targeted peer mode.
(config-router)#exit
Exit router configuration mode.
(config)#interface eth1
Enter interface mode.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)#mpls vpls VPLS1 100
Configuring VPLS instance with name and VPLS ID.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance.
(config-vpls-sig)#vpls-type vlan
Configuring VPLS type as VLAN mode.
(config-vpls-sig)#vpls-peer 1.1.1.1
(config-vpls-sig)#vpls-peer 3.3.3.3
Configuring VPLS mesh peers.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#mpls vpls v4 28
Enter VPLS config mode
(config-vpls)#signaling ldp
Define Signaling as LDP
(config-vpls-sig)#vpls-type vlan
Type VLAN configuration for VPLS
(config-vpls-sig)#vpls-peer 1.1.1.1
Configure VPLS Peers
config-vpls-sig)#vpls-peer 3.3.33
Configure VPLS Peers
(config-vpls-sig)# exit-signaling
Exit Signaling LDP mode
(config-vpls)#exit
Exit VPLS mode
(config)#service-template st1
Template configuration.
(config-svc)#match outer-vlan 10
Match criteria under template configuration
(config-svc)#exit
Exit service template mode.
(config)#service-template template4
Template configuration
(config-svc)#match outer-vlan 700
Allow VLAN 700 traffic on this VC
(config-svc)#match double-tag outer-vlan 1200 inner-vlan 3200
Allow double tag match with s+c tags
(config-svc)#match untagged
Allow untagged traffic
(config-svc)# rewrite ingress push 300
Push Action performed for service template
(config-svc)#exit
Exit configure SVC mode
(config)#interface eth2
Specify the attachment circuit interface.
(config-if)#switchport
Configuring the attachment circuit interface as Layer-2.
(config-if)mpls-vpls VPLS1 service-template st1
Associating the VPLS Instance to the attachment circuit interface to match service template st1.
(config-if)mpls-vpls v4 service-template template4
Associating the VPLS Instance to the attachment circuit interface.
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)exit
Exit interface mode.
(config)#exit
Exit configure mode.
#copy running-config startup-config
Save the configuration.
PE-3
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode.
(config-if)#ip address 3.3.3.3/32 secondary
Configure IP address for the loopback interface.
(config-if)#exit
Exit interface mode.
(config)#interface eth1
Specify the Interface (eth1) to be configured.
(config-if)#ip address 30.30.1.1/24
Configure IP address for the interface.
(config-if)#no shutdown
Administratively brining up the interface.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Configure the routing process and specify the routing process ID(100).
(config-router)#network 30.30.1.0/24 area 0
(config-router)#network 3.3.3.3/32 area 0
Define the interface address on which the OSPF runs and associate an area ID(0) with the interface address.
(config-router)#exit
Exit router mode.
(config)#router ldp
Enter router mode for LDP.
(config-router)#targeted-peer ipv4 1.1.1.1
 
Configuring targeted LDP sessions to PE-2
(config-router-targeted-peer)#exit
Exit targeted peer mode
(config-router-targeted-peer)#targeted-peer ipv4 2.2.2.2
Configuring targeted LDP sessions to PE-3
config-router-targeted-peer)#exit
 
Exit targeted peer mode
(config-router)#exit
Exit router configuration mode.
(config)#interface eth1
Enter interface mode.
(config-if)#label-switching
Enable label switching capability on the interface.
(config-if)#enable-ldp ipv4
Enabling LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)#mpls vpls VPLS1 100
Configuring VPLS instance with name and VPLS ID.
(config-vpls)#signaling ldp
Enabling LDP signaling for the VPLS instance.
(config-vpls-sig)#vpls-type vlan
Configuring VPLS type as VLAN mode.
(config-vpls-sig)#vpls-peer 1.1.1.1
(config-vpls-sig)#vpls-peer 2.2.2.2
Configuring VPLS mesh peers.
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#mpls vpls v4 28
Enter VPLS config mode
(config-vpls)#signaling ldp
Define Signaling as LDP
(config-vpls-sig)#vpls-type vlan
Type VLAN configuration for VPLS
(config-vpls-sig)#vpls-peer 1.1.1.1
Configure VPLS Peers
(config-vpls-sig)#vpls-peer 2.2.2.2
Configure VPLS Peers
(config-vpls-sig)#exit-signaling
Exit from VPLS signaling mode.
(config-vpls)#exit
Exit from VPLS Mode.
(config)#service-template st1
Template configuration.
(config-svc)# match outer-vlan 20
Match criteria under template configuration
(config-svc)# exit
Exit service template mode.
(config)#service-template template4
Template configuration
(config-svc)# match outer-vlan 700
Allow VLAN 700 traffic on this VC
(config-svc)# match double-tag outer-vlan 1200 inner-vlan 3200
Allow double tag match with s+c tags
(config-svc)# match untagged
Allow untagged traffic
(config-svc)# rewrite ingress push 300
Push Action performed for service template
(config-svc)#exit
Exit configure SVC mode
(config)#interface eth2
Specify the attachment circuit interface.
(config-if)#switchport
Configuring the attachment circuit interface as Layer-2.
(config-if)mpls-vpls VPLS1 service-template st1
Associating the VPLS Instance to the attachment circuit interface to match service template st1.
(config-if-vpls)#exit
Exit VPLS attachment-circuit mode
(config-if)exit
Exit interface mode.
(config)#exit
Exit configure mode.
#copy running-config startup-config
Save the configuration.
Validation
PE-1
Verify VPLS Session
PE1#sh mpls vpls detail
Virtual Private LAN Service Instance: VPLS1, ID: 100
SIG-Protocol: LDP
Attachment-Circuit :UP
Learning: Enabled
Group ID: 0, VPLS Type: Ethernet VLAN, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Tagged
Svlan Id: 0
Svlan Tpid: 8100
Configured interfaces:
Interface: eth2
Service-template : s1
Match criteria : 10
 
Mesh Peers:
2.2.2.2 (Up)
3.3.3.3 (Up)
PE1#
Virtual Private LAN Service Instance: v4, ID: 28
SIG-Protocol: LDP
Attachment-Circuit :UP
Learning: Enabled
Group ID: 0, VPLS Type: Ethernet VLAN, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Tagged
Svlan Id: 0
Svlan Tpid: 8100
Configured interfaces:
Interface: eth2
Service-template : template4
Match criteria : 700
1200/3200
Untagged
Action type : Push
Action value : 300
 
 
Mesh Peers:
2.2.2.2 (Up)
3.3.3.3 (Up)
PE1#
 
 
 
 
Verify VPLS Mesh Peer
PE1#sh mpls vpls mesh
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status Ecmp-Group100
100 2.2.2.2 24320 24322 eth2 24321 2/Up 1 LDP Active N/A
100 3.3.3.3 24325 24321 eth2 24323 2/Up 1 LDP Active N/A
28 2.2.2.2 24327 24324 eth2 24325 2/Up 1 LDP Active N/A
28 3.3.3.3 24345 24325 eth2 24324 2/Up 1 LDP Active N/A
 
Validation for the Number of Configured VPLS Instances
This example below shows number of configured VPLS instances.
PE-1#show mpls vpls count
-------------------------------
Total VPLS instances : 2
Active VPLS instances : 2
Inactive VPLS instances : 2
-------------------------------
The example below shows the Count of VPLS from LDP standpoint
.
PE-1#show ldp vpls count
-------------------------------
Total VPLS instances : 2
Active VPLS instances : 2
Inactive VPLS instances : 0
-------------------------------
The example below shows the number of MAC addresses learnt by the VPLS.
PE-1#show mpls vpls mac-address count
Total no of MAC addresses learnt :6