neighbor remote-as
Use this command to establish a BGP peering relationship with a customer edge router.
The specified neighbor only exchanges unicast address prefixes, unless the neighbor is also activated using the
neighbor activate command, which allows the exchange of other routing information.
Use the no parameter with this command to delete this peering.
Command Syntax
neighbor (A.B.C.D|X:X::X:X|WORD) remote-as (<1-4294967295>|internal|external)
no neighbor (A.B.C.D|X:X::X:X|WORD) remote-as (<1-4294967295>|internal|external)
For BGP unnumbered mode:
neighbor WORD remote-as (internal|external)
no neighbor WORD remote-as (internal|external)
Parameters
A.B.C.D
Address of the BGP neighbor in an IPv4 format
X:X::X:X
Address of the BGP neighbor in an IPv6 format
WORD
Name of a BGP peer group created with the
neighbor WORD peer-group command. When you specify this parameter, the command applies to all peers in the group.
For an unnumbered interface (RFC 5549), specify an interface name configured with neighbor discovery or an IPv4 address with /31 or /30.
<1-4294967295>
Neighbor’s autonomous system number (ASN) when extended capabilities are configured. If the specified ASN matches the ASN number specified in the router BGP global configuration, the neighbor is identified as internal. If the ASN does no match, the neighbor is identified as external to the local AS.
internal
iBGP peer.
external
eBGP peer.
Default
By default, neighbor remote is disabled
Command Mode
Router mode and Address Family-vrf mode and BGP unnumbered mode
Applicability
This command was introduced before OcNOS version 1.3 and updated in OcNOS version 1.3.6.
Example
#configure terminal
(config)#router bgp 11
(config-router)#neighbor 10.10.0.73 remote-as 345
(config-router)#neighbor 11.11.0.74 remote-as 23456
Note: The last command in the example above should be used when the local speaker is OBGP and the neighbor is NBGP with a 4-octet ASN.
(config)#router bgp 100
(config-router)#address-family ipv4 vrf VRF_A
(config-router-af)#neighbor 10.10.0.1 remote-as 65000
(config)#router bgp 100
(config-router)#address-family ipv6 vrf VRF_A
(config-router-af)#neighbor 3ffe:15:15:15:15::0 remote-as 65000
(config-router)#bgp unnumbered-mode
(config-router-unnum)#neighbor eth1 remote-as internal
(config-router-unnum)#show running bgp
router bgp 100
!
bgp unnumbered-mode
neighbor eth1 remote-as internal
neighbor eth2 remote-as external
exit-unnumbered-mode
!
Last modified date: 07-13-2023