OcNOS-RON-6.3.1 : Quality of Service Guide : Quality of Service Configuration Guide : Explicit Congestion Notification (ECN) Configuration : Configuring ECN on L2 Interface
Configuring ECN on L2 Interface
Do the following to configure ECN on anL2 interface.
 
#configure terminal
Enter inside configure mode
(config)#bridge 1 protocol mstp
Configure bridge 1 as MSTP aware
(config)#interface xe29
Enter interface mode
(config-if)#switchport
Configure xe29 as a layer 2 port
(config-if)#bridge-group 1
Associate bridge to an interface
(config-if)#switchport mode trunk
Configure port as trunk
(config-if)#switchport trunk allowed vlan all
Allow all the vlan on the interface xe29
(config-if)#exit
Exit the xe29 interface mode
(config)#interface xe30
Enter interface mode
(config-if)#switchport
Configure xe30 as a layer 2 port
(config-if)#bridge-group 1
Associate bridge to an interface
(config-if)#switchport mode trunk
Configure port as trunk
(config-if)#switchport trunk allowed vlan all
Allow all the vlan on the interface xe30
(config-if)#exit
Exit the xe30 interface mode
(config)#qos enable
Enable QoS on configuration mode
(config)#qos statistics
Enable QoS statistics on configuration mode
(config)#class-map match-any cmap
Enter Class-map mode
(cmap-qos-match-any-mode)#match precedence 3
Configure match criteria as precedence with Value 3
(config-pmap-qos)#policy-map pmap
Enter policy-map mode
(config-pmap-qos)#class cmap
Assign Class cmap to Policy-map pmap
(config-pmap-c-qos)# police cir 328 mbps pir 556 mbps conform transmit exceed transmit violate transmit
Police Precedence 3 frames @ Committed information rate of 328 mbps and pir 556 mbps conform transmit exceed transmit violate transmit.
(config-pmap-c-qos)#end
Exit out of policy-class-map mode
#configure terminal
Enter inside configure mode
(config)#interface xe29
Enter interface mode
(config-if)#trust dscp
Configure trust DSCP on the interface xe29
(config-if)#service-policy type qos input pmap
Assign service-policy to interface on in-direction
(config-if)#exit
Exit interface mode
(config)#policy-map type queuing default xyz
Enter policy-map queuing mode
(config-pmap-que-def)#class type queuing default q3
Enter class-map type queuing
(config-pmap-c-que-def)#shape average 900 mbps
Configure shape average 900 in q3
(config-pmap-c-que-def)#random-detect green 1000 2000 yellow 3000 4000 red 5000 6000 bytes ecn
Configure ECN with Random Early Detection which includes minimum and maximum threshold for green, yellow and red packets
(config-pmap-c-que-def)#end
Exit pmap mode
#configure terminal
Enter configure mode
(config)#interface xe30
Enter interface mode
(config-if)#service-policy type queuing output xyz
Attach policy on egress interface
(config-if)#commit
Committing the configured line
(config-if)#exit
Exit configure mode
Last modified date: 07-14-2023