OcNOS-RON-6.3.1 : Multicast Guide : Multicast Configuration Guide : IGMP Snooping Configuration : Configuration
Configuration
To enable IGMP Snooping on an interface:
1. Add a bridge to the spanning-tree table
2. Specify the interface to be configured
3. Associate the interface with bridge group
4. IGMP snooping will be enabled by default
5. Configure ports that are connected to routers as multicast router ports
6. By default, IGMP report suppression is enabled on the switch
S1
 
#configure terminal
Enter the Configure mode.
(config)#bridge 1 protocol ieee vlan-bridge
Add bridge 1 to the spanning-tree table.
(config)#vlan database
enter VLAN mode
(config-vlan)#vlan 2 bridge 1
Create VLAN and add it to bridge 1
(config)#exit
Exit VLAN mode
(config)#interface eth3
Specify the interface eth3 to be configured, and Enter interface mode.
(config-if)#shutdown
Shut down the interface.
(config-if)#switchport
Configure the interface as a switch port.
(config-if)#bridge-group 1
Associate the interface eth1 with bridge-group 1.
(config-if)#switchport mode trunk
Configure the port as an trunk port.
(config-if)#switchport trunk allowed vlan all
Add VLAN to trunk
(config-if)#no shutdown
Bring up the interface.
(config-if)#exit
Exit interface mode.
(config)#interface eth1
Specify interface eth1 to be configured.
(config-if)#shutdown
Shut down the interface.
(config-if)#switchport
Configure the interface as a switch port.
(config-if)#bridge-group 1
Associate interface eth1 with bridge-group 1.
(config-if)#switchport mode trunk
Configure the port as an trunk port.
(config-if)#switchport trunk allowed vlan all
Add VLAN to trunk
(config-if)#no shutdown
Bring up the interface.
(config-if)#exit
Exit interface mode.
(config)#interface eth2
Specify interface eth2 to be configured.
(config-if)#shutdown
Shut down the interface.
(config-if)#switchport
Configure the interface as a switch port.
(config-if)#bridge-group 1
Associate interface eth2 with bridge-group 1.
(config-if)#switchport mode trunk
Configure the port as an trunk port.
(config-if)#switchport trunk allowed vlan all
Add VLAN to trunk
(config-if)#no shutdown
Bring up the interface.
(config-if)#exit
Exit interface mode.
(config)#interface vlan1.2
Specify interface vlan1.1 to be configured.
(config)#ip address 1.2.3.4/24
Specify IP address
(config-if)#igmp snooping mrouter interface eth1
Configure this port as a multicast router port
(config-if)#exit
Exit interface mode
Validation
#show running-config interface eth3
!
interface eth3
switchport
bridge-group 1
switchport mode trunk
switchport trunk allowed vlan add 2
 
#show running-config interface eth1
!
interface eth1
switchport
bridge-group 1
switchport mode trunk
switchport trunk allowed vlan add 2
 
#show running-config interface eth2
!
interface eth2
switchport
bridge-group 1
switchport mode trunk
switchport trunk allowed vlan add 2
 
#show igmp snooping groups
IGMP Snooping Group Membership
Group source list: (R - Remote, S - Static)
Vlan Group/Source Address Interface Flags Uptime Expires Last Reporter Version
2 224.1.1.1 eth3 R 00:00:03 00:04:17 0.0.0.0 V3
2 224.1.1.1 eth2 R 00:00:03 00:04:17 0.0.0.0 V3
 
#show igmp snooping interface vlan1.2
IGMP Snooping information for vlan1.2
IGMP Snooping enabled
Snooping Querier none
IGMP Snooping other querier timeout is 255 seconds
Group Membership interval is 260 seconds
IGMPv2 fast-leave is disabled
IGMPv1/v2 Report suppression enabled
IGMPv3 Report suppression enabled
Router port detection using IGMP Queries
Number of router-ports: 1
Number of Groups: 1
Number of v1-reports: 0
Number of v2-reports: 0
Number of v2-leaves: 0
Number of v3-reports: 2
Active Ports:
Eth3
Eth1
Eth2
Last modified date: 07-14-2023