OcNOS-RON-6.3.1 : System Management Guide : System Management Configuration Guide : DHCP Snooping over MLAG : Topology
Topology
Figure 14-21: DHCP Snooping over MLAG
LEAF
 
#configure terminal
Configure terminal.
(config)#bridge 1 protocol rstp vlan-bridge
Configuring the rstp vlan bridge
(config)#vlan 2 bridge 1 state enable
Configure VLAN for the bridge
(config)#interface po1
Enter interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#bridge-group 1
Associate the interface to bridge
(config-if)#switchport mode trunk
Configure the mode as trunk
(config-if)#switchport trunk allowed vlan add 2
Allow vlan 2 on the interface
(config-if)#exit
Exit interface mode
(config)#interface ce1/2
Enter interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#bridge-group 1
Associate the interface to bridge
(config-if)#switchport mode trunk
Configure the mode as trunk
(config-if)#switchport trunk allowed vlan add 2
Allow vlan 2 on the interface
(config-if)#exit
Exit interface mode
(config)#interface ce16/1
Enter interface mode
(config-if)#channel-group 1 mode active
Enable channel-group 1
(config-if)#exit
Exit interface mode
(config)#interface ce16/2
Enter interface mode
(config-if)#channel-group 1 mode active
Enable channel-group 1
(config-if)#exit
Exit interface mode
(config)#interface ce25/1
Enter interface mode
(config-if)#channel-group 1 mode active
Enable channel-group 1
(config-if)#exit
Exit interface mode
(config)#interface ce25/2
Enter interface mode
(config-if)#channel-group 1 mode active
Enable channel-group 1
(config-if)#exit
Exit the configure mode
TOR1
 
#configure terminal
Configure terminal.
(config)#bridge 1 protocol rstp vlan-bridge
Configuring the rstp vlan bridge
(config)#vlan 2 bridge 1 state enable
Configure VLAN for the bridge
(config)#ip dhcp snooping bridge 1
Enable DHCP Snooping on the bridge
(config)#ip dhcp snooping vlan 2 bridge 1
Enable DHCP Snooping on the vlan 2
(config)#interface mlag1
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#bridge-group 1
Associate the interface to bridge
(config-if)#switchport mode trunk
Configure the mode as trunk
(config-if)#switchport trunk allowed vlan add 2
Allow vlan 2 on the interface
(config-if)#ip dhcp snooping trust
Enable the port as trusted.
(config-if)#exit
Exit interface mode
(config)#interface mlag2
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#bridge-group 1
Associate the interface to bridge
(config-if)#switchport mode trunk
Configure the mode as trunk
(config-if)#switchport trunk allowed vlan add 2
Allow vlan 2 on the interface
(config-if)#exit
Exit interface mode
(config)#interface po1
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#mlag 1
Map po1 to mlag1
(config-if)#exit
Exit interface mode
(config)#interface po2
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#mlag 2
Map po2 to mlag2
(config-if)#exit
Exit interface mode
(config)#interface po5
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#bridge-group 1
Associate the interface to bridge
(config-if)#switchport mode trunk
Configure the mode as trunk
(config-if)#switchport trunk allowed add 2
Allow vlan 2 on the interface
(config-if)#exit
Exit interface mode
(config)#interface xe49/1
Enter Interface mode
(config-if)#channel-group 2 mode active
Enable channel-group 2
(config-if)#exit
Exit interface mode
(config)#interface xe49/2
Enter Interface mode
(config-if)#channel-group 2 mode active
Enable channel-group 2
(config-if)#exit
Exit interface mode
(config)#interface xe51/1
Enter Interface mode
(config-if)#channel-group 1 mode active
Enable channel-group 1
(config-if)#exit
Exit interface mode
(config)#interface xe51/2
Enter Interface mode
(config-if)#channel-group 1 mode active
Enable channel-group 1
(config-if)#exit
Exit interface mode
(config)#interface xe53/1
Enter Interface mode
(config-if)#channel-group 5 mode active
Enable channel-group 5
(config-if)#exit
Exit interface mode
(config)#interface xe53/2
Enter Interface mode
(config-if)#channel-group 5 mode active
Enable channel-group 5
(config-if)#exit
Exit interface mode
(config)#mcec domain configuration
Enter MCEC mode
(config-mcec-domain)#domain-address 1111.2222.3333
Domain address for the mlag domain
(config-mcec-domain)#domain-system-number 2
Configure the domain system number
(config-mcec-domain)#intra-domain-link po5
Specify the intra domain link for MLAG communication
{config-mcec-domain)#end
Exit the configure mode
TOR2
 
#configure terminal
Configure terminal.
(config)#bridge 1 protocol rstp vlan-bridge
Configuring the rstp vlan bridge
(config)#vlan 2 bridge 1 state enable
Configure VLAN for the bridge
(config)#ip dhcp snooping bridge 1
Enable DHCP Snooping on the bridge
(config)#ip dhcp snooping vlan 2 bridge 1
Enable DHCP Snooping on the vlan 2
(config)#interface mlag1
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#bridge-group 1
Associate the interface to bridge
(config-if)#switchport mode trunk
Configure the mode as trunk
(config-if)#switchport trunk allowed vlan add 2
Allow vlan 2 on the interface
(config-if)#ip dhcp snooping trust
Enable the port as trusted.
(config-if)#exit
Exit interface mode
(config)#interface mlag2
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#bridge-group 1
Associate the interface to bridge
(config-if)#switchport mode trunk
Configure the mode as trunk
(config-if)#switchport trunk allowed vlan add 2
Allow vlan 2 on the interface
(config-if)#exit
Exit interface mode
(config)#interface po1
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#mlag 1
Map po1 to mlag1
(config-if)#exit
Exit interface mode
(config)#interface po2
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#mlag 2
Map po2 to mlag2
(config-if)#exit
Exit interface mode
(config)#interface po5
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#bridge-group 1
Associate the interface to bridge
(config-if)#switchport mode trunk
Configure the mode as trunk
(config-if)#switchport trunk allowed vlan add 2
Allow vlan 2 on the interface
(config-if)#exit
Exit interface mode
(config)#interface ce16/1
Enter Interface mode
(config-if)#channel-group 1 mode active
Enable channel-group 1
(config-if)#exit
Exit interface mode
(config)#interface ce16/2
Enter Interface mode
(config-if)#channel-group 1 mode active
Enable channel-group 1
(config-if)#exit
Exit interface mode
(config)#interface ce25/1
Enter Interface mode
(config-if)#channel-group 5 mode active
Enable channel-group 5
(config-if)#exit
Exit interface mode
(config)#interface ce25/2
Enter Interface mode
(config-if)#channel-group 5 mode active
Enable channel-group 5
(config-if)#exit
Exit interface mode
(config)#interface ce26/1
Enter Interface mode
(config-if)#channel-group 2 mode active
Enable channel-group 2
(config-if)#exit
Exit interface mode
(config)#interface ce26/2
Enter Interface mode
(config-if)#channel-group 2 mode active
Enable channel-group 2
(config-if)#exit
Exit interface mode
(config)#mcec domain configuration
Enter MCEC mode
(config-mcec-domain)#domain-address 1111.2222.3333
Domain address for the mlag domain
(config-mcec-domain)#domain-system-number 1
Configure the domain system number
(config-mcec-domain)#intra-domain-link po5
Specify the intra domain link for MLAG communication
(config-mcec-domain)#end
Exit the configure mode
L2SW
 
#configure terminal
Configure terminal.
(config)#bridge 1 protocol rstp vlan-bridge
Configuring the rstp vlan bridge
(config)#vlan 2 bridge 1 state enable
Configure VLAN for the bridge
(config-if)#interface po2
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#bridge-group 1
Associate the interface to bridge
(config-if)#switchport mode trunk
Configure the mode as trunk
(config-if)#switchport trunk allowed vlan add 2
Allow vlan 2 on the interface
(config-if)#exit
Exit interface mode
(config)#interface xe3
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#bridge-group 1
Associate the interface to bridge
(config-if)#switchport mode trunk
Configure the mode as trunk
(config-if)#switchport trunk allowed vlan add 2
Allow vlan 2 on the interface
(config-if)#exit
Exit interface mode
(config)#interface xe49/1
Enter Interface mode
(config-if)#channel-group 2 mode active
Enable channel-group 2
(config-if)#exit
Exit interface mode
(config)#interface xe49/2
Enter Interface mode
(config-if)#channel-group 2 mode active
Enable channel-group 2
(config-if)#exit
Exit interface mode
(config)#interface xe53/1
Enter Interface mode
(config-if)#channel-group 2 mode active
Enable channel-group 2
(config-if)#exit
Exit interface mode
(config)#interface xe53/2
Enter Interface mode
(config-if)#channel-group 2 mode active
Enable channel-group 2
(config-if)#exit
Exit the configure mode
Static MLAG configuration for TOR1 and TOR2
Note: Only mlag related configs for static MLAG is provided. While rest of the configuration is similar to dynamic.
TOR1:
#configure terminal
Configure terminal.
(config)#interface mlag1
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#bridge-group 1
Associate the interface to bridge
(config-if)#switchport mode trunk
Configure the mode as trunk
(config-if)#switchport trunk allowed vlan add 2
Allow vlan 2 on the interface
(config-if)#mode active-standby
Configure mlag mode for mlag1
(config-if)#ip dhcp snooping trust
Enable the port as trusted.
(config-if)#exit
Exit interface mode
(config)#interface mlag2
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#bridge-group 1
Associate the interface to bridge
(config-if)#switchport mode trunk
Configure the mode as trunk
(config-if)#switchport trunk allowed vlan add 2
Allow vlan 2 on the interface
(config-if)#mode active-active
Configure mlag mode for mlag2
(config-if)#exit
Exit interface mode
(config)#interface sa1
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#mlag 1
Map sa1 to mlag1
(config-if)#exit
Exit interface mode
(config)#interface sa2
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#mlag 2
Map sa2 to mlag2
(config-if)#exit
Exit interface mode
(config)#interface sa5
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#bridge-group 1
Associate the interface to bridge
(config-if)#switchport mode trunk
Configure the mode as trunk
(config-if)#switchport trunk allowed vlan add 2
Allow vlan 2 on the interface
(config-if)#exit
Exit interface mode
(config)#mcec domain configuration
Enter MCEC mode
(config-mcec-domain)#domain-address 1111.2222.3333
Domain address for the mlag domain
(config-mcec-domain)#domain-system-number 1
Configure the domain system number
(config-mcec-domain)#intra-domain-link sa5
Specify the intra domain link for MLAG communication
(config-mcec-domain)#end
Exit the configure mode
TOR2:
#configure terminal
Configure terminal.
(config)#interface mlag1
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#bridge-group 1
Associate the interface to bridge
(config-if)#switchport mode trunk
Configure the mode as trunk
(config-if)#switchport trunk allowed vlan add 2
Allow vlan 2 on the interface
(config-if)#mode active-standby
Configure mlag mode for mlag1
(config-if)#ip dhcp snooping trust
Enable the port as trusted.
(config-if)#exit
Exit interface mode
(config)#interface mlag2
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#bridge-group 1
Associate the interface to bridge
(config-if)#switchport mode trunk
Configure the mode as trunk
(config-if)#switchport trunk allowed vlan add 2
Allow vlan 2 on the interface
(config-if)#mode active-active
Configure mlag mode for mlag2
(config-if)#exit
Exit interface mode
(config)#interface sa1
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#mlag 1
Map sa1 to mlag1
(config-if)#exit
Exit interface mode
(config)#interface sa2
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#mlag 2
Map sa2 to mlag2
(config-if)#exit
Exit interface mode
(config)#interface sa5
Enter Interface mode
(config-if)#switchport
Make the interface Layer 2
(config-if)#bridge-group 1
Associate the interface to bridge
(config-if)#switchport mode trunk
Configure the mode as trunk
(config-if)#switchport trunk allowed vlan add 2
Allow vlan 2 on the interface
(config-if)#exit
Exit interface mode
(config)#mcec domain configuration
Enter MCEC mode
(config-mcec-domain)#domain-address 1111.2222.3333
Domain address for the mlag domain
(config-mcec-domain)#domain-system-number 2
Configure the domain system number
(config-mcec-domain)#intra-domain-link sa5
Specify the intra domain link for MLAG communication
(config-mcec-domain)#end
Exit the configure mode
 
 
Last modified date: 07-14-2023