OcNOS-RON-6.3.1 : Virtual Extensible LAN Guide : Virtual eXtensible Local Area Network Configuration Guide : VXLAN Hybrid Access Port Configuration : Topology
Topology
RTR1/VTEP1
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode for loopback.
(config-if)#ip address 10.10.10.10/32 secondary
Assign secondary IP address.
(config-if)#exit
Exit interface mode.
(config)#mac vrf vrf12345
Create mac routing/forwarding instance with vrf12345 name and enter VRF mode.
(config-vrf)#rd 1.1.1.1:1
Assign Rd value.
(config-vrf)#route-target both 10.10.10.10:10
Assign route-target both value.
(config-vrf)#exit
Exit VRF configuration mode.
(config)#bridge 32 protocol ieee vlan-bridge
Configure the ieee VLAN-bridge with Id 32.
(config)#vlan 2-5 bridge 32
Configure the VLANs 2-5 for the configured bridge Id 32.
(config)#interface ce25/1
Enter interface mode for ce25/1.
(config-if)#ip address 20.20.20.0/31
Assign IP address 20.20.20.0 in /31 mask.
(config-if)#exit
Exit interface mode.
(config)#interface ce25/2
Enter interface mode for ce25/2.
(config-if)#switchport
Make it L2 interface.
(config-if)#bridge-group 32
Associate the bridge-group 32 to the interface.
(config-if)#switchport mode hybrid
Configure the Hybrid mode.
(config-if)#switchport hybrid allowed vlan add 4 egress-tagged enable
Configure hybrid allowed VLAN add 4 to support the created VLAN in the L2 Bridge.
(config-if)#exit
Exit interface mode.
(config)#interface ce31/1
Enter interface mode for ce31/1.
(config-if)#switchport
Make it L2 interface.
(config-if)#bridge-group 32
Associate the bridge-group 32 to the interface.
(config-if)#switchport mode hybrid
Configure the Hybrid mode.
(config-if)#switchport hybrid allowed vlan add 4 egress-tagged enable
Configure hybrid allowed VLAN add 4 to support the created VLAN in the L2 Bridge.
(config-if)#exit
Exit interface mode.
(config)#router bgp 64512
Enter BGP router mode.
(config-router)#bgp router-id 1.1.1.1
Assign BGP router ID
(config-router)#neighbor 20.20.20.1 remote-as 64513
Specify a neighbor router with peer ip address and remote-as defined.
(config-router)#address-family ipv4 unicast
Enter into IPv4 unicast address family
(config-router-af)#network 10.10.10.10/32
Advertise loopback network into BGP for VTEP ID reachability
(config-router-af)#exit-address-family
Exit IPv4 unicast address family mode
(config-router)#address-family l2vpn evpn
Enter L2VPN address family mode.
(config-router-af)#neighbor 20.20.20.1 activate
Activate the peer into address family mode.
(config-router-af)#exit-address-family
Exit L2VPN address family mode.
(config-router)#exit
Exit BGP router mode.
(config)#nvo vxlan enable
Enable Vxlan.
(config)#nvo vxlan vtep-ip-global 10.10.10.10
Configure the source Vtep-ip.
(config)#nvo vxlan id 16777215 ingress-replication inner-vid-disabled
Configure Vxlan Network identifier with/without inner-vid-disabled configure and enter Vxlan tenant mode.
(config-nvo)#vxlan host-reachability-protocol evpn-bgp vrf12345
Assign VRF for evpn-bgp to carry evpn route.
(config-nvo)#exit
Exit Vxlan tenant mode.
(config)#nvo vxlan access-if port-vlan ce31/1 3
Enable port-VLAN mapping i.e. access port to outer-VLAN (SVLAN) mapping.
(config-nvo-acc-if)#map vnid 16777215
Map Vxlan Identifier to access-port.
(config-nvo-acc-if)#exit
Exit Vxlan access-interface mode.
(config)#commit
Commit the candidate configuration to the running configuration
RTR2
 
#configure terminal
Enter configure mode.
(config)#bridge 32 protocol ieee vlan-bridge
Configure the ieee VLAN-bridge with Id 32.
(config)#vlan 2-5 bridge 32
Configure the VLANs 2-5 for the configured bridge Id 32.
(config)#interface xe17
Enter interface mode for xe17.
(config-if)#ip address 20.20.20.1/31
Assign IP address 20.20.20.1 in /31 mask.
(config-if)#exit
Exit interface mode.
(config)#interface xe18
Enter interface mode for xe18.
(config-if)#switchport
Make it L2 interface .
(config-if)#bridge-group 32
Associate the bridge-group 32 to the interface.
(config-if)#switchport mode hybrid
Configure the Hybrid mode.
(config-if)#switchport hybrid allowed vlan add 4 egress-tagged enable
Configure hybrid allowed VLAN add 4 to support the created VLAN in the L2 Bridge.
(config-if)#exit
Exit interface mode.
(config)#interface xe33
Enter interface mode for xe33.
(config-if)#ip address 30.30.30.0/31
Assign IP address 30.30.30.0 in /31 mask.
(config-if)#exit
Exit interface mode.
(config)#interface xe34
Enter interface mode for xe34.
(config-if)#switchport
Make it L2 interface.
(config-if)#bridge-group 32
Associate the bridge-group 32 to the interface.
(config-if)#switchport mode hybrid
Configure the Hybrid mode.
(config-if)#switchport hybrid allowed vlan add 4 egress-tagged enable
Configure hybrid allowed VLAN add 4 to support the created VLAN in the L2 Bridge.
(config-if)#exit
Exit interface mode.
(config)#router bgp 64513
Enter BGP router mode.
(config-router)#bgp router-id 2.2.2.2
Assign BGP router ID
(config-router)#neighbor 20.20.20.0 remote-as 64512
Specify a neighbor router with peer ip address and remote-as defined.
(config-router)#neighbor 30.30.30.1 remote-as 64514
Specify a neighbor router with peer ip address and remote-as defined.
(config-router)#address-family l2vpn evpn
Enter L2VPN address family mode.
(config-router-af)#neighbor 20.20.20.0 activate
Activate the peer into address family mode.
(config-router-af)#neighbor 30.30.30.1 activate
Activate the peer into address family mode.
(config-router-af)#exit-address-family
Exit L2VPN address family mode.
(config-router)#exit
Exit BGP router mode.
(config)#commit
Commit the candidate configuration to the running configuration
RTR3/VTEP2
 
#configure terminal
Enter configure mode.
(config)#interface lo
Enter interface mode for loopback.
(config-if)#ip address 40.40.40.40/32 secondary
Assign secondary IP address.
(config-if)#exit
Exit interface mode.
(config)#mac vrf vrf12345
Create mac routing/forwarding instance with vrf12345 name and enter VRF mode.
(config-vrf)#rd 2.2.2.2:2
Assign Rd value.
(config-vrf)#route-target both 10.10.10.10:10
Assign route-target both value.
(config-vrf)#exit
Exit VRF configuration mode.
(config)#bridge 32 protocol ieee vlan-bridge
Configure the ieee VLAN-bridge with Id 32.
(config)#vlan 2-5 bridge 32
Configure the VLANs 2-5 for the configured bridge Id 32.
(config)#interface xe 49/1
Enter interface mode for xe49/1.
(config-if)#ip address 30.30.30.1/31
Assign Ip address 30.30.30.1 in /31 mask.
(config-if)#exit
Exit interface mode.
(config)#interface xe49/2
Enter interface mode for xe49/2.
(config-if)#switchport
Make it L2 interface .
(config-if)#bridge-group 32
Associate the bridge-group 32 to the interface.
(config-if)#switchport mode hybrid
Configure the Hybrid mode.
(config-if)#switchport hybrid allowed vlan add 4 egress-tagged enable
Configure hybrid allowed VLAN add 4 to support the created VLAN in the L2 Bridge.
(config-if)#exit
Exit interface mode.
(config)#interface xe1
Enter interface mode for xe1.
(config-if)#switchport
Make it L2 interface .
(config-if)#bridge-group 32
Associate the bridge-group 32 to the interface.
(config-if)#switchport mode hybrid
Configure the Hybrid mode.
(config-if)#switchport hybrid allowed vlan add 4 egress-tagged enable
Configure hybrid allowed VLAN add 4 to support the created VLAN in the L2 Bridge.
(config-if)#exit
Exit interface mode.
(config)#router bgp 64514
Enter BGP router mode.
(config-router)#bgp router-id 3.3.3.3
Assign BGP router ID
(config-router)#neighbor 30.30.30.0 remote-as 64513
Specify a neighbor router with peer IP address and remote-as defined.
(config-router)#address-family ipv4 unicast
Enter into IPv4 unicast address family
(config-router-af)#network 40.40.40.40/32
Advertise loopback network into BGP for VTEP ID reachability
(config-router-af)#exit-address-family
Exit IPv4 unicast address family mode
(config-router)#address-family l2vpn evpn
Enter L2VPN address family mode.
(config-router-af)#neighbor 30.30.30.0 activate
Activate the peer into address family mode.
(config-router-af)#exit-address-family
Exit L2VPN address family mode.
(config-router)#exit
Exit BGP router mode.
(config)#nvo vxlan enable
Enable Vxlan.
(config)#nvo vxlan vtep-ip-global 40.40.40.40
Configure the source Vtep-ip.
(config)#nvo vxlan id 16777215 ingress-replication inner-vid-disabled
Configure Vxlan Network identifier with/without inner-vid-disabled configure and enter Vxlan tenant mode.
(config-nvo)#vxlan host-reachability-protocol evpn-bgp vrf12345
Assign VRF for evpn-bgp to carry evpn route.
(config-nvo)#exit
Exit Vxlan tenant mode.
(config)#nvo vxlan access-if port-vlan xe1 3
Enable port-VLAN mapping i.e. access port to outer-VLAN (SVLAN) mapping.
(config-nvo-acc-if)#map vnid 16777215
Map Vxlan Identifier to access-port.
(config-nvo-acc-if)#exit
Exit Vxlan access-interface mode.
(config)#commit
Commit the candidate configuration to the running configuration
Last modified date: 07-14-2023