OcNOS-RON : Layer 2 Guide : Layer 2 Configuration Guide : Link Aggregation Configuration : LACP Minimum-Link, Minimum-Bandwidth on Dynamic and Static Channel-Groups with MC-LAG
LACP Minimum-Link, Minimum-Bandwidth on Dynamic and Static Channel-Groups with MC-LAG
Overview
OcNOS allows the configuration of minimum number of the LAG members per LAG group. Both these configurations are meaningful in case the LAG is used for incremental-BW mode. The minimum configuration controls the minimum number of members /bandwidth that must be operationally up / bandwidth available to declare their LAG as operationally UP.
When static/dynamic LAG interface configured with minimum links / minimum bandwidth, the following conditions are to be met:
Ports which are admin and operational up are considered for min-link.
The specified minimum number of links should be up.
Min-link and min-bandwidth cannot co-exist.
When ports are down due to min-link/min-bandwidth, in show interface brief command output, port down with the corresponding reason code for the failure due to min-link/min-bandwidth.
Minimum Active Members/Bandwidth
The user can specify the minimum number of members that must be operationally up to declare their LAG as operationally UP. Note that this parameter applies to static/dynamic LAG.
port-channel min-links <2 - 32>
The minimum active member configuration will be allowed to be modified to be greater than the current number of active members. In such configuration, the LAG operational status will become operationally down.
The user can specify the minimum bandwidth, based on the configured value and the ports that satisfy the conditions LAG will be operationally UP. This parameter is applied for static/dynamic LAG.
port-channel min-bandwidth BANDWIDTH
BANDWIDTH <1-999>k|m for 1 to 999 kilo bits or mega bits <1-1000>g for 1 to 1000 giga bits.
When condition fails, the operational state changes to DOWN.
Note: Do not configure minimum-link, Minimum Bandwidth both on TORS and switches at the same time to avoid flaps of MLAG.
Topology
Figure 8-13: MC - LAG Topology
Configuration
TOR1:
 
#configure terminal
Enter configure mode.
(config)# bridge 1 protocol rstp vlan-bridge end
Configure bridge type
configure terminal
Enter Configure mode
(config)# vlan database
Enter vlan database
(config-vlan)# vlan 600 bridge 1 state enable
Configure vlans
(config-if)#end
 
#configure terminal
Enter Configure mode.
(config)#interface mlag1
Enter Interface mode
(config-if)# switchport
Make mlag as layer2 port
(config-if)# bridge-group 1
Attach interface to bridge
(config-if)# switchport mode trunk
Configure trunk port
(config-if)# switchport trunk allowed vlan add 600,601,502
Add interface to vlans
(config-if)# spanning-tree edgeport
Configure port as edge port to avoid loops
(config-if)# spanning-tree bpdu-filter enable
Enable bpdu filter to avoid loops
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface mlag3
Enter Interface mode
(config-if)# switchport
Make mlag as layer2 port
(config-if)# bridge-group 1
Attach interface to bridge
(config-if)# switchport mode trunk
Configure trunk port
(config-if)# switchport trunk allowed vlan add 600,502
Add interface to vlans
(config-if)# spanning-tree edgeport
Configure port as edge port to avoid loops
(config-if)# spanning-tree bpdu-filter enable
Enable bpdu filter to avoid loops
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface po100
Enter Interface mode
(config-if)# switchport
Make po as layer2 port
(config-if)# bridge-group 1
Associate the interface with bridge group 1.
(config-if)# switchport mode trunk
Set the switching characteristics of this interface to trunk mode.
(config-if)# switchport trunk allowed vlan all
Enable all VLAN identifiers on this interface.
(config-if)# mtu 9216
Configure mtu
(config-if)#end
 
#configure terminal
Enter Configure mode.
(config)#interface sa1
Enter Interface mode
(config-if)# switchport
Make sa1 as layer2 port
(config-if)# bridge-group 1
Associate the interface with bridge group 1.
(config-if)# switchport mode trunk
Set the switching characteristics of this interface to trunk mode.
(config-if)# switchport trunk allowed all
Enable all VLAN identifiers on this interface.
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce2/1
Enter Interface mode
(config-if)#port breakout enable
Port breakout enabled
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce2/2
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa1
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce2/3
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa1
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce2/4
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa1
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce3/1
Enter Interface mode
(config-if)#port breakout enable
Port breakout enabled
(config-if)# channel-group 100 mode active
Add interface to po100
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce3/2
Enter Interface mode
(config-if)# channel-group 100 mode active
Add interface to po100
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce3/3
Enter Interface mode
(config-if)# channel-group 100 mode active
Add interface to po100
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce3/4
Enter Interface mode
(config-if)# channel-group 100 mode active
Add interface to po100
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce4/1
Enter Interface mode
(config-if)#port breakout enable
Port breakout enabled
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce4/2
Enter Interface mode
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce4/3
Enter Interface mode
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#mcec domain configuration
Enter Multichasis Etherchannel domain configuration mode.
(config-mcec-domain)# domain-address 1111.2222.3333
Configure the domain address.
(config-mcec-domain)# domain-system-number 1
Configure the domain system number
(config-mcec-domain)# intra-domain-link po100
Specify the intra domain link for MLAG communication
(config-mcec-domain)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#int mlag1
Enter Interface mode
(config-if)#mode active-standby
Configure mlag mode for mlag1
(config-if)#switchover type revertive 10
Configure revertive timer
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface sa1
Enter Interface mode
(config-if)#mlag 1
Map sa1 to mlag1
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#int mlag3
Enter Interface mode
(config-if)#mode active-standby
Configure mlag mode for mlag3
(config-if)#switchover type revertive 10
Configure revertive timer
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface sa3
Enter Interface mode
(config-if)#mlag 3
Map sa3 to mlag3
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config-if)# interface sa1
Enter sa interface mode
(config-if)#port-channel min-links 3
Configure min-link value on sa interface
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface sa3
Enter sa Interface mode
(config-if)#port-channel min-bandwidth 30g
Configure min-bandwidth value on sa/po interface
TOR2
 
#configure terminal
Enter configure mode.
bridge 1 protocol rstp vlan-bridge end
Configure bridge type
configure terminal
Enter Configure mode.
(config)# vlan database
Enter vlan database
(config-vlan)# vlan 600 bridge 1 state enable
Configure vlans
#configure terminal
Enter Configure mode.
(config)#interface mlag1
Enter Interface mode
(config-if)# switchport
Make mlag as layer2 port
(config-if)# bridge-group 1
Attach interface to bridge
(config-if)# switchport mode trunk
Configure trunk port
(config-if)# switchport trunk allowed vlan add 600,601,502
Add interface to vlans
(config-if)# spanning-tree edgeport
Configure port as edge port to avoid loops
(config-if)# spanning-tree bpdu-filter enable
Enable bpdu filter to avoid loops
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface mlag3
Enter Interface mode
(config-if)# switchport
Make mlag as layer2 port
(config-if)# bridge-group 1
Attach interface to bridge
(config-if)# switchport mode trunk
Configure trunk port
(config-if)# switchport trunk allowed vlan add 600,502
Add interface to vlans
(config-if)# spanning-tree edgeport
Configure port as edge port to avoid loops
(config-if)# spanning-tree bpdu-filter enable
Enable bpdu filter to avoid loops
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface po100
Enter Interface mode
(config-if)# switchport
Make po(IDL) as layer2 port
(config-if)# bridge-group 1
Associate the interface with bridge group 1.
(config-if)# switchport mode trunk
Set the switching characteristics of this interface to trunk mode.
(config-if)# switchport trunk allowed vlan all
Enable all VLAN identifiers on this interface.
(config-if)# port-channel load-balance src-dst-mac
Enable load balance
(config-if)# mtu 9216
Configure mtu
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface sa1
Enter Interface mode
(config-if)# switchport
Make sa1 as layer2 port
(config-if)# bridge-group 1
Associate the interface with bridge group 1.
(config-if)# switchport mode trunk
Set the switching characteristics of this interface to trunk mode.
(config-if)# switchport trunk allowed all
Enable all VLAN identifiers on this interface.
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface sa3
Enter Interface mode
(config-if)# switchport
Make sa3 as layer2 port
(config-if)# bridge-group 1
Associate the interface with bridge group 1.
(config-if)# switchport mode trunk
Set the switching characteristics of this interface to trunk mode.
(config-if)# switchport trunk allowed all
Enable all VLAN identifiers on this interface.
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce1/1
Enter Interface mode
(config-if)#port breakout enable
Port breakout enabled
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce1/2
Enter Interface mode
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce1/3
Enter Interface mode
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce3/1
Enter Interface mode
(config-if)# channel-group 100 mode active
Add interface to po100
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce3/2
Enter Interface mode
(config-if)# channel-group 100 mode active
Add interface to po100
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce3/3
Enter Interface mode
(config-if)# channel-group 100 mode active
Add interface to po100
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce3/4
Enter Interface mode
(config-if)# channel-group 100 mode active
Add interface to po100
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce5/1
Enter Interface mode
(config-if)#port breakout enable
Port breakout enabled
(config-if)# static-channel-group 1
Add interface to sa1
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce5/2
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa1
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface ce5/3
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa1
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#mcec domain configuration
Enter Multichasis Etherchannel domain configuration mode.
(config-mcec-domain)# domain-address 1111.2222.3333
Configure the domain address.
(config-mcec-domain)# domain-system-number 2
Configure the domain system number
(config-mcec-domain)# intra-domain-link po100
Specify the intra domain link for MLAG communication
(config-mcec-domain)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#int mlag1
Enter Interface mode
(config-if)#mode active-standby
Configure mlag mode for mlag1
(config-if)#switchover type revertive 10
Configure revertive timer
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface sa1
Enter Interface mode
(config-if)#mlag 1
Map sa1 to mlag1
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#int mlag3
Enter Interface mode
(config-if)#mode active-standby
Configure mlag mode for mlag3
(config-if)#switchover type revertive 10
Configure revertive timer
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface sa3
Enter Interface mode
(config-if)#mlag 3
Map sa3 to mlag3
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config-if)# interface sa1
Enter sa interface mode
(config-if)#port-channel min-links 3
Configure min-link value on sa interface
(config)#interface sa3
Enter sa Interface mode
(config-if)#port-channel min-bandwidth 30g
Configure min-bandwidth value on sa interface.
SW1
 
configure terminal
Enter Configure mode.
bridge 1 protocol rstp vlan-bridge
Configure bridge type
(config)#vlan database
Create vlan database
(config-vlan)#vlan 600,601,502,101,100 bridge 1 state enable
Create Vlans
(config-vlan)#end
Return to privilege mode
configure terminal
Enter Configure mode.
(config)#interface xe1
Enter Interface mode
(config-if)# switchport
Make xe1 as layer2 port
(config-if)# bridge-group 1
Associate the interface with bridge group 1.
(config-if)# switchport mode trunk
Set the switching characteristics of this interface to trunk mode.
(config-if)# switchport trunk allowed vlan all
Enable all VLAN identifiers on this interface.
(config-if)#spanning-tree edgeport
Configure port as edgeport
(config-if)#spanning-tree bpdu-filter enable
Enable spanning tree bpdu filter
(config-if)# mtu 9216
Configure mtu
(config-if)#end
Return to privilege mode
configure terminal
Enter Configure mode.
(config)#interface sa1
Enter Interface mode
(config-if)# switchport
Make xe1 as layer2 port
(config-if)# bridge-group 1
Associate the interface with bridge group 1.
(config-if)# switchport mode trunk
Set the switching characteristics of this interface to trunk mode.
(config-if)# switchport trunk allowed vlan add 100,101,300,401,402
Enable all VLAN identifiers on this interface.
(config-if)#spanning-tree edgeport
Configure port as edgeport
(config-if)#spanning-tree bpdu-filter enable
Enable spanning tree bpdu filter
(config-if)# mtu 9216
Configure mtu
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface xe2
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa1
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface xe3
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa1
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface xe4
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa1
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface xe6
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa3
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface xe7
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa3
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface xe8
Enter Interface mode
(config-if)# static-channel-group 1
Add interface to sa3
(config-if)#end
Return to privilege mode
SW2
 
configure terminal
Enter Configure mode.
bridge 1 protocol rstp vlan-bridge
Configure bridge type
(config)#vlan database
Create vlan database
(config-vlan)#vlan 600,601,502,101,100 bridge 1 state enable
Create vlans
(config-vlan)#end
Return to privilege mode
configure terminal
Enter Configure mode.
(config)#interface xe5/1
Enter Interface mode
(config-if)# switchport
Make xe1 as layer2 port
(config-if)# bridge-group 1
Associate the interface with bridge group 1.
(config-if)# switchport mode trunk
Set the switching characteristics of this interface to trunk mode.
(config-if)# switchport trunk allowed vlan all
Enable all VLAN identifiers on this interface.
(config-if)#spanning-tree edgeport
Configure port as edge port
(config-if)#spanning-tree bpdu-filter enable
Enable spanning tree bpdu filter
(config-if)# mtu 9216
Configure mtu
(config-if)#end
Return to privilege mode
configure terminal
Enter Configure mode.
(config)#interface sa3
Enter Interface mode
(config-if)# switchport
Make sa3 as layer2 port
(config-if)# bridge-group 1
Associate the interface with bridge group 1.
(config-if)# switchport mode trunk
Set the switching characteristics of this interface to trunk mode.
(config-if)# switchport trunk allowed vlan add 100,101,401,402,600,502
Enable all VLAN identifiers on this interface.
(config-if)#spanning-tree edgeport
Configure port as edge port
(config-if)#spanning-tree bpdu-filter enable
Enable spanning tree bpdu filter
(config-if)# mtu 9216
Configure mtu
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface xe3/1
Enter Interface mode
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface xe3/2
Enter Interface mode
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface xe3/3
Enter Interface mode
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface xe1/1
Enter Interface mode
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface xe1/2
Enter Interface mode
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#end
Return to privilege mode
#configure terminal
Enter Configure mode.
(config)#interface xe1/3
Enter Interface mode
(config-if)# static-channel-group 3
Add interface to sa3
(config-if)#end
Return to privilege mode
This configuration is applicable for the dynamic LAG with MC-LAG topology except dynamic LAG interface creations, which needs to be referred from the dynamic LAG configurations given above.
Validation Commands
sh int brief sa [id], sh int brief po [id], sh mlag-domain summary, sh static-channel-group <sa id>, <sh etherchannel>, sh running-config interface sa [id], <sh etherchannel summary>.
When sa or po goes down due to min-link or min-bandwidth not satisfied, below validations to be done:
SW2
#sh int brief sa1
Codes: ETH - Ethernet, LB - Loopback, AGG - Aggregate, MLAG - MLAG Aggregate
FR - Frame Relay, TUN -Tunnel, PBB - PBB Logical Port, VP - Virtual Port
CVP - Channelised Virtual Port, METH - Management Ethernet, UNK- Unknown
ED - ErrDisabled, PD - Protocol Down, AD - Admin Down,
IA - InActive
PD(Min L/B) - Protocol Down Min-Links/Bandwidth
DV - DDM Violation, NA - Not Applicable
NOM - No operational members, PVID - Port Vlan-id
Ctl - Control Port (Br-Breakout/Bu-Bundle)
HD - ESI Hold Timer Down
 
------------------------------------------------------------------------------
Port-channel Type PVID Mode Status Reason Speed
Interface
--------------------------------------------------------------------------------
sa1 AGG 1 trunk down PD(Min L/B) 0
 
#
#sh int brief po100
 
Codes: ETH - Ethernet, LB - Loopback, AGG - Aggregate, MLAG - MLAG Aggregate
FR - Frame Relay, TUN -Tunnel, PBB - PBB Logical Port, VP - Virtual Port
CVP - Channelised Virtual Port, METH - Management Ethernet, UNK- Unknown
ED - ErrDisabled, PD - Protocol Down, AD - Admin Down,
IA - InActive
PD(Min L/B) - Protocol Down Min-Links/Bandwidth
DV - DDM Violation, NA - Not Applicable
NOM - No operational members, PVID - Port Vlan-id
Ctl - Control Port (Br-Breakout/Bu-Bundle)
HD - ESI Hold Timer Down
 
 
--------------------------------------------------------------------------------
Port-channel Type PVID Mode Status Reason Speed
Interface
--------------------------------------------------------------------------------
po100 AGG 1 trunk down PD(Min L/B) 0
 
#
#sh etherchannel
% Lacp Aggregator: po100
% Min-Bandwidth : 40g
% Protocol Down (Min L/B) : True
% Member:
ce3/1
ce3/2
ce3/3
ce3/4
------------------------------------
% Lacp Aggregator: po200
% Member:
ce29/1
ce29/2
------------------------------------
% Lacp Aggregator: sa1
% Min-links : 3
% Protocol Down (Min L/B): True
% Member:
ce2/2
ce2/3
ce2/4
------------------------------------
% Lacp Aggregator: sa3
% Member:
ce4/1
ce4/2
ce4/3
#
#sh running-config interface sa1
!
interface sa1
switchport
port-channel load-balance src-dst-mac
port-channel min-links 3
mlag 1
!
 
#sh static-channel-group 1
Static Aggregator: sa1
Minimum-Links 3
Member Status
ce2/2 down
ce2/3 down
ce2/4 down
#
#sh etherchannel summary
Aggregator po100 100100
Aggregator Type: Layer2
Admin Key: 0100 - Oper Key 0100
Link: ce3/1 (5057) sync: 0
Link: ce3/2 (5058) sync: 0
Link: ce3/3 (5059) sync: 0
Link: ce3/4 (5060) sync: 0
--------------------------------------
Last modified date: 07/13/2023