OcNOS-RON : Layer 1 Guide : Layer 1 Configuration Guide : Cross-Connect (XC)
Cross-Connect (XC)
This Chapter contains the cross-connect configuration example.
Overview
This feature is to configure the cross connection between two ports.
The cross connect is bi-directional. The traffic which is received on the first interface is transmitted out to the second interface and the traffic which is received on the second interface is transmitted out to the first interface.
It is point-to-point and same end points cannot be used for another cross connect
This following are the types of endpoints supported by this port based cross connect.
1. Native Ethernet interface
2. LAG interface
OSPF, BGP and BFD Session Establishments via Cross-connect
The following configuration example will illustrate OSPF, BFD and BGP session establishments via Cross-connect.
Topology
Session establishments via Cross-connect
R1
 
#configure terminal
Enter configure mode
(config)#hostname R1
Configure the host name
(config)#interface xe1/1
Enter into interface level
(config-if)#ip address 10.10.10.1/24
Configure IP address to the interface
(config-if)#exit
Exiting from interface level
(config)#interface xe32/1
Enter into interface mode
(config-if)#ip address 20.20.20.1/24
Configure ip address to the interface
(config-if)#exit
Exiting from interface level
(config)#interface lo
Enter into loop-back interface
(config-if)#ip address 1.1.1.1/24 secondary
Configuring secondary IP address
(config-if)#exit
Exiting the loop-back interface level
(config)#bfd interval 3 minrx 3 multiplier 3
Configuring BFD options
(config)#router ospf 10
Configuring OSPF process
(config-router)#router-id 1.1.1.1
Configuring router-id
(config-router)#network 10.10.10.0 0.0.0.255 area 0
Configuring Network id and Area ID
(config-router)#redistribute connected
Configuring redistribute connected
(config-router)#bfd all-interfaces
Configuring bfd on all-interfaces
(config-router)#exit
Exiting the OSPF process
(config)#router bgp 100
Configuring BGP process
(config-router)#neighbor 10.10.10.2 remote-as 200
Configuring neighbor details
(config-router)#commit
Commit the configuration
XC_node1
 
#configure terminal
Enter configure mode
(config)#hostname Xc Node-1
Configuring the hostname
(config)#coherent-module 7
Entering into coherent-module
(config-module)#enable
Enabling the coherent module
(config-module)#exit
Exiting the coherent module
(config)#interface ce29
Entering into interface level
(config-if)#switchport
Configuring switchport
(config-if)#exit
Exiting the interface level
(config)#interface ce11/1
Entering the interface level
(config-if)#switchport
Configuring the switchport
(config-if)#exit
Exiting the interface level
(config)#cross-connect OSPF_BFD_BGP
Configuring the Cross-connect
(config-XC)#ep1 ce11/1 ep2 ce29
Creating endpoints
(config-XC)#commit
Commit the configuration
XC_node2
 
#configure terminal
Enter configure mode
(config)#hostname Xc Node-2
Configuring the hostname
(config)#coherent-module 1
Entering into coherent-module
(config-module)#enable
Enabling the coherent module
(config-module)#exit
Exiting the coherent module
(config)#interface ce17
Entering into interface level
(config-if)#switchport
Configuring switchport
(config-if)#exit
Exiting the interface level
(config)#interface ce11/1
Entering the interface level
(config-if)#switchport
Configuring the switchport
(config-if)#exit
Exiting the interface level
(config)#cross-connect OSPF_BFD_BGP-1
Configuring the Cross-connect
(config-XC)#ep1 ce17 ep2 ce11/1
Creating endpoints
(config-XC)#commit
Commit the configuration
R2
 
#configure terminal
Enter configure mode
(config)#hostname R2
Configure the host name
(config)#interface xe49/1
Enter into interface level
(config-if)#ip address 10.10.10.2/24
Configure IP address to the interface
(config-if)#exit
Exiting from interface level
(config)#interface xe45
Enter into interface mode
(config-if)#ip address 30.30.30.1/24
Configure ip address to the interface
(config-if)#exit
Exiting from interface level
(config)#interface lo
Enter into loop-back interface
(config-if)#ip address 2.2.2.2/24 secondary
Configuring secondary IP address
(config-if)#exit
Exiting the loop-back interface level
(config)#bfd interval 3 minrx 3 multiplier 3
Configuring BFD options
(config)#router ospf 10
Configuring OSPF process
(config-router)#router-id 2.2.2.2
Configuring router-id
(config-router)#network 10.10.10.0 0.0.0.255 area 0
Configuring Network id and Area ID
(config-router)#redistribute connected
Configuring redistribute connected
(config-router)#bfd all-interfaces
Configuring bfd on all-interfaces
(config-router)#exit
Exiting the OSPF process
(config)#router bgp 200
Configuring BGP process
(config-router)#neighbor 10.10.10.1 remote-as 100
Configuring neighbor details
(config-router)#commit
Commit the configuration
Validation
Coherent-module Summary Validation
XC_node1#show coherent-module 7
---------------------------------------------------------------
SLOT-ID : 7
---------------------------------------------------------------
Module Type : DCO
Admin-Status : UP
Oper-Status : Ready
Vendor-name : Acacia Comm Inc.
Vendor-SN : 203066225
Vendor-FW-Version : 38.5
Network-Interfaces : 1
Host-Interfaces : 2
CFP2 Vendor-name : Acacia Comm Inc.
CFP2 Vendor-OUI : 0x0
CFP2 Vendor-Part : AC200-D23-005
CFP2 Vendor-SN : 203066225
CFP2 Vendor-FW-Version : 38.5
CFP2 Temperature : 48.60 °C
CFP2 Power Supply : 3.322 V
 
---------------------------------------------------------------
SLOT-ID : 7 NETIF : 0
---------------------------------------------------------------
OperStatus : ready
DSP-OperStatus : ready
Modulation-format : dp-16-qam
FEC Mode : 15per-denali
Differential Encoding : FALSE
Pulseshaping-Rx :
Pulseshaping-Tx : TRUE
Loopback-type : none
PRBS-type : none
Losi-Enabled :
PRBS-IN-SYNC : FALSE
Current PRBS BER : nan
Current BER Period : 1000 ms
Current PRE FEC BER : 1.115706e-03
Current POST FEC BER :
Current Chromatic Dispersion : -1 ps/nm
Current Differential Group Delay : 3 ps
Tx-Disable : FALSE
TX-Output-Power : 0.00 dBm
TX-Laser-freq : 193500000.000000 MHz
Min-LaserFreq : 191250000.000000 MHz
Max-LaserFreq : 196100000.000000 MHz
Current TX Laser Freq : 193500000.000000 MHz
Grid-Spacing : 6.25-ghz
Laser-Grid : 50-ghz 12.5-ghz 6.25-ghz
Current Output Power : 0.04 dBm
Current Input Power : -4.36 dBm
Current Post VOA Power :
Current Prov~ Chnl Power : -3.78 dBm
Current Post VOA Prov~ Chnl Power : -3.78 dBm
Current OSNR Estimate : 34.30 dB
Current Q-Margin : 2.80 dB
Current Uncorrected Block-count : 0
Laser Age : 0 %
 
---------------------------------------------------------------
SLOT-ID : 7 HOSTIF : 0
---------------------------------------------------------------
Fec-type : none
Loopback-type : none
Current PRE FEC BER : nan
---------------------------------------------------------------
SLOT-ID : 7 HOSTIF : 1
---------------------------------------------------------------
Fec-type : none
Loopback-type : none
Current PRE FEC BER : nan
 
XC_node2#sh coherent-module 1
---------------------------------------------------------------
SLOT-ID : 1
---------------------------------------------------------------
Module Type : DCO
Admin-Status : UP
Oper-Status : Ready
Vendor-name : LUMENTUM
Vendor-SN : VCD19310002
Vendor-FW-Version : 0.52
Network-Interfaces : 1
Host-Interfaces : 2
CFP2 Vendor-name : LUMENTUM
CFP2 Vendor-OUI : 0xF00200
CFP2 Vendor-Part : TRB200DAA-01
CFP2 Vendor-SN : VCD19310002
CFP2 Vendor-FW-Version : 0.52
CFP2 Temperature : 69.02 °C
CFP2 Power Supply : 3.340 V
 
---------------------------------------------------------------
SLOT-ID : 1 NETIF : 0
---------------------------------------------------------------
OperStatus : ready
DSP-OperStatus : ready
Modulation-format : dp-16-qam
FEC Mode : 15per-denali
Differential Encoding : FALSE
Pulseshaping-Rx :
Pulseshaping-Tx : TRUE
Loopback-type : none
PRBS-type : none
Losi-Enabled :
PRBS-IN-SYNC : FALSE
Current PRBS BER : nan
Current BER Period : 1000 ms
Current PRE FEC BER : 4.560457e-04
Current POST FEC BER :
Current Chromatic Dispersion : 5 ps/nm
Current Differential Group Delay : 6 ps
Tx-Disable : FALSE
TX-Output-Power : 0.00 dBm
TX-Laser-freq : 193500000.000000 MHz
Min-LaserFreq : 191150000.000000 MHz
Max-LaserFreq : 196100000.000000 MHz
Current TX Laser Freq : 193500000.000000 MHz
Grid-Spacing : 6.25-ghz
Laser-Grid : 100-ghz 50-ghz 25-ghz 12.5-ghz 6.25-ghz
Current Output Power : -0.18 dBm
Current Input Power : -1.79 dBm
Current Post VOA Power :
Current Prov~ Chnl Power : -2.44 dBm
Current Post VOA Prov~ Chnl Power : -2.44 dBm
Current OSNR Estimate : 25.00 dB
Current Q-Margin : 3.50 dB
Current Uncorrected Block-count : 0
Laser Age : 0 %
 
---------------------------------------------------------------
SLOT-ID : 1 HOSTIF : 0
---------------------------------------------------------------
Fec-type : none
Loopback-type : none
Current PRE FEC BER : nan
---------------------------------------------------------------
SLOT-ID : 1 HOSTIF : 1
---------------------------------------------------------------
Fec-type : none
Loopback-type : none
Current PRE FEC BER : nan
 
XC_node2#sh run interface ce17
!
interface ce17
!
Cross-Connect Validation
XC_node1# sh cross-connect
Codes: EP - Endpoint, Bkp_EP - Backup endpoint
* - Active Endpoint, none - not configured Cross-connect name : OSPF_BFD_BGP
EP1:ce11/1 EP2:ce29 Revertive:No Bkp_EP1:None Bkp_EP2:None Admin Status:UP Oper Status:UP
+======================================================================================
============================+
| EP | OVID | IVID | Rx packets | Rx bytes | Tx packets |Tx bytes
|Interface Status|
+======================================================================================
============================+
| EP1*
|UP | -
| | - |0 |0 |0 |0
| EP2*
|UP | -
| | - |0 |0 |0 |0
+======================================================================================
============================+
cross-connect summary Total XC : 1
Admin Up : 1
Admin Down : 0
Total Rules : 1
 
XC_node1#show running-config cross-connect
cross-connect OSPF_BFD_BGP
ep1 ce11/1 ep2 ce29
 
XC_node2# sh cross-connect
Codes: EP - Endpoint, Bkp_EP - Backup endpoint
* - Active Endpoint, none - not configured Cross-connect name : OSPF_BFD_BGP-1
EP1:ce17 EP2:ce11/1 Revertive:No Bkp_EP1:None Bkp_EP2:None Admin Status:UP Oper Status:UP
+======================================================================================
============================+
| EP | OVID | IVID | Rx packets | Rx bytes | Tx packets |Tx bytes
|Interface Status|
+======================================================================================
============================+
| EP1*
|UP | -
| | - |0 |0 |0 |0
| EP2*
|UP | -
| | - |0 |0 |0 |0
+======================================================================================
============================+
cross-connect summary Total XC : 1
Admin Up : 1
Admin Down : 0
Total Rules : 1
 
XC_node2#show running-config cross-connect
cross-connect OSPF_BFD_BGP-1
ep1 ce17 ep2 ce11/1
OSPF Validation
R1#show ip ospf neighbor
 
Total number of full neighbors: 1
OSPF process 10 VRF(default):
Neighbor ID Pri State Dead Time Address Interface
Instance ID
2.2.2.2 1 Full/Backup 00:00:37 10.10.10.2 xe1/1
0
 
R2#show ip ospf neighbor
Total number of full neighbors: 1
OSPF process 10 VRF(default):
Neighbor ID Pri State Dead Time Address Interface
Instance ID
1.1.1.1 1 Full/Backup 00:00:38 10.10.10.1 xe49/1
0
BFD Validation
R1#show bfd interface xe1/1
Interface: xe1/1 ifindex: 10001 state: UP
Interface level configuration: NO ECHO, NO SLOW TMR
Min Tx: 3 Min Rx: 3 Multiplier: 3
 
R1#show bfd session
 
BFD process for VRF: (DEFAULT VRF)
================================================================================
=====
Sess-Idx Remote-Disc Lower-Layer Sess-Type Sess-State UP-Time Interface
Down-Reason Remote-Addr
1 1 IPv4 Single-Hop Up 00:02:54 xe1/1
NA 10.10.10.2/32
Number of Sessions: 1
 
R1#show bfd session
 
BFD process for VRF: (DEFAULT VRF)
================================================================================
=====
Sess-Idx Remote-Disc Lower-Layer Sess-Type Sess-State UP-Time Interface
Down-Reason Remote-Addr
1 1 IPv4 Single-Hop Up 00:02:54 xe1/1
NA 10.10.10.2/32
Number of Sessions: 1
 
R1#show bfd session detail
 
BFD process for VRF: (DEFAULT VRF)
================================================================================
====
 
Session Interface Index : 10001 Interface name :xe1/1
Session Index : 1
Lower Layer : IPv4 Version : 1
Session Type : Single Hop Session State : Up
Local Discriminator : 1 Local Address : 10.10.10.1/32
Remote Discriminator : 1 Remote Address : 10.10.10.2/32
Local Port : 49152 Remote Port : 3784
Options :
 
Diagnostics : None
 
Timers in Milliseconds :
Min Tx: 3 Min Rx: 3 Multiplier: 3
Neg Tx: 3 Neg Rx: 3 Neg detect mult: 3
Min echo Tx: 1000 Min echo Rx: 1000 Neg echo intrvl: 0
Storage type : 2
Sess down time : 00:00:00
Sess Down Reason : NA
Bfd GTSM Disabled
Bfd Authentication Disabled
 
Counters values:
Pkt In : 00000000000000117138 Pkt Out : 00000000000000117172
Pkts Drop : 00000000000000000000 Auth Pkts Drop : 00000000000000000000
Echo Out : 00000000000000000000 IPv6 Echo Out : 00000000000000000000
IPv6 Pkt In : 00000000000000000000 IPv6 Pkt Out : 00000000000000000000
UP Count : 1 UPTIME : 00:05:42
 
Protocol Client Info:
OSPF-> Client ID: 4 Flags: 4
----------------------------------------------------------
Number of Sessions: 1
 
R2#show bfd interface xe49/1
Interface: xe49/1 ifindex: 10049 state: UP
Interface level configuration: NO ECHO, NO SLOW TMR
Min Tx: 3 Min Rx: 3 Multiplier: 3
 
R2#show bfd session
 
BFD process for VRF: (DEFAULT VRF)
================================================================================
=====
Sess-Idx Remote-Disc Lower-Layer Sess-Type Sess-State UP-Time Interface
Down-Reason Remote-Addr
1 1 IPv4 Single-Hop Up 00:04:12 xe49/1
NA 10.10.10.1/32
Number of Sessions: 1
 
R2#sh bfd session detail
 
BFD process for VRF: (DEFAULT VRF)
================================================================================
====
 
Session Interface Index : 10049 Interface name :xe49/1
Session Index : 1
Lower Layer : IPv4 Version : 1
Session Type : Single Hop Session State : Up
Local Discriminator : 1 Local Address : 10.10.10.2/32
Remote Discriminator : 1 Remote Address : 10.10.10.1/32
Local Port : 49152 Remote Port : 3784
Options :
 
Diagnostics : None
 
Timers in Milliseconds :
Min Tx: 3 Min Rx: 3 Multiplier: 3
Neg Tx: 3 Neg Rx: 3 Neg detect mult: 3
Min echo Tx: 1000 Min echo Rx: 1000 Neg echo intrvl: 0
Storage type : 2
Sess down time : 00:00:00
Sess Down Reason : NA
Bfd GTSM Disabled
Bfd Authentication Disabled
 
Counters values:
Pkt In : 00000000000000044905 Pkt Out : 00000000000000044905
Pkts Drop : 00000000000000000000 Auth Pkts Drop : 00000000000000000000
Echo Out : 00000000000000000000 IPv6 Echo Out : 00000000000000000000
IPv6 Pkt In : 00000000000000000000 IPv6 Pkt Out : 00000000000000000000
UP Count : 1 UPTIME : 00:02:11
 
Protocol Client Info:
OSPF-> Client ID: 4 Flags: 4
----------------------------------------------------------
Number of Sessions: 1
BGP Vaildation
R1#sh bgp neighbors
BGP neighbor is 10.10.10.2, remote AS 200, local AS 100, external link
BGP version 4, local router ID 10.10.10.1, remote router ID 2.2.2.2
BGP state = Established, up for 00:04:00
Last read 00:00:08, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Received 11 messages, 0 notifications, 0 in queue
Sent 12 messages, 0 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 30 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
Connections established 1; dropped 0
Local host: 10.10.10.1, Local port: 179
Foreign host: 10.10.10.2, Foreign port: 58033
Nexthop: 10.10.10.1
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
 
R2#sh ip bgp neighbors
BGP neighbor is 10.10.10.1, remote AS 100, local AS 200, external link
BGP version 4, local router ID 2.2.2.2, remote router ID 10.10.10.1
BGP state = Established, up for 00:00:03
Last read 00:00:03, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Received 2 messages, 0 notifications, 0 in queue
Sent 2 messages, 0 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 30 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 1, Offset 0, Mask 0x2
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
Connections established 1; dropped 0
Local host: 10.10.10.2, Local port: 58033
Foreign host: 10.10.10.1, Foreign port: 179
Nexthop: 10.10.10.2
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
Show interface counters
R1#sh interface counters rate gbps
+-------------------+--------------+-------------+--------------+-------------+
| Interface | Rx gbps | Rx pps | Tx gbps | Tx pps |
+-------------------+--------------+-------------+--------------+-------------+
xe1/1 6.91 13082945 6.91 13082949
xe32/1 6.91 13082325 6.91 13082325
 
XC_node1#sh interface counters rate gbps
+-------------------+--------------+-------------+--------------+-------------+
| Interface | Rx gbps | Rx pps | Tx gbps | Tx pps |
+-------------------+--------------+-------------+--------------+-------------+
ce11/1 6.91 13082437 6.91 13082437
ce29 6.91 13082457 6.91 13082458
 
XC_node1# sh cross-connect
Codes: EP - Endpoint, Bkp_EP - Backup endpoint
* - Active Endpoint, none - not configured Cross-connect name : OSPF_BFD_BGP
EP1:ce11/1 EP2:ce29 Revertive:No Bkp_EP1:None Bkp_EP2:None Admin Status:UP Oper Status:UP
+======================================================================================
============================+
| EP | OVID | IVID | Rx packets | Rx bytes | Tx packets |Tx bytes
|Interface Status|
+======================================================================================
============================+
| EP1*
|UP | -
| | - |13082437 |1674551936 |13082437 |1674551936
| EP2*
|UP | -
| | - |13082457 |1674554496 |13082457 |1674554496
+======================================================================================
============================+
cross-connect summary Total XC : 1
Admin Up : 1
Admin Down : 0
Total Rules : 1
 
XC_node2#sh interface counters rate gbps
+-------------------+--------------+-------------+--------------+-------------+
| Interface | Rx gbps | Rx pps | Tx gbps | Tx pps |
+-------------------+--------------+-------------+--------------+-------------+
ce11/1 6.91 13082428 6.91 13082429
ce17 6.91 13082381 6.91 13082378
 
XC_node2# sh cross-connect
Codes: EP - Endpoint, Bkp_EP - Backup endpoint
* - Active Endpoint, none - not configured Cross-connect name : OSPF_BFD_BGP-1
EP1:ce17 EP2:ce11/1 Revertive:No Bkp_EP1:None Bkp_EP2:None Admin Status:UP Oper Status:UP
+======================================================================================
============================+
| EP | OVID | IVID | Rx packets | Rx bytes | Tx packets |Tx bytes
|Interface Status|
+======================================================================================
============================+
| EP1*
|UP | -
| | - |13082428 |1674550784 |13082429 |1674550784
| EP2*
|UP | -
| | - |13082381 |1674544768 |13082381 |1674544768
+======================================================================================
============================+
cross-connect summary Total XC : 1
Admin Up : 1
Admin Down : 0
Total Rules : 1
 
 
 
 
 
R2#sh interface counters rate gbps
+-------------------+--------------+-------------+--------------+-------------+
| Interface | Rx gbps | Rx pps | Tx gbps | Tx pps |
+-------------------+--------------+-------------+--------------+-------------+
xe45 6.91 13081988 6.91 13081988
xe49/1 6.91 13082339 6.91 13082339
Cross-connect using Dynamic/Static LAG
The following configuration example illustrates configuration of cross-connect using LAG interfaces on XC Nodes.
Topology
 
Cross-connect using LAG Interfaces
R1
 
#configure terminal
Enter configure mode
(config)#interface po100
Create Port channel interface
(config-if)#exit
Exiting from interface level
(config)#interface xe1/1
Enter into interface mode
(config-if)#channel-group 100 mode active
Adding member port to the port channel interface
(config-if)#exit
Exiting from interface level
(config)#interface xe1/2
Enter into interface level
(config-if)#channel-group 100 mode active
Adding member port to the port channel interface
(config-if)#commit
Commit the configuration
XC_node1
 
#configure terminal
Enter configure mode
(config)#interface po100
Create Port channel interface
(config-if)#switchport
Configuring Switchport to the interface
(config-if)#exit
Exiting from interface level
(config)#interface po200
Create Port channel interface
(config-if)#switchport
Configuring Switchport to the interface
(config-if)#exit
Exiting from interface level
(config)#interface ce11/1
Enter into interface level
(config-if)#channel-group 100 mode active
Adding member port to the port channel interface
(config-if)#exit
Exiting from interface level
(config)#interface ce11/2
Enter into interface level
(config-if)#channel-group 100 mode active
Adding member port to the port channel interface
(config-if)#exit
Exiting from interface level
(config)#interface ce29
Enter into interface level
(config-if)#channel-group 200 mode active
Adding member port to the port channel interface
(config-if)#exit
Exiting from interface level
(config)#interface ce30
Enter into interface level
(config-if)#channel-group 200 mode active
Adding member port to the port channel interface
(config-if)#exit
Exiting from interface level
(config)#cross-connect lag
Create cross-connect by providing the name
(config-XC)#ep1 po100 ep2 po200
Adding end-points ep1 and ep2 as lag interfaces
(config-XC)#exit
Exit Cross-connect mode
(config)#commit
Commit the configuration
XC_node2
 
#configure terminal
Enter configure mode
(config)#interface po200
Create Port channel interface
(config-if)#switchport
Configuring Switchport to the interface
(config-if)#exit
Exiting from interface level
(config)#interface ce29
Enter into interface level
(config-if)#channel-group 200 mode active
Adding member port to the port channel interface
(config-if)#exit
Exiting from interface level
(config)#interface ce30
Enter into interface level
(config-if)#channel-group 200 mode active
Adding member port to the port channel interface
(config-if)#exit
Exiting from interface level
(config)#interface ce11/1
Enter into interface level
(config-if)#switchport
Configuring Switchport to the interface
(config-if)#exit
Exiting from interface level
(config)#cross-connect lag
Create cross-connect by providing the name
(config-XC)#ep1 po100 ep2 ce11/1
Adding end-points ep1 and ep2 as lag interfaces
(config-XC)#exit
Exit Cross-connect mode
(config)#commit
Commit the configuration
Validation
Cross-connect using Dynamic LAG on XC_node1
# sh cross-connect
Codes: EP - Endpoint, Bkp_EP - Backup endpoint
* - Active Endpoint, none - not configured Cross-connect name : lag
EP1:po100 EP2:po200 Revertive:No Bkp_EP1:None Bkp_EP2:None Admin Status:UP Oper Status:UP
+======================================================================================
============================+
| EP | OVID | IVID | Rx packets | Rx bytes | Tx packets |Tx bytes
|Interface Status|
+======================================================================================
============================+
| EP1*
|UP | -
| | - |0 |0 |0 |0
| EP2*
|UP | -
| | - |0 |0 |0 |0
+======================================================================================
============================+
cross-connect summary Total XC : 1
Admin Up : 1
Admin Down : 0
Total Rules : 1
 
#sh running-config cross-connect
!
cross-connect lag
ep1 po100 ep2 po200
!
 
#sh etherchannel summary
Aggregator po100 100100
Aggregator Type: Layer2
Admin Key: 0100 - Oper Key 0100
Link: ce11/1 (5073) sync: 1
Link: ce11/2 (5074) sync: 1
--------------------------------------
Aggregator po200 100200
Aggregator Type: Layer2
Admin Key: 0200 - Oper Key 0200
Link: ce30 (5005) sync: 1
Link: ce29 (5006) sync: 1
Cross-connect using Dynamic lag on XC_node2
# sh cross-connect
Codes: EP - Endpoint, Bkp_EP - Backup endpoint
* - Active Endpoint, none - not configured Cross-connect name : lag
EP1:po200 EP2:ce11/1 Revertive:No Bkp_EP1:None Bkp_EP2:None Admin Status:UP Oper Status:UP
+======================================================================================
============================+
| EP | OVID | IVID | Rx packets | Rx bytes | Tx packets |Tx bytes
|Interface Status|
+======================================================================================
============================+
| EP1*
|UP | -
| | - |0 |0 |0 |0
| EP2*
|UP | -
| | - |0 |0 |0 |0
+======================================================================================
============================+
cross-connect summary Total XC : 1
Admin Up : 1
Admin Down : 0
Total Rules : 1
 
#show running-config cross-connect
!
cross-connect lag
ep1 po200 ep2 ce11/1
 
#sh etherchannel summary
Aggregator po200 100200
Aggregator Type: Layer2
Admin Key: 0200 - Oper Key 0200
Link: ce18 (5009) sync: 1
Link: ce17 (5010) sync: 1
Configuring Cross-connect using Static LAG Interfaces
R1
 
#configure terminal
Enter configure mode
(config)#interface sa100
Create static LAG interface
(config-if)#exit
Exiting from interface level
(config)#interface xe1/1
Enter into interface mode
(config-if)#static-channel-group 100
Adding member port to the static LAG interface
(config-if)#exit
Exiting from interface level
(config)#interface xe1/2
Enter into interface level
(config-if)#static-channel-group 100
Adding member port to the static LAG interface
(config-if)#commit
Commit the configuration
XC_node1
 
#configure terminal
Enter configure mode
(config)#interface sa100
Create static LAG interface
(config-if)#switchport
Configuring Switchport to the interface
(config-if)#exit
Exiting from interface level
(config)#interface sa200
Create static LAG interface
(config-if)#switchport
Configuring Switchport to the interface
(config-if)#exit
Exiting from interface level
(config)#interface ce11/1
Enter into interface level
(config-if)#static-channel-group 100
Adding member port to the static LAG interface
(config-if)#exit
Exiting from interface level
(config)#interface ce11/2
Enter into interface level
(config-if)#static-channel-group 100
Adding member port to the static LAG interface
(config-if)#exit
Exiting from interface level
(config)#interface ce29
Enter into interface level
(config-if)#static-channel-group 200
Adding member port to the static LAG interface
(config-if)#exit
Exiting from interface level
(config)#interface ce30
Enter into interface level
(config-if)#static-channel-group 200
Adding member port to the static LAG interface
(config-if)#exit
Exiting from interface level
(config)#cross-connect static-lag
Create cross-connect by providing the name
(config-XC)#ep1 sa100 ep2 sa200
Adding end-points ep1 and ep2 as lag interfaces
(config-XC)#exit
Exit Cross-connect mode
(config)#commit
Commit the configuration
XC_node2
 
#configure terminal
Enter configure mode
(config)#interface sa200
Create static LAG interface
(config-if)#switchport
Configuring Switchport to the interface
(config-if)#exit
Exiting from interface level
(config)#interface ce29
Enter into interface level
(config-if)#static-channel-group 200
Adding member port to the static LAG interface
(config-if)#exit
Exiting from interface level
(config)#interface ce30
Enter into interface level
(config-if)#static-channel-group 200
Adding member port to the static LAG interface
(config-if)#exit
Exiting from interface level
(config)#interface ce11/1
Enter into interface level
(config-if)#switchport
Configure switchport to the interface
(config-if)#exit
Exiting from interface level
(config)#cross-connect static-lag
Create cross-connect by providing the name
(config-XC)#ep1 po200 ep2 ce11/1
Adding end-points ep1 and ep2 as lag interfaces
(config-XC)#exit
Exit Cross-connect mode
(config)#commit
Commit the configuration
Validation
Cross-connect using Static LAG on XC_node1
#sh cross-connect
Codes: EP - Endpoint, Bkp_EP - Backup endpoint
* - Active Endpoint, none - not configured Cross-connect name : static-lag
EP1:sa100 EP2:sa200 Revertive:No Bkp_EP1:None Bkp_EP2:None Admin Status:UP Oper Status:UP
+======================================================================================
============================+
| EP | OVID | IVID | Rx packets | Rx bytes | Tx packets |Tx bytes
|Interface Status|
+======================================================================================
============================+
| EP1*
|UP | -
| | - |0 |0 |0 |0
| EP2*
|UP | -
| | - |0 |0 |0 |0
+======================================================================================
============================+
cross-connect summary Total XC : 1
Admin Up : 1
Admin Down : 0
Total Rules : 1
Cross-connect using Static Lag on XC_node2
# sh cross-connect
Codes: EP - Endpoint, Bkp_EP - Backup endpoint
* - Active Endpoint, none - not configured Cross-connect name : static-lag
EP1:sa200 EP2:ce11/1 Revertive:No Bkp_EP1:None Bkp_EP2:None Admin Status:UP Oper Status:UP
+======================================================================================
============================+
| EP | OVID | IVID | Rx packets | Rx bytes | Tx packets |Tx bytes
|Interface Status|
+======================================================================================
============================+
| EP1*
|UP | -
| | - |0 |0 |0 |0
| EP2*
|UP | -
| | - |0 |0 |0 |0
+======================================================================================
============================+
cross-connect summary Total XC : 1
Admin Up : 1
Admin Down : 0
Total Rules : 1
Disable Cross-connect on XC_node1
 
#configure terminal
Enter configure mode
(config)#cross-connect lag
Create cross-connect by providing the name
(config-XC)#disable
Disabling the Cross-connect
(config-XC)#exit
Exit Cross-connect mode
(config)#commit
Commit the configuration
Validation
Disable the cross-connect on XC node1
# sh cross-connect
Codes: EP - Endpoint, Bkp_EP - Backup endpoint
* - Active Endpoint, none - not configured Cross-connect name : lag
EP1:po100 EP2:po200 Revertive:No Bkp_EP1:None Bkp_EP2:None Admin Status:DOWN Oper Status:DOWN
+======================================================================================
============================+
| EP | OVID | IVID | Rx packets | Rx bytes | Tx packets |Tx bytes
|Interface Status|
+======================================================================================
============================+
| EP1*
|UP | -
| | - |13082428 |1674550784 |13082429 |1674550784
| EP2*
|UP | -
| | - |13082381 |1674544768 |13082381 |1674544768
+======================================================================================
============================+
cross-connect summary Total XC : 1
Admin Up : 0 Admin Down : 1 Total Rules : 0
Enable Cross-connect on XC_node1
 
#configure terminal
Enter configure mode
(config)#cross-connect lag
Create cross-connect by providing the name
(config-XC)#no disable
Enable the Cross-connect
(config-XC)#exit
Exit Cross-connect mode
(config)#commit
Commit the configuration
Validation
Cross-connect after enable on XC_node1
# sh cross-connect
Codes: EP - Endpoint, Bkp_EP - Backup endpoint
* - Active Endpoint, none - not configured Cross-connect name : lag
EP1:po100 EP2:po200 Revertive:No Bkp_EP1:None Bkp_EP2:None Admin Status:UP Oper Status:UP
+======================================================================================
============================+
| EP | OVID | IVID | Rx packets | Rx bytes | Tx packets |Tx bytes
|Interface Status|
+======================================================================================
============================+
| EP1*
|UP | -
| | - |13082428 |1674550784 |13082429 |1674550784
| EP2*
|UP | -
| | - |13082381 |1674544768 |13082381 |1674544768
+======================================================================================
============================+
cross-connect summary Total XC : 1
Admin Up : 1 Admin Down : 0 Total Rules : 1