OcNOS-RON : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : MPLS Statistics Configuration
MPLS Statistics Configuration
This chapter provides the configuration required for configuring MPLS LSPs and verifying the statistics of packets captured at the supported interfaces, in terms of both packet count and bytes, when traffic is sent.
Configure LDP-LSP
Topology
MPLS Statistics Topology
RTR1
Loopback Interface configuration
 
#configure terminal
Enter configure mode.
(config)#interface lo
Specify the interface (lo) to be configured.
(config-if)#ip address 11.11.11.11/32 secondary
Configure IP address on loopback interface
(config-if)#exit
Exit interface mode.
Global LDP configuration
 
(config)#router ldp
Enter Router mode for LDP.
(config-router)#transport-address ipv4 11.11.11.11
Configure the loopback address as transport-address
(config-router)#targeted-peer ipv4 44.44.44.44
Configure the loopback address of RTR4 as targeted peer.
(config-router-targeted-peer)#exit
Exit router-targeted-peer mode and enter config-router mode
(config-router)#end
Exit router and configure mode
Enabling LDP and label switching on interface
 
#configure terminal
Enter configure mode.
(config)#interface eth2
Enter interface mode for eth2.
(config-if)#enable-ldp ipv4
Enable LDP on the interface.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#ip address 10.10.10.1/24
Configure IP address on the interface.
(config-if)#exit
Exit interface mode.
Global OSPF configuration
 
(config)#router ospf 100
Enter the Router OSPF mode.
(config-router)#network 11.11.11.11/32 area 0
Advertise loopback address in OSPF.
(config-router)#network 10.10.10.0/24 area 0
Advertise network address (eth2) in OSPF.
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
RTR2
Loopback Interface configuration
 
#configure terminal
Enter configure mode.
(config)#interface lo
Specify the interface (lo) to be configured.
(config-if)#ip address 22.22.22.22/32 secondary
Configure IP address on loopback interface
(config-if)#exit
Exit interface mode.
Global LDP configuration
 
(config)#router ldp
Enter Router mode for LDP.
(config-router)#transport-address ipv4 22.22.22.22
Configure the loopback address as transport-address
(config-router)#end
Exit router and configure mode
Enabling LDP and label switching on interface
 
#configure terminal
Enter configure mode.
(config)#interface eth1
Enter interface mode for eth1.
(config-if)#enable-ldp ipv4
Enable LDP on the interface.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#ip address 10.10.10.2/24
Configure IP address on the interface.
(config-if)#exit
Exit interface mode.
(config)#interface eth2
Enter interface mode for eth2.
(config-if)#enable-ldp ipv4
Enable LDP on the interface.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#ip address 20.20.20.1/24
Configure IP address on the interface.
(config-if)#exit
Exit interface mode.
OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode
(config-router)#network 22.22.22.22/32 area 0.0.0.0
Advertise loopback address in OSPF
(config-router)#network 10.10.10.2/24 area 0.0.0.0
Advertise network address (eth1) in OSPF.
(config-router)#network 20.20.20.1/24 area 0.0.0.0
Advertise network address (eth2) in OSPF.
(config-router)#exit
Exit OSPF router configuration mode.
RTR3
Loopback Interface configuration
 
#configure terminal
Enter configure mode.
(config)#interface lo
Specify the interface (lo) to be configured.
(config-if)#ip address 33.33.33.33/32 secondary
Configure IP address on loopback interface
(config-if)#exit
Exit interface mode.
Global LDP configuration
 
(config)#router ldp
Enter Router mode for LDP.
(config-router)#transport-address ipv4 33.33.33.33
Configure the loopback address as transport-address
(config-router)#end
Exit router and configure mode
Enabling LDP and label switching on interface
 
#configure terminal
Enter configure mode.
(config)#interface eth1
Enter interface mode for eth1.
(config-if)#enable-ldp ipv4
Enable LDP on the interface.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#ip address 20.20.20.2/24
Configure IP address on the interface.
(config-if)#exit
Exit interface mode.
(config)#interface eth2
Enter interface mode for eth2.
(config-if)#enable-ldp ipv4
Enable LDP on the interface.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#ip address 30.30.30.1/24
Configure IP address on the interface.
(config-if)#exit
Exit interface mode.
OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode
(config-router)#network 33.33.33.33/32 area 0.0.0.0
Advertise loopback address in OSPF
(config-router)#network 20.20.20.2/24 area 0.0.0.0
Advertise network address (eth1) in OSPF.
(config-router)#network 30.30.30.1/24 area 0.0.0.0
Advertise network address (eth2) in OSPF.
(config-router)#exit
Exit OSPF router configuration mode.
RTR4
Loopback Interface configuration
 
#configure terminal
Enter configure mode.
(config)#interface lo
Specify the interface (lo) to be configured.
(config-if)#ip address 44.44.44.44/32 secondary
Configure IP address on loopback interface
(config-if)#exit
Exit interface mode.
Global LDP configuration
 
(config)#router ldp
Enter Router mode for LDP.
(config-router)#transport-address ipv4 44.44.44.44
Configure the loopback address as transport-address
(config-router)#targeted-peer ipv4 11.11.11.11
Configure the loopback address of RTR1 as targeted peer.
(config-router-targeted-peer)#exit
Exit router-targeted-peer mode and enter config-router mode
(config-router)#end
Exit router and configure mode
Enabling LDP and label switching on interface
 
#configure terminal
Enter configure mode.
(config)#interface eth1
Enter interface mode for eth1.
(config-if)#enable-ldp ipv4
Enable LDP on the interface.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#ip address 30.30.30.2/24
Configure IP address on the interface.
(config-if)#exit
Exit interface mode.
Global OSPF Configuration
 
(config)#router ospf 100
Enter the Router OSPF mode
(config-router)#network 44.44.44.44/32 area 0.0.0.0
Advertise loopback address in OSPF
(config-router)#network 30.30.30.2/24 area 0.0.0.0
Advertise network address (eth1) in OSPF.
(config-router)#exit
Exit OSPF router configuration mode.
Virtual Circuit Configuration
RTR1
Global VC Configuration
 
(config)#mpls l2-circuit t1 100 44.44.44.44
Enter the VC configuration command in router mode.
(config)#bridge 1 protocol ieee vlan-bridge
Creating a VLAN-bridge in router mode.
Interface Configuration
 
(config)#service-template st1
Template configuration
(config-svc)#exit
Exit service template configuration
(config)#interface eth1
Enter interface mode for eth1.
(config-if)#switchport
Enable switchport on the interface.
(config-if)#mpls-l2-circuit t1 service-template st1
Bind the interface to VC created in ethernet mode.
(config-if)#exit
Exit interface mode.
RTR4
Global VC Configuration
 
(config)#mpls l2-circuit t1 100 11.11.11.11
Enter the VC configuration command in router mode.
(config)#bridge 1 protocol ieee vlan-bridge
Creating a VLAN-bridge in router mode.
Interface Configuration
 
(config)#service-template st1
Template configuration
(config-svc)#exit
Exit service template mode
(config)#interface eth2
Enter interface mode for eth2.
(config-if)#switchport
Enable switchport on the interface.
(config-if)#mpls-l2-circuit t1 service-template st1
Bind the interface to VC created in ethernet mode.
(config-if)#exit
Exit interface mode.
Configure Static-LSP
RTR1
Global Static configuration
 
(config)#mpls ftn-entry 44.44.44.44/32 100 10.10.10.2 eth2
Configure FTN entry for rtr4 loopback.
(config)#mpls ilm-entry 900 pop
Pop the incoming label
Enabling label switching on interface
 
(config)#interface eth2
Enter interface mode for eth2.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#exit
Exit interface mode.
RTR2
Global Static configuration
 
mpls ilm-entry 100 swap 200 eth2 20.20.20.2 44.44.44.44/32
Swap the incoming label
mpls ilm-entry 800 swap 900 eth1 10.10.10.1 11.11.11.11/32
Swap the incoming label
Enabling label switching on interface
 
(config)#interface eth1
Enter interface mode for eth1.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#exit
Exit interface mode.
(config)#interface eth2
Enter interface mode for eth2.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#exit
Exit interface mode.
RTR3
Global Static configuration
 
(config)#mpls ilm-entry 200 swap 300 eth2 30.30.30.2 44.44.44.44/32
Swap the incoming label
(config)#mpls ilm-entry 700 swap 800 eth1 20.20.20.1 11.11.11.11/32
Swap the incoming label
Enabling label switching on interface
 
(config)#interface eth1
Enter interface mode for eth1.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#exit
Exit interface mode.
(config)#interface eth2
Enter interface mode for eth2.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#exit
Exit interface mode.
RTR4
Global Static configuration
 
(config)#mpls ftn-entry 11.11.11.11/32 700 30.30.30.1 eth1
Configure FTN entry for RTR1 loopback.
(config)mpls ilm-entry 300 pop
Pop the incoming label.
Enabling label switching on interface
 
(config)#interface eth1
Enter interface mode for eth1.
(config-if)#label-switching
Enable Label switching on the interface.
(config-if)#exit
Exit interface mode.
Validation
Here, 1000 packets are transmitted between the PE nodes and the output of counters at each node is mentioned below.
For Static-LSP
RTR1#show mpls counters static
[FTN statistics]
+------------------+-----------+--------------------+--------------------+
| FEC | out-label | Tx packets | Tx bytes |
+------------------+-----------+--------------------+--------------------+
44.44.44.44/32 100 49939 807798
[ILM statistics]
+------------------+-----------+-----------+--------------------+--------------------+--------------------+--------------------+
| FEC | in-label | out-label | Rx packets | Rx bytes | Tx packets | Tx bytes |
+------------------+-----------+-----------+--------------------+--------------------+--------------------+--------------------+
0.0.0.0/0 900 n/a 40546 3486956 n/a n/a
RTR1#
 
 
RTR2#show mpls counters static
[FTN statistics]
+------------------+-----------+--------------------+--------------------+
| FEC | out-label | Tx packets | Tx bytes |
+------------------+-----------+--------------------+--------------------+
 
[ILM statistics]
+------------------+-----------+-----------+--------------------+---------------
-----+--------------------+--------------------+
| FEC | in-label | out-label | Rx packets | Rx bytes
| Tx packets | Tx bytes |
+------------------+-----------+-----------+--------------------+---------------
-----+--------------------+--------------------+
44.44.44.44/32 100 200 9393 807798
9393 807798
11.11.11.11/32 800 900 40546 3486956
40546 3486956
RTR2#
 
 
RTR3#show mpls counters static
[FTN statistics]
+------------------+-----------+--------------------+--------------------+
| FEC | out-label | Tx packets | Tx bytes |
+------------------+-----------+--------------------+--------------------+
 
[ILM statistics]
+------------------+-----------+-----------+--------------------+--------------------+--------------------+--------------------+
| FEC | in-label | out-label | Rx packets | Rx bytes | Tx packets | Tx bytes |
+------------------+-----------+-----------+--------------------+--------------------+--------------------+--------------------+
44.44.44.44/32 200 300 9393 807798 9393 807798
11.11.11.11/32 700 800 40546 3486956 40546 3486956
RTR3#
 
 
RTR4#show mpls counters static
[FTN statistics]
+------------------+-----------+--------------------+--------------------+
| FEC | out-label | Tx packets | Tx bytes |
+------------------+-----------+--------------------+--------------------+
11.11.11.11/32 700 49939 3486956
 
[ILM statistics]
+------------------+-----------+-----------+--------------------+---------------
-----+--------------------+--------------------+
| FEC | in-label | out-label | Rx packets | Rx bytes
| Tx packets | Tx bytes |
+------------------+-----------+-----------+--------------------+---------------
-----+--------------------+--------------------+
0.0.0.0/0 300 n/a 9393 807798
n/a n/a
RTR4#
For LDP-LSP
RTR1#show mpls counters ldp
[FTN statistics]
+------------------+-----------+--------------------+--------------------+
| FEC | out-label | Tx packets | Tx bytes |
+------------------+-------------+------------------+--------------------+
44.44.44.44/32 52483 1000 1004000
[ILM statistics]
+-----+---------+-----------+------------+---------+-----------+---------+
| FEC |in-label | out-label | Rx packets | Rx bytes| Tx packets| Tx bytes|
+-----+---------+-----------+------------+---------+-----------+---------+
 
RTR2#show mpls counters ldp
[FTN statistics]
+------------------+-----------+--------------------+--------------------+
| FEC | out-label | Tx packets | Tx bytes |
+------------------+-----------+--------------------+--------------------+
[ILM statistics]
+-----+----------+-----------+------------+----------+------------+----------+
| FEC | in-label | out-label | Rx packets | Rx bytes | Tx packets | Tx bytes |
+-----+----------+-----------+------------+----------+------------+----------+
44.44.44.44/32 52483 52483 1000 1004000 1000 1004000
For LDP-VC
R1#show mpls l2-circuit t1 statistics
MPLS Layer-2 Virtual Circuit: t1, id 100
Access port statistics:
RX: Input packets : 0
Input bytes : 0
TX: Output packets : 4642811
Output bytes : 297139904
 
Network port statistics:
RX: Input packets : 4642804
Input bytes : 399281144
TX: Output packets : 0
Output bytes : 0
 
 
R4#show mpls l2-circuit t1 statistics
MPLS Layer-2 Virtual Circuit: t1, id 100
Access port statistics:
RX: Input packets : 4633957
Input bytes : 296573248
TX: Output packets : 0
Output bytes : 0
 
Network port statistics:
RX: Input packets : 0
Input bytes : 0
TX: Output packets : 4633960
Output bytes : 398520560