OcNOS-RON : Multi-Protocol Label Switching Guide : Multi-Protocol Label Switching Configuration Guide : Multi-Segment Pseudowire Configuration
Multi-Segment Pseudowire Configuration
This chapter contains configurations for Multi-Segment Pseudowires (MS-PW).
For details about the commands used, see the Label Distribution Protocol Command Reference.
Overview
An L2VPN (Layer 2 Virtual Private Network) multi-segment pseudowire (MS-PW), also called a switched PW, is a statically- or dynamically-configured set of two or more PW segments that function as a single PW. An MS-PW spans across multiple cores or autonomous systems of the same or different carrier networks.
Multi-segment pseudowires enable a service provider to extend the reach of pseudo-wires across multiple domains. The domains can be autonomous systems under one provider administrative control, IGP areas in one autonomous system, different autonomous systems under the administrative control of two or more service providers, or administratively established pseudowire domains.
The end routers are called terminating PE routers (T-PEs), and the switching routers are called S-PE routers. The S-PE router terminates the tunnels of the preceding and succeeding PW segments in an MS-PW.
The S-PE router switches the control and data planes of the preceding and succeeding PW segments of the MS-PW. An MS-PW is declared to be up when all the single-segment PWs are up.
This document contains the procedures required to accomplish the following tasks:
Configure signaled VCs (virtual circuits)
Configure static VCs
Add FIB entries for static VCs
Bind Layer 2 VC to physical interfaces (switchport)
Configure targeted LDP sessions and enable the pseudowire status TLV (pw-status-tlv)
Enable or Disable LDP and label-switching on interfaces
Stitch two VCs at an S-PE
Configure S-PE string descriptions
Display details of MS-PW associations on an S-PE
Display the stitching associations configured on an S-PE
Display the Status, Interface and Label associations for an MS-PW
Display the configuration of the S-PE for the LDP module.
Topology
MS-PW Configuration
 
Dynamic MS-PW
T-PE2
 
#configure terminal
Enter Configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ip add 30.30.30.55/24
Assign an IP address.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Enter Router OSPF mode.
(config-router)#network 4.5.6.7/32 a 0
Configure OSPF network.
(config-router)#network 30.30.30.0/24 a 0
Configure OSPF network.
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
(config)#router ldp
Enter Router LDP mode.
(config-router)#pw-status-tlv
Enable pw-status-tlv.
(config-router)#targeted-peer ipv4 3.4.5.6
Configure targeted-peer LDP session to S-PE2.
(config-router)#exit
Exit Router LDP mode and return to Configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#label-switching
Enable label-switching on the interface connected to S-PE.
(config-if)#enable-ldp ipv4
Enable LDP on the interface connected to S-PE.
(config-if)#exit
Exit interface mode.
(config)#mpls l2-circuit c3 300 3.4.5.6 passive
Configure dynamic-passive pseudowire.
(config-pseduowire)#exit
Exit pseudowire mode.
(config)#interface eth2
Enter interface mode.
(config-if)#switchport
Change eth2 to Layer 2 interface.
(config-if)#mpls-l2-circuit c3 ethernet
Bind the PW to the Layer 2 interface connected to CE router.
(config-if)#exit
Exit interface mode.
S-PE2
 
#configure terminal
Enter Configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ip add 20.20.20.54/24
Assign an IP address.
(config-if)#exit
Exit interface mode.
(config)#interface eth2
Enter interface mode.
(config-if)#ip add 30.30.30.54/24
Assign an IP address.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Enter Router OSPF mode.
(config-router)#network 3.4.5.6/32 a 0
Configure OSPF network.
(config-router)#network 20.20.20.0/24 a 0
Configure OSPF network.
(config-router)#network 30.30.30.0/24 a 0
Configure OSPF network.
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
(config)#router ldp
Enter Router LDP mode.
(config-router)#pw-status-tlv
Enable pw-status-tlv.
(config-router)#targeted-peer ipv4 4.5.6.7
Configure targeted-peer LPD session to T-PE2.
(config-router)#targeted-peer ipv4 2.3.4.5
Configure targeted-peer LDP session to S-PE1.
(config-router)#exit
Exit Router LDP mode and return to Configure mode.
(config)#mpls l2-circuit c3 300 4.5.6.7
Configure dynamic PW for circuit c3.
(config-pseduowire)#exit
Exit pseudowire mode.
(config)#mpls l2-circuit c2 200 2.3.4.5
Configure dynamic PW for circuit c2.
(config-pseduowire)#exit
Exit pseudowire mode.
(config)#mpls ms-pw-stitch sp2 c2 c3
Stitch the two PWs.
(config)#mpls ms-pw sp2 from-mpls-pc2-to-mpls-pc4
Configure S-PE description.
S-PE1
 
#configure terminal
Enter Configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ip add 10.10.10.53/24
Assign an IP address.
(config-if)#exit
Exit interface mode.
(config)#interface eth2
Enter interface mode.
(config-if)#ip add 20.20.20.52/24
Assign an IP address.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Enter Router OSPF mode.
(config-router)#network 2.3.4.5/32 a 0
Configure OSPF network.
(config-router)#network 10.10.10.0/24 a 0
Configure OSPF network.
(config-router)#network 20.20.20.0/24 a 0
Configure OSPF network.
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
(config)#router ldp
Enter Router LDP mode.
(config-router)#pw-status-tlv
Enable pw-status-tlv.
(config-router)#targeted-peer ipv4 3.4.5.6
Configure targeted-peer LDP session to S-PE2.
(config-router)#targeted-peer ipv4 1.2.3.4
Configure targeted-peer LDP session to T-PE1.
(config-router)#exit
Exit Router LDP mode and return to Configure mode.
(config)#mpls l2-circuit c2 200 3.4.5.6
Configure dynamic PW for circuit c2.
(config-pseduowire)#exit
Exit pseudowire mode.
(config)#mpls l2-circuit c1 100 1.2.3.4
Configure dynamic PW for circuit c1.
(config-pseduowire)#exit
Exit pseudowire mode.
(config)#mpls ms-pw-stitch sp2 c1 c2
Stitch the two pseudowires.
(config)#mpls ms-pw sp1 from-mpls-pc1-to-mpls-pc3
Configure S-PE description.
Static MS-PW
S-PE1
 
(config)#mpls l2-circuit c1 100 1.2.3.4 manual
Configure static pseudowire.
(config)#mpls ms-pw-stitch sp1 c1 c2 mtu 1500 ethernet
Stitch the two pseudowires, one of which is signaled and the other is manual.
(config)#mpls l2-circuit-fib-entry 100 101 201 1.2.3.4 eth3 c2
Add FIB entry for the static PW. c2 is the PW to which it has to be stitched at S-PE1.
T-PE1
 
#configure terminal
Enter Configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ip add 10.10.10.51/24
Assign IP address.
(config-if)#exit
Exit interface mode.
(config)#router ospf 100
Enter Router OSPF mode.
(config-router)#network 1.2.3.4/32 a 0
Configure OSPF network.
(config-router)#network 10.10.10.0/24 a 0
Configure OSPF network.
(config-router)#exit
Exit Router OSPF mode and return to Configure mode.
(config)#router ldp
Enter Router LDP mode
(config-router)#pw-status-tlv
Enable pw-status-tlv.
(config-router)#targeted-peer ipv4 2.3.4.5
Configure targeted-peer LDP session to S-PE1.
(config-router)#exit
Exit Router LDP mode and return to Configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#label-switching
Enable label-switching on the interface.
(config-if)#enable-ldp ipv4
Enable LDP on the interface.
(config-if)#exit
Exit interface mode.
(config)#mpls l2-circuit c1 100 2.3.4.5
Configure dynamic PW.
(config-pseduowire)#exit
Exit pseudowire mode.
(config)#interface eth2
Enter interface mode.
(config-if)#switchport
Configure eth2 as a Layer 2 interface.
(config-if)#mpls-l2-circuit c1 ethernet
Bind the PW to the Layer 2 interface connected to CE router.
(config-if)#exit
Exit interface mode.
T-PE1
 
(config)#mpls l2-circuit c1 100 2.3.4.5 manual
Configure static pseudowire.
(config)#mpls l2-circuit-fib-entry 100 201 101 2.3.4.5 eth1 eth2
Adding FIB entry for the static PW created, after binding it to the access interface (eth2).
Validation
Display LDP Configuration on S-PE
#show ldp ms-pw sp2
S-PE description: from-mpls-pc3-to-mpls-pc4
===================================================================
id: 200 id: 300
Endpoint: 2.3.4.5 Endpoint: 4.5.6.7
Role: Passive Role: Passive
Group ID: 4 Groups ID: 4
Rmt Flt/Clr sndr(S-PE): 0.0.0.0 Rmt Flt/Clr sndr(S-PE): 0.0.0.0
===================================================================
Display All Stitching Associations Configured on S-PE
#show mpls ms-pw
===================================================================
MS-PW Segment-1 VC1-ID Segment-2 VC2-ID
sp2 c2 200 c3 300
Display Details of MS-PW Association on S-PE
#show mpls ms-pw sp2
===================================================================
VC1: c2 VC2: c3
id: 200 id: 300
Endpoint: 2.3.4.5 Endpoint: 4.5.6.7
Control Word: 0 Control Word: 0
VC Type: Ethernet VC Type: Ethernet
Owner: Signaled Owner: Signaled
Role: Active Role: Active
===================================================================
Display Status, Interface and Label Associations for an MS-PW
#show mpls ms-pw sp2 vc-table
===================================================================
In VC Vlan-ID In-lbl Nw-Intf Out-Lbl Status Tunnel-lbl
c2 N/A 53125 eth4 53120 Active 3
c3 N/A 53124 eth3 53124 Active 3
===================================================================
#show mpls ms-pw sp1 vc-table (in case of stitched dynamic and static PW at S-PE)
===================================================================
In VC Vlan-ID In-Lbl Nw-Intf Out-Lbl Status Tunnel- Lbl
c1 N/A 101 eth4 53120 Active 3
c2 N/A 53120 eth3 201 Active 3
===================================================================
Display Details of MS-PW Association on S-PE if One VC is Manual
#show mpls ms-pw sp1 (in case of one signaled VC and one manual VC, stitched)
===================================================================
VC1: c1 VC2: c2
id: 100 id: 200
Endpoint: 1.2.3.4 Endpoint: 3.4.5.6
Control Word: 0 Control Word: 0
VC Type: Ethernet VC Type: Ethernet
Owner: Manual Owner: Signaled
Role: Active Role: Active
===================================================================
Display VC-Table and PW-Status Individual Segments of a MS-PW
#show ldp mpls-l2-circuit
===================================================================
Transport Client VC VC Local Remote Destination
VC ID Binding State Type VC Label VC Label Address
200 eth4 UP Ethernet 53125 53124 2.3.4.5
300 eth3 UP Ethernet 53124 53120 4.5.6.7
===================================================================
 
#show mpls vc-table
===================================================================
VC-ID Vlan-ID Access-Intf Network-Intf Out Label Tunnel-Label Nexthop Status
200 N/A eth4 eth3 53124 3 2.3.4.5 Active
300 N/A eth3 eth4 53120 3 4.5.6.7 Active
===================================================================