SW1#configure terminal | Enter configure mode. |
SW1(config)#bridge 1 protocol rstp vlan- bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW1(config)#vlan database | Entering VLAN database. |
SW1(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW1(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW1(config-vlan)#exit | Exit config mode. |
SW1(config)#int ce49 | Configure interface ce49. |
SW1(config-if)#switchport | Configure the interface as switch port. |
SW1(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW1(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW1(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface ce49. |
SW1(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW1(config-if)#exit | Exit config mode. |
SW1(config)#ethernet cfm domain-type character-string domain-name mdnam level 7 mip-creation default | Create cfm domain with type as character string and set mip creation criteria to default. |
SW1(config-ether-cfm)#service ma-type string ma-name testtm | Create ma type as string and set mip creation criteria to de-fault. |
SW1(config-ether-cfm-ma)#vlan 512 bridge 1 | Configure primary VLAN ID |
SW1(config-ether-cfm-ma)#mip-creation default | Configure MIP creation permission |
SW1(config-ether-cfm-ma)#ethernet cfm mep down mpid 2 active true ce49 | Create down mep for local-vid on ce49. |
SW1(config-ether-cfm-ma-mep)#cc multicast state enable | Enable cc multicast. |
SW1(config-ether-cfm-ma-mep)#exit-ether-ma- mep-mode | Exit ethernet cfm ma-mep mode. |
SW1(config-ether-cfm-ma)#mep crosscheck mpid 1 | Configure crosscheck to remote MEP in VLAN 512. |
SW1(config-ether-cfm-ma)#cc interval 10ms | Enable cc interval for 10 millisecond. |
SW1(config-ether-cfm-ma)#exit-ether-ma-mode | Exit ethernet ma mode. |
SW1(config-ether-cfm)#commit | Commit the candidate configuration to the running configuration. |
SW1(config-ether-cfm)#exit | Exit ethernet CFM mode. |
SW1(config)#ethernet cfm loss-measurement profile-name SLM | Creating loss-measurement profile for SLM |
SW1(config-cfm-lm)#measurement-interval 1 | Specify the measurement-interval in minutes |
SW1(config)#intervals-stored 3 | Specify the number of history interval to be stored |
SW1(config)# message-period 1 | Specify message period interval time |
SW1(config)#commit | Commit the candidate configuration to the running configuration. |
SW2#configure terminal | Enter configure mode. |
SW2(config)#bridge 1 protocol rstp vlan- bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW2(config)#vlan database | Entering VLAN database. |
SW2(config-vlan)#vlan 512 type customer bridge 1 state enable | Create VLAN 512 for customer bridge. |
SW2(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-vlan)#exit | Exit config mode. |
SW2(config)#interface ce0 | Configure interface ce0. |
SW2(config)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#switchport | Configure interface as a switch port. |
SW2(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW2(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW2(config-if)#switchport trunk allowed vlan all | Allow all customer VLANs on interface ce0. |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#int xe0 | Configure interface xe0 |
SW2(config-if)#switchport | Configure interface as switch port. |
SW2(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW2(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW2(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface xe1 |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit config mode. |
SW3#configure terminal | Enter configure mode. |
SW3(config)#bridge 1 protocol rstp vlan- bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW3(config)#vlan database | Entering VLAN database. |
SW3(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW3(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-vlan)#exit | Exit config mode. |
SW3(config)#int xe17 | Configure interface xe17. |
SW3(config-if)#switchport | Configure the interface as switch port. |
SW3(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW3(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW3(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface xe17. |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit config mode. |
SW3(config)#int xe1 | Configure interface xe1. |
SW3(config-if)#switchport | Configure the interface as switch port. |
SW3(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW3(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW3(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface xe1. |
SW3(config-if)#exit | Exit config mode. |
SW4#configure terminal | Enter configure mode. |
SW4(config)#bridge 1 protocol rstp vlan- bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW4(config)#vlan database | Entering VLAN database. |
SW4(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW4(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-vlan)#exit | Exit config mode. |
SW4(config)#int xe1 | Configure interface xe1. |
SW4(config-if)#switchport | Configure the interface as switch port. |
SW4(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW4(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW4(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface xe1. |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit config mode. |
SW4(config)#int xe9 | Configure interface xe9. |
SW4(config-if)#switchport | Configure the interface as switch port. |
SW4(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW4(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW4(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface xe9. |
SW4(config-if)#exit | Exit config mode. |
SW5#configure terminal | Enter configure mode. |
SW5(config)#bridge 1 protocol rstp vlan- bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW5(config)#vlan database | Entering VLAN database. |
SW5(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW5(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW5(config-vlan)#exit | Exit config mode. |
SW5(config)#int xe9 | Configure interface xe9. |
SW5(config-if)#switchport | Configure the interface as switch port. |
SW5(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW5(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW5(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface xe9. |
SW5(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW5(config-if)#exit | Exit config mode. |
SW5(config)#ethernet cfm domain-type character-string domain-name mdnam level 7 mip-creation default | Create cfm domain with type as character string and set mip creation criteria to default. |
SW5(config-ether-cfm)#service ma-type string ma-name testtm | Create ma type as string and set mip creation criteria to default. |
SW5(config-ether-cfm-ma)#vlan 512 bridge 1 | Configure primary VLAN ID |
SW5(config-ether-cfm-ma)#mip-creation default | Configure MIP creation permission |
SW5(config-ether-cfm-ma)#ethernet cfm mep down mpid 1 active true xe9 | Create down mep for local-vid on xe9 |
SW5(config-ether-cfm-ma-mep)#cc multicast state enable | Enable cc multicast. |
SW5(config-ether-cfm-ma-mep)#ethernet cfm loss-measurement reply slm | Generate and send SLR responses tacked |
SW5(config-ether-cfm-ma-mep)#exit-ether-ma- mep-mode | Exit ethernet cfm ma-mep mode. |
SW5(config-ether-cfm-ma)#mep crosscheck mpid 2 | Configure crosscheck to remote MEP in VLAN 512. |
SW5(config-ether-cfm-ma)#cc interval 10ms | Enable cc interval for 10 millisecond. |
SW5(config-ether-cfm-ma)#exit-ether-ma-mode | Exit ethernet ma mode. |
SW5(config-ether-cfm)#commit | Commit the candidate configuration to the running configuration. |
SW5(config-ether-cfm)#exit | Exit ethernet CFM mode. |
SW1#configure terminal | Enter configure mode. |
SW1(config)#bridge 1 protocol rstp vlan- bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW1(config)#vlan database | Entering VLAN database. |
SW1(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW1(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW1(config-vlan)#exit | Exit config mode. |
SW1(config)#interface ce49 | Configure interface ce49. |
SW1(config-if)#switchport | Configure the interface as switch port. |
SW1(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW1(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW1(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface ce49. |
SW1(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW1(config-if)#exit | Exit config mode. |
SW2#configure terminal | Enter configure mode. |
SW2(config)#interface ce0 | Configure interface ce0. |
SW2(config-if)#switchport | Configure interface as a switch port. |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#interface xe0 | Configure interface xe1. |
SW2(config-if)#no switchport | Configure interface as router port. |
SW2(config-if)#ip address 10.0.0.1/24 | Assign IP address to router port xe0 |
SW2(config-if)#no shutdown | Making the interface up |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#interface lo | Configure interface lo |
SW2(config-if)#ip address 1.1.1.1/32 secondary | Configure secondary IP address to loopback interface . |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#router ospf 100 | Configure ospf |
SW2(config-router)#network 10.0.0.0/24 area 0 | Advertising 10 network |
SW2(config-router)#network 1.1.1.1/32 area 0 | Advertising loopback IP |
SW2(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-router)#exit | Exit router mode. |
SW2(config)#router rsvp | Configuring rsvp |
SW2(config-router)#hello-receipt | Configuring hello reception |
SW2(config-router)#no php | Configuring device as not a PHP |
SW2(config-router)#revert-timer 10 | Configuring reversion time of RSVP |
SW2(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-router)#exit | Exit router mode. |
SW2(config)#rsvp-trunk to-1 ipv4 | Configuring RSVP path |
SW2(config-trunk)#to 2.2.2.2 | Configuring first hop |
SW2(config-trunk)#to 3.3.3.3 | Configuring second hop |
SW2(config-trunk)#exit | Exit trunk mode. |
SW2(config)#interface xe0 | Configuring interface |
SW2(config-if)#enable-rsvp | Enabling RSVP in interface |
SW2(config-if)#label-switching | Enabling MPLS labeling |
SW2(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#router ldp | Configuring LDP |
SW2(config-router)#targeted-peer ipv4 3.3.3.3 | Configuring LDP target peer for PW |
SW2(config-router-targeted-peer)#exit-targeted-peer-mode | Exit target peer mode |
SW2(config-router)#no multicast-hellos | Disabling LDP multicast |
SW2(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-router)#exit | Exit router mode. |
SW2(config)#mpls l2-circuit ETH-2001 1 3.3.3.3 | Creating VPWS PW |
SW2(config-pseudowire)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-pseudowire)#exit | Exit pseudowire config mode. |
SW2(config)#service-template ETH-2001 | Configuring service template profile for PW |
SW2(config-svc)#match outer-vlan 10 | Configuring match condition |
SW2(config-svc)# rewrite ingress push 2000 | Configuring action for match |
SW2(config-svc)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-svc)#exit | Exit service template mode |
SW2(config)#interface ce0 | Configuring interface |
SW2(config-if)#mpls-l2-circuit ETH-2001 ser-vice-template ETH-2001 | Mapping VPWS in AC |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#hardware-profile filter cfm-domain-name-str enable | Enabling HW filter for character string domain name |
SW2(config)#ethernet cfm domain-type character-string domain-name 12345 level 7 mip-creation none | Configuring CFM domain over VPWS |
SW2(config-ether-cfm-mpls-md)#service ma-type string ma-name 43981 mip-creation none | Creating MA for domain |
SW2(config-ether-cfm-mpls-md-ma)#cc interval 100ms | Configuring CFM interval |
SW2(config-ether-cfm-mpls-md-ma)#mep cross-check mpid 1 | Configuring remote mep |
SW2(config-ether-cfm-mpls-md-ma)#ethernet cfm mep up mpid 4001 active true vpws ETH-2001 | Configuring local mep and mapping the same with vpws ser-vice |
SW2(config-ether-cfm-mpls-ma-mep)#cc mul-ticast state enable | Enabling the CFM multicast |
SW2(config-ether-cfm-mpls-ma-mep)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-ether-cfm-mpls-ma-mep)#exit | Exit CFM MEP configuration mode |
SW2(config-ether-cfm-mpls-md-ma)#exit | Exit CFM MA configuration mode |
SW2(config-ether-cfm-mpls-md)#exit | End current mode and down to previous mode |
SW2(config)#ethernet cfm loss-measurement profile-name slm | Configuring LM profile |
SW2(config-cfm-lm)#measurement-type slm | Configuring measurement type as SLM |
SW2(config-cfm-lm)#message-period 3 | Configuring message period |
SW2(config-cfm-lm)#measurement-interval 1 | Configuring measurement interval |
SW2(config-cfm-lm)#intervals-stored 3 | Configuring number of interval to be stored |
SW2(config-cfm-lm)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-cfm-lm)#end | Exit config mode |
SW3#configure terminal | Enter configure mode. |
SW3(config)#interface xe17 | Configure interface |
SW3(config-if)#no switchport | Configure interface as router port. |
SW3(config-if)#ip address 20.0.0.1/24 | Assign IP address to router port |
SW3(config-if)#no shutdown | Making the interface up |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit interface mode. |
SW3(config)#interface xe1 | Configure interface |
SW3(config-if)#no switchport | Configure interface as router port. |
SW3(config-if)#ip address 10.0.0.2/24 | Assign IP address to router port |
SW3(config-if)#no shutdown | Making the interface up |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit interface mode. |
SW3(config)#interface lo | Configure interface lo |
SW3(config-if)#ip address 2.2.2.2/32 secondary | Configure secondary IP address to loopback interface . |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit interface mode. |
SW3(config)#router ospf 100 | Configure ospf |
SW3(config-router)#network 10.0.0.0/24 area 0 | Advertising 10 network |
SW3(config-router)#network 20.0.0.0/24 area 0 | Advertising 10 network |
SW3(config-router)#network 2.2.2.2/32 area 0 | Advertising loopback IP |
SW3(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-router)#exit | Exit router mode. |
SW3(config)#router rsvp | Configuring rsvp |
SW3(config-router)#hello-receipt | Configuring hello reception |
SW3(config-router)#no php | Configuring device as not a PHP |
SW3(config-router)#revert-timer 10 | Configuring reversion time of RSVP |
SW3(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-router)#exit | Exit router mode. |
SW3(config)#interface xe1 | Configuring interface |
SW3(config-if)#enable-rsvp | Enabling RSVP in interface |
SW3(config-if)#label-switching | Enabling MPLS labeling |
SW3(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit interface mode. |
SW3(config)#interface xe17 | Configuring interface |
SW3(config-if)#enable-rsvp | Enabling RSVP in interface |
SW3(config-if)#label-switching | Enabling MPLS labeling |
SW3(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit interface mode. |
SW4#configure terminal | Enter configure mode. |
SW4(config)#interface xe9 | Configure interface |
SW4(config-if)#switchport | Configure interface as switch port. |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit interface mode. |
SW4(config)#interface xe1 | Configure interface |
SW4(config-if)#no switchport | Configure interface as router port. |
SW4(config-if)#ip address 20.0.0.2/24 | Assign IP address to router port |
SW4(config-if)#no shutdown | Making the interface up |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit interface mode. |
SW4(config)#interface lo | Configure interface lo |
SW4(config-if)#ip address 3.3.3.3/32 secondary | Configure secondary IP address to loopback interface . |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit interface mode. |
SW4(config)#router ospf 100 | Configure ospf |
SW4(config-router)#network 20.0.0.0/24 area 0 | Advertising 10 network |
SW4(config-router)#network 3.3.3.3/32 area 0 | Advertising loopback IP |
SW4(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-router)#exit | Exit router mode. |
SW4(config)#router rsvp | Configuring rsvp |
SW4(config-router)#hello-receipt | Configuring hello reception |
SW4(config-router)#no php | Configuring device as not a PHP |
SW4(config-router)#revert-timer 10 | Configuring reversion time of RSVP |
SW4(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-router)#exit | Exit router mode. |
SW4(config)#rsvp-trunk to-1 ipv4 | Configuring RSVP path |
SW4(config-trunk)#to 2.2.2.2 | Configuring first hop |
SW4(config-trunk)#to 1.1.1.1 | Configuring second hop |
SW4(config-trunk)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-trunk)#exit | Exit trunk mode. |
SW4(config)#interface xe1 | Configuring interface |
SW4(config-if)#enable-rsvp | Enabling RSVP in interface |
SW4(config-if)#label-switching | Enabling MPLS labeling |
SW4(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit interface mode. |
SW4(config)#router ldp | Configuring LDP |
SW4(config-router)#targeted-peer ipv4 1.1.1.1 | Configuring LDP target peer for PW |
SW4(config-router-targeted-peer)#exit-targeted-peer-mode | Exit target peer mode |
SW4(config-router)#no multicast-hellos | Disabling LDP multicast |
SW4(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-router)#exit | Exit router mode. |
SW4(config)#mpls l2-circuit ETH-2001 1 1.1.1.1 | Creating VPWS PW |
SW4(config-pseudowire)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-pseudowire)#exit | Exit pseudowire config mode. |
SW4(config)#service-template ETH-2001 | Configuring service template profile for PW |
SW4(config-svc)# match outer-vlan 200 | Configuring match condition |
SW4(config-svc)# rewrite ingress push 2000 | Configuring action for match |
SW4(config-svc)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-svc)#exit | Exit service template mode |
SW4(config)#interface xe9 | Configuring interface |
SW4(config-if)#mpls-l2-circuit ETH-2001 ser-vice-template ETH-2001 | Mapping VPWS in AC |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit interface mode. |
SW4(config)#hardware-profile filter cfm-domain-name-str enable | Enabling HW filter for character string domain name |
SW4(config)#ethernet cfm domain-type charac-ter-string domain-name 12345 level 7 mip-creation none | Configuring CFM domain over VPWS |
SW4(config-ether-cfm-mpls-md)#service ma-type string ma-name 43981 | Creating MA for domain |
SW4(config-ether-cfm-ma)#mip-creation none | Configuring MIP creation permission |
SW4(config-ether-cfm-mpls-md-ma)#cc interval 100ms | Configuring CFM interval |
SW4(config-ether-cfm-mpls-md-ma)#cc interval 3 | Configuring CFM interval |
SW4(config-ether-cfm-mpls-md-ma)#mep cross-check mpid 4001 | Configuring remote mep |
SW4(config-ether-cfm-mpls-md-ma)#ethernet cfm mep up mpid 1 active true vpws ETH-2001 | Configuring local mep and mapping the same with vpws ser-vice |
SW4(config-ether-cfm-mpls-ma-mep)#cc mul-ticast state enable | Enabling the CFM multicast |
SW4(config-ether-cfm-mpls-ma-mep)#ethernet cfm loss-measurement reply slm | Configuring SLR |
SW4(config-ether-cfm-mpls-ma-mep)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-ether-cfm-mpls-ma-mep)#end | Exit config mode |
SW5#configure terminal | Enter configure mode. |
SW5(config)#bridge 1 protocol rstp vlan- bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW5(config)#vlan database | Entering VLAN database. |
SW5(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW5(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW5(config-vlan)#exit | Exit config mode. |
SW5(config)#interface xe9 | Configure interface ce49. |
SW5(config-if)#switchport | Configure the interface as switch port. |
SW5(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
SW5(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW5(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface ce49. |
SW5(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW5(config-if)#exit | Exit config mode. |
SW1#configure terminal | Enter configure mode. |
SW1(config)#bridge 1 protocol rstp vlan-bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW1(config)#vlan database | Entering vlan database |
SW1(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW1(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW1(config-vlan)#exit | Exit vlan database |
SW1(config)#int ce49 | Configure interface ce49. |
SW1(config-if)#switchport | Configure the interface as switch port. |
SW1(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW1(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW1(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface ce49. |
SW1(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW1(config-if)#exit | Exit config mode. |
SW1(config)#ethernet cfm domain-type character-string domain-name mdnam level 7 mip-creation default | Create cfm domain with type as character string and set mip creation criteria to default. |
SW1(config-ether-cfm)#service ma-type string ma-name testtm | Create ma type as string and set mip creation criteria to default. |
SW1(config-ether-cfm)#vlan 512 | Configure primary VLAN ID |
SW1(config-ether-cfm-ma)#mip-creation default | Configure MIP creation permission |
SW1(config-ether-cfm-ma)#ethernet cfm mep down mpid 2 active true local-vid 512 ce49 | Create down mep for local-vid on ce49. |
SW1(config-ether-cfm-ma-mep)#cc multicast state enable | Enable cc multicast. |
SW1(config-ether-cfm-ma-mep)#exit-ether-ma-mep-mode | Exit ethernet cfm ma-mep mode. |
SW1(config-ether-cfm-ma)#mep crosscheck mpid 1 | Configure crosscheck to remote MEP in VLAN 512. |
SW1(config-ether-cfm-ma)#cc interval 10ms | Enable cc interval for 10 millisecond. |
SW1(config-ether-cfm-ma)#exit-ether-ma-mode | Exit ethernet ma mode. |
SW1(config-ether-cfm)#commit | Commit the candidate configuration to the running configuration. |
SW1(config-ether-cfm)#exit | Exit ethernet CFM mode. |
SW1(config)# ethernet cfm loss-measurement profile-name LMM | Creating loss-measurement profile for LMM |
SW1(config-cfm-lm)# measurement-type lmm | Specify the measurement type |
SW1(config-cfm-lm)# measurement-interval 1 | Specify the measurement-interval in minutes |
SW1(config)# intervals-stored 3 | Specify the number of history interval to be stored |
SW1(config)# message-period 1s | Specify message period interval time |
SW1(config)#commit | Commit the candidate configuration to the running configuration. |
SW2#configure terminal | Enter configure mode. |
SW2(config)#bridge 1 protocol rstp vlan-bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW2(config)#vlan database | Entering vlan database |
SW2(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW2(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-vlan)#exit | Exit vlan database |
SW2(config)#int ce0 | Configure interface ce0. |
SW2(config-if)#switchport | Configure the interface as switch port. |
SW2(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW2(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW2(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface ce0. |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit config mode. |
SW2(config)#int xe0 | Configure interface xe0. |
SW2(config-if)#switchport | Configure the interface as switch port. |
SW2(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW2(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW2(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface xe1. |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit config mode. |
SW3#configure terminal | Enter configure mode. |
SW3(config)#bridge 1 protocol rstp vlan-bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW3(config)#vlan database | Entering vlan database |
SW3(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW3(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-vlan)#exit | Exit vlan database |
SW3(config)#int xe17 | Configure interface xe17. |
SW3(config-if)#switchport | Configure the interface as switch port. |
SW3(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW3(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW3(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface xe17. |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit config mode. |
SW3(config)#int xe1 | Configure interface xe1. |
SW3(config-if)#switchport | Configure the interface as switch port. |
SW3(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW3(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW3(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface xe1. |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit config mode. |
SW4#configure terminal | Enter configure mode. |
SW4(config)#bridge 1 protocol rstp vlan-bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW4(config)#vlan database | Entering vlan database |
SW4(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW4(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-vlan)#exit | Exit vlan database |
SW4(config)#int xe1 | Configure interface xe1. |
SW4(config-if)#switchport | Configure the interface as switch port. |
SW4(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW4(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW4(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface xe1. |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit config mode. |
SW4(config)#int xe9 | Configure interface xe9. |
SW4(config-if)#switchport | Configure the interface as switch port. |
SW4(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW4(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW4(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface xe9. |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit config mode. |
SW5#configure terminal | Enter configure mode. |
SW5(config)#bridge 1 protocol rstp vlan-bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW5(config)#vlan database | Entering vlan database |
SW5(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW5(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW5(config-vlan)#exit | Exit vlan database |
SW5(config)#int xe9 | Configure interface xe9. |
SW5(config-if)#switchport | Configure the interface as switch port. |
SW5(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW5(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW5(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface xe9. |
SW5(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW5(config-if)#exit | Exit config mode. |
SW5(config)#ethernet cfm domain-type character-string domain-name mdnam level 7 mip-creation default | Create cfm domain with type as character string and set mip creation criteria to default. |
SW5(config-ether-cfm)#service ma-type string ma-name testtm | Create ma type as string and set mip creation criteria to default. |
SW5(config-ether-cfm-ma)#vlan 512 bridge 1 | Configure primary VLAN ID |
SW5(config-ether-cfm-ma)#mip-creation default | Configure MIP creation permission |
SW5(config-ether-cfm-ma)#ethernet cfm mep down mpid 1 active true xe9 | Create down mep for local-vid on xe9 |
SW5(config-ether-cfm-ma-mep)#cc multicast state enable | Enable cc multicast. |
SW5(config-ether-cfm-ma-mep)#ethernet cfm loss-measurement reply lmm | Generate and send LMR responses tacked |
SW5(config-ether-cfm-ma-mep)#exit-ether-ma-mep-mode | Exit ethernet cfm ma-mep mode. |
SW5(config-ether-cfm-ma)#mep crosscheck mpid 2 | Configure crosscheck to remote MEP in VLAN 512. |
SW5(config-ether-cfm-ma)#cc interval 10ms | Enable cc interval for 10 millisecond. |
SW5(config-ether-cfm-ma)#exit-ether-ma-mode | Exit ethernet ma mode. |
SW5(config-ether-cfm-ma)#commit | Commit the candidate configuration to the running configuration. |
SW5(config-ether-cfm)#exit | Exit ethernet CFM mode. |
SW1#configure terminal | Enter configure mode. |
SW1(config)#bridge 1 protocol rstp vlan- bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW1(config)#vlan database | Entering VLAN database. |
SW1(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW1(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW1(config-vlan)#exit | Exit config mode. |
SW1(config)#interface ce49 | Configure interface ce49. |
SW1(config-if)#switchport | Configure the interface as switch port. |
SW1(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW1(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW1(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface ce49. |
SW1(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW1(config-if)#exit | Exit config mode. |
SW2#configure terminal | Enter configure mode. |
SW2(config)#interface ce0 | Configure interface ce0. |
SW2(config-if)#switchport | Configure interface as a switch port. |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#interface xe0 | Configure interface xe0. |
SW2(config-if)#no switchport | Configure interface as router port. |
SW2(config-if)#ip address 10.0.0.1/24 | Assign IP address to router port xe0 |
SW2(config-if)#no shutdown | Making the interface up |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#interface lo | Configure interface lo |
SW2(config-if)#ip address 1.1.1.1/32 secondary | Configure secondary IP address to loopback interface . |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#router ospf 100 | Configure ospf |
SW2(config-router)#network 10.0.0.0/24 area 0 | Advertising 10 network |
SW2(config-router)#network 1.1.1.1/32 area 0 | Advertising loopback IP |
SW2(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-router)#exit | Exit router mode. |
SW2(config)#router rsvp | Configuring rsvp |
SW2(config-router)#hello-receipt | Configuring hello reception |
SW2(config-router)#no php | Configuring device as not a PHP |
SW2(config-router)#revert-timer 10 | Configuring reversion time of RSVP |
SW2(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-router)#exit | Exit router mode. |
SW2(config)#rsvp-trunk to-1 ipv4 | Configuring RSVP path |
SW2(config-trunk)#to 2.2.2.2 | Configuring first hop |
SW2(config-trunk)#to 3.3.3.3 | Configuring second hop |
SW2(config-trunk)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-trunk)#exit | Exit trunk mode. |
SW2(config)#interface xe0 | Configuring interface |
SW2(config-if)#enable-rsvp | Enabling RSVP in interface |
SW2(config-if)#label-switching | Enabling MPLS labeling |
SW2(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#router ldp | Configuring LDP |
SW2(config-router)#targeted-peer ipv4 3.3.3.3 | Configuring LDP target peer for PW |
SW2(config-router-targeted-peer)#exit-targeted-peer-mode | Exit target peer mode |
SW2(config-router)#no multicast-hellos | Disabling LDP multicast |
SW2(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-router)#exit | Exit router mode. |
SW2(config)#mpls l2-circuit ETH-2001 1 3.3.3.3 | Creating VPWS PW |
SW2(config-pseudowire)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-pseudowire)#exit | Exit pseudowire config mode. |
SW2(config)#service-template ETH-2001 | Configuring service template profile for PW |
SW2(config-svc)#match outer-vlan 200 | Configuring match condition |
SW2(config-svc)# rewrite ingress push 2000 | Configuring action for match |
SW2(config-svc)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-svc)#exit | Exit service template mode |
SW2(config)#interface ce0 | Configuring interface |
SW2(config-if)#mpls-l2-circuit ETH-2001 ser-vice-template ETH-2001 | Mapping VPWS in AC |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#hardware-profile filter cfm-domain-name-str enable | Enabling HW filter for character string domain name |
SW2(config)#ethernet cfm domain-type character-string domain-name 12345 level 7 mip-creation none | Configuring CFM domain over VPWS |
SW2(config-ether-cfm-mpls-md)#service ma-type string ma-name 43981 mip-creation none | Creating MA for domain |
SW2(config-ether-cfm-mpls-md-ma)#cc interval 100ms | Configuring CFM interval |
SW2(config-ether-cfm-mpls-md-ma)#mep cross-check mpid 1 | Configuring remote mep |
SW2(config-ether-cfm-mpls-md-ma)#ethernet cfm mep up mpid 4001 active true vpws ETH-2001 | Configuring local mep and mapping the same with vpws ser-vice |
SW2(config-ether-cfm-mpls-ma-mep)#cc mul-ticast state enable | Enabling the CFM multicast |
SW2(config-ether-cfm-mpls-ma-mep)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-ether-cfm-mpls-ma-mep)#exit | Exit CFM MEP configuration mode |
SW2(config-ether-cfm-mpls-md-ma)#exit | Exit CFM MA configuration mode |
SW2(config-ether-cfm-mpls-md)#exit | End current mode and down to previous mode |
SW2(config)#ethernet cfm loss-measurement profile-name lmm | Configuring LM profile |
SW2(config-cfm-lm)#measurement-type lmm | Configuring measurement type as LMM |
SW2(config-cfm-lm)#message-period 3 | Configuring message period |
SW2(config-cfm-lm)#measurement-interval 1 | Configuring measurement interval |
SW2(config-cfm-lm)#intervals-stored 3 | Configuring number of interval to be stored |
SW2(config-cfm-lm)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-cfm-lm)#end | Exit config mode |
SW3#configure terminal | Enter configure mode. |
SW3(config)#interface xe17 | Configure interface |
SW3(config-if)#no switchport | Configure interface as router port. |
SW3(config-if)#ip address 20.0.0.1/24 | Assign IP address to router port |
SW3(config-if)#no shutdown | Making the interface up |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit interface mode. |
SW3(config)#interface xe1 | Configure interface |
SW3(config-if)#no switchport | Configure interface as router port. |
SW3(config-if)#ip address 10.0.0.2/24 | Assign IP address to router port |
SW3(config-if)#no shutdown | Making the interface up |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit interface mode. |
SW3(config)#interface lo | Configure interface lo |
SW3(config-if)#ip address 2.2.2.2/32 secondary | Configure secondary IP address to loopback interface. |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit interface mode. |
SW3(config)#router ospf 100 | Configure ospf |
SW3(config-router)#network 10.0.0.0/24 area 0 | Advertising 10 network |
SW3(config-router)#network 20.0.0.0/24 area 0 | Advertising 10 network |
SW3(config-router)#network 2.2.2.2/32 area 0 | Advertising loopback IP |
SW3(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-router)#exit | Exit router mode. |
SW3(config)#router rsvp | Configuring rsvp |
SW3(config-router)#hello-receipt | Configuring hello reception |
SW3(config-router)#no php | Configuring device as not a PHP |
SW3(config-router)#revert-timer 10 | Configuring reversion time of RSVP |
SW3(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-router)#exit | Exit router mode. |
SW3(config)#interface xe1 | Configuring interface |
SW3(config-if)#enable-rsvp | Enabling RSVP in interface |
SW3(config-if)#label-switching | Enabling MPLS labeling |
SW3(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit interface mode. |
SW3(config)#interface xe17 | Configuring interface |
SW3(config-if)#enable-rsvp | Enabling RSVP in interface |
SW3(config-if)#label-switching | Enabling MPLS labeling |
SW3(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit interface mode. |
SW4#configure terminal | Enter configure mode. |
SW4(config)#interface xe9 | Configure interface |
SW4(config-if)#switchport | Configure interface as switch port. |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit interface mode. |
SW4(config)#interface xe1 | Configure interface |
SW4(config-if)#no switchport | Configure interface as router port. |
SW4(config-if)#ip address 20.0.0.2/24 | Assign IP address to router port |
SW4(config-if)#no shutdown | Making the interface up |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit interface mode. |
SW4(config)#interface lo | Configure interface lo |
SW4(config-if)#ip address 3.3.3.3/32 secondary | Configure secondary IP address to loopback interface . |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit interface mode. |
SW4(config)#router ospf 100 | Configure ospf |
SW4(config-router)#network 20.0.0.0/24 area 0 | Advertising 10 network |
SW4(config-router)#network 3.3.3.3/32 area 0 | Advertising loopback IP |
SW4(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-router)#exit | Exit router mode. |
SW4(config)#router rsvp | Configuring rsvp |
SW4(config-router)#hello-receipt | Configuring hello reception |
SW4(config-router)#no php | Configuring device as not a PHP |
SW4(config-router)#revert-timer 10 | Configuring reversion time of RSVP |
SW4(config-router)#exit | Exit router mode. |
SW4(config)#rsvp-trunk to-1 ipv4 | Configuring RSVP path |
SW4(config-trunk)#to 2.2.2.2 | Configuring first hop |
SW4(config-trunk)#to 1.1.1.1 | Configuring second hop |
SW4(config-trunk)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-trunk)#exit | Exit trunk mode. |
SW4(config)#interface xe1 | Configuring interface |
SW4(config-if)#enable-rsvp | Enabling RSVP in interface |
SW4(config-if)#label-switching | Enabling MPLS labeling |
SW4(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit interface mode. |
SW4(config)#router ldp | Configuring LDP |
SW4(config-router)#targeted-peer ipv4 1.1.1.1 | Configuring LDP target peer for PW |
SW4(config-router-targeted-peer)#exit-targeted-peer-mode | Exit target peer mode |
SW4(config-router)#no multicast-hellos | Disabling LDP multicast |
SW4(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-router)#exit | Exit router mode. |
SW4(config)#mpls l2-circuit ETH-2001 1 1.1.1.1 | Creating VPWS PW |
SW4(config-pseudowire)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-pseudowire)#exit | Exit pseudowire config mode. |
SW4(config)#service-template ETH-2001 | Configuring service template profile for PW |
SW4(config-svc)# match outer-vlan 200 | Configuring match condition |
SW4(config-svc)# rewrite ingress push 2000 | Configuring action for match |
SW4(config-svc)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-svc)#exit | Exit service template mode |
SW4(config)#interface xe9 | Configuring interface |
SW4(config-if)#mpls-l2-circuit ETH-2001 ser-vice-template ETH-2001 | Mapping VPWS in AC |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit interface mode. |
SW4(config)#hardware-profile filter cfm-domain-name-str enable | Enabling HW filter for character string domain name |
SW4(config)#ethernet cfm domain-type charac-ter-string domain-name 12345 level 7 mip-creation none | Configuring CFM domain over VPWS |
SW4(config-ether-cfm-mpls-md)#service ma-type string ma-name 43981 | Creating MA for domain |
SW4(config-ether-cfm-ma)#mip-creation none | Configuring MIP creation permission |
SW4(config-ether-cfm-mpls-md-ma)#cc interval 100ms | Configuring CFM interval |
SW4(config-ether-cfm-mpls-md-ma)#mep cross-check mpid 4001 | Configuring remote mep |
SW4(config-ether-cfm-mpls-md-ma)#ethernet cfm mep up mpid 1 active true vpws ETH-2001 | Configuring local mep and mapping the same with vpws ser-vice |
SW4(config-ether-cfm-mpls-ma-mep)#cc mul-ticast state enable | Enabling the CFM multicast |
SW4(config-ether-cfm-mpls-ma-mep)#ethernet cfm loss-measurement reply lmm | Configuring LMR |
SW4(config-ether-cfm-mpls-ma-mep)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-ether-cfm-mpls-ma-mep)#end | Exit config mode |
SW5#configure terminal | Enter configure mode. |
SW5(config)#bridge 1 protocol rstp vlan- bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW5(config)#vlan database | Entering VLAN database. |
SW5(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW5(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW5(config-vlan)#exit | Exit config mode. |
SW5(config)#interface xe9 | Configure interface ce49. |
SW5(config-if)#switchport | Configure the interface as switch port. |
SW5(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
SW5(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW5(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface ce49. |
SW5(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW5(config-if)#exit | Exit config mode. |
SW1#configure terminal | Enter configure mode. |
SW1(config)#bridge 1 protocol rstp vlan-bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW1(config)#vlan database | Entering vlan database |
SW1(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW1(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW1(config-vlan)#exit | Exit vlan database |
SW1(config)#int ce49 | Configure interface ce49. |
SW1(config-if)#switchport | Configure the interface as switch port. |
SW1(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW1(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW1(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface ce49. |
SW1(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW1(config-if)#exit | Exit config mode. |
SW1(config)#ethernet cfm domain-type character-string domain-name mdnam level 7 mip-creation default | Create cfm domain with type as character string and set mip creation criteria to default. |
SW1(config-ether-cfm)#service ma-type string ma-name testtm | Create ma type as string and set mip creation criteria to default. |
SW1(config-ether-cfm-ma)#vlan 512 bridge 1 | Configure primary VLAN ID |
SW1(config-ether-cfm-ma)#mip-creation default | Configure MIP creation permission |
SW1(config-ether-cfm-ma)#ethernet cfm mep down mpid 2 active true ce49 | Create down mep for local-vid on ce49. |
SW1(config-ether-cfm-ma-mep)#cc multicast state enable | Enable cc multicast. |
SW1(config-ether-cfm-ma-mep)#exit-ether-ma-mep-mode | Exit ethernet cfm ma-mep mode. |
SW1(config-ether-cfm-ma)#mep crosscheck mpid 1 | Configure crosscheck to remote MEP in VLAN 512. |
SW1(config-ether-cfm-ma)#cc interval 10ms | Enable cc interval for 10 millisecond. |
SW1(config-ether-cfm-ma)#exit-ether-ma-mode | Exit ethernet ma mode. |
SW1(config-ether-cfm)#commit | Commit the candidate configuration to the running configuration. |
SW1(config-ether-cfm)#exit | Exit ethernet CFM mode. |
SW1(config)# ethernet cfm delay-measurement profile-name DM | Creating loss-measurement profile for DM |
SW1(config-cfm-dm)# measurement-interval 1 | Specify the measurement-interval in minutes |
SW1(config-cfm-dm)# intervals-stored 3 | Specify the number of history interval to be stored |
SW1(config-cfm-dm)# message-period 1s | Specify message period interval time |
SW1(config-cfm-dm)# bins-per-fd-interval 4 | Specify the number of measurement bins per Measurement Interval for Frame Delay measurements. |
SW1(config-cfm-dm)# bins-per-ifdv-interval 3 | Specify the number of measurement bins per Measurement Interval for Inter-Frame Delay Variation measurements. |
SW1(config-cfm-dm)#commit | Commit the candidate configuration to the running configuration. |
SW2#configure terminal | Enter configure mode. |
SW2(config)#bridge 1 protocol rstp vlan-bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW2(config)#vlan database | Entering vlan database |
SW2(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW2(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-vlan)#exit | Exit vlan database |
SW2(config)#int ce0 | Configure interface ce0. |
SW2(config-if)#switchport | Configure the interface as switch port. |
SW2(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW2(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW2(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface ce0. |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit config mode. |
SW2(config)#int xe0 | Configure interface xe0. |
SW2(config-if)#switchport | Configure the interface as switch port. |
SW2(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW2(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW2(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface xe1. |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit config mode. |
SW3#configure terminal | Enter configure mode. |
SW3(config)#bridge 1 protocol rstp vlan-bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW3(config)#vlan database | Entering vlan database |
SW3(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW3(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-vlan)#exit | Exit vlan database |
SW3(config)#int xe17 | Configure interface xe17. |
SW3(config-if)#switchport | Configure the interface as switch port. |
SW3(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW3(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW3(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface xe17. |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit config mode. |
SW3(config)#int xe1 | Configure interface xe1. |
SW3(config-if)#switchport | Configure the interface as switch port. |
SW3(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW3(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW3(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface xe1. |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit config mode. |
SW4#configure terminal | Enter configure mode. |
SW4(config)#bridge 1 protocol rstp vlan-bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW4(config)#vlan database | Entering vlan database |
SW4(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW4(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-vlan)#exit | Exit vlan database |
SW4(config)#int xe1 | Configure interface xe1. |
SW4(config-if)#switchport | Configure the interface as switch port. |
SW4(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW4(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW4(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface xe1. |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit config mode. |
SW4(config)#int xe9 | Configure interface xe9. |
SW4(config-if)#switchport | Configure the interface as switch port. |
SW4(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW4(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW4(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface xe9. |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit config mode. |
SW5#configure terminal | Enter configure mode. |
SW5(config)#bridge 1 protocol rstp vlan-bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW5(config)#vlan database | Entering vlan database |
SW5(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW5(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW5(config-vlan)#exit | Exit vlan database |
SW5(config)#int xe9 | Configure interface xe9. |
SW5(config-if)#switchport | Configure the interface as switch port. |
SW5(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW5(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW5(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface xe9. |
SW5(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW5(config-if)#exit | Exit config mode. |
SW5(config)#ethernet cfm domain-type character-string domain-name mdnam level 7 mip-creation default | Create cfm domain with type as character string and set mip creation criteria to default. |
SW5(config-ether-cfm)#service ma-type string ma-name testtm | Create ma type as string and set mip creation criteria to default. |
SW5(config-ether-cfm)#vlan 512 bridge 1 | Configure primary VLAN ID |
SW5(config-ether-cfm-ma)#mip-creation default | Configure MIP creation permission |
SW5(config-ether-cfm-ma)#ethernet cfm mep down mpid 1 active true xe9 | Create down mep for local-vid on xe9 |
SW5(config-ether-cfm-ma-mep)#cc multicast state enable | Enable cc multicast. |
SW5(config-ether-cfm-ma-mep)# ethernet cfm delay-measurement reply dmm | Generate and send DMM responses tacked |
SW5(config-ether-cfm-ma-mep)#exit-ether-ma-mep-mode | Exit ethernet cfm ma-mep mode. |
SW5(config-ether-cfm-ma)#mep crosscheck mpid 2 | Configure crosscheck to remote MEP in VLAN 512. |
SW5(config-ether-cfm-ma)#cc interval 10ms | Enable cc interval for 10 millisecond. |
SW5(config-ether-cfm-ma)#exit-ether-ma-mode | Exit ethernet ma mode. |
SW5(config-ether-cfm)#commit | Commit the candidate configuration to the running configuration. |
SW5(config-ether-cfm)#exit | Exit ethernet CFM mode. |
SW1#configure terminal | Enter configure mode. |
SW1(config)#bridge 1 protocol rstp vlan- bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW1(config)#vlan database | Entering VLAN database. |
SW1(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW1(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW1(config-vlan)#exit | Exit config mode. |
SW1(config)#interface ce49 | Configure interface ce49. |
SW1(config-if)#switchport | Configure the interface as switch port. |
SW1(config-if)#bridge-group 1 | Configure interface in bridge group 1. |
SW1(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW1(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface ce49. |
SW1(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW1(config-if)#exit | Exit config mode. |
SW2#configure terminal | Enter configure mode. |
SW2(config)#interface ce0 | Configure interface ce0. |
SW2(config-if)#switchport | Configure interface as a switch port. |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#interface xe0 | Configure interface xe0. |
SW2(config-if)#no switchport | Configure interface as router port. |
SW2(config-if)#ip address 10.0.0.1/24 | Assign IP address to router port xe0 |
SW2(config-if)#no shutdown | Making the interface up |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#interface lo | Configure interface lo |
SW2(config-if)#ip address 1.1.1.1/32 secondary | Configure secondary IP address to loopback interface. |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#router ospf 100 | Configure ospf |
SW2(config-router)#network 10.0.0.0/24 area 0 | Advertising 10 network |
SW2(config-router)#network 1.1.1.1/32 area 0 | Advertising loopback IP |
SW2(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-router)#exit | Exit router mode. |
SW2(config)#router rsvp | Configuring rsvp |
SW2(config-router)#hello-receipt | Configuring hello reception |
SW2(config-router)#no php | Configuring device as not a PHP |
SW2(config-router)#revert-timer 10 | Configuring reversion time of RSVP |
SW2(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-router)#exit | Exit router mode. |
SW2(config)#rsvp-trunk to-1 ipv4 | Configuring RSVP path |
SW2(config-trunk)#to 2.2.2.2 | Configuring first hop |
SW2(config-trunk)#to 3.3.3.3 | Configuring second hop |
SW2(config-trunk)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-trunk)#exit | Exit trunk mode. |
SW2(config)#interface xe0 | Configuring interface |
SW2(config-if)#enable-rsvp | Enabling RSVP in interface |
SW2(config-if)#label-switching | Enabling MPLS labeling |
SW2(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#router ldp | Configuring LDP |
SW2(config-router)#targeted-peer ipv4 3.3.3.3 | Configuring LDP target peer for PW |
SW2(config-router-targeted-peer)#exit-targeted-peer-mode | Exit target peer mode |
SW2(config-router)#no multicast-hellos | Disabling LDP multicast |
SW2(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-router)#exit | Exit router mode. |
SW2(config)#mpls l2-circuit ETH-2001 1 3.3.3.3 | Creating VPWS PW |
SW2(config-pseudowire)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-pseudowire)#exit | Exit pseudowire config mode. |
SW2(config)#service-template ETH-2001 | Configuring service template profile for PW |
SW2(config-svc)#match outer-vlan 200 | Configuring match condition |
SW2(config-svc)# rewrite ingress push 2000 | Configuring action for match |
SW2(config-svc)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-svc)#exit | Exit service template mode |
SW2(config)#interface ce0 | Configuring interface |
SW2(config-if)#mpls-l2-circuit ETH-2001 ser-vice-template ETH-2001 | Mapping VPWS in AC |
SW2(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-if)#exit | Exit interface mode. |
SW2(config)#hardware-profile filter cfm-domain-name-str enable | Enabling HW filter for character string domain name |
SW2(config)#ethernet cfm domain-type character-string domain-name 12345 level 7 mip-creation none | Configuring CFM domain over VPWS |
SW2(config-ether-cfm-mpls-md)#service ma-type string ma-name 43981 mip-creation none | Creating MA for domain |
SW2(config-ether-cfm-mpls-md-ma)#cc interval 100ms | Configuring CFM interval |
SW2(config-ether-cfm-mpls-md-ma)#mep cross-check mpid 1 | Configuring remote mep |
SW2(config-ether-cfm-mpls-md-ma)#ethernet cfm mep up mpid 4001 active true vpws ETH-2001 | Configuring local mep and mapping the same with vpws ser-vice |
SW2(config-ether-cfm-mpls-ma-mep)#cc mul-ticast state enable | Enabling the CFM multicast |
SW2(config-ether-cfm-mpls-ma-mep)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-ether-cfm-mpls-ma-mep)#exit | Exit CFM MEP configuration mode |
SW2(config-ether-cfm-mpls-md-ma)#exit | Exit CFM MA configuration mode |
SW2(config-ether-cfm-mpls-md)#exit | End current mode and down to previous mode |
SW2(config)#ethernet cfm delay-measurement profile-name DM | Configuring DM profile |
SW2(config-cfm-dm)#measurement interval | Configuring measurement interval |
SW2(config-cfm-dm)#intervals-stored 3 | Configuring the number of history interval to be stored |
SW2(config-cfm-dm)# message-period 1s | Configuring message period interval time |
SW2(config-cfm-dm)# bins-per-fd-interval 4 | Configuring the number of measurement bins per Meas-urement Interval for Frame Delay measurements. |
SW2(config-cfm-dm)# bins-per-ifdv-interval 3 | Configuring the number of measurement bins per Meas-urement Interval for Inter-Frame Delay Variation measure-ments. |
SW2(config-cfm-dm)#commit | Commit the candidate configuration to the running configuration. |
SW2(config-cfm-dm)#end | Exit config mode |
SW3#configure terminal | Enter configure mode. |
SW3(config)#interface xe17 | Configure interface |
SW3(config-if)#no switchport | Configure interface as router port. |
SW3(config-if)#ip address 20.0.0.1/24 | Assign IP address to router port |
SW3(config-if)#no shutdown | Making the interface up |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit interface mode. |
SW3(config)#interface xe1 | Configure interface |
SW3(config-if)#no switchport | Configure interface as router port. |
SW3(config-if)#ip address 10.0.0.2/24 | Assign IP address to router port |
SW3(config-if)#no shutdown | Making the interface up |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit interface mode. |
SW3(config)#interface lo | Configure interface lo |
SW3(config-if)#ip address 2.2.2.2/32 secondary | Configure secondary IP address to loopback interface . |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit interface mode. |
SW3(config)#router ospf 100 | Configure ospf |
SW3(config-router)#network 10.0.0.0/24 area 0 | Advertising 10 network |
SW3(config-router)#network 20.0.0.0/24 area 0 | Advertising 10 network |
SW3(config-router)#network 2.2.2.2/32 area 0 | Advertising loopback IP |
SW3(config-router)#exit | Exit router mode. |
SW3(config)#router rsvp | Configuring rsvp |
SW3(config-router)#hello-receipt | Configuring hello reception |
SW3(config-router)#no php | Configuring device as not a PHP |
SW3(config-router)#revert-timer 10 | Configuring reversion time of RSVP |
SW3(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-router)#exit | Exit router mode. |
SW3(config)#interface xe1 | Configuring interface |
SW3(config-if)#enable-rsvp | Enabling RSVP in interface |
SW3(config-if)#label-switching | Enabling MPLS labeling |
SW3(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit interface mode. |
SW3(config)#interface xe17 | Configuring interface |
SW3(config-if)#enable-rsvp | Enabling RSVP in interface |
SW3(config-if)#label-switching | Enabling MPLS labeling |
SW3(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
SW3(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW3(config-if)#exit | Exit interface mode. |
SW4#configure terminal | Enter configure mode. |
SW4(config)#interface xe9 | Configure interface |
SW4(config-if)#switchport | Configure interface as switch port. |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit interface mode. |
SW4(config)#interface xe1 | Configure interface |
SW4(config-if)#no switchport | Configure interface as router port. |
SW4(config-if)#ip address 20.0.0.2/24 | Assign IP address to router port |
SW4(config-if)#no shutdown | Making the interface up |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit interface mode. |
SW4(config)#interface lo | Configure interface lo |
SW4(config-if)#ip address 3.3.3.3/32 secondary | Configure secondary IP address to loopback interface . |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit interface mode. |
SW4(config)#router ospf 100 | Configure ospf |
SW4(config-router)#network 20.0.0.0/24 area 0 | Advertising 10 network |
SW4(config-router)#network 3.3.3.3/32 area 0 | Advertising loopback IP |
SW4(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-router)#exit | Exit router mode. |
SW4(config)#router rsvp | Configuring rsvp |
SW4(config-router)#hello-receipt | Configuring hello reception |
SW4(config-router)#no php | Configuring device as not a PHP |
SW4(config-router)#revert-timer 10 | Configuring reversion time of RSVP |
SW4(config-router)#exit | Exit router mode. |
SW4(config)#rsvp-trunk to-1 ipv4 | Configuring RSVP path |
SW4(config-trunk)#to 2.2.2.2 | Configuring first hop |
SW4(config-trunk)#to 1.1.1.1 | Configuring second hop |
SW4(config-trunk)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-trunk)#exit | Exit trunk mode. |
SW4(config)#interface xe1 | Configuring interface |
SW4(config-if)#enable-rsvp | Enabling RSVP in interface |
SW4(config-if)#label-switching | Enabling MPLS labeling |
SW4(config-if)#enable-ldp ipv4 | Enabling ldp on interface |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit interface mode. |
SW4(config)#router ldp | Configuring LDP |
SW4(config-router)#targeted-peer ipv4 1.1.1.1 | Configuring LDP target peer for PW |
SW4(config-router-targeted-peer)#exit-targeted-peer-mode | Exit target peer mode |
SW4(config-router)#no multicast-hellos | Disabling LDP multicast |
SW4(config-router)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-router)#exit | Exit router mode. |
SW4(config)#mpls l2-circuit ETH-2001 1 1.1.1.1 | Creating VPWS PW |
SW4(config-pseudowire)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-pseudowire)#exit | Exit pseudowire config mode. |
SW4(config)#service-template ETH-2001 | Configuring service template profile for PW |
SW4(config-svc)# match outer-vlan 200 | Configuring match condition |
SW4(config-svc)# rewrite ingress push 2000 | Configuring action for match |
SW4(config-svc)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-svc)#exit | Exit service template mode |
SW4(config)#interface xe9 | Configuring interface |
SW4(config-if)#mpls-l2-circuit ETH-2001 ser-vice-template ETH-2001 | Mapping VPWS in AC |
SW4(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-if)#exit | Exit interface mode. |
SW4(config)#hardware-profile filter cfm-domain-name-str enable | Enabling HW filter for character string domain name |
SW4(config)#ethernet cfm domain-type charac-ter-string domain-name 12345 level 7 mip-creation none | Configuring CFM domain over VPWS |
SW4(config-ether-cfm-mpls-md)#service ma-type string ma-name 43981 | Creating MA for domain |
SW4(config-ether-cfm-ma)#mip-creation none | Configuring MIP creation permission |
SW4(config-ether-cfm-mpls-md-ma)#cc interval 100ms | Configuring CFM interval |
SW4(config-ether-cfm-mpls-md-ma)#mep cross-check mpid 4001 | Configuring remote mep |
SW4(config-ether-cfm-mpls-md-ma)#ethernet cfm mep up mpid 1 active true vpws ETH-2001 | Configuring local mep and mapping the same with vpws ser-vice |
SW4(config-ether-cfm-mpls-ma-mep)#cc mul-ticast state enable | Enabling the CFM multicast |
SW4(config-ether-cfm-mpls-ma-mep)#ethernet cfm delay-measurement reply dmm | Configuring DMR |
SW4(config-ether-cfm-mpls-ma-mep)#commit | Commit the candidate configuration to the running configuration. |
SW4(config-ether-cfm-mpls-ma-mep)#end | Exit config mode |
SW5#configure terminal | Enter configure mode. |
SW5(config)#bridge 1 protocol rstp vlan- bridge | Create bridge 1 as an RSTP VLAN-aware bridge. |
SW5(config)#vlan database | Entering VLAN database. |
SW5(config-vlan)#vlan 512 bridge 1 state enable | Create VLAN 512 on bridge 1. |
SW5(config-vlan)#commit | Commit the candidate configuration to the running configuration. |
SW5(config-vlan)#exit | Exit config mode. |
SW5(config)#interface xe9 | Configure interface ce49. |
SW5(config-if)#switchport | Configure the interface as switch port. |
SW5(config-if)#bridge-group 1 | Configure interface in bridge group 1 |
SW5(config-if)#switchport mode trunk | Configure interface mode as trunk. |
SW5(config-if)#switchport trunk allowed vlan all | Allow all VLANs on interface ce49. |
SW5(config-if)#commit | Commit the candidate configuration to the running configuration. |
SW5(config-if)#exit | Exit config mode. |