OcNOS-SP : Layer 3 Guide : Virtual Router Redundancy Protocol Configuration Guide : Object Tracking Using IP SLA
Object Tracking Using IP SLA
This feature is used to track the state of an object for reachability using IP SLA. A client process such as Virtual Router Redundancy Protocol (VRRP), or RIB, registers itself to track objects and then get notified when a state change occurs.
IP SLA (Service-Level Assurance Protocol) is a Performance Measurement protocol. The protocol is used to Analyze IP Service Levels for IP applications and services. IP SLA's uses active traffic-monitoring technology to monitor continuous traffic on the network. 
IP SLA uses Internet Control Message Protocol (ICMP) pings to identify a link failure and notifies to the clients that are registered for tracking.
The Object Tracking feature provides complete separation between the objects to be tracked and the action to be taken by a client when a tracked object state changes. Thus, several clients such as VRRP, or RIB can register their interest with the tracking process, track the same object, and each take different action when the object changes. The Tracking feature is present in OAMD.
Each tracked object is identified by a unique number that is specified on the tracking CLI. Client processes use this number to track a specific object.
The tracking process processes events from the tracked objects and notes any change of value. The changes in the tracked object are communicated to interested client processes, either immediately or after a specified delay. The object values are reported as either up or down.
To configure VRRP Object Tracking, the object is configured to have a priority-delta value, which is passed to VRRP when a failure occurs. The priority of Virtual Router on the circuit is decremented by the priority- delta value, causing the VR Master to VR Backup transition.
In this example, two routers, R1 and R2, are configured as Master and backup routers with different priorities respectively. The priority-delta value is configured to be greater than the difference of both the priorities. R1 is configured to have a priority of 150, and R2 has a priority of 100. R1, with a greater priority, is the Virtual Router Master. The priority-delta value is 60, greater than 50 (150 minus 100). On R1, when the external interface xe41 fails, the Track state becomes DOWN and the priority of R1 becomes 90 (150 minus 60). Since R2 has a greater priority (100) than R1, R2 becomes the VR Master, and routing of packages continues without interruption. When the track state comes UP this VR Backup (R1) is UP again, it regains its original priority (150), and becomes the VR Master again.
Topology
VRRP Object Tracking
R1
 
(config)#configure terminal
Enter the Configure mode.
(config)#bridge 1 protocol rstp vlan-bridge
Create a RSTP VLAN aware bridge.
(config)#vlan 1001-1002 bridge 1
Create VLAN 1001,1002 and map it to bridge 1.
(config)#interface xe29
Enter interface mode.
(config-if)#switchport
Configure switch port.
(config-if)#bridge-group 1 spanning-tree disable
Configure bridge group to l2 interface with spanning-tree Disable.
(config-if)#switchport mode trunk
Configure switch port mode as trunk.
(config-if)#switchport trunk allowed vlan add 1001,1002
Allow vlan 1001 ,1002 on the interface.
(config-if)#interface vlan1.1001
Enter the vlan interface
(config-if)#ip address 10.1.1.2/24
Configure ipv4 address
(config-if)#ipv6 address 1000:1::2/32
Configure ipv6 address
(config-if)#ipv6 router ospf area 0.0.0.0
Tag ospfv3 instance on interface with area 0
(config-if)#exit
Exit the interface mode
(config)#ip sla 1
Configure IP SLA
(config-ip-sla)#icmp-echo ipv4 4.4.4.4 source-interface xe41
Configure ICMP-echo with a destination ipv4/ipv6 address
(config)#time-range tr1
Configure Time-Range
(config-tr)#start-time now
Configure the Start-Time
(config-tr)#commit
commit
(config-tr)#end-time after 100
Configure end-time
(config)#track 1 ip sla 1 reachability
Track the reachability of the IP SLA
(config)#router vrrp 1 vlan1.1001
Create a new ipv4 VRRP instance for interface vlan1.1001
(config-router)#virtual-ip 10.1.1.1
Set the virtual IP address for the VRRP session
(config-router)#priority 150
Configure the priority to 150
(config-router)# track 1 decrement 60
Configure the priority-delta value to be 60. In case of failover, this priority-delta value is subtracted from the current VR Master.
(config-router)#v2-compatible
Enable the v2-compatible
(config-router)#enable
Enable the VRRP session on the router.
(config-router)#commit
Commit the configuration on the node
(config-router)#exit
Exit the router mode.
(config)#router ipv6 vrrp 1 vlan1.1001
Create a new ipv6 VRRP instance for interface vlan1.1001.
(config-router)#virtual-ipv6 fe80::1
Set the virtual IPv6 address for the VRRP session.
(config-router)#priority 150
Configure the priority to 150
(config-router)# track 1 decrement 60
Configure the priority-delta value to be 70. In case of failover, this priority-delta value is subtracted from the current VR Master.
(config-router)#enable
Enable the VRRP session on the router.
(config-router)#commit
Commit the configuration on the node
(config-router)#exit
Exit the router mode
(config-if)#interface xe41
Enter interface mode
(config-if)#ip address 60.1.1.1/24
Configure ipv4 address
(config-if)#ipv6 address 6000::1/64
Configure ipv6 address
(config-if)#ipv6 router ospf area 0.0.0.0
Tag ospfv3 instance on interface with area 0
(config-if)#commit
Commit the configuration on the node
(config-if)#exit
Exit interface and configure mode
R2
 
(config)#bridge 1 protocol rstp vlan-bridge
Create a RSTP VLAN aware bridge with bridge-id.
(config)#vlan 1001-1002 bridge 1
Create VLAN 1001,1002 and map it to bridge 1
(config)#interface xe31
Enter interface mode
(config-if)#switchport
Configure switch port
(config-if)#bridge-group 1 spanning-tree disable
Configure bridge group to l2 interface with spanning-tree Disable
(config-if)#switchport mode trunk
Configure switch port mode as trunk
(config-if)#switchport trunk allowed vlan add 1001,1002
Allow vlan 1001 ,1002 on the interface
(config-if)#interface vlan1.1001
Enter the vlan interface
(config-if)#ip address 10.1.1.3/24
Configure ipv4 address
(config-if)#ipv6 address 1000:1::3/32
Configure ipv6 address
(config-if)#ipv6 router ospf area 0.0.0.0
Tag ospfv3 instance on interface with area 0
(config-if)#commit
Commit the configuration on the node
(config-if)#exit
Exit interface mode
(config)#router vrrp 1 vlan1.1001
Create a router ipv4 VRRP instance for interface vlan1.1001.
(config-router)#virtual-ip 10.1.1.1
Set the virtual IP address for the VRRP session.
(config-router)#priority 50
Configure the priority to 50 (less than 150), because R2 is the VR Backup router.
(config-router)#v2-compatible
Enable the v2-compatible
(config-router)#authentication text abcd
Configure the authentication text to specify that as simple text for vrrpv2 packets, accept only 8 characters.
(config-router)#enable
Enable the VRRP session
(config-router)#commit
Commit the configuration on the node
(config-router)#exit
Exit the router mode
(config)#router ipv6 vrrp 1 vlan1.1001
Create a router ipv6 VRRP ipv6 instance for interface vlan1.1001.
(config-router)#virtual-ipv6 fe80::1
Set the virtual IPv6 address for the VRRP session.
(config-router)#priority 50
Configure the priority to 50 (less than 150), because R2 is the VR Backup router.
(config-router)#commit
Commit the configuration on the node
(config-router)#exit
Exit the router mode
(config)#interface xe41
Enter interface mode
(config-if)#ip address 80.1.1.1/24
Configure ipv4 address
(config-if)#ipv6 address 8000::1/64
Configure ipv6 address
(config-if)#ipv6 router ospf area 0.0.0.0
Tag ospfv3 instance on interface with area 0
Validation
R1# sh track
TRACK Id: 1
IP SLA 1 reachability
Reachability is UP
2 changes, last change : 2019 Feb 19 07:19:57
 
R1# show vrrp 1 vlan1.1001 VRRP Version: 3
VMAC enabled
Backward Compatibility disabled Address family IPv4
VRRP Id: 1 on interface: vlan1.1001 State: AdminUp - Master
Virtual IP address: 10.1.1.1 (Not-owner) Virtual MAC address is 0000.5e00.0101 Operational primary IP address: 10.1.1.2 Operational master IP address: 10.1.1.2 Configured priority: 150, Current priority: 150 Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 0 hours 1 minutes 12 seconds (7200 centi sec)
Master uptime: 0 hours 2 minutes 34 seconds (15400 centi sec) Accept mode: TRUE
Preempt mode: TRUE
Monitored circuit: xe41, Priority Delta: 70, Status: UP Monitored circuit: xe50/1, Priority Delta: 10, Status: UP Monitored circuit: xe50/2, Priority Delta: 30, Status: UP
Auth-type: simple text, String: abcd
Multicast membership on IPv4 interface vlan1.1001: JOINED V 2-Compatible: TRUE
 
R1#
R2#show vrrp 1 vlan1.1001 VRRP Version: 3
VMAC enabled
Backward Compatibility disabled Address family IPv4
VRRP Id: 1 on interface: vlan1.1001 State: AdminUp - Backup
Virtual IP address: 10.1.1.1 (Not-owner) Virtual MAC address is 0000.5e00.0101 Operational primary IP address: 10.1.1.3 Operational master IP address: 10.1.1.2 Priority is 100
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 7 hours 52 minutes 53 seconds (2837300 centi sec) Skew time: 80 centi sec
Master Down Interval: 380 centi sec Accept mode: TRUE
Preempt mode: TRUE
Auth-type: simple text, String: abcd
Multicast membership on IPv4 interface vlan1.1001: JOINED V2-Compatible: TRUE
 
 
 
R2#
R1#show vrrp ipv6 1 vlan1.1001 VRRP Version: 3
VMAC enabled
Backward Compatibility disabled Address family IPv6
VRRP Id: 1 on interface: vlan1.1001 State: AdminUp - Master
Virtual IP address: fe80::1 (Not-owner) Virtual MAC address is 0000.5e00.0201
Operational primary IP address: fe80::ba6a:97ff:fe3c:de9d Operational master IP address: fe80::ba6a:97ff:fe3c:de9d Configured priority: 150, Current priority: 150 Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 0 hours 3 minutes 54 seconds (23400 centi sec)
Master uptime: 0 hours 2 minutes 34 seconds (15400 centi sec) Accept mode: TRUE
Preempt mode: TRUE
Monitored circuit: xe41, Priority Delta: 70, Status: UP Monitored circuit: xe50/1, Priority Delta: 10, Status: UP Monitored circuit: xe50/2, Priority Delta: 30, Status: UP Multicast membership on IPv6 interface vlan1.1001: JOINED V2-Compatible: FALSE
R1#
R2#show vrrp ipv6 1 vlan1.1001 VRRP Version: 3
VMAC enabled
Backward Compatibility disabled Address family IPv6
VRRP Id: 1 on interface: vlan1.1001 State: AdminUp - Backup
Virtual IP address: fe80::1 (Not-owner) Virtual MAC address is 0000.5e00.0201
Operational primary IP address: fe80::82a2:35ff:fe35:135f Operational master IP address: fe80::ba6a:97ff:fe3c:de9d Priority is 100
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 7 hours 55 minutes 11 seconds (2851100 centi sec) Skew time: 80 centi sec
Master Down Interval: 380 centi sec Accept mode: TRUE
Preempt mode: TRUE
Multicast membership on IPv6 interface vlan1.1001: JOINED V2-Compatible: FALSE
R2#
 
After shut down the tracked Object (xe41) in R1:
R1# sh track
TRACK Id: 1
IP SLA 1 reachability
Reachability is DOWN
2 changes, last change : 2019 Feb 19 07:19:57
 
R1#show vrrp 1 vlan1.1001 VRRP Version: 3
VMAC enabled
Backward Compatibility disabled Address family IPv4
VRRP Id: 1 on interface: vlan1.1001 State: AdminUp - Backup
Virtual IP address: 10.1.1.1 (Not-owner)
 
 
Virtual MAC address is 0000.5e00.0101 Operational primary IP address: 10.1.1.2 Operational master IP address: 10.1.1.3
Priority is 90 (Configured Priority is 150) Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 0 hours 7 minutes 46 seconds (46600 centi sec) Skew time: 84 centi sec
Master Down Interval: 380 centi sec Accept mode: TRUE
Preempt mode: TRUE
Monitored circuit: xe41, Priority Delta: 70, Status: DOWN Monitored circuit: xe50/1, Priority Delta: 10, Status: DOWN Monitored circuit: xe50/2, Priority Delta: 30, Status: DOWN Auth-type: simple text, String: abcd
Multicast membership on IPv4 interface vlan1.1001: JOINED V2-Compatible: TRUE
R1#
R2#show vrrp 1 vlan1.1001 VRRP Version: 3
VMAC enabled
Backward Compatibility disabled Address family IPv4
VRRP Id: 1 on interface: vlan1.1001 State: AdminUp - Master
Virtual IP address: 10.1.1.1 (Not-owner) Virtual MAC address is 0000.5e00.0101 Operational primary IP address: 10.1.1.3 Operational master IP address: 10.1.1.3 Priority is 100
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 7 hours 57 minutes 41 seconds (2866100 centi sec)
Master uptime: 0 hours 2 minutes 34 seconds (15400 centi sec) Accept mode: TRUE
Preempt mode: TRUE
Multicast membership on IPv4 interface vlan1.1001: JOINED V2-Compatible: FALSE
R2#
R1#show vrrp ipv6 1 vlan1.1001 VRRP Version: 3
VMAC enabled
Backward Compatibility disabled Address family IPv6
VRRP Id: 1 on interface: vlan1.1001 State: AdminUp - Backup
Virtual IP address: fe80::1 (Not-owner) Virtual MAC address is 0000.5e00.0201
Operational primary IP address: fe80::ba6a:97ff:fe3c:de9d Operational master IP address: fe80::82a2:35ff:fe35:135f Priority is 90 (Configured Priority is 150)
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 0 hours 8 minutes 43 seconds (52300 centi sec) Skew time: 84 centi sec
Master Down Interval: 380 centi sec Accept mode: TRUE
 
 
Preempt mode: TRUE
Monitored circuit: xe41, Priority Delta: 70, Status: DOWN Monitored circuit: xe50/1, Priority Delta: 10, Status: DOWN Monitored circuit: xe50/2, Priority Delta: 30, Status: DOWN Multicast membership on IPv6 interface vlan1.1001: JOINED V2-Compatible: FALSE
R1#
R2#show vrrp ipv6 1 vlan1.1001 VRRP Version: 3
VMAC enabled
Backward Compatibility disabled Address family IPv6
VRRP Id: 1 on interface: vlan1.1001 State: AdminUp - Master
Virtual IP address: fe80::1 (Not-owner) Virtual MAC address is 0000.5e00.0201
Operational primary IP address: fe80::82a2:35ff:fe35:135f Operational master IP address: fe80::82a2:35ff:fe35:135f Priority is 100
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 7 hours 59 minutes 4 seconds (2874400 centi sec)
Master uptime: 0 hours 2 minutes 34 seconds (15400 centi sec) Accept mode: TRUE
Preempt mode: TRUE
Multicast membership on IPv6 interface vlan1.1001: JOINED V2-Compatible: FALSE
R2#