#configure terminal | Enter Configure mode. |
(config)#interface eth1 | Specify the interface (eth1) to configure. |
(config-if)#ipv6 address 3ffe:10::10/48 | Specify the IPv6 global address. |
(config-if)#exit | Enter Configure mode. |
(config)#router bgp 200 | Define the routing process. The number 200 specifies the AS number of R2. |
(config-router)#bgp router-id 10.10.10.11 | Configure a fixed Router ID (10.10.10.11) for the BGP4+ routing process. |
(config-router)#neighbor 3ffe:10::10 remote-as 200 | Define the BGP neighbor (R1), and establish a TCP session by specifying the global IPv6 address (3ffe:10::10)and the AS number(200)of neighbor R1. |
(config-router)#address-family ipv6 | Enter Address Family mode for configuring routing sessions that use IPv6 address prefixes. |
(config-router-af)#neighbor 3ffe:10::10 activate | Activate the neighbor R1(3ffe:10::10), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#exit-address-family | Exit address family |
(config-router)#commit | Commit the candidate configuration to the running configuration |
#configure terminal | Enter Configure mode. |
(config)#interface eth1 | Specify the interface (eth1) to configure. |
(config-if)#ipv6 address 3ffe:10::11/48 | Specify the IPv6 global address. |
(config-if)#exit | Enter Configure mode. |
(config)#router bgp 200 | Define the routing process. The number 200 specifies the AS number of R2. |
(config-router)#bgp router-id 10.10.10.11 | Configure a fixed Router ID (10.10.10.11) for the BGP4+ routing process. |
(config-router)#neighbor 3ffe:10::10 remote-as 200 | Define the BGP neighbor (R1), and establish a TCP session by specifying the global IPv6 address (3ffe:10::10)and the AS number(200)of neighbor R1. |
(config-router)#address-family ipv6 | Enter Address Family mode for configuring routing sessions that use IPv6 address prefixes. |
(config-router-af)#neighbor 3ffe:10::10 activate | Activate the neighbor R1(3ffe:10::10), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#exit-address-family | Exit address family |
(config-router)#commit | Commit the candidate configuration to the running configuration |
#configure terminal | Enter Configure mode. |
---|---|
(config)#router bgp 200 | Define the routing process. The number 200 specifies the AS number of R1. |
(config-router)#bgp router-id 10.10.10.10 | Configure a fixed Router ID (10.10.10.10) for the BGP4+ routing process. |
(config-router)#neighbor fe80::2 remote-as 200 | Define BGP neighbor (R2), and establish a TCP session by specifying the link-local address (fe80::2)and the AS number(200)of neighbor R2. |
(config-router)#neighbor fe80::2 interface eth0 | To specify a link-local neighbor, configure the interface name of the neighbor fe80::2. |
(config-router)#address-family ipv6 | Enter Address Family mode for configuring routing sessions that use IPv6 address prefixes. |
(config-router-af)#neighbor fe80::2 activate | Activate the neighbor R2(fe80::2), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#exit-address-family | Exit address family |
(config-router)#commit | Commit the candidate configuration to the running configuration |
(config)#router bgp 200 | Define the routing process. The number 200 specifies the AS number of R2. |
(config-router)#bgp router-id 10.10.10.11 | Configure a fixed Router ID (10.10.10.11) for the BGP4+ routing process. |
(config-router)#neighbor fe80::1 remote-as 200 | Define the BGP neighbor (R1), and establish a TCP session by specifying the link-local address R1(fe80::1) and the AS number(200)of neighbor R1. |
(config-router)#neighbor fe80::1 interface eth1 | To specify a link-local neighbor, configure the interface name of the neighbor fe80::1. |
(config-router)#address-family ipv6 | Enter Address Family mode for configuring routing sessions that use IPv6 address prefixes. |
(config-router-af)#neighbor fe80::1 activate | Activate the neighbor R1(fe80:1), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#exit-address-family | Exit address family |
(config-router)#commit | Commit the candidate configuration to the running configuration |
#configure terminal | Enter Configure mode. |
---|---|
(config)#router bgp 200 | Define the routing process. The number 200 specifies the AS number of R1. |
(config-router)#bgp router-id 10.10.10.10 | Configure a fixed Router ID (10.10.10.10) for the BGP4+ routing process. |
(config-router)#neighbor 3ffe:10::11 remote-as 300 | Define the BGP neighbor (R2), and establish a TCP session by specifying the IPv6 address (3ffe:10::11) and the AS number(300)of neighbor R2. |
(config-router)#address-family ipv6 | Enter Address Family mode for configuring routing sessions that use IPv6 address prefixes. |
(config-router-af)#neighbor 3ffe:10::11 activate | Activate the neighbor R2(3ffe:10::11), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#exit-address-family | Exit address family |
(config-router)#commit | Commit the candidate configuration to the running configuration |
(config)#router bgp 300 | Define the routing process. The number 300 specifies the AS number of R2. |
(config-router)#bgp router-id 10.10.10.11 | Configure a fixed Router ID (10.10.10.11) for the BGP4+ routing process. |
(config-router)#neighbor 3ffe:10::10 remote-as 200 | Define the BGP neighbor (R1), and establish a TCP session by specifying the IPv6 address (3ffe:10::10) and the AS number(200)of neighbor R1. |
(config-router)#address-family ipv6 | Enter Address Family mode for configuring routing sessions that use IPv6 address prefixes. |
(config-router-af)#neighbor 3ffe:10::10 activate | Activate the neighbor R1(3ffe:10::10) and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#exit-address-family | Exit address family |
(config-router)#commit | Commit the candidate configuration to the running configuration |
#configure terminal | Enter Configure mode. |
---|---|
(config)Interface eth1 | Specify the interface (eth1) to configure |
(config)Ipv6 address 3ffe:10::10/64 | Specify the IPv6 global address |
(config)Exit | Enter Configure mode |
(config)#ipv6 prefix-list myPrefixList | Create an entry in the prefix-list. myPrefixList is the name of the map that is created |
(config-ipv6-prefix-list)#seq 5 deny 3ffe:12::/32 ge 48 le 64 | Here 5 and 10 specify the sequence number or position of this specific route map. deny specifies the packets are to be rejected. permit specifies the packets are to be allowed. 48 and 64 are the minimum and maximum prefix lengths, respectively, to be matched. |
(config-ipv6-prefix-list)#seq 10 permit any | Create another entry in the myPrefixList map. 10 specifies the sequence number or position of this specific route map. permit any specifies accept all packets of any length. |
(config-ipv6-prefix-list)#exit | Exit the prefix-list mode |
(config)#route-map myPrefixList permit 1 | Enter Route-map mode. |
(config-route-map)#match ipv6 address prefix-list myPrefixList | Set the match criteria. In this case, if the route-map name matches myPrefixList, the packets from the first sequence will be denied. |
(config-route-map)#exit | Exit Route-map mode, and return to Configure mode. |
(config)#commit | Commit the candidate configuration to the running configuration |
(config)#router bgp 10 | Define the routing process. The number 10 specifies the AS number of R1. |
(config-router)#bgp router-id 192.168.10.10 | Configure a fixed Router ID (192.168.10.10) for the BGP4+ routing process. |
(config-router)#neighbor 3ffe:10:11 remote-as 11 | Define the BGP neighbor (R2), and establish a TCP session by specifying the IPv6 address (3ffe:10::11)and the AS number(11)of neighbor R2. |
(config-router-af)#exit | Exit from router BGP mode. |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config-router)#address-family ipv6 | Enter Address Family mode for configuring routing sessions that use IPv6 address prefixes. |
(config-router-af)#neighbor 3ffe:10::11 activate | Activate the neighbor R2(3ffe:10::11), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#neighbor 3ffe:10::11 route-map myPrefixList in | Apply the route-map myPrefixList to all incoming routes. |
(config-router-af)#exit-address-family | Exit Address Family mode, and return to Router mode. |
(config-router-af)#exit | Exit Router mode, and return to Configure mode. |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter Configure mode. |
(config)Interface eth1 | Specify the interface (eth1) to configure |
(config)Ipv6 address 3ffe:10::11/64 | Specify the IPv6 global address |
(config)Exit | Enter Configure mode |
(config)#router bgp 11 | Define the routing process. The number 11 specifies the AS number of R2. |
(config-router)#bgp router-id 192.168.10.11 | Configure a fixed Router ID (192.168.10.11) for the BGP4+ routing process. |
(config-router)#neighbor 3ffe:10::10 remote-as 10 | Define the BGP neighbor (R1), and establish a TCP session by specifying the IPv6 address (3ffe:10::10)and the AS number(10)of neighbor R1. |
(config-router)#address-family ipv6 | Enter Address Family mode for configuring routing sessions that use IPv6 address prefixes. |
(config-router-af)#network 3ffe:11::/48 | Announce the IPv6 network prefix (3ffe:11::/48). |
(config-router-af)#network 3ffe:12::/48 | Announce the IPv6 network prefix (3ffe:12::/48). |
(config-router-af)#neighbor 3ffe:10::10 activate | Activate the neighbor R1(3ffe:10::10), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#exit-address-family | Exit Address Family mode, and return to Router mode. |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter Configure mode. |
(config)#router bgp 1 | Define the routing process. The number 1 specifies the AS number of R5 (RR). |
(config-router)#bgp router-id 10.10.10.10 | Configure a fixed Router ID (10.10.10.10) for the BGP4+ routing process. |
(config-router)#neighbor 3ffe:10::50 remote-as 1 | Define the BGP neighbor (R2), and establish a TCP session by specifying the IPv6 address (3ffe:10::50)and the AS number(1)of neighbor R2. |
(config-router)#neighbor 3ffe:11::50 remote-as 1 | Define the BGP neighbor (R4), and establish a TCP session by specifying the IPv6 address (3ffe:11::50)and the AS number(1) of neighbor R4. |
(config-router)#address-family ipv6 | Enter Address Family mode for configuring routing sessions that use IPv6 address prefixes. |
(config-router-af)#neighbor 3ffe:10::50 activate | Activate the neighbor R2(3ffe:10::50), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#neighbor 3ffe:10::50 route-reflector-client | Configure R5 as the Route-Reflector (RR) and neighbor R2 as its client. |
(config-router-af)#neighbor 3ffe:11::50 activate | Activate the neighbor R4(3ffe:11::50), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#neighbor 3ffe:11::50 route-reflector-client | Configure R5 as the Route-Reflector (RR) and neighbor R4 as its client. |
(config-router-af)#exit-address-family | Exit address family |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 1 | Define the routing process. The number 1 specifies the AS number of R2 (RR Client 1). |
(config-router)#bgp router-id 10.10.10.50 | Configure a fixed Router ID (10.10.10.50) for the BGP4+ routing process. |
(config-router)#neighbor 3ffe:10::10 remote-as 1 | Define the BGP neighbor (R5), and establish a TCP session by specifying the IPv6 address (3ffe:10::10) and the AS number(1) of neighbor R5. |
(config-router)#address-family ipv6 | Enter Address Family mode for configuring routing sessions that use IPv6 address prefixes. |
(config-router-af)#neighbor 3ffe:10::10 activate | Activate the neighbor (3ffe:10::10), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#exit-address-family | Exit address family |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 1 | Define the routing process. The number 1 specifies the AS number of R4 (RR Client 2). |
(config-router)#bgp router-id 10.10.11.50 | Configure a fixed Router ID (10.10.11.50) for the BGP4+ routing process. |
(config-router)#neighbor 3ffe:11::10 remote-as 1 | Define the BGP neighbor (R5), and establish a TCP session by specifying the IPv6 address (3ffe:11::10) and the AS number(1) of the neighbor. |
(config-router)#address-family ipv6 | Enter Address Family mode for configuring routing sessions that use IPv6 address prefixes. |
(config-router-af)#neighbor 3ffe:11::10 activate | Activate the neighbor (3ffe:11::10), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#exit-address-family | Exit address family |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter Configure mode. |
(config)#router bgp 1000 | Define the routing process. The number 1000 specifies the AS number of R2. |
(config-router)#bgp router-id 10.10.10.2 | Configure a fixed Router ID (10.10.10.2) for the BGP4+ routing process. |
(config-router)#bgp confederation identifier 1 | Specify the BGP Confederation Identifier (1). To others, the group will appear as a single AS, and the identifier as its AS number. |
(config-router)#bgp confederation peers 1001 | Specify AS 1001 as s confederation peer, making it a member of the Confederation. |
(config-router)#bgp confederation peers 1002 | Specify AS 1002 as s confederation peer, making it a member of the Confederation. |
(config-router)#neighbor 3ffe:10::5 remote-as 1001 | Define the BGP neighbor (R5), and establish a TCP session by specifying the IPv6 address (3ffe:10::5) and the AS number(1001)of neighbor R5. |
(config-router)#neighbor 3ffe:9::1 remote-as 1000 | Define the BGP neighbor (R1), and establish a TCP session by specifying the IPv6 address (3ffe:9::1) and the AS number(1000)of neighbor R1. |
(config-router)#neighbor 3ffe:7::3 remote-as 1000 | Define the BGP neighbor (R3), and establish a TCP session by specifying the IPv6 address (3ffe:7::3)and the AS number(1000)of neighbor R3. |
(config-router)#address-family ipv6 | Enter Address Family mode for configuring routing sessions that use IPv6 address prefixes. |
(config-router-af)#neighbor 3ffe:10::5 activate | Activate neighbor R5(3ffe:10::5), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#neighbor 3ffe:9::1 activate | Activate neighbor R1(3ffe:9::1), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#neighbor 3ffe:7::3 activate | Activate neighbor R3(3ffe:7::3), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#exit-address-family | Exit address family |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 1001 | Define the routing process. The number 1001 specifies the AS number of R5. |
(config-router)#bgp router-id 10.10.10.5 | Configure a fixed Router ID (10.10.10.5) for the BGP4+ routing process. |
(config-router)#bgp confederation identifier 1 | Specify the BGP Confederation Identifier (1). To others, the group will appear as a single AS, and the identifier as its AS number. |
(config-router)#bgp confederation peers 1000 | Specify AS 1000 as s confederation peer, making it a member of the Confederation. |
(config-router)#bgp confederation peers 1002 | Specify AS 1002 as s confederation peer, making it a member of the Confederation. |
(config-router)#neighbor 3ffe:10::2 remote-as 1000 | Define the BGP neighbor (R2), and establish a TCP session by specifying the IPv6 address (3ffe:10::2)and the AS number(1000)of neighbor R2. |
(config-router)#neighbor 3ffe:11::7 remote-as 1002 | Define the BGP neighbor (R7), and establish a TCP session by specifying the IPv6 address (3ffe:11::7)and the AS number(1002)of neighbor R7. |
(config-router)#neighbor 3ffe:12::4 remote-as 1001 | Define the BGP neighbor (R4), and establish a TCP session by specifying the IPv6 address (3ffe:12::4)and the AS number(1001)of neighbor R4. |
(config-router)#neighbor 3ffe:13::6 remote-as 1001 | Define the BGP neighbor (R6), and establish a TCP session by specifying the IPv6 address (3ffe:13::6)and the AS number(1001)of neighbor R6. |
(config-router)#address-family ipv6 | Enter Address Family mode for configuring routing sessions that use IPv6 address prefixes. |
(config-router-af)#neighbor 3ffe:10::2 activate | Activate the neighbor R2(3ffe:10::2), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#neighbor 3ffe:11::7 activate | Activate the neighbor R7(3ffe:11::7), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#neighbor 3ffe:12::4 activate | Activate the neighbor R4(3ffe:12::4), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#neighbor 3ffe:13::6 activate | Activate the neighbor R6(3ffe:13::6), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#exit-address-family | Exit address family |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 1002 | Define the routing process. The number 1002 specifies the AS number of R7. |
(config-router)#bgp router-id 10.10.11.7 | Configure a fixed Router ID (10.10.11.7) for the BGP4+ routing process. |
(config-router)#bgp confederation identifier 1 | Specify BGP Confederation Identifier (1). To others, the group will appear as a single AS, and the identifier as its AS number. |
(config-router)#bgp confederation peers 1000 | Specify AS 1000 as s confederation peer, making it a member of the Confederation. |
(config-router)#bgp confederation peers 1001 | Specify AS 1001 as s confederation peer, making it a member of the Confederation. |
(config-router)#neighbor 3ffe:11::5 remote-as 1001 | Define the BGP neighbor (R5), and establish a TCP session by specifying the IPv6 address (3ffe:11::5)and the AS number(1001)of neighbor R5. |
(config-router)#neighbor 3ffe:15::8 remote-as 1002 | Define the BGP neighbor (R8), and establish a TCP session by specifying the IPv6 address (3ffe:15::8)and the AS number(1002)of neighbor R8. |
(config-router)#address-family ipv6 | Enter Address Family mode for configuring routing sessions that use IPv6 address prefixes. |
(config-router-af)#neighbor 3ffe:11::5 activate | Activate the neighbor R5(3ffe:11::5), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#neighbor 3ffe:15::8 activate | Activate the neighbor R8(3ffe:15::8), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#exit-address-family | Exit address family |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter Configure mode. |
---|---|
(config)#interface lo | Enter to the interface mode. |
(config-if)#ipv6 address 4000::1/64 | Assign ipv6 address to loopback interface. |
(config-if)#exit | Exit from interface mode. |
(config)#interface xe9 | Enter to the interface mode. |
(config-if)#ipv6 address 4ffe::119/64 | Configure ipv6 address. |
(config-if)#exit | Exit from interface mode. |
(config)#router bgp 100 | Assign the ASN value (100) to the router. |
(config-router)# bgp router-id 1.1.1.1 | Configuring bgp router id. |
(config-router)#bgp graceful-restart | Enable BGP graceful restart support. |
(config-router)#neighbor 4ffe::120 remote-as 200 | Specify the neighbor’s IP address (4ffe::120) and the ASN value of the neighbor (200). |
(config-router)#address-family ipv6 unicast | Exchange the IPv6 capabilities, and switch the mode to the IPv6 address family. |
(config-router-af)#network 4000::/64 | Advertising ipv6 address. |
(config-router-af)#neighbor 4ffe::120 activate | Specify the neighbor’s IPv6 address(4ffe::120), and activate the neighbor. |
(config-router-af)#neighbor 4ffe::120 capability graceful-restart | Specify the neighbor’s IPv6 address (4ffe::120) for which the graceful restart capability is supported. |
(config-router-af)#exit-address-family | Exit address family |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter Configure mode |
(config)#interface xe9 | Enter to the interface mode |
(config-if)#ipv6 address 4ffe::119/64 | Configure ipv6 address. |
(config-if)#exit | Exit from interface mode. |
(config)#router bgp 200 | Assign the ASN value (200) to the router. |
(config-router)# bgp router-id 2.2.2.2 | Configuring bgp router id. |
(config-router)#bgp graceful-restart | Enable BGP graceful restart support. |
(config-router)#bgp graceful-restart restart-time 120 | Configure the maximum time (120) required for neighbor(s) to restart. |
(config-router)#bgp graceful-restart stalepath-time 120 | Configure the maximum time (120) to retain stale paths from the restarting neighbor(s). |
(config-router)#neighbor 4ffe::119 remote-as 100 | Specify the neighbor’s IP address (4ffe::119) and the ASN value of the neighbor (100). |
(config-router)#address-family ipv6 unicast | Exchange the IPv6 capabilities, and switch the mode to the IPv6 address family. |
(config-router-af)#neighbor 4ffe::119 activate | Specify the neighbor’s IPv6 address(4ffe::119), and activate the neighbor. |
(config-router-af)#neighbor 4ffe::119 capability graceful-restart | Specify the neighbor’s IPv6 address (4ffe::119) for which the graceful restart capability is supported. |
(config-router-af)#exit-address-family | Exit address family |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter Configure mode. |
(config)#router bgp 100 | Assign the ASN value (100) to the router. |
(config-router)#neighbor 4ffe::120 remote-as 100 | Specify the neighbor's IP address and ASN value. |
(config-router)#address-family ipv6 unicast | Enter IPv6 Address-Family mode. |
(config-router-af)#neighbor 4ffe::120 activate | Activate the IPv6 neighbor. |
(config-router-af)#network 8ffe::132/64 | Specify the network to be advertised by the BGP routing process. |
(config-router-af)#exit-address-family | Exit Address Family mode, and return to Router mode. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter Configure mode. |
(config)#router bgp 100 | Assign the ASN value (100) to the router. |
(config-router)#neighbor 4ffe::121 remote-as 100 | Specify the neighbor’s IP address and ASN value. |
(config-router)#neighbor 5ffe::115 remote-as 200 | Specify the neighbor’s IP address and the ASN value of another neighbor. |
(config-router)#address-family ipv6 unicast | Enter IPv6 Address-Family mode. |
(config-router-af)#aggregate-address 2ffe::102/32 summary-only | Configure an IPv6 non-AS-set aggregate route on R2. The local distance will be applied to this route. |
(config-router-af)#neighbor 4ffe::121 activate | Activate the IPv6 neighbor. |
(config-router-af)#neighbor 5ffe::115 activate | Activate the IPv6 neighbor. |
(config-router-af)#distance bgp 12 13 11 | Configure the administrative distance for external, internal, and local routes received in IPv6 Address-Family mode. |
(config-router-af)#exit-address-family | Exit Address Family mode, and return to Router mode. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter Configure mode. |
(config)#router bgp 100 | Assign the ASN value (100) to the router. |
(config-router)#neighbor 5ffe::114 remote-as 100 | Specify the neighbor's IP address and ASN value. |
(config-router)#address-family ipv6 unicast | Enter IPv6 Address-Family mode. |
(config-router)#network 7ffe::99/64 | Specify the network to be advertised by the BGP routing process. |
(config-router-af)#neighbor 5ffe::114 activate | Activate the IPv6 neighbor. |
(config-router-af)#exit-address-family | Exit Address Family mode, and return to Router mode. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter Configure mode. |
---|---|
(config)#router bgp 100 | Assign the ASN value (100) to the router. |
(config-router)#bgp graceful-restart | Enable BGP graceful restart support. |
(config-router)#bgp graceful-restart graceful-reset | Configure to invoke graceful restart when a configuration change forces a peer reset. |
(config-router)#neighbor 4ffe::120 remote-as 200 | Specify the neighbor’s IP address (4ffe::120) and the ASN value of the neighbor (200). |
(config-router)#address-family ipv6 unicast | Exchange the IPv6 capabilities, and switch the mode to the IPv6 address family. |
(config-router-af)#neighbor 4ffe::120 activate | Specify the neighbor’s IPv6 address(4ffe::120), and activate the neighbor. |
(config-router-af)#neighbor 4ffe::120 capability graceful-restart | Specify the neighbor’s IPv6 address (4ffe::120) for which the graceful restart capability is supported. |
(config-router-af)#exit-address-family | Exit Address Family mode, and return to Router mode. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter Configure mode. |
---|---|
(config)#router bgp 200 | Assign the ASN value (200) to the router. |
(config-router)#bgp graceful-restart | Enable BGP graceful restart support. |
(config-router)#bgp graceful-restart graceful-reset | Configure to invoke graceful restart when a configuration change forces a peer reset. |
(config-router)#neighbor 4ffe::119 remote-as 100 | Specify the neighbor’s IP address (4ffe::119) and the ASN value of the neighbor (100). |
(config-router)#address-family ipv6 unicast | Exchange the IPv6 capabilities, and switch the mode to the IPv6 address family. |
(config-router-af)#neighbor 4ffe::119 activate | Specify the neighbor’s IPv6 address(4ffe::119), and activate the neighbor. |
(config-router-af)#neighbor 4ffe::119 capability graceful-restart | Specify the neighbor’s IPv6 address (4ffe::119) for which the graceful restart capability is supported. |
(config-router-af)#exit-address-family | Exit Address Family mode, and return to Router mode. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter Configure mode. |
(config)# ip vrf VRF1 | Create a VRF, vrf1. |
(config-vrf)#rd 100:10 | Configure a route distinguisher value. |
(config-vrf)#route-target both 100:10 | Configure a route target both value to VRF. |
(config-vrf)#exit | Exit from VRF configuration mode. |
(config)#interface eth1 | Enter Interface configuration mode. |
(config-if)#ip vrf forwarding VRF1 | Configure the interface to a VRF. |
(config-if)#ip address 30.30.30.30/24 | Assign an IP address to the interface. |
(config-if)#ipv6 address 2ffe::10/64 | Assign an IPV6 address to the interface. |
(config-if)#exit | Exit from interface configuration mode. |
(config)#ip route vrf VRF1 50.50.50.0/24 eth1 | Create a VRF static route. |
(config)#interface eth2 Enter | Interface configuration mode. |
(config-if)#ipv6 address 3ffe::10/64 | Assign an IPV6 address to the interface. |
(config-if)#exit | Exit from interface configuration mode. |
(config)#router bgp 100 Define the routing process. | The number 100 specifies the AS number of R1. |
(config-router)#bgp router-id 1.1.1.1 | Configure a fixed Router ID (1.1.1.1) for the BGP4+ routing process. |
(config-router)#neighbor 2.2.2.2 remote-as 200 | Define BGP neighbors, and establish a TCP session. 2.2.2.2 is the IP address of the neighbor (R1), and 200 is the neighbor’s AS number. |
(config-router)#neighbor 3ffe::11 remote-as 200 | Define the BGP neighbor (R2), and establish a TCP session by specifying the IPv6 address (3ffe::11)and the AS number(200)of neighbor R2. |
(config-router)#address-family vpnv4 unicast | Enter Address Family mode for configuring routing sessions that use IPv6 address prefixes. |
(config-router-af)#neighbor 2.2.2.2 activate | Activate the neighbor R2 (2.2.2.2), and enable exchange of IP address prefix types with this neighbor. |
(config-router-af)#neighbor 2.2.2.2 allow-ebgp-vpn | Configures the neighbor address to allow EBGP VPN. |
(config-router-af)#neighbor 3ffe::11 allow-ebgp-vpn | Apply allow-ebgp-vpn to allow an eBGP neighbor to be a VPN peer. |
(config-router-af)#neighbor 3ffe::11 activate | Activate the neighbor R2(3ffe::11), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#neighbor 3ffe::11 capability extended-nexthop-encode | Enable capability to encode IPv6 nexthop in VPNv4 NLRI. |
(config-router-af)#exit-address-family | Exit Address Family mode, and return to Router mode. |
(config-router)#address-family ipv4 vrf VRF1 | Enter IPv4 VRF address family. |
(config-router-af)#redistribute static | Redistribute static into the IPv4 VRF address family. |
(config-router-af)#exit-address-family | Exit Address Family mode, and return to Router mode. |
(config-router)#exit | Exit Router mode, and return to Configure mode. |
(config)#commit | Apply commit. |
(config)#exit | Exit the config mode. |
#configure terminal | Enter Configure mode. |
(config)# ip vrf VRF1 | Create a VRF, vrf1. |
(config-vrf)#rd 100:10 | Configure a route distinguisher value. |
(config-vrf)#route-target both 100:10 | Configure a route target both value to VRF. |
(config-vrf)#exit | Exit from VRF configuration mode. |
(config)#interface eth1 | Enter Interface configuration mode. |
(config-if)#ip vrf forwarding VRF1 | Configure the interface to a VRF. |
(config-if)#ip address 40.40.40.40/24 | Assign an IP address to the interface. |
(config-if)#ipv6 address 4ffe::10/64 | Assign an IPV6 address to the interface. |
(config-if)#exit | Exit from interface configuration mode. |
(config)#ip route vrf VRF1 66.66.66.0/24 eth1 | Create a VRF static route. |
(config)#interface eth2 | Enter Interface configuration mode. |
(config-if)#ipv6 address 3ffe::11/64 | Assign an IPV6 address to the interface. |
(config-if)#exit | Exit from interface configuration mode. |
(config)#router bgp 200 Define the routing process. | The number 200 specifies the AS number of R1. |
(config-router)#bgp router-id 2.2.2.2 | Configure a fixed Router ID (2.2.2.2) for the BGP4+ routing process. |
(config-router)#neighbor 1.1.1.1 remote-as 100 | Define BGP neighbors, and establish a TCP session. 1.1.1.1 is the IP address of the neighbor (R1), and 100 is the neighbor’s AS number. |
(config-router)#neighbor 3ffe::10 remote-as 100 | Define the BGP neighbor (R2), and establish a TCP session by specifying the IPv6 address (3ffe::10)and the AS number(100)of neighbor R2. |
(config-router)#address-family vpnv4 unicast | Enter Address Family mode for configuring routing sessions that use IPv6 address prefixes. |
(config-router-af)#neighbor 1.1.1.1 activate | Activate the neighbor R2(1.1.1.1), and enable exchange of IP address prefix types with this neighbor. |
(config-router-af)#neighbor 1.1.1.1 allow-ebgp-vpn | Configures the neighbor address to allow EBGP VPN. |
(config-router-af)#neighbor 3ffe::10 allow- ebgp-vpn | Apply allow-ebgp-vpn to allow an eBGP neighbor to be a VPN peer. |
(config-router-af)#neighbor 3ffe::10 activate | Activate the neighbor R2(3ffe::10), and enable exchange of IPv6 address prefix types with this neighbor. |
(config-router-af)#neighbor 3ffe::10 capability extended-nexthop-encode | Enable capability to encode IPv6 nexthop in VPNv4 NLRI. |
(config-router-af)#exit-address-family | Exit Address Family mode, and return to Router mode. |
(config-router)#address-family ipv4 vrf VRF1 | Enter IPv4 VRF address family. |
(config-router-af)#redistribute static | Redistribute static into the IPv4 VRF address family. |
(config-router-af)#exit-address-family | Exit Address Family mode, and return to Router mode. |
(config-router)#exit | Exit Router mode, and return to Configure mode. |
(config)#commit | Apply commit. |
(config)#exit | Exit the config mode. |