#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 11.11.11.55/32 secondary | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)#interface xe16 | Enter interface mode |
(config-if)#ip address 172.4.5.55/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)#exit | Exit interface mode. |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router ospf 1 | Configure the routing process OSPF with process Id 1. |
(config-router)#network 172.4.5.0/24 area 0 | Define the interface (172.4.5.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 11.11.11.55/32 area 0 | Define the interface (11.11.11.55/32) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 100 | Enter Router BGP mode |
(config-router)#neighbor 21.21.21.56 update-source lo | Add loopback IP of PE2 as neighbor with neighbor AS |
(config-router)#neighbor 21.21.21.56 update- source lo | Update the source for that particular neighbor as loopback interface |
(config-router)#neighbor 172.4.5.52 remote- as 100 | Add neighbor with neighbor AS |
(config-router)#allocate-label all | Allocate labels |
(config-router)#address-family ipv4 labeled- unicast | Enter into labeled-unicast address family |
(config-router-af)#neighbor 172.4.5.52 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)#exit-address-family | Exit from address family IPv4 labeled unicast |
(config-router)#address-family vpnv4 unicast | Enter into vpnv4 unicast address family |
(config-router-af)#neighbor 21.21.21.56 activate | Activate the neighbor inside vpnv4 address family |
(config-router-af)#exit-address-family | Exit from address family vpnv4. |
(config-router)#address-family ipv4 unicast | Enter into ipv4 unicast address family |
(config-router-af)#network 11.11.11.55/32 | Advertise the loopback of RTR1 in BGP |
(config-router-af)#exit-address-family | Exit from address family vpnv4 |
(config-router)#exit | Exit from router BGP mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)# ip vrf vrf1 | Specify the name of the VRF (vrf1) to be created. |
(config-vrf)#rd 10:100 | Assign a route distinguisher (RD) for the VRF, which is a unique value on the router. The RD value can be in ASN:NN or A.B.C.D:NN format. |
(config-vrf)#route-target both 100:300 | Specify the 2-Octet AS specific or IPv4 specific Transitive Route-Target extended community attribute. |
(config-vrf)#exit | Exit VRF mode, and return to Configure mode. |
(config)#interface xe10 | Enter interface mode |
(config-if)# ip vrf forwarding vrf1 | Bind the interface (eth2) to the VRF vrf1 |
(config-if)# ip address 172.10.20.55/24 | Configure the IP address of the interface eth2 |
(config-if)#exit | Exit interface mode. |
(config)#router bgp 100 | Enter Router BGP mode |
(config-router)# address-family ipv4 vrf vrf1 | Enter address family ipv4 vrf mode |
(config-router-af)# redistribute connected | Redistribute connected routes |
(config-router-af)# exit-address-family | Exit address-family mode. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 22.22.22.52/32 secondary | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)#interface xe16 | Enter interface mode |
(config-if)#ip address 172.4.5.52/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)#exit | Exit interface mode. |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#interface xe12 | Enter interface mode |
(config-if)#ip address 172.6.7.52/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)#exit | Exit interface mode. |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router ospf 1 | Configure the routing process OSPF with process Id 1 |
(config-router)#network 172.4.5.0/24 area 0 | Define the interface (172.4.5.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 172.6.7.0/24 area 0 | Define the interface (172.6.7.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)#router bgp 100 | Enter Router BGP mode |
(config-router)# neighbor 172.4.5.55 remote-as 100 | Add neighbor with neighbor AS |
(config-router)# neighbor 172.6.7.54 remote-as 100 | Add neighbor with neighbor AS |
(config-router)#allocate-label all | Allocate labels |
(config-router)# address-family ipv4 labeled-unicast | Enter into labeled-unicast address family |
(config-router-af)#neighbor 172.6.7.54 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)#neighbor 172.4.5.55 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)# neighbor 172.4.5.55 route-reflector-client | Enable Route reflector client for the neighbor inside address family IPv4 labeled unicast |
(config-router-af)# neighbor 172.6.7.54 route-reflector-client | Enable Route reflector client for the neighbor inside address family IPv4 labeled unicast |
(config-router-af)# neighbor 172.4.5.55 next-hop-self | Enable next hop self for the particular neighbor inside address family IPv4 labeled unicast |
(config-router-af)# neighbor 172.6.7.54 next-hop-self | Enable next hop self for the particular neighbor inside address family IPv4 labeled unicast |
(config-router-af)#exit-address-family | Exit address-family mode |
(config-router)#exit | Exit from router BGP mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)# ip address 200.200.200.54/32 secondary | Configure the IP address of the interface loopbak |
(config-if)#exit | Exit interface mode |
(config)#interface xe16 | Enter interface mode |
(config-if)#ip address 172.1.2.54/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)#exit | Exit interface mode. |
(config)#interface xe12 | Enter interface mode |
(config-if)#ip address 172.6.7.54/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)#exit | Exit interface mode. |
(config)#router ospf 1 | Configure the routing process OSPF with process Id 1 |
(config-router)#network 172.1.2.0/24 area 0 | Define the interface (172.1.2.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 172.6.7.0/24 area 0 | Define the interface (172.6.7.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 100 | Enter Router BGP mode |
(config-router)# neighbor 172.1.2.53 remote-as 100 | Add neighbor with neighbor AS |
(config-router)# neighbor 172.6.7.52 remote-as 100 | Add neighbor with neighbor AS |
(config-router)#allocate-label all | Allocate labels |
(config-router)# address-family ipv4 labeled-unicast | Enter into labeled-unicast address family |
(config-router-af)#neighbor 172.6.7.52 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)#neighbor 172.1.2.53 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)# neighbor 172.1.2.53 route-reflector-client | Enable Route reflector client for the neighbor inside address family IPv4 labeled unicast |
(config-router-af)# neighbor 172.6.7.52 route-reflector-client | Enable Route reflector client for the neighbor inside address family IPv4 labeled unicast |
(config-router-af)# neighbor 172.1.2.53 next-hop-self | Enable next hop self for the particular neighbor inside address family IPv4 labeled unicast |
(config-router-af)# neighbor 172.6.7.52 next-hop-self | Enable next hop self for the particular neighbor inside address family IPv4 labeled unicast |
(config-router)# exit-address-family | Exit from address family. |
(config-router)#exit | Exit from router BGP mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)# ip address 44.44.44.53/32 secondary | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)#interface xe16 | Enter interface mode |
(config-if)#ip address 172.1.2.53/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)#exit | Exit interface mode. |
(config)#interface xe10 | Enter interface mode |
(config-if)#ip address 172.3.4.53/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)#exit | Exit interface mode. |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router ospf 1 | Configure the routing process OSPF with process Id 1 |
(config-router)#network 172.1.2.0/24 area 0 | Define the interface (172.1.2.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 172.3.4.0/24 area 0 | Define the interface (172.3.4.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 100 | Enter Router BGP mode |
(config-router)# neighbor 172.1.2.54 remote-as 100 | Add neighbor with neighbor AS |
(config-router)# neighbor 172.3.4.56 remote-as 100 | Add neighbor with neighbor AS |
(config-router)#allocate-label all | Allocate labels |
(config-router)# address-family ipv4 labeled-unicast | Enter into labeled-unicast address family |
(config-router-af)#neighbor 172.3.4.56 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)#neighbor 172.1.2.54 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)# neighbor 172.3.4.56 route-reflector-client | Enable Route reflector client for the neighbor inside address family IPv4 labeled unicast |
(config-router-af)# neighbor 172.1.2.54 route-reflector-client | Enable Route reflector client for the neighbor inside address family IPv4 labeled unicast |
(config-router-af)# neighbor 172.3.4.56 next-hop-self | Enable next hop self for the particular neighbor inside address family IPv4 labeled unicast |
(config-router-af)# neighbor 172.1.2.54 next-hop-self | Enable next hop self for the particular neighbor inside address family IPv4 labeled unicast |
(config-router-af)#exit-address-family | Exit from address family vpnv4 |
(config-router)#exit | Exit from router BGP mode |
(config)#end | Exit from config mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 21.21.21.56/32 secondary | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)#interface xe10 | Enter interface mode |
(config-if)#ip address 172.3.4.56/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)#exit | Exit interface mode. |
(config)#router ospf 1 | Configure the routing process OSPF with process Id 1 |
(config-router)#network 172.3.4.0/24 area 0 | Define the interface (172.3.4.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 21.21.21.56/32 area 0 | Define the interface (21.21.21.56/32) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 100 | Enter Router BGP mode |
(config-router)#neighbor 11.11.11.55 remote-as 100 | Add loopback ip of PE1 as neighbor with neighbor AS |
(config-router)#neighbor 11.11.11.55 update-source lo | Update the source for that particular neighbor as loopback interface |
(config-router)# neighbor 172.3.4.53 remote-as 100 | Add neighbor with neighbor AS |
(config-router)#allocate-label all | Allocate labels |
(config-router)# address-family ipv4 labeled-unicast | Enter into labeled-unicast address family |
(config-router-af)#neighbor 172.3.4.53 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)#exit-address-family | Exit from address family IPv4 labeled unicast |
(config-router)#address-family vpnv4 unicast | Enter into vpnv4 unicast address family |
(config-router-af)#neighbor 11.11.11.55 activate | Activate the neighbor inside vpnv4 address family |
(config-router-af)#exit-address-family | Exit from address family vpnv4 |
(config-router-af)#network 21.21.21.56/32 | Advertise the loopback in BGP |
(config-router-af)#exit-address-family | Exit from address family ipv4 unicast |
(config-router)#exit | Exit from router BGP mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)# ip vrf vrf1 | Specify the name of the VRF (vrf1) to be created. |
(config-vrf)#rd 10:100 | Assign a route distinguisher (RD) for the VRF, which is a unique value on the router. The RD value can be in ASN:NN or A.B.C.D:NN format. |
(config-vrf)#route-target both 100:300 | Specify the 2-Octet AS specific or IPv4 specific Transitive Route-Target extended community attribute. |
(config-vrf)#exit | Exit VRF mode, and return to Configure mode. |
(config)#interface xe0 | Enter interface mode |
(config-if)# ip vrf forwarding vrf1 | Bind the interface (eth2) to the VRF vrf1 |
(config-if)# ip address 172.23.4.56/24 | Configure the IP address of the interface eth2 |
(config-if)#exit | Exit interface mode. |
(config)#router bgp 100 | Enter Router BGP mode |
(config-router)# address-family ipv4 vrf vrf1 | Enter address family ipv4 vrf mode |
(config-router)# redistribute connected | Redistribute connected routes |
(config-router)#exit | Exit from router mode into privilege mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 1.1.1.54/32 secondary | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)#interface eth1 | Enter interface mode |
(config-if)#ip address 10.1.1.54/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth1 interface |
(config-if)#exit | Exit interface mode. |
(config)#router ospf 10 | Configure the routing process OSPF with process id 10 |
(config-router)#network 1.1.1.54/32 area 0 | Define the interface (1.1.1.54/32) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 10.1.1.0/24 area 0 | Define the interface (10.1.1.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 100 | Enter Router BGP mode |
(config-router)#neighbor 7.7.7.55 remote- as 100 | Add loopback ip of PE2 as neighbor with neighbor AS |
(config-router)#neighbor 7.7.7.55 update- source lo | Update the source for that particular neighbor as loopback interface |
(config-router)#neighbor 3.3.3.52 remote- as 100 | Add loopback ip of ABR1 as neighbor with neighbor AS |
(config-router)#neighbor 3.3.3.52 update- source lo | Update the source for that particular neighbor as loopback interface |
(config-router)#allocate-label all | Allocate labels |
(config-router)#address-family ipv4 labeled- unicast | Enter into labeled-unicast address family |
(config-router-af)#neighbor 3.3.3.52 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)#exit-address-family | Exit from address family IPv4 labeled unicast |
(config-router)#address-family vpnv4 unicast | Enter into vpnv4 unicast address family |
(config-router-af)#neighbor 7.7.7.55 activate | Activate the neighbor inside vpnv4 address family |
(config-router)#address-family ipv4 labeled- unicast | Enter into labeled-unicast address family |
(config-router)#address-family ipv4 unicast | Enter into ipv4 unicast address family |
(config-router-af)#network 1.1.1.54/32 | Advertise the loopback of RTR1 in BGP |
(config-router-af)#exit-address-family | Exit from address family |
(config-router)#exit | Exit from router BGP mode |
(config)# router ldp | Configure Router LDP instance |
(config-router)# transport-address ipv4 1.1.1.54 0 | Configure Transport address for LDP with label space value 0 |
(config-router)#exit | Exit from router mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)# ip vrf vrf1 | Specify the name of the VRF (vrf1) to be created. |
(config-vrf)#rd 10:100 | Assign a route distinguisher (RD) for the VRF, which is a unique value on the router. The RD value can be in ASN:NN or A.B.C.D:NN format. |
(config-vrf)#route-target both 100:300 | Specify the 2-Octet AS specific or IPv4 specific Transitive Route-Target extended community attribute. |
(config-vrf)#exit | Exit VRF mode, and return to Configure mode. |
(config)#interface eth2 | Enter interface mode |
(config-if)# ip vrf forwarding vrf1 | Bind the interface (eth2) to the VRF vrf1 |
(config-if)# ip address 61.1.1.54/24 | Configure the IP address of the interface eth2 |
(config-if)#exit | Exit interface mode. |
(config)#router bgp 100 | Enter Router BGP mode |
(config-router)# address-family ipv4 vrf vrf1 | Enter address family ipv4 vrf mode |
(config-router-af)# redistribute connected | Redistribute connected routes |
(config-router-af)# exit-address-family | Exit address-family mode. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 2.2.2.23/32 | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)#interface eth1 | Enter interface mode |
(config-if)#ip address 10.1.1.23/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth1 interface |
(config-if)#exit | Exit interface mode. |
(config)#interface eth2 | Enter interface mode |
(config-if)#ip address 20.1.1.23/24 | Configure the IP address of the interface eth2 |
(config-if)#label-switching | Enable label-switching on interface eth2 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth2 interface |
(config-if)#exit | Exit interface mode. |
(config)#router ospf 10 | Configure the routing process OSPF with process id 10 |
(config-router)#network 20.1.1.0/24 area 0 | Define the interface (20.1.1.0/24)) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 10.1.1.0/24 area 0 | Define the interface (10.1.1.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 2.2.2.23/32 area 0 | Define the interface (2.2.2.23/32) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)# router ldp | Configure Router LDP instance |
(config-router)# transport-address ipv4 2.2.2.23 0 | Configure Transport address for LDP with label space value 0 |
(config-router)#exit | Exit from router mode |
(config)# ip route 7.7.7.55/32 20.1.1.52 | Specify the destination prefix and mask for the network and a gateway. |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 3.3.3.52/32 | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)#interface eth1 | Enter interface mode |
(config-if)#ip address 30.1.1.52/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth1 interface |
(config-if)#exit | Exit interface mode. |
(config)#interface eth2 | Enter interface mode |
(config-if)#ip address 20.1.1.52/24 | Configure the IP address of the interface eth2 |
(config-if)#label-switching | Enable label-switching on interface eth2 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth2 interface |
(config-if)#exit | Exit interface mode. |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router ospf 20 | Configure the routing process OSPF with process id 20 |
(config-router)#network 3.3.3.52/32 area 0 | Define the interface (3.3.3.52/32) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 20.1.1.0/24 area 0 | Define the interface (20.1.1.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)# router ldp | Configure Router LDP instance |
(config-router)# transport-address ipv4 3.3.3.52 0 | Configure Transport address for LDP with label space value 0 |
(config-router)#exit | Exit from router mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 100 | Enter Router BGP mode |
(config-router)#neighbor 1.1.1.54 remote- as 100 | Add loopback ip of PE2 as neighbor with neighbor AS |
(config-router)#neighbor 1.1.1.54 update- source lo | Update the source for that particular neighbor as loopback interface |
(config-router)#neighbor 5.5.5.56 remote- as 100 | Add loopback ip of ABR1 as neighbor with neighbor AS |
(config-router)#neighbor 5.5.5.56 update- source lo | Update the source for that particular neighbor as loopback interface |
(config-router)#allocate-label all | Allocate labels |
(config-router)#address-family ipv4 labeled- unicast | Enter into labeled-unicast address family |
(config-router-af)#neighbor 1.1.1.54 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)#neighbor 5.5.5.56 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)# neighbor 1.1.1.54 route-reflector-client | Enable Route reflector client for the neighbor inside address family IPv4 labeled unicast |
(config-router-af)# neighbor 5.5.5.56 route-reflector-client | Enable Route reflector client for the neighbor inside address family IPv4 labeled unicast |
(config-router-af)# neighbor 1.1.1.54 next-hop-self | Enable next hop self for the particular neighbor inside address family IPv4 labeled unicast |
(config-router-af)# neighbor 5.5.5.56 next-hop-self | Enable next hop self for the particular neighbor inside address family IPv4 labeled unicast |
(config-router-af)#exit-address-family | Exit from address family labeled-unicast |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 4.4.4.53/32 | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)#interface eth1 | Enter interface mode |
(config-if)#ip address 30.1.1.53/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth1 interface |
(config-if)#exit | Exit interface mode. |
(config)#interface eth2 | Enter interface mode |
(config-if)#ip address 40.1.1.53/24 | Configure the IP address of the interface eth2 |
(config-if)#label-switching | Enable label-switching on interface eth2 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth2 interface |
(config-if)#exit | Exit interface mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router ospf 20 | Configure the routing process OSPF with process id 20 |
(config-router)#network 30.1.1.0/24 area 0 | Define the interface (30.1.1.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 40.1.1.0/24 area 0 | Define the interface (40.1.1.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 4.4.4.53/32 area 0 | Define the interface (4.4.4.53/32) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)# router ldp | Configure Router LDP instance |
(config-router)# transport-address ipv4 4.4.4.53 0 | Configure Transport address for LDP with label space value 0 |
(config-router)#exit | Exit from router mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 5.5.5.56/32 | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)#interface eth1 | Enter interface mode |
(config-if)#ip address 50.1.1.56/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth1 interface |
(config-if)#exit | Exit interface mode. |
(config)#interface eth2 | Enter interface mode |
(config-if)#ip address 40.1.1.56/24 | Configure the IP address of the interface eth2 |
(config-if)#label-switching | Enable label-switching on interface eth2 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth2 interface |
(config-if)#exit | Exit interface mode. |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router ospf 30 | Configure the routing process OSPF with process id 20 |
(config-router)#network 5.5.5.56/32 area 0 | Define the interface 5.5.5.56/32) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 50.1.1.0/24 area 0 | Define the interface (50.1.1.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router ospf 20 | Configure the routing process OSPF with process id 20 |
(config-router)#network 5.5.5.56/32 area 0 | Define the interface 5.5.5.56/32) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 40.1.1.0/24 area 0 | Define the interface (40.1.1.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)# router ldp | Configure Router LDP instance |
(config-router)# transport-address ipv4 3.3.3.52 0 | Configure Transport address for LDP with label space value 0 |
(config-router)#exit | Exit from router mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 100 | Enter Router BGP mode |
(config-router)#neighbor 3.3.3.52 remote- as 100 | Add loopback ip of PE2 as neighbor with neighbor AS |
(config-router)#neighbor 3.3.3.52 update- source lo | Update the source for that particular neighbor as loopback interface |
(config-router)#neighbor 7.7.7.55 remote- as 100 | Add loopback ip of ABR1 as neighbor with neighbor AS |
(config-router)#neighbor 7.7.7.55 update- source lo | Update the source for that particular neighbor as loopback interface |
(config-router)#address-family ipv4 labeled- unicast | Enter into labeled-unicast address family |
(config-router-af)#neighbor 3.3.3.52 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)#neighbor 7.7.7.55 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)# neighbor 3.3.3.52 route-reflector-client | Enable Route reflector client for the neighbor inside address family IPv4 labeled unicast |
(config-router-af)# neighbor 7.7.7.55 route-reflector-client | Enable Route reflector client for the neighbor inside address family IPv4 labeled unicast |
(config-router-af)# neighbor 3.3.3.52 next-hop-self | Enable next hop self for the particular neighbor inside address family IPv4 labeled unicast |
(config-router-af)# neighbor 7.7.7.55 next-hop-self | Enable next hop self for the particular neighbor inside address family IPv4 labeled unicast |
(config-router-af)#exit-address-family | Exit from address family labeled-unicast |
(config-router)#exit | Exit from router BGP mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 6.6.6.22/32 | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)#interface eth1 | Enter interface mode |
(config-if)#ip address 50.1.1.22/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth1 interface |
(config-if)#exit | Exit interface mode. |
(config)#interface eth2 | Enter interface mode |
(config-if)#ip address 60.1.1.22/24 | Configure the IP address of the interface eth2 |
(config-if)#label-switching | Enable label-switching on interface eth2 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth2 interface |
(config-if)#exit | Exit interface mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router ospf 30 | Configure the routing process OSPF with process id 20 |
(config-router)#network 50.1.1.0/24 area 0 | Define the interface (30.1.1.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 60.1.1.0/24 area 0 | Define the interface (40.1.1.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 6.6.6.22/32 area 0 | Define the interface (4.4.4.53/32) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)# router ldp | Configure Router LDP instance |
(config-router)# transport-address ipv4 6.6.6.22 0 | Configure Transport address for LDP with label space value 0 |
(config-router)#exit | Exit from router mode |
(config)# ip route 1.1.1.54/32 50.1.1.56 | Specify the destination prefix and mask for the network and a gateway. |
(config)#exit | Exit from config mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 7.7.7.55/32 secondary | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)#interface eth2 | Enter interface mode |
(config-if)#ip address 60.1.1.55/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth1 interface |
(config-if)#exit | Exit interface mode. |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router ospf 30 | Configure the routing process OSPF with process id 10 |
(config-router)#network 7.7.7.55/32 area 0 | Define the interface (7.7.7.55/32) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 60.1.1.0/24 area 0 | Define the interface (60.1.1.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 100 | Enter Router BGP mode |
(config-router)#neighbor 1.1.1.54 remote- as 100 | Add loopback ip of PE2 as neighbor with neighbor AS |
(config-router)#neighbor 1.1.1.54 update- source lo | Update the source for that particular neighbor as loopback interface |
(config-router)#neighbor 5.5.5.56 remote- as 100 | Add loopback ip of ABR1 as neighbor with neighbor AS |
(config-router)#neighbor 5.5.5.56 update- source lo | Update the source for that particular neighbor as loopback interface |
(config-router)#allocate-label all | Allocate labels |
(config-router)#address-family ipv4 labeled- unicast | Enter into labeled-unicast address family |
(config-router-af)#neighbor 5.5.5.56 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)#exit-address-family | Exit from address family IPv4 labeled unicast |
(config-router)#address-family vpnv4 unicast | Enter into vpnv4 unicast address family |
(config-router-af)#neighbor 1.1.1.54 activate | Activate the neighbor inside vpnv4 address family |
(config-router-af)#exit-address-family | Exit from address family vpnv4 |
(config-router)#address-family ipv4 unicast | Enter into ipv4 unicast address family |
(config-router-af)#network 7.7.7.55/32 | Advertise the loopback of RTR1 in BGP |
(config-router-af)#exit-address-family | Exit from address family |
(config-router)#exit | Exit from router BGP mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)# router ldp | Configure Router LDP instance |
(config-router)# transport-address ipv4 7.7.7.55 0 | Configure Transport address for LDP with label space value 0 |
(config-router)#exit | Exit from router mode |
(config)# ip vrf vrf1 | Specify the name of the VRF (vrf1) to be created. |
(config-vrf)#rd 10:100 | Assign a route distinguisher (RD) for the VRF, which is a unique value on the router. The RD value can be in ASN:NN or A.B.C.D:NN format. |
(config-vrf)#route-target both 100:300 | Specify the 2-Octet AS specific or IPv4 specific Transitive Route-Target extended community attribute. |
(config-vrf)#exit | Exit VRF mode, and return to Configure mode. |
(config)#interface eth2 | Enter interface mode |
(config-if)# ip vrf forwarding vrf1 | Bind the interface (eth2) to the VRF vrf1 |
(config-if)# ip address 62.1.1.55/24 | Configure the IP address of the interface eth2 |
(config-if)#exit | Exit interface mode. |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 100 | Enter Router BGP mode |
(config-router)# address-family ipv4 vrf vrf1 | Enter address family ipv4 vrf mode |
(config-router-af)# redistribute connected | Redistribute connected routes |
(config-router-af)# exit-address-family | Exit address-family mode. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 1.1.1.54/32 secondary | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)#interface eth1 | Enter interface mode |
(config-if)#ip address 10.1.1.54/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth1 interface |
(config-if)#exit | Exit interface mode. |
(config)#router ospf 10 | Configure the routing process OSPF with process id 10 |
(config-router)#network 1.1.1.54/32 area 0 | Define the interface (1.1.1.54/32) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 10.1.1.0/24 area 0 | Define the interface (10.1.1.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 100 | Enter Router BGP mode |
(config-router)#neighbor 7.7.7.55 remote- as 100 | Add loopback ip of PE2 as neighbor with neighbor AS |
(config-router)#neighbor 7.7.7.55 update- source lo | Update the source for that particular neighbor as loopback interface |
(config-router)#neighbor 3.3.3.52 remote- as 100 | Add loopback ip of ABR1 as neighbor with neighbor AS |
(config-router)#neighbor 3.3.3.52 update- source lo | Update the source for that particular neighbor as loopback interface |
(config-router)#allocate-label all | Allocate labels |
(config-router)#address-family ipv4 labeled- unicast | Enter into labeled-unicast address family |
(config-router-af)#neighbor 3.3.3.52 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)#exit-address-family | Exit from address family IPv4 labeled unicast |
(config-router)#address-family vpnv4 unicast | Enter into vpnv4 unicast address family |
(config-router-af)#neighbor 7.7.7.55 activate | Activate the neighbor inside vpnv4 address family |
(config-router-af)#network 1.1.1.54/32 | Advertise the loopback of RTR1 in BGP |
(config-router-af)#exit-address-family | Exit from address family vpnv4 |
(config-router)#exit | Exit from router BGP mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)# router ldp | Configure Router LDP instance |
(config-router)# transport-address ipv4 1.1.1.54 0 | Configure Transport address for LDP with label space value 0 |
(config-router)#exit | Exit from router mode |
(config)# ip vrf vrf1 | Specify the name of the VRF (vrf1) to be created. |
(config-vrf)#rd 10:100 | Assign a route distinguisher (RD) for the VRF, which is a unique value on the router. The RD value can be in ASN:NN or A.B.C.D:NN format. |
(config-vrf)#route-target both 100:300 | Specify the 2-Octet AS specific or IPv4 specific Transitive Route-Target extended community attribute. |
(config-vrf)#exit | Exit VRF mode, and return to Configure mode. |
(config)#interface eth2 | Enter interface mode |
(config-if)# ip vrf forwarding vrf1 | Bind the interface (eth2) to the VRF vrf1 |
(config-if)# ip address 61.1.1.54/24 | Configure the IP address of the interface eth2 |
(config-if)#exit | Exit interface mode. |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 100 | Enter Router BGP mode |
(config-router)# address-family ipv4 vrf vrf1 | Enter address family ipv4 vrf mode |
(config-router-af)# redistribute connected | Redistribute connected routes |
(config-router-af)# exit-address-family | Exit address-family mode. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 2.2.2.23/32 | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)#interface eth1 | Enter interface mode |
(config-if)#ip address 10.1.1.23/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth1 interface |
(config-if)#exit | Exit interface mode. |
(config)#interface eth2 | Enter interface mode |
(config-if)#ip address 20.1.1.23/24 | Configure the IP address of the interface eth2 |
(config-if)#label-switching | Enable label-switching on interface eth2 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth2 interface |
(config-if)#exit | Exit interface mode. |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router ospf 10 | Configure the routing process OSPF with process id 10 |
(config-router)#network 20.1.1.0/24 area 0 | Define the interface (20.1.1.0/24)) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 10.1.1.0/24 area 0 | Define the interface (10.1.1.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 2.2.2.23/32 area 0 | Define the interface (2.2.2.23/32) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)# router ldp | Configure Router LDP instance |
(config-router)# transport-address ipv4 2.2.2.23 0 | Configure Transport address for LDP with label space value 0 |
(config-router)#exit | Exit from router mode |
(config)# ip route 7.7.7.55/32 20.1.1.52 | Specify the destination prefix and mask for the network and a gateway. |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 3.3.3.52/32 | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)#interface eth1 | Enter interface mode |
(config-if)#ip address 52.56.1.52/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth1 interface |
(config-if)#exit | Exit interface mode. |
(config)#interface eth2 | Enter interface mode |
(config-if)#ip address 20.1.1.52/24 | Configure the IP address of the interface eth2 |
(config-if)#label-switching | Enable label-switching on interface eth2 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth2 interface |
(config-if)#exit | Exit interface mode. |
(config)#router ospf 10 | Configure the routing process OSPF with process id 20 |
(config-router)#network 3.3.3.52/32 area 0 | Define the interface (3.3.3.52/32) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 20.1.1.0/24 area 0 | Define the interface (20.1.1.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)# router ldp | Configure Router LDP instance |
(config-router)# transport-address ipv4 3.3.3.52 0 | Configure Transport address for LDP with label space value 0 |
(config-router)#exit | Exit from router mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 100 | Enter Router BGP mode |
(config-router)#neighbor 1.1.1.54 remote- as 100 | Add loopback ip of PE2 as neighbor with neighbor AS |
(config-router)#neighbor 1.1.1.54 update- source lo | Update the source for that particular neighbor as loopback interface |
(config-router)#neighbor 52.56.1.56 remote- as 100 | Add loopback ip of ABR1 as neighbor with neighbor AS |
(config-router)#allocate-label all | Allocate labels |
(config-router)#address-family ipv4 labeled- unicast | Enter into labeled-unicast address family |
(config-router-af)#neighbor 1.1.1.54 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)#neighbor 52.56.1.56 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)# neighbor 1.1.1.54 route-reflector-client | Enable Route reflector client for the neighbor inside address family IPv4 labeled unicast |
(config-router-af)# neighbor 1.1.1.54 next-hop-self | Enable next hop self for the particular neighbor inside address family IPv4 labeled unicast |
(config-router-af)# neighbor 52.56.1.56 next-hop-self | Enable next hop self for the particular neighbor inside address family IPv4 labeled unicast |
(config-router-af)#exit-address-family | Exit from address family labeled-unicast |
(config-router)#exit | Exit from router BGP mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 5.5.5.56/32 | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)#interface eth1 | Enter interface mode |
(config-if)#ip address 50.1.1.56/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)#exit | Exit interface mode. |
(config)#interface eth2 | Enter interface mode |
(config-if)#ip address 52.56.1.56/24 | Configure the IP address of the interface eth2 |
(config-if)#label-switching | Enable label-switching on interface eth2 |
(config-if)#exit | Exit interface mode. |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router ospf 30 | Configure the routing process OSPF with process Id 1 |
(config-router)#network 5.5.5.56/32 area 0 | Define the interface (5.5.5.56/32) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 50.1.1.0/24 area 0 | Define the interface (50.1.1.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)# router ldp | Configure Router LDP instance |
(config-router)# transport-address ipv4 5.5.5.56 0 | Configure Transport address for LDP with label space value 0 |
(config-router)#exit | Exit from router mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 200 | Enter Router BGP mode |
(config-router)#neighbor 52.56.1.52 remote- as 100 | Add neighbor peer ip and neighbor AS |
(config-router)#neighbor 7.7.7.55 remote- as 100 | Add loopback ip of PE2 as neighbor with neighbor AS |
(config-router)#neighbor 7.7.7.55 update- source lo | Update the source for that particular neighbor as loopback interface |
(config-router)#allocate-label all | Allocate labels |
(config-router)#address-family ipv4 labeled- unicast | Enter into labeled-unicast address family |
(config-router-af)#neighbor 52.56.1.52 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)#neighbor 7.7.7.55 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)# neighbor 7.7.7.55 route-reflector-client | Enable Route reflector client for the neighbor inside address family IPv4 labeled unicast |
(config-router-af)# neighbor 52.56.1.52 next-hop-self | Enable next hop self for the particular neighbor inside address family IPv4 labeled unicast |
(config-router-af)# neighbor 7.7.7.55 next-hop-self | Enable next hop self for the particular neighbor inside address family IPv4 labeled unicast |
(config-router-af)#exit-address-family | Exit from address family vpnv4 |
(config-router)#exit | Exit from router BGP mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 6.6.6.22/32 | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)#interface eth1 | Enter interface mode |
(config-if)#ip address 50.1.1.22/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth1 interface |
(config-if)#exit | Exit interface mode. |
(config)#interface eth2 | Enter interface mode |
(config-if)#ip address 60.1.1.22/24 | Configure the IP address of the interface eth2 |
(config-if)#label-switching | Enable label-switching on interface eth2 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth2 interface |
(config-if)#exit | Exit interface mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router ospf 30 | Configure the routing process OSPF with process id 20 |
(config-router)#network 50.1.1.0/24 area 0 | Define the interface (30.1.1.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 60.1.1.0/24 area 0 | Define the interface (40.1.1.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 6.6.6.22/32 area 0 | Define the interface (4.4.4.53/32) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)# router ldp | Configure Router LDP instance |
(config-router)# transport-address ipv4 6.6.6.22 0 | Configure Transport address for LDP with label space value 0 |
(config-router)#exit | Exit from router mode |
(config)# ip route 1.1.1.54/32 50.1.1.56 | Specify the destination prefix and mask for the network and a gateway. |
(config)#exit | Exit from Cofig mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 7.7.7.55/32 secondary | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)#interface eth2 | Enter interface mode |
(config-if)#ip address 60.1.1.55/24 | Configure the IP address of the interface eth1 |
(config-if)#label-switching | Enable label-switching on interface eth1 |
(config-if)# enable-ldp ipv4 | Enable LDP process on eth1 interface |
(config-if)#exit | Exit interface mode. |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router ospf 30 | Configure the routing process OSPF with process id 10 |
(config-router)#network 7.7.7.55/32 area 0 | Define the interface (7.7.7.55/32) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#network 60.1.1.0/24 area 0 | Define the interface (60.1.1.0/24) on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 200 | Enter Router BGP mode |
(config-router)#neighbor 1.1.1.54 remote- as 100 | Add loopback ip of PE2 as neighbor with neighbor AS |
(config-router)#neighbor 1.1.1.54 update- source lo | Update the source for that particular neighbor as loopback interface |
(config-router)#neighbor 1.1.1.54 ebgp-multihop | Enable neighbor connection between two eBGP |
(config-router)#neighbor 5.5.5.56 remote- as 200 | Add loopback ip of ABR1 as neighbor with neighbor AS |
(config-router)#neighbor 5.5.5.56 update- source lo | Update the source for that particular neighbor as loopback interface |
(config-router)#allocate-label all | Allocate labels |
(config-router)#address-family ipv4 labeled- unicast | Enter into labeled-unicast address family |
(config-router-af)#neighbor 5.5.5.56 activate | Activate the neighbor inside vpnv4 address family |
(config-router-af)#exit-address-family | Exit from address family IPv4 labeled unicast |
(config-router)#address-family vpnv4 unicast | Enter into vpnv4 unicast address family |
(config-router-af)#neighbor 1.1.1.54 allow-ebgp-vpn | Allow eBGP neighbor to be a vpn peer. |
(config-router-af)#neighbor 1.1.1.54 activate | Activate the neighbor inside labeled-unicast address family |
(config-router-af)#exit-address-family | Exit from address family vpnv4 |
(config-router)#address-family ipv4 unicast | Enter into ipv4 unicast address family |
(config-router-af)#network 7.7.7.55/32 | Advertise the loopback of RTR1 in BGP |
(config-router-af)#exit-address-family | Exit from address family vpnv4 |
(config-router)#exit | Exit from router BGP mode |
(config)# router ldp | Configure Router LDP instance |
(config-router)# transport-address ipv4 7.7.7.55 0 | Configure Transport address for LDP with label space value 0 |
(config-router)#exit | Exit from router mode |
(config)# ip vrf vrf1 | Specify the name of the VRF (vrf1) to be created. |
(config-vrf)#rd 10:100 | Assign a route distinguisher (RD) for the VRF, which is a unique value on the router. The RD value can be in ASN:NN or A.B.C.D:NN format. |
(config-vrf)#route-target both 100:300 | Specify the 2-Octet AS specific or IPv4 specific Transitive Route-Target extended community attribute. |
(config-vrf)#exit | Exit VRF mode, and return to Configure mode. |
(config)#interface eth2 | Enter interface mode |
(config-if)# ip vrf forwarding vrf1 | Bind the interface (eth2) to the VRF vrf1 |
(config-if)# ip address 62.1.1.55/24 | Configure the IP address of the interface eth2 |
(config-if)#exit | Exit interface mode. |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 100 | Enter Router BGP mode |
(config-router)# address-family ipv4 vrf vrf1 | Enter address family ipv4 vrf mode |
(config-router-af)# redistribute connected | Redistribute connected routes |
(config-router-af)# exit-address-family | Exit address-family mode. |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
(config)# interface lo | Enter interface mode for Loopback |
(config-if)#ip address 1.1.1.1/32 secondary | Configure ip address for Loopback interface |
(config-if)#ip address 11.11.11.11/32 secondary | Configure ip address for Loopback interface |
(config-if)#exit | Exit interface mode |
(config)#router bgp 200 | Define the routing process. The number 200 specifies the AS number of R1. |
(config-router)#neighbor ABC peer-group | Create a peer group named ABC. |
(config-router)#neighbor ABC remote-as 200 | Assign options to the peer group named ABC. |
(config-router)#neighbor 2.2.2.2 peer-group ABC | Define neighbor 2.2.2.2 (R2) as a peer group member. |
(config-router)#neighbor 3.3.3.3 peer-group ABC | Define neighbor 3.3.3.3 (R3) as a peer group member. |
(config-router)#address-family ipv4 labeled-unicast | Enter address-family ipv4 labeled-unicast mode |
(config-router-af)#neighbor ABC activate | Activate the peer-group ABC for address-family ipv4 labeled-unicast |
(config-router-af)#neighbor ABC route-reflector-client | Configure the peer-group ABC to be route-reflector-client |
(config-router-af)# exit-address-family | Exit address-family ipv4 labeled-unicast mode |
(config-router)#address-family ipv4 unicast | Enter address-family ipv4 unicast mode |
(config-router-af)#network 1.1.1.1/32 | Advertise the network 1.1.1.1/32 |
(config-router-af)#network 11.11.11.11/32 | Advertise the network 11.11.11.11/32 |
(config-router-af)# exit-address-family | Exit address-family ipv4 unicast mode |
(config-router)#allocate-label all | Allocate labels for all IPv4 prefixes advertised |
(config-router)#exit | Exit router bgp mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter configure mode. |
(config)#router bgp 200 | Define the routing process. The number 200 specifies the AS number of R2. |
(config-router)#neighbor 2.2.2.1 remote-as 200 | Create a TCP connection with neighbor 2.2.2.1 of AS 200. |
config-router)#allocate-label all | Allocate labels for all IPv4 prefixes advertised |
(config-router)#address-family ipv4 labeled-unicast | Enter address-family ipv4 labeled-unicast mode |
(config-router-af)#neighbor 2.2.2.1 activate | Activate the neighbor R1 for address-family ipv4 labeled-unicast |
(config-router-af)# exit-address-family | Exit address-family ipv4 labeled-unicast mode |
(config-router)# exit | Exit router bgp mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter configure mode. |
(config)#router bgp 200 | Define the routing process. The number 200 specifies the AS number of R3. |
(config-router)#neighbor 3.3.3.1 remote-as 200 | Create a TCP connection with neighbor 3.3.3.1 of AS 200. |
config-router)#allocate-label all | Allocate labels for all IPv4 prefixes advertised |
(config-router)#address-family ipv4 labeled-unicast | Enter address-family ipv4 labeled-unicast mode |
(config-router-af)#neighbor 3.3.3.1 activate | Activate the neighbor R1 for address-family ipv4 labeled-unicast |
(config-router-af)# exit-address-family | Exit address-family ipv4 labeled-unicast mode |
(config-router)# exit | Exit router bgp mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter configure mode. |
(config)# ip access-list permit-1 | Configure access-list to permit 1.1.1.1/32 |
(config-ip-acl)# permit any 1.1.1.1/32 any | Configure a permit statement in the acl to permit 1.1.1.1/32 |
(config-ip-acl)#exit | Exit ip access-list mode |
(config)# route-map permit-only-1 | Configure route-map |
(config-route-map)# match ip address permit- 1 | Configure a match statement in the route-map to match the access-list permit-1 |
(config-route-map)#exit | Exit route-map mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 200 | Define the routing process. The number 200 specifies the AS number of R1. |
(config-router)#no allocate-label all | Unconfiguring allocate label all |
config-router)# allocate-label route-map permit-only-1 | Allocate labels to the route map |
(config-router)#address-family ipv4 labeled- unicast | Enter address-family ipv4 labeled-unicast mode |
(config-router-af)# neighbor ABC route-map permit-only-1 out | Configure the peer-group ABC with route-map in the outbound direction |
(config-router-af)#exit | Exit address-family mode |
(config-router)#exit | Exit router bgp mode |
(config# exit | Exit configure terminal mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
#clear ip bgp peer-group ABC ipv4 labeled- unicast soft out | Do outbound soft reset for the peer-group ABC for the policy to take affect for the labelled-unicast peer-group members |
#configure terminal | Enter configure mode. |
(config)# interface lo | Enter interface mode for Loopback interface |
(config-if)#ip address 100.1.1.1/24 secondary | Configure IP address for Loopback interaface |
(config-if)#interface eth3 | Enter interface mode for interface eth3 |
(config-if)#ip address 22.1.1.1/24 | Configure IP address for interface eth3 |
(config-if)#exit | Exit interface mode |
(config)#router bgp 200 | Enter router bgp mode |
(config-router)#address-family ipv4 unicast | Enter address-family ipv4 unicast mode |
(config-router-af)#network 22.1.1.0/24 | Advertise the network of eth3 in BGP |
(config-router-af)#network 100.1.1.0/24 | Advertise the network of Loopback in BGP |
(config-router-af)#exit-address-family | Exit address-family mode |
(config-router)#allocate-label all | Allocate labels for all IPv4 prefixes advertised |
(config-router)#exit | Exit router bgp mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter configure mode. |
(config)# interface lo | Enter interface mode for Loopback interface |
(config-if)#ip address 100.1.1.2/24 secondary | Configure IP address for Loopback interaface |
(config-if)#interface eth3 | Enter interface mode for interface eth3 |
(config-if)#ip address 22.1.1.2/24 | Configure IP address for interface eth3 |
(config-if)#exit | Exit interface mode |
(config)#router bgp 200 | Enter router bgp mode |
(config-router)#address-family ipv4 unicast | Enter address-family ipv4 unicast mode |
(config-router-af)#network 22.1.1.0/24 | Advertise the network of eth3 in BGP |
(config-router-af)#network 100.1.1.0/24 | Advertise the network of Loopback in BGP |
(config-router-af)#exit-address-family | Exit address-family mode |
(config-router)#allocate-label all | Allocate labels for all IPv4 prefixes advertised |
(config-router)#exit | Exit router bgp mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
#configure terminal | Enter configure mode. |
(config)#ip access-list permit-22 | Configure access-list to permit 22.1.1.0/24 |
(config-ip-acl)# permit any 22.1.1.0/24 any | Configure a permit statement to permit 22.1.1.0/24 |
(config-ip-acl)#exit | Exit ip access-list mode |
(config)#route-map permit-only-22 | Configure route-map |
(config-route-map)#match ip address permit- 22 | Configure match statement in route-map to match the access- list permit-22 |
(config-route-map)#exit | Exit route-map mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
(config)#router bgp 200 | Enter BGP router mode |
(config-router)#address-family ipv4 labeled- unicast | Enter the address-family ipv4 labeled-unicast mode |
(config-router-af)#neighbor ABC route-map permit-only-22 in | Configure the peer-group ABC with route-map in the inbound direction under address-family ipv4 labeled-unicast |
(config-router-af)# neighbor ABC activate | Activate PEER-GROUP in the address family |
(config-router-af)#exit-address-family | Exit address-family ipv4 labeled-unicast mode |
(config-router)#exit | Exit router bgp mode |
(config)# exit | Exit configure terminal mode |
(config)#commit | Commit the candidate configuration to the running configuration. |
#clear ip bgp peer-group ABC ipv4 labeled- unicast soft in | Do inbound soft reset for the peer-group ABC for the policy to take affect for the labelled-unicast peer-group members |