CE1#configure terminal | Enters the configuration mode on the OcNOS device. |
CE1(config)#interface po1 | Enters the configuration mode for a Port-Channel interface named po1. |
CE1(config-if)# load-interval 30 | Sets the load interval for the Port-Channel interface to 30 seconds. |
CE1(config-if)#interface po1.101 | Enters the configuration mode for a subinterface of Port-Channel 1, specifically subinterface 101. |
CE1(config-if)# encapsulation dot1q 101 | Configures the subinterface to use IEEE 802.1Q encapsulation with VLAN ID 101. |
CE1(config-if)# ip address 101.101.101.2/24 | Assigns the IP address 101.101.101.2 with a subnet mask of /24 to the subinterface. |
CE1(config-if)#interface po1.1001 | Enters the configuration mode for another subinterface of Port-Channel 1, specifically subinterface 1001. |
CE1(config-if)# encapsulation dot1q 1001 | Configures the subinterface with IEEE 802.1Q encapsulation using VLAN ID 1001. |
CE1(config-if)# ipv6 address 1001::2/64 | Assigns an IPv6 address 1001::2 with a subnet prefix length of /64 to the subinterface. |
CE1(config-if)# ipv6 router ospf area 0.0.0.0 tag 1001 instance-id 0 | Configures OSPF for IPv6 on the subinterface, specifying area 0.0.0.0 with a tag of 1001 and instance ID 0. |
CE1(config-if)# ip address 99.99.99.1/243 | Assigns the IP address 99.99.99.1 with a subnet mask of /243 to the Gigabit Ethernet interface. Note: The subnet mask value seems to be incorrect; it should typically be in the format /24. |
CE1(config-if)#interface lo | Enters the configuration mode for a loopback interface. |
CE1(config-if)# ip address 127.0.0.1/8 | Assigns the primary IP address 127.0.0.1 with a subnet mask of /8 to the loopback interface. |
CE1(config-if)# ip address 1.1.1.1/32 secondary | Adds a secondary IP address, 1.1.1.1 with a /32 subnet mask, to the loopback interface. |
CE1(config-if)# ipv6 address ::1/128 | Assigns the IPv6 address ::1 with a subnet prefix length of /128 to the loopback interface. |
CE1(config-if)#interface xe7 | Enters the configuration mode for Ten Gigabit Ethernet interface 7. |
CE1(config-if)# channel-group 1 mode active | Configures the interface to be part of an EtherChannel group with group number 1 and sets the mode to active. |
CE1(config-if)#exit | Exits the interface configuration mode. |
CE1(config)#router ospf 101 | Enters the configuration mode for OSPF (routing process 101. |
CE1(config-router)# ospf router-id 1.1.1.1 | Sets the OSPF router ID to 1.1.1.1. |
CE1(config-router)# redistribute connected | Configures OSPF to redistribute connected routes into the OSPF routing process. |
CE1(config-router)# network 101.101.101.0/24 area 0.0.0.0 | Specifies that the network 101.101.101.0/24 is part of OSPF Area 0.0.0.0. |
CE1(config-router)#router ipv6 ospf 1001 | Enters the configuration mode for OSPFv3 (OSPF for IPv6) routing process 1001. |
CE1(config-router)# router-id 1.1.1.1 | Sets the OSPFv3 router ID to 1.1.1.1. |
CE1(config-router)#Exit | Exists from the configurations. |
CE1(config)#int po1 | Enters interface configuration mode for port-channel 1 (po1). |
CE1(config-if)#mtu 9216 | Sets the Maximum Transmission Unit (MTU) for the interface po1 to 9216 bytes, which is a jumbo frame MTU size. |
CE1(config-if)#commit | Commit the changes made to the interface configuration. |
CE1((config-if)#int po1.101 | Enters interface configuration mode for subinterface po1.101. |
CE1(config-if)#mtu 9216 | Sets the MTU to 9216 bytes. |
CE1(config-if)#int po1.1001 | Enters interface configuration mode for subinterface po1.1001. |
CE1(config-if)#mtu 9216 | Sets the MTU to 9216 bytes. |
CE1(config-if)#Exit | Exits the interface configuration mode. |
PE1#configure terminal | Enters the global configuration mode. |
PE1(config)#evpn mpls enable | Enables EVPN-MPLS within the configuration. |
PE1(config)#evpn mpls irb | Configures EVPN-MPLS IRB. |
PE1(config)#mac vrf MacVrf1 | Creates a MAC VRF named MacVrf1. |
PE1(config-vrf)# rd 2.2.2.2:100 | Defines a RD for MacVrf1 as 2.2.2.2:100. |
PE1(config-vrf)# route-target both 100:1 | Sets the route target for MacVrf1 to 100:1 for both import and export. |
PE1(config-vrf)#ip vrf IpVrf1 | Creates an IP VRF named IpVrf1. |
PE1(config-vrf)# rd 2.2.2.2:200 | Defines an RD for IpVrf1 as 2.2.2.2:200. |
PE1(config-vrf)# route-target both 100:100 | Sets the route target for IpVrf1 to 100:100 for both import and export. |
PE1(config-vrf)# l3vni 100 | Configures Layer 3 Virtual Network Identifier (L3VNI) as 100 for IpVrf1. |
PE1(config-vrf)#evpn mpls vtep-ip-global 2.2.2.2 | Configures the EVPN-MPLS Virtual Tunnel EndPoint (VTEP) IP address as 2.2.2.2. |
PE1(config)#evpn mpls id 101 | Defines EVPN-MPLS ID as 101. |
PE1(config-evpn-mpls)# host-reachability-protocol evpn-bgp MacVrf1 | Specifies BGP as the host reachability protocol for MacVrf1. |
PE1(config-evpn-mpls)# evpn irb irb101 | Associates IRB 101 with EVPN-MPLS. |
PE1(config-evpn-mpls)#evpn mpls id 1001 | Defines EVPN-MPLS ID as 1001. |
PE1(config-evpn-mpls)# host-reachability-protocol evpn-bgp MacVrf1 | Specifies BGP as the host reachability protocol for MacVrf1. |
PE1(config-evpn-mpls)# evpn irb irb1001 | Associates IRB 1001 with EVPN-MPLS. |
PE1(config-evpn-mpls)#qos enable | Enables QoS features. |
PE1(config)#qos statistics | Configures QoS statistics collection. |
PE1(config)#hostname PE1 | Sets the hostname of the device to PE1. |
PE1(config)#segment-routing | Enters the configuration mode for segment routing. |
PE1(config-sr)# mpls sr-prefer | Configures MPLS as the preferred segment routing method. |
PE1(config-sr)#exit | Exits the segment routing configuration mode. |
PE1(config)#interface po1 | Enters the configuration mode for Port-Channel 1. |
PE1(config-if)# switchport | Configures the interface as a switchport. |
PE1(config-if)# load-interval 30 | Sets the load interval to 30 seconds for the interface. |
PE1(config-if)#interface po1.101 switchport | Enters the configuration mode for subinterface 101 of Port-Channel 1 and configures it as a switchport. |
PE1(config-if)# encapsulation dot1q 101 | Configures IEEE 802.1Q encapsulation with VLAN ID 101 for the subinterface. |
PE1(config-if)# rewrite pop | Configures packet rewriting for the subinterface. |
PE1(config-if)# access-if-evpn | Specifies that this interface is associated with EVPN. |
PE1(config-acc-if-evpn)# map vpn-id 101 | Maps this interface to VPN ID 101. |
PE1(config-acc-if-evpn)#interface po1.1001 switchport | Enters the configuration mode for subinterface 1001 of Port-Channel 1 and configures it as a switchport. |
PE1(config-if)# encapsulation dot1q 1001 | Configures IEEE 802.1Q encapsulation with VLAN ID 1001 for the subinterface. |
PE1(config-if)# rewrite pop | Configures packet rewriting for the subinterface. |
PE1(config-if)# access-if-evpn | Specifies that this interface is associated with E |
PE1(config-acc-if-evpn)# map vpn-id 1001 | Maps this interface to VPN ID 1001. |
PE1(config-acc-if-evpn)#exit | Exits the access-if-evpn configuration mode. |
PE1(config-if)#interface irb101 | Enters the configuration mode for IRB interface 101. |
PE1(config-irb-if)# ip vrf forwarding IpVrf1 | Associates the IRB interface with the IP VRF IpVrf1. |
PE1(config-irb-if)# ip address 101.101.101.1/24 | Configures the IP address 101.101.101.1 with a subnet mask of /24 on the IRB interface. |
PE1(config-irb-if)#interface irb1001 | Enters the configuration mode for IRB interface 1001. |
PE1(config-irb-if)# ip vrf forwarding IpVrf1 | Associates the IRB interface with the IP VRF IpVrf1. |
PE1(config-irb-if)# ipv6 address 1001::1/64 | Configures an IPv6 address 1001::1 with a subnet prefix length of /64 on the IRB interface. |
PE1(config-irb-if)# ipv6 router ospf area 0.0.0.0 tag IpVrf1 instance-id 0 | Configures OSPF for IPv6 on the IRB interface, specifying area 0.0.0.0 with a tag and instance ID. |
PE1(config-irb-if)#interface lo | Enters the configuration mode for loopback interface. |
PE1(config-if)# ip address 127.0.0.1/8 | Configures the primary IP address of the loopback interface as 127.0.0.1 with a subnet mask of /8. |
PE1(config-if)# ip address 2.2.2.2/32 secondary | Adds a secondary IP address 2.2.2.2 with a /32 subnet mask to the loopback interface. |
PE1(config-if)# ipv6 address ::1/128 | Configures an IPv6 address ::1 with a subnet prefix length of /128 on the loopback interface. |
PE1(config-if)# prefix-sid index 2 | Configures a prefix SID with an index of 2. |
PE1(config-if)#interface xe7 | Enters the configuration mode for Ten Gigabit Ethernet interface 7. |
PE1(config-if)# channel-group 1 mode active | Configures the interface to be part of an EtherChannel group with group number 1 and sets the mode to active. |
PE1(config-if)#interface xe10 | Enters the configuration mode for Ten Gigabit Ethernet interface 10. |
PE1(config-if)# speed 10g | Sets the speed of the interface to 10 gigabits per second. |
PE1(config-if)# ip address 10.1.1.1/24 | Configures an IP address 10.1.1.1 with a subnet mask of /24 on the interface. |
PE1(config-if)# label-switching | Enables label switching on the interface. |
PE1(config-if)# exit | Exits the interface configuration mode. |
PE1(config)#router ospf 100 | Enters the configuration mode for OSPF routing process 100. |
PE1(config-router)# ospf router-id 2.2.2.2 | Sets the OSPF router ID to 2.2.2.2. |
PE1(config-router)# network 2.2.2.2/32 area 0.0.0.0 | Configures the network 2.2.2.2/32 within OSPF Area 0.0.0.0. |
PE1(config-router)# network 10.1.1.0/24 area 0.0.0.0 | Configures the network 10.1.1.0/24 within OSPF Area 0.0.0.0. |
PE1(config-router)# segment-routing mpls | Configures MPLS for segment routing. |
PE1(config-router)#router ospf 101 IpVrf1 | Enters the configuration mode for OSPF routing process 101 within VRF IpVrf. |
PE1(config-router)# network 10.1.1.0/24 area 0.0.0.0 | Specifies the network 10.1.1.0 with a /24 subnet mask to be included in OSPF Area 0.0.0.0. |
PE1(config-router)# segment-routing mpls | Enables MPLS-based segment routing in the OSPF configuration. |
PE1(config-router)#router ospf 101 IpVrf1 | Enters the configuration mode for OSPF routing process 101 associated with VRF IpVrf1. |
PE1(config-router)# ospf router-id 2.2.2.2 | Sets the OSPF router ID to 2.2.2.2. |
PE1(config-router)# redistribute bgp | Configures the redistribution of BGP routes into OSPF. |
PE1(config-router)# network 101.101.101.0/24 area 0.0.0.0 | Specifies the network 101.101.101.0 with a /24 subnet mask to be included in OSPF Area 0.0.0.0 for VRF IpVrf1. |
PE1(config-router)#router ipv6 vrf ospf IpVrf1 | Enters the configuration mode for OSPFv3 (OSPF for IPv6) routing process associated with VRF IpVrf1. |
PE1(config-router)# router-id 2.2.2.2 | Sets the OSPFv3 router ID to 2.2.2.2. |
PE1(config-router)#router bgp 100 | Enters the configuration mode for BGP routing process 100. |
PE1(config-router)# bgp router-id 2.2.2.2 | Sets the BGP router ID to 2.2.2.2. |
PE1(config-router)# neighbor 5.5.5.5 remote-as 100 | Specifies a BGP neighbor with IP address 5.5.5.5 and assigns it the remote autonomous system number 100. |
PE1(config-router)# neighbor 5.5.5.5 update-source lo | Sets the loopback interface as the source for BGP updates to the neighbor. |
PE1(config-router)# neighbor 5.5.5.5 advertisement-interval 0 | Configures the BGP neighbor's advertisement interval to 0. |
PE1(config-router)# address-family l2vpn evpn | Enters the configuration mode for the BGP address family l2vpn evpn. |
PE1(config-router-af)# neighbor 5.5.5.5 activate | Activates the BGP neighbor within the l2vpn evpn address family. |
PE1(config-router-af)# exit-address-family | Exits the l2vpn evpn address family configuration. |
PE1(config-router)# address-family ipv4 vrf IpVrf1 | Enters the configuration mode for the BGP address family ipv4 vrf IpVrf1. |
PE1(config-router-af)# redistribute ospf 101 | Configures the redistribution of OSPF routes from OSPF process 101 into the ipv4 vrf IpVrf1 address family. |
PE1(config-router-af)# exit-address-family | Exits the ipv4 vrf IpVrf1 address family configuration. |
PE1(config-router)# address-family ipv6 vrf IpVrf1 | Enters the configuration mode for the BGP address family ipv6 vrf IpVrf1. |
PE1(config-router-af)# redistribute ospf | Configures the redistribution of OSPFv3 routes into the ipv6 vrf IpVrf1 address family. |
PE1(config-router-af)# exit-address-family | Exits the ipv6 vrf IpVrf1 address family configuration. |
PE1(config-router)#line console 0 | Enters the configuration mode for the console line. |
PE1(config-line)# exec-timeout 0 0 | Sets the console line's execution timeout values to 0 seconds. |
PE1(config-line)#line vty 0 871 | Enters the configuration mode for virtual terminal lines 0 to 871. |
PE1(config-line)# exec-timeout 0 0 | Sets the execution timeout values for virtual terminal lines to 0 seconds. |
PE1(config-line)# privilege level 16 | Specifies the privilege level for users accessing the virtual terminal lines. |
PE1(config-line)#commit | Commits the configuration changes. |
PE1(config-line)#end | Exits the configuration mode. |
PE1(config)#interface irb101 | Enters interface configuration mode for IRB interface 101. |
PE1(config-irb-if)#mtu 9216 | Sets the MTU to 9216 bytes. |
PE1(config-irb-if)#commit | Commit the changes made to the interface configuration. |
PE1(config-irb-if)#exit | Exits the IRB interface configuration mode and returns to the global configuration mode. |
PE1(config)#interface irb1001 | Enters interface configuration mode for IRB interface 1001. |
PE1(config-irb-if)#mtu 9216 | Sets the MTU to 9216 bytes. |
PE1(config-irb-if)#commit | Commit the changes made to the interface configuration. |
PE1(config-irb-if)#exit | Exits the IRB interface configuration mode and returns to the global configuration mode. |
PE1(config)#interface int po1 | Enters interface configuration mode for IRB int po1. |
PE1(config-irb-if)#mtu 9216 | Sets the MTU to 9216 bytes. |
PE1(config-irb-if)#commit | Commit the changes made to the interface configuration. |
PE1(config-irb-if)#exit | Exits the IRB interface configuration mode and returns to the global configuration mode. |
P1#configure terminal | Enters the global configuration mode. |
P1(config)#segment-routing | Enters the configuration mode for Segment Routing. |
P1(config-sr)# mpls sr-prefer | Configures the preference for MPLS as part of the Segment Routing setup. |
P1(config-if)#interface ce50 | Enters the configuration mode for interface ce50. |
P1(config-if)# ip address 20.1.1.1/24 | Assigns an IP address of 20.1.1.1 with a /24 subnet mask to interface ce50. |
P1(config-if)# label-switching | Enables label switching for the interface ce50. |
P1(config-if)#interface lo | Enters the configuration mode for a loopback interface. |
P1(config-if)# ip address 127.0.0.1/8 | Assigns an IP address of 127.0.0.1 with a /8 subnet mask to the loopback interface. |
P1(config-if)# ip address 3.3.3.3/32 secondary | Adds a secondary IP address of 3.3.3.3 with a /32 subnet mask to the loopback interface. |
P1(config-if)# ipv6 address ::1/128 | Assigns an IPv6 address of ::1/128 to the loopback interface. |
P1(config-if)# prefix-sid index 3 | Configures a prefix SID with an index of 3 for the loopback interface. |
P1(config-if)#interface xe3 | Enters the configuration mode for Ten Gigabit Ethernet interface 3. |
P1(config-if)# ip address 10.1.1.2/24 | Assigns an IP address of 10.1.1.2 with a /24 subnet mask to interface xe3. |
P1(config-if)# label-switching | Enables label switching for interface xe3. |
P1(config-if)# exit | Exits the interface configuration. |
P1(config-router)#router ospf 100 | Enters the configuration mode for OSPF routing process 100. |
P1(config-router)# ospf router-id 3.3.3.3 | Sets the OSPF router ID to 3.3.3.3. |
P1(config-router)# network 3.3.3.3/32 area 0.0.0.0 | Specifies the network 3.3.3.3 with a /32 subnet mask to be included in OSPF Area 0.0.0.0. |
P1(config-router)# network 10.1.1.0/24 area 0.0.0.0 | Specifies the network 10.1.1.0 with a /24 subnet mask to be included in OSPF Area 0.0.0.0. |
P1(config-router)# network 20.1.1.0/24 area 0.0.0.0 | Specifies the network 20.1.1.0 with a /24 subnet mask to be included in OSPF Area 0.0.0.0. |
P1(config-router)# segment-routing mpls | Enables MPLS-based segment routing in the OSPF configuration. |
P1(config-router)#line console 0 | Enters the configuration mode for the console line. |
P1(config-line)# exec-timeout 0 0 | Sets the console line's execution timeout values to 0 seconds. |
P1(config-line)#line vty 0 871 | Enters the configuration mode for virtual terminal lines 0 to 871. |
P1(config-line)# exec-timeout 0 0 | Sets the execution timeout values for virtual terminal lines to 0 seconds. |
P1(config-line)# privilege level 16 | Specifies the privilege level for users accessing the virtual terminal lines. |
P1(config-line)# Exit | Exits from configuration mode. |
P2#configure terminal | Enters the global configuration mode. |
P2(config)#segment-routing | Enters the configuration mode for Segment Routing. |
P2(config-sr)# mpls sr-prefer | Configures the preference for MPLS as part of the Segment Routing setup. |
P2(config-sr)#interface ce1 | Enters the configuration mode for interface ce1. |
P2(config-if)# ip address 20.1.1.2/24 | Assigns an IP address of 20.1.1.2 with a /24 subnet mask to interface ce1. |
P2(config-if)# label-switching | Enables label switching for interface ce1. |
P2(config-if)#interface ce2 | Enters the configuration mode for interface ce2. |
P2(config-if)# speed 40g | Sets the speed of interface ce2 to 40Gbps. |
P2(config-if)# ip address 30.1.1.1/24 | Assigns an IP address of 30.1.1.1 with a /24 subnet mask to interface ce2. |
P2(config-if)# label-switching | Enables label switching for interface ce2. |
P2(config-if)#interface lo | Enters the configuration mode for a loopback interface. |
P2(config-if)# ip address 127.0.0.1/8 | Assigns an IP address of 127.0.0.1 with a /8 subnet mask to the loopback interface. |
P2(config-if)# ip address 4.4.4.4/32 secondary | Adds a secondary IP address of 4.4.4.4 with a /32 subnet mask to the loopback interface. |
P2(config-if)# ipv6 address ::1/128 | Assigns an IPv6 address of ::1/128 to the loopback interface. |
P2(config-if)# prefix-sid index 4 | Configures a prefix SID with an index of 4 for the loopback interface. |
P2(config)#router ospf 100 | Enters the configuration mode for OSPF routing process 100. |
P2(config-router)# ospf router-id 4.4.4.4 | Sets the OSPF router ID to 4.4.4.4. |
P2(config-router)# network 4.4.4.4/32 area 0.0.0.0 | Specifies the network 4.4.4.4 with a /32 subnet mask to be included in OSPF Area 0.0.0.0. |
P2(config-router)# network 20.1.1.0/24 area 0.0.0.0 | Specifies the network 20.1.1.0 with a /24 subnet mask to be included in OSPF Area 0.0.0.0. |
P2(config-router)# network 30.1.1.0/24 area 0.0.0.0 | Specifies the network 30.1.1.0 with a /24 subnet mask to be included in OSPF Area 0.0.0.0. |
P2(config-router)# segment-routing mpls | Enables MPLS-based segment routing in the OSPF configuration. |
P2(config-router)#line console 0 | Enters the configuration mode for the console line. |
P2(config-line)# exec-timeout 0 0 | Sets the console line's execution timeout values to 0 seconds. |
P2(config-line)#line vty 0 871 | Enters the configuration mode for virtual terminal lines 0 to 871. |
P2(config-line)# exec-timeout 0 0 | Sets the execution timeout values for virtual terminal lines to 0 seconds. |
P2(config-line)# privilege level 16 | Specifies the privilege level for users accessing the virtual terminal lines. |
P2(config-line)#Exit | Exits the configuration. |
PE2#configure terminal | Enters the global configuration mode. |
PE2(config)#evpn mpls enable | Enables EVPN MPLS. |
PE2(config)#evpn mpls irb | Enables EVPN MPLS IRB. |
PE2(config)mac vrf MacVrf2 | Enters the configuration mode for MAC VRF with the name MacVrf2. |
PE2(config-vrf)# rd 5.5.5.5:100 | Sets the route distinguisher for the MAC VRF to 5.5.5.5:100. |
PE2(config-vrf)# route-target both 100:1 | Specifies route targets for import and export for the MAC VRF. |
PE2(config-vrf)#ip vrf IpVrf1 | Enters the configuration mode for IP VRF with the name IpVrf1. |
PE2(config-vrf)# rd 5.5.5.5:200 | Sets the route distinguisher for the IP VRF to 5.5.5.5:200. |
PE2(config-vrf)# route-target both 100:100 | Specifies route targets for import and export for the IP VRF. |
PE2(config-vrf)# l3vni 100 | Configures an L3VNI with ID 100 for the IP VRF. |
PE2(config-vrf)#evpn mpls vtep-ip-global 5.5.5.5 | Sets the global VTEP IP address for EVPN MPLS to 5.5.5.5. |
PE2(config)#evpn mpls id 201 | Configures an EVPN MPLS instance with ID 201. |
PE2(config-evpn-mpls)# host-reachability-protocol evpn-bgp MacVrf2 | Specifies BGP as the host reachability protocol for EVPN MPLS using MacVrf2. |
PE2(config-evpn-mpls)# evpn irb irb101 | Configures EVPN MPLS IRB with the IRB interface named irb101. |
PE2(config-evpn-mpls)#evpn mpls id 2001 | Configures another EVPN MPLS instance with ID 2001. |
PE2(config-evpn-mpls)# host-reachability-protocol evpn-bgp MacVrf2 | Specifies BGP as the host reachability protocol for EVPN MPLS using MacVrf2. |
PE2(config-evpn-mpls)# evpn irb irb1001 | Configures EVPN MPLS IRB with the IRB interface named irb1001. |
PE2(config-evpn-mpls)#qos enable | Enables QoS features for EVPN MPLS. |
PE2(config)qos statistics | Configures statistics for QoS. |
PE2(config)#hostname PE2 | Sets the hostname of the device to PE2. |
PE2(config)#segment-routing | Enters the configuration mode for Segment Routing. |
PE2(config-sr)# mpls sr-prefer | Configures the preference for MPLS in Segment Routing. |
PE2(config)#interface ce1 | Enters the configuration mode for interface ce1. |
PE2(config-if)# switchport | Enables the switchport mode for the interface. |
PE2(config-if)# load-interval 30 | Sets the load interval to 30 seconds for the interface. |
PE2(config)#interface ce1.101 switchport | Enters the configuration mode for subinterface ce1.101 and enables the switchport mode. |
PE2(config-if)# encapsulation dot1q 101 | Specifies VLAN encapsulation with VLAN ID 101 for the subinterface. |
PE2(config-if)# rewrite pop | Configures the rewrite operation as "pop" for the subinterface. |
PE2(config-if)# access-if-evpn | Configures the subinterface as an access interface for EVPN. |
PE2(config-acc-if-evpn)# map vpn-id 201 | Maps the subinterface to EVPN with VPN ID 201. |
PE2(config-acc-if-evpn)#exit | Exits the access interface configuration. |
PE2(config)#interface ce3 | Enters the configuration mode for interface ce3. |
PE2(config)# ip address 30.1.1.2/24 | Assigns the IP address 30.1.1.2 with a subnet mask of 255.255.255.0 to interface ce3. |
PE2(config)# label-switching | Enables label-switching on interface ce3. |
PE2(config-if)#interface irb101 | Enters the configuration mode for interface irb101. |
PE2(config-irb-if)# ip vrf forwarding IpVrf1 | Associates interface irb101 with the VRF (Virtual Routing and Forwarding) instance IpVrf1. |
PE2(config-irb-if)# ip address 201.201.201.1/24 | Assigns the IP address 201.201.201.1 with a subnet mask of 255.255.255.0 to interface irb101. |
PE2(config-irb-if)# ip router isis 101 | Enables ISIS routing protocol on interface irb101. |
PE2(config-irb-if)#interface irb1001 | Enters the configuration mode for interface irb1001. |
PE2(config-irb-if)# ip vrf forwarding IpVrf1 | Associates interface irb1001 with the VRF instance IpVrf1. |
PE2(config-irb-if)# ipv6 address 2001::1/64 | Assigns the IPv6 address 2001::1 with a prefix length of 64 to interface irb1001. |
PE2(config-irb-if)# ipv6 router isis 101 | Enables ISIS routing protocol for IPv6 on interface irb1001. |
PE2(config-irb-if)#interface lo | Enters the configuration mode for the loopback interface. |
PE2(config-if)# ip address 127.0.0.1/8 | Assigns the IP address 127.0.0.1 with a subnet mask of 255.0.0.0 to the loopback interface. |
PE2(config-if)# ip address 5.5.5.5/32 secondary | Assigns the secondary IP address 5.5.5.5 with a subnet mask of 255.255.255.255 to the loopback interface. |
PE2(config-if)# ipv6 address ::1/128 | Assigns the IPv6 address ::1 with a prefix length of 128 to the loopback interface. |
PE2(config-if)# prefix-sid index 5 | Configures a prefix SID with an index of 5. |
PE2(config-if)#exit | Exits the interface configuration mode. |
PE2(config)#router ospf 100 | Enters the configuration mode for OSPF with process ID 100. |
PE2(config-router)# ospf router-id 5.5.5.5 | Sets the OSPF router ID to 5.5.5.5. |
PE2(config-router)# network 5.5.5.5/32 area 0.0.0.0 | Advertises the network 5.5.5.5/32 into OSPF area 0.0.0.0. |
PE2(config-router)# network 30.1.1.0/24 area 0.0.0.0 | Advertises the network 30.1.1.0/24 into OSPF area 0.0.0.0. |
PE2(config-router)# segment-routing mpls | Enables MPLS for segment routing. |
PE2(config-router)#router isis 101 IpVrf1 | Enters the configuration mode for ISIS with process ID 101 and VRF instance IpVrf1. |
PE2(config-irb-if)#interface lo | Enters the configuration mode for the loopback interface. |
PE2(config-if)# ip address 127.0.0.1/8 | Assigns the IP address 127.0.0.1 with a subnet mask of 255.0.0.0 to the loopback interface. |
PE2(config-if)# ip address 5.5.5.5/32 secondary | Assigns the secondary IP address 5.5.5.5 with a subnet mask of 255.255.255.255 to the loopback interface. |
PE2(config-if)# ipv6 address ::1/128 | Assigns the IPv6 address ::1 with a prefix length of 128 to the loopback interface. |
PE2(config-if)# prefix-sid index 5 | Configures a prefix SID with an index of 5. |
PE2(config)#router ospf 100 | Enters the configuration mode for OSPF with process ID 100. |
PE2(config-router)# ospf router-id 5.5.5.5 | Sets the OSPF router ID to 5.5.5.5. |
PE2(config-router)# network 5.5.5.5/32 area 0.0.0.0 | Advertises the network 5.5.5.5/32 into OSPF area 0.0.0.0. |
PE2(config-router)# network 30.1.1.0/24 area 0.0.0.0 | Advertises the network 30.1.1.0/24 into OSPF area 0.0.0.0. |
PE2(config-router)# segment-routing mpls | Enables MPLS for segment routing. |
PE2(config-router)#router isis 101 IpVrf1 | Enters the configuration mode for ISIS with process ID 101 and VRF instance IpVrf1. |
PE2(config-router)# is-type level-2-only | Configures ISIS as a level-2-only routing protocol. |
PE2(config-router)# net 49.0001.0000.0000.0005.00 | Sets the ISIS NET for this router. |
PE2(config-router)# redistribute bgp | Configures redistribution of BGP routes into ISIS. |
PE2(config-router)#router bgp 100 | Enters the configuration mode for BGP with AS number 100. |
PE2(config-router)# bgp router-id 5.5.5.5 | Sets the BGP router ID to 5.5.5.5. |
PE2(config-router)# neighbor 2.2.2.2 remote-as 100 | Configures a BGP neighbor with the remote AS number 100 and IP address 2.2.2.2. |
PE2(config-router)# neighbor 2.2.2.2 update-source lo | Specifies the loopback interface as the source for BGP updates to the neighbor. |
PE2(config-router)# neighbor 2.2.2.2 advertisement-interval 0 | Sets the BGP advertisement interval to 0. |
PE2(config-router)# address-family l2vpn evpn | Enters the address-family configuration mode for L2VPN EVPN. |
PE2(config-router-af)# neighbor 2.2.2.2 activate | Activates the BGP neighbor for the L2VPN EVPN address family. |
PE2(config-router-af)# exit-address-family | Exits the address-family configuration. |
PE2(config-router)# address-family ipv4 vrf IpVrf1 | Enters the address-family configuration mode for IPv4 with VRF instance IpVrf1. |
PE2(config-router-af)# redistribute isis | Configures redistribution of ISIS routes into the IPv4 address family. |
PE2(config-router-af)# exit-address-family | Exits the address-family configuration. |
PE2(config)#interface irb101 | Enters interface configuration mode for IRB interface 101. |
PE2(config-irb-if)#mtu 9216 | Sets the MTU to 9216 bytes. |
PE2(config-irb-if)#commit | Commit the changes made to the interface configuration. |
PE2(config)#interface irb1001 | Enters interface configuration mode for IRB interface 1001. |
PE2(config-irb-if)#mtu 9216 | Sets the MTU to 9216 bytes. |
PE2(config-irb-if)#commit | Commit the changes made to the interface configuration. |
PE2(config-irb-if)#exit | Exits the IRB interface configuration mode and returns to the global configuration mode. |
PE2(config)#interface ce1 | Enters interface configuration mode for IRB interface ce1. |
PE2(config-irb-if)#mtu 9216 | Sets the MTU to 9216 bytes. |
PE2(config-irb-if)#commit | Commit the changes made to the interface configuration. |
PE2(config-irb-if)#exit | Exits the IRB interface configuration mode and returns to the global configuration mode. |
CE2#Configure Terminal | Enters the configuration mode. |
CE2(config)#interface ce1 | Enters the configuration mode for interface ce1. |
CE2(config-if)# load-interval 30 | Sets the load interval for the interface to 30 seconds. |
CE2(config-if)#interface ce1.101 | Enters the configuration mode for subinterface ce1.101. |
CE2(config-if)# encapsulation dot1q 101 | Configures 802.1Q encapsulation with VLAN ID 101 for the subinterface. |
CE2(config-if)# ip address 201.201.201.2/24 | Assigns the IPv4 address 201.201.201.2 with a subnet mask of /24 to the subinterface. |
CE2(config-if)# ip router isis 101 | Specifies ISIS as the routing protocol for IPv4. |
CE2(config-if)#interface ce1.1001 | Enters the configuration mode for subinterface ce1.1001. |
CE2(config-if)# encapsulation dot1q 1001 | Configures 802.1Q encapsulation with VLAN ID 1001 for the subinterface. |
CE2(config-if)# ipv6 address 2001::2/64 | Assigns the IPv6 address 2001::2 with a /64 prefix length to the subinterface. |
CE2(config-if)# ipv6 router isis 101 | Specifies ISIS as the routing protocol for IPv6. |
CE2(config-if)#interface lo | Enters the configuration mode for the loopback interface. |
CE2(config-if)# ip address 127.0.0.1/8 | Assigns the primary IPv4 address 127.0.0.1 to the loopback interface with a subnet mask of /8. |
CE2(config-if)# ip address 6.6.6.6/32 secondary | Adds a secondary IPv4 address, 6.6.6.6 with a /32 subnet mask, to the loopback interface. |
CE2(config-if)# ipv6 address ::1/128 | Assigns the primary IPv6 address ::1 to the loopback interface with a /128 prefix length. |
CE2(config)#router isis 101 | Enters the configuration mode for ISIS with process ID 101. |
CE2(config-router)# is-type level-2-only | Configures ISIS as a level-2-only routing protocol. |
CE2(config-router)# net 49.0001.0000.0000.0006.00 | Sets the ISIS NET for this router. |
CE2(config-router)# address-family ipv6 | Enters the address-family configuration mode for IPv6. |
CE2(config-router-af)# exit-address-family | Exits the address-family configuration for IPv6. |
CE2(config)#line console 0 | Enters the configuration mode for the console line. |
CE2(config-line)# exec-timeout 0 0 | Sets the console line's exec-timeout to 0. |
CE2(config-line)#line vty 0 871 | Enters the configuration mode for VTY lines 0 through 871. |
CE2(config-router-af)# exit | Exits the from configuration mode. |
CE2(config)#int ce1 | Enters interface configuration mode for int ce1. |
CE2(config-irb-if)#mtu 9216 | Sets the MTU to 9216 bytes. |
CE2(config-irb-if)#commit | Commit the changes made to the interface configuration. |
CE2(config-irb-if)#exit | Exits the IRB interface configuration mode and returns to the global configuration mode. |
CE2(config)#int ce1.101 | Enters interface configuration mode for int ce1.101. |
CE2(config-irb-if)#mtu 9216 | Sets the MTU to 9216 bytes. |
CE2(config-irb-if)#commit | Commit the changes made to the interface configuration. |
CE2(config-irb-if)#exit | Exits the IRB interface configuration mode and returns to the global configuration mode. |
CE2(config)#int ce1.1001 | Enters interface configuration mode for int ce1.1001. |
CE2(config-irb-if)#mtu 9216 | Sets the MTU to 9216 bytes. |
CE2(config-irb-if)#commit | Commit the changes made to the interface configuration. |
CE2(config-irb-if)#exit | Exits the IRB interface configuration mode and returns to the global configuration mode. |
Acronym | Description |
ECMP | Equal-Cost Multipath |
EVPN | Ethernet Virtual Private Netwrok |
MPLS | Multiprotocol Label Switching |
MPLS | Multiprotocol Label Switching |
SR | Segment Routing |
IRB | Integrated Routing |
OSPF | Open Shortest Path First |
ISIS | Intermediate System to Intermediate System |
Single Home EVPN-MPLS | A network architecture that combines EVPN and MPLS to provide efficient and scalable Layer 2 and Layer 3 services within a network, particularly in SP environments. |
IRB | A networking feature that enables the integration of Layer 3 IP routing and Layer 2 MAC address bridging within the same interface, simplifying network management and resource utilization. |
OSPF | A dynamic and efficient link-state routing protocol used to determine the best path for data packets in an IP network. It is characterized by rapid convergence and adaptability, making it suitable for large and dynamic networks. |
ISIS | A routing protocol designed for scalability and stability in computer networks, commonly used in large Service Provider networks. It provides a robust framework for routing information exchange. |
Layer 3 Routing | Network routing operations at the Network Layer (Layer 3) of the OSI model, focusing on routing IP packets between different subnets or networks. |
Layer 2 Bridging | Network bridging operations at the Data Link Layer (Layer 2) of the OSI model, handling the forwarding of data frames based on MAC addresses within the same network segment. |
EVPN | Ethernet VPN, a technology that provides advanced and efficient methods for Layer 2 and Layer 3 services in Ethernet networks, often used in data centers and service provider environments. |