PEI(Config)# terminal | Enters the configuration mode. |
PE1(config)#interface sa1 | Configure the sa1 interface as a network interface. |
PE1(config-if)# ip address 10.1.1.1/24 | Assigns an IP address to the sa1 interface with a subnet mask of /24. |
PE1(config-if)# ip ospf cost 10 | Configures the OSPF cost for the sa1 interface, setting it to 10. |
PE1(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the sa1 interface. |
PE1(config)#interface xe1 | Enters the interface xe1 mode. |
PE1(config-if)# static-channel-group 1 | Assigns the static channel group 1 to the xe2 interface. |
PE1(config-irb-if)#interface lo | Configures the loopback (lo) interface. |
PE1(config-if)# ip address 1.1.1.1/32 secondary | Assigns the primary IP address 1.1.1.1/32 to the loopback interface and specifies it as secondary. |
PE1(config)#router ospf 1 | Enters the OSPF configuration mode for OSPF process 1. |
PE1(config-router)# ospf router-id 1.1.1.1 | Sets the OSPF router ID to 1.1.1.1 for OSPF process 1. |
PE1(config-router)# network 1.1.1.1/32 area 0.0.0.0 | Advertises the network 1.1.1.1/32 into OSPF area 0.0.0.0. |
PE1(config-router)# network 10.1.1.0/24 area 0.0.0.0 | Advertises the network 10.1.1.0/24 into OSPF area 0.0.0.0. |
PE1(config)#hardware-profile filter vxlan enable | Enables the hardware profile filter for VXLAN. |
PE1(config)#nvo vxlan enable | Enables the VXLAN feature on the device. |
PE1(config)#nvo vxlan irb | Enables VXLAN IRB functionality. |
PE1(config-vrf)#mac vrf L2VRF1 | Configures a MAC VRF named L2VRF1. |
PE1(config-vrf)# rd 1.1.1.1:11 | Sets the Route Distinguisher (RD) to 1.1.1.1:11 for the VRF. |
PE1(config-vrf)# route-target both 9.9.9.9:100 | Configures both import and export route targets for the VRF. |
PE1(config-vrf)#ip vrf L3VRF1 | Configures an IP VRF named L3VRF1. |
PE1(config-vrf)# rd 51000:11 | Sets the RD value to 51000:11 for the L3VRF1. |
PE1(config-vrf)# route-target both 100:100 | Configures both import and export route targets for L3VRF1. |
PE1(config-vrf)# l3vni 1000 | Configures the L3 Virtual Network Identifier (L3VNI) with the value 1000. |
PE1(config)#interface irb1001 | Configures the IRB interface for L3VRF1. |
PE1(config-irb-if)# ip vrf forwarding L3VRF1 | Assigns the L3VRF1 to the IRB interface. |
PE1(config-irb-if)# ip address 11.11.11.1/24 | Assigns an IP address 11.11.11.1/24 to the IRB interface. |
PE1(config-irb)#interface irb2001 | Configures the IRB interface for IPv6 in L3VRF1. |
PE1(config-irb-if)# ip vrf forwarding L3VRF1 | Assigns the L3VRF1 to the IPv6 IRB interface. |
PE1(config-irb-if)# ipv6 address 2001::1/64 | Assigns an IP address 11.11.11.1/24 to the IRB interface. |
PE1(config-irb-if)#mtu 9000 | Sets the Maximum Transmission Unit (MTU) for this IRB interface to 9000 bytes. |
PE1(config-router)#router ospf 2 L3VRF1 | Configures OSPF on the L3VRF1. |
PE1(config-router)# network 11.11.11.0/24 area 0.0.0.0 | Advertises the network 11.11.11.0/24 into OSPF area 0.0.0.0. |
PE1(config-router)#router ipv6 vrf ospf L3VRF1 | Configures OSPFv3 on the L3VRF1. |
PE1(config-router)# router-id 1.1.1.1 | Configures the router ID as 1.1.1.1. |
PE1(config-irb)#interface irb2001 | Configures the IPv6 IRB interface. |
PE1(config-irb-if)# ipv6 router ospf area 0.0.0.0 tag L3VRF1 instance-id 0 | Attaches the OSPFv3 instance ID to the IPv6 IRB interface. |
PE1(config)#nvo vxlan vtep-ip-global 1.1.1.1 | Configures the global VTEP IP address as 1.1.1.1. |
PE1(config)#nvo vxlan id 101 ingress-replication | Configures the VXLAN ID as 101 for ingress replication. |
PE1(config-nvo)# vxlan host-reachability-protocol evpn-bgp L2VRF1 | Maps the EVPN-BGP host reachability protocol to L2VRF1. |
PE1(config-nvo)# evpn irb1001 | Maps the IRB interface 1001 to EVPN. |
PE1(config-nvo)# vni-name VNI-101 | Configures the VNI name as VNI-101. |
PE1(config)#nvo vxlan id 2001 ingress-replication | Configures the VXLAN ID as 2001 for ingress replication. |
PE1(config-nvo)# vxlan host-reachability-protocol evpn-bgp L2VRF1 | Maps the EVPN-BGP host reachability protocol to L2VRF1. |
PE1(config-nvo)# evpn irb2001 | Maps the IPv6 IRB interface to EVPN. |
PE1(config)#interface xe2 | Configures the xe2 interface. |
PE1(config-if)# switchport | Configures the port as a Layer 2 (L2) switchport. |
PE1(config-if)# load-interval 30 | Configures the load-interval of 30 minutes for monitoring traffic on the xe2 interface. |
PE1(config-if)#interface xe2.100 switchport | Configures a Layer 2 access interface subinterface |
PE1(config-if)# encapsulation dot1q 100 | Sets the encapsulation to be a single-tag with VLAN ID 100 |
PE1(config-if)# rewrite pop | Configures the rewrite pop action. |
PE1(config-if)# access-if-evpn | Configures the port as an access interface for EVPN. |
PE1(config-acc-if-evpn)# map vpn-id 101 | Maps the VPN ID 101 to the interface. |
PE1(config)#interface xe2.2001 switchport | Configures a Layer 2 access interface subinterface. |
PE1(config-if)# rewrite pop | Configures the rewrite pop action. |
PE1(config-if)# access-if-evpn | Configures the port as an access interface for EVPN. |
PE1(config-acc-if-evpn)# map vpn-id 2001 | Maps the VPN ID 2001 to the interface. |
PE1(config-router)#router bgp 100 | Configures the BGP process with AS number 100. |
PE1(config-router)# bgp router-id 1.1.1.1 | Assigns the router ID as 1.1.1.1 for the BGP instance. |
PE1(config-router)# neighbor 4.4.4.4 remote-as 100 | Configures neighbor 4.4.4.4 with a remote AS number of 100. |
PE1(config-router)# neighbor 4.4.4.4 update-source lo | Configures the update source for neighbor 4.4.4.4 to be the loopback interface. |
PE1(config-router)# neighbor 4.4.4.4 advertisement-interval 0 | Configures the advertisement interval for neighbor 4.4.4.4 as 0. |
PE1(config-router)# address-family l2vpn evpn | Configures the address-family for L2VPN EVPN. |
PE1(config-router-af)# neighbor 4.4.4.4 activate | Activates the neighbor for the L2VPN EVPN address-family. |
PE1(config-router-af)# exit-address-family | Exits from the address family configuration. |
PE1(config-router)# address-family ipv4 vrf L3VRF1 | Configures the IPv4 address-family for VRF L3VRF1. |
PE1(config-router-af)# redistribute connected | Configures the redistribution of connected routes within the IPv4 address-family. |
PE1(config-router-af)# exit-address-family | Exits the IPv4 address-family configuration. |
PE1(config-router)# address-family ipv6 vrf L3VRF1 | Configures the IPv6 address-family for VRF L3VRF1. |
PE1(config-router-af)# redistribute connected | Configures the redistribution of connected routes within the IPv6 address-family. |
PE1(config-router-af)# exit-address-family | Exits the IPv6 address-family configuration. |
PE5#configure terminal | Enters the configuration mode |
PE5(config)#interface sa1 | Configure the sa1 interface as a network interface. |
PE5(config-if)# ip address 10.1.1.1/24 | Assigns an IP address to the sa1 interface with a subnet mask of /24. |
PE5(config-if)# ip ospf cost 10 | Configures the OSPF cost for the sa1 interface, setting it to 10. |
PE5(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the sa1 interface. |
PE5(config)#interface xe1 | Configure network interface towards PE6. |
PE5(config-if)# static-channel-group 1 | Assigns the static channel group 1 to the xe1 interface. |
PE5(config)#interface xe5 | configures the xe5 interface. |
PE5(config-if)#ip address 30.1.1.1/24 | Assigns the primary IP address 1.1.1.1/32 to the loopback interface and specifies it as secondary. |
PE5(config)#ip ospf cost 10 | Configures the OSPF cost for the xe5 interface, setting it to 10. |
PE5(config-router)# ospf router-id 1.1.1.1 | Assigns an IP address (30.1.1.1) to the xe5 interface with a subnet mask of /24. |
PE5(config)#load-interval 30 | Configures the load-interval for monitoring traffic on the xe5 interface. |
PE5(config)#router ospf 1 | Enters the OSPF configuration mode for OSPF process 1. |
PE5(config-router)# network 30.1.1.0/24 area 0.0.0.0 | Advertises the network 30.1.1.0/24 into OSPF area 0.0.0.0. |
PE5(config-router)# network 10.1.1.0/24 area 0.0.0.0 | Advertises the network 10.1.1.0/24 into OSPF area 0.0.0.0. |
PE3#configure terminal | Enters the configuration mode |
PE3(config)#interface ce30 | Configure the ce30 interface as a network interface. |
PE3(config-if)# ip address 40.1.1.2/24 | Assigns an IP address to the ce30 interface with a subnet mask of /24. |
PE3(config-if)# ip ospf cost 10 | Configures the OSPF cost for the sa1 interface, setting it to 10. |
PE3(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the sa1 interface. |
PE3(config)#interface lo | Configure the loopback interface. |
PE3(config-if)#ip address 4.4.4.4/32 secondary | Assign an secondary IP to an loopback interface. |
PE3(config)#ip ospf cost 10 | Configures the OSPF cost for the xe7interface, setting it to 10. |
PE3(config)#load-interval 30 | Configures the load-interval for monitoring traffic on the xe5 interface. |
PE3(config)#router ospf 1 | Enters the OSPF configuration mode for OSPF process 1. |
PE3(config-router)# ospf router-id 4.4.4.4 | Configures the router id to an ospf instance. |
PE3(config-router)# network 4.4.4.4/32 area 0.0.0.0 | Advertises the loopback address. |
PE3(config-router)# network 40.1.1.0/24 area 0.0.0.0 | Advertises the network interface IP address. |
PE3(config)#hardware-profile filter vxlan enable | Enables hardware profile filter for vxlan |
PE3(config)#nvo vxlan enable | Enables VXLAN on the device, allowing it to participate in VXLAN networks. |
PE3(config)#nvo vxlan irb | Enables VXLAN IRB functionality, that allows routing between VXLAN and non-VXLAN networks. |
PE3(config-vrf)#mac vrf L2VRF1 | Configures a L2 MAC VRF instance named L2VRF1, which is a logical network segment for L2 traffic isolation. |
PE3(config-vrf)# rd 4.4.4.4:11 | Configures a RD for the L2VRF1, with the value 4.4.4.4:11. |
PE3(config-vrf)# route-target both 9.9.9.9:100 | Configures a route target for the VRF. |
PE3(config-vrf)#ip vrf L3VRF1 | Configures a L3 VRF named L3VRF1. |
PE3(config-vrf)# rd 56000:11 | Configures a RD for the L3VRF1, with the value 56000:11. |
PE3(config-vrf)# route-target both 100:100 | Configures a route target for the VRF. |
PE3(config-vrf)# l3vni 1000 | Configures a L3VNI with the ID 1000 for the VRF. |
PE3(config)#interface irb1001 | Configures the IRB interface with the ID 1001. |
PE3(config-irb-if)# ip vrf forwarding L3VRF1 | Associates the IRB interface with the L3VRF1, ensuring that traffic from this interface is isolated within that VRF. |
PE3(config-irb-if)# ip address 12.12.12.1/24 | Assigns an IP address 12.12.12.1 with a subnet mask of /24 to the IRB interface, enabling it for L3 routing. |
PE3(config-irb-if)# mtu 1500 | Configures the MTU for the interface irb1001 to 1500 bytes. |
PE3(config)#interface irb2001 | Configures another IRB interface with the ID 2001. |
PE3(config-irb-if)# ip vrf forwarding L3VRF1 | Associates the IRB interface with the L3VRF1. |
PE3(config-irb-if)# ipv6 address 2002::1/64 | Assigns an IPv6 address 2002::1 with a subnet mask of /64 to the IRB interface, enabling it for IPv6 routing. |
PE3(config-irb-if)# mtu 1500 | Configures the MTU for the interface irb2001 to 1500 bytes. |
PE3(config-router)#router ospf 2 L3VRF1 | Configures the OSPF routing process on OSPF instance 2 for the L3VRF1. |
PE3(config-router)# network 12.12.12.0/24 area 0.0.0.0 | Advertises the network 12.12.12.0/24 to OSPF area 0.0.0.0. |
PE3(config-router)#router ipv6 vrf ospf L3VRF1 | Configures the OSPFv3 routing process on OSPFv3 instance for the L3VRF1. |
PE3(config-router)# router-id 4.4.4.4 | Sets the router ID for the OSPF/OSPFv3 instances to 4.4.4.4. |
PE3(config)#nvo vxlan vtep-ip-global 4.4.4.4 | Configures the global VTEP IP address as 4.4.4.4 for VXLAN. |
PE3(config)#nvo vxlan id 102 ingress-replication | Configures the VXLAN with VNI ID 102 for ingress replication. |
PE3(config-nvo)# vxlan host-reachability-protocol evpn-bgp L2VRF1 | Maps the VXLAN configuration with the EVPN-BGP protocol and associates it with the L2VRF1. |
PE3(config-nvo)# evpn irb1001 | Maps the IRB interface irb1001 to the VXLAN. |
PE3(config-nvo)# vni-name VNI-101 | Configures the VNI name as VNI-101. |
PE3(config)#nvo vxlan id 2002 ingress-replication | Configures another VXLAN with VNI ID 2002 for ingress replication. |
PE3(config-nvo)# vxlan host-reachability-protocol evpn-bgp L2VRF1 | Maps the VXLAN configuration with the EVPN-BGP protocol and associates it with the L2VRF1. |
PE3(config-nvo)# evpn irb2001 | Maps the IPv6 IRB interface irb2001 to the VXLAN. |
PE3(config)#interface sa4 | Configures interface sa4. |
PE3(config-if)# switchport | Configures the interface as a switchport. |
PE3(config-if)# load-interval 30 | Sets the load interval for the interface to 30 seconds. |
PE3(config-if)# mtu 1500 | Configures the MTU for the interface to 1500 bytes. |
PE3(config)#interface xe1 | Configures interface xe1. |
PE3(config-if)# static-channel-group 4 | Assigns a static channel group to interface xe1. |
PE3(config-if)#interface sa4.100 switchport | Configures subinterface sa4.100 as a switchport with VLAN 100. |
PE3(config-if)# encapsulation dot1q 100 | Configures the encapsulation with VLAN ID 100.v |
PE3(config-if)# rewrite pop | Configures the rewrite behavior for popping VLAN tags. |
PE3(config-if)# access-if-evpn | Configures the interface as an access interface for EVPN. |
PE3(config-acc-if-evpn)# map vpn-id 102 | Maps the access interface to VPN ID 102 for EVPN routing. |
PE3(config)#interface sa4.2002 switchport | Configures subinterface sa4.2002 as a switchport with VLAN 2002. |
PE3(config-if)# encapsulation dot1q 2002 | Configures the encapsulation with VLAN ID 2002. |
PE3(config-if)# rewrite pop | Configures the rewrite behavior for popping VLAN tags. |
PE3(config-if)# access-if-evpn | Configures the interface as an access interface for EVPN. |
PE3(config-acc-if-evpn)# map vpn-id 2002 | Maps the access interface to VPN ID 2002 for EVPN routing. |
PE3(config-router)#router bgp 100 | Configures the BGP with AS number 100. |
PE3(config-router)# bgp router-id 4.4.4.4 | Sets the BGP router ID to 4.4.4.4. |
PE3(config-router)# neighbor 1.1.1.1 remote-as 100 | Configures a BGP neighbor with the remote AS number 100 and the IP address 1.1.1.1. |
PE3(config-router)# neighbor 1.1.1.1 update-source lo | Specifies the BGP neighbor to use the loopback interface as the source for updates. |
PE3(config-router)# neighbor 1.1.1.1 advertisement-interval 0 | Configures the advertisement interval for BGP neighbor updates. |
PE3(config-router)# address-family l2vpn evpn | Configures the BGP address family for Layer 2 VPN EVPN. |
PE3(config-router-af)# neighbor 1.1.1.1 activate | Activates the BGP neighbor for the specified address family. |
PE3(config-router-af)# exit-address-family | Exits the BGP address family configuration. |
PE3(config-router)# address-family ipv4 vrf L3VRF1 | Configures the BGP address family for IPv4 within VRF L3VRF1. |
PE3(config-router-af)# redistribute connected | Configures BGP to redistribute connected routes into the BGP process. |
PE3(config-router-af)# exit-address-family | Exits the BGP address family configuration for IPv4. |
PE3(config-router)# address-family ipv6 vrf L3VRF1 | Configures the BGP address family for IPv6 within VRF L3VRF1. |
PE3(config-router-af)# redistribute connected | Configures BGP to redistribute connected routes into the BGP process. |
PE3(config-router-af)# exit-address-family | Exits the BGP address family configuration for IPv6. |
PE6#configure terminal | Enters the configuration mode. |
PE6(config)#interface ce2 | Configure the ce2 interface as a network interface. |
PE6(config-if)# ip address 10.1.1.1/24 | Assigns an IP address to the sa1 interface with a subnet mask of /24. |
PE6(config-if)# ip ospf cost 10 | Configures the OSPF cost for the sa1 interface, setting it to 10. |
PE6(config-if)# load-interval 30 | Configures the load-interval for monitoring traffic on the sa1 interface. |
PE6(config)#interface xe7 | Configure network interface towards PE5. |
PE6(config-if)# static-channel-group 1 | Assigns the static channel group 1 to the xe1 interface. |
PE6(config-if)#ip address 30.1.1.1/24 | Assign IP address to network interface. |
PE6(config)#ip ospf cost 10 | Configures the OSPF cost for the xe7interface, setting it to 10. |
PE6(config)#load-interval 30 | Configures the load-interval for monitoring traffic on the xe5 interface. |
PE6(config)#router ospf 1 | Enters the OSPF configuration mode for OSPF process 1. |
PE6(config-router)# network 30.1.1.0/24 area 0.0.0.0 | Advertises the network 30.1.1.0/24 into OSPF area 0.0.0.0. |
PE6(config-router)# network 40.1.1.0/24 area 0.0.0.0 | Advertises the network 40.1.1.0/24 into OSPF area 0.0.0.0. |
PE2(config-if)# interface po1 | Enters configuration mode for po 1. |
PE2(config-if)# ip address 20.1.1.1/24 | Assigns the IP address 20.1.1.1 with a subnet mask of 255.255.255.0 to the interface. |
PE2(config-if)#ip router isis 1 | Enables ISIS routing protocol on the interface with process ID 1. |
PE2(config-if)#load-interval 30 | Sets the interval for which interface statistics are collected to 30 seconds. |
PE2(config)#hardware-profile filter vxlan enable | Enables the hardware profile filter for VxLAN on the device. |
PE2(config)#nvo vxlan enable | Enables the VXLAN feature on the device. |
PE2(config)#nvo vxlan irb | Enables VXLAN IRB functionality. |
PE2(config-vrf)#mac vrf L2VRF2 | Enters the configuration mode for a MAC VRF named L2VRF2. |
PE2(config-vrf)# rd 2.2.2.2:11 | Sets the route distinguisher (RD) for the VRF to 2.2.2.2:11. |
PE2(config-vrf)#route-target both 10.10.10.10:100 | Specifies import and export route targets for the VRF. |
PE2(config-vrf)#ip vrf L3VRF2 | Enters the configuration mode for an IP VRF named L3VRF2. |
PE2(config-vrf)#rd 61000:11 | Sets the RD for the IP VRF to 61000:11 |
PE2(config-vrf)# route-target both 101:101 | Specifies import and export route targets for the IP VRF. |
PE2(config-vrf)# l3vni 2000 | Configures the Layer 3 VNI (Virtual Network Identifier) for the IP VRF. |
PE2(config)#interface irb2001 | Enters the configuration mode for interface IRB2001. |
PE2(config-irb-if)# ip vrf forwarding L3VRF2 | Associates the interface with the IP VRF L3VRF2. |
PE2(config-irb-if)# ip address 13.13.13.1/24 | Configures an IP address with a subnet mask of /24 on IRB2001. |
PE2(config-irb-if)#mtu 9000 | Sets the Maximum Transmission Unit (MTU) for the interface to 9000 bytes. |
PE2(config-irb-if)#ip router isis 2 | Associates the interface with ISIS routing process 2. |
PE2(config-irb)#interface irb3001 | Enters the configuration mode for interface IRB3001. |
PE2(config-irb-if)# ip vrf forwarding L3VRF2 | Associates the interface with the IP VRF L3VRF2. |
PE2(config-irb-if)# ipv6 address 3001::1/64 | Configures an IPv6 address on IRB3001 with the specified prefix length. |
PE2(config-irb-if)#mtu 9000 | Sets the MTU for the interface to 9000 bytes. |
PE2(config-irb)#ipv6 router isis 3 | Associates the interface with IPv6 ISIS routing process 3. |
PE2(config)#router isis 2 L3VRF2 | Enters the configuration mode for ISIS routing process 2 within VRF L3VRF2. |
PE2(config-router)#is-type level-1-2 | Specifies the ISIS level type as level-1-2. |
PE2(config-router)#metric-style wide | Configures a wide metric style for ISIS. |
PE2(config-router)# dynamic-hostname | Enables dynamic hostname assignment for the ISIS router. |
PE2(config-router)# bfd all-interfaces | Enables Bidirectional Forwarding Detection (BFD) on all interfaces within ISIS. |
PE2(config-router)#net 49.0000.0000.0221.00 | Configures the network entity title (NET) for the ISIS process. |
PE2(config)#router isis 3 L3VRF2 | Enters the configuration mode for ISIS routing process 3 within VRF L3VRF2. |
PE2(config-router)#is-type level-1-2 | Specifies the ISIS level type as level-1-2. |
PE2(config-router)# metric-style wide | Configures a wide metric style for ISIS. |
PE2(config-router)# dynamic-hostname | Enables dynamic hostname assignment for the ISIS router. |
PE2(config-router)#bfd all-interfaces | Enables BFD on all interfaces within ISIS. |
PE2(config-router)# net 49.0000.0000.0222.00 | Configures the network entity title (NET) for ISIS routing with the specified value. |
PE2(config)#nvo vxlan vtep-ip-global 2.2.2.2 | Configures the global VxLAN VTEP IP address to 2.2.2.2. |
PE2(config)#nvo vxlan id 201 ingress- replication | Configures a VxLAN with VNI 201 and specifies ingress-replication for multicast traffic handling. |
PE2(config-nvo)# vxlan host-reachability- protocol evpn-bgp L2VRF2 | Specifies the EVPN-BGP host-reachability-protocol for the VxLAN with the VRF L2VRF2 |
PE2(config-nvo)# evpn irb2001 | Enables EVPN IRB (Integrated Routing and Bridging) for VxLAN interface IRB2001. |
PE2(config-nvo)# vni-name VNI-201 | Assigns a name VNI-201 to the VxLAN VNI 201. |
PE2(config)#nvo vxlan id 3001 ingress- replication | Configures another VxLAN with VNI 3001 and specifies ingress-replicationr for multicast traffic handling. |
PE2(config-nvo)# vxlan host-reachability- protocol evpn-bgp L2VRF2 | Specifies the EVPN-BGP host-reachability-protocol for the VxLAN with the VRF L2VRF2. |
PE2(config-nvo)# evpn irb3001 | Enables EVPN IRB for VxLAN interface IRB3001. |
PE2(config-if)#interface xe11 | Enters the configuration mode for the interface 11. |
PE2(config-if)#switchport | Configures the interface as a Layer 2 switchport. |
PE2(config-if)#load-interval 30 | Sets the interval for which interface statistics are collected to 30 seconds. |
PE2(config-if)#interface xe11.200 switchport | Enters the configuration mode for subinterface xe11.200 and configures it as a Layer 2 switchport. |
PE2(config-if)#encapsulation dot1q 200 | Sets the IEEE 802.1Q VLAN encapsulation for subinterface xe11.200 with VLAN ID 200. |
PE2(config-if)#rewrite pop | Configures the subinterface to rewrite the outer header for provider edge devices. |
PE2(config-if)#access-if-evpn | Configures the subinterface as an access interface for EVPN (Ethernet VPN). |
PE2(config-if)#map vpn-id 201 | Maps the VPN ID 201 to the subinterface for EVPN. |
PE2(config-if)#interface xe11.3001 switchport | Configures interface xe11.3001. |
PE2(config-if)#encapsulation dot1q 200 | Sets the IEEE 802.1Q VLAN encapsulation for subinterface xe11.200 with VLAN ID 200. |
PE2(config-if)#rewrite pop | Configures the subinterface to rewrite the outer header for provider edge devices. |
PE2(config-if)#access-if-evpn | Configures the subinterface as an access interface for EVPN. |
PE2(config-if)#map vpn-id 3001 | Maps the VPN ID 3001 to the subinterface for EVPN. |
PE2(config-if)#router isis 1 | Starts the ISIS routing process with process ID 1. |
PE2(config-if)#is-type level-1-2 | Specifies that the router participates in both Level 1 and Level 2 routing. |
PE2(config-if)#metric-style wide | Configures the metric style to be wide, enabling more flexibility in metric calculations. |
PE2(config-if)#mpls traffic-eng router-id 2.2.2.2 | Sets the MPLS Traffic Engineering router ID to 2.2.2.2. |
PE2(config-if)#mpls traffic-eng level-1 | Enables MPLS Traffic Engineering for Level 1 ISIS. |
PE2(config-if)#mpls traffic-eng level-2 | Enables MPLS Traffic Engineering for Level 2 ISIS. |
PE2(config-if)#dynamic-hostname | Enables the dynamic hostname feature for ISIS. |
PE2(config-if)#bfd all-interfaces | Configures Bidirectional Forwarding Detection on all interfaces. |
PE2(config-if)#net 49.0000.0000.0001.00 | Specifies the network entity title (NET) for ISIS. |
PE2(config)#router bgp 100 | Starts the BGP routing process with an autonomous system number (AS) of 100. |
PE2(config-router)#bgp router-id 2.2.2.2 | Sets the BGP router ID to 2.2.2.2. |
PE2(config-router)#neighbor 3.3.3.3 remote-as 100 | Configures a BGP neighbor with the IP address 3.3.3.3 and specifies the remote AS number as 100. |
PE2(config-router)#neighbor 3.3.3.3 update-source lo | Specifies that loopback interface (lo) is the source for BGP updates to the neighbor. |
PE2(config-router)#neighbor 3.3.3.3 advertisement-interval 0 | Sets the advertisement interval to 0, which means updates will be sent immediately. |
PE2(config-router)#address-family ipv4 unicast | Enters the configuration mode for the IPv4 unicast address family within the router configuration. |
PE2(config-router-af)#network 2.2.2.2/32 | Specifies that network 2.2.2.2 with a /32 subnet mask is part of the IPv4 unicast address family. |
PE2(config-router-af)#neighbor 3.3.3.3 activate | Activates the neighbor with the IP address 3.3.3.3 for the IPv4 unicast address family. |
PE2(config-router-af)#exit-address-family | Exits the configuration mode for the IPv4 unicast address family. |
PE2(config-router)#address-family l2vpn evpn | Enters the configuration mode for the L2VPN EVPN address family within the router configuration. |
PE2(config-router-af)#neighbor 3.3.3.3 activate | Activates the neighbor with the IP address 3.3.3.3 for the L2VPN EVPN address family. |
PE2(config-router-af)#exit-address-family | Exits the configuration mode for the L2VPN EVPN address family. |
PE2(config-router)#address-family ipv4 vrf L3VRF2 | Enters the configuration mode for the IPv4 address family within the VRF named L3VRF2. |
PE2(config-router-af)#redistribute connected | Configures the redistribution of directly connected routes into the IPv4 address family for the specified VRF. |
PE2(config-router-af)#exit-address-family | Exits the configuration mode for the IPv4 address family within the VRF L3VRF2. |
PE2(config-router-af)#address-family ipv6 vrf L3VRF2 | Enters the configuration mode for the IPv6 address family within the VRF named L3VRF2. |
PE2(config-router-af)#redistribute connected | Configures the redistribution of directly connected routes into the IPv6 address family for the specified VRF. |
PE2(config-router-af)#exit-address-family | Exits the configuration mode for the IPv6 address family within the VRF L3VRF2. |
PE5(config-if)#interface po1 | Enters the configuration mode for po1. |
PE5(config-if)#ip address 20.1.1.2/24 | Assigns the IP address 20.1.1.2 with a subnet mask of /24 to this interface. |
PE5(config-if)#ip router isis 1 | Specifies that ISIS routing process 1 is enabled on this interface. |
PE5(config-if)#load-interval 30 | Sets the load interval to 30 seconds for monitoring the interface. |
PE5(config-if)#interface ce50 | Enters the configuration mode for ce50. |
PE5(config-if)#ip address 50.1.1.1/24 | Assigns the IP address 50.1.1.1 with a subnet mask of /24 to this interface. |
PE5(config-if)#ip router isis 1 | Specifies that ISIS routing process 1 is enabled on this interface. |
PE5(config-if)#load-interval 30 | Sets the load interval to 30 seconds for monitoring the interface. |
PE5(config-if)#router isis 1 | Enters ISIS configuration mode with process ID 1. |
PE5(config-if)#is-type level-1-2 | Configures this ISIS router to support both Level 1 and Level 2 routing. |
PE5(config-if)#metric-style wide | Configures ISIS to use the wide metric style, which allows for greater flexibility in metric values. |
PE5(config-if)#dynamic-hostname | Allows the hostname to be dynamically generated. |
PE5(config-if)#bfd all-interfaces | Enables Bidirectional Forwarding Detection on all interfaces. |
PE5(config-if)#net 49.0000.0005.0001.00 | Sets the NET for this router. |
PE5(config-if)#exit | Exits from the router mode. |
PE6#configure terminal | Enters the configuration maode. |
PE6(config-if)#interface xe5 | Enters configuration mode for interface xe5. |
PE6(config-if)#ip address 60.1.1.1/24 | Assigns the IP address 80.1.1.2 with a subnet mask of 255.255.255.0 to interface sa2. |
PE6(config-if)#ip router isis 1 | Associates ISIS routing protocol with this interface using process ID 1. |
PE6(config-if)#load-interval 30 | Sets the load-interval to 30 seconds. |
PE6(config-if)#interface ce1 | Enters configuration mode for interface ce1. |
PE6(config-if)#ip address 50.1.1.2/24 | Assigns the IP address 50.1.1.2 with a subnet mask of 255.255.255.0 to interface ce1. |
PE6(config-if)#ip router isis 1 | Associates ISIS routing protocol with this interface using process ID 1. |
PE6(config-if)#load-interval 30 | Sets the load-interval to 30 seconds. |
PE6(config-if)#router isis 1 | Enters ISIS configuration mode with process ID 1. |
PE6(config-if)#is-type level-1-2 | Configures this ISIS router to support both Level 1 and Level 2 routing. |
PE6(config-if)#metric-style wide | Configures ISIS to use the wide metric style, which allows for greater flexibility in metric values. |
PE6(config-if)#dynamic-hostname | Allows the hostname to be dynamically generated. |
PE6(config-if)#bfd all-interfaces | Enable BFD on all network interfaces. |
PE4#configure terminal | Enters the configuration mode. |
PE4(config-if)# interface xe26 | Enters configuration mode for xe26. |
PE4(config-if)# ip address 60.1.1.2/24 | Assigns the IP address 60.1.1.2 with a subnet mask of 255.255.255.0 to the interface. |
PE4(config-if)#ip router isis 1 | Enables ISIS routing protocol on the interface with process ID 1. |
PE4(config-if)#ip router isis 1 | Enables ISIS routing protocol on the interface with process ID 1. |
PE4(config-if)#load-interval 30 | Sets the interval for which interface statistics are collected to 30 seconds. |
PE4(config)#hardware-profile filter vxlan enable | Enables the hardware profile filter for VXLAN. |
PE4(config)#nvo vxlan enable | Enables the VXLAN feature on the device. |
PE4(config)#nvo vxlan irb | Enables VXLAN IRB functionality. |
PE4(config-vrf)#mac vrf L2VRF2 | Configures a VRF instance named L2VRF2 and associates it with a specific RD |
PE4(config-vrf)# rd 3.3.3.3:11 | Sets the RD for the L2VRF2 VRF to 3.3.3.3:11. |
PE4(config-vrf)#route-target both 10.10.10.10:100 | Associates a route target with the L2VRF2 VRF for VPN route distribution. |
PE4(config-vrf)#ip vrf L3VRF2 | Configures another VRF named L3VRF2. |
PE4(config-vrf)#rd 63000:11 | Sets the RD for the L3VRF2 VRF to 63000:11. |
PE4(config-vrf)# route-target both 101:101 | Associates a route target with the L3VRF2 VRF for VPN route distribution. |
PE4(config-vrf)# l3vni 2000 | Configures the L3VNI for the L3VRF2 VRF. |
PE4(config)#interface irb2001 | Configuring an IRB interface with the number 2001. |
PE4(config-irb-if)# ip vrf forwarding L3VRF2 | Associates the IRB interface with the L3VRF2 VRF. |
PE4(config-irb-if)# ip address 14.14.14.1/24 | Assigns an IP address to the IRB interface. |
PE4(config-irb-if)#mtu 9000 | Sets the MTU for the IRB interface. |
PE4(config-irb-if)#ip router isis 2 | Associates the IRB interface with ISIS routing. |
PE4(config-irb)#interface irb3002 | Configures another IRB interface with the number 3002. |
PE4(config-irb-if)# ip vrf forwarding L3VRF2 | Associates the second IRB interface with the "L3VRF2" VRF. |
PE4(config-irb-if)# ipv6 address 3002::1/64 | Assigns an IPv6 address to the second IRB interface. |
PE4(config-irb-if)#mtu 9000 | Sets the MTU for the second IRB interface. |
PE4(config-irb)#ipv6 router isis 3 | Associates the IRB interfaces with IPv6 and ISIS routing. |
PE4(config)#router isis 2 L3VRF2 | Configures ISIS routing with the VRF L3VRF2. |
PE4(config-router)#is-type level-1-2 | Sets the ISIS level type to level-1-2. |
PE4(config-router)# metric-style wide | Configures a wide metric style for ISIS. |
PE4(config-router)# dynamic-hostname | Enables dynamic hostname assignment for the ISIS router. |
PE4(config-router)#bfd all-interfaces | Enables BFD on all interfaces within ISIS. |
PE4(config-router)# net 49.0000.0000.0441.00 | Configures the network entity title (NET) for ISIS routing with the specified value. |
PE4(config)#router isis 3 L3VRF2 | Configures ISIS routing with the VRF L3VRF2. |
PE4(config-router)#is-type level-1-2 | Sets the ISIS level type to level-1-2. |
PE4(config-router)# metric-style wide | Configures a wide metric style for ISIS. |
PE4(config-router)# dynamic-hostname | Enables dynamic hostname assignment for the ISIS router. |
PE4(config-router)#bfd all-interfaces | Enables BFD on all interfaces within ISIS. |
PE4(config-router)# net 49.0000.0000.0442.00 | Configures the network entity title (NET) for ISIS routing with the specified value. |
PE4(config)#nvo vxlan vtep-ip-global 3.3.3.3 | Configures the global VxLAN VTEP IP address to 3.3.3.3. |
PE4(config)#nvo vxlan id 201 ingress- replication | Configures a VxLAN with VNI 201 and specifies ingress-replication for multicast traffic handling. |
PE4(config-nvo)# vxlan host-reachability- protocol evpn-bgp L2VRF2 | Specifies the EVPN-BGP host-reachability-protocol for the VxLAN with the VRF L2VRF2 |
PE4(config-nvo)# evpn irb2001 | Enables EVPN IRB (Integrated Routing and Bridging) for VxLAN interface IRB2001. |
PE4(config-nvo)# vni-name VNI-201 | Assigns a name VNI-201 to the VxLAN VNI 201. |
PE4(config)#nvo vxlan id 3002 ingress- replication | Configures another VxLAN with VNI 3002 and specifies ingress-replicationr for multicast traffic handling. |
PE4(config-nvo)# vxlan host-reachability- protocol evpn-bgp L2VRF2 | Specifies the EVPN-BGP host-reachability-protocol for the VxLAN with the VRF L2VRF2. |
PE4(config-nvo)# evpn irb3002 | Enables EVPN IRB for VxLAN interface IRB3002 |
PE4(config-if)#interface xe26 | Enters the configuration mode for the interface 26. |
PE4(config-if)#switchport | Configures the interface as a L2 switchport. |
PE4(config-if)#load-interval 30 | Sets the interval for which interface statistics are collected to 30 seconds. |
PE4(config)#hardware-profile filter vxlan enable | Enables the hardware profile filter for VxLAN on the device. |
PE4(config-if)#interface xe26.200 switchport | Enters the configuration mode for subinterface xe26.200 and configures it as a Layer 2 switchport. |
PE4(config-if)#encapsulation dot1q 200 | Sets the IEEE 802.1Q VLAN encapsulation for subinterface xe11.200 with VLAN ID 200. |
PE4(config-if)#rewrite pop | Configures the subinterface to rewrite the outer header for provider edge devices. |
PE4(config-if)#access-if-evpn | Configures the subinterface as an access interface for EVPN (Ethernet VPN). |
PE4(config-if)#map vpn-id 201 | Maps the VPN ID 201 to the subinterface for EVPN. |
PE4(config-if)#interface xe26.3001 switchport | Configures xe26.3001 interface. |
PE4(config-if)#encapsulation dot1q 200 | Sets the IEEE 802.1Q VLAN encapsulation for subinterface xe11.200 with VLAN ID 200. |
PE4(config-if)#rewrite pop | Configures the subinterface to rewrite the outer header for provider edge devices. |
PE4(config-if)#access-if-evpn | Configures the subinterface as an access interface for EVPN. |
PE4(config-if)#map vpn-id 3002 | Maps the VPN ID 3002 to the subinterface for EVPN. |
PE4(config-if)#router isis 1 | Starts the ISIS routing process with process ID 1. |
PE4(config-if)#is-type level-1-2 | Specifies that the router participates in both Level 1 and Level 2 routing. |
PE4(config-if)#metric-style wide | Configures the metric style to be wide, enabling more flexibility in metric calculations. |
PE4(config-if)#mpls traffic-eng router-id 2.2.2.2 | Sets the MPLS Traffic Engineering router ID to 2.2.2.2. |
PE4(config-if)#mpls traffic-eng level-1 | Enables MPLS Traffic Engineering for Level 1 ISIS. |
PE4(config-if)#mpls traffic-eng level-2 | Enables MPLS Traffic Engineering for Level 2 ISIS. |
PE4(config-if)#dynamic-hostname | Enables the dynamic hostname feature for ISIS. |
PE4(config-if)#bfd all-interfaces | Configures Bidirectional Forwarding Detection on all interfaces. |
PE4(config-if)#net 49.0000.0003.0001.00 | Specifies the network entity title (NET) for ISIS. |
PE4(config)#router bgp 100 | Starts the BGP routing process with an autonomous system number (AS) of 100. |
PE4(config-router)#bgp router-id 3.3.3.3 | Sets the BGP router ID to 3.3.3.3 |
PE4(config-router)#neighbor 2.2.2.2 remote-as 100 | Configures a BGP neighbor with the IP address 2.2.2.2 and specifies the remote AS number as 100. |
PE4(config-router)#neighbor 2.2.2.2 update-source lo | Specifies that loopback interface (lo) is the source for BGP updates to the neighbor. |
PE4(config-router)#neighbor 2.2.2.2 advertisement-interval 0 | Sets the advertisement interval to 0, which means updates will be sent immediately. |
PE4(config-router)#address-family ipv4 unicast | Enters the configuration mode for the IPv4 unicast address family within the router configuration. |
PE4(config-router-af)#network 3.3.3.3/32 | Specifies that network 3.3.3.3 with a /32 subnet mask is part of the IPv4 unicast address family. |
PE4(config-router-af)#neighbor 2.2.2.2 activate | Activates the neighbor with the IP address 2.2.2.2 for the IPv4 unicast address family. |
PE4(config-router-af)#exit-address-family | Exits the configuration mode for the IPv4 unicast address family. |
PE4(config-router)#address-family l2vpn evpn | Enters the configuration mode for the L2VPN EVPN address family within the router configuration. |
PE4(config-router-af)#neighbor 2.2.2.32 activate | Activates the neighbor with the IP address 2.2.2.2 for the L2VPN EVPN address family. |
PE4(config-router-af)#exit-address-family | Exits the configuration mode for the L2VPN EVPN address family. |
PE4(config-router)#address-family ipv4 vrf L3VRF2 | Enters the configuration mode for the IPv4 address family within the VRF named L3VRF2. |
PE4(config-router-af)#redistribute connected | Configures the redistribution of directly connected routes into the IPv4 address family for the specified VRF. |
PE4(config-router-af)#exit-address-family | Exits the configuration mode for the IPv4 address family within the VRF L3VRF2. |
PE4(config-router-af)#address-family ipv6 vrf L3VRF2 | Enters the configuration mode for the IPv6 address family within the VRF named L3VRF2. |
PE4(config-router-af)#redistribute connected | Configures the redistribution of directly connected routes into the IPv6 address family for the specified VRF. |
PE4(config-router-af)#exit-address-family | Exits the configuration mode for the IPv6 address family within the VRF L3VRF2. |
Acronym | Description |
ECMP | Equal-Cost Multipath |
EVPN | Ethernet Virtual Private Netwrok |
MPLS | Multiprotocol Label Switching |
VxLAN | Virtual Extensible LAN |
SR | Segment Routing |
IRB | Integrated Routing |
OSPF | Open Shortest Path First |
ISIS | Intermediate System to Intermediate System |
Single Home VxLAN | This refers to a Virtual Extensible LAN (VxLAN) deployment where a single data center or network site is connected to a single external network (usually the internet) for connectivity. |
IRB | A networking feature that enables the integration of Layer 3 IP routing and Layer 2 MAC address bridging within the same interface, simplifying network management and resource utilization. |
OSPF | A dynamic and efficient link-state routing protocol used to determine the best path for data packets in an IP network. It is characterized by rapid convergence and adaptability, making it suitable for large and dynamic networks. |
ISIS | A routing protocol designed for scalability and stability in computer networks, commonly used in large Service Provider networks. It provides a robust framework for routing information exchange. |
Layer 3 Routing | Network routing operations at the Network Layer (Layer 3) of the OSI model, focusing on routing IP packets between different subnets or networks. |
Layer 2 Bridging | Network bridging operations at the Data Link Layer (Layer 2) of the OSI model, handling the forwarding of data frames based on MAC addresses within the same network segment. |
EVPN | Ethernet VPN, a technology that provides advanced and efficient methods for Layer 2 and Layer 3 services in Ethernet networks, often used in data centers and service provider environments. |