(config)#hostname CE1 | Configure host name |
(config)#bridge 1 protocol ieee vlan-bridge | Configure bridge as IEEE VLAN bridge |
(config)#interface xe6 | Enter interface mode |
(config-if)#switchport | Configure the interface as switchport |
(config-if)#exit | Exit interface mode |
(config)#interface xe7 | Enter interface mode |
(config-if)#switchport | Configure the interface as switchport |
(config-if)#bridge-group 1 | Associate bridge to an interface. |
(config-if)#switchport mode trunk | Configure port as a trunk. |
(config-if)#switchport trunk allowed vlan all | Allow all VLANs on the interface. |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
#con t | Enter configure mode |
(config)#hostname VTEP-1 | Configure host name |
(config)#hardware-profile filter vxlan enable | Enable hardware-profile filter for VxLAN |
(config)#hardware-profile statistics ingress-acl enable | Configure hardware profile statistics ingress-acl |
(config)#nvo vxlan enable | Enable VxLAN globally on this vtep |
(config)#mac vrf evpn_sh | Configure a new VRF |
(config-vrf)#rd 1.1.1.1:1 | Assign the Route Distinguisher value. |
(config-vrf)#route-target both 10:1 | Configure route target to import and export the routes |
(config-vrf)#exit | Exit vrf mode |
(config)#bridge 1 protocol ieee vlan-bridge | Configure bridge as IEEE VLAN bridge |
(config)#interface xe6 | Enter interface mode |
(config-if)#switchport | Configure the interface as switchport |
(config-if)#exit | Exit interface mode |
(config)#interface xe15 | Enter interface mode |
(config-if)#ip address 10.10.10.1/24 | Configure IP address on the interface |
(config-if)#exit | Exit interface mode |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 1.1.1.1/32 secondary | Configure IP address on the interface |
(config-if)#exit | Exit interface mode |
(config)#router ospf 100 | Enter router mode for OSPF |
(config-router)#bfd all-interfaces | Enable BFD for all-interface into OSPF |
(config-router)#network 1.1.1.1/32 area 0.0.0.0 | Add 1.1.1.1 network into area 0 |
(config-router)#network 10.10.10.0/24 area 0.0.0.0 | Add 10.10.10.0 network into area 0 |
(config)#router bgp 100 | Enter BGP router mode |
(config-router)#bgp router-id 1.1.1.1 | Assign BGP router ID |
(config-router)#neighbor 2.2.2.2 remote-as 100 | Specify a neighbor router with peer ip address and remote-as defined |
(config-router)#neighbor 2.2.2.2 update-source lo | Specify the neighbor to use loopback address as source |
(config-router)#address-family l2vpn evpn | Enter into l2vpn address family mode |
(config-router-af)#neighbor 2.2.2.2 activate | Activate the peer into address family mode |
(config-router-af)#exit-address-family | Exit l2vpn address family mode |
(config-router)#exit | Exit BGP router mode |
(config)#nvo vxlan vtep-ip-global 1.1.1.1 | Configure Source vtep-ip-global configuration |
(config)#nvo vxlan id 10 xconnect target-vxlan-id 20 | add a tenant and the type of VPN. This creates an ELAN with source and target identifier for ELINE XConnect |
(config-nvo)#vxlan host-reachability-protocol evpn-bgp evpn_sh | Set the host reachable protocol to Ethernet- |
(config-nvo)#nvo vxlan access-if port-vlan xe6 2 | Map the access port xe6 of this VTEP with vlan 2 |
(config-nvo-acc-if)#map vnid 10 | Map the VNID to access-port |
(config-nvo-acc-if)#commit | Commit the candidate configuration to the running configuration. |
(config)#hostname SPINE-1 | Configure hostname |
(config)#hardware-profile statistics ingress-acl enable | Configure hardware profile statistics ingress-acl |
(config)#interface xe8 | Enter interface mode |
(config-if)#ip address 20.20.20.1/24 | Configure IP address on the interface |
(config-if)#exit | Exit interface mode |
(config)#interface xe15 | Enter interface mode |
(config-if)#ip address 10.10.10.2/24 | Configure IP address on the interface |
(config-if)#exit | Exit interface mode |
(config)#router ospf 100 | Enter OSPF router mode |
(config-router)#bfd all-interfaces | Enable BFD for all-interface into OSPF |
(config-router)#network 10.10.10.0/24 area 0.0.0.0 | Add 10.10.10.0 network into area 0 |
(config-router)#network 20.20.20.0/24 area 0.0.0.0 | Add 20.20.20.0 network into area 0 |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
#con t | Enter configure mode |
(config)#hostname VTEP-2 | Configure hostname |
(config)#hardware-profile filter vxlan enable | Enable hardware-profile filter for VxLAN |
(config)#hardware-profile statistics ingress-acl enable | Configure hardware profile statistics ingress-acl |
(config)#nvo vxlan enable | Enable VxLAN globally on this vtep |
(config)#mac vrf evpn_sh | Configure a new VRF |
(config-vrf)#rd 2.2.2.2:1 | Assign the Route Distinguisher value. |
(config-vrf)#route-target both 10:1 | Configure route target to import and export the routes |
(config-vrf)#exit | Exit vrf mode |
(config)#bridge 1 protocol ieee vlan-bridge | Configure bridge as IEEE VLAN bridge |
(config)#interface xe6 | Enter interface mode |
(config-if)#switchport | Configure the interface as switchport |
(config-if)#exit | Exit interface mode |
(config)#interface xe8 | Enter interface mode |
(config-if)#ip address 20.20.20.2/24 | Configure IP address on the interface |
(config-if)#exit | Exit interface mode |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 2.2.2.2/32 secondary | Configure IP address on the interface |
(config-if)#exit | Exit interface mode |
(config)#router ospf 100 | Enter into router ospf mode |
(config-router)#bfd all-interfaces | Enable BFD for all-interface into OSPF |
(config-router)#network 2.2.2.2/32 area 0.0.0.0 | Add lo ip address 2.2.2.2 as network into area 0 |
(config-router)#network 20.20.20.0/24 area 0.0.0.0 | Add 20.20.20.0 network into area 0 |
(config-router)#exit | Exit router mode |
(config)#router bgp 100 | Enter BGP router mode |
(config-router)#bgp router-id 2.2.2.2 | Assign BGP router ID |
(config-router)#neighbor 1.1.1.1 remote-as 100 | Specify a neighbor router with peer ip address and remote-as defined |
(config-router)#neighbor 1.1.1.1 update-source lo | Specify the neighbor to use loopback address as source |
(config-router)#address-family l2vpn evpn | Enter into l2vpn address family mode |
(config-router-af)#neighbor 1.1.1.1 activate | Activate the peer into address family mode |
(config-router-af)#exit-address-family | Exit l2vpn address family mode |
(config-router)#exit | Exit BGP router mode |
(config)#nvo vxlan vtep-ip-global 2.2.2.2 | Configure Source vtep-ip-global configuration |
(config)#nvo vxlan id 20 xconnect target-vxlan-id 10 | add a tenant and the type of VPN. This creates an ELAN with source and target identifier for ELINE XConnect |
(config-nvo)#vxlan host-reachability-protocol evpn-bgp evpn_sh | Set the host reachable protocol to Ethernet- |
(config-nvo)#nvo vxlan access-if port-vlan xe6 2 | Map the access port xe6 of this VTEP with vlan 2 |
(config-nvo-acc-if)#map vnid 20 | Map the VNID to access-port |
(config-nvo-acc-if)#commit | Commit the candidate configuration to the running configuration. |
(config)#hostname CE1 | Configure host name |
(config)#bridge 1 protocol ieee vlan-bridge | Configure bridge as IEEE VLAN bridge |
(config)#interface xe6 | Enter interface mode |
(config-if)#switchport | Configure the interface as switchport |
(config-if)#exit | Exit interface mode |
(config)#interface xe7 | Enter interface mode |
(config-if)#switchport | Configure the interface as switchport |
(config-if)#bridge-group 1 | Associate bridge to an interface. |
(config-if)#switchport mode trunk | Configure port as a trunk. |
(config-if)#switchport trunk allowed vlan all | Allow all VLANs on the interface. |
(config-if)#commit | Commit the candidate configuration to the running configuration. |
#con t | Enter configure mode |
(config)#hostname VTEP1 | Configure hostname |
(config)#hardware-profile filter egress-ipv4 enable | Enable hardware filter for egress ipv4 |
(config)#hardware-profile filter vxlan enable | Enable hardware-profile filter for VxLAN |
(config)#hardware-profile filter vxlan-mh enable | Enable hardware-profile filter for multi-homed VxLAN |
(config)#hardware-profile statistics ingress-acl enable | Configure hardware profile statistics ingress-acl |
(config)#nvo vxlan enable | Enable VxLAN globally on this vtep |
(config)#mac vrf evpn_mh_eline | Configure a new VRF |
(config-vrf)#rd 1.1.1.1:2 | Assign the Route Distinguisher value. |
(config-vrf)#route-target both 2:2 | Configure route target to import and export the routes |
(config-vrf)#evpn vxlan multihoming enable | Enable evpn vxlan multihoming |
(config-vrf)#exit | Exit vrf mode |
(config)#interface po100 | Enter interface mode |
(config-if)#ip address 51.1.1.1/24 | Configure IP address on the interface |
(config-if)#isis circuit-type level-1 | Configure instance as level-1-only routing. |
(config-if)#ip router isis VxLAN | Enable IS-IS routing on the interface |
(config-if)#exit | Exit interface mode |
(config)#interface sa200 | Enter interface mode |
(config-if)#interface sa200.200 | Enter interface mode |
(config-if)#encapsulation dot1q 200 | Configure the encapsulation as dot1q matching vlan 200 |
(config-if)#ip address 61.1.1.1/24 | Configure IP address on the interface |
(config-if)#isis circuit-type level-1 | Configure instance as level-1-only routing. |
(config-if)#ip router isis VxLAN | Enable IS-IS routing on the interface |
(config-if)#interface ce0 | Enter interface mode |
(config-if)#channel-group 100 mode active | Add this interface to channel group 100 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#interface lo | Enter interface mode |
(config-if)#ip address 1.1.1.1/32 secondary | Configure IP address on the interface |
(config-if)#ip router isis VxLAN | Enable IS-IS routing on the interface |
(config-if)#interface xe4 | Enter interface mode |
(config-if)#switchport | Configure the interface as switchport |
(config-if)#interface xe8 | Enter interface mode |
(config-if)#static-channel-group 200 | Add this interface to channel group 200 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#interface xe9 | Enter interface mode |
(config-if)#static-channel-group 200 | Add this interface to channel group 200 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#interface xe10 | Enter interface mode |
(config-if)#static-channel-group 200 | Add this interface to channel group 200 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#interface xe16.100 | Enter interface mode |
(config-if)#encapsulation dot1q 100 | Configure the encapsulation as dot1q matching vlan 100 |
(config-if)#ip address 50.1.1.1/24 | Configure IP address on the interface |
(config-if)#isis circuit-type level-1 | Configure instance as level-1-only routing. |
(config-if)#ip router isis VxLAN | Enable IS-IS routing on the interface |
(config-if)#exit | Exit interface mode |
(config)#router isis VxLAN | Create an IS-IS routing instance |
(config-router)#is-type level-1 | Configure instance as level-1-only routing |
(config-router)#spf-interval-exp 0 0 | Set the minimum and maximum hold intervals between Shortest Path First (SPF) calculations |
(config-router)#metric-style wide | Configure the new style of metric type as wide. |
(config-router)#mpls traffic-eng level-1 | Enable MPLS-TE in is-type Level-1. |
(config-router)#dynamic-hostname | Configure a hostname to use for the Dynamic Hostname Exchange Mechanism and System-ID to hostname translation |
(config-router)#bfd all-interfaces | Enable BFD for all-interface on ISIS |
(config-router)#net 49.0000.0000.0001.00 | Set a Network Entity Title for this instance, specifying the area address and the system ID. |
(config-router)#exit | Exit router mode |
(config)#router bgp 100 | Enter BGP router mode |
(config-router)#bgp router-id 1.1.1.1 | Assign BGP router ID |
(config-router)#neighbor 3.3.3.3 remote-as 100 | Specify a neighbor router with peer ip address and remote-as defined |
(config-router)#neighbor 4.4.4.4 remote-as 100 | Specify a neighbor router with peer ip address and remote-as defined |
(config-router)#neighbor 3.3.3.3 update-source lo | Specify the neighbor to use loopback address as source |
(config-router)#neighbor 4.4.4.4 update-source lo | Specify the neighbor to use loopback address as source |
(config-router)#address-family l2vpn evpn | Enter into l2vpn address family mode |
(config-router-af)#neighbor 3.3.3.3 activate | Activate the peer into address family mode |
(config-router-af)#neighbor 4.4.4.4 activate | Activate the peer into address family mode |
(config-router-af)#exit-address-family | Exit l2vpn address family mode |
(config-router)#nvo vxlan vtep-ip-global 1.1.1.1 | Configure Source vtep-ip-global configuration |
(config)#nvo vxlan id 2 xconnect target-vxlan-id 1002 | add a tenant and the type of VPN. This creates an ELAN with source and target identifier for ELINE XConnect |
(config-nvo)#vxlan host-reachability-protocol evpn-bgp evpn_mh_eline | Set the host reachable protocol to Ethernet- |
(config-nvo)#nvo vxlan access-if port-vlan xe4 2 | Map the access port xe4 of this VTEP with vlan 2 |
(config-nvo-acc-if)#map vnid 2 | Map the VNID to access-port |
(config-nvo-acc-if)#nvo vxlan access-if port-vlan xe4 2000 | Map the access port xe4 of this VTEP with vlan 2000 |
(config-nvo-acc-if)#map vnid 2000 | Map the VNID to access-port |
(config-nvo-acc-if)#commit | Commit the candidate configuration to the running configuration. |
#con t | Enter configure mode |
(config)#hostname VTEP2 | Configure hostname |
(config)#hardware-profile filter egress-ipv4 enable | Enable hardware filter for egress ipv4 |
(config)#hardware-profile filter vxlan enable | Enable hardware-profile filter for VxLAN |
(config)#hardware-profile filter vxlan-mh enable | Enable hardware-profile filter for multi-homed VxLAN |
(config)#hardware-profile statistics ingress-acl enable | Configure hardware profile statistics ingress-acl |
(config)#nvo vxlan enable | Enable VxLAN globally on this vtep |
(config)#mac vrf evpn_mh_eline | Configure a new VRF |
(config-vrf)#rd 4.4.4.4:2 | Assign the Route Distinguisher value. |
(config-vrf)#route-target both 2:2 | Configure route target to import and export the routes |
(config-vrf)#evpn vxlan multihoming enable | Enable evpn vxlan multihoming |
(config)#vlan database | Enter VLAN configure mode |
(config-vlan)#vlan 200 bridge 1 | Configure a VLAN and add it to the bridge. |
(config-vlan)#interface po10 | Enter interface mode |
(config-if)#switchport | Configure the interface as switchport |
(config-if)#evpn multi-homed system-mac 0000.0000.1111 | Configure system mac as ESI value for the interface |
(config-if)#interface po200 | Enter interface mode |
(config-if)#ip address 63.1.1.2/24 | Configure IP address on the interface |
(config-if)#isis circuit-type level-1 | Configure instance as level-1-only routing. |
(config-if)#ip router isis VxLAN | Enable IS-IS routing on the interface |
(config-if)#interface ce49 | Enter interface mode |
(config-if)#switchport | Configure the interface as switchport |
(config-if)#bridge-group 1 | Associate bridge to an interface. |
(config-if)#switchport mode trunk | Configure port as a trunk. |
(config-if)#switchport trunk allowed vlan add 200 | Allow VLAN 200 on the interface. |
(config-if)#interface ce50 | Enter interface mode |
(config-if)#channel-group 200 mode active | Add this interface to channel group 200 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#interface ce53 | Enter interface mode |
(config-if)#channel-group 200 mode active | Add this interface to channel group 200 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#interface lo | Enter interface mode |
(config-if)#ip address 4.4.4.4/32 secondary | Configure IP address on the interface |
(config-if)#ip router isis VxLAN | Enable IS-IS routing on the interface |
(config-if)#interface vlan1.200 | Enter interface mode |
(config-if)#ip address 20.1.1.2/24 | Configure IP address on the interface |
(config-if)#isis circuit-type level-1 | Configure instance as level-1-only routing. |
(config-if)#ip router isis VxLAN | Enable IS-IS routing on the interface |
(config-if)#interface xe9 | Enter interface mode |
(config-if)#channel-group 10 mode active | Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode |
(config)#router isis VxLAN | Create an IS-IS routing instance |
(config-router)#is-type level-1 | Configure instance as level-1-only routing |
(config-router)#spf-interval-exp 0 0 | Set the minimum and maximum hold intervals between Shortest Path First (SPF) calculations |
(config-router)#metric-style wide | Configure the new style of metric type as wide. |
(config-router)#mpls traffic-eng level-1 | Enable MPLS-TE in is-type Level-1. |
(config-router)#dynamic-hostname | Configure a hostname to use for the Dynamic Hostname Exchange Mechanism and System-ID to hostname translation |
(config-router)#bfd all-interfaces | Enable BFD for all-interface on ISIS |
(config-router)#net 49.0000.0000.0004.00 | Set a Network Entity Title for this instance, specifying the area address and the system ID. |
(config-router)#exit | Exit isis interface mode |
(config-router)#router bgp 100 | Enter BGP router mode |
(config-router)#bgp router-id 4.4.4.4 | Assign BGP router ID |
(config-router)#neighbor 1.1.1.1 remote-as 100 | Specify a neighbor router with peer ip address and remote-as defined |
(config-router)#neighbor 3.3.3.3 remote-as 100 | Specify a neighbor router with peer ip address and remote-as defined |
(config-router)#neighbor 1.1.1.1 update-source lo | Specify the neighbor to use loopback address as source |
(config-router)#neighbor 3.3.3.3 update-source lo | Specify the neighbor to use loopback address as source |
(config-router)#address-family l2vpn evpn | Enter into l2vpn address family mode |
(config-router-af)#neighbor 1.1.1.1 activate | Activate the peer into address family mode |
(config-router-af)#neighbor 3.3.3.3 activate | Activate the peer into address family mode |
(config-router-af)#exit-address-family | Exit l2vpn address family mode |
(config-router)#nvo vxlan vtep-ip-global 4.4.4.4 | Configure Source vtep-ip-global configuration |
(config)#nvo vxlan id 3000 xconnect target-vxlan-id 2000 | add a tenant and the type of VPN. This creates an ELAN with source and target identifier for ELINE XConnect |
(config-nvo)#vxlan host-reachability-protocol evpn-bgp evpn_mh_eline | Set the host reachable protocol to Ethernet- |
(config-nvo)#nvo vxlan access-if port-vlan po10 2000 | Map the access port po10 of this VTEP with vlan 2000 |
(config-nvo-acc-if)#map vnid 3000 | Map the VNID to access-port |
(config-nvo-acc-if)#commit | Commit the candidate configuration to the running configuration. |
#con t | Enter configure mode |
(config)#hostname VTEP3 | Configure host name |
(config)#hardware-profile filter egress-ipv4 enable | Enable hardware filter for egress ipv4 |
(config)#hardware-profile filter vxlan enable | Enable hardware-profile filter for VxLAN |
(config)#hardware-profile filter vxlan-mh enable | Enable hardware-profile filter for multi-homed VxLAN |
(config)#hardware-profile statistics ingress-acl enable | Configure hardware profile statistics ingress-acl |
(config)#nvo vxlan enable | Enable VxLAN globally on this vtep |
(config)#mac vrf evpn_mh_eline | Configure a new VRF |
(config-vrf)#rd 3.3.3.3:2 | Assign the Route Distinguisher value. |
(config-vrf)#route-target both 2:2 | Configure route target to import and export the routes |
(config-vrf)#evpn vxlan multihoming enable | Enable evpn vxlan multihoming |
(config)#bridge 1 protocol ieee vlan-bridge | Configure bridge as IEEE VLAN bridge |
(config)#vlan database | Enter VLAN configure mode |
(config-vlan)#vlan 300 bridge 1 | Configure a VLAN and add it to the bridge. |
(config-vlan)#interface po10 | Enter interface mode |
(config-if)#switchport | Configure the interface as switchport |
(config-if)#evpn multi-homed system-mac 0000.0000.1111 | Configure system mac as ESI value for the interface |
(config-if)#interface po100 | Enter interface mode |
(config-if)#ip address 51.1.1.2/24 | Configure IP address on the interface |
(config-if)#isis circuit-type level-1 | Configure instance as level-1-only routing. |
(config-if)#ip router isis VxLAN | Enable IS-IS routing on the interface |
(config-if)#interface po200 | Enter interface mode |
(config-if)#ip address 63.1.1.1/24 | Configure IP address on the interface |
(config-if)#isis circuit-type level-1 | Configure instance as level-1-only routing. |
(config-if)#ip router isis VxLAN | Enable IS-IS routing on the interface |
(config-if)#interface ce49 | Enter interface mode |
(config-if)#channel-group 100 mode active | Add this interface to channel group 100 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#interface ce50 | Enter interface mode |
(config-if)#channel-group 200 mode active | Add this interface to channel group 200 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#interface ce53 | Enter interface mode |
(config-if)#channel-group 200 mode active | Add this interface to channel group 200 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#interface lo | Enter interface mode |
(config-if)#ip address 3.3.3.3/32 secondary | Configure IP address on the interface |
(config-if)#ip router isis VxLAN | Enable IS-IS routing on the interface |
(config-if)#interface vlan1.300 | Enter interface mode |
(config-if)#ip address 40.1.1.2/24 | Configure IP address on the interface |
(config-if)#isis circuit-type level-1 | Configure instance as level-1-only routing. |
(config-if)#ip router isis VxLAN | Enable IS-IS routing on the interface |
(config-if)#interface xe2 | Enter interface mode |
(config-if)#ip address 62.1.1.1/24 | Configure IP address on the interface |
(config-if)#isis circuit-type level-1 | Configure instance as level-1-only routing. |
(config-if)#ip router isis VxLAN | Enable IS-IS routing on the interface |
(config-if)#interface xe3 | Enter interface mode |
(config-if)#channel-group 10 mode active | Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#interface xe16.100 | Enter interface mode |
(config-if)#encapsulation dot1q 100 | Configure the encapsulation as dot1q matching vlan 100 |
(config-if)#ip address 50.1.1.2/24 | Configure IP address on the interface |
(config-if)#isis circuit-type level-1 | Configure instance as level-1-only routing. |
(config-if)#ip router isis VxLAN | Enable IS-IS routing on the interface |
(config-if)#exit | Exit interface mode |
(config)#router isis VxLAN | Create an IS-IS routing instance |
(config-router)#is-type level-1 | Configure instance as level-1-only routing |
(config-router)#spf-interval-exp 0 0 | Set the minimum and maximum hold intervals between Shortest Path First (SPF) calculations |
(config-router)#metric-style wide | Configure the new style of metric type as wide. |
(config-router)#mpls traffic-eng level-1 | Enable MPLS-TE in is-type Level-1. |
(config-router)#dynamic-hostname | Configure a host name to use for the Dynamic Hostname Exchange Mechanism and System-ID to host name translation |
(config-router)#bfd all-interfaces | Enable BFD for all-interface on ISIS |
(config-router)#net 49.0000.0000.0006.00 | Set a Network Entity Title for this instance, specifying the area address and the system ID. |
(config-router)#exit | Exit isis router mode |
(config)#router bgp 100 | Enter BGP router mode |
(config-router)#bgp router-id 3.3.3.3 | Assign BGP router ID |
(config-router)#neighbor 1.1.1.1 remote-as 100 | Specify a neighbor router with peer ip address and remote-as defined |
(config-router)#neighbor 4.4.4.4 remote-as 100 | Specify a neighbor router with peer ip address and remote-as defined |
(config-router)#neighbor 1.1.1.1 update-source lo | Specify the neighbor to use loopback address as source |
(config-router)#neighbor 4.4.4.4 update-source lo | Specify the neighbor to use loopback address as source |
(config-router)#address-family l2vpn evpn | Enter into l2vpn address family mode |
(config-router-af)#neighbor 1.1.1.1 activate | Activate the peer into address family mode |
(config-router-af)#neighbor 4.4.4.4 activate | Activate the peer into address family mode |
(config-router-af)#exit-address-family | Exit l2vpn address family mode |
(config-router)#nvo vxlan vtep-ip-global 3.3.3.3 | Configure Source vtep-ip-global configuration |
(config)#nvo vxlan id 3000 xconnect target-vxlan-id 2000 | add a tenant and the type of VPN. This creates an ELAN with source and target identifier for ELINE XConnect |
(config-nvo)#vxlan host-reachability-protocol evpn-bgp evpn_mh_eline | Set the host reachable protocol to Ethernet- |
(config-nvo)#nvo vxlan access-if port-vlan po10 2000 | Map the access port po10 of this VTEP with vlan 2000 |
(config-nvo-acc-if)#map vnid 3000 | Map the VNID to access-port |
(config-nvo-acc-if)#commit | Commit the candidate configuration to the running configuration. |
#con t | Enter configure mode |
(config)#hostname SPINE | Configure host name |
(config)#hardware-profile statistics ingress-acl enable | Configure hardware profile statistics ingress-acl |
(config)#bridge 1 protocol ieee vlan-bridge | Configure bridge as IEEE VLAN bridge |
(config)#vlan database | Enter VLAN configure mode |
(config-vlan)#vlan 200 bridge 1 | Configure a VLAN and add it to the bridge. |
(config-if)#interface sa200 | Enter interface mode |
(config-if)#interface sa200.200 | Enter interface mode |
(config-if)#encapsulation dot1q 200 | Configure the encapsulation as dot1q matching vlan 200 |
(config-if)#ip address 61.1.1.2/24 | Configure IP address on the interface |
(config-if)#isis circuit-type level-1 | Configure instance as level-1-only routing. |
(config-if)#ip router isis VxLAN | Enable IS-IS routing on the interface |
(config-if)#interface ce0 | Enter interface mode |
(config-if)#switchport | Configure the interface as switchport |
(config-if)#bridge-group 1 | Associate bridge to an interface. |
(config-if)#switchport mode trunk | Configure port as a trunk. |
(config-if)#switchport trunk allowed vlan add 200 | Allow VLAN 200 on the interface. |
(config-if)#interface lo | Enter interface mode |
(config-if)#ip address 11.11.11.11/32 secondary | Configure IP address on the interface |
(config-if)#ip router isis VxLAN | Enable IS-IS routing on the interface |
(config-if)#interface vlan1.200 | Enter interface mode |
(config-if)#ip address 20.1.1.1/24 | Configure IP address on the interface |
(config-if)#isis circuit-type level-1 | Configure instance as level-1-only routing. |
(config-if)#ip router isis VxLAN | Enable IS-IS routing on the interface |
(config-if)#interface xe2 | Enter interface mode |
(config-if)#ip address 62.1.1.2/24 | Configure IP address on the interface |
(config-if)#isis circuit-type level-1 | Configure instance as level-1-only routing. |
(config-if)#ip router isis VxLAN | Enable IS-IS routing on the interface |
(config-if)#interface xe8 | Enter interface mode |
(config-if)#static-channel-group 200 | Add this interface to channel group 200 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#interface xe9 | Enter interface mode |
(config-if)#static-channel-group 200 | Add this interface to channel group 200 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#interface xe10 | Enter interface mode |
(config-if)#static-channel-group 200 | Add this interface to channel group 200 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#exit | Exit interface mode |
(config-if)#router isis VxLAN | Create an IS-IS routing instance |
(config-router)#is-type level-1 | Configure instance as level-1-only routing |
(config-router)#spf-interval-exp 0 0 | Set the minimum and maximum hold intervals between Shortest Path First (SPF) calculations |
(config-router)#metric-style wide | Configure the new style of metric type as wide. |
(config-router)#mpls traffic-eng level-1 | Enable MPLS-TE in is-type Level-1. |
(config-router)#dynamic-hostname | Configure a host name to use for the Dynamic Hostname Exchange Mechanism and System-ID to host name translation |
(config-router)#bfd all-interfaces | Enable BFD for all-interface on ISIS |
(config-router)#net 49.0000.0000.0003.00 | Set a Network Entity Title for this instance, specifying the area address and the system ID. |
(config-router)#exit | Exit isis interface mode |
(config)#router bgp 100 | Enter BGP router mode |
(config-router)#neighbor 1.1.1.1 remote-as 100 | Assign BGP router ID |
(config-router)#neighbor 5.5.5.5 remote-as 100 | Specify a neighbor router with peer ip address and remote-as defined |
(config-router)#address-family l2vpn evpn | Enter into l2vpn address family mode |
(config-router-af)#neighbor 1.1.1.1 activate | Activate the peer into address family mode |
(config-router-af)#neighbor 1.1.1.1 route-reflector-client | Configure this node as the route reflector with the mentioned peer as its client |
(config-router-af)#neighbor 5.5.5.5 activate | Activate the peer into address family mode |
(config-router-af)#neighbor 5.5.5.5 route-reflector-client | Configure this node as the route reflector with the mentioned peer as its client |
(config-router-af)#exit-address-family | Exit l2vpn address family mode |
(config-router)#commit | Commit the candidate configuration to the running configuration. |
#con t | Enter configure mode |
(config)#hostname CE3-MH | Configure host name |
(config)#hardware-profile statistics ingress-acl enable | Configure hardware profile statistics ingress-acl |
(config)#interface po10 | Enter interface mode |
(config-if)#switchport | Configure the interface as switchport |
(config-if)#interface po10.100 switchport | Enter interface mode |
(config-if)#encapsulation default | Configure the encapsulation as default |
(config-if)#interface ce0 | Enter interface mode |
(config-if)#interface ce0.100 switchport | Enter interface mode |
(config-if)#encapsulation default | Configure the encapsulation as default |
(config-if)#interface xe1 | Enter interface mode |
(config-if)#channel-group 10 mode active | Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#interface xe9 | Enter interface mode |
(config-if)#channel-group 10 mode active | Add this interface to channel group 10 and enable link aggregation so that it can be selected for aggregation by the local system. |
(config-if)#cross-connect MH-CE3 | Create cross-connect with name MH-CE3 |
(config-xc)#interface po10.100 | Attach interface po10.100 |
(config-xc)#interface ce0.100 | Attach interface ce0.100 |
(config-xc)#commit | Commit the candidate configuration to the running configuration. |