VTEP1#configure terminal | Enter configuration terminal |
VTEP1(config)#hostname VTEP1 | Configure hostname |
VTEP1(config)#mac vrf vrf1 | Configure mac vrf vrf1 |
VTEP1(config-vrf)# rd 1.1.1.1:11 | Configure RD for vrf1 |
VTEP1(config-vrf)# route-target both 10.10.10.10:100 | Configure RT for vrf1 |
VTEP1(config-vrf)#mac vrf vrf2 | Configure mac vrf vrf2 |
VTEP1(config-vrf)# rd 1.1.1.1:12 | Configure RD for vrf2 |
VTEP1(config-vrf)# route-target both 10.10.10.10:102 | Configure RT for vrf2 |
VTEP1(config-vrf)#bfd interval 3 minrx 3 multiplier 3 | Configure bfd interval globally |
VTEP1(config)#hardware-profile filter egress-ipv4 enable | Enable hardware filter for egress ipv4 |
VTEP1(config)#hardware-profile filter vxlan enable | Enable vxlan in hardware |
VTEP1(config)# hardware-profile filter vxlan-mh enable | Enable vxlan-mh in hardware |
VTEP1(config)#hardware-profile statistics ac-lif enable | Enable ac-lif for enabling vxlan counters |
VTEP1(config)#evpn vxlan multihoming enable | Enable evpn vxlan multihoming |
VTEP1(config)#nvo vxlan enable | Enable vxlan |
VTEP1(config)#qos enable | Enable qos |
VTEP1(config)#qos statistics | Enable qos statistics |
VTEP1(config)#bridge 1 protocol ieee vlan-bridge | Configure IEEE vlan bridge |
VTEP1(config)#no bridge 1 spanning-tree enable | Disable spanning tree in bridge 1 globally |
VTEP1(config)#no igmp snooping | Disable igmp snooping messages globally |
VTEP1(config)#vlan database | Enter into the vlan database |
VTEP1(config-vlan)# vlan 10-200 bridge 1 state enable | Configure vlan 10-200 and associate with bridge 1 |
VTEP1(config-vlan)# vlan 4000 bridge 1 state enable | Configure vlan 4000 and associate with bridge 1 |
VTEP1(config-vlan)#interface po1 | Enter interface mode |
VTEP1(config-if)# switchport | Set the interface as Layer2 port |
VTEP1(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
VTEP1(config-if)# evpn multi-homed system-mac aa22.3344.5566 | Configure evpn system-mac |
VTEP1(config-if)#interface lo | Enter lo interface mode |
VTEP1(config-if)# ip address 1.1.1.1/32 secondary | Assign loopback ip |
VTEP1(config-if)#interface vlan1.10 | Specify interface vlan1.10 to be configured. |
VTEP1(config-if)# ip address 12.1.1.1/24 | Assign ip address |
VTEP1(config-if)# ip ospf cost 1 | Change ospf cost of the link |
VTEP1(config-if)#interface vlan1.20 | Specify interface vlan1.20 to be configured. |
VTEP1(config-if)# ip address 13.1.1.1/24 | Assign ip address |
VTEP1(config-if)# ip ospf cost 1 | Change ospf cost of the link |
VTEP1(config-if)#interface vlan1.30 | Specify interface vlan1.30 to be configured. |
VTEP1(config-if)# ip address 14.1.1.1/24 | Assign ip address |
VTEP1(config-if)# ip ospf cost 1 | Change ospf cost of the link |
VTEP1(config-if)#interface xe1 | Enter interface mode |
VTEP1(config-if)# switchport | Set the interface as Layer2 port |
VTEP1(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
VTEP1(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
VTEP1(config-if)# switchport trunk allowed vlan add 20,29 | Enable VLAN's allowed on this interface. |
VTEP1(config-if)# switchport trunk native vlan 29 | Configure native vlan |
VTEP1(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
VTEP1(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
VTEP1(config-if)#interface xe5 | Enter interface mode |
VTEP1(config-if)# switchport | Set the interface as Layer2 port |
VTEP1(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
VTEP1(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
VTEP1(config-if)# switchport trunk allowed vlan add 10,19 | Enable VLAN's allowed on this interface. |
VTEP1(config-if)# switchport trunk native vlan 19 | Configure native vlan |
VTEP1(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
VTEP1(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
VTEP1(config-if)#interface xe7 | Enter interface mode |
VTEP1(config-if)# switchport | Set the interface as Layer2 port |
VTEP1(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
VTEP1(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
VTEP1(config-if)# switchport trunk allowed vlan add 30,39 | Enable VLAN's allowed on this interface. |
VTEP1(config-if)# switchport trunk native vlan 39 | Configure native vlan |
VTEP1(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
VTEP1(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
VTEP1(config-if)#interface xe41 | Enter interface mode |
VTEP1(config-if)# channel-group 1 mode active | Map this interface to po1 |
VTEP1(config-if)#interface xe42 | Enter interface mode |
VTEP1(config-if)# channel-group 1 mode active | Map this interface to po1 |
VTEP1(config-if)#interface xe46 | Enter interface mode |
VTEP1(config-if)# switchport | Map this interface to po1 |
VTEP1(config-if)#router ospf 1 | Enter ospf configuration mode |
VTEP1(config-router)# ospf router-id 1.1.1.1 | Configure ospf router id |
VTEP1(config-router)# bfd all-interfaces | Enable bfd in all ospf interfaces |
VTEP1(config-router)# network 1.1.1.1/32 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
VTEP1(config-router)# network 12.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
VTEP1(config-router)# network 13.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
VTEP1(config-router)# network 14.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
VTEP1(config-router)#router bgp 100 | Enter Router BGP mode and define the AS number 100. |
VTEP1(config-router)# address-family ipv4 unicast | Enter address-family ipv4 unicast mode |
VTEP1(config-router)# network 1.1.1.1/32 | Add the lo network to bgp route |
VTEP1(config-router-af)# neighbor 2.2.2.2 activate | Activate neigbors |
VTEP1(config-router-af)# neighbor 6.6.6.6 activate | Activate neigbors |
VTEP1(config-router-af)#exit-address-family | Exit address-family mode. |
VTEP1(config-router)# neighbor 2.2.2.2 remote-as 100 | Configure bgp remote-as 100 with neighbor IP |
VTEP1(config-router)# neighbor 2.2.2.2 update-source lo | Define BGP neighbors, to update the source routes with lo |
(config-router)#neighbor 2.2.2.2 advertisement-interval 0 | Configure advertisement-interval as 0 for fast convergence for VTEP2 |
VTEP1(config-router)# neighbor 6.6.6.6 remote-as 100 | Configure bgp remote-as 100 with neighbor IP |
VTEP1(config-router)# neighbor 6.6.6.6 update-source lo | Define BGP neighbors, to update the source routes with lo |
(config-router)#neighbor 6.6.6.6 advertisement-interval 0 | Configure advertisement-interval as 0 for fast convergence for VTEP3 |
VTEP1(config-router)# address-family l2vpn evpn | Enter in to bgp l2vpn evpn address-family |
VTEP1(config-router-af)# neighbor 2.2.2.2 activate | Activate neigbors |
VTEP1(config-router-af)# neighbor 6.6.6.6 activate | Activate neigbors |
VTEP1(config-router-af)# exit-address-family | Exit from bgp l2vpn evpn address-family |
VTEP1(config-router)#nvo vxlan vtep-ip-global 1.1.1.1 | Configure vxlan global ip |
VTEP1(config)#nvo vxlan id 1 ingress-replication inner-vid-disabled | Create vnid 1 |
VTEP1(config-nvo)# vxlan host-reachability-protocol evpn-bgp vrf1 | Associate vnid with evpn and vrf1 |
VTEP1(config-nvo)#nvo vxlan id 1000 ingress-replication inner-vid-disabled | Create vnid 1000 |
VTEP1(config-nvo)# vxlan host-reachability-protocol evpn-bgp vrf2 | Associate vnid with evpn and vrf2 |
VTEP1(config-nvo-acc-if)#nvo vxlan access-if port-vlan po1 2000 | Create vxlan access port port-vlan |
VTEP1(config-nvo-acc-if)# no shutdown | Unshut the access interface |
VTEP1(config-nvo-acc-if)# map vnid 1000 | Map the vnid to access-if |
VTEP1(config-nvo)#nvo vxlan access-if port xe46 | Create vxlan access port |
VTEP1(config-nvo-acc-if)# no shutdown | Unshut the access interface |
VTEP1(config-nvo-acc-if)# map vnid 1 | Map the vnid to access-if |
VTEP1(config-nvo-acc-if)#nvo vxlan access-if port-vlan po1 1000 | Create vxlan access port port-vlan |
VTEP1(config-nvo-acc-if)# no shutdown | Unshut the access interface |
VTEP1(config-nvo-acc-if)# map vnid 1 | Map the vnid to access-if |
VTEP1(config-nvo-acc-if)# mac 0000.1111.1111 ip 100.1.1.100 | Configure static mac ip |
VTEP1(config-nvo-acc-if)# mac 0000.1111.1112 | Configure static mac |
VTEP1(config-nvo-acc-if)# mac 0000.1111.1113 | Configure static mac |
VTEP1(config-nvo-acc-if)# mac 0000.1111.1114 | Configure static mac |
VTEP1(config-nvo-acc-if)# mac 0000.1111.1115 | Configure static mac |
VTEP1(config-nvo-acc-if)# commit | Commit the candidate configuration to the running configuration |
VTEP2#configure terminal | Enter configuration terminal |
VTEP2(config)#hostname VTEP2 | Configure hostname |
VTEP2(config)#mac vrf vrf1 | Configure mac vrf vrf1 |
VTEP2(config-vrf)# rd 2.2.2.2:11 | Configure RD for vrf1 |
VTEP2(config-vrf)# route-target both 10.10.10.10:100 | Configure RT for vrf1 |
VTEP2(config-vrf)#mac vrf vrf2 | Configure mac vrf vrf2 |
VTEP2(config-vrf)# rd 2.2.2.2:12 | Configure RD for vrf2 |
VTEP2(config-vrf)# route-target both 10.10.10.10:102 | Configure RT for vrf2 |
VTEP2(config)#hardware-profile filter egress-ipv4 enable | Enable hardware filter for egress ipv4 |
VTEP2(config)#hardware-profile filter vxlan enable | Enable vxlan in hardware |
VTEP2(config)#nvo vxlan enable | Enable vxlan |
VTEP2(config)# hardware-profile filter vxlan-mh enable | Enable vxlan-mh in hardware |
VTEP2(config)#evpn vxlan multihoming enable | Enable evpn vxlan multihoming |
VTEP2(config)#hardware-profile statistics ac-lif enable | Enable ac-lif for enabling vxlan counters |
VTEP2(config)#qos enable | Enable qos |
VTEP2(config)#qos statistics | Enable qos statistics |
VTEP2(config)#bridge 1 protocol ieee vlan-bridge | Configure IEEE vlan bridge |
VTEP2(config)#no bridge 1 spanning-tree enable | Disable spanning tree in bridge 1 globally |
VTEP2(config)#vlan database | Enter into the vlan database |
VTEP2(config-vlan)# vlan 10-200 bridge 1 state enable | Configure vlan 10-200 and associate with bridge 1 |
VTEP2(config-vlan)#interface po1 | Enter interface mode |
VTEP2(config-if)# switchport | Set the interface as Layer2 port |
VTEP2(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
VTEP2(config-if)# evpn multi-homed system-mac aa22.3344.5566 | Configure evpn system-mac |
VTEP2(config-if)#interface lo | Enter interface mode |
VTEP2(config-if)# ip address 2.2.2.2/32 secondary | Configure loopback ip |
VTEP2(config-if)#interface vlan1.10 | Specify interface vlan1.10 to be configured. |
VTEP2(config-if)# ip address 12.1.1.2/24 | Assign ip address |
VTEP2(config-if)#interface vlan1.40 | Specify interface vlan1.40 to be configured. |
VTEP2(config-if)# ip address 23.1.1.1/24 | Assign ip address |
VTEP2(config-if)# ip ospf cost 1 | Change ospf cost of the link |
VTEP2(config-if)#interface vlan1.50 | Specify interface vlan1.50 to be configured. |
VTEP2(config-if)# ip address 24.1.1.1/24 | Assign ip address |
VTEP2(config-if)#interface ce53 | Enter interface mode |
VTEP2(config-if)# switchport | Set the interface as Layer2 port |
VTEP2(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
VTEP2(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
VTEP2(config-if)# switchport trunk allowed vlan add 40,49 | Enable VLAN's allowed on this interface. |
VTEP2(config-if)# switchport trunk native vlan 49 | Configure native vlan |
VTEP2(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
VTEP2(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
VTEP2(config-if)#interface xe5 | Enter interface mode |
VTEP2(config-if)# switchport | Set the interface as Layer2 port |
VTEP2(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
VTEP2(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode |
VTEP2(config-if)# switchport trunk allowed vlan add 10,19 | Enable VLAN's allowed on this interface |
VTEP2(config-if)# switchport trunk native vlan 19 | Configure native vlan |
VTEP2(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
VTEP2(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
VTEP2(config-if)#interface xe9 | Enter interface mode |
VTEP2(config-if)# switchport | Set the interface as Layer2 port |
VTEP2(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
VTEP2(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
VTEP2(config-if)# switchport trunk allowed vlan add 50,59 | Enable VLAN's allowed on this interface. |
VTEP2(config-if)# switchport trunk native vlan 59 | Configure native vlan |
VTEP2(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
VTEP2(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
VTEP2(config-if)#interface xe41 | Enter interface mode |
VTEP2(config-if)# channel-group 1 mode active | Map the interface to po1 |
VTEP2(config-if)#interface xe42 | Enter interface mode |
VTEP2(config-if)# channel-group 1 mode active | Map the interface to po1 |
VTEP2(config-if)#interface xe47 | Enter interface mode |
VTEP2(config-if)# switchport | Set the interface as Layer2 port |
VTEP2(config-if)#router ospf 1 | Enter ospf configuration mode |
VTEP2(config-router)# ospf router-id 2.2.2.2 | Configure ospf router id |
VTEP2(config-router)# network 2.2.2.2/32 area 0.0.0.0 | Enable bfd in all ospf interfaces |
VTEP2(config-router)# network 12.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
VTEP2(config-router)# network 23.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
VTEP2(config-router)# network 24.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
VTEP2(config-router)# network 25.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
VTEP2(config-router)#router bgp 100 | Enter Router BGP mode and define the AS number 100. |
VTEP2(config-router)# address-family ipv4 unicast | Enter address-family ipv4 unicast mode |
VTEP2(config-router)# network 2.2.2.2/32 | Add the lo network to bgp route |
VTEP2(config-router-af)# neighbor 1.1.1.1 activate | Activate neigbors |
VTEP2(config-router-af)# neighbor 6.6.6.6 activate | Activate neigbors |
VTEP2(config-router-af)#exit-address-family | Exit address-family mode. |
VTEP2(config-router)# neighbor 1.1.1.1 remote-as 100 | Configure bgp remote-as 100 with neighbor IP |
VTEP2(config-router)#neighbor 1.1.1.1 advertisement-interval 0 | Configure advertisement-interval as 0 for fast convergence for VTEP1 |
VTEP2(config-router)# neighbor 1.1.1.1 update-source lo | Define BGP neighbors, to update the source routes with lo |
VTEP2(config-router)# neighbor 6.6.6.6 remote-as 100 | Configure bgp remote-as 100 with neighbor IP |
VTEP2(config-router)#neighbor 6.6.6.6 advertisement-interval 0 | Configure advertisement-interval as 0 for fast convergence for VTEP3 |
VTEP2(config-router)# neighbor 6.6.6.6 update-source lo | Define BGP neighbors, to update the source routes with lo |
VTEP2(config-router)# address-family l2vpn evpn | Enter in to bgp l2vpn evpn address-family |
VTEP2(config-router-af)# neighbor 1.1.1.1 activate | Activate neigbors |
VTEP2(config-router-af)# neighbor 6.6.6.6 activate | Activate neigbors |
VTEP2(config-router-af)# exit-address-family | Exit from bgp l2vpn evpn address-family |
VTEP2(config-router)#nvo vxlan vtep-ip-global 2.2.2.2 | Configure vxlan global ip |
VTEP2(config)#nvo vxlan id 1 ingress-replication inner-vid-disabled | Create vnid 1 |
VTEP2(config-nvo)# vxlan host-reachability-protocol evpn-bgp vrf1 | Associate vnid with evpn and vrf1 |
VTEP2(config-nvo)#nvo vxlan id 1000 ingress-replication inner-vid-disabled | Create vnid 1000 |
VTEP2(config-nvo)# vxlan host-reachability-protocol evpn-bgp vrf2 | Associate vnid with evpn and vrf2 |
VTEP2(config-nvo)#nvo vxlan access-if port xe47 | Create vxlan access port |
VTEP2(config-nvo-acc-if)# map vnid 1 | Map the vnid to access-if |
VTEP2(config-nvo-acc-if)#nvo vxlan access-if port-vlan po1 2001 | Create vxlan access port |
VTEP2(config-nvo-acc-if)# map vnid 1000 | Map the vnid to access-if |
VTEP2(config-nvo-acc-if)#nvo vxlan access-if port-vlan po1 2000 | Create vxlan access port |
VTEP2(config-nvo-acc-if)# map vnid 1000 | Map the vnid to access-if |
VTEP2(config-nvo-acc-if)# commit | Commit the candidate configuration to the running configuration |
P1#configure terminal | Enter configuration terminal |
P1(config)#hostname P1 | Configure hostname |
P1(config)#bfd interval 3 minrx 3 multiplier 3 | Configure bfd interval globally |
P1(config)#qos enable | Enable qos |
P1(config)#bridge 1 protocol ieee vlan-bridge | Configure IEEE vlan bridge |
P1(config)#no bridge 1 spanning-tree enable | Disable spanning tree in bridge 1 globally |
P1(config)#no igmp snooping | Disable igmp snooping messages globally |
P1(config)#vlan database | Enter into the vlan database |
P1(config-vlan)# vlan 10-200 bridge 1 state enable | Configure vlan 10-200 and associate with bridge 1 |
P1(config-if)#interface lo | Enter loopback interface mode |
P1(config-if)# ip address 3.3.3.3/32 secondary | Assign loopback ip |
P1(config-if)#interface vlan1.20 | Specify interface vlan1.20 to be configured. |
P1(config-if)# ip address 13.1.1.2/24 | Assign ip address |
P1(config-if)# ip ospf cost 1 | Change ospf cost of the link |
P1(config-if)#interface vlan1.40 | Specify interface vlan1.40 to be configured. |
P1(config-if)# ip address 23.1.1.2/24 | Assign ip address |
P1(config-if)#interface vlan1.60 | Specify interface vlan1.60 to be configured. |
P1(config-if)# ip address 35.1.1.1/24 | Assign ip address |
P1(config-if)# ip ospf cost 1 | Change ospf cost of the link |
P1(config-if)#interface vlan1.100 | Specify interface vlan1.100 to be configured. |
P1(config-if)# ip address 34.1.1.1/24 | Assign ip address |
P1(config-if)# ip ospf cost 1 | Change ospf cost of the link |
P1(config-vlan)#interface ce49 | Enter interface mode |
P1(config-if)# switchport | Set the interface as Layer2 port |
P1(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
P1(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
P1(config-if)# switchport trunk allowed vlan add 40,49 | Enable VLAN's allowed on this interface. |
P1(config-if)# switchport trunk native vlan 49 | Configure native vlan |
P1(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
P1(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
P1(config-if)#interface xe1 | Enter interface mode |
P1(config-if)# switchport | Set the interface as Layer2 port |
P1(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
P1(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
P1(config-if)# switchport trunk allowed vlan add 20,29 | Enable VLAN's allowed on this interface. |
P1(config-if)# switchport trunk native vlan 29 | Configure native vlan |
P1(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
P1(config-if)# mtu 1600 | Change the interface mtu value |
P1(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
P1(config-if)#interface xe10 | Enter interface mode |
P1(config-if)# switchport | Set the interface as Layer2 port |
P1(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
P1(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
P1(config-if)# switchport trunk allowed vlan add 60,69 | Enable VLAN's allowed on this interface. |
P1(config-if)# switchport trunk native vlan 69 | Configure native vlan |
P1(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
P1(config-if)# mtu 1600 | Change the interface mtu value |
P1(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
P1(config-if)#interface xe25 | Enter interface mode |
P1(config-if)# switchport | Set the interface as Layer2 port |
P1(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
P1(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
P1(config-if)# switchport trunk allowed vlan add 100,109 | Enable VLAN's allowed on this interface. |
P1(config-if)# switchport trunk native vlan 109 | Configure native vlan |
P1(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
P1(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
P1(config-if)#router ospf 1 | Enter ospf configuration mode |
P1(config-router)# ospf router-id 3.3.3.3 | Configure ospf router id |
P1(config-router)# bfd all-interfaces | Enable bfd in all ospf interfaces |
P1(config-router)# network 3.3.3.3/32 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
P1(config-router)# network 10.10.10.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
P1(config-router)# network 13.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
P1(config-router)# network 23.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
P1(config-router)# network 34.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
P1(config-router)# network 35.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
P1(config-router)# commit | Commit the candidate configuration to the running configuration |
P2#configure terminal | Enter configuration terminal |
P2(config)#bfd interval 3 minrx 3 multiplier 3 | Configure bfd interval globally |
P2(config)#qos enable | Enable qos |
P2(config)#hostname P2 | Configure hostname |
P2(config)#bridge 1 protocol ieee vlan-bridge | Configure IEEE vlan bridge |
P2(config)#no bridge 1 spanning-tree enable | Disable spanning tree in bridge 1 globally |
P2(config)#no igmp snooping | Disable igmp snooping messages globally |
P2(config)#vlan database | Enter into the vlan database |
P2(config-vlan)# vlan 10-200 bridge 1 state enable | Configure vlan 10-200 and associate with bridge 1 |
P2(config-vlan)#interface lo | Enter lo interface mode |
P2(config-if)# ip address 4.4.4.4/32 secondary | Assign loopback ip |
P2(config-if)#interface vlan1.30 | Specify interface vlan1.30 to be configured. |
P2(config-if)# ip address 14.1.1.2/24 | Assign ip address |
P2(config-if)# ip ospf cost 1 | Change ospf cost of the link |
P2(config-if)#interface vlan1.50 | Specify interface vlan1.50 to be configured. |
P2(config-if)# ip address 24.1.1.2/24 | Assign ip address |
P2(config-if)#interface vlan1.70 | Specify interface vlan1.70 to be configured. |
P2(config-if)# ip address 45.1.1.1/24 | Assign ip address |
P2(config-if)# ip ospf cost 1 | Change ospf cost of the link |
P2(config-if)#interface vlan1.90 | Specify interface vlan1.90 to be configured. |
P2(config-if)# ip address 46.1.1.1/24 | Assign ip address |
P2(config-if)# ip ospf cost 1 | Change ospf cost of the link |
P2(config-if)#interface vlan1.100 | Specify interface vlan1.100 to be configured. |
P2(config-if)# ip address 34.1.1.2/24 | Assign ip address |
P2(config-if)# ip ospf cost 1 | Change ospf cost of the link |
P2(config-if)#interface xe2 | Enter interface mode |
P2(config-if)# switchport | Set the interface as Layer2 port |
P2(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
P2(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
P2(config-if)# switchport trunk allowed vlan add 70,79 | Enable VLAN's allowed on this interface. |
P2(config-if)# switchport trunk native vlan 79 | Configure native vlan |
P2(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
P2(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
P2(config-if)#interface xe3 | Enter interface mode |
P2(config-if)# switchport | Set the interface as Layer2 port |
P2(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
P2(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
P2(config-if)# switchport trunk allowed vlan add 90,99 | Enable VLAN's allowed on this interface. |
P2(config-if)# switchport trunk native vlan 99 | Configure native vlan |
P2(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
P2(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
P2(config-if)#interface xe7 | Enter interface mode |
P2(config-if)# switchport | Set the interface as Layer2 port |
P2(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
P2(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
P2(config-if)# switchport trunk allowed vlan add 30,39 | Enable VLAN's allowed on this interface. |
P2(config-if)# switchport trunk native vlan 39 | Configure native vlan |
P2(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
P2(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
P2(config-if)#interface xe9 | Enter interface mode |
P2(config-if)# switchport | Set the interface as Layer2 port |
P2(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
P2(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
P2(config-if)# switchport trunk allowed vlan add 50,59 | Enable VLAN's allowed on this interface. |
P2(config-if)# switchport trunk native vlan 59 | Configure native vlan |
P2(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
P2(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
P2(config-if)#interface xe25 | Enter interface mode |
P2(config-if)# switchport | Set the interface as Layer2 port |
P2(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
P2(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
P2(config-if)# switchport trunk allowed vlan add 100,109 | Enable VLAN's allowed on this interface. |
P2(config-if)# switchport trunk native vlan 109 | Configure native vlan |
P2(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
P2(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
P2(config-if)#router ospf 1 | Enter ospf configuration mode |
P2(config-router)# ospf router-id 4.4.4.4 | Configure ospf router id |
P2(config-router)# bfd all-interfaces | Enable bfd in all ospf interfaces |
P2(config-router)# network 4.4.4.4/32 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
P2(config-router)# network 14.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
P2(config-router)# network 24.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
P2(config-router)# network 34.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
P2(config-router)# network 45.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
P2(config-router)# network 46.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
P2(config-router)#commit | Commit the candidate configuration to the running configuration |
P3(config)#hostname P3 | Configure hostname |
P3(config)#bfd interval 3 minrx 3 multiplier 3 | Configure bfd interval globally |
P3(config)#qos enable | Enable qos |
P3(config)#bridge 1 protocol ieee vlan-bridge | Configure IEEE vlan bridge |
P3(config)#no bridge 1 spanning-tree enable | Disable spanning tree in bridge 1 globally |
P3(config)#no igmp snooping | Disable igmp snooping messages globally |
P3(config)#vlan database | Enter into the vlan database |
P3(config-vlan)# vlan 10-200 bridge 1 state enable | Configure vlan 10-200 and associate with bridge 1 |
P3(config-vlan)#interface lo | Enter lo interface mode |
P3(config-if)# ip address 5.5.5.5/32 secondary | Assign loopback ip |
P3(config-if)#interface vlan1.60 | Specify interface vlan1.60 to be configured. |
P3(config-if)# ip address 35.1.1.2/24 | Assign ip address |
P3(config-if)# ip ospf cost 1 | Change ospf cost of the link |
P3(config-if)#interface vlan1.70 | Specify interface vlan1.70 to be configured. |
P3(config-if)# ip address 45.1.1.2/24 | Assign ip address |
P3(config-if)# ip ospf cost 1 | Change ospf cost of the link |
P3(config-if)#interface vlan1.80 | Specify interface vlan1.80 to be configured. |
P3(config-if)# ip address 56.1.1.1/24 | Assign ip address |
P3(config-if)# ip ospf cost 1 | Change ospf cost of the link |
P3(config-if)#interface vlan1.110 | Specify interface vlan1.1100 to be configured. |
P3(config-if)# ip address 15.1.1.2/24 | Assign ip address |
P3(config-if)# ip ospf cost 1 | Change ospf cost of the link |
P3(config-if)#interface vlan1.160 | Specify interface vlan1.160 to be configured. |
P3(config-if)# ip address 25.1.1.2/24 | Assign ip address |
P3(config-if)# ip ospf cost 1 | Change ospf cost of the link |
P3(config-if)#interface xe2 | Enter interface mode |
P3(config-if)# switchport | Set the interface as Layer2 port |
P3(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
P3(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
P3(config-if)# switchport trunk allowed vlan add 70,79 | Enable VLAN's allowed on this interface. |
P3(config-if)# switchport trunk native vlan 79 | Configure native vlan |
P3(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
P3(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
P3(config-if)#interface xe10 | Enter interface mode |
P3(config-if)# switchport | Set the interface as Layer2 port |
P3(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
P3(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
P3(config-if)# switchport trunk allowed vlan add 60,69 | Enable VLAN's allowed on this interface. |
P3(config-if)# switchport trunk native vlan 69 | Configure native vlan |
P3(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
P3(config-if)# mtu 1600 | Change interface mtu value |
P3(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
P3(config-if)#interface xe15 | Enter interface mode |
P3(config-if)# switchport | Set the interface as Layer2 port |
P3(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
P3(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
P3(config-if)# switchport trunk allowed vlan add 80,89 | Enable VLAN's allowed on this interface. |
P3(config-if)# switchport trunk native vlan 89 | Configure native vlan |
P3(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
P3(config-if)# mtu 1600 | Change interface mtu value |
P3(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
P3(config-if)#router ospf 1 | Enter ospf configuration mode |
P3(config-router)# ospf router-id 5.5.5.5 | Configure ospf router id |
P3(config-router)# bfd all-interfaces | Enable bfd in all ospf interfaces |
P3(config-router)# network 5.5.5.5/32 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
P3(config-router)# network 15.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
P3(config-router)# network 25.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
P3(config-router)# network 35.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
P3(config-router)# network 45.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
P3(config-router)# network 56.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
P3(config-router)#commit | Commit the candidate configuration to the running configuration |
VTEP3#configure terminal | Enter configuration terminal |
VTEP3(config)#hostname VTEP3 | Configure hostname |
VTEP3(config)#mac vrf vrf1 | Configure mac vrf vrf1 |
VTEP3(config-vrf)# rd 6.6.6.6:11 | Configure RD for vrf1 |
VTEP3(config-vrf)# route-target both 10.10.10.10:100 | Configure RT for vrf1 |
VTEP3(config-vrf)#mac vrf vrf2 | Configure mac vrf vrf2 |
VTEP3(config-vrf)# rd 6.6.6.6:12 | Configure RD for vrf2 |
VTEP3(config-vrf)# route-target both 10.10.10.10:101 | Configure RT for vrf2 |
VTEP3(config-vrf)# route-target both 10.10.10.10:102 | Configure RT for vrf2 |
VTEP3(config-vrf)#bfd interval 3 minrx 3 multiplier 3 | Configure bfd interval globally |
VTEP3(config)#load-balance enable | Enable load balancing |
VTEP3(config)#load-balance ipv4 dest-ipv4 src-ipv4 | Enable load balnce based on souce and destination ip address |
VTEP3(config)#hardware-profile filter egress-ipv4 enable | Enable hardware filter for egress ipv4 |
VTEP3(config)#hardware-profile filter vxlan enable | Enable vxlan-mh in hardware |
VTEP3(config)# hardware-profile filter vxlan-mh enable | Enable evpn vxlan multihoming |
VTEP3(config)#evpn vxlan multihoming enable | Enable vxlan in hardware |
VTEP3(config)#hardware-profile statistics ac-lif enable | Enable statistics on vxlan access interface |
VTEP3(config)#nvo vxlan enable | Enable vxlan |
VTEP3(config)#qos enable | Enable qos |
VTEP3(config)#qos statistics | Enable qos statistics |
VTEP3(config)#bridge 1 protocol ieee vlan-bridge | Configure IEEE vlan bridge |
VTEP3(config)#no bridge 1 spanning-tree enable | Disable spanning tree in bridge 1 globally |
VTEP3(config)#no igmp snooping | Disable igmp snooping messages globally |
VTEP3(config)#vlan database | Enter into the vlan database |
VTEP3(config-vlan)# vlan 10-200 bridge 1 state enable | Configure vlan 10-200 and associate with bridge 1 |
VTEP3(config-vlan)#interface lo | Enter lo interface mode |
VTEP3(config-if)# ip address 6.6.6.6/32 secondary | Assign loopback ip |
VTEP3(config-if)#interface vlan1.80 | Specify interface vlan1.80 to be configured. |
VTEP3(config-if)# ip address 56.1.1.2/24 | Assign ip address |
VTEP3(config-if)# ip ospf cost 1 | Change ospf cost of the link |
VTEP3(config-if)#interface vlan1.90 | Specify interface vlan1.90 to be configured. |
VTEP3(config-if)# ip address 46.1.1.2/24 | Assign ip address |
VTEP3(config-if)# ip ospf cost 1 | Change ospf cost of the link |
VTEP3(config-if)#interface xe3 | Enter interface mode |
VTEP3(config-if)# switchport | Set the interface as Layer2 port |
VTEP3(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
VTEP3(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
VTEP3(config-if)# switchport trunk allowed vlan add 90,99 | Enable VLAN's allowed on this interface. |
VTEP3(config-if)# switchport trunk native vlan 99 | Configure native vlan |
VTEP3(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
VTEP3(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
VTEP3(config-if)#interface xe15 | Enter interface mode |
VTEP3(config-if)# switchport | Set the interface as Layer2 port |
VTEP3(config-if)# bridge-group 1 spanning-tree disable | Associate the interface with bridge group 1 and disable spanning tree |
VTEP3(config-if)# switchport mode trunk | Set the switching characteristics of this interface to trunk mode. |
VTEP3(config-if)# switchport trunk allowed vlan add 80,89 | Enable VLAN's allowed on this interface. |
VTEP3(config-if)# switchport trunk native vlan 89 | Configure native vlan |
VTEP3(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
VTEP3(config-if)# mtu 1600 | Change interface mtu value |
VTEP3(config-if)# spanning-tree edgeport | Set the port as an edge-port to enable rapid transitions |
VTEP3(config-if)#interface xe45 | Enter interface mode |
VTEP3(config-if)# switchport | Set the interface as Layer2 port |
VTEP3(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
VTEP3(config-if)#interface xe46 | Enter interface mode |
VTEP3(config-if)# switchport | Set the interface as Layer2 port |
VTEP3(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
VTEP3(config-if)#router ospf 1 | Enter ospf configuration mode |
VTEP3(config-router)# ospf router-id 6.6.6.6 | Configure ospf router id |
VTEP3(config-router)# bfd all-interfaces | Enable bfd in all ospf interfaces |
VTEP3(config-router)# network 6.6.6.6/32 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
VTEP3(config-router)# network 46.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
VTEP3(config-router)# network 56.1.1.0/24 area 0.0.0.0 | Define the Network on which OSPF runs and associate the area ID (area 0) with the interface. |
VTEP3(config-router)#router bgp 100 | Enter address-family ipv4 unicast mode |
VTEP3(config-router)# address-family ipv4 unicast | Add the lo network to bgp route |
VTEP3(config-router)# network 6.6.6.6/32 | Activate neighbors |
VTEP3(config-router-af)# neighbor 1.1.1.1 activate | Activate neighbors |
VTEP3(config-router-af)# neighbor 2.2.2.2 activate | Exit address-family mode. |
VTEP3(config-router-af)#exit-address-family | Enter Router BGP mode and define the AS number 100. |
VTEP3(config-router)# neighbor 1.1.1.1 remote-as 100 | Configure bgp remote-as 100 with neighbor IP |
VTEP3(config-router)# neighbor 1.1.1.1 update-source lo | Define BGP neighbors, to update the source routes with lo |
VTEP3(config-router)# neighbor 2.2.2.2 remote-as 100 | Configure bgp remote-as 100 with neighbor IP |
VTEP3(config-router)# neighbor 2.2.2.2 update-source lo | Configure advertisement-interval as 0 for fast convergence for VTEP2 |
(config-router)#neighbor 2.2.2.2 advertisement-interval 0 | Configure advertisement-interval as 0 for fast convergence for VTEP1 |
(config-router)#neighbor 1.1.1.1 advertisement-interval 0 | Define BGP neighbors, to update the source routes with lo |
VTEP3(config-router)# address-family l2vpn evpn | Enter in to bgp l2vpn evpn address-family |
VTEP3(config-router-af)# neighbor 1.1.1.1 activate | Activate neigbors |
VTEP3(config-router-af)# neighbor 2.2.2.2 activate | Activate neigbors |
VTEP3(config-router-af)# exit-address-family | Exit from bgp l2vpn evpn address-family |
VTEP3(config-router)#nvo vxlan vtep-ip-global 6.6.6.6 | Configure vxlan global ip |
VTEP3(config)#nvo vxlan id 1 ingress-replication inner-vid-disabled | Create vnid 1 |
VTEP3(config-nvo)# vxlan host-reachability-protocol evpn-bgp vrf1 | Associate vnid with evpn and vrf1 |
VTEP3(config-nvo)#nvo vxlan id 1000 ingress-replication inner-vid-disabled | Create vnid 1000 |
VTEP3(config-nvo)# vxlan host-reachability-protocol evpn-bgp vrf2 | Associate vnid with evpn and vrf2 |
VTEP3(config-nvo)#nvo vxlan access-if port-vlan xe45 3001 | Create vxlan access port port-vlan |
VTEP3(config-nvo-acc-if)# map vnid 1 | Map the vnid to access-if |
VTEP3(config-nvo-acc-if)#nvo vxlan access-if port xe46 | Create vxlan access port |
VTEP3(config-nvo-acc-if)# map vnid 1000 | Map the vnid to access-if |
VTEP3(config-nvo-acc-if)# commit | Commit the candidate configuration to the running configuration |
SWITCH#configure terminal | Enter configuration terminal |
SWITCH#(config)# bridge 1 protocol rstp vlan-bridge | Configure rstp vlan bridge |
SWITCH#(config)#interface po1 | Enter interface mode |
SWITCH#(config-if)# switchport | Set the interface as Layer2 port |
SWITCH#(config-if)# load-interval 30 | Configure load period in multiple of 30 seconds |
SWITCH#(config-if)#interface ce9/1 | Enter interface mode |
SWITCH#(config-if)# channel-group 1 mode active | Map this interface to po1 |
SWITCH#(config-if)#interface ce9/2 | Enter interface mode |
SWITCH#(config-if)# channel-group 1 mode active | Map this interface to po1 |
SWITCH#(config-if)#interface ce10/1 | Enter interface mode |
SWITCH#(config-if)# channel-group 1 mode active | Map this interface to po1 |
SWITCH#(config-if)#interface ce10/2 | Enter interface mode |
SWITCH#(config-if)# channel-group 1 mode active | Map this interface to po1 |
SWITCH#(config-if)#interface ce31/1 | Set the port as an edge-port to enable rapid transitions |
SWITCH#(config-if)# switchport | Enter interface mode |
SWITCH#(config-if)# bridge-group 1 spanning-tree disable | Set the interface as Layer2 port |
SWITCH#(config-if)# switchport mode trunk | Associate the interface with bridge group 1 and disable spanning tree |
SWITCH#(config-if)# switchport trunk allowed vlan all | Set the switching characteristics of this interface to trunk mode. |
SWITCH#(config-if)# load-interval 30 | Configure native vlan |
SWITCH#(config-if)# commit | Commit the candidate configuration to the running configuration |