Hierarchical VPLS
Overview
A Virtual Private LAN Service (VPLS) enables multipoint to multipoint communication, creating LAN-like connectivity between customers' sites. However, the typical full mesh topology required for LAN emulation can be impractical in large networks. To address this, Hierarchical VPLS (H-VPLS) introduces a hierarchical approach using a spoke-PW (pseudowire) type. Unlike the standard mesh-PW, the spoke-PW facilitates traffic between hierarchical levels, offering a more scalable solution for VPLS networks.
H-VPLS Redundancy Characteristics
In a Virtual Private LAN Service (VPLS) network, when a node connects through a spoke-PW, a single point of failure arises. In the event of a connection failure to the VPLS mesh or a failure within the PE-rs node, the spoke device experiences a complete loss of connectivity. To address this, PW redundancy is implemented, configuring a secondary path that activates if the primary path fails. The MTU-s is configured with a primary spoke-PW connected to PE1-rs and a secondary spoke-PW connected to PE2-rs. During normal operation, the primary spoke-PW is active, but in case of failure, the MTU-s can switch to the standby spoke-PW for continued connectivity, aiming for sub-second convergence times with potential MAC flush-related traffic loss.
Benefits
Hierarchical VPLS (H-VPLS) is introduced to address scalability challenges associated with the traditional VPLS (Virtual Private LAN Service) architecture. It introduces a hierarchical approach that enhances scalability, reduces configuration complexity, optimizes traffic flow, and improves overall network efficiency and fault tolerance.
Limitations
Automatic revertive cases from secondary to primary will not be supported.
MAC Address Withdrawal feature will not be supported in release 6.5.2.
Convergence on redundancy may require bidirectional traffic or MAC aging.
Prerequisites
The block-mesh-spoke-on-all-ac-down and ignore-ac-spoke-state commands are optional and mutually exclusive, meaning only one can be applied at a time, or neither. By default, neither command is applied. If one of commands is applied, applying the other will make it the active one. To remove a command, use the no prefix.
signaling ldp
(block-mesh-spoke-on-all-ac-down | ignore-ac-spoke-state)
(no block-mesh-spoke-on-all-ac-down | no ignore-ac-spoke-state)
Define Interfaces and Loopback Addresses:
Configure Layer 2 interfaces, like port channel interfaces (e.g., po1), and assign specific IP addresses for proper identification and routing. Additionally, assign loopback IP addresses to establish essential points of connec-tivity. These configurations establish the efficient network routing and communication.
!
interface lo
ip address 127.0.0.1/8
ip address 2.2.2.2/32 secondary
ipv6 address ::1/128
 
interface xe14
ip address 30.1.1.2/24
Configure IGP for Dynamic Routing: Enable ISIS to facilitate dynamic routing on all nodes within the net-work. Define ISIS router instances to match loopback IP addresses and add network segments to ISIS areas for proper route distribution.Set up neighbor relationships using loopback IP addresses, ensuring efficient route advertisement and convergence for optimal network performance.
ISIS Configuration:
router isis 1
is-type level-2-only
metric-style wide
microloop-avoidance level-2
mpls traffic-eng router-id 2.2.2.2
mpls traffic-eng level-2
capability cspf
dynamic-hostname
bfd all-interfaces
net 49.0000.0000.0002.00
passive-interface lo
!
interface xe14
mpls ldp-igp sync isis level-2
isis network point-to-point
ip router isis 1
OSPF Configuration:
router ospf 1
ospf router-id 2.2.2.2
network 2.2.2.2/32 area 0.0.0.0
network 30.1.1.0/24 area 0.0.0.0!
!
interface xe14
ip ospf network point-to-point
Configuration for H-VPLS with Redundancy
Configure various nodes within the topology to set up a H-VPLS session.
Topology
This sample topology provides basic connectivity and routing between the devices.
H-VPLS Configuration with Redundancy
Configure H-VPLS on PE1 Router
Follow the steps to configure the H-VPLS on PE1 router:
1. Configure router LDP.
PE1(config)#router ldp
PE1(config-router)# router-id 2.2.2.2
PE1(config-router)# transport-address ipv4 2.2.2.2
2. Configure targeted-peer under router LDP.
PE1(config-router)# targeted-peer ipv4 5.5.5.5
PE1(config-router-targeted-peer)# exit-targeted-peer-mode
PE1(config-router)# targeted-peer ipv4 3.3.3.3
PE1(config-router-targeted-peer)# exit-targeted-peer-mode
3. Enable LDP and label-switching for core interface.
PE1(config)#interface xe14
PE1(config-if)# enable-ldp ipv4
PE1(config-if)#label-switching
 
PE1(config)#interface xe26
PE1(config-if)# enable-ldp ipv4
PE1(config-if)#label-switching
4. Configure VPLS instance.
PE1(config)#mpls vpls vpls2000 2000
PE1(config-vpls)# signaling ldp
PE1(config-vpls-sig)# vpls-peer 3.3.3.3
PE1(config-vpls-sig)# vpls-peer 5.5.5.5
PE1(config-vpls-sig)# exit-signaling
PE1(config-vpls)# exit-vpls
PE1(config)#
5. Configure sub-interface and attach vpls-instance to sub-interface.
PE1(config)#
PE1(config)#interface xe16.2000 switchport
PE1(config-if)# encapsulation dot1q 2000
PE1(config-if)# access-if-vpls
PE1(config-acc-if-vpls)# mpls-vpls vpls2000
PE1(config-acc-if-vpls)#
Configure H-VPLS on PE2 (Primary Hub)
Follow the steps to configure the H-VPLS on PE2 (Primary Hub):
1. Configure router LDP.
PE2(config)#router ldp
PE2(config-router)# router-id 5.5.5.5
PE2(config-router)# transport-address ipv4 5.5.5.5
2. Configure targeted-peer under router LDP.
PE2(config)#router ldp
PE2(config-router)# targeted-peer ipv4 2.2.2.2
PE2(config-router-targeted-peer)# exit-targeted-peer-mode
PE2(config-router)# targeted-peer ipv4 3.3.3.3
PE2(config-router-targeted-peer)# exit-targeted-peer-mode
PE2(config-router)#
3. Enable LDP and label-switching for core interface.
PE2(config)#interface xe1
PE2(config-if)# enable-ldp ipv4
PE2(config-if)#label-switching
 
PE2(config)#interface xe12
PE2(config-if)# enable-ldp ipv4
PE2(config-if)#label-switching
4. Configure VPLS instance.
PE2(config)#mpls vpls vpls2000 2000
PE2(config-vpls)# signaling ldp
PE2(config-vpls-sig)# vpls-peer 2.2.2.2
PE2(config-vpls-sig)# vpls-peer 3.3.3.3
PE2(config-vpls-sig)# exit-signaling
PE2(config-vpls)# exit-vpls
PE2(config)#
5. Configure L2-ckt.
PE2(config)#mpls l2-circuit vc2000 2222 8.8.8.8 mode raw
PE2(config-pseudowire)#
6. Attach L2-ckt under vpls instance.
PE2(config)#mpls vpls vpls2000 2000
PE2(config-vpls)#vpls-vc vc2000
PE2(config-vpls-spoke)#
Configure H-VPLS on PE3 (Secondary Hub)
Follow the steps to configure the H-VPLS on PE3 (Secondary Hub):
1. Configure router LDP.
PE3(config)#router ldp
PE3(config-router)# router-id 3.3.3.3
PE3(config-router)# transport-address ipv4 3.3.3.3
2. Configure targeted-peer under router LDP.
PE3(config)#router ldp
PE3(config-router)# targeted-peer ipv4 2.2.2.2
PE3(config-router-targeted-peer)# exit-targeted-peer-mode
PE3(config-router)# targeted-peer ipv4 5.5.5.5
PE3(config-router-targeted-peer)# exit-targeted-peer-mode
PE3(config-router)#
3. Enable LDP and label-switching for core interface.
PE3(config)#interface xe23
PE3(config-if)# enable-ldp ipv4
PE3(config-if)#label-switching
 
PE3(config)#interface xe26
PE3(config-if)# enable-ldp ipv4
PE3(config-if)#label-switching
4. Configure VPLS instance.
PE3(config)#mpls vpls vpls2000 2000
PE3(config-vpls)# signaling ldp
PE3(config-vpls-sig)# vpls-peer 2.2.2.2
PE3(config-vpls-sig)# vpls-peer 5.5.5.5
PE3(config-vpls-sig)# exit-signaling
PE3(config-vpls)# exit-vpls
PE3(config)#
5. Configure L2-ckt.
PE3(config)#mpls l2-circuit vc2001 2223 8.8.8.8 mode raw
PE3(config-pseudowire)#
6. 6.Attach L2-ckt under vpls instance.
PE3 (config)#mpls vpls vpls2000 2000
PE3(config-vpls)#vpls-vc vc2001
PE3(config-vpls-spoke)#
Configure H-VPLS on Spoke Router
Follow the steps to configure the H-VPLS on Spoke router:
1. Configure router LDP.
Spoke(config)#router ldp
Spoke(config-router)# router-id 8.8.8.8
Spoke(config-router)# transport-address ipv4 8.8.8.8
2. Configure targeted-peer under router LDP.
Spoke(config-router)# targeted-peer ipv4 5.5.5.5
Spoke(config-router-targeted-peer)# exit-targeted-peer-mode
Spoke(config-router)# targeted-peer ipv4 3.3.3.3
Spoke(config-router-targeted-peer)# exit-targeted-peer-mode
3. Enable LDP and label-switching for core interface.
Spoke(config)#interface xe12
Spoke(config-if)# enable-ldp ipv4
Spoke(config-if)#label-switching
 
Spoke(config)#interface xe25
Spoke(config-if)# enable-ldp ipv4
Spoke(config-if)#label-switching
4. Configure VPLS instance.
Spoke (config)#mpls vpls vpls2000 2000
Spoke (config-vpls)#
5. 5.Configure L2-ckt.
Spoke(config)#mpls l2-circuit vc2000 2222 5.5.5.5 mode raw
Spoke(config-pseudowire)#!
Spoke(config-pseudowire)#mpls l2-circuit vc2001 2223 3.3.3.3 mode raw
Spoke(config-pseudowire)#
6. 6.Configure Primary and secondary spoke under vpls instance.
Spoke(config)#mpls vpls vpls2000 2000
Spoke(config-vpls)#vpls-vc vc2000
Spoke(config-vpls-spoke)# secondary vc2001
Spoke(config-vpls-spoke)# exit-spoke
Spoke(config-vpls)# exit-vpls
Spoke(config)#
7. Configure sub-interface and attach vpls-instance to sub-interface.
Spoke(config)#
Spoke(config)#interface xe26.2000 switchport
Spoke(config-if)# encapsulation dot1q 2000
Spoke(config-if)# access-if-vpls
Spoke(config-acc-if-vpls)# mpls-vpls vpls2000
Spoke(config-acc-if-vpls)#
Running Configuration on PE1 Router
router ldp
router-id 2.2.2.2
targeted-peer ipv4 3.3.3.3
exit-targeted-peer-mode
targeted-peer ipv4 5.5.5.5
transport-address ipv4 2.2.2.2
!
interface xe14
enable-ldp ipv4
!
interface xe26
enable-ldp ipv4
!
mpls vpls vpls2000 2000
signaling ldp
vpls-peer 3.3.3.3
vpls-peer 5.5.5.5
exit-signaling
exit-vpls
!
interface xe16.2000 switchport
access-if-vpls
mpls-vpls vpls2000
Running Configuration on PE2 Router
router ldp
targeted-peer ipv4 2.2.2.2
exit-targeted-peer-mode
targeted-peer ipv4 3.3.3.3
exit-targeted-peer-mode
transport-address ipv4 5.5.5.5
!
mpls l2-circuit vc2000 2222 8.8.8.8 mode raw
!
mpls vpls vpls2000 2000
vpls-vc vc2000
exit-spoke
signaling ldp
vpls-peer 2.2.2.2
vpls-peer 3.3.3.3
exit-signaling
exit-vpls
Running Configuration on PE3 Router
router ldp
targeted-peer ipv4 2.2.2.2
exit-targeted-peer-mode
targeted-peer ipv4 5.5.5.5
exit-targeted-peer-mode
transport-address ipv4 3.3.3.3
!
mpls l2-circuit vc2001 2223 8.8.8.8 mode raw
!
mpls vpls vpls2000 2000
vpls-vc vc2001
exit-spoke
signaling ldp
vpls-peer 2.2.2.2
vpls-peer 5.5.5.5
exit-signaling
exit-vpls
Running Configuration on Spoke Router
router ldp
router-id 8.8.8.8
targeted-peer ipv4 3.3.3.3
exit-targeted-peer-mode
targeted-peer ipv4 5.5.5.5
exit-targeted-peer-mode
transport-address ipv4 8.8.8.8
!
mpls l2-circuit vc2000 2222 5.5.5.5 mode raw
!
mpls l2-circuit vc2001 2223 3.3.3.3 mode raw
!
mpls vpls vpls2000 2000
vpls-vc vc2000
secondary vc2001
exit-spoke
exit-vpls
!
interface xe26.2000 switchport
access-if-vpls
mpls-vpls vpls2000
Validation
Validate the show output after configuration as shown below.
Verify vpls mesh are up between PE1 and Hub Nodes
 
PE1#sho mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
 
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status UpTime
2000 3.3.3.3 29447 28164 xe26 27532 2/Up 3 LDP Active 2d12h08m
2000 5.5.5.5 31364 28162 xe14 26883 2/Up 4 LDP Active 2d12h04m
 
PE2#sho mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
 
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status UpTime
2000 2.2.2.2 29446 26883 xe1 28162 2/Up 3 LDP Active 2d12h05m
2000 3.3.3.3 31367 26884 xe1 27528 2/Up 4 LDP Active 2d12h15m
 
PE3#sho mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
 
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status UpTime
2000 2.2.2.2 29440 27532 xe26 28164 2/Up 3 LDP Active 2d12h10m
2000 5.5.5.5 31363 27528 xe26 26884 2/Up 4 LDP Active 2d12h16m
 
 
Verify vpls spoke between Hub and Spoke
 
PE2#sho mpls vpls spoke
VPLS-ID Virtual Circuit Tunnel-Label In-Label Network-Intf Out-Label Lkps/St Secondary
2000 vc2000 29443 26882 xe1 26886 2/Up ---
 
PE3#show mpls vpls spoke
VPLS-ID Virtual Circuit Tunnel-Label In-Label Network-Intf Out-Label Lkps/St Secondary
2000 vc2001 N/A 27527 N/A 26883 0/Dn ---
 
Spoke#show mpls vpls spoke
VPLS-ID Virtual Circuit Tunnel-Label In-Label Network-Intf Out-Label Lkps/St Secondary
2000 vc2000 29440 26886 xe12 26882 2/Up vc2001
2000 vc2001 N/A 26883 N/A 27527 0/Dn ---
 
Verify H-vpls session on Hub and spoke:
 
PE2#show mpls vpls vpls2000
Virtual Private LAN Service Instance: vpls2000, ID: 2000
SIG-Protocol: LDP
Attachment-Circuit: UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, VPLS Type: Ethernet, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Raw
Ignoring AC interface and spoke-VC state
 
Configured interfaces:
None
 
Mesh Peers:
2.2.2.2 (Peer VPLS Type: Ethernet) (Up) (UpTime: 2d12h13m)
3.3.3.3 (Peer VPLS Type: Ethernet) (Up) (UpTime: 2d12h22m)
Spoke Peers:
vc2000 (Up) (UpTime 01:31:27)
 
 
PE3#show mpls vpls vpls2000
Virtual Private LAN Service Instance: vpls2000, ID: 2000
SIG-Protocol: LDP
Attachment-Circuit: UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, VPLS Type: Ethernet, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Raw
Ignoring AC interface and spoke-VC state
 
Configured interfaces:
None
 
Mesh Peers:
2.2.2.2 (Peer VPLS Type: Ethernet) (Up) (UpTime: 2d12h16m)
5.5.5.5 (Peer VPLS Type: Ethernet) (Up) (UpTime: 2d12h22m)
Spoke Peers:
vc2001 (Dn) (Reason: VC on standby)
 
 
Spoke#show mpls vpls vpls2000
Virtual Private LAN Service Instance: vpls2000, ID: 2000
SIG-Protocol: N/A
Attachment-Circuit: UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Raw
 
Configured interfaces:
Interface: xe26.2000
Status: Up
Subinterface Match Criteria(s) :
dot1q 2000
 
Spoke Peers:
vc2000 (Up) (UpTime 01:31:33)
Secondary: vc2001 (Dn) (Reason: VC on standby)
Configuration for H-VPLS without Redundancy
Configure various nodes within the topology to set up a H-VPLS session.
Topology
This sample topology provides basic connectivity and routing between the devices.
H-VPLS Configuration without Redundancy
Configure H-VPLS on PE1 Router
Follow the steps to configure the H-VPLS on PE1 router:
1. Configure router LDP.
PE1(config)#router ldp
PE1(config-router)# router-id 2.2.2.2
PE1(config-router)# transport-address ipv4 2.2.2.2
2. Configure targeted-peer under router LDP.
PE1(config-router)# targeted-peer ipv4 5.5.5.5
PE1(config-router-targeted-peer)# exit-targeted-peer-mode
3. Enable LDP and label-switching for core interface.
PE1(config)#interface xe14
PE1(config-if)# enable-ldp ipv4
PE1(config-if)#label-switching
4. Configure VPLS instance.
PE1(config)#mpls vpls vpls2000 2000
PE1(config-vpls)# signaling ldp
PE1(config-vpls-sig)# vpls-peer 5.5.5.5
PE1(config-vpls-sig)# exit-signaling
PE1(config-vpls)# exit-vpls
PE1(config)#
5. Configure sub-interface and attach vpls-instance to sub-interface
PE1(config)#
PE1(config)#interface xe16.2000 switchport
PE1(config-if)# encapsulation dot1q 2000
PE1(config-if)# access-if-vpls
PE1(config-acc-if-vpls)# mpls-vpls vpls2000
PE1(config-acc-if-vpls)#
Configure H-VPLS on Hub Router
Follow the steps to configure the H-VPLS on Hub router:
1. Configure router LDP.
Hub(config)#router ldp
Hub(config-router)# router-id 5.5.5.5
Hub(config-router)# transport-address ipv4 5.5.5.5
2. Configure targeted-peer under router LDP.
Hub(config-router)# targeted-peer ipv4 2.2.2.2
Hub(config-router-targeted-peer)# exit-targeted-peer-mode
R5-P5(config-router)# targeted-peer ipv4 8.8.8.8
R5-P5(config-router-targeted-peer)#
3. Enable LDP and label-switching for core interface.
Hub(config)#interface xe1
Hub(config-if)# enable-ldp ipv4
Hub(config-if)#label-switching
 
Hub(config)#interface xe12
Hub(config-if)# enable-ldp ipv4
Hub(config-if)#label-switching
4. Configure VPLS instance.
Hub(config)#mpls vpls vpls2000 2000
Hub(config-vpls)# signaling ldp
Hub(config-vpls-sig)# vpls-peer 2.2.2.2
Hub(config-vpls-sig)# exit-signaling
Hub(config-vpls)# exit-vpls
Hub(config)#
5. Configure L2-ckt.
Hub (config)#mpls l2-circuit vc2000 2222 8.8.8.8 mode raw
Hub (config-pseudowire)#
6. Attach L2-ckt under vpls instance.
Hub (config)#mpls vpls vpls2000 2000
Hub (config-vpls)#vpls-vc vc2000
Hub(config-vpls-spoke)#
Configure H-VPLS on Spoke Router
Follow the steps to configure the H-VPLS on Spoke router:
1. Configure router LDP.
Spoke(config)#router ldp
Spoke(config-router)# router-id 8.8.8.8
Spoke(config-router)# transport-address ipv4 8.8.8.8
2. Configure targeted-peer under router LDP.
Spoke(config-router)# targeted-peer ipv4 5.5.5.5
Spoke(config-router-targeted-peer)# exit-targeted-peer-mode
3. Enable LDP and label-switching for core interface.
Spoke(config)#interface xe12
Spoke(config-if)# enable-ldp ipv4
Spoke(config-if)#label-switching
4. Configure VPLS instance.
Spoke(config)#mpls vpls vpls2000 2000
Spoke(config-vpls)#
5. Configure L2-ckt.
Spoke(config)#mpls l2-circuit vc2000 2222 5.5.5.5 mode raw
Spoke(config-pseudowire)#
6. Attach L2-ckt under vpls instance.
Spoke (config)#mpls vpls vpls2000 2000
Spoke(config-vpls)#vpls-vc vc2000
Spoke(config-vpls-spoke)#
7. Configure sub-interface and attach vpls-instance to sub-interface.
Spoke(config)#
Spoke(config)#interface xe26.2000 switchport
Spoke(config-if)# encapsulation dot1q 2000
Spoke(config-if)# access-if-vpls
Spoke(config-acc-if-vpls)# mpls-vpls vpls2000
Spoke(config-acc-if-vpls)#
Running Configuration on PE1 Router
router ldp
router-id 2.2.2.2
targeted-peer ipv4 5.5.5.5
exit-targeted-peer-mode
transport-address ipv4 2.2.2.2
!
interface xe14
enable-ldp ipv4
!
mpls vpls vpls2000 2000
signaling ldp
vpls-peer 5.5.5.5
exit-signaling
exit-vpls
!
interface xe16.2000 switchport
access-if-vpls
mpls-vpls vpls2000
Running Configuration on Hub Router
router ldp
targeted-peer ipv4 2.2.2.2
exit-targeted-peer-mode
targeted-peer ipv4 8.8.8.8
exit-targeted-peer-mode
!
!
mpls l2-circuit vc2000 2222 8.8.8.8 mode raw
!
mpls vpls vpls2000 2000
vpls-vc vc2000
exit-spoke
signaling ldp
vpls-peer 2.2.2.2
exit-signaling
exit-vpls
Running Configuration on Spoke Router
router ldp
router-id 8.8.8.8
targeted-peer ipv4 5.5.5.5
exit-targeted-peer-mode
transport-address ipv4 8.8.8.8
!
mpls l2-circuit vc2000 2222 5.5.5.5 mode raw
!
mpls vpls vpls2000 2000
vpls-vc vc2000
exit-spoke
exit-vpls
!
interface xe26.2000 switchport
access-if-vpls
mpls-vpls vpls2000
 
Validation
Validate the show output after configuration as shown below.
Verify vpls mesh are up between PE and Hub
 
PE1#show mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
 
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status UpTime
2000 5.5.5.5 31364 28162 xe14 26883 2/Up 4 LDP Active 2d10h36m
 
Hub#sho mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
 
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status UpTime
2000 2.2.2.2 29446 26883 xe1 28162 2/Up 3 LDP Active 2d10h39m
 
 
Verify vpls spoke are up between Hub and Spoke
 
Hub#sho ldp mpls-l2-circuit
Transport Client VC VC Local Remote Destination Lo-cal Remote
VC ID Binding State Type VC Label VC Label Address PW Status PW Status
2222 VPLS:2000 UP Ethernet 26882 26886 8.8.8.8 Forwarding Forwarding
 
Hub#sho mpls vpls spoke
VPLS-ID Virtual Circuit Tunnel-Label In-Label Network-Intf Out-Label Lkps/St Secondary
2000 vc2000 29443 26882 ce4 26886 2/Up
---
 
Spoke#show ldp mpls-l2-circuit
Transport Client VC VC Local Remote Destination Lo-cal Remote
VC ID Binding State Type VC Label VC Label Address PW Status PW Status
2222 VPLS:2000 UP Ethernet 26886 26882 5.5.5.5 Forwarding Forwarding
 
Spoke#show mpls vpls spoke
VPLS-ID Virtual Circuit Tunnel-Label In-Label Network-Intf Out-Label Lkps/St Secondary
2000 vc2000 29440 26886 ce4 26882 2/Up ---
 
Verify H-vpls session on Hub and spoke:
 
Hub#show mpls vpls vpls2000
Virtual Private LAN Service Instance: vpls2000, ID: 2000
SIG-Protocol: LDP
Attachment-Circuit: UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, VPLS Type: Ethernet, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Raw
Ignoring AC interface and spoke-VC state
 
Configured interfaces:
None
 
Mesh Peers:
2.2.2.2 (Peer VPLS Type: Ethernet) (Up) (UpTime: 2d10h47m)
3.3.3.3 (Peer VPLS Type: Ethernet) (Up) (UpTime: 2d10h56m)
Spoke Peers:
vc2000 (Up) (UpTime 00:05:48)
 
 
Spoke#show mpls vpls vpls2000
Virtual Private LAN Service Instance: vpls2000, ID: 2000
SIG-Protocol: N/A
Attachment-Circuit: UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, Configured MTU: 1500
Description: none
service-tpid: dot1.q
Operating mode: Raw
 
Configured interfaces:
Interface: xe26.2000
Status: Up
Subinterface Match Criteria(s) :
dot1q 2000
 
Spoke Peers:
vc2000 (Up) (UpTime 00:07:47)
Commands for H-VPLS Configuration
The H-VPLS uses the following configuration commands.
vpls-vc
Use this command to add a spoke virtual circuit to VPLS domain hierarchically.
Use no parameter of this command to remove this configuration.
Command Syntax
vpls-vc NAME
(secondary NAME|)
(ethernet|vlan|)
Parameters
 
Default
Disabled
Command Mode
VPLS mode
Applicability
Introduced before OcNOS version 1.3.
Modified the command prompt into a hierarchical structure from single line in the OcNOS version 6.5.1.
Example
Example for adding a spoke virtual circuit with VPLS name vc1 and secondary spoke vc2:
#configure terminal
(config)#mpls vpls vpls1 3000
(config-vpls)#vpls-vc vc1
(config-vpls-spoke)#secondary vc2
(config-vpls-spoke)#type ethernet
(config-vpls-spoke)#exit-spoke
(config-vpls)#exit
Example to remove the configuration of the spoke virtual circuit with VPLS name vc1:
#configure terminal
(config)#mpls vpls vpls1 3000
(config-vpls)#no vpls-vc vc1
(config-vpls)#exit
signaling
Use this command to set all mesh and spoke pseudowires to down when all access interfaces are down.
Use ignore-ac-spoke-state parameter of this command to remove this configuration.
Command Syntax
signaling ldp block-mesh-spoke-on-all-ac-down
signaling ignore-ac-spoke-state
Parameters
 
Default
disabled
Command Mode
VPLS mode
Applicability
Introduced before OcNOS version 1.3.
Modified the command prompt into a hierarchical structure from single line in the OcNOS version 6.5.1.
Example
Example for setting up all mesh and spoke pseudowires to down when all access interfaces are down:
#configure terminal
(config)# mpls vpls test 100
(config-vpls)#signaling ldp
(config-vpls-sig)#block-mesh-spoke-on-all-ac-down
(config-vpls-sig)#exit
Example for setting up all mesh and spoke pseudowires to up:
#configure terminal
(config)# mpls vpls test 100
(config-vpls)#signaling ldp
(config-vpls-sig)#ignore-ac-spoke-state
(config-vpls-sig)#exit