R1#configure terminal | Enter configure mode. |
R1(config)#interface xe1 | Specify the interface xe1 to be configured. |
R1(config-if)#ip address 10.10.10.1/24 | Assign IP address 10.10.10.1/24 to interface. |
R1(config-if)#label-switching | Enable label switching on interface xe1. |
R1(config-if)#exit | Exit interface mode. |
R1(config)#interface lo | Specify the loopback interface to be configured. |
R1(config-if)#ip address 1.1.1.1/32 secondary | Set the IP address of the loopback interface to 1.1.1.1/32. |
R1(config-if)#commit | Commit the transaction. |
R1(config)#router ldp | Enter Router mode for LDP. |
R1(config-router)#router-id 1.1.1.1 | Set the router ID to IP address 1.1.1.1. |
R1(config-router)#transport-address ipv4 1.1.1.1 | Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter ipv6 if you are configuring an IPv6 interface. |
R1(config-router)#targeted-peer ipv4 3.3.3.3 | Configure targeted peer 3.3.3.3. |
R1(config-router-targeted-peer)#exit | Exit targeted peer-mode. |
R1(config-router)#exit | Exit the router mode and return to the configure mode. |
R1(config)#interface xe1 | Enter interface mode xe1. |
R1(config-if)#enable-ldp ipv4 | Enable LDP on xe1. |
R1(config-if)#commit | Commit the transaction. |
R1(config)#router ospf 100 | Configure the routing process and specify the process ID 100. The process ID should be a unique positive integer identifying the routing process. |
R1(config-router)#network 10.10.10.0/24 area 0 | Define the interface 10.10.10.0/24,on which OSPF runs and associate the area ID 0 with the interface. |
R1(config-router)#network 1.1.1.1/32 area 0 | Define the interface 1.1.1.1/32, on which OSPF runs and associate the area ID 0 with the interface. |
R1(config-router)#commit | Commit the transaction. |
R2#configure terminal | Enter configure mode. |
R2(config)#interface lo | Specify the loopback interface to be configured. |
R2(config-if)#ip address 2.2.2.2/32 secondary | Set the IP address of the loopback interface to 2.2.2.2/32. |
R2(config-if)#exit | Exit interface mode. |
R2(config)#interface xe1 | Specify the interface xe1 to be configured. |
R2(config-if)#ip address 20.20.20.1/24 | Assign IP address 20.20.20.1/24 to interface. |
R2(config-if)#label-switching | Enable label switching on interface xe1. |
R2(config-if)#exit | Exit interface mode. |
R2(config)#interface xe2 | Specify the interface xe2 to be configured. |
R2(config-if)#ip address 10.10.10.2/24 | Assign IP address 10.10.10.2/24 to interface. |
R2(config-if)#label-switching | Enable label switching on interface xe2. |
R2(config-if)#commit | Commit the transaction. |
R2(config)#router ldp | Enter Router mode. |
R2(config-router)#router-id 2.2.2.2 | Set the router ID to IP address 2.2.2.2. |
R2(config-router)#transport-address ipv4 2.2.2.2 | Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter ipv6 if you are configuring an IPv6 interface. |
R2(config-router)#neighbor 1.1.1.1 tcp-mss 600 | Configure the TCP MSS value on peer node which have active side only. |
R2(config-router)#exit | Exit router mode and return to configure mode. |
R2(config)#interface xe1 | Specify the interface xe1 to be configured. |
R2(config-if)#enable-ldp ipv4 | Enable LDP on a specified interface xe1. |
R2(config-if)#exit | Exit interface mode. |
R2(config)#interface xe2 | Specify the interface xe2 to be configured. |
R2(config-if)#enable-ldp ipv4 | Enable LDP on a specified interface xe2. |
R2(config-if)#commit | Commit the transaction. |
R2(config)#router ospf 100 | Configure the routing process and specify the process ID 100. The process ID should be a unique positive integer identifying the routing process. |
R2(config-router)#network 10.10.10.0/24 area 0 | Define the interfaces 10.10.10.0/24, on which OSPF runs and associate the area ID 0 with them. |
R2(config-router)#network 20.20.20.0/24 area 0 | Define the interfaces 20.20.20.0/24, on which OSPF runs and associate the area ID 0 with them. |
R2(config-router)#network 2.2.2.2/32 area 0 | Define the interfaces 2.2.2.2/32, on which OSPF runs and associate the area ID 0 with them. |
R2(config-router)#commit | Commit the transaction. |
R3#configure terminal | Enter configure mode. |
R3(config)#interface lo | Specify the loopback interface to be configured. |
R3(config-if)#ip address 3.3.3.3/32 secondary | Set the IP address of the loopback interface to 3.3.3.3/32. |
R3(config-if)#exit | Exit interface mode. |
R3(config)#interface xe1 | Specify the interface xe1 to be configured. |
R3(config-if)#ip address 20.20.20.2/24 | Set the IP address of the interface to 20.20.20.2/24. |
R3(config-if)#label-switching | Enable label switching on interface xe1. |
R3(config-if)#commit | Commit the transaction. |
R3(config)#router ldp | Enter Router mode. |
R3(config-router)#router-id 3.3.3.3 | Set the router ID for IP address 3.3.3.3. |
R3(config-router)#transport-address ipv4 3.3.3.3 | Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter ipv6 if you are configuring an IPv6 interface. |
R3(config-router)#neighbor 2.2.2.2 tcp-mss 650 | Configure the TCP MSS value on peer node which have active side only. |
R3(config-router)#targeted-peer ipv4 1.1.1.1 | Configure targeted peer. |
R3(config-router-targeted-peer)#exit | Exit targeted peer-mode. |
R3(config-router)#exit | Exit the router mode and return to the configure mode. |
R3(config)#interface xe1 | Enter interface mode xe1. |
R3(config-if)#enable-ldp ipv4 | Enable LDP on xe1. |
R3(config-if)#commit | Commit the transaction. |
R3(config)#router ospf 100 | Configure the routing process and specify the Process ID 100. The Process ID should be a unique positive integer identifying the routing process. |
R3(config-router)#network 20.20.20.0/24 area 0 | Define the interfaces 20.20.20.0/24, on which OSPF runs and associate the area ID 0 with them. |
R3(config-router)#network 3.3.3.3/32 area 0 | Define the interfaces 3.3.3.3/32, on which OSPF runs and associate the area ID 0 with them. |
R3(config-router)#commit | Commit the transaction. |
R1#configure terminal | Enter configure mode. |
R1(config)#interface xe1 | Specify the interface xe1 to be configured. |
R1(config-if)#ip address 10.10.10.1/24 | Assign IP address 10.10.10.1/24 to interface. |
R1(config-if)#label-switching | Enable label switching on interface xe1. |
R1(config-if)#exit | Exit interface mode. |
R1(config)#interface lo | Specify the loopback interface to be configured. |
R1(config-if)#ip address 1.1.1.1/32 secondary | Set the IP address of the loopback interface to 1.1.1.1/32. |
R1(config-if)#commit | Commit the transaction. |
R1(config)#router ldp | Enter Router mode for LDP. |
R1(config-router)#router-id 1.1.1.1 | Set the router ID to IP address 1.1.1.1. |
R1(config-router)#transport-address ipv4 1.1.1.1 | Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter ipv6 if you are configuring an IPv6 interface. |
R1(config-router)#targeted-peer ipv4 3.3.3.3 | Configure targeted peer. |
R1(config-router)#neighbor all tcp-mss 700 | Configure the TCP MSS value with all neighbor. |
R1(config-router-targeted-peer)#exit | Exit-targeted-peer-mode. |
R1(config-router)#exit | Exit the Router mode and return to the Configure mode. |
R1(config)#interface xe1 | Enter interface mode xe1. |
R1(config-if)#enable-ldp ipv4 | Enable LDP on xe1. |
R1(config-if)#commit | Commit the transaction. |
R1(config)#router ospf 100 | Configure the routing process and specify the process ID (100). The process ID should be a unique positive integer identifying the routing process. |
R1(config-router)#network 10.10.10.0/24 area 0 | Define the interface 10.10.10.0/24, on which OSPF runs and associate the area ID (0) with the interface. |
R1(config-router)#network 1.1.1.1/32 area 0 | Define the interface 1.1.1.1/32, on which OSPF runs and associate the area ID (0) with the interface. |
R1(config-router)#commit | Commit the transaction. |
R2#configure terminal | Enter configure mode. |
R2(config)#interface lo | Specify the loopback (lo) interface to be configured. |
R2(config-if)#ip address 2.2.2.2/32 secondary | Set the IP address of the loopback interface to 2.2.2.2/32. |
R2(config-if)#exit | Exit interface mode. |
R2(config)#interface xe1 | Specify the interface xe1 to be configured. |
R2(config-if)#ip address 20.20.20.1/24 | Assign IP address 20.20.20.1/24 to interface. |
R2(config-if)#label-switching | Enable label switching on interface xe1. |
R2(config-if)#exit | Exit interface mode. |
R2(config)#interface xe2 | Specify the interface xe2 to be configured. |
R2(config-if)#ip address 10.10.10.2/24 | Assign IP address 10.10.10.2/24 to interface. |
R2(config-if)#label-switching | Enable label switching on interface xe2. |
R2(config-if)#commit | Commit the transaction. |
R2(config)#router ldp | Enter Router mode. |
R2(config-router)#router-id 2.2.2.2 | Set the router ID to IP address 2.2.2.2. |
R2(config-router)#transport-address ipv4 2.2.2.2 | Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter ipv6 if you are configuring an IPv6 interface. |
R2(config-router)#neighbor all tcp-mss 710 | Configure the TCP MSS value with all neighbor. |
R2(config-router)#exit | Exit Router mode and return to configure mode. |
R2(config)#interface xe1 | Specify the interface xe1 to be configured. |
R2(config-if)#enable-ldp ipv4 | Enable LDP on a specified interface xe1. |
R2(config-if)#exit | Exit interface mode. |
R2(config)#interface xe2 | Specify the interface xe2 to be configured. |
R2(config-if)#enable-ldp ipv4 | Enable LDP on a specified interface xe2. |
R2(config-if)#commit | Commit the transaction. |
R2(config)#router ospf 100 | Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process. |
R2(config-router)#network 10.10.10.0/24 area 0 | Define the interfaces 10.10.10.0/24, on which OSPF runs and associate the area ID (0) with them. |
R2(config-router)#network 20.20.20.0/24 area 0 | Define the interfaces 20.20.20.0/24, on which OSPF runs and associate the area ID (0) with them. |
R2(config-router)#network 2.2.2.2/32 area 0 | Define the interfaces 2.2.2.2/32, on which OSPF runs and associate the area ID (0) with them. |
R2(config-router)#commit | Commit the transaction. |
R3#configure terminal | Enter configure mode. |
R3(config)#interface lo | Specify the loopback interface to be configured. |
R3(config-if)#ip address 3.3.3.3/32 secondary | Set the IP address of the loopback interface to 3.3.3.3/32. |
R3(config-if)#exit | Exit interface mode. |
R3(config)#interface xe1 | Specify the interface xe1 to be configured. |
R3(config-if)#ip address 20.20.20.2/24 | Set the IP address of the interface to 20.20.20.2/24. |
R3(config-if)#label-switching | Enable label switching on interface xe1. |
R3(config-if)#commit | Commit the transaction. |
R3(config)#router ldp | Enter Router mode. |
R3(config-router)#router-id 3.3.3.3 | Set the router ID for IP address 3.3.3.3. |
R3(config-router)#transport-address ipv4 3.3.3.3 | Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter ipv6 if you are configuring an IPv6 interface. |
R3(config-router)#neighbor all tcp-mss 720 | Configure the TCP MSS value with all neighbor. |
R3(config-router)#targeted-peer ipv4 1.1.1.1 | Configure targeted peer. |
R3(config-router-targeted-peer)#exit | Exit-targeted-peer-mode. |
R3(config-router)#exit | Exit the Router mode and return to the Configure mode. |
R3(config)#interface xe1 | Enter interface mode. |
R3(config-if)#enable-ldp ipv4 | Enable LDP on xe1. |
R3(config-if)#commit | Commit the transaction. |
R3(config)#router ospf 100 | Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process. |
R3(config-router)#network 20.20.20.0/24 area 0 | Define the interfaces 20.20.20.0/24, on which OSPF runs and associate the area ID (0) with them. |
R3(config-router)#network 3.3.3.3/32 area 0 | Define the interfaces 3.3.3.3/32, on which OSPF runs and associate the area ID (0) with them. |
R3(config-router)#commit | Commit the transaction. |
R1#configure terminal | Enter configure mode. |
R1(config)#interface xe1 | Specify the interface xe1 to be configured. |
R1(config-if)#ip address 10.10.10.1/24 | Assign IP address 10.10.10.1/24 to interface. |
R1(config-if)#label-switching | Enable label switching on interface xe1. |
R1(config-if)#exit | Exit interface mode. |
R1(config)#interface lo | Specify the loopback interface to be configured. |
R1(config-if)#ip address 1.1.1.1/32 secondary | Set the IP address of the loopback interface to 1.1.1.1/32. |
R1(config-if)#commit | Commit the transaction. |
R1(config)#router ldp | Enter Router mode for LDP. |
R1(config-router)#router-id 1.1.1.1 | Set the router ID to IP address 1.1.1.1. |
R1(config-router)#transport-address ipv4 1.1.1.1 | Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter ipv6 if you are configuring an IPv6 interface. |
R1(config-router)#targeted-peer ipv4 3.3.3.3 | Configure targeted peer. |
R1(config-router-targeted-peer)#exit | Exit-targeted-peer-mode. |
R1(config-router)#exit | Exit the Router mode and return to the configure mode. |
R1(config)#interface xe1 | Enter interface mode. |
R1(config-if)#enable-ldp ipv4 | Enable LDP on xe1. |
R1(config-if)#commit | Commit the transaction. |
R1(config)#router ospf 100 | Configure the routing process and specify the process ID (100). The process ID should be a unique positive integer identifying the routing process. |
R1(config-router)#network 10.10.10.0/24 area 0 | Define the interface 10.10.10.0/24, on which OSPF runs and associate the area ID (0) with the interface. |
R1(config-router)#network 1.1.1.1/32 area 0 | Define the interface 1.1.1.1/32, on which OSPF runs and associate the area ID (0) with the interface. |
R1(config-router)#commit | Commit the transaction. |
R2#configure terminal | Enter configure mode. |
R2(config)#interface lo | Specify the loopback interface to be configured. |
R2(config-if)#ip address 2.2.2.2/32 secondary | Set the IP address of the loopback interface to 2.2.2.2/32. |
R2(config-if)#exit | Exit interface mode. |
R2(config)#interface xe1 | Specify the interface xe1 to be configured. |
R2(config-if)#ip address 20.20.20.1/24 | Assign IP address 20.20.20.1/24 to interface. |
R2(config-if)#label-switching | Enable label switching on interface xe1. |
R2(config-if)#exit | Exit interface mode. |
R2(config)#interface xe2 | Specify the interface xe2 to be configured. |
R2(config-if)#ip address 10.10.10.2/24 | Assign IP address 10.10.10.2/24 to interface. |
R2(config-if)#label-switching | Enable label switching on interface xe2. |
R2(config-if)#commit | Commit the transaction. |
R2(config)#router ldp | Enter Router mode. |
R2(config-router)#router-id 2.2.2.2 | Set the router ID to IP address 2.2.2.2. |
R2(config-router)#transport-address ipv4 2.2.2.2 | Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter ipv6 if you are configuring an IPv6 interface. |
R2(config-router)#neighbor auto-targeted tcp-mss 800 | Configure the TCP MSS value on all auto-targeted neighbors. |
R2(config-router)#exit | Exit Router mode and return to configure mode. |
R2(config)#interface xe1 | Specify the interface xe1 to be configured. |
R2(config-if)#enable-ldp ipv4 | Enable LDP on a specified interface xe1. |
R2(config-if)#exit | Exit interface mode. |
R2(config)#interface xe2 | Specify the interface xe2 to be configured. |
R2(config-if)#enable-ldp ipv4 | Enable LDP on a specified interface xe2. |
R2(config-if)#commit | Commit the transaction. |
R2(config)#router ospf 100 | Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process. |
R2(config-router)#network 10.10.10.0/24 area 0 | Define the interfaces 10.10.10.0/24, on which OSPF runs and associate the area ID (0) with them. |
R2(config-router)#network 20.20.20.0/24 area 0 | Define the interfaces 20.20.20.0/24, on which OSPF runs and associate the area ID (0) with them. |
R2(config-router)#network 2.2.2.2/32 area 0 | Define the interfaces 2.2.2.2/32, on which OSPF runs and associate the area ID (0) with them. |
R2(config-router)#commit | Commit the transaction. |
R3#configure terminal | Enter configure mode. |
R3(config)#interface lo | Specify the loopback interface to be configured. |
R3(config-if)#ip address 3.3.3.3/32 secondary | Set the IP address of the loopback interface to 3.3.3.3/32. |
R3(config-if)#exit | Exit interface mode. |
R3(config)#interface xe1 | Specify the interface xe1 to be configured. |
R3(config-if)#ip address 20.20.20.2/24 | Set the IP address of the interface to 20.20.20.2/24. |
R3(config-if)#label-switching | Enable label switching on interface xe1. |
R3(config-if)#commit | Commit the transaction. |
R3(config)#router ldp | Enter Router mode. |
R3(config-router)#router-id 3.3.3.3 | Set the router ID for IP address 3.3.3.3. |
R3(config-router)#transport-address ipv4 3.3.3.3 | Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface. Note: It is preferable to use the loopback address as transport address. In addition, use the parameter ipv6 if you are configuring an IPv6 interface. |
R3(config-router)#neighbor auto-targeted tcp-mss 810 | Configure the TCP MSS value on all auto-targeted neighbors. |
R3(config-router)#targeted-peer ipv4 1.1.1.1 | Configure targeted peer. |
R3(config-router-targeted-peer)#exit | Exit-targeted-peer-mode. |
R3(config-router)#exit | Exit the Router mode and return to the configure mode. |
R3(config)#interface xe1 | Enter interface mode xe1. |
R3(config-if)#enable-ldp ipv4 | Enable LDP on xe1. |
R3(config-if)#commit | Commit the transaction. |
R3(config)#router ospf 100 | Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process. |
R3(config-router)#network 20.20.20.0/24 area 0 | Define the interfaces 20.20.20.0/24, on which OSPF runs and associate the area ID (0) with them. |
R3(config-router)#network 3.3.3.3/32 area 0 | Define the interfaces 3.3.3.3/32, on which OSPF runs and associate the area ID (0) with them. |
R3(config-router)#commit | Commit the transaction. |
Acronym | Description |
ACK | Acknowledgment |
IGP | Interior Gateway Protocol |
LDP | Label Distribution Protocol |
MSS | Maximum Segment Size |
MTU | Maximum Transmission Unit |
OSPF | Open Short Path First |
SYN | Synchronize |
TCP | Transmission Control Protocol |
LDP | LDP is a routing protocol that manages and distributes the labels to the route in a Multiprotocol Label Switching (MPLS) network. Adding a label to a route helps to control the flow of network traffic and increases the forwarding speed, ensuring a smooth and optimized data transmission. |
LDP session | LDP session is the connection established between LDP routers in an MPLS network. |
MSS | MSS is a TCP parameter that defines the maximum amount of data in a TCP segment that can be transmitted. |
TCP | TCP is one of the main protocols in the Internet Protocol (IP) suite. It offers a secure and reliable connection between two devices. |
TCP segment | TCP segment is a unit of data transmitted in a TCP connection. The segment consists of header and payload. The header contains the control information to manage the transmission, and the payload contains the actual data that needs to be transmitted. |