Anycast Gateway Routing for Multiple Subnets in EVPN-IRB
Overview
In the Ethernet VPN Integrated Routing and Bridging (EVPN-IRB) scenario, any two Layer 2 Virtual Network Identifiers (L2 VNID) nodes communicate using the Routing IP Virtual Routing and Forwarding (VRF). This communication is enriched with Anycast Gateway Routing to accommodate communication among multiple subnets under the IRB interface (per VNID).
In the current implementation, the router’s primary IPv4 or IPv6 address is either Router Media Access Control (MAC) or Anycast MAC, and the secondary IPv4 or IPv6 address is always the Router MAC address. Hence, Anycast MAC support was only for the primary IP with a single subnet.
Additionally, the BGP router cannot establish a connection with the primary IP as it is in Anycast mode, and the TCP connection is possible only with any of the routers, as both the routes have the IP as Anycast.
To overcome this drawback, the feature is enhanced to configure both Router MAC or Anycast MAC for both primary and secondary subnets.
By default, each subnet uses the Router MAC address received from the ARP/ND cache. The anycast argument in evpn irb-if forwarding anycast gateway CLI is used to configure the Anycast MAC for primary or secondary subnets. The argument helps to update the ARP/ND cache with Anycast MAC. This enables the user to use Anycast MAC for multiple subnets under L2 VNID. For example, users can have Subnets A, B, C with Anycast MAC and Subnet D with Router MAC.
Feature Characteristics
This feature enhancement provides the following support:
• Enables configuration of either a Router MAC or an Anycast MAC address for primary or secondary subnets.
• Use of Anycast or Routing IP Gateway for multiple subnets under the Layer-2 VNID's.
• Flexibility to have Anycast Gateway for multiple subnets (for example, Subnet A, B, and C) while allowing the other subnet (for example, Subnet D) to be reserved for BGP.
• The InterfaceFull model that provides the flexibility to respond to the ARP/ND requests from the ARP/ND table.
• The InterfaceLess model that use the kernel interface with a unique MAC per interface, either Router MAC or Anycast MAC for all the subnets.
LIMITATIONS:
In InterfaceLess model, the kernel IRB interface has a single MAC that is either Router MAC or Anycast MAC, however, the response message always has Anycast MAC irrespective of whether the interface’s IP address is Anycast or Router MAC.
Benefits
Allows users to have primary and secondary subnets with either Router MAC or Anycast MAC. This flexibility provides support for Anycast Gateway for multiple subnets under Layer 2 VNIDs.
Configuration
Following configuration illustrates how to use the anycast argument in evpn irb-if forwarding anycast gateway CLI to configure the Anycast MAC for both primary or secondary subnets.
Topology
Anycast Gateway support for subnets
PE1 Configuration
PE1: Loopback Interface
PE1(config)#interface lo | Enter the loopback interface mode. |
PE1(config-if)#ip address 22.22.22.22/32 secondary | Configure the IP address on loopback interface. |
PE1(config-if)#ip router isis ISIS-100 | Enable the IS-IS routing on an interface for area 49 (ISIS-100). |
PE1(config-if)#enable-ldp ipv4 | Enable the LDP IPv4. |
PE1(config-if)#Commit | Commit the configurations |
PE1(config-if)#exit | Exit the configuration mode. |
PE1: Global LDP
PE1(config)#router ldp | Enter the Router LDP mode. |
PE1(config-router)#router-id 22.22.22.22 | Enter the LDP router-id. |
PE1(config-router)#targeted-peer ipv4 29.29.29.29 | Configure the LDP target peer address. |
PE1(config-router-targeted-peer)#exit-targeted-peer-mode | Exit from targeted peer mode. |
PE1(config-router)#transport-address ipv4 22.22.22.22 | Configure the LDP transport address. |
PE1(config-router)#Commit | Commit the configurations |
PE1(config-router)#exit | Exit the configuration mode. |
PE1: Interface Configuration on Network Side
PE1(config)#interface po1 | Enter the Interface mode for the port channel interface |
PE1(config-if)#ip address 10.1.1.22/24 | Configure the IP address on port channel interface |
PE1(config-if)#label-switching | Enable the label switching |
PE1(config-if)#ip router isis ISIS-100 | Enable the IS-IS routing on an interface for area 49 (ISIS-100) |
PE1(config-if)#enable-ldp ipv4 | Enable the LDP IPv4 |
PE1(config-if)#interface xe22 | Enter interface mode |
PE1(config-if)#channel-group 1 mode active | Moving interface to Dynamic LAG 1 |
PE1(config-if)#Commit | Commit the configurations |
PE1(config-if)#exit | Exit the configuration mode. |
PE1: IGP-ISIS Configuration
PE1(config)#router isis ISIS-100 | Create an ISIS routing instance for area 49 (ISIS-100). |
PE1(config-router)#is-type level-1 | Configure instance as level-1 routing. |
PE1(config-router)#metric-style wide | Configure the new style of metric type as wide. |
PE1(config-router)#mpls traffic-eng router-id 22.22.22.22 | Configure MPLS-TE unique router-id TLV. |
PE1(config-router)#mpls traffic-eng level-1 | Enable the MPLS-TE in is-type Level-1. |
PE1(config-router)#capability cspf | Enable the Constrained Shortest Path First (CSPF). |
PE1(config-router)#dynamic-hostname | Configure the host name to be advertised for an ISIS instance. |
PE1(config-router)#net 49.0001.0000.0000.0001.00 | Set a Network Entity Title for this instance, specifying the area address and the system ID. |
PE1(config-router)#Commit | Commit the configurations |
PE1(config-router)#exit | Exit the configuration mode. |
PE1: BGP Configuration
PE1(config)#router bgp 65535 | Enter into Router BGP mode. |
PE1(config-router)#bgp router-id 22.22.22.22 | Configure router-id as 22.22.22.22 (loopback ip address). |
PE1(config-router)#neighbor 29.29.29.29 remote-as 65535 | Configuring PE2 as iBGP neighbor using it's loopback IP. |
PE1(config-router)#neighbor 29.29.29.29 update- source lo | Source of routing updates as loopback. |
PE1(config-router)#neighbor 29.29.29.29 advertisement-interval 0 | Configure advertisement-interval as 0 for fast convergence for PE2 |
PE1(config-router)#address-family l2vpn evpn | Enter into l2vpn EVPN address family mode. |
PE1(config-router-af)#neighbor 29.29.29.29 active | Enabling EVPN Address family for neighbor. |
PE1(config-router-af)#exit-address-family | Exiting of Address family mode. |
PE1(config-router)#address-family ipv4 vrf ip_vrf205_mgmt | Entering into VRF address family mode. |
PE1(config-router-af)#redistribute connected | Redistribute connected routes to the network. |
PE1(config-router-af)#exit-address-family | Exiting of Address family mode. |
PE1(config-router)#Commit | Commit the configurations |
PE1(config-router)#exit | Exit the configuration mode. |
PE1: Global EVPN MPLS Command
PE1(config)#evpn mpls enable | Enable the EVPN MPLS globally. |
PE1(config)#evpn mpls irb | Enable the EVPN MPLS IRB globally. |
PE1(config)#evpn mpls multihoming enable | Enable the Multi homing, save configures and reboot the board for multi homing to be effective. |
PE1(config)#qos enable | Enable the QOS. |
PE1(config)#evpn irb-forwarding anycast-gateway-mac 0011.2233.4455 | Configure anycast gateway MAC globally. |
PE1(config)#evpn mpls vtep-ip-global 22.22.22.22 | Configure VTEP global IP. |
PE1(config)#Commit | Commit the configurations |
PE1(config)#exit | Exit the configuration mode. |
PE1: MAC VRF Configuration
PE1(config)#mac vrf vrf205_mgmt | Enter Mac VRF mode. |
PE1(config-vrf)#rd 22.22.22.22:205 | Configuring Route-Distinguisher value. |
PE1(config-vrf)#route-target both evpn-auto-rt | Configuring import and export value as evpn-auto-rt. Route targets will be derived automatically. |
PE1(config-vrf)#Commit | Commit the configurations |
PE1(config-vrf)#exit | Exit the configuration mode. |
PE1: IP VRF Configuration
PE1(config)#ip vrf ip_vrf205_mgmt | Enter IP VRF mode |
PE1(config-vrf)#rd 22.22.22.22:305 | Configuring Route-Distinguisher value |
PE1(config-vrf)#route-target both 305:305 | Configuring route target values i.e import and export values |
PE1(config-vrf)#l3vni 305 | Configure L3 VNID for routing |
PE1(config-vrf)#Commit | Commit the configurations |
PE1(config-vrf)#exit | Exit the configuration mode. |
PE1: IRB Interface Configuration with multiple IPs
PE1(config)#interface irb127 | Create IRB interface irb127 |
PE1(config-irb-if)#ip vrf forwarding ip_vrf205_mgmt | Bind the VRF instance to the interface |
PE1(config-irb-if)#evpn irb-if-forwarding anycast-gateway-mac | Enable an IRB interface to use the global anycast IRB mac- address |
PE1(config-irb-if)#ip address 98.98.101.1/24 anycast | Configure the IPv4 primary address and use anycast mac address |
PE1(config-irb-if)#ip address 103.103.102.1/24 secondary | Configure secondary IPv4 secondary address |
PE1(config-irb-if)#ip address 104.104.103.1/24 secondary anycast | Configure secondary IPv4 secondary address and use as anycast mac address |
PE1(config-irb-if)#Commit | Commit the configurations |
PE1(config-irb-if)#exit | Exit the configuration mode. |
PE1: EVPN MPLS Id Configuration
PE1(config)#evpn mpls id 127 | Configure secondary IPv4 secondary address |
PE1(config-evpn-mpls)#host-reachability-protocol evpn-bgp vrf205_mgmt | Map the MAC VRF red |
PE1(config-evpn-mpls)#evpn irb irb127 | Map the IRB interface |
PE1(config-evpn-mpls)#commit | Commit the configurations |
PE1(config-evpn-mpls)#exit | Exit the configuration mode. |
PE1: Interface Configuration on Access Side
PE1(config)#interface xe72.127 switchport | Creating L2 sub interface of physical interface xe72 |
PE1(config-if)#encapsulation dot1q 127 | Setting Encapsulation to dot1q with VLAN ID 127 Supported Encapsulation: dot1ad, dot1q, untagged, default |
PE1(config-if)#rewrite pop | Configure rewrite with action pop |
PE1(config-if)#access-if-evpn | Entering Access mode for EVPN MPLS ID configuration |
PE1(config-acc-if-evpn)#map vpn-id 127 | Map VPN-ID 127 |
PE1(config-acc-if-evpn)#Commit | Commit the configurations |
PE1(config-acc-if-evpn)#exit | Exit the configuration mode. |
P Configuration
P: Loopback Interface
P(config)#interface lo | Enter the Interface mode for the loopback interface. |
P(config-if)#ip address 8.8.8.8/32 secondary | Configure the IP address on loopback interface. |
P(config-if)#ip router isis ISIS-100 | Enable the IS-IS routing on an interface for area 49 (ISIS-100). |
P(config-if)#enable-ldp ipv4 | Enable the LDP IPv4. |
P(config-if)#Commit | Commit the configurations |
P(config-if)#exit | Exit the configuration mode. |
P: Global LDP
P(config)#router ldp | Enter the Router LDP mode. |
P(config-router)#router-id 8.8.8.8 | Enter the LDP router-id. |
P(config-router)#transport-address ipv4 8.8.8.8 | Configure the LDP transport address. |
P(config-router)#Commit | Commit the configurations |
P(config-router)#exit | Exit the configuration mode. |
P: Interface Configuration on Network Side
P(config)#interface po1 | Enter the Interface mode for the port channel interface. |
P(config-if)#ip address 10.1.1.8/24 | Configure the IP address on port channel interface. |
P(config-if)#label-switching | Enable the label switching. |
P(config-if)#ip router isis ISIS-100 | Enable the IS-IS routing on an interface for area 49 (ISIS-100). |
P(config-if)#enable-ldp ipv4 | Enable the LDP IPv4. |
P(config-if)#Commit | Commit the configurations |
P(config-if)#exit | Exit the configuration mode. |
P(config)#interface xe22 | Enter interface mode. |
P(config-if)#channel-group 1 mode active | Moving interface to Dynamic LAG 1. |
P(config-if)#Commit | Commit the configurations |
P(config-if)#exit | Exit the configuration mode. |
P(config)#interface po10 | Enter the Interface mode for the port channel interface. |
P(config-if)#ip address 10.1.3.8/24 | Configure the IP address on port channel interface. |
P(config-if)#label-switching | Enable the label switching. |
P(config-if)#ip router isis ISIS-100 | Enable the IS-IS routing on an interface for area 49 (ISIS-100). |
P(config-if)#enable-ldp ipv4 | Enable the LDP IPv4. |
P(config-if)#interface xe10 | Enter interface mode. |
P(config-if)#channel-group 10 mode active | Moving interface to Dynamic LAG 10. |
P(config-if)#Commit | Commit the configurations |
P(config-if)#exit | Exit the configuration mode. |
P: IGP-ISIS Configuration
P(config)#router isis ISIS-100 | Create an IS-IS routing instance for area 49 (ISIS-100). |
P(config-router)#is-type level-1 | Configure the instance as level-1 routing. |
P(config-router)#metric-style wide | Configure the new style of metric type as wide. |
P(config-router)#mpls traffic-eng router-id 8.8.8.8 | Configure MPLS-TE unique router-id TLV. |
P(config-router)#mpls traffic-eng level-1 | Enable the MPLS-TE in is-type Level-1. |
P(config-router)#capability cspf | Enable the CSPF (Constrained Shortest Path First). |
P(config-router)#dynamic-hostname | Configure the hostname to be advertised for an ISIS instance. |
P(config-router)#net 49.0001.0000.0000.0002.00 | Set a Network Entity Title for this instance, specifying the area address and the system ID. |
P(config-router)#Commit | Commit the configurations |
P(config-router)#exit | Exit the configuration mode. |
PE2 Configuration
PE2: Loopback Interface
PE2(config)#interface lo | Enter the Interface mode for the loopback interface. |
PE2(config-if)#ip address 29.29.29.29/32 secondary | Configure the IP address on loopback interface. |
PE2(config-if)#ip router isis ISIS-100 | Enable the IS-IS routing on an interface for area 49 (ISIS-100). |
PE2(config-if)#enable-ldp ipv4 | Enable the LDP IPv4. |
PE2(config-if)#Commit | Commit the configurations |
PE2(config-if)#exit | Exit the configuration mode. |
PE2: Global LDP
PE2(config)#router ldp | Enter the Router LDP mode. |
PE2(config-router)#router-id 29.29.29.29 | Enter the LDP router-id. |
PE2(config-router)#targeted-peer ipv4 22.22.22.22 | Configure the LDP target peer address. |
PE2(config-router-targeted-peer)#exit-targeted-peer-mode | Exit from targeted peer mode. |
PE2(config-router)#transport-address ipv4 29.29.29.29 | Configure the LDP transport address. |
PE2(config-router)#Commit | Commit the configurations |
PE2(config-router)#exit | Exit the configuration mode. |
PE2: Global LDP
PE2(config)#router ldp | Enter the Router LDP mode. |
PE2(config-router)#router-id 29.29.29.29 | Enter the LDP router-id. |
PE2(config-router)#targeted-peer ipv4 22.22.22.22 | Configure the LDP target peer address. |
PE2(config-router-targeted-peer)#exit-targeted-peer-mode | Exit from targeted peer mode. |
PE2(config-router)#transport-address ipv4 29.29.29.29 | Configure the LDP transport address. |
PE2(config-router)#Commit | Commit the configurations |
PE2(config-router)#exit | Exit the configuration mode. |
PE2: Interface Configuration on Network Side
PE2(config)#interface po10 | Enter the Interface mode for the port channel interface. |
PE2(config-if)#ip address 10.1.3.29/24 | Configure the IP address on port channel interface. |
PE2(config-if)#label-switching | Enable the label switching. |
PE2(config-if)#ip router isis ISIS-100 | Enable the IS-IS routing on an interface for area 49 (ISIS-100). |
PE2(config-if)#enable-ldp ipv4 | Enable the LDP IPv4. |
PE2(config-if)#interface ge1 | Enter interface mode. |
PE2(config-if)#channel-group 10 mode active | Moving interface to Dynamic LAG 10. |
PE2(config-if)#Commit | Commit the configurations |
PE2(config-if)#exit | Exit the configuration mode. |
PE2: IGP-ISIS Configuration
PE2(config)#router isis ISIS-100 | Create an IS-IS routing instance for area 49 (ISIS-100). |
PE2(config-router)#is-type level-1 | Configure instance as level-1 routing. |
PE2(config-router)#metric-style wide | Configure the new style of metric type as wide. |
PE2(config-router)#mpls traffic-eng router-id 29.29.29.29 | Configure MPLS-TE unique router-id TLV. |
PE2(config-router)#mpls traffic-eng level-1 | Enable the MPLS-TE in is-type Level-1. |
PE2(config-router)#capability cspf | Enable the CSPF (Constrained Shortest Path First). |
PE2(config-router)#dynamic-hostname | Configure the hostname to be advertised for an ISIS instance. |
PE2(config-router)#net 49.0001.0000.0000.0029.00 | Set a Network Entity Title for this instance, specifying the area address and the system ID. |
PE2(config-router)#Commit | Commit the configurations |
PE2(config-router)#exit | Exit the configuration mode. |
PE2: BGP Configuration
PE2(config)#router bgp 65535 | Enter into Router BGP mode. |
PE2(config-router)#bgp router-id 29.29.29.29 | Configure router-id as 29.29.29.29 (loopback ip address). |
PE2(config-router)#neighbor 22.22.22.22 remote-as 65535 | Configuring PE2 as iBGP neighbor using it's loopback IP. |
PE2(config-router)#neighbor 22.22.22.22 update- source lo | Source of routing updates as loopback. |
PE2(config-router)#neighbor 22.22.22.22 advertisement-interval 0 | Configure advertisement-interval as 0 for fast convergence for PE2. |
PE2(config-router)#address-family l2vpn evpn | Enter into l2vpn EVPN address family mode. |
PE2(config-router-af)#neighbor 22.22.22.22 active | Enabling EVPN Address family for neighbor. |
PE2(config-router-af)#exit-address-family | Exiting of Address family mode. |
PE2(config-router)#address-family ipv4 vrf ip_vrf205_mgmt | Entering into VRF address family mode. |
PE2(config-router-af)#redistribute connected | Redistribute connected routes to the network. |
PE2(config-router-af)#exit-address-family | Exiting of Address family mode. |
PE2(config-router-af)#commit | Commit the configurations |
PE2(config-router-af)#exit | Exit the configuration mode. |
PE2: Global EVPN MPLS Command
PE2(config)#evpn mpls enable | Enable the EVPN MPLS globally. |
PE2(config)#evpn mpls irb | Enable the EVPN MPLS IRB globally. |
PE2(config)#evpn mpls multihoming enable | Enable the Multihoming, save configs and reboot the board for multihoming to be effective. |
PE2(config)#qos enable | Enable the QOS. |
PE2(config)#evpn irb-forwarding anycast-gateway-mac 0011.2233.4567 | Configure anycast gateway MAC globally. |
PE2(config)#evpn mpls vtep-ip-global 29.29.29.29 | Configure VTEP global IP. |
PE2(config)#Commit | Commit the configurations |
PE2(config)#exit | Exit the configuration mode. |
PE2: MAC VRF Configuration
PE2(config)#mac vrf vrf205_mgmt | Enter Mac VRF mode. |
PE2(config-vrf)#rd 29.29.29.29:205 | Configuring Route-Distinguisher value. |
PE2(config-vrf)#route-target both evpn-auto-rt | Configuring import and export value as evpn-auto-rt. Route target will be derived automatically. |
PE2(config-vrf)#Commit | Commit the configurations |
PE2(config-vrf#exit | Exit the configuration mode. |
PE2: IP VRF Configuration
PE2(config)#ip vrf ip_vrf205_mgmt | Enter IP VRF mode. |
PE2(config-vrf)#rd 29.29.29.29:305 | Configuring Route-Distinguisher value. |
PE2(config-vrf)#route-target both 305:305 | Configuring route target values i.e import and export values. |
PE2(config-vrf)#l3vni 305 | Configure L3 VNID for routing. |
PE2(config-vrf)#Commit | Commit the configurations |
PE2(config-vrf)#exit | Exit the configuration mode. |
PE2: IRB Interface Configuration with multiple IPs
PE2(config)#interface irb127 | Create IRB interface irb127. |
PE2(config-irb-if)#ip vrf forwarding ip_vrf205_mgmt | Bind the VRF instance to the interface. |
PE2(config-irb-if)#evpn irb-if-forwarding anycast-gateway-mac | Enable an IRB interface to use the global anycast IRB mac- address. |
PE2(config-irb-if)#ip address 99.99.101.1/24 anycast | Configure the IPv4 primary address and use anycast mac address. |
PE2(config-irb-if)#ip address 103.103.103.1/24 secondary | Configure secondary IPv4 secondary address. |
PE2(config-irb-if)#ip address 104.104.104.1/24 secondary anycast | Configure secondary IPv4 secondary address and use as anycast mac address. |
PE2(config-rib-if)#Commit | Commit the configurations |
PE2(config-rib-if)#exit | Exit the configuration mode. |
PE2: EVPN MPLS Id Configuration
PE2(config)#evpn mpls id 127 | Configure secondary IPv4 secondary address. |
PE2(config-evpn-mpls)#host-reachability-protocol evpn-bgp vrf205_mgmt | Map the MAC VRF red. |
PE2(config-evpn-mpls)#evpn irb irb127 | Map the IRB interface. |
PE2(config-evpn-mpls)#commit | Commit the configurations |
PE2(config-evpn-mpls)#exit | Exit the configuration mode. |
PE2: Interface Configuration on Access Side
PE2(config)#interface xe12.127 switchport | Creating L2 sub interface on physical interface xe12. |
PE2(config-if)#encapsulation dot1q 127 | Setting Encapsulation to dot1q with VLAN ID 127 Supported Encapsulation: dot1ad, dot1q, untagged, default. |
PE2(config-if)#rewrite pop | Configure rewrite with action pop. |
PE2(config-if)#access-if-evpn | Entering Access mode for EVPN MPLS ID configuration. |
PE2(config-acc-if-evpn)#map vpn-id 127 | Map VPN-ID 127. |
PE2(config-acc-if-evpn)#Commit | Commit the configurations |
PE2(config-acc-if-evpn)#exit | Exit the configuration mode. |
Validation
Verify installed EVPN MPLS tunnels information.
PE1:
#show evpn mpls
EVPN-MPLS Information
=================
Codes: NW - Network Port
AC - Access Port
(u) - Untagged
VPN-ID EVI-Name EVI-Type Type Interface ESI VLAN DF-Status Src-Addr Dst-Addr
_______________________________________________________________________________________________________________________________
127 ---- L2 NW ---- ---- ---- ---- 22.22.22.22 29.29.29.29
127 ---- -- AC xe72.127 --- Single Homed Port --- ---- ---- ---- ----
PE2:
#show evpn mpls tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update evpn-id
===================================================================================
22.22.22.22 29.29.29.29 Installed 11:40:31 11:40:31 127
Verify the MAC addresses that are cached in the EVPN MAC and ARP table.
Verify the Anycast Gateway MAC addresses that are updated when configuring subnets with Anycast MAC:
PE1 verification:
#show evpn mpls mac-table
=========================================================================================================================================
EVPN MPLS MAC Entries
=========================================================================================================================================
VNID Interface VlanId In-VlanId Mac-Addr VTEP-Ip/ESI Type Status MAC move AccessPortDesc
_________________________________________________________________________________________________________________________________________
127 irb127 ---- ---- 0011.2233.4455 22.22.22.22 Static Local ------- 0 -------
127 irb127 ---- ---- e49d.73b3.c101 22.22.22.22 Static Local ------- 0 -------
127 ---- ---- ---- 0011.2233.4567 29.29.29.29 Static Remote ------- 0 -------
127 ---- ---- ---- e8c5.7aff.96de 29.29.29.29 Static Remote ------- 0 -------
Total number of entries are 4
#show evpn mpls arp-cache
MPLS-EVPN ARP-CACHE Information
===============================
EVPN-ID Ip-Addr Mac-Addr Type Age-Out Retries-Left
_____________________________________________________________________________
127 98.98.101.1 0011.2233.4455 Static Local ----
127 99.99.101.1 0011.2233.4567 Static Remote ----
127 103.103.102.1 e49d.73b3.c101 Static Local ----
127 103.103.103.1 e8c5.7aff.96de Static Remote ----
127 104.104.103.1 0011.2233.4455 Static Local ----
127 104.104.104.1 0011.2233.4567 Static Remote ----
Total number of entries are 6
PE2 verification:
#show evpn mpls mac-table
=========================================================================================================================================
EVPN MPLS MAC Entries
=========================================================================================================================================
VNID Interface VlanId In-VlanId Mac-Addr VTEP-Ip/ESI Type Status MAC move AccessPortDesc
_________________________________________________________________________________________________________________________________________
127 ---- ---- ---- 0011.2233.4455 22.22.22.22 Static Remote ------- 0 -------
127 irb127 ---- ---- 0011.2233.4567 29.29.29.29 Static Local ------- 0 -------
127 ---- ---- ---- e49d.73b3.c101 22.22.22.22 Static Remote ------- 0 -------
127 irb127 ---- ---- e8c5.7aff.96de 29.29.29.29 Static Local ------- 0 -------
Total number of entries are : 4
#show evpn mpls arp-cache
MPLS-EVPN ARP-CACHE Information
===============================
ARP Timeout : 180 sec Random-Jitter-Max : 200
EVPN-ID Ip-Addr Mac-Addr Type Age-Out Retries-Left
_____________________________________________________________________________
127 98.98.101.1 0011.2233.4455 Static Remote ----
127 99.99.101.1 0011.2233.4567 Static Local ----
127 103.103.102.1 e49d.73b3.c101 Static Remote ----
127 103.103.103.1 e8c5.7aff.96de Static Local ----
127 104.104.103.1 0011.2233.4455 Static Remote ----
127 104.104.104.1 0011.2233.4567 Static Local ----
Verify EVPN route count information as per VPN-ID or Route type:
PE1 verification:
#show evpn mpls route-count
EVPN-MPLS Active route count information
====================================
Max supported route count : 131072
Active route count: 8
---------------------------------------------
VNID Total MACONLY MACIPv4 MACIPv6
---------------------------------------------
127 8 0 6 2
PE2 verification:
#show evpn mpls route-count
EVPN-MPLS Active route count information
====================================
Max supported route count : 131072
Active route count: 8
---------------------------------------------
VNID Total MACONLY MACIPv4 MACIPv6
---------------------------------------------
127 8 0 6 2
Verify in the BGP EVPN table:
PE1 Verification:
#show bgp l2vpn evpn
BGP table version is 2, local router ID is 22.22.22.22
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
[EVPN route type]:[ESI]:[VNID]:[relevant route information]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
Network Next Hop Metric LocPrf Weight Path Peer Encap
RD[10:200]
*>i [5]:[0]:[0]:[24]:[80.80.1.0]:[0.0.0.0]:[17]
29.29.29.29 0 100 0 ? 29.29.29.29 MPLS
RD[20:200]
*>i [5]:[0]:[0]:[24]:[80.80.1.0]:[0.0.0.0]:[16]
10.10.10.10 0 100 0 ? 10.10.10.10 MPLS
RD[10.10.10.10:123]
*>i [2]:[0]:[123]:[48,0011:2233:4567]:[32,99.99.99.1]:[22]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*>i [3]:[123]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
RD[10.10.10.10:124]
*>i [2]:[0]:[124]:[48,0011:2233:4567]:[32,99.99.100.1]:[24]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*>i [3]:[124]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
RD[10.10.10.10:125]
*>i [2]:[0]:[125]:[48,0011:2233:4567]:[32,88.88.3.1]:[21]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*>i [3]:[125]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
RD[10.10.10.10:126]
*>i [3]:[126]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
RD[10.10.10.10:205]
*>i [2]:[0]:[127]:[48,0011:2233:4567]:[32,99.99.101.1]:[26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*>i [2]:[0]:[127]:[48,0011:2233:4567]:[32,104.104.104.1]:[26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*>i [2]:[0]:[127]:[48,0011:2233:4567]:[128,1000::1][26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*>i [2]:[0]:[127]:[48,d077:ce2a:8001]:[32,103.103.103.1]:[26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*>i [2]:[0]:[127]:[48,d077:ce2a:8001]:[128,1100::1][26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*>i [3]:[127]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
RD[10.10.10.10:305]
*>i [5]:[0]:[0]:[24]:[99.99.101.0]:[0.0.0.0]:[17]
10.10.10.10 0 100 0 ? 10.10.10.10 MPLS
*>i [5]:[0]:[0]:[24]:[103.103.103.0]:[0.0.0.0]:[17]
10.10.10.10 0 100 0 ? 10.10.10.10 MPLS
*>i [5]:[0]:[0]:[24]:[104.104.104.0]:[0.0.0.0]:[17]
10.10.10.10 0 100 0 ? 10.10.10.10 MPLS
RD[10.10.10.10:333]
*>i [5]:[0]:[0]:[24]:[99.99.99.0]:[0.0.0.0]:[19]
10.10.10.10 0 100 0 ? 10.10.10.10 MPLS
RD[10.10.10.10:334]
*>i [5]:[0]:[0]:[24]:[99.99.100.0]:[0.0.0.0]:[18]
10.10.10.10 0 100 0 ? 10.10.10.10 MPLS
RD[10.10.10.10:500]
*>i [3]:[500]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
RD[22.22.22.22:123] VRF[vrf100_mgmt]:
*> [2]:[0]:[123]:[48,0011:2233:4455]:[32,98.98.98.1]:[25618]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [2]:[0]:[123]:[48,0011:2233:4567]:[32,99.99.99.1]:[28]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
* i 10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [3]:[123]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> [3]:[123]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [3]:[123]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[22.22.22.22:124] VRF[vrf200_mgmt]:
*> [2]:[0]:[124]:[48,0011:2233:4455]:[32,98.98.99.1]:[25619]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [2]:[0]:[124]:[48,0011:2233:4567]:[32,99.99.100.1]:[29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
* i 10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [3]:[124]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> [3]:[124]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [3]:[124]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[22.22.22.22:125] VRF[vrf201_mgmt]:
*> [2]:[0]:[125]:[48,0011:2233:4455]:[32,88.88.1.1]:[25629]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [2]:[0]:[125]:[48,0011:2233:4567]:[32,88.88.3.1]:[37]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
* i 10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [3]:[125]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> [3]:[125]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [3]:[125]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[22.22.22.22:126] VRF[vrf202_mgmt]:
* i [3]:[126]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> [3]:[126]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [3]:[126]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[22.22.22.22:200] VRF[blue]:
*> [2]:[0]:[200]:[48,e49d:73b3:c101]:[32,70.70.1.1]:[25636]
22.22.22.22 0 100 32768 i ---------- MPLS
*> [3]:[200]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
RD[22.22.22.22:205] VRF[vrf205_mgmt]:
*> [2]:[0]:[127]:[48,0011:2233:4455]:[32,98.98.101.1]:[25608]
22.22.22.22 0 100 32768 i ---------- MPLS
*> [2]:[0]:[127]:[48,0011:2233:4455]:[32,104.104.103.1]:[25608]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [2]:[0]:[127]:[48,0011:2233:4567]:[32,99.99.101.1]:[22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
* i 10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [2]:[0]:[127]:[48,0011:2233:4567]:[32,104.104.104.1]:[22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
* i 10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [2]:[0]:[127]:[48,0011:2233:4567]:[128,1000::1][22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
* i 10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [2]:[0]:[127]:[48,d077:ce2a:8001]:[32,103.103.103.1]:[26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [2]:[0]:[127]:[48,d077:ce2a:8001]:[128,1100::1][26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> [2]:[0]:[127]:[48,e49d:73b3:c101]:[32,103.103.102.1]:[25608]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [2]:[0]:[127]:[48,e8c5:7aff:96de]:[32,103.103.103.1]:[22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
* i [2]:[0]:[127]:[48,e8c5:7aff:96de]:[128,1100::1][22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
* i [3]:[127]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> [3]:[127]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [3]:[127]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[22.22.22.22:500] VRF[ELAN_vrf500]:
* i [3]:[500]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> [3]:[500]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [3]:[500]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[22.22.22.22:501] VRF[ELAN_vrf501]:
*> [3]:[501]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [3]:[501]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[22.22.22.22:502] VRF[ELAN_vrf502]:
*> [3]:[502]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [3]:[502]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[22.22.22.22:503] VRF[ELAN_vrf503]:
*> [3]:[503]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [3]:[503]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[22.22.22.22:504] VRF[ELAN_vrf504]:
*> [3]:[504]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [3]:[504]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[22.22.22.22:505] VRF[ELAN_vrf505]:
*> [3]:[505]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [3]:[505]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[22.22.22.22:506] VRF[ELAN_vrf506]:
*> [3]:[506]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [3]:[506]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[22.22.22.22:507] VRF[ELAN_vrf507]:
*> [3]:[507]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [3]:[507]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[22.22.22.22:508] VRF[ELAN_vrf508]:
*> [3]:[508]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [3]:[508]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[22.22.22.22:509] VRF[ELAN_vrf509]:
*> [3]:[509]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [3]:[509]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[22.22.22.22:510] VRF[ELAN_vrf510]:
*> [3]:[510]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [3]:[510]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[22.22.22.22:600] VRF[eline600]:
*> [1]:[0]:[600]:[25628]
22.22.22.22 0 100 32768 i ---------- MPLS
RD[22.22.22.22:602] VRF[eline602]:
*> [1]:[0]:[602]:[25635]
22.22.22.22 0 100 32768 i ---------- MPLS
RD[22.22.22.22:604] VRF[eline604]:
*> [1]:[0]:[604]:[25631]
22.22.22.22 0 100 32768 i ---------- MPLS
RD[22.22.22.22:606] VRF[eline606]:
*> [1]:[0]:[606]:[25634]
22.22.22.22 0 100 32768 i ---------- MPLS
RD[22.22.22.22:608] VRF[eline608]:
*> [1]:[0]:[608]:[25613]
22.22.22.22 0 100 32768 i ---------- MPLS
RD[22.22.22.22:610] VRF[eline610]:
*> [1]:[0]:[610]:[25626]
22.22.22.22 0 100 32768 i ---------- MPLS
RD[22.22.22.22:612] VRF[eline612]:
*> [1]:[0]:[612]:[25632]
22.22.22.22 0 100 32768 i ---------- MPLS
RD[22.22.22.22:614] VRF[eline614]:
*> [1]:[0]:[614]:[25625]
22.22.22.22 0 100 32768 i ---------- MPLS
RD[22.22.22.22:616] VRF[eline616]:
*> [1]:[0]:[616]:[25612]
22.22.22.22 0 100 32768 i ---------- MPLS
RD[22.22.22.22:618] VRF[eline618]:
*> [1]:[0]:[618]:[25617]
22.22.22.22 0 100 32768 i ---------- MPLS
RD[22.22.22.22:620] VRF[eline620]:
*> [1]:[0]:[620]:[25638]
22.22.22.22 0 100 32768 i ---------- MPLS
RD[22.22.22.22:2002] VRF[vrf2002]:
*> [1]:[0]:[2224]:[25630]
22.22.22.22 0 100 32768 i ---------- MPLS
RD[22.22.22.22:2003] VRF[vrf2003]:
*> [1]:[0]:[2226]:[25637]
22.22.22.22 0 100 32768 i ---------- MPLS
RD[22.22.22.22:2004] VRF[vrf2004]:
*> [1]:[0]:[2228]:[25633]
22.22.22.22 0 100 32768 i ---------- MPLS
RD[22.22.22.22:2005] VRF[vrf2005]:
*> [1]:[0]:[2300]:[25639]
22.22.22.22 0 100 32768 i ---------- MPLS
RD[29.29.29.29:123]
*>i [2]:[0]:[123]:[48,0011:2233:4567]:[32,99.99.99.1]:[28]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
*>i [3]:[123]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[29.29.29.29:124]
*>i [2]:[0]:[124]:[48,0011:2233:4567]:[32,99.99.100.1]:[29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
*>i [3]:[124]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[29.29.29.29:125]
*>i [2]:[0]:[125]:[48,0011:2233:4567]:[32,88.88.3.1]:[37]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
*>i [3]:[125]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[29.29.29.29:126]
*>i [3]:[126]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[29.29.29.29:205]
*>i [2]:[0]:[127]:[48,0011:2233:4567]:[32,99.99.101.1]:[22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
*>i [2]:[0]:[127]:[48,0011:2233:4567]:[32,104.104.104.1]:[22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
*>i [2]:[0]:[127]:[48,0011:2233:4567]:[128,1000::1][22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
*>i [2]:[0]:[127]:[48,e8c5:7aff:96de]:[32,103.103.103.1]:[22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
*>i [2]:[0]:[127]:[48,e8c5:7aff:96de]:[128,1100::1][22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
*>i [3]:[127]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[29.29.29.29:305]
*>i [5]:[0]:[0]:[24]:[99.99.101.0]:[0.0.0.0]:[18]
29.29.29.29 0 100 0 ? 29.29.29.29 MPLS
*>i [5]:[0]:[0]:[24]:[103.103.103.0]:[0.0.0.0]:[18]
29.29.29.29 0 100 0 ? 29.29.29.29 MPLS
*>i [5]:[0]:[0]:[24]:[104.104.104.0]:[0.0.0.0]:[18]
29.29.29.29 0 100 0 ? 29.29.29.29 MPLS
RD[29.29.29.29:333]
*>i [5]:[0]:[0]:[24]:[99.99.99.0]:[0.0.0.0]:[20]
29.29.29.29 0 100 0 ? 29.29.29.29 MPLS
RD[29.29.29.29:334]
*>i [5]:[0]:[0]:[24]:[99.99.100.0]:[0.0.0.0]:[19]
29.29.29.29 0 100 0 ? 29.29.29.29 MPLS
RD[29.29.29.29:500]
*>i [3]:[500]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[29.29.29.29:501]
*>i [3]:[501]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[29.29.29.29:502]
*>i [3]:[502]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[29.29.29.29:503]
*>i [3]:[503]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[29.29.29.29:504]
*>i [3]:[504]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[29.29.29.29:505]
*>i [3]:[505]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[29.29.29.29:506]
*>i [3]:[506]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[29.29.29.29:507]
*>i [3]:[507]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[29.29.29.29:508]
*>i [3]:[508]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[29.29.29.29:509]
*>i [3]:[509]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[29.29.29.29:510]
*>i [3]:[510]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
Total number of prefixes 121
PE2 Verification:
#show bgp l2vpn evpn
BGP table version is 3, local router ID is 29.29.29.29
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
[EVPN route type]:[ESI]:[VNID]:[relevant route information]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
Network Next Hop Metric LocPrf Weight Path Peer Encap
RD[20:200]
*>i [5]:[0]:[0]:[24]:[80.80.1.0]:[0.0.0.0]:[16]
10.10.10.10 0 100 0 ? 10.10.10.10 MPLS
RD[30:200]
*>i [5]:[0]:[0]:[24]:[70.70.1.0]:[0.0.0.0]:[25600]
22.22.22.22 0 100 0 ? 22.22.22.22 MPLS
RD[10.10.10.10:123]
*>i [2]:[0]:[123]:[48,0011:2233:4567]:[32,99.99.99.1]:[22]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*>i [3]:[123]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
RD[10.10.10.10:124]
*>i [2]:[0]:[124]:[48,0011:2233:4567]:[32,99.99.100.1]:[24]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*>i [3]:[124]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
RD[10.10.10.10:125]
*>i [2]:[0]:[125]:[48,0011:2233:4567]:[32,88.88.3.1]:[21]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*>i [3]:[125]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
RD[10.10.10.10:126]
*>i [3]:[126]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
RD[10.10.10.10:200]
*>i [2]:[0]:[100]:[48,d077:ce2a:8001]:[32,80.80.1.1]:[23]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*>i [3]:[100]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
RD[10.10.10.10:205]
*>i [2]:[0]:[127]:[48,0011:2233:4567]:[32,99.99.101.1]:[26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*>i [2]:[0]:[127]:[48,0011:2233:4567]:[32,104.104.104.1]:[26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*>i [2]:[0]:[127]:[48,0011:2233:4567]:[128,1000::1][26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*>i [2]:[0]:[127]:[48,d077:ce2a:8001]:[32,103.103.103.1]:[26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*>i [2]:[0]:[127]:[48,d077:ce2a:8001]:[128,1100::1][26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*>i [3]:[127]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
RD[10.10.10.10:305]
*>i [5]:[0]:[0]:[24]:[99.99.101.0]:[0.0.0.0]:[17]
10.10.10.10 0 100 0 ? 10.10.10.10 MPLS
*>i [5]:[0]:[0]:[24]:[103.103.103.0]:[0.0.0.0]:[17]
10.10.10.10 0 100 0 ? 10.10.10.10 MPLS
*>i [5]:[0]:[0]:[24]:[104.104.104.0]:[0.0.0.0]:[17]
10.10.10.10 0 100 0 ? 10.10.10.10 MPLS
RD[10.10.10.10:333]
*>i [5]:[0]:[0]:[24]:[99.99.99.0]:[0.0.0.0]:[19]
10.10.10.10 0 100 0 ? 10.10.10.10 MPLS
RD[10.10.10.10:334]
*>i [5]:[0]:[0]:[24]:[99.99.100.0]:[0.0.0.0]:[18]
10.10.10.10 0 100 0 ? 10.10.10.10 MPLS
RD[10.10.10.10:500]
*>i [3]:[500]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
RD[22.22.22.22:123]
*>i [2]:[0]:[123]:[48,0011:2233:4455]:[32,98.98.98.1]:[25618]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*>i [3]:[123]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
RD[22.22.22.22:124]
*>i [2]:[0]:[124]:[48,0011:2233:4455]:[32,98.98.99.1]:[25619]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*>i [3]:[124]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
RD[22.22.22.22:125]
*>i [2]:[0]:[125]:[48,0011:2233:4455]:[32,88.88.1.1]:[25629]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*>i [3]:[125]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
RD[22.22.22.22:126]
*>i [3]:[126]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
RD[22.22.22.22:205]
*>i [2]:[0]:[127]:[48,0011:2233:4455]:[32,98.98.101.1]:[25608]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*>i [2]:[0]:[127]:[48,0011:2233:4455]:[32,104.104.103.1]:[25608]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*>i [2]:[0]:[127]:[48,e49d:73b3:c101]:[32,103.103.102.1]:[25608]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*>i [3]:[127]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
RD[22.22.22.22:305]
*>i [5]:[0]:[0]:[24]:[98.98.101.0]:[0.0.0.0]:[25601]
22.22.22.22 0 100 0 ? 22.22.22.22 MPLS
*>i [5]:[0]:[0]:[24]:[103.103.102.0]:[0.0.0.0]:[25601]
22.22.22.22 0 100 0 ? 22.22.22.22 MPLS
*>i [5]:[0]:[0]:[24]:[104.104.103.0]:[0.0.0.0]:[25601]
22.22.22.22 0 100 0 ? 22.22.22.22 MPLS
RD[22.22.22.22:333]
*>i [5]:[0]:[0]:[24]:[98.98.98.0]:[0.0.0.0]:[25606]
22.22.22.22 0 100 0 ? 22.22.22.22 MPLS
RD[22.22.22.22:334]
*>i [5]:[0]:[0]:[24]:[98.98.99.0]:[0.0.0.0]:[25605]
22.22.22.22 0 100 0 ? 22.22.22.22 MPLS
RD[22.22.22.22:335]
*>i [5]:[0]:[0]:[24]:[88.88.1.0]:[0.0.0.0]:[25604]
22.22.22.22 0 100 0 ? 22.22.22.22 MPLS
RD[22.22.22.22:500]
*>i [3]:[500]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
RD[22.22.22.22:501]
*>i [3]:[501]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
RD[22.22.22.22:502]
*>i [3]:[502]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
RD[22.22.22.22:503]
*>i [3]:[503]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
RD[22.22.22.22:504]
*>i [3]:[504]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
RD[22.22.22.22:505]
*>i [3]:[505]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
RD[22.22.22.22:506]
*>i [3]:[506]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
RD[22.22.22.22:507]
*>i [3]:[507]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
RD[22.22.22.22:508]
*>i [3]:[508]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
RD[22.22.22.22:509]
*>i [3]:[509]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
RD[22.22.22.22:510]
*>i [3]:[510]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
RD[29.29.29.29:123] VRF[vrf100_mgmt]:
* i [2]:[0]:[123]:[48,0011:2233:4455]:[32,98.98.98.1]:[25618]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
* i [2]:[0]:[123]:[48,0011:2233:4567]:[32,99.99.99.1]:[22]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> 29.29.29.29 0 100 32768 i ---------- MPLS
* i [3]:[123]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [3]:[123]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [3]:[123]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
RD[29.29.29.29:124] VRF[vrf200_mgmt]:
* i [2]:[0]:[124]:[48,0011:2233:4455]:[32,98.98.99.1]:[25619]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
* i [2]:[0]:[124]:[48,0011:2233:4567]:[32,99.99.100.1]:[24]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> 29.29.29.29 0 100 32768 i ---------- MPLS
* i [3]:[124]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [3]:[124]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [3]:[124]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
RD[29.29.29.29:125] VRF[vrf201_mgmt]:
* i [2]:[0]:[125]:[48,0011:2233:4455]:[32,88.88.1.1]:[25629]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
* i [2]:[0]:[125]:[48,0011:2233:4567]:[32,88.88.3.1]:[21]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> 29.29.29.29 0 100 32768 i ---------- MPLS
* i [3]:[125]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [3]:[125]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [3]:[125]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
RD[29.29.29.29:126] VRF[vrf202_mgmt]:
* i [3]:[126]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [3]:[126]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [3]:[126]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
RD[29.29.29.29:200] VRF[blue]:
* i [2]:[0]:[100]:[48,d077:ce2a:8001]:[32,80.80.1.1]:[23]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> [2]:[0]:[100]:[48,e8c5:7aff:96de]:[32,80.80.1.1]:[38]
29.29.29.29 0 100 32768 i ---------- MPLS
* i [3]:[100]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> [3]:[100]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
RD[29.29.29.29:205] VRF[vrf205_mgmt]:
* i [2]:[0]:[127]:[48,0011:2233:4455]:[32,98.98.101.1]:[25608]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
* i [2]:[0]:[127]:[48,0011:2233:4455]:[32,104.104.103.1]:[25608]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
* i [2]:[0]:[127]:[48,0011:2233:4567]:[32,99.99.101.1]:[26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> 29.29.29.29 0 100 32768 i ---------- MPLS
* i [2]:[0]:[127]:[48,0011:2233:4567]:[32,104.104.104.1]:[26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> 29.29.29.29 0 100 32768 i ---------- MPLS
* i [2]:[0]:[127]:[48,0011:2233:4567]:[128,1000::1][26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> 29.29.29.29 0 100 32768 i ---------- MPLS
* i [2]:[0]:[127]:[48,d077:ce2a:8001]:[32,103.103.103.1]:[26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [2]:[0]:[127]:[48,d077:ce2a:8001]:[128,1100::1][26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [2]:[0]:[127]:[48,e49d:73b3:c101]:[32,103.103.102.1]:[25608]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [2]:[0]:[127]:[48,e8c5:7aff:96de]:[32,103.103.103.1]:[22]
29.29.29.29 0 100 32768 i ---------- MPLS
*> [2]:[0]:[127]:[48,e8c5:7aff:96de]:[128,1100::1][22]
29.29.29.29 0 100 32768 i ---------- MPLS
* i [3]:[127]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [3]:[127]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [3]:[127]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
RD[29.29.29.29:500] VRF[ELAN_vrf500]:
* i [3]:[500]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [3]:[500]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [3]:[500]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
RD[29.29.29.29:501] VRF[ELAN_vrf501]:
* i [3]:[501]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [3]:[501]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
RD[29.29.29.29:502] VRF[ELAN_vrf502]:
* i [3]:[502]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [3]:[502]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
RD[29.29.29.29:503] VRF[ELAN_vrf503]:
* i [3]:[503]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [3]:[503]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
RD[29.29.29.29:504] VRF[ELAN_vrf504]:
* i [3]:[504]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [3]:[504]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
RD[29.29.29.29:505] VRF[ELAN_vrf505]:
* i [3]:[505]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [3]:[505]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
RD[29.29.29.29:506] VRF[ELAN_vrf506]:
* i [3]:[506]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [3]:[506]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
RD[29.29.29.29:507] VRF[ELAN_vrf507]:
* i [3]:[507]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [3]:[507]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
RD[29.29.29.29:508] VRF[ELAN_vrf508]:
* i [3]:[508]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [3]:[508]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
RD[29.29.29.29:509] VRF[ELAN_vrf509]:
* i [3]:[509]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [3]:[509]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
RD[29.29.29.29:510] VRF[ELAN_vrf510]:
* i [3]:[510]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [3]:[510]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
RD[29.29.29.29:650] VRF[vrf650]:
*> [3]:[650]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
Total number of prefixes 110
Verify the specific type of EVPN routes using VRF:
PE1:
#show bgp l2vpn evpn vrf vrf205_mgmt
BGP table version is 1, local router ID is 22.22.22.22
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
[EVPN route type]:[ESI]:[VNID]:[relevant route information]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
Network Next Hop Metric LocPrf Weight Path Peer Encap
*> [2]:[0]:[127]:[48,0011:2233:4455]:[32,98.98.101.1]:[25608]
22.22.22.22 0 100 32768 i ---------- MPLS
*> [2]:[0]:[127]:[48,0011:2233:4455]:[32,104.104.103.1]:[25608]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [2]:[0]:[127]:[48,0011:2233:4567]:[32,99.99.101.1]:[22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
* i 10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [2]:[0]:[127]:[48,0011:2233:4567]:[32,104.104.104.1]:[22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
* i 10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [2]:[0]:[127]:[48,0011:2233:4567]:[128,1000::1][22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
* i 10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [2]:[0]:[127]:[48,d077:ce2a:8001]:[32,103.103.103.1]:[26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [2]:[0]:[127]:[48,d077:ce2a:8001]:[128,1100::1][26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> [2]:[0]:[127]:[48,e49d:73b3:c101]:[32,103.103.102.1]:[25608]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [2]:[0]:[127]:[48,e8c5:7aff:96de]:[32,103.103.103.1]:[22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
* i [2]:[0]:[127]:[48,e8c5:7aff:96de]:[128,1100::1][22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
* i [3]:[127]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> [3]:[127]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [3]:[127]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
Total number of prefixes 13
PE2:
#show bgp l2vpn evpn vrf vrf205_mgmt
BGP table version is 1, local router ID is 29.29.29.29
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
[EVPN route type]:[ESI]:[VNID]:[relevant route information]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
Network Next Hop Metric LocPrf Weight Path Peer Encap
* i [2]:[0]:[127]:[48,0011:2233:4455]:[32,98.98.101.1]:[25608]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
* i [2]:[0]:[127]:[48,0011:2233:4455]:[32,104.104.103.1]:[25608]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
* i [2]:[0]:[127]:[48,0011:2233:4567]:[32,99.99.101.1]:[26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> 29.29.29.29 0 100 32768 i ---------- MPLS
* i [2]:[0]:[127]:[48,0011:2233:4567]:[32,104.104.104.1]:[26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> 29.29.29.29 0 100 32768 i ---------- MPLS
* i [2]:[0]:[127]:[48,0011:2233:4567]:[128,1000::1][26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> 29.29.29.29 0 100 32768 i ---------- MPLS
* i [2]:[0]:[127]:[48,d077:ce2a:8001]:[32,103.103.103.1]:[26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [2]:[0]:[127]:[48,d077:ce2a:8001]:[128,1100::1][26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [2]:[0]:[127]:[48,e49d:73b3:c101]:[32,103.103.102.1]:[25608]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [2]:[0]:[127]:[48,e8c5:7aff:96de]:[32,103.103.103.1]:[22]
29.29.29.29 0 100 32768 i ---------- MPLS
*> [2]:[0]:[127]:[48,e8c5:7aff:96de]:[128,1100::1][22]
29.29.29.29 0 100 32768 i ---------- MPLS
* i [3]:[127]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [3]:[127]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [3]:[127]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
Total number of prefixes 13
Verify the specific type of EVPN routes using RD:
PE1:
#show bgp l2vpn evpn rd 22.22.22.22:205
BGP table version is 2, local router ID is 22.22.22.22
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
[EVPN route type]:[ESI]:[VNID]:[relevant route information]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
Network Next Hop Metric LocPrf Weight Path Peer Encap
RD[22.22.22.22:205] VRF[vrf205_mgmt]:
*> [2]:[0]:[127]:[48,0011:2233:4455]:[32,98.98.101.1]:[25608]
22.22.22.22 0 100 32768 i ---------- MPLS
*> [2]:[0]:[127]:[48,0011:2233:4455]:[32,104.104.103.1]:[25608]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [2]:[0]:[127]:[48,0011:2233:4567]:[32,99.99.101.1]:[22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
* i 10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [2]:[0]:[127]:[48,0011:2233:4567]:[32,104.104.104.1]:[22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
* i 10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [2]:[0]:[127]:[48,0011:2233:4567]:[128,1000::1][22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
* i 10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [2]:[0]:[127]:[48,d077:ce2a:8001]:[32,103.103.103.1]:[26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [2]:[0]:[127]:[48,d077:ce2a:8001]:[128,1100::1][26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> [2]:[0]:[127]:[48,e49d:73b3:c101]:[32,103.103.102.1]:[25608]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [2]:[0]:[127]:[48,e8c5:7aff:96de]:[32,103.103.103.1]:[22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
* i [2]:[0]:[127]:[48,e8c5:7aff:96de]:[128,1100::1][22]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
* i [3]:[127]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> [3]:[127]:[32,22.22.22.22]
22.22.22.22 0 100 32768 i ---------- MPLS
* i [3]:[127]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
Total number of prefixes 13
PE2:
#show bgp l2vpn evpn rd 29.29.29.29:205
BGP table version is 3, local router ID is 29.29.29.29
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
[EVPN route type]:[ESI]:[VNID]:[relevant route information]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
Network Next Hop Metric LocPrf Weight Path Peer Encap
RD[29.29.29.29:205] VRF[vrf205_mgmt]:
* i [2]:[0]:[127]:[48,0011:2233:4455]:[32,98.98.101.1]:[25608]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
* i [2]:[0]:[127]:[48,0011:2233:4455]:[32,104.104.103.1]:[25608]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
* i [2]:[0]:[127]:[48,0011:2233:4567]:[32,99.99.101.1]:[26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> 29.29.29.29 0 100 32768 i ---------- MPLS
* i [2]:[0]:[127]:[48,0011:2233:4567]:[32,104.104.104.1]:[26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> 29.29.29.29 0 100 32768 i ---------- MPLS
* i [2]:[0]:[127]:[48,0011:2233:4567]:[128,1000::1][26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
*> 29.29.29.29 0 100 32768 i ---------- MPLS
* i [2]:[0]:[127]:[48,d077:ce2a:8001]:[32,103.103.103.1]:[26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [2]:[0]:[127]:[48,d077:ce2a:8001]:[128,1100::1][26]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [2]:[0]:[127]:[48,e49d:73b3:c101]:[32,103.103.102.1]:[25608]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [2]:[0]:[127]:[48,e8c5:7aff:96de]:[32,103.103.103.1]:[22]
29.29.29.29 0 100 32768 i ---------- MPLS
*> [2]:[0]:[127]:[48,e8c5:7aff:96de]:[128,1100::1][22]
29.29.29.29 0 100 32768 i ---------- MPLS
* i [3]:[127]:[32,10.10.10.10]
10.10.10.10 0 100 0 i 10.10.10.10 MPLS
* i [3]:[127]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
*> [3]:[127]:[32,29.29.29.29]
29.29.29.29 0 100 32768 i ---------- MPLS
Total number of prefixes 13
Verify the specific type of EVPN routes using Prefix:
PE1:
#show bgp l2vpn evpn prefix [3]:[127]:[32,29.29.29.29]
BGP table version is 2, local router ID is 22.22.22.22
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
[EVPN route type]:[ESI]:[VNID]:[relevant route information]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
Network Next Hop Metric LocPrf Weight Path Peer Encap
RD[22.22.22.22:205] VRF[vrf205_mgmt]:
* i [3]:[127]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
RD[29.29.29.29:205]
*>i [3]:[127]:[32,29.29.29.29]
29.29.29.29 0 100 0 i 29.29.29.29 MPLS
Total number of prefixes 2
PE2:
#show bgp l2vpn evpn prefix [3]:[127]:[32,22.22.22.22]
BGP table version is 3, local router ID is 29.29.29.29
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
[EVPN route type]:[ESI]:[VNID]:[relevant route information]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
Network Next Hop Metric LocPrf Weight Path Peer Encap
RD[22.22.22.22:205]
*>i [3]:[127]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
RD[29.29.29.29:205] VRF[vrf205_mgmt]:
* i [3]:[127]:[32,22.22.22.22]
22.22.22.22 0 100 0 i 22.22.22.22 MPLS
Total number of prefixes 2
Verify the specific type of EVPN routes using both VRF and Prefix:
PE1:
#show bgp l2vpn evpn vrf vrf205_mgmt prefix [3]:[127]:[32,29.29.29.29]
BGP table version is 1, local router ID is 22.22.22.22
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
[EVPN route type]:[ESI]:[VNID]:[relevant route information]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
Network Next Hop Metric LocPrf Weight Path Peer Encap
* i [3]:[127]:[32,29.29.29.29] 29.29.29.29 0 100 0 i 29.29.29.29 MPLS
Total number of prefixes 1
PE2:
#show bgp l2vpn evpn vrf vrf205_mgmt prefix [3]:[127]:[32,22.22.22.22]
BGP table version is 1, local router ID is 29.29.29.29
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
[EVPN route type]:[ESI]:[VNID]:[relevant route information]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
Network Next Hop Metric LocPrf Weight Path Peer Encap
* i [3]:[127]:[32,22.22.22.22] 22.22.22.22 0 100 0 i 22.22.22.22 MPLS
Total number of prefixes 1
Verify detailed information of EVPN routes:
PE1:
#show bgp l2vpn evpn vrf vrf205_mgmt prefix [3]:[127]:[32,29.29.29.29] detail
BGP route entry for prefix : [3]:[127]:[32,29.29.29.29]
Route-Distinguisher: [29.29.29.29:205]
Flags : Valid, IBGP
Nexthop : 29.29.29.29 MED value : 0
Community:
Extended Community: RT:65535:1073741951 Encapsulation:MPLS
Weight :0, Local Preference :100
AS Path : Local
Origin : IGP
Last Update : Mon Oct 9 10:14:47 2023
Peer : 29.29.29.29
Total number of prefixes 1
PE2:
#show bgp l2vpn evpn vrf vrf205_mgmt prefix [3]:[127]:[32,22.22.22.22] detail
BGP route entry for prefix : [3]:[127]:[32,22.22.22.22]
Route-Distinguisher: [22.22.22.22:205]
Flags : Valid, IBGP
Nexthop : 22.22.22.22 MED value : 0
Community:
Extended Community: RT:65535:1073741951 Encapsulation:MPLS
Weight :0, Local Preference :100
AS Path : Local
Origin : IGP
Last Update : Mon Apr 15 07:05:47 2019
Peer : 22.22.22.22
Abbreviations
Acronym | Description |
---|
VNID | L2 Virtual Network Identifier |
VRF | Virtual Routing and Forwarding |
EVPN-IRB | Ethernet VPN Integrated Routing and Bridging |
MAC | Media Access Control address |