#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 1.1.1.1/32 secondary | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)# commit | Committing the configuration to apply in running configuration |
(config)#interface xe4 | Enter interface mode |
(config-if)#ip address 20.20.40.40/31 | Configure the IP address on the interface |
(config-if)# description to_pe1 | Adding Description to interface |
(config-if)#exit | Exit interface mode. |
(config)# commit | Committing the configuration to apply in running configuration |
(config)#interface xe24 | Enter interface mode |
(config-if)#ip address 20.20.40.42/31 | Configure the IP address on the interface |
(config-if)# description ospf backdoor | Adding Description to interface |
(config-if)# ip ospf cost 10 | Set the OSPF cost of this link |
(config-if)#exit | Exit interface mode. |
(config)# commit | Committing the configuration to apply in running configuration |
(config)#router ospf 1 | Configure the routing process OSPF with process id |
(config-router)#network 1.1.1.1/32 area 2 | Define the interface on which OSPF runs, and associate the area ID with the interface. |
(config-router)#network 20.20.40.40/31 area 2 | Define the interface on which OSPF runs, and associate the area ID with the interface. |
(config-router)#network 20.20.40.42/31 area 2 | Define the interface on which OSPF runs, and associate the area ID with the interface. |
(config-router)#exit | Exit from router ospf mode |
(config)# commit | Committing the configuration to apply in running configuration |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 2.2.2.2/32 | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)# commit | Committing the configuration to apply in running configuration |
(config)#ip vrf vrf1 | Create vrf1 |
(config-vrf)# description vrf1 | Adding description to vrf |
(config-vrf)#rd 100:1 | Specify the route distinguisher in the VRF |
(config-vrf)#route-target both 100:1 | Specify the import & export route target |
(config)# commit | Committing the configuration to apply in running configuration |
(config)# router ldp | Configure Router LDP instance |
(config)# commit | Committing the configuration to apply in running configuration |
(config)#interface xe4 | Enter interface mode |
(config-if)# description to_ce1 | Adding description to interface |
(config-if)# ip vrf forwarding vrf1 | Associate the interface to vrf1 |
(config-if)#ip address 20.20.40.41/31 | Configure the IP address on the interface |
(config-if)#exit | Exit interface mode. |
(config)#interface xe10 | Enter interface mode |
(config-if)# description to_pe2 | Adding description to interface |
(config-if)#ip address 20.20.40.48/31 | Configure the IP address on the interface |
(config-if)#label-switching | Enable label-switching on interface |
(config-if)# enable-ldp ipv4 | Enable LDP process on interface |
(config-if)#exit | Exit interface mode. |
(config)# commit | Committing the configuration to apply in running configuration |
(config)# interface lo.vrf1 | Enter interface mode |
(config-if)# ip vrf forwarding vrf1 | Associate the interface to vrf1 |
ip address 11.11.11.11/32 secondary | Configure the IP address on the interface |
(config)# commit | Committing the configuration to apply in running configuration |
(config)#router ospf 1 vrf1 | Associate the ospf process with vrf1. |
(config-router)# redistribute bgp | Redistribute BGP into OSPF. |
(config-router)#network 20.20.40.40/31 area 2 | Define the interface on which OSPF runs, and associate the area ID with the interface. |
(config-router)# area 0.0.0.2 sham-link 11.11.11.11 22.22.22.22 cost 5 | Configuring Sham-link between PE routers with cost 5. |
(config-router)#exit | Exit from router ospf mode |
(config)#router ospf 100 | Configure the routing process OSPF with process id |
(config-router)#network 2.2.2.2/32 area 2 | Define the interface on which OSPF runs, and associate the area ID with the interface. |
(config-router)#network 20.20.40.48/31 area 0 | Define the interface on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)# commit | Committing the configuration to apply in running configuration |
(config)#router bgp 100 | Enter Router BGP mode |
(config-router)#neighbor 3.3.3.3 remote- | |
as 100 | Add loopback ip of ABR2 as neighbor with neighbor AS |
(config-router)#neighbor 3.3.3.3 update- source 2.2.2.2 | Update the source for that particular neighbor as loopback interface |
(config-router)#address-family vpnv4 unicast | Enter into vpnv4 unicast address family |
(config-router-af)#neighbor 3.3.3.3 activate | Activate the neighbor inside vpnv4 address family |
(config-router-af)#exit-address-family | Exit from address family vpnv4 |
(config-router)# address-family ipv4 vrf vrf1 | Enter into vrf address family |
(config-router-af)# network 11.11.11.11/32 | Advertise a route via iBGP connection. |
(config-router-af)#redistribute ospf 1 | Redistribute ospf routes into bgp |
(config-router-af)#exit-address-family | Exit from address family vpnv4 |
(config-router)#exit | Exit from router BGP mode |
(config)# commit | Committing the configuration to apply in running configuration |
(config)#end | Exit from config mode into privilege mode |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 3.3.3.3/32 | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)# commit | Committing the configuration to apply in running configuration |
(config)#ip vrf vrf1 | Create vrf1 |
(config-vrf)# description vrf1 | Adding description to vrf |
(config-vrf)#rd 100:1 | Specify the route distinguisher in the VRF |
(config-vrf)#route-target both 100:1 | Specify the import & export route target |
(config)# commit | Committing the configuration to apply in running configuration |
(config)# router ldp | Configure Router LDP instance |
(config)# commit | Committing the configuration to apply in running configuration |
(config)#interface xe5 | Enter interface mode |
(config-if)# description to_ce2 | Adding description to interface |
(config-if)# ip vrf forwarding vrf1 | Associate the interface to vrf1 |
(config-if)# ip address 20.20.40.38/31 | Configure the IP address on the interface |
(config-if)#exit | Exit interface mode. |
(config)#interface xe10 | Enter interface mode |
(config-if)# description to_pe1 | Adding description to interface |
(config-if)#ip address 20.20.40.49/31 | Configure the IP address on the interface |
(config-if)#label-switching | Enable label-switching on interface |
(config-if)# enable-ldp ipv4 | Enable LDP process on interface |
(config-if)#exit | Exit interface mode. |
(config)# commit | Committing the configuration to apply in running configuration |
(config)# interface lo.vrf1 | Enter interface mode |
(config-if)# ip vrf forwarding vrf1 | Associate the interface to vrf1 |
ip address 22.22.22.22/32 secondary | Configure the IP address on the interface |
(config)# commit | Committing the configuration to apply in running configuration |
(config)#router ospf 1 vrf1 | Associate the ospf process with vrf1. |
(config-router)# redistribute bgp | Redistribute BGP into OSPF. |
(config-router)#network 20.20.40.38/31 area 2 | Define the interface on which OSPF runs, and associate the area ID with the interface. |
(config-router)# area 0.0.0.2 sham-link 22.22.22.22 11.11.11.11 cost 5 | Configuring Sham-link between PE routers with cost 5. |
(config-router)#exit | Exit from router ospf mode |
(config)#router ospf 100 | Configure the routing process OSPF with process id |
(config-router)#network 3.3.3.3/32 area 2 | Define the interface on which OSPF runs, and associate the area ID with the interface. |
(config-router)#network 20.20.40.48/31 area 0 | Define the interface on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area). |
(config-router)#exit | Exit from router ospf mode |
(config)# commit | Committing the configuration to apply in running configuration |
(config)#router bgp 100 | Enter Router BGP mode |
(config-router)#neighbor 2.2.2.2 remote-as 100 | Add loopback ip of ABR2 as neighbor with neighbor AS |
(config-router)#neighbor 2.2.2.2 update- source 3.3.3.3 | Update the source for that particular neighbor as loopback interface |
(config-router)#address-family vpnv4 unicast | Enter into vpnv4 unicast address family |
(config-router-af)#neighbor 2.2.2.2 activate | Activate the neighbor inside vpnv4 address family |
(config-router-af)#exit-address-family | Exit from address family vpnv4 |
(config-router)# address-family ipv4 vrf vrf1 | Enter into vrf address family |
(config-router-af)# network 22.22.22.22/32 | Advertise a route via iBGP connection. |
(config-router-af)#redistribute ospf 1 | Redistribute ospf routes into bgp |
(config-router-af)#exit-address-family | Exit from address family vpnv4 |
(config-router)#exit | Exit from router BGP mode |
(config)# commit | Committing the configuration to apply in running configuration |
(config)#end | Exit from config mode into privilege mode |
#configure terminal | Enter the Configure mode. |
(config)#interface lo | Enter interface mode |
(config-if)#ip address 4.4.4.4/32 secondary | Configure the IP address of the interface loopback |
(config-if)#exit | Exit interface mode |
(config)# commit | Committing the configuration to apply in running configuration |
(config)#interface xe5 | Enter interface mode |
(config-if)#ip address 20.20.40.39/31 | Configure the IP address on the interface |
(config-if)# description to_pe2 | Adding Description to interface |
(config-if)#exit | Exit interface mode. |
(config)# commit | Committing the configuration to apply in running configuration |
(config)#interface xe7 | Enter interface mode |
(config-if)#ip address 20.20.40.43/31 | Configure the IP address on the interface |
(config-if)# description ospf backdoor | Adding Description to interface |
(config-if)# ip ospf cost 10 | Set the OSPF cost of this link |
(config-if)#exit | Exit interface mode. |
(config)# commit | Committing the configuration to apply in running configuration |
(config)#router ospf 1 | Configure the routing process OSPF with process id |
(config-router)#network 4.4.4.4/32 area 2 | Define the interface on which OSPF runs, and associate the area ID with the interface. |
(config-router)#network 20.20.40.38/31 area 2 | Define the interface on which OSPF runs, and associate the area ID with the interface. |
(config-router)#network 20.20.40.42/31 area 2 | Define the interface on which OSPF runs, and associate the area ID with the interface. |
(config-router)#exit | Exit from router ospf mode |
(config)# commit | Committing the configuration to apply in running configuration |