RSVP-Multipath Configuration
RSVP multipath provides multiple paths to reach the destination. RSVP services (L2 VPN, L3 VPN, LU, mapped route, etc.) can be mapped to RSVP multipath so that traffic is load-balanced. At ingress node the traffic is load-balanced based on the configured hash (L3 src/dest IP/port, L2 src/dst mac, or in-label if intermediate Autonomous segments). Each LSP path within multipath group can provide individual protection for each path (facility, 1-to-1, secondary). Each tunnel path in multipath group cost may vary (can have different hop, with consideration for load-balancing the traffic). Each member can have the backup protection as other multipath member path or outside the multipath member path.
Topology
RSVP-Multipath Topology
Configuration
R1
#configure terminal | Enter configure mode. |
(config)#hardware-profile statistics tunnel-lif enable | Configure hardware-profile statistics |
(config)#interface lo | Enter interface mode. |
(config-if)#ip address 40.40.40.40/32 secondary | Set a secondary IP address of the interface. |
(config-if)#exit | Exit interface mode. |
(config)#router rsvp | Enter Configure Router mode. |
(config-router)#router-id 40.40.40.40 | Set the router ID to IP address 40.40.40.40 |
(config-router)#exit | Exit Router mode. |
(config)#interface xe1 | Enter interface mode. |
(config-if)#ip address 10.10.1.1/24 | Set the IP address for the interface. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe11 | Enter interface mode. |
(config-if)#ip address 13.1.1.1/24 | Set the IP address for the interface. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#router ospf 1 | Configure the Routing process and specify the Process ID (1). The Process ID should be a unique positive integer identifying the routing process. |
(config-router)#router-id 40.40.40.40 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 10.1.1.0/24 area 0 | Define the network (10.1.1.0/24) on which OSPF runs and associate the area ID (0). |
(config-router)#network 13.1.1.0/24 area 0 | Define the network (13.1.1.0/24) on which OSPF runs and associate the area ID (0). |
(config-router)#network 40.40.40.40/32 area 0 | Set the IP address of the loopback interface to 40.40.40.40/32. |
(config-router)#exit | Exit Router mode. |
(config)#rsvp-path path1 mpls | Enter the path mode for RSVP path1. |
(config-path)#10.1.1.2 strict | Configure this explicit route path as a strict hop. |
(config-path)#11.1.1.3 strict | Configure this explicit route path as a strict hop. |
(config-path)#12.1.1.4 strict | Configure this explicit route path as a strict hop. |
(config)#exit | Exit the path mode. |
(config)#rsvp-path path2 mpls | Enter the path mode for RSVP path2. |
(config-path)#13.1.1.2 strict | Configure this explicit route path as a strict hop. |
(config-path)#14.1.1.3 strict | Configure this explicit route path as a strict hop. |
(config-path)#15.1.1.4 strict | Configure this explicit route path as a strict hop. |
(config)#exit | Exit the path mode. |
(config)#rsvp-trunk t1 ipv4 | Enter the trunk mode for rsvp. |
(config-trunk)#primary path path1 | Configure trunk t1 to use the defined path. |
(config-trunk)#from 40.40.40.40 | Specify the IPv4 ingress (source point) for the LSP. |
(config-trunk)#to 47.47.47.47 | Specify the IPv4 egress (destination point) for the LSP. |
(config-trunk)#exit | Exit from trunk mode. |
(config)#rsvp-trunk t2 ipv4 | Enter the trunk mode for rsvp. |
(config-trunk)#primary path path2 | Configure trunk t2 to use the defined path. |
(config-trunk)#from 40.40.40.40 | Specify the IPv4 egress (source point) for the LSP. |
(config-trunk)#to 47.47.47.47 | Specify the IPv4 ingress (destination point) for the LSP. |
(config-trunk)#exit | Exit from trunk mode. |
(config)#rsvp-multipath test | Configure RSVP Multipath group. |
(config-multipath)#to 47.47.47.47 | Configure a mandatory destination FEC(egress router). |
(config-multipath)#description "my-group” | Configure description to RSVP Multipath group. |
(config-multipath)#exit | Exit from RSVP Multipath mode. |
(config)#rsvp-trunk t1 ipv4 | Enter the trunk mode for rsvp. |
(config-trunk)#multipath-group test | Configure RSVP Multipath group to trunk t1. |
(config-trunk)#exit | Exit from trunk mode. |
(config)#rsvp-trunk t2 ipv4 | Enter the trunk mode for rsvp. |
(config-trunk)#multipath-group test | Configure RSVP Multipath group to trunk t2. |
(config-trunk)#exit | Exit from trunk mode. |
(config)#commit | Commit all the configurations. |
R2
#configure terminal | Enter configure mode. |
(config)#interface lo | Enter interface mode. |
(config-if)#ip address 46.46.46.46/32 secondary | Set a secondary IP address of the interface |
(config-if)#exit | Exit interface mode. |
(config)#router rsvp | Enter Configure Router mode. |
(config-router)#exit | Exit Router mode. |
(config)#interface xe1 | Enter interface mode. |
(config-if)#ip address 10.10.1.2/24 | Set the IP address for the interface. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe5 | Enter interface mode. |
(config-if)#ip address 11.1.1.2/24 | Set the IP address for the interface. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#router ospf 1 | Configure the Routing process and specify the Process ID (1). The Process ID should be a unique positive integer identifying the routing process. |
(config-router)#router-id 46.46.46.46 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 10.1.1.0/24 area 0 | Define the network (10.1.1.0/24) on which OSPF runs and associate the area ID (0). |
(config-router)#network 11.1.1.0/24 area 0 | Define the network (11.1.1.0/24) on which OSPF runs and associate the area ID (0). |
(config-router)#network 46.46.46.46/32 area 0 | Set the IP address of the loopback interface to 46.46.46.46/32. |
(config-router)#exit | Exit Router mode. |
(config)#commit | Commit all the configurations. |
R3
#configure terminal | Enter configure mode. |
(config)#interface lo | Enter interface mode. |
(config-if)#ip address 48.48.48.48/32 secondary | Set a secondary IP address of the interface. |
(config-if)#exit | Exit interface mode. |
(config)#router rsvp | Enter Configure Router mode. |
(config-router)#exit | Exit Router mode. |
(config)#interface xe1 | Enter interface mode. |
(config-if)#ip address 12.1.1.3/24 | Set the IP address for the interface. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe5 | Enter interface mode. |
(config-if)#ip address 11.1.1.3/24 | Set the IP address for the interface. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#router ospf 1 | Configure the Routing process and specify the Process ID (1). The Process ID should be a unique positive integer identifying the routing process. |
(config-router)#router-id 48.48.48.48 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 11.1.1.0/24 area 0 | Define the network (11.1.1.0/24) on which OSPF runs and associate the area ID (0). |
(config-router)#network 12.1.1.0/24 area 0 | Define the network (12.1.1.0/24) on which OSPF runs and associate the area ID (0). |
(config-router)#network 48.48.48.48/32 area 0 | Set the IP address of the loopback interface to 48.48.48.48/32. |
(config-router)#exit | Exit Router mode. |
(config)#commit | Commit all the configurations. |
R4
#configure terminal | Enter configure mode. |
(config)#interface lo | Enter interface mode. |
(config-if)#ip address 56.56.56.56/32 secondary | Set a secondary IP address of the interface |
(config-if)#exit | Exit interface mode. |
(config)#router rsvp | Enter Configure Router mode. |
(config-router)#exit | Exit Router mode. |
(config)#interface xe11 | Enter interface mode. |
(config-if)#ip address 13.1.1.2/24 | Set the IP address for the interface. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe17 | Enter interface mode. |
(config-if)#ip address 14.1.1.2/24 | Set the IP address for the interface. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#router ospf 1 | Configure the Routing process and specify the Process ID (1). The Process ID should be a unique positive integer identifying the routing process. |
(config-router)#router-id 56.56.56.56 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 13.1.1.0/24 area 0 | Define the network (13.1.1.0/24) on which OSPF runs and associate the area ID (0). |
(config-router)#network 14.1.1.0/24 area 0 | Define the network (14.1.1.0/24) on which OSPF runs and associate the area ID (0). |
(config-router)#network 56.56.56.56/32 area 0 | Set the IP address of the loopback interface to 56.56.56.56/32. |
(config-router)#exit | Exit Router mode. |
(config)#commit | Commit all the configurations. |
R5
#configure terminal | Enter configure mode. |
(config)#interface lo | Enter interface mode. |
(config-if)#ip address 58.58.58.58/32 secondary | Set a secondary IP address of the interface |
(config-if)#exit | Exit interface mode. |
(config)#router rsvp | Enter Configure Router mode. |
(config-router)#exit | Exit Router mode. |
(config)#interface xe15 | Enter interface mode. |
(config-if)#ip address 15.1.1.3/24 | Set the IP address for the interface. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe17 | Enter interface mode. |
(config-if)#ip address 14.1.1.3/24 | Set the IP address for the interface. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#router ospf 1 | Configure the Routing process and specify the Process ID (1). The Process ID should be a unique positive integer identifying the routing process. |
(config-router)#router-id 58.58.58.58 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 15.1.1.0/24 area 0 | Define the network (15.1.1.0/24) on which OSPF runs and associate the area ID (0). |
(config-router)#network 14.1.1.0/24 area 0 | Define the network (14.1.1.0/24) on which OSPF runs and associate the area ID (0). |
(config-router)#network 58.58.58.58/32 area 0 | Set the IP address of the loopback interface to 58.58.58.58/32. |
(config-router)#exit | Exit Router mode. |
(config)#commit | Commit all the configurations. |
R6
#configure terminal | Enter configure mode. |
(config)#interface lo | Enter interface mode. |
(config-if)#ip address 47.47.47.47/32 secondary | Set a secondary IP address of the interface |
(config-if)#exit | Exit interface mode. |
(config)#router rsvp | Enter Configure Router mode. |
(config-router)#exit | Exit Router mode. |
(config)#interface xe1 | Enter interface mode. |
(config-if)#ip address 12.1.1.4/24 | Set the IP address for the interface. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#interface xe15 | Enter interface mode. |
(config-if)#ip address 15.1.1.4/24 | Set the IP address for the interface. |
(config-if)#label-switching | Enable label switching on interface. |
(config-if)#enable-rsvp | Enable RSVP message exchange on this interface. |
(config-if)#exit | Exit interface mode. |
(config)#router ospf 1 | Configure the Routing process and specify the Process ID (1). The Process ID should be a unique positive integer identifying the routing process. |
(config-router)#router-id 47.47.47.47 | Configure OSPF router-ID same as loopback interface IP address |
(config-router)#network 12.1.1.0/24 area 0 | Define the network (12.1.1.0/24) on which OSPF runs and associate the area ID (0). |
(config-router)#network 15.1.1.0/24 area 0 | Define the network (15.1.1.0/24) on which OSPF runs and associate the area ID (0). |
(config-router)#network 47.47.4747/32 area 0 | Set the IP address of the loopback interface to 47.47.47.47/32. |
(config-router)#exit | Exit Router mode. |
(config)#commit | Commit all the configurations. |
Validation
R1
#show ip ospf neighbor
Total number of full neighbors: 2
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
46.46.46.46 1 Full/DR 00:00:38 10.1.1.2 ce54 0
56.56.56.56 1 Full/DR 00:00:37 13.1.1.2 xe11 0
#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
Ingress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
47.47.47.47 40.40.40.40 PRI t1-Primary UP 00:01:46 1 1 SE - 24320 DEFAULT
47.47.47.47 40.40.40.40 PRI t2-Primary UP 00:01:46 1 1 SE - 24320 DEFAULT
Total 2 displayed, Up 2, Down 0.
#show rsvp multipath
RSVP-multipath Name : test, ID : 101
Description : "my-group"
Member count : 2, Egress : 47.47.47.47/32
Member details :
----------------
Trunk-ID Trunk-name Status
5001 t1 active
5002 t2 active
#show mpls rsvp-multipath
Codes: > - installed FTN, * - selected FTN, t - tunnel, R - RSVP-TE FTN
Multipath Name : test, ID : 101, Nhlfe Ix : 4
Active member count : 2, FEC : 47.47.47.47/32
Active member details :
-----------------------
Index Code FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
1 R(t)> 1 3 5001 Yes LSP_DEFAULT 24320 ce54 No 10.1.1.2
2 R(t)> 2 5 5002 Yes LSP_DEFAULT 24320 xe11 No 13.1.1.2
#show mpls counters rsvp multipath-name test
Tunnel-id 5001 Extended Tunnel-ID 40.40.40.40 Egress 47.47.47.47
lsp-name : t1-Primary [Ingress]
lsp-ingress : 40.40.40.40 lsp-id : 2201
Rx pkts : n/a Rx bytes : n/a
Tx pkts : 864364 Tx bytes : 1298276230
Tunnel-id 5002 Extended Tunnel-ID 40.40.40.40 Egress 47.47.47.47
lsp-name : t2-Primary [Ingress]
lsp-ingress : 40.40.40.40 lsp-id : 2202
Rx pkts : n/a Rx bytes : n/a
Tx pkts : 864366 Tx bytes : 1298277732
#show mpls ftn-table
Primary FTN entry with FEC: 47.47.47.47/32, id: 1, row status: Active, Tunnel-Policy: N/A
Owner: RSVP, distance: 0, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 5001, Protected LSP id: 2201, QoS Resource id: 2, Description: t1, Color: 0
Multipath group: test
Cross connect ix: 3, in intf: - in label: 0 out-segment ix: 3
Owner: RSVP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 3, owner: RSVP, Stale: NO, out intf: ce54, out label: 24320
Nexthop addr: 10.1.1.2 cross connect ix: 3, op code: Push
Primary FTN entry with FEC: 47.47.47.47/32, id: 2, row status: Active, Tunnel-Policy: N/A
Owner: RSVP, distance: 0, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 5002, Protected LSP id: 2202, QoS Resource id: 3, Description: t2, Color: 0
Multipath group: test
Cross connect ix: 4, in intf: - in label: 0 out-segment ix: 5
Owner: RSVP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 5, owner: RSVP, Stale: NO, out intf: xe11, out label: 24320
Nexthop addr: 13.1.1.2 cross connect ix: 4, op code: Push
#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN,
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
R(t)> 47.47.47.47/32 1 3 5001 Yes LSP_DEFAULT 24320 ce54 No 10.1.1.2
R(t)> 47.47.47.47/32 2 5 5002 Yes LSP_DEFAULT 24320 xe11 No 13.1.1.2
#show rsvp session detail
Egress
40.40.40.40
From: 47.47.47.47, LSPstate: Up, LSPname: PE2-PE1-Primary
Egress FSM state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 24960, Label out: -,
Tspec rate: 0k, Fspec rate: 0k
Tunnel Id: 5001, LSP Id: 2201, Ext-Tunnel Id: 47.47.47.47
Bind value: 0, Oper state: NA, Alloc mode: NA
Upstream: 13.1.1.2, xe11
Path lifetime: 157 seconds (due in 146 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 34571 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
13.1.1.1/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
15.1.1.4
14.1.1.3
13.1.1.2
<self>
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Current Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Trunk Type: mpls
Ingress (Primary)
47.47.47.47
From: 40.40.40.40, LSPstate: Up, LSPname: t1-Primary
Ingress FSM state: Operational
Establishment Time: 0s 22ms
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: OSPF
IGP-Shortcut: Disabled, LSP metric: 3
LSP Protection: None
Label in: -, Label out: 24320,
Tspec rate: 0k, Fspec rate: 0k
Policer: Not Configured
Tunnel Id: 5001, LSP Id: 2201, Ext-Tunnel Id: 40.40.40.40
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 10.1.1.2, ce54
Path refresh: 30 seconds (RR enabled) (due in 29859 seconds)
Resv lifetime: 157 seconds (due in 149 seconds)
Retry count: 0, intrvl: 30 seconds
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: none
Configured Path: path1 (in use)
Configured Explicit Route Detail :
10.1.1.2/32 strict
11.1.1.3/32 strict
12.1.1.4/32 strict
Session Explicit Route Detail :
10.1.1.2/32 strict
11.1.1.3/32 strict
12.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
<self>
10.1.1.2
11.1.1.3
12.1.1.4
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
Current Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Last Signaled Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Trunk Type: mpls
Ingress (Primary)
47.47.47.47
From: 40.40.40.40, LSPstate: Up, LSPname: t2-Primary
Ingress FSM state: Operational
Establishment Time: 0s 30ms
Setup priority: 7, Hold priority: 0
CSPF usage: Enabled, CSPF Retry Count: 0, CSPF Retry Interval: 30 seconds
LSP Re-Optimization: Disabled, Re-Optimization Timer: NA, Cspf Client: OSPF
IGP-Shortcut: Disabled, LSP metric: 3
LSP Protection: None
Label in: -, Label out: 24320,
Tspec rate: 0k, Fspec rate: 0k
Policer: Not Configured
Tunnel Id: 5002, LSP Id: 2202, Ext-Tunnel Id: 40.40.40.40
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 13.1.1.2, xe11
Path refresh: 30 seconds (RR enabled) (due in 29850 seconds)
Resv lifetime: 157 seconds (due in 146 seconds)
Retry count: 0, intrvl: 30 seconds
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: none
Configured Path: path2 (in use)
Configured Explicit Route Detail :
13.1.1.2/32 strict
14.1.1.3/32 strict
15.1.1.4/32 strict
Session Explicit Route Detail :
13.1.1.2/32 strict
14.1.1.3/32 strict
15.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
<self>
13.1.1.2
14.1.1.3
15.1.1.4
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
Current Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Last Signaled Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Trunk Type: mpls
#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
B> vrf-PE1 1 24320 Nolabel N/A vrf-PE1 N/A LSP_DEFAULT
R> 40.40.40.40/32 2 24960 Nolabel N/A N/A 127.0.0.1 ELSP_CONFIG
R2#show ip ospf neighbor
Total number of full neighbors: 2
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
40.40.40.40 1 Full/Backup 00:00:37 10.10.1.1 xe1 0
48.48.48.48 1 Full/Backup 00:00:34 11.1.1.3 xe12 0
R2#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
Transit RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
47.47.47.47 40.40.40.40 PRI t1-Primary UP 00:14:13 1 1 SE 25600 25600 ELSP_CON
Total 1 displayed, Up 1, Down 0.
R2#
R2#
R2#
R2#show rsvp session detail
Transit
47.47.47.47
From: 40.40.40.40, LSPstate: Up, LSPname: t1-Primary
Transit upstream state: Operational, downstream state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 25600, Label out: 25600,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5001, LSP Id: 2201, Ext-Tunnel Id: 40.40.40.40
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 11.1.1.3, xe12 Upstream: 10.10.1.1, xe1
Path refresh: 30 seconds (RR enabled) (due in 29011 seconds)
Path lifetime: 157 seconds (due in 133 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 32105 seconds)
Resv lifetime: 157 seconds (due in 133 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
10.10.1.2/32 strict
11.1.1.3/32 strict
12.1.1.4/32 strict
Session Explicit Route Detail :
11.1.1.3/32 strict
12.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
10.10.1.1
<self>
11.1.1.3
12.1.1.4
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Recorded Time : N/A
Current Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Trunk Type: mpls
R2#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM, ! - using backup
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
LDP ilm-ecmp - disabled
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop pri LSP-Type
R> 47.47.47.47/32 1 25600 25600 N/A xe12 11.1.1.3 Yes ELSP_CONFIG
R3#show ip ospf neighbor
Total number of full neighbors: 2
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
46.46.46.46 1 Full/DR 00:00:31 11.1.1.2 xe40 0
47.47.47.47 1 Full/Backup 00:00:32 12.1.1.4 xe6
R3#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
Transit RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
47.47.47.47 40.40.40.40 PRI t1-Primary UP 00:20:52 1 1 SE 25600 25600 ELSP_CON
Total 1 displayed, Up 1, Down 0.
R3#show rsvp session detail
Transit
47.47.47.47
From: 40.40.40.40, LSPstate: Up, LSPname: t1-Primary
Transit upstream state: Operational, downstream state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 25600, Label out: 25600,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5001, LSP Id: 2201, Ext-Tunnel Id: 40.40.40.40
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 12.1.1.4, xe1 Upstream: 11.1.1.2, xe5
Path refresh: 30 seconds (RR enabled) (due in 28622 seconds)
Path lifetime: 157 seconds (due in 151 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 41536 seconds)
Resv lifetime: 157 seconds (due in 141 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
11.1.1.3/32 strict
12.1.1.4/32 strict
Session Explicit Route Detail :
12.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
10.10.1.1
11.1.1.2
<self>
12.1.1.4
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Recorded Time : N/A
Current Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Trunk Type: mpls
R3# R3#show rsvp session detail
Transit
47.47.47.47
From: 40.40.40.40, LSPstate: Up, LSPname: t1-Primary
Transit upstream state: Operational, downstream state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 25600, Label out: 25600,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5001, LSP Id: 2201, Ext-Tunnel Id: 40.40.40.40
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 12.1.1.4, xe6 Upstream: 11.1.1.2, xe40
Path refresh: 30 seconds (RR enabled) (due in 28622 seconds)
Path lifetime: 157 seconds (due in 151 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 41536 seconds)
Resv lifetime: 157 seconds (due in 141 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
11.1.1.3/32 strict
12.1.1.4/32 strict
Session Explicit Route Detail :
12.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
10.10.1.1
11.1.1.2
<self>
12.1.1.4
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Recorded Time : N/A
Current Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Trunk Type: mpls
R3#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM, ! - using backup
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
LDP ilm-ecmp - disabled
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop pri LSP-Type
R> 47.47.47.47/32 1 25600 25600 N/A xe6 12.1.1.4 Yes ELSP_CONFIG
R4:
R4#show ip ospf neighbor
Total number of full neighbors: 2
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
40.40.40.40 1 Full/Backup 00:00:33 13.1.1.1 xe2 0
58.58.58.58 1 Full/DR 00:00:39 14.1.1.3 xe3 0
R4#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
Transit RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
47.47.47.47 40.40.40.40 PRI t2-Primary UP 00:54:24 1 1 SE 24320 52480 ELSP_CON
Total 1 displayed, Up 1, Down 0.
R4#show rsvp session detail
Transit
47.47.47.47
From: 40.40.40.40, LSPstate: Up, LSPname: t2-Primary
Transit upstream state: Operational, downstream state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 24320, Label out: 52480,
Tspec rate: 0k, Fspec rate: 0k
Tunnel Id: 5002, LSP Id: 2202, Ext-Tunnel Id: 40.40.40.40
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 14.1.1.3, xe3 Upstream: 13.1.1.1, xe2
Path refresh: 30 seconds (RR enabled) (due in 26617 seconds)
Path lifetime: 157 seconds (due in 143 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 36430 seconds)
Resv lifetime: 157 seconds (due in 143 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
13.1.1.2/32 strict
14.1.1.3/32 strict
15.1.1.4/32 strict
Session Explicit Route Detail :
14.1.1.3/32 strict
15.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
13.1.1.1
<self>
14.1.1.3
15.1.1.4
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Current Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Trunk Type: mpls R4#
R4#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop LSP-Type
R> 47.47.47.47/32 1 24320 52480 N/A xe3 14.1.1.3 ELSP_CONFIG
R5#show ip ospf neighbor
Total number of full neighbors: 2
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
56.56.56.56 1 Full/Backup 00:00:39 14.1.1.2 xe42 0
47.47.47.47 1 Full/DR 00:00:38 15.1.1.4 xe39 0
R5#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
Transit RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
47.47.47.47 40.40.40.40 PRI t2-Primary UP 00:59:48 1 1 SE 52480 25601 ELSP_CON
Total 1 displayed, Up 1, Down 0.
R5#show rsvp session detail
Transit
47.47.47.47
From: 40.40.40.40, LSPstate: Up, LSPname: t2-Primary
Transit upstream state: Operational, downstream state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 52480, Label out: 25601,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5002, LSP Id: 2202, Ext-Tunnel Id: 40.40.40.40
Bind value: 0, Oper state: NA, Alloc mode: NA
Downstream: 15.1.1.4, xe39 Upstream: 14.1.1.2, xe42
Path refresh: 30 seconds (RR enabled) (due in 26344 seconds)
Path lifetime: 157 seconds (due in 149 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 37267 seconds)
Resv lifetime: 157 seconds (due in 132 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
14.1.1.3/32 strict
15.1.1.4/32 strict
Session Explicit Route Detail :
15.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
13.1.1.1
14.1.1.2
<self>
15.1.1.4
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Current Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Trunk Type: mpls
R5#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM, ! - using backup
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
U - unknown
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop pri LSP-Type
R> 47.47.47.47/32 1 52480 25601 N/A xe39 15.1.1.4 Yes ELSP_CONFIG
R5#
R5#
R6:
R6#show ip ospf neighbor
Total number of full neighbors: 2
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
48.48.48.48 1 Full/DR 00:00:30 12.1.1.3 xe6 0
58.58.58.58 1 Full/Backup 00:00:33 15.1.1.3 xe5 0
R6#show rsvp session
Type : PRI - Primary, SEC - Secondary, DTR - Detour, BPS - Bypass
State : UP - Up, DN - Down, BU - Backup in Use, SU - Secondary in Use, FS - Forced to Secondary
* indicates the session is active with local repair at one or more nodes
(P) indicates the secondary-priority session is acting as primary
Egress RSVP:
To From Type LSPName State Uptime Rt Style Labelin Labelout DSType
47.47.47.47 40.40.40.40 PRI t1-Primary UP 01:05:33 1 1 SE 25600 - ELSP_CON
47.47.47.47 40.40.40.40 PRI t2-Primary UP 01:04:57 1 1 SE 25601 - ELSP_CON
Total 2 displayed, Up 2, Down 0.
R6#
R6#show rsvp session detail
Egress
47.47.47.47
From: 40.40.40.40, LSPstate: Up, LSPname: t1-Primary
Egress FSM state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 25600, Label out: -,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5001, LSP Id: 2201, Ext-Tunnel Id: 40.40.40.40
Bind value: 0, Oper state: NA, Alloc mode: NA
Upstream: 12.1.1.3, xe6
Path lifetime: 157 seconds (due in 143 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 19100 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
12.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
10.10.1.1
11.1.1.2
12.1.1.3
<self>
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Recorded Time : N/A
Current Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Trunk Type: mpls
Egress
47.47.47.47
From: 40.40.40.40, LSPstate: Up, LSPname: t2-Primary
Egress FSM state: Operational
Setup priority: 7, Hold priority: 0
IGP-Shortcut: Disabled, LSP metric: 65
LSP Protection: None
Label in: 25601, Label out: -,
Tspec rate: 0, Fspec rate: 0
Tunnel Id: 5002, LSP Id: 2202, Ext-Tunnel Id: 40.40.40.40
Bind value: 0, Oper state: NA, Alloc mode: NA
Upstream: 15.1.1.3, xe5
Path lifetime: 157 seconds (due in 156 seconds)
Resv refresh: 30 seconds (RR enabled) (due in 30939 seconds)
RRO re-use as ERO: Disabled
Label Recording: Disabled
Admin Groups: Received Explicit Route Detail :
15.1.1.4/32 strict
Record route:
-------------------------------------------------------------
IP Address Label
-------------------------------------------------------------
13.1.1.1
14.1.1.2
15.1.1.3
<self>
Style: Shared Explicit Filter
Traffic type: controlled-load
Minimum Path MTU: 1500
LSP Type: ELSP_CONFIG
CLASS DSCP_value EXP_value
Recorded Time : N/A
Current Error:
Code : None, Value : None
Originated Node : None, Recorded Time : N/A
Trunk Type: mpls
R6#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM, ! - using backup
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
LDP ilm-ecmp - disabled
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop pri LSP-Type
R> 47.47.47.47/32 1 25600 Nolabel N/A N/A 127.0.0.1 Yes ELSP_CONFIG
R> 47.47.47.47/32 2 25601 Nolabel N/A N/A 127.0.0.1 Yes ELSP_CONFIG