#configure terminal | Enter Configure mode. |
(config)#interface xe1 | Specify the interface to be configured on Host A |
(config-if)#ip address 20.20.0.3/8 | Configure the IP address on the interface |
(config)# ip route 0.0.0.0/0 20.20.0.1 | Configure the default gateway |
(config)#commit | Commit the candidate configuration to the running configuration |
(config)#end | Exit interface and configure mode |
#configure terminal | Enter Configure mode |
(config)#interface xe1 | Specify the interface to be configured on Host B |
(config-if)#ip address 20.20.1.2/24 | Configure the ip address on the interface |
(config)# ip route 0.0.0.0/0 20.20.1.1 | Configure the default gateway |
(config)#commit | Commit the candidate configuration to the running configuration |
(config)#end | Exit interface and configure mode |
#configure terminal | Enter Configure mode. |
(config)#interface xe1 | Specify the interface connected to Host A |
(config-if)#ip address 20.20.0.1/24 | Configure the ip address on the interface |
(config-if)#interface xe2 | Specify the interface connected to Host B |
(config-if)#ip address 20.20.1.1/24 | Configure the ip address on the interface |
(config-if)#interface xe1 | Specify the interface to configure Proxy ARP |
(config-if)#ip proxy-arp | Enable Proxy ARP |
(config)#commit | Commit the candidate configuration to the running configuration |
(config)#end | Exit interface and configure mode |
#configure terminal | Enter Configure mode. |
(config)#interface xe1 | Specify the interface to be configured on Host A |
(config-if)#ip address 20.20.0.2/24 | Configure the ip address on the interface |
(config)#commit | Commit the candidate configuration to the running configuration |
(config)#end | Exit interface and configure mode |
#configure terminal | Enter Configure mode |
(config)#interface xe1 | Specify the interface to be configured on Host B |
(config-if)#ip address 20.20.0.3/24 | Configure the ip address on the interface |
(config)#commit | Commit the candidate configuration to the running configuration |
(config)#end | Exit interface and configure mode |
#configure terminal | Enter Configure mode. |
(config)#bridge 1 protocol ieee vlan-bridge | Create ieee vlan-bridge on switch for pvlan configuration |
(config)#vlan database | Enter into the vlan database |
(config-vlan)#vlan 100-101 bridge 1 state enable | Create vlans 100 and 101 as part of bridge 1 |
(config-vlan)#private-vlan 100 primary bridge 1 | Configure vlan 100 as a primary vlan |
(config-vlan)#private-vlan 101 isolated bridge 1 | Configure vlan 101 as a isolated vlan |
(config-vlan)#private-vlan 100 association add 101 bridge 1 | Associate secondary vlan 101 to primary vlan 100 |
(config-vlan)#exit | Exit from the vlan database |
(config)#commit | Commit the candidate configuration to the running configuration |
(config)#interface xe1 | Specify the interface to be configured |
(config-if)#switchport | Configure xe1 as a layer2 interface. |
(config-if)#switchport mode access | Set the switching characteristics of this interface to access mode. |
(config-if)#bridge-group 1 | Associate the interface to the bridge |
(config-if)#switchport access vlan 100 | Associate primary vlan to the interface |
(config-if)#switchport mode private-vlan promiscuous | Configure xe1 interface as a promiscuous port |
(config-if)#switchport private-vlan mapping 100 add 101 | Associate primary vlan 100 and secondary vlan 101 to a promiscuous port |
(config-if)#exit | Exit interface mode |
(config)#commit | Commit the candidate configuration to the running configuration |
(config)#interface xe2 | Specify the interface to be configured |
(config-if)#switchport | Configure xe2 as a layer2 interface. |
(config-if)#switchport mode access | Set the switching characteristics of this interface to access mode. |
(config-if)#bridge-group 1 | Associate the interface to the bridge |
(config-if)#switchport access vlan 100 | Associate primary vlan to the interface |
(config-if)#switchport mode private-vlan promiscuous | Configure xe2 interface as a promiscuous port |
(config-if)#switchport private-vlan mapping 100 add 101 | Associate primary vlan 100 and secondary vlan 101 to a promiscuous port |
(config-if)#exit | Exit interface mode |
(config)#commit | Commit the candidate configuration to the running configuration |
(config)#interface xe3 | Specify the interface to be configured |
(config-if)#switchport | Configure xe3 as a layer2 interface. |
(config-if)#switchport mode access | Set the switching characteristics of this interface to access mode. |
(config-if)#bridge-group 1 | Associate the interface to the bridge |
(config-if)#switchport access vlan 100 | Associate primary VLAN to the interface |
(config-if)#switchport mode private-vlan promiscuous | Configure xe2 interface as a promiscuous port |
(config-if)#switchport private-vlan mapping 100 add 101 | Associate primary vlan 100 and secondary vlan 101 to a promiscuous port |
(config-if)#exit | Exit interface mode |
(config)#commit | Commit the candidate configuration to the running configuration |
#configure terminal | Enter Configure mode |
(config)#interface xe1 | Specify the interface to be configured on router |
(config-if)#ip address 20.20.0.1/24 | Configure the ip address on the interface |
(config-if)#ip local-proxy-arp | Enable Local Proxy ARP |
(config)#commit | Commit the candidate configuration to the running configuration |
(config)#end | Exit interface and configure mode |