ISIS Segment Routing Micro-Loop Avoidance
Micro-loop avoidance provides a mechanism leveraging SR to ensure loop-freeness during the IGP re-convergence process following a link-state change event. Using segment routing, a headend can enforce an explicit path without creating any state along the post-convergence path. As a result, a converging node can enforce traffic on the post-convergence path in a loop-free manner, using a SID list (typically short). So nodes converge over their new optimal path, but temporarily use an SR policy to ensure loop-freeness over that path.
Topology
ISIS-SR micro-loop avoidance
PE1
PE1#configure terminal | Enter configure mode. |
PE1(config)#hardware-profile micro-bfd enable | Enable hardware profile micro bfd |
PE1(config)#bfd interval 3 minrx 3 multiplier 3 | Enable bfd interval min with 3 multiplier 3 |
PE1(config)#qos enable | Enable qos |
PE1(config)#vlan database | Configure vlan database |
PE1(config)#vlan 20 bridge 1 state enable | Configure vlan id |
PE1(config)#interface lo | Enter loopback interface mode |
PE1(config-if)#ip address 26.26.26.26/32 secondary | Configure the secondary IP address of the- loopback interface. |
PE1(config-if)#prefix-sid index 100 no-php | Configure sid value with no-php |
PE1(config-if)#ip router isis 1 | Make the interface part of the router isis instance. |
PE1(config-if)#exit | Exit from interface mode. |
PE1(config)#interface po1 | Configure interface as po1 |
PE1(config-if)#exit | Exit from interface mode. |
PE1(config)#interface po1.10 | Configure interface as po1 subinterface |
PE1(config-if)#encapsulation dot1q 10 | Enable encapsulate dot1q |
PE1(config-if)#ip address 10.1.1.26/24 | Configure the IP address of the interface. |
PE1(config-if)#label-switching | Enable label switching. |
PE1(config-if)#isis network point-to-point | Enable network as point to point. |
PE1(config-if)#ip router isis 1 | Make the interface part of the router isis instance. |
PE1(config-if)#exit | Exit from interface mode |
PE1(config)#interface vlan1.20 | Enter vlan interface mode. |
PE1(config-if)#ip address 20.1.1.26/24 | Configure the IP address of the interface. |
PE1(config-if)#label-switching | Enable label switching. |
PE1(config-if)#isis network point-to-point | Enable network as point to point |
PE1(config-if)#ip router isis 1 | Make the interface part of the router isis instance. |
PE1(config-if)#exit | Exit interface mode. |
PE1(config)#interface xe2 | Enter interface mode. |
PE1(config-if)#switchport | Enter the switchport mode. |
PE1(config-if)#bridge-group 1 | Enable bridge group |
PE1(config-if)#switchport mode trunk | Enter switchport mode trunk |
PE1(config-if)#switchport trunk allowed vlan add 20 | Enter switchport trunk allow vlan and add vlan id |
PE1(config-if)#exit | Exit interface mode. |
PE1(config)#interface xe7 | Enter interface mode. |
PE1(config-if)#channel-group 1 mode active | Enable channel group 1 mode active |
PE1(config-if)#exit | Exit interface mode. |
PE1(config)#commit | Commit the candidate configuration to the running configuration |
PE1(config)#router isis 1 | Set the routing process ID. |
PE1(config-router)#is-type level-1-2 | Enable iks-type as level1-2 |
PE1(config-router)#spf-interval-exp 10000 10000 | Enable spf interval value |
PE1(config-router)#metric-style wide | Configure Network entity title (NET). |
PE1(config-router)#microloop-avoidance level-1 | Enable microloop avoidance as level-1 |
PE1(config-router)#microloop-avoidance level-2 | Enable microloop avoidance as level-2 |
PE1(config-router)#mpls traffic-eng router-id 26.26.26.26 | Enable mpls traffic eng router-id |
PE1(config-router)#mpls traffic-eng level-1 | Enable MPLS Traffic Engineering as level-1. |
PE1(config-router)#mpls traffic-eng level-2 | Enable MPLS Traffic Engineering as level-2. |
PE1(config-router)#dynamic-hostname | Enable dynamic-hostname under ISIS process. |
PE1(config-router)#fast-reroute ti-lfa level-1 proto ipv4 | Enable ti-lfa with level-1 |
PE1(config-router)#fast-reroute ti-lfa level-2 proto ipv4 | Enable ti-lfa with level-2 |
PE1(config-router)#bfd all-interfaces | Enable bfd all interfaces |
PE1(config-router)#net 49.0000.0000.0026.00 | Configure Network entity title (NET). |
PE1(config-router)#passive-interface lo | Enable passive interface with loopback |
PE1(config-router)#segment-routing mpls | Enable segment routing mpls ISIS processP1 |
PE1(config-router)#exit | Exit router mode. |
PE1(config)#commit | Commit the candidate configuration to the running configuration |
P1
P1#configure terminal | Enter configure mode. |
P1(config)#hardware-profile micro-bfd enable | Enable hardware profile micro bfd |
P1(config)#bfd interval 3 minrx 3 multiplier 3 | Enable bfd interval min with 3 multiplier 3 |
P1(config)#qos enable | Enable qos |
P1(config)#interface lo | Enter loopback interface mode |
P1(config-if)#ip address 3.3.3.3/32 secondary | Configure the secondary IP address of the- loopback interface. |
P1(config-if)#ip router isis 1 | Configure sid value with no-php |
P1(config-if)#prefix-sid index 200 no-php | Make the interface part of the router isis instance. |
P1(config-if)#exit | Exit from interface mode. |
P1(config)#interface po1 | Configure interface as po1 |
P1(config-if)#exit | Exit from interface mode. |
P1(config)#interface po1.10 | Configure interface as po1 subinterface |
P1(config-if)#encapsulation dot1q 10 | Enable encapsulate dot1q |
P1(config-if)#ip address 10.1.1.3/24 | Configure the IP address of the interface. |
P1(config-if)#label-switching | Enable label switching. |
P1(config-if)#isis network point-to-point | Enable network as point to point. |
P1(config-if)#ip router isis 1 | Make the interface part of the router isis instance. |
P1(config-if)#exit | Exit from interface mode |
P1(config)#interface po2 | Configure interface as po2 |
P1(config-if)#exit | Exit from interface mode. |
P1(config)#interface po2.11 | Configure interface as po2 subinterface |
P1(config-if)#encapsulation dot1q 11 | Enable encapsulate dot1q |
P1(config-if)#ip address 11.1.1.3/24 | Configure the IP address of the interface. |
P1(config-if)#label-switching | Enable label switching. |
P1(config-if)#isis network point-to-point | Enable network as point to point. |
P1(config-if)#ip router isis 1 | Make the interface part of the router isis instance. |
P1(config-if)#exit | Exit from interface mode |
P1(config)#interface ce43 | Enter interface modce |
P1(config-if)#channel-group 2 mode active | Enable channel group 2 mode active |
P1(config-if)#exit | Exit from interface mode |
P1(config)#interface xe7 | Enter interface mode |
P1(config-if)#channel-group 1 mode active | Enable channel group 1 mode active |
P1(config-if)#exit | Exit from interface mode |
P1(config)#router isis 1 | Set the routing process ID. |
P1(config-router)#is-type level-1-2 | Enable iks-type as level1-2 |
P1(config-router)#spf-interval-exp 10000 10000 | Enable spf interval value |
P1(config-router)#metric-style wide | Configure Network entity title (NET). |
P1(config-router)#microloop-avoidance level-1 | Enable microloop avoidance as level-1 |
P1(config-router)#microloop-avoidance level-2 | Enable microloop avoidance as level-2 |
P1(config-router)#mpls traffic-eng router-id 3.3.3.3 | Enable mpls traffic eng router-id |
P1(config-router)#mpls traffic-eng level-1 | Enable MPLS Traffic Engineering as level-1. |
P1(config-router)#mpls traffic-eng level-2 | Enable MPLS Traffic Engineering as level-2. |
P1(config-router)#capability cspf | Enable capability cspf |
P1(config-router)#dynamic-hostname | Enable dynamic-hostname under ISIS process. |
P1(config-router)#set-overload-bit on-startup 120 | Configure set overload bit on startup |
P1(config-router)#fast-reroute ti-lfa level-1 proto ipv4 | Enable ti-lfa with level-1 |
P1(config-router)#fast-reroute ti-lfa level-2 proto ipv4 | Enable ti-lfa with level-2 |
P1(config-router)#bfd all-interfaces | Enable bfd all interfaces |
P1(config-router)#net 49.0000.0000.0003.00 | Configure Network entity title (NET). |
P1(config-router)#passive-interface lo | Enable passive interface with loopback |
P1(config-router)#segment-routing mpls | Enable segment routing mpls ISIS process. |
P1(config-router)#exit | Exit router mode. |
P1(config)#commit | Commit the candidate configuration to the running configuration |
P2
P2#configure terminal | Enter configure mode. |
P2(config)#hardware-profile micro-bfd enable | Enable hardware profile micro bfd |
P2(config)#bfd interval 3 minrx 3 multiplier 3 | Enable bfd interval min with 3 multiplier 3 |
P2(config)#qos enable | Enable qos |
P2(config)#vlan database | Configure vlan database |
P2(config-vlan)#vlan 20 bridge 1 state enable | Configure vlan id |
P2(config-vlan)#exit | Exit from vlan mode |
P2(config)#interface lo | Enter loopback interface mode |
P2(config-if)#ip address 2.2.2.2/32 secondary | Configure the secondary IP address of the- loopback interface. |
P2(config-if)#prefix-sid index 400 no-php | Configure sid value with no-php |
P2(config-if)#ip router isis 1 | Make the interface part of the router isis instance. |
P2(config-if)#exit | Exit from interface mode. |
P2(config)#interface xe1 | Enter the interface mode. |
P2(config-if)#ip address 81.1.1.1/24 | Configure the IP address of the interface. |
P2(config-if)#label-switching | Enable label switching. |
P2(config-if)#isis network point-to-point | Enable isis network as point to point. |
P2(config-if)#ip router isis 1 | Make the interface part of the router isis instance. |
P2(config-if)#exit | Exit from interface mode. |
P2(config)#interface xe2 | Enter interface mode. |
P2(config-if)#switchport | Enable switchport |
P2(config-if)#bridge-group 1 | Enable bridge group 1 |
P2(config-if)#switchport mode trunk | Enable switchport mode trunk |
P2(config-if)#switchport trunk allowed vlan add 20 | Enable switchport trunk allow vlan with vlan id. |
P2(config-if)#exit | Exit from interface mode. |
P2(config)#router isis 1 | Set the routing process ID. |
P2(config-router)#is-type level-1-2 | Enable is-type as level1-2 |
P2(config-router)#spf-interval-exp 10000 10000 | Enable spf interval value |
P2(config-router)#metric-style wide | Configure metric style wide |
P2(config-router)#microloop-avoidance level-1 | Enable microloop avoidance as level-1 |
P2(config-router)#microloop-avoidance level-2 | Enable microloop avoidance as level-2 |
P2(config-router)#mpls traffic-eng router-id 2.2.2.2 | Enable mpls traffic eng router-id |
P2(config-router)#mpls traffic-eng level-1 | Enable MPLS Traffic Engineering as level-1. |
P2(config-router)#mpls traffic-eng level-2 | Enable MPLS Traffic Engineering as level-2. |
P2(config-router)#dynamic-hostname | Enable dynamic-hostname under ISIS process. |
P2(config-router)#fast-reroute ti-lfa level-1 proto ipv4 | Enable ti-lfa with level-1 |
P2(config-router)#fast-reroute ti-lfa level-2 proto ipv4 | Enable ti-lfa with level-2 |
P2(config-router)#bfd all-interfaces | Enable bfd all interfaces |
P2(config-router)#net 49.0000.0000.0002.00 | Configure Network entity title (NET). |
P2(config-router)#passive-interface lo | Enable passive interface with loopback |
P2(config-router)#segment-routing mpls | Enable segment routing mpls ISIS process. |
P2(config-router)#exit | Exit router mode. |
P2(config)#commit | Commit the candidate configuration to the running configuration |
P3
P3#configure terminal | Enter configure mode. |
P3(config)#bfd interval 3 minrx 3 multiplier 3 | Enable bfd interval min with 3 multiplier 3 |
P3(config)#qos enable | Enable qos |
P3(config)#interface lo | Enter loopback interface mode |
P3(config-if)#ip address 6.6.6.6/32 secondary | Configure the secondary IP address of the- loopback interface. |
P3(config-if)#prefix-sid index 6 no-php | Configure sid value with no-php |
P3(config-if)#ip router isis 1 | Make the interface part of the router isis instance. |
P3(config-if)#exit | Exit from interface mode. |
P3(config-if)#interface ce14 | Enter interface mode. |
P3(config-if)#ip address 82.1.1.2/24 | Configure the IP address of the interface. |
P3(config-if)#label-switching | Enable label switching. |
P3(config-if)#isis network point-to-point | Configure isis network as point to point. |
P3(config-if)#ip router isis 1 | Make the interface part of the router isis instance. |
P3(config-if)#exit | Exit from interface mode |
P3(config)#interface xe1 | Enter interface mode. |
P3(config-if)#ip address 81.1.1.2/24 | Configure the IP address of the interface. |
P3(config-if)#label-switching | Enable label switching. |
P3(config-if)#isis network point-to-point | Configure isis network as point to point. |
P3(config-if)#ip router isis 1 | Make the interface part of the router isis instance. |
P3(config-if)#exit | Exit from interface mode. |
P3(config)#router isis 1 | Set the routing process ID. |
P3(config-router)#is-type level-1-2 | Enable iks-type as level1-2 |
P3(config-router)#spf-interval-exp 10000 10000 | Enable spf interval value |
P3(config-router)#metric-style wide | Configure Network entity title (NET). |
P3(config-router)#microloop-avoidance level-1 | Enable microloop avoidance as level-1 |
P3(config-router)#microloop-avoidance level-2 | Enable microloop avoidance as level-2 |
P3(config-router)#mpls traffic-eng router-id 6.6.6.6 | Enable mpls traffic eng router-id |
P3(config-router)#mpls traffic-eng level-1 | Enable MPLS Traffic Engineering as level-1. |
P3(config-router)#mpls traffic-eng level-2 | Enable MPLS Traffic Engineering as level-2. |
P3(config-router)#dynamic-hostname | Enable dynamic-hostname under ISIS process. |
P3(config-router)#fast-reroute ti-lfa level-1 proto ipv4 | Enable ti-lfa with level-1 |
P3(config-router)#fast-reroute ti-lfa level-2 proto ipv4 | Enable ti-lfa with level-2 |
P3(config-router)#bfd all-interfaces | Enable bfd all interfaces |
P3(config-router)#net 49.0000.0000.0006.00 | Configure Network entity title (NET). |
P3(config-router)#passive-interface lo | Enable passive interface with loopback |
P3(config-router)#segment-routing mpls | Enable segment routing mpls ISIS process. |
P3(config-router)#exit | Exit router mode. |
P3(config)#commit | Commit the candidate configuration to the running configuration |
PE2
PE2#configure terminal | Enter configure mode. |
PE2(config)#bfd interval 3 minrx 3 | Enable bfd interval min with 3 multiplier 3 |
PE2(config)#qos enable | Enable qos |
PE2(config)#interface lo | Enter loopback interface mode |
PE2(config-if)#ip address 23.23.23.23/32 secondary | Configure the secondary IP address of the- loopback interface. |
PE2(config-if)#prefix-sid index 300 no-php | Configure sid value with no-php |
PE2(config-if)#ip router isis 1 | Make the interface part of the router isis instance. |
PE2(config-if)#exit | Exit from interface mode. |
PE2(config)#interface po2 | Configure interface as po2 |
PE2(config-if)#exit | Exit from interface mode. |
PE2(config)#interface po2.11 | Configure interface as po2 subinterface |
PE2(config-if)#encapsulation dot1q 11 | Enable encapsulate dot1q |
PE2(config-if)#ip address 11.1.1.23/24 | Configure the IP address of the interface. |
PE2(config-if)#label-switching | Enable label switching. |
PE2(config-if)#isis network point-to-point | Enable network as point to point. |
PE2(config-if)#ip router isis 1 | Make the interface part of the router isis instance. |
PE2(config-if)#exit | Exit from interface mode |
PE2(config)#interface ce14 | Enter interface mode. |
PE2(config-if)#ip address 82.1.1.1/24 | Configure the IP address of the interface. |
PE2(config-if)#label-switching | Enable label switching. |
PE2(config-if)#isis network point-to-point | Enable network as point to point. |
PE2(config-if)#ip router isis 1 | Make the interface part of the router isis instance. |
PE2(config-if)#exit | Exit from interface mode. |
PE2(config)#interface ce43 | Enter interface mode. |
PE2(config-if)#channel-group 2 mode active | Enable channel group 2 mode active |
PE2(config-if)#exit | Exit from interface mode. |
PE2(config)#router isis 1 | Set the routing process ID. |
PE2(config-router)#is-type level-1-2 | Enable iks-type as level1-2 |
PE2(config-router)#spf-interval-exp 10000 10000 | Enable spf interval value |
PE2(config-router)#metric-style wide | Enable metric style wide |
PE2(config-router)#microloop-avoidance level-1 | Enable microloop avoidance as level-1 |
PE2(config-router)#microloop-avoidance level-2 | Enable microloop avoidance as level-2 |
PE2(config-router)#mpls traffic-eng router-id 23.23.23.23 | Enable mpls traffic eng router-id |
PE2(config-router)#mpls traffic-eng level-1 | Enable MPLS Traffic Engineering as level-1. |
PE2(config-router)#mpls traffic-eng level-2 | Enable MPLS Traffic Engineering as level-2. |
PE2(config-router)#dynamic-hostname | Enable dynamic-hostname under ISIS process. |
PE2(config-router)#fast-reroute ti-lfa level-1 proto ipv4 | Enable ti-lfa with level-1 |
PE2(config-router)#fast-reroute ti-lfa level-2 proto ipv4 | Enable ti-lfa with level-2 |
PE2(config-router)#bfd all-interfaces | Enable bfd all interfaces |
PE2(config-router)#net 49.0000.0000.0023.00 | Configure Network entity title (NET). |
PE2(config-router)#passive-interface lo | Enable passive interface with loopback |
PE2(config-router)#segment-routing mpls | Enable segment routing mpls ISIS process. |
PE2(config-router)#exit | Exit router mode. |
PE2(config)#commit | Commit the candidate configuration to the running configuration |
Note: By default, PHP is enabled. To see all the labels in MPLS forwarding and ILM tables, we have enabled with non-php option.
Validation
Validation 1
Verify ISIS neighbor adjacency between routers.
PE1#show clns neighbors
Total number of L1 adjacencies: 2
Total number of L2 adjacencies: 2
Total number of adjacencies: 4
Tag 1: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
P2 vlan1.20 e8c5.7a76.581d Up 19 L1L2 IS-IS
P1 po1.10 3417.ebe4.af32 Up 19 L1L2 IS-IS
PE1#
P1#show clns neighbors
Total number of L1 adjacencies: 2
Total number of L2 adjacencies: 2
Total number of adjacencies: 4
Tag 1: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
PE1 po1.10 b86a.9725.a7f2 Up 26 L1L2 IS-IS
PE2 po2.11 5c07.5819.4890 Up 24 L1L2 IS-IS
P1#
P2#show clns neighbors
Total number of L1 adjacencies: 2
Total number of L2 adjacencies: 2
Total number of adjacencies: 4
Tag 1: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
P3 xe1 e8c5.7a25.f40c Up 21 L1L2 IS-IS
PE1 vlan1.20 b86a.9725.a7bb Up 25 L1L2 IS-IS
P2#
P3#show clns neighbors
Total number of L1 adjacencies: 2
Total number of L2 adjacencies: 2
Total number of adjacencies: 4
Tag 1: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
P2 xe1 e8c5.7a76.581f Up 22 L1L2 IS-IS
PE2 ce14 5c07.5819.4882 Up 22 L1L2 IS-IS
P3#
PE2#show clns neighbors
Total number of L1 adjacencies: 2
Total number of L2 adjacencies: 2
Total number of adjacencies: 4
Tag 1: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
P3 ce14 e8c5.7a25.f41b Up 25 L1L2 IS-IS
P1 po2.11 3417.ebe4.af33 Up 27 L1L2 IS-IS
PE2#
Validation 2
The command output below displays the details of routers configured with segment routing.
PE1#show isis segment-routing capability
Tag 1 Segment-Routing:
-----------------------------------------------------
Advertisement Router Capability :2.2.2.2
Algorithm0 :0
SRMS Preference :0
Total SID'S Supported :8000
SID Range List Count :1
SID's Range :16000 - 23999
Total SID'S Supported (SRLB) :0
SRLB Range List Count :0
-----------------------------------------------------
Advertisement Router Capability :3.3.3.3
Algorithm0 :0
SRMS Preference :0
Total SID'S Supported :8000
SID Range List Count :1
SID's Range :16000 - 23999
Total SID'S Supported (SRLB) :0
SRLB Range List Count :0
-----------------------------------------------------
Advertisement Router Capability :6.6.6.6
Algorithm0 :0
SRMS Preference :0
Total SID'S Supported :8000
SID Range List Count :1
SID's Range :16000 - 23999
Total SID'S Supported (SRLB) :0
SRLB Range List Count :0
-----------------------------------------------------
Advertisement Router Capability :23.23.23.23
Algorithm0 :0
SRMS Preference :0
Total SID'S Supported :8000
SID Range List Count :1
SID's Range :16000 - 23999
Total SID'S Supported (SRLB) :0
SRLB Range List Count :0
-----------------------------------------------------
Advertisement Router Capability :26.26.26.26
Algorithm0 :0
SRMS Preference :0
Total SID'S Supported :8000
SID Range List Count :1
SID's Range :16000 - 23999
Total SID'S Supported (SRLB) :0
SRLB Range List Count :0
-----------------------------------------------------
PE1#
Validation 3
Verify that segment routing information is present in ISIS database.
PE1#show isis database verbose
Tag 1: VRF : default
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
P2.00-00 0x00000013 0x671A 898 0/0/0
Area Address: 49
NLPID: 0xCC
Hostname: P2
IP Address: 21.1.1.2
Router ID: 2.2.2.2
Router Cap: 2.2.2.2
SRGB Range: 8000 SRGB Base SID: 16000 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended PE1.00
IPv4 Interface Address: 20.1.1.2
Neighbor IP Address: 20.1.1.26
Maximum Link Bandwidth : 1000000.00 kbits/sec
Reservable Bandwidth : 1000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 1000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 25600 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IS-Extended P3.00
IPv4 Interface Address: 81.1.1.1
Neighbor IP Address: 81.1.1.2
Maximum Link Bandwidth : 10000000.00 kbits/sec
Reservable Bandwidth : 10000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 10000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 25601 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 21.1.1.0/24
Metric: 0 IP-Extended 2.2.2.2/32
Prefix-SID: index 400 R:0 N:1 P:1 E:0 V:0 L:0
Metric: 10 IP-Extended 20.1.1.0/24
Metric: 10 IP-Extended 81.1.1.0/24
P1.00-00 0x00000015 0xF8A6 1113 0/0/0
Area Address: 49
NLPID: 0xCC
Hostname: P1
IP Address: 22.1.1.3
Router ID: 3.3.3.3
Router Cap: 3.3.3.3
SRGB Range: 8000 SRGB Base SID: 16000 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended PE1.00
IPv4 Interface Address: 10.1.1.3
Neighbor IP Address: 10.1.1.26
Maximum Link Bandwidth : 1000000.00 kbits/sec
Reservable Bandwidth : 1000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 1000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 25600 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IS-Extended PE2.00
IPv4 Interface Address: 11.1.1.3
Neighbor IP Address: 11.1.1.23
Maximum Link Bandwidth : 1000000.00 kbits/sec
Reservable Bandwidth : 1000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 1000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 25601 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 22.1.1.0/24
Metric: 0 IP-Extended 3.3.3.3/32
Prefix-SID: index 200 R:0 N:1 P:1 E:0 V:0 L:0
Metric: 10 IP-Extended 10.1.1.0/24
Metric: 10 IP-Extended 11.1.1.0/24
P3.00-00 0x00000011 0xF02F 865 0/0/0
Area Address: 49
NLPID: 0xCC
Hostname: P3
IP Address: 82.1.1.2
Router ID: 6.6.6.6
Router Cap: 6.6.6.6
SRGB Range: 8000 SRGB Base SID: 16000 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended P2.00
IPv4 Interface Address: 81.1.1.2
Neighbor IP Address: 81.1.1.1
Maximum Link Bandwidth : 10000000.00 kbits/sec
Reservable Bandwidth : 10000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 10000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 25600 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IS-Extended PE2.00
IPv4 Interface Address: 82.1.1.2
Neighbor IP Address: 82.1.1.1
Maximum Link Bandwidth : 100000000.00 kbits/sec
Reservable Bandwidth : 100000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 100000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 25601 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 82.1.1.0/24
Metric: 10 IP-Extended 81.1.1.0/24
Metric: 0 IP-Extended 6.6.6.6/32
Prefix-SID: index 6 R:0 N:1 P:1 E:0 V:0 L:0
PE2.00-00 0x00000016 0x2CF0 1130 0/0/0
Area Address: 49
NLPID: 0xCC
Hostname: PE2
IP Address: 22.1.1.23
Router ID: 23.23.23.23
Router Cap: 23.23.23.23
SRGB Range: 8000 SRGB Base SID: 16000 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended P1.00
IPv4 Interface Address: 11.1.1.23
Neighbor IP Address: 11.1.1.3
Maximum Link Bandwidth : 1000000.00 kbits/sec
Reservable Bandwidth : 1000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 1000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 27520 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IS-Extended P3.00
IPv4 Interface Address: 82.1.1.1
Neighbor IP Address: 82.1.1.2
Maximum Link Bandwidth : 100000000.00 kbits/sec
Reservable Bandwidth : 100000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 100000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 27521 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 22.1.1.0/24
Metric: 0 IP-Extended 23.23.23.23/32
Prefix-SID: index 300 R:0 N:1 P:1 E:0 V:0 L:0
Metric: 10 IP-Extended 11.1.1.0/24
Metric: 10 IP-Extended 82.1.1.0/24
PE1.00-00 * 0x00000016 0x14BF 919 0/0/0
Area Address: 49
NLPID: 0xCC
Hostname: PE1
IP Address: 10.1.1.26
Router ID: 26.26.26.26
Router Cap: 26.26.26.26
SRGB Range: 8000 SRGB Base SID: 16000 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended P1.00
IPv4 Interface Address: 10.1.1.26
Neighbor IP Address: 10.1.1.3
Maximum Link Bandwidth : 1000000.00 kbits/sec
Reservable Bandwidth : 1000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 1000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 27520 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IS-Extended P2.00
IPv4 Interface Address: 20.1.1.26
Neighbor IP Address: 20.1.1.2
Maximum Link Bandwidth : 1000000.00 kbits/sec
Reservable Bandwidth : 1000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 1000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 27521 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 0 IP-Extended 26.26.26.26/32
Prefix-SID: index 100 R:0 N:1 P:1 E:0 V:0 L:0
Metric: 10 IP-Extended 20.1.1.0/24
Metric: 10 IP-Extended 10.1.1.0/24
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
P2.00-00 0x0000001A 0xB346 898 0/0/0
Area Address: 49
NLPID: 0xCC
Hostname: P2
IP Address: 21.1.1.2
Router ID: 2.2.2.2
Router Cap: 2.2.2.2
SRGB Range: 8000 SRGB Base SID: 16000 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended PE1.00
IPv4 Interface Address: 20.1.1.2
Neighbor IP Address: 20.1.1.26
Maximum Link Bandwidth : 1000000.00 kbits/sec
Reservable Bandwidth : 1000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 1000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 25600 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IS-Extended P3.00
IPv4 Interface Address: 81.1.1.1
Neighbor IP Address: 81.1.1.2
Maximum Link Bandwidth : 10000000.00 kbits/sec
Reservable Bandwidth : 10000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 10000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 25601 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 21.1.1.0/24
Metric: 0 IP-Extended 2.2.2.2/32
Prefix-SID: index 400 R:0 N:1 P:1 E:0 V:0 L:0
Metric: 10 IP-Extended 20.1.1.0/24
Metric: 20 IP-Extended 3.3.3.3/32
Prefix-SID: index 200 R:1 N:0 P:1 E:0 V:0 L:0
Metric: 20 IP-Extended 10.1.1.0/24
Metric: 30 IP-Extended 22.1.1.0/24
Metric: 10 IP-Extended 26.26.26.26/32
Prefix-SID: index 100 R:1 N:0 P:1 E:0 V:0 L:0
Metric: 30 IP-Extended 11.1.1.0/24
Metric: 20 IP-Extended 23.23.23.23/32
Prefix-SID: index 300 R:1 N:0 P:1 E:0 V:0 L:0
Metric: 10 IP-Extended 81.1.1.0/24
Metric: 20 IP-Extended 82.1.1.0/24
Metric: 10 IP-Extended 6.6.6.6/32
Prefix-SID: index 6 R:1 N:0 P:1 E:0 V:0 L:0
P1.00-00 0x0000001D 0x49B9 1113 0/0/0
Area Address: 49
NLPID: 0xCC
Hostname: P1
IP Address: 22.1.1.3
Router ID: 3.3.3.3
Router Cap: 3.3.3.3
SRGB Range: 8000 SRGB Base SID: 16000 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended PE1.00
IPv4 Interface Address: 10.1.1.3
Neighbor IP Address: 10.1.1.26
Maximum Link Bandwidth : 1000000.00 kbits/sec
Reservable Bandwidth : 1000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 1000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 25600 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IS-Extended PE2.00
IPv4 Interface Address: 11.1.1.3
Neighbor IP Address: 11.1.1.23
Maximum Link Bandwidth : 1000000.00 kbits/sec
Reservable Bandwidth : 1000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 1000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 25601 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 22.1.1.0/24
Metric: 0 IP-Extended 3.3.3.3/32
Prefix-SID: index 200 R:0 N:1 P:1 E:0 V:0 L:0
Metric: 10 IP-Extended 10.1.1.0/24
Metric: 10 IP-Extended 26.26.26.26/32
Prefix-SID: index 100 R:1 N:0 P:1 E:0 V:0 L:0
Metric: 20 IP-Extended 20.1.1.0/24
Metric: 20 IP-Extended 2.2.2.2/32
Prefix-SID: index 400 R:1 N:0 P:1 E:0 V:0 L:0
Metric: 30 IP-Extended 21.1.1.0/24
Metric: 10 IP-Extended 11.1.1.0/24
Metric: 10 IP-Extended 23.23.23.23/32
Prefix-SID: index 300 R:1 N:0 P:1 E:0 V:0 L:0
Metric: 30 IP-Extended 81.1.1.0/24
Metric: 20 IP-Extended 82.1.1.0/24
Metric: 20 IP-Extended 6.6.6.6/32
Prefix-SID: index 6 R:1 N:0 P:1 E:0 V:0 L:0
P3.00-00 0x00000012 0xDC43 865 0/0/0
Area Address: 49
NLPID: 0xCC
Hostname: P3
IP Address: 82.1.1.2
Router ID: 6.6.6.6
Router Cap: 6.6.6.6
SRGB Range: 8000 SRGB Base SID: 16000 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended P2.00
IPv4 Interface Address: 81.1.1.2
Neighbor IP Address: 81.1.1.1
Maximum Link Bandwidth : 10000000.00 kbits/sec
Reservable Bandwidth : 10000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 10000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 10000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 25600 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IS-Extended PE2.00
IPv4 Interface Address: 82.1.1.2
Neighbor IP Address: 82.1.1.1
Maximum Link Bandwidth : 100000000.00 kbits/sec
Reservable Bandwidth : 100000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 100000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 25601 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 82.1.1.0/24
Metric: 10 IP-Extended 81.1.1.0/24
Metric: 0 IP-Extended 6.6.6.6/32
Prefix-SID: index 6 R:0 N:1 P:1 E:0 V:0 L:0
Metric: 10 IP-Extended 2.2.2.2/32
Prefix-SID: index 400 R:1 N:0 P:1 E:0 V:0 L:0
Metric: 20 IP-Extended 3.3.3.3/32
Prefix-SID: index 200 R:1 N:0 P:1 E:0 V:0 L:0
Metric: 30 IP-Extended 10.1.1.0/24
Metric: 20 IP-Extended 11.1.1.0/24
Metric: 20 IP-Extended 20.1.1.0/24
Metric: 20 IP-Extended 21.1.1.0/24
Metric: 20 IP-Extended 22.1.1.0/24
Metric: 10 IP-Extended 23.23.23.23/32
Prefix-SID: index 300 R:1 N:0 P:1 E:0 V:0 L:0
Metric: 20 IP-Extended 26.26.26.26/32
Prefix-SID: index 100 R:1 N:0 P:1 E:0 V:0 L:0
PE2.00-00 0x0000001A 0x6918 1130 0/0/0
Area Address: 49
NLPID: 0xCC
Hostname: PE2
IP Address: 22.1.1.23
Router ID: 23.23.23.23
Router Cap: 23.23.23.23
SRGB Range: 8000 SRGB Base SID: 16000 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended P1.00
IPv4 Interface Address: 11.1.1.23
Neighbor IP Address: 11.1.1.3
Maximum Link Bandwidth : 1000000.00 kbits/sec
Reservable Bandwidth : 1000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 1000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 27520 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IS-Extended P3.00
IPv4 Interface Address: 82.1.1.1
Neighbor IP Address: 82.1.1.2
Maximum Link Bandwidth : 100000000.00 kbits/sec
Reservable Bandwidth : 100000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 100000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 100000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 27521 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IP-Extended 22.1.1.0/24
Metric: 0 IP-Extended 23.23.23.23/32
Prefix-SID: index 300 R:0 N:1 P:1 E:0 V:0 L:0
Metric: 10 IP-Extended 11.1.1.0/24
Metric: 10 IP-Extended 3.3.3.3/32
Prefix-SID: index 200 R:1 N:0 P:1 E:0 V:0 L:0
Metric: 20 IP-Extended 10.1.1.0/24
Metric: 20 IP-Extended 2.2.2.2/32
Prefix-SID: index 400 R:1 N:0 P:1 E:0 V:0 L:0
Metric: 30 IP-Extended 20.1.1.0/24
Metric: 30 IP-Extended 21.1.1.0/24
Metric: 20 IP-Extended 26.26.26.26/32
Prefix-SID: index 100 R:1 N:0 P:1 E:0 V:0 L:0
Metric: 10 IP-Extended 82.1.1.0/24
Metric: 20 IP-Extended 81.1.1.0/24
Metric: 10 IP-Extended 6.6.6.6/32
Prefix-SID: index 6 R:1 N:0 P:1 E:0 V:0 L:0
PE1.00-00 * 0x0000001E 0x0FE6 919 0/0/0
Area Address: 49
NLPID: 0xCC
Hostname: PE1
IP Address: 10.1.1.26
Router ID: 26.26.26.26
Router Cap: 26.26.26.26
SRGB Range: 8000 SRGB Base SID: 16000 I:1 V:0
SR-Algorithm:
Algorithm: 0
Metric: 10 IS-Extended P1.00
IPv4 Interface Address: 10.1.1.26
Neighbor IP Address: 10.1.1.3
Maximum Link Bandwidth : 1000000.00 kbits/sec
Reservable Bandwidth : 1000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 1000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 27520 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 10 IS-Extended P2.00
IPv4 Interface Address: 20.1.1.26
Neighbor IP Address: 20.1.1.2
Maximum Link Bandwidth : 1000000.00 kbits/sec
Reservable Bandwidth : 1000000.00 kbits/sec
Unreserved Bandwidth:
Unreserved Bandwidth at priority 0: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 1: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 2: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 3: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 4: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 5: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 6: 1000000.00 kbits/sec
Unreserved Bandwidth at priority 7: 1000000.00 kbits/sec
TE-Default Metric: 10
Adjacency SID: 27521 F:0 B:0 V:1 L:1 S:0 P:0
Metric: 0 IP-Extended 26.26.26.26/32
Prefix-SID: index 100 R:0 N:1 P:1 E:0 V:0 L:0
Metric: 10 IP-Extended 20.1.1.0/24
Metric: 10 IP-Extended 10.1.1.0/24
Metric: 10 IP-Extended 3.3.3.3/32
Prefix-SID: index 200 R:1 N:0 P:1 E:0 V:0 L:0
Metric: 20 IP-Extended 22.1.1.0/24
Metric: 10 IP-Extended 2.2.2.2/32
Prefix-SID: index 400 R:1 N:0 P:1 E:0 V:0 L:0
Metric: 20 IP-Extended 21.1.1.0/24
Metric: 20 IP-Extended 11.1.1.0/24
Metric: 20 IP-Extended 23.23.23.23/32
Prefix-SID: index 300 R:1 N:0 P:1 E:0 V:0 L:0
Metric: 20 IP-Extended 81.1.1.0/24
Metric: 30 IP-Extended 82.1.1.0/24
Metric: 20 IP-Extended 6.6.6.6/32
Prefix-SID: index 6 R:1 N:0 P:1 E:0 V:0 L:0
PE1#
Validation 4
Verify that segment routing is enabled and that prefix SIDs are announced to other routers.
Verify that prefix SIDs are installed as labels in MPLS forwarding table. Verify the same in FTN and ILM tables.
PE1#show mpls forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, t - tunnel, P - SR Policy FTN,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport, (e) - FTN is ECMP
Code FEC FTN-ID Nhlfe-ID Tunnel-id Pri LSP-Type Out-Label Out-Intf ELC Nexthop
i> 2.2.2.2/32 2 8 0 Yes LSP_DEFAULT 16400 vlan1.20 No 20.1.1.2
i> 2.2.2.2/32 8 22 0 No LSP_DEFAULT 16400 - No 10.1.1.3
i> 3.3.3.3/32 1 4 0 Yes LSP_DEFAULT 16200 po1.10 No 10.1.1.3
i> 3.3.3.3/32 9 24 0 No LSP_DEFAULT 16200 - No 20.1.1.2
i> 6.6.6.6/32 5 18 0 Yes LSP_DEFAULT 16006 vlan1.20 No 20.1.1.2
i> 6.6.6.6/32 10 26 0 No LSP_DEFAULT 16006 - No 10.1.1.3
i> 6.6.6.6/32 7 20 2202 Yes LSP_DEFAULT 16006 vlan1.20 No 20.1.1.2
i> 23.23.23.23/32 3 10 0 Yes LSP_DEFAULT 16300 po1.10 No 10.1.1.3
i> 23.23.23.23/32 11 28 0 No LSP_DEFAULT 16300 - No 20.1.1.2
i> 23.23.23.23/32 6 19 2201 Yes LSP_DEFAULT 16300 po1.10 No 10.1.1.3
B> 2001::/64 4 15 0 Yes LSP_DEFAULT 25601 - No 23.23.23.23
PE1#
In the forwarding tables above, the configured prefix SIDs are in the Out-Label column which is expected and is global across the topology. The swap happens in between nodes with this prefix SID and there is no local labelling.
Also verify the ILM and FTN tables.
PE1#show mpls ilm-table
Codes: > - installed ILM, * - selected ILM, p - stale ILM, ! - using backup
K - CLI ILM, T - MPLS-TP, s - Stitched ILM
S - SNMP, L - LDP, R - RSVP, C - CRLDP
B - BGP , K - CLI , V - LDP_VC, I - IGP_SHORTCUT
O - OSPF/OSPF6 SR, i - ISIS SR, k - SR CLI
P - SR Policy, U - unknown
LDP ilm-ecmp - disabled
Code FEC/VRF/L2CKT ILM-ID In-Label Out-Label In-Intf Out-Intf/VRF Nexthop pri LSP-Type
i> 2.2.2.2/32 8 16400 16400 N/A vlan1.20 20.1.1.2 Yes LSP_DEFAULT
i> 2.2.2.2/32 14 16400 16400 N/A po1.10 10.1.1.3 No LSP_DEFAULT
i> 26.26.26.26/32 4 16100 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
B evpn:500 3 17 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
B evpn:400 1 16 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
B evpn:500 2 640 Nolabel N/A N/A 127.0.0.1 Yes LSP_DEFAULT
i> 6.6.6.6/32 13 16006 16006 N/A vlan1.20 20.1.1.2 Yes LSP_DEFAULT
i> 6.6.6.6/32 16 16006 16006 N/A po1.10 10.1.1.3 No LSP_DEFAULT
i> 23.23.23.23/32 9 16300 16300 N/A po1.10 10.1.1.3 Yes LSP_DEFAULT
i> 23.23.23.23/32 17 16300 16300 N/A vlan1.20 20.1.1.2 No LSP_DEFAULT
i> 3.3.3.3/32 6 16200 16200 N/A po1.10 10.1.1.3 Yes LSP_DEFAULT
i> 3.3.3.3/32 15 16200 16200 N/A vlan1.20 20.1.1.2 No LSP_DEFAULT
i> 10.1.1.3/32 5 27520 3 N/A po1.10 10.1.1.3 Yes LSP_DEFAULT
i> 10.1.1.3/32 19 27520 16200 N/A vlan1.20 20.1.1.2 No LSP_DEFAULT
B> vrf100 10 25600 Nolabel N/A vrf100 N/A Yes LSP_DEFAULT
B> 6PE 11 25601 Nolabel N/A N/A N/A Yes LSP_DEFAULT
i> 20.1.1.2/32 7 27521 3 N/A vlan1.20 20.1.1.2 Yes LSP_DEFAULT
i> 20.1.1.2/32 18 27521 16400 N/A po1.10 10.1.1.3 No LSP_DEFAULT
V> l2ckt:200 12 26880 Nolabel po1.10 xe1.200 N/A Yes LSP_DEFAULT
PE1#
PE1#show mpls ftn-table
Primary FTN entry with FEC: 2.2.2.2/32, id: 2, row status: Active, Tunnel-Policy: N/A, State: Installed
Owner: ISIS-SR, distance: 115, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Cross connect ix: 5, in intf: - in label: 0 out-segment ix: 7
Owner: ISIS-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 7, owner: ISIS-SR, Stale: NO, out intf: vlan1.20, out label: 16400
Nexthop addr: 20.1.1.2 cross connect ix: 5, op code: Push
Non-primary FTN entry with FEC: 2.2.2.2/32, id: 8, row status: Active, Tunnel-Policy: N/A, State: Installed
Owner: ISIS-SR, distance: 115, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A, , Color: 0
Cross connect ix: 14, in intf: - in label: 0 out-segment ix: 21
Owner: ISIS-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 21, owner: ISIS-SR, Stale: NO, ISIS-SR out intf: po1.10, transport out intf: N/A, out label: 16400
Nexthop addr: 10.1.1.3 cross connect ix: 14, op code: Push and Lookup
bypass_ftn_ix 6
Primary FTN entry with FEC: 3.3.3.3/32, id: 1, row status: Active, Tunnel-Policy: N/A, State: Installed
Owner: ISIS-SR, distance: 115, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Cross connect ix: 3, in intf: - in label: 0 out-segment ix: 3
Owner: ISIS-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 3, owner: ISIS-SR, Stale: NO, out intf: po1.10, out label: 16200
Nexthop addr: 10.1.1.3 cross connect ix: 3, op code: Push
Non-primary FTN entry with FEC: 3.3.3.3/32, id: 9, row status: Active, Tunnel-Policy: N/A, State: Installed
Owner: ISIS-SR, distance: 115, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A, , Color: 0
Cross connect ix: 15, in intf: - in label: 0 out-segment ix: 23
Owner: ISIS-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 23, owner: ISIS-SR, Stale: NO, ISIS-SR out intf: vlan1.20, transport out intf: N/A, out label: 16200
Nexthop addr: 20.1.1.2 cross connect ix: 15, op code: Push and Lookup
bypass_ftn_ix 7
Primary FTN entry with FEC: 6.6.6.6/32, id: 5, row status: Active, Tunnel-Policy: N/A, State: Installed
Owner: ISIS-SR, distance: 115, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Cross connect ix: 13, in intf: - in label: 0 out-segment ix: 17
Owner: ISIS-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 17, owner: ISIS-SR, Stale: NO, out intf: vlan1.20, out label: 16006
Nexthop addr: 20.1.1.2 cross connect ix: 13, op code: Push
Non-primary FTN entry with FEC: 6.6.6.6/32, id: 10, row status: Active, Tunnel-Policy: N/A, State: Installed
Owner: ISIS-SR, distance: 115, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A, , Color: 0
Cross connect ix: 16, in intf: - in label: 0 out-segment ix: 25
Owner: ISIS-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 25, owner: ISIS-SR, Stale: NO, ISIS-SR out intf: po1.10, transport out intf: N/A, out label: 16006
Nexthop addr: 10.1.1.3 cross connect ix: 16, op code: Push and Lookup
bypass_ftn_ix 6
Primary FTN entry with FEC: 6.6.6.6/32, id: 7, row status: Active, Tunnel-Policy: N/A, State: Installed
Owner: ISIS-SR, distance: 115, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 2202, Protected LSP id: 0, QoS Resource id: 0, Description: N/A, , Color: 0
Cross connect ix: 13, in intf: - in label: 0 out-segment ix: 17
Owner: ISIS-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 17, owner: ISIS-SR, Stale: NO, out intf: vlan1.20, out label: 16006
Nexthop addr: 20.1.1.2 cross connect ix: 13, op code: Push
Primary FTN entry with FEC: 23.23.23.23/32, id: 3, row status: Active, Tunnel-Policy: N/A, State: Installed
Owner: ISIS-SR, distance: 115, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Cross connect ix: 6, in intf: - in label: 0 out-segment ix: 9
Owner: ISIS-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 9, owner: ISIS-SR, Stale: NO, out intf: po1.10, out label: 16300
Nexthop addr: 10.1.1.3 cross connect ix: 6, op code: Push
Non-primary FTN entry with FEC: 23.23.23.23/32, id: 11, row status: Active, Tunnel-Policy: N/A, State: Installed
Owner: ISIS-SR, distance: 115, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 0, Protected LSP id: 0, QoS Resource id: 0, Description: N/A, , Color: 0
Cross connect ix: 17, in intf: - in label: 0 out-segment ix: 27
Owner: ISIS-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 27, owner: ISIS-SR, Stale: NO, ISIS-SR out intf: vlan1.20, transport out intf: N/A, out label: 16300
Nexthop addr: 20.1.1.2 cross connect ix: 17, op code: Push and Lookup
bypass_ftn_ix 7
Primary FTN entry with FEC: 23.23.23.23/32, id: 6, row status: Active, Tunnel-Policy: N/A, State: Installed
Owner: ISIS-SR, distance: 115, Action-type: Redirect to Tunnel, Exp-bits: 0x0, Incoming DSCP: none
Tunnel id: 2201, Protected LSP id: 0, QoS Resource id: 0, Description: N/A, , Color: 0
Cross connect ix: 6, in intf: - in label: 0 out-segment ix: 9
Owner: ISIS-SR, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 9, owner: ISIS-SR, Stale: NO, out intf: po1.10, out label: 16300
Nexthop addr: 10.1.1.3 cross connect ix: 6, op code: Push
Primary FTN entry with FEC: 2001::/64, id: 4, row status: Active, Tunnel-Policy: N/A, State: Installed
Owner: BGP, distance: 0, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none
VRF id 0, BGP peer 1717:1717:: BGP prefix 2001::
Transport Tunnel id: 0, Protected LSP id: 0, Description: N/A, , Color: 0
Cross connect ix: 11, in intf: - in label: 0 out-segment ix: 15
Owner: BGP, Persistent: No, Admin Status: Up, Oper Status: Up
Out-segment with ix: 15, owner: BGP, Stale: NO, BGP out intf: po1.10, transport out intf: po1.10, out label: 25601
Nexthop addr: 23.23.23.23 cross connect ix: 11, op code: Push and Lookup
PE1#
Validation 5
Verify microloop avoidance setting.
PE1#sh isis microloop-avoidance
Tag 1: VRF : default
Level-1 status:
FSM State: OFIB_STABLE
Level-2 status:
FSM State: OFIB_STABLE
PE1#
PE1#sh isis microloop-avoidance detail
Tag 1: VRF : default
Level-1 status:
FSM State: OFIB_HOLDING_DOWN
Event type: Neighbor Down
Near end: 0000.0000.0026.00 Far end:0000.0000.0003.00
Hold-down timer running: Yes Time Remaning: 00:00:02.811
Delay timer running: No
Level-2 status:
FSM State: OFIB_HOLDING_DOWN
Event type: Neighbor Down
Near end: 0000.0000.0026.00 Far end:0000.0000.0003.00
Hold-down timer running: Yes Time Remaning: 00:00:02.811
Delay timer running: No
oFIB Route Table:
Destination Metric Next-Hop Interface Tag
PE1#
PE1#sh isis microloop-avoidance detail
Tag 1: VRF : default
Level-1 status:
FSM State: OFIB_ONGOING
Event type: Neighbor Down
Near end: 0000.0000.0026.00 Far end:0000.0000.0003.00
Hold-down timer running: No
Delay timer running: Yes Time Remaning: 00:00:00.000
Level-2 status:
FSM State: OFIB_STABLE
oFIB Route Table:
Destination Metric Next-Hop Interface Tag
L1 22.1.1.0/24 40 20.1.1.2 vlan1.20 0
Src: 0000.0000.0023
L1 23.23.23.23/32 30 20.1.1.2 vlan1.20 0
Src: 0000.0000.0023
L1 82.1.1.0/24 30 20.1.1.2 vlan1.20 0
Src: 0000.0000.0006
PE1#
PE1#sh isis microloop-avoidance detail
Tag 1: VRF : default
Level-1 status:
FSM State: OFIB_STABLE
Level-2 status:
FSM State: OFIB_STABLE
PE1#