Operations, Administration and Maintenance (OAM) over SRv6
This chapter contains configurations of OAM with SRv6.
IPv6 OAM operations can be performed for any SRv6 SID whose behavior allows Upper-Layer header processing for an applicable OAM payload (e.g., ICMPv6, UDP).
Ping
Ping to an SRv6 SID is used to verify that the SID is reachable and is locally programmed at the target node.
Traceroute
Traceroute to a SRV6 SID is used for hop-by-hop fault localization as well as path tracing to a SID.
IPv6 OAM operations can be performed with the target SID in the IPv6 destination address without an SRH or with an SRH where the target SID is the last segment. In general, OAM operations to a target SID may not exercise all of its processing depending on its behavior definition.
This document only illustrates ICMPv6-based ping and UDP-based traceroute to an SRv6 SID.
For example, ping to an End.X SID only validates the SID is locally programmed at the target node and does not validate switching to the correct outgoing interface.
Topology
OAM over SRv6 Topology
Configuration
PE1
PE1#configure terminal | Enter configure mode. |
PE2(config)#bfd interval 3 minrx 3 multiplier 3 | Configure bfd interval 3 min 3 multiplier 3 |
PE1(config)#bfd multihop-peer cafe:1:2::11 interval 250 minrx 250 multiplier 250 | Configure bfd multihop peer interval 250 min 250 multiplier 250 |
PE1(config)#commit | Commit the candidate configuration to the running configuration |
PE1(config)#tunnel-policy policy0 | Configure tunnel policy |
PE1(config-tnl-policy)# color 1 | Configure color code |
PE1(config-tnl-policy)# tunnel-type srv6 | Configure tunnel type as srv6 |
PE1(config-tnl-policy)#exit | Exit from tunnel policy |
PE1(config)#ip vrf vrf103 | Configure ip vrf vrf name |
PE1(config-vrf)# tunnel-select-policy policy0 | tunnel-policy to be mapped |
PE1(config-vrf)# rd 10:103 | Configure route distinguisher value |
PE1(config-vrf)# route-target both 10:103 | Configure route-target import and export |
PE1(config-vrf)#exit | Exit from vrf mode |
PE1(config)#segment-routing | Enable Segment Routing |
PE1(config-sr)#srv6 | Segment-Routing over IPv6 Data-Plane |
PE1(config-srv6)#locators | Configure SRv6 locators |
PE1(config-srv6-loc)#locator SR7029 | Configure SRv6 locator name |
PE1(config-srv6-loc-conf)#prefix cafe:1:2:a11::/64 | Configure prefix for locator |
PE1(config-srv6-loc-conf)#exit-locator | Exit from locator |
PE1(config-srv6-loc)#exit-locators | Exit from locators |
PE1(config-srv6)# exit-srv6 | Exit from srv6 mode |
PE1(config-sr)#traffic-engineering | Configure Segment Routing traffic engineering |
PE1(config-sr-te)#segment-list PE1-PE2 | Segment List configuration |
PE1(config-sr-sl)#index 1 segment-type-2 cafe:1:2:a22:2001:: | Specify the entry index Segment-descriptor type: SRv6 Prefix |
PE1(config-sr-sl)#exit-sr-sl | Exit from segment list |
PE1(config-sr-te)#policy P1 | Configure policy policy name |
PE1(config-sr-pol)#color 1 end-point cafe:1:2::22 | SR Policy color value policy end point ipv6 address |
PE1(config-sr-pol)#candidate-path 1 | Configfure policy candidate path value |
PE1(config-sr-pol-cp)#explicit segment-list PE1-PE2 | Configure explicit candidate path segment list with name of the SID list |
PE1(config-sr-pol-cp)#exit-pol-cp | Exit from policy |
PE1(config-sr-te)#exit-te | Exit from traffic engineer |
PE1(config-sr)#exit | Exit from segment routing |
PE1(config)#commit | Commit the candidate configuration to the running configuration |
PE1(config)#interface lo | Enter the interface mode |
PE1(config-if)#ip address 29.29.29.29/32 secondary | Assign the ipv4 address |
PE1(config-if)#ipv6 address cafe:1:2::11/128 | Assign the ipv6 address |
PE1(config-if)# ipv6 router ospf area 0.0.0.0 tag 100 instance-id 0 | Configure ospf area as 0 tag is 100 and instance id as 0 |
PE1(config-if)#exit | Exit from interface mode |
PE1(config)#commit | Commit the candidate configuration to the running configuration |
PE1(config)#interface ce1.4001 | Enter the sub-interface mode |
PE1(config-if)# encapsulation dot1q 4001 | Enable encapsulate dot1q vlan id |
PE1(config-if)# ip vrf forwarding vrf103 | Enable vrf forwarding vrf name |
PE1(config-if)# ip address 103.21.1.1/24 | Assign the ip address |
PE1(config-if)#exit | Exit from interface mode |
PE1(config)#commit | Commit the candidate configuration to the running configuration |
PE1(config)#interface ce15 | Enter the interface mode |
PE1(config-if)# load-interval 30 | Enable load interval |
PE1(config-if)# ipv6 address 1000::1/64 | Assign the ipv6 address |
PE1(config-if)# mtu 9216 | Set the mtu size |
PE1(config-if)# ipv6 nd suppress-ra | Enable ipv6 supress ra |
PE1(config-if)# ipv6 ospf network point-to-point instance-id 0 | Configure ip ospf network as point to point |
PE1(config-if)# ipv6 router ospf area 0.0.0.0 tag 100 instance-id 0 | Configure ospf area as 0 tag 100 and instance id as 0 |
PE1(config-if)#exit | Exit from interface mode |
PE1(config)#commit | Commit the candidate configuration to the running configuration |
PE1(config)#router ipv6 ospf 100 | Configure ospf instance |
PE1(config-router)# router-id 29.29.29.29 | Configure ospf router id |
PE1(config-router)# bfd all-interfaces | Enable bfd all interfaces |
PE1(config-router)# segment-routing srv6 | Enable segment routing srv6 |
PE1(config-router-srv6)# srv6-locator SR7029 | Configure srv6 locator name |
PE1(config-router-srv6)# exit-srv6 | Exit from srv6 |
PE1(config-router)#exit | Exit from router ospf mode |
PE1(config)#commit | Commit the candidate configuration to the running configuration |
PE1(config)#router bgp 65010 | Configure bgp instance |
PE1(config-router)# bgp router-id 29.29.29.29 | Configure bgp router id |
PE1(config-router)# neighbor cafe:1:2::22 remote-as 65010 | Configure neighbor remote as 65010 |
PE1(config-router)# neighbor cafe:1:2::22 update-source lo | Configure neighbor update loopback |
PE1(config-router)# address-family vpnv4 unicast | Configure address family vpnv4 uncast |
PE1(config-router-af)# segment-routing srv6 | Enable segment routing srv6 |
PE1(config-router-vpnv4-srv6)# srv6-locator SR7029 | Enable srv6 locator name |
PE1(config-router-vpnv4-srv6)# exit-srv6 | Exit from srv6 |
PE1(config-router-af)# neighbor cafe:1:2::22 activate | Activate the ipv6 neighbor |
PE1(config-router-af)# neighbor cafe:1:2::22 capability extended-nexthop-encode | Configure neighbor ipv6 address capability extended nexthop encode |
PE1(config-router-af)# exit-address-family | Exit from address family |
PE1(config-router)# address-family ipv4 vrf vrf103 | Enter address family ipv4 vrf vrf name |
PE1(config-router-af)# redistribute connected | Configure redistribute connected |
PE1(config-router-af)# segment-routing srv6 | Configure segment routing srv6 |
PE1(config-router-vrfv4-srv6)# sid-alloc per-vrf | Configure sid per vrf |
PE1(config-router-vrfv4-srv6)# exit-srv6 | Exit from srv6 |
PE1(config-router-af)# exit-address-family | Exit from address family |
PE1(config-router)#exit | Exit from bgp instance |
PE1(config)#commit | Commit the candidate configuration to the running configuration |
P
P#configure terminal | Enter configure mode. |
P(config)#bfd interval 3 minrx 3 multiplier 3 | Configure bfd interval 3 min 3 multiplier 3 |
P(config)#bfd multihop-peer cafe:1:2::33 interval 250 minrx 250 multiplier 250 | Configure bfd multihop peer interval 250 min 250 multiplier 250 |
P(config)#commit | Commit the candidate configuration to the running configuration |
P(config)#segment-routing | Enable Segment Routing |
P(config-sr)#srv6 | Segment-Routing over IPv6 Data-Plane |
P(config-srv6)#locators | Configure SRv6 locators |
P(config-srv6-loc)#locator SR7030 | Configure SRv6 locator name |
P(config-srv6-loc-conf)#prefix cafe:1:2:33::/64 | Configure prefix for locator |
P(config-srv6-loc-conf)#exit-locator | Exit from locator |
P(config-srv6-loc)#exit-locators | Exit from locators |
P(config-srv6)#exit-srv6 | Exit from srv6 mode |
P(config-sr)#exit | Exit from segment routing mode |
P(config)#commit | Commit the candidate configuration to the running configuration |
P(config)#interface lo | Enter the interface mode |
P(config-if)#ip address 30.30.30.30/32 secondary | Assign the ipv4 address |
P(config-if)#ipv6 address cafe:1:2::33/128 | Assign the ipv6 address |
P(config-if)# ipv6 router ospf area 0.0.0.0 tag 100 instance-id 0 | Configure ospf area as 0 tag is 100 and instance id as 0 |
P(config-if)#exit | Exit from interface mode |
P(config)#commit | Commit the candidate configuration to the running configuration |
P(config)#interface ce4 | Enter the interface mode |
P(config-if)# load-interval 30 | Enable load interval |
P(config-if)# ipv6 address 2000::2/64 | Assign the ipv6 address |
P(config-if)# mtu 9216 | Set the mtu size |
P(config-if)# ipv6 nd suppress-ra | Enable ipv6 supress ra |
P(config-if)# ipv6 ospf network point-to-point instance-id 0 | Configure ip ospf network as point to point |
P(config-if)# ipv6 router ospf area 0.0.0.0 tag 100 instance-id 0 | Configure ospf area as 0 tag 100 and instance id as 0 |
P(config-if)#exit | Exit from interface mode |
P(config)#commit | Commit the candidate configuration to the running configuration |
P(config)#interface ce5 | Enter the interface mode |
P(config-if)# load-interval 30 | Enable load interval |
P(config-if)# ipv6 address 1000::2/64 | Assign the ipv6 address |
P(config-if)# mtu 9216 | Set the mtu size |
P(config-if)# ipv6 nd suppress-ra | Enable ipv6 supress ra |
P(config-if)# ipv6 ospf network point-to-point instance-id 0 | Configure ip ospf network as point to point |
P(config-if)# ipv6 router ospf area 0.0.0.0 tag 100 instance-id 0 | Configure ospf area as 0 tag 100 and instance id as 0 |
P(config-if)#exit | Exit from interface mode |
P(config)#commit | Commit the candidate configuration to the running configuration |
P(config)#router ipv6 ospf 100 | Configure ospf instance |
P(config-router)# router-id 30.30.30.30 | Configure ospf router id |
P(config-router)# bfd all-interfaces | Enable bfd all interfaces |
P(config-router)# segment-routing srv6 | Enable segment routing srv6 |
P(config-router-srv6)# srv6-locator SR7030 | Configure srv6 locator name |
P(config-router-srv6)# exit-srv6 | Exit from srv6 |
PE2
PE2#configure terminal | Enter configure mode. |
PE2(config)#tunnel-policy policy0 | Configure tunnel policy |
PE2(config-tnl-policy)# color 1 | Configure color code |
PE2(config-tnl-policy)# tunnel-type srv6 | Configure tunnel type as srv6 |
PE2(config-tnl-policy)#exit | Exit from tunnel policy |
PE2(config)#ip vrf vrf103 | Configure ip vrf vrf name |
PE2(config-vrf)# tunnel-select-policy policy0 | tunnel-policy to be mapped |
PE2(config-vrf)# rd 10:103 | Configure route distinguisher value |
PE2(config-vrf)# route-target both 10:103 | Configure route-target import and export |
PE2(config-vrf)#exit | Exit from vrf mode |
PE2(config)#commit | Commit the candidate configuration to the running configuration |
PE2(config)#bfd interval 3 minrx 3 multiplier 3 | Configure bfd interval 3 min 3 multiplier 3 |
PE2(config)#bfd multihop-peer cafe:1:2::11 interval 250 minrx 250 multiplier 250 | Configure bfd multihop peer interval 250 min 250 multiplier 250 |
PE2(config)#commit | Commit the candidate configuration to the running configuration |
PE2(config)#segment-routing | Enable Segment Routing |
PE2(config-sr)#srv6 | Segment-Routing over IPv6 Data-Plane |
PE2(config-srv6)#locators | Configure SRv6 locators |
PE2(config-srv6-loc)#locator SR7028 | Configure SRv6 locator name |
PE2(config-srv6-loc-conf)#prefix cafe:1:2:a22::/64 | Configure prefix for locator |
PE2(config-srv6-loc-conf)#exit-locator | Exit from locator |
PE2(config-srv6-loc)#exit-locators | Exit from locators |
PE2(config-srv6)#exit-srv6 | Exit from srv6 mode |
PE2(config-sr)#traffic-engineering | Configure Segment Routing traffic engineering |
PE2(config-sr-te)#segment-list PE1-PE2 | Segment List configuration |
PE2(config-sr-sl)#index 1 segment-type-2 cafe:1:2:a11:2001:: | Specify the entry index Segment-descriptor type SRv6 Prefix |
PE2(config-sr-sl)#exit-sr-sl | Exit from segment list |
PE2(config-sr-te)# policy P1 | Configure policy policy name |
PE2(config-sr-pol)#color 1 end-point cafe:1:2::11 | SR Policy color value policy end point ipv6 address |
PE2(config-sr-pol)#candidate-path 1 | Configure policy candidate path value |
PE2(config-sr-pol-cp)#explicit segment-list PE1-PE2 | Configure explicit candidate path segment list with name of the SID list |
PE2(config-sr-pol-cp)#exit-pol-cp | Exit from candidate path |
PE2(config-sr-pol)#exit-sr-pol | Exit from policy |
PE2(config-sr-te)#exit-te | Exit from traffic engineer |
PE2(config-sr)#exit | Exit from segment routing |
PE2(config)#commit | Commit the candidate configuration to the running configuration |
PE2(config)#interface lo | Enter the interface mode |
PE2(config-if)#ip address 28.28.28.28/32 secondary | Assign the ipv4 address |
PE2(config-if)#ipv6 address cafe:1:2::22/128 | Assign the ipv6 address |
PE2(config-if)#ipv6 router ospf area 0.0.0.0 tag 100 instance-id 0 | Configure ospf area as 0 tag is 100 and instance id as 0 |
PE2(config-if)#exit | Exit from interface mode |
PE2(config)#commit | Commit the candidate configuration to the running configuration |
PE2(config)#interface ce4 | Enter the interface mode |
PE2(config-if)# load-interval 30 | Enable load interval |
PE2(config-if)# ipv6 address 2000::1/64 | Assign the ipv6 address |
PE2(config-if)# mtu 9216 | Set the mtu size |
PE2(config-if)# ipv6 nd suppress-ra | Enable ipv6 supress ra |
PE2(config-if)# ipv6 ospf network point-to-point instance-id 0 | Configure ip ospf network as point to point |
PE2(config-if)# ipv6 router ospf area 0.0.0.0 tag 100 instance-id 0 | Configure ospf area as 0 tag 100 and instance id as 0 |
PE2(config-if)#exit | Exit from interface mode |
PE2(config)#commit | Commit the candidate configuration to the running configuration |
PE2(config)#interface ce14.4001 | Enter the subinterface mode |
PE2(config-if)# encapsulation dot1q 4001 | Enable the encapsulate dot 1q vlan id |
PE2(config-if)# ip vrf forwarding vrf103 | Enable vrf forwarding vrf name |
PE2(config-if)# ip address 103.22.1.1/24 | Assign the ip address |
PE2(config-if)#exit | Exit from interface mode |
PE2(config)#commit | Commit the candidate configuration to the running configuration |
PE2(config)#router ipv6 ospf 100 | Configure ospf instance |
PE2(config-router)# router-id 28.28.28.28 | Configure ospf router id |
PE2(config-router)# bfd all-interfaces | Enable bfd all interfaces |
PE2(config-router)# segment-routing srv6 | Enable segment routing srv6 |
PE2(config-router-srv6)# srv6-locator SR7028 | Configure srv6 locator name |
PE2(config-router-srv6)# exit-srv6 | Exit from srv6 |
PE2(config-router)#exit | Exit from router ospf mode |
PE2(config)#commit | Commit the candidate configuration to the running configuration |
PE2(config)#router bgp 65010 | Configure bgp instance |
PE2(config-router)# bgp router-id 28.28.28.28 | Configure bgp router id |
PE2(config-router)# neighbor cafe:1:2::11 remote-as 65010 | Configure neighbor remote as 65010 |
PE2(config-router)# neighbor cafe:1:2::11 update-source lo | Configure neighbor update loopback |
PE2(config-router)# address-family vpnv4 unicast | Configure address family vpnv4 uncast |
PE2(config-router-af)# segment-routing srv6 | Enable segment routing srv6 |
PE2(config-router-vpnv4-srv6)# srv6-locator SR7028 | Enable srv6 locator name |
PE2(config-router-vpnv4-srv6)# exit-srv6 | Exit from srv6 |
PE2(config-router-af)# neighbor cafe:1:2::11 activate | Activate the ipv6 neighbor |
PE2(config-router-af)# neighbor cafe:1:2::11 capability extended-nexthop-encode | Configure neighbor ipv6 address capability extended nexthop encode |
PE2(config-router-af)# exit-address-family | Exit from address family |
PE2(config-router)# address-family ipv4 vrf vrf103 | Enter address family ipv4 vrf vrf name |
PE2(config-router-af)# redistribute connected | Configure redistribute connected |
PE2(config-router-af)# segment-routing srv6 | Configure segment routing srv6 |
PE2(config-router-vrfv4-srv6)# sid-alloc per-vrf | Configure sid per vrf |
PE2(config-router-vrfv4-srv6)# exit-srv6 | Exit from srv6 |
PE2(config-router-af)# exit-address-family | Exit from address family |
PE2(config-router)#exit | Exit from bgp instance |
PE2(config)#commit | Commit the candidate configuration to the running configuration |
PE2(config)#end | End from config mode |
Validation
PE1#show ipv6 ospf neighbor
Total number of full neighbors: 1
OSPFv3 Process (100)
Neighbor ID Pri State Dead Time Interface Instance ID
30.30.30.30 1 Full/ - 00:00:30 ce15 0
PE1#
PE1#sh ipv6 ospf database locator
OSPFv3 Router with ID (29.29.29.29) (Process 100)
Locator-LSA (Area 0.0.0.0)
LS age: 712
LS Type: Locator LSA
Link State ID: 0.0.39.163
Advertising Router: 28.28.28.28
LS Seq Number: 0x80000001
Checksum: 0xA9F0
Length: 120
Locator-TLV (Length:96):
Route type:0 Algorithm:0
Flags:0 Metric:0
Prefix: cafe:1:2:a22::/64
SRv6 END Sub TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a22:2001::
End-point behaviour: End with PSP (2)
SRv6 END Sub TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a22:1001::
End-point behaviour: End with USP (3)
SRv6 END Sub TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a22:801::
End-point behaviour: End with USD (28)
LS age: 748
LS Type: Locator LSA
Link State ID: 0.0.39.77
Advertising Router: 29.29.29.29
LS Seq Number: 0x80000001
Checksum: 0x73BD
Length: 120
Locator-TLV (Length:96):
Route type:0 Algorithm:0
Flags:0 Metric:0
Prefix: cafe:1:2:a11::/64
SRv6 END Sub TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a11:2001::
End-point behaviour: End with PSP (2)
SRv6 END Sub TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a11:1001::
End-point behaviour: End with USP (3)
SRv6 END Sub TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:a11:801::
End-point behaviour: End with USD (28)
LS age: 344
LS Type: Locator LSA
Link State ID: 0.0.39.163
Advertising Router: 30.30.30.30
LS Seq Number: 0x80000007
Checksum: 0xE788
Length: 120
Locator-TLV (Length:96):
Route type:0 Algorithm:0
Flags:0 Metric:0
Prefix: cafe:1:2:33::/64
SRv6 END Sub TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:33:2001::
End-point behaviour: End with PSP (2)
SRv6 END Sub TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:33:1001::
End-point behaviour: End with USP (3)
SRv6 END Sub TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:33:801::
End-point behaviour: End with USD (28)
LS age: 344
LS Type: Locator LSA
Link State ID: 0.0.39.167
Advertising Router: 30.30.30.30
LS Seq Number: 0x80000007
Checksum: 0xBFAC
Length: 120
Locator-TLV (Length:96):
Route type:0 Algorithm:0
Flags:0 Metric:0
Prefix: cafe:1:2:33::/64
SRv6 END Sub TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:33:2001::
End-point behaviour: End with PSP (2)
SRv6 END Sub TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:33:1001::
End-point behaviour: End with USP (3)
SRv6 END Sub TLV (Length:20):
Flags:0 Reserved:0
END SID: cafe:1:2:33:801::
End-point behaviour: End with USD (28)
PE1#sh ipv6 ospf database router
OSPFv3 Router with ID (29.29.29.29) (Process 100)
Router-LSA (Area 0.0.0.0)
LS age: 1476
LS Type: Router-LSA
Link State ID: 0.0.0.0
Advertising Router: 28.28.28.28
LS Seq Number: 0x80000006
Checksum: 0x80FA
Length: 40
Flags: 0x00 (-|-|-|-|-)
Options: 0x000133 (AF|*|*|DC|R|-|-|E|V6)
Link connected to: another Router (point-to-point)
Metric: 1
Interface ID: 10147
Neighbor Interface ID: 10147
Neighbor Router ID: 30.30.30.30
LS age: 345
LS Type: Router-LSA
Link State ID: 0.0.0.0
Advertising Router: 29.29.29.29
LS Seq Number: 0x80000007
Checksum: 0xEFD8
Length: 40
Flags: 0x00 (-|-|-|-|-)
Options: 0x000133 (AF|*|*|DC|R|-|-|E|V6)
Link connected to: another Router (point-to-point)
Metric: 1
Interface ID: 10061
Neighbor Interface ID: 10151
Neighbor Router ID: 30.30.30.30
LS age: 351
LS Type: Router-LSA
Link State ID: 0.0.0.0
Advertising Router: 30.30.30.30
LS Seq Number: 0x8000000A
Checksum: 0xE8C4
Length: 56
Flags: 0x00 (-|-|-|-|-)
Options: 0x000133 (AF|*|*|DC|R|-|-|E|V6)
Link connected to: another Router (point-to-point)
Metric: 1
Interface ID: 10147
Neighbor Interface ID: 10147
Neighbor Router ID: 28.28.28.28
Link connected to: another Router (point-to-point)
Metric: 1
Interface ID: 10151
Neighbor Interface ID: 10061
Neighbor Router ID: 29.29.29.29
PE1#
PE1#sh ip bgp neighbors
BGP neighbor is cafe:1:2::22, remote AS 65010, local AS 65010, internal link
BGP version 4, local router ID 29.29.29.29, remote router ID 28.28.28.28
BGP state = Established, up for 01:13:26
Last read 00:00:17, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family VPNv4 Unicast: advertised and received
Received 177 messages, 0 notifications, 0 in queue
Sent 177 messages, 0 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
Update source is lo
For address family: VPNv4 Unicast BGP table version 3, neighbor version 3
Index 1, Offset 0, Mask 0x2
AIGP is enabled
Extended Nexthop Encoding: advertised and received
Community attribute sent to this neighbor (both)
Large Community attribute sent to this neighbor
1 accepted prefixes
1 announced prefixes
Connections established 1; dropped 0
Local host: cafe:1:2::11, Local port: 46015
Foreign host: cafe:1:2::22, Foreign port: 179
Nexthop: 29.29.29.29
Nexthop global: cafe:1:2::11
Nexthop local: ::
BGP connection: non shared network
PE1#
PE1#sh segment-routing srv6 transports
Codes: > - installed P6, * - selected P6, p - stale P6,
U - unknown P6
Code FEC SRv6-Policy-Name color Pri Out-SID Out-Intf Nexthop
> cafe:1:2::22 P1 1 Y cafe:1:2:a22:2001:: ce15 fe80::5e07:58ff:fe71:205d
PE1#sh segment-routing srv6 services
Status codes: > - installed, * - selected, T - Uses service-mapped tunnel
L3VPN:
Service Flags vrf FEC SID Nexthop SRv6-Policy-Name
vpnv4 >T vrf103 103.22.1.0/24 cafe:1:2:a22:8001:: cafe:1:2::22 P1
EVPN:
PE1#
PE1#sh segment-routing srv6 sid
SRv6 Segment ID table:
SID Operation Nexthop Originator
+----------------------+------------+------------------------+----------
cafe:1:2:a11:801:: END[usd] :: nsm
cafe:1:2:a11:1001:: END[usp] :: nsm
cafe:1:2:a11:2001:: END[psp] :: nsm
cafe:1:2:a11:2002:: END.X[psp] fe80::5e07:58ff:fe71:205dospf
cafe:1:2:a11:8001:: END.DT4 vrf vrf103 bgp:65010
PE1#
PE1#
PE1#sh segment-routing srv6 sid id cafe:1:2:a11:2002::
SID Operation Nexthop Originator
+----------------------+------------+------------------------+----------
cafe:1:2:a11:2002:: END.X fe80::5e07:58ff:fe71:205dconnected
Last update 00:19:54 ago
PE1#
PE1#sh segment-routing policy
Policy-Name Color End-point State Forwarding-Info
P1 1 cafe:1:2::22 UP cafe:1:2:a22:2001::/ce15
PE1#
PE1#sh segment-routing policy detail
Policy-Name: P1 Color 1 End-point cafe:1:2::22 Tunnel-ID: 1
Admin-Status: UP Oper-Status: UP for 00:38:54
State Transition Count: 3
CP ID: 1, Active
Preference: 100 Path Type: Explicit CP Origin: Local
CP state: Valid
Segment List:
Total no. of segments: 1
Segment0[SRv6]: SID :cafe:1:2:a22:2001::
Out-if: ce15 Out-label-stack: cafe:1:2:a22:2001::
Attributes:
Configured:
Explicit segment-list Name: PE1-PE2
PE1#
Ping srv6 ipv6 with option
PE1#ping srv6 ipv6 cafe:1:2::22
Sending 5 SRV6 Echos to cafe:1:2::22, timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '*' - timeout,
'x' - Retcode 0, 'M' - Malformed Request
Type 'Ctrl+C' to abort
! seq_num = 1 :: 1.44 ms
! seq_num = 2 :: 0.68 ms
! seq_num = 3 :: 0.34 ms
! seq_num = 4 :: 0.51 ms
! seq_num = 5 :: 0.36 ms
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.34/0.89/1.44
PE1#
PE1#ping srv6 ipv6 cafe:1:2::22 interval 10
Sending 5 SRV6 Echos to cafe:1:2::22, timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '*' - timeout,
'x' - Retcode 0, 'M' - Malformed Request
Type 'Ctrl+C' to abort
! seq_num = 1 :: 0.56 ms
! seq_num = 2 :: 0.67 ms
! seq_num = 3 :: 0.54 ms
! seq_num = 4 :: 0.54 ms
! seq_num = 5 :: 0.50 ms
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.50/0.59/0.67
PE1#
PE1#ping srv6 ipv6 cafe:1:2::22 repeat 10
Sending 10 SRV6 Echos to cafe:1:2::22, timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '*' - timeout,
'x' - Retcode 0, 'M' - Malformed Request
Type 'Ctrl+C' to abort
! seq_num = 1 :: 0.49 ms
! seq_num = 2 :: 0.46 ms
! seq_num = 3 :: 0.48 ms
! seq_num = 4 :: 0.52 ms
! seq_num = 5 :: 0.50 ms
! seq_num = 6 :: 0.56 ms
! seq_num = 7 :: 0.30 ms
! seq_num = 8 :: 0.49 ms
! seq_num = 9 :: 0.45 ms
! seq_num = 10 :: 0.53 ms
Success Rate is 100.00 percent (10/10)
round-trip min/avg/max = 0.30/0.43/0.56
PE1#
PE1#ping srv6 ipv6 cafe:1:2::22 source-ip cafe:1:2::11
Sending 5 SRV6 Echos to cafe:1:2::22, timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '*' - timeout,
'x' - Retcode 0, 'M' - Malformed Request
Type 'Ctrl+C' to abort
! seq_num = 1 :: 0.73 ms
! seq_num = 2 :: 0.32 ms
! seq_num = 3 :: 0.30 ms
! seq_num = 4 :: 0.42 ms
! seq_num = 5 :: 0.36 ms
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.30/0.51/0.73
PE1#
Ping srv6 with Policy
PE1#ping srv6 policy P1
Sending 5 SRV6 Echos to P1 , timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '*' - timeout,
'x' - Retcode 0, 'M' - Malformed Request
Type 'Ctrl+C' to abort
! seq_num = 1 :: 0.62 ms
! seq_num = 2 :: 0.29 ms
! seq_num = 3 :: 0.32 ms
! seq_num = 4 :: 0.67 ms
! seq_num = 5 :: 0.53 ms
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.29/0.48/0.67
PE1#
PE1#ping srv6 policy P1 candidate-path 1
Sending 5 SRV6 Echos to P1 , timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '*' - timeout,
'x' - Retcode 0, 'M' - Malformed Request
Type 'Ctrl+C' to abort
! seq_num = 1 :: 0.62 ms
! seq_num = 2 :: 0.52 ms
! seq_num = 3 :: 0.38 ms
! seq_num = 4 :: 0.50 ms
! seq_num = 5 :: 0.44 ms
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.38/0.50/0.62
PE1#
PE1#ping srv6 policy P1 interval 15
Sending 5 SRV6 Echos to P1 , timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '*' - timeout,
'x' - Retcode 0, 'M' - Malformed Request
Type 'Ctrl+C' to abort
! seq_num = 1 :: 0.65 ms
! seq_num = 2 :: 0.60 ms
! seq_num = 3 :: 0.44 ms
! seq_num = 4 :: 0.58 ms
! seq_num = 5 :: 0.55 ms
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.44/0.55/0.65
PE1#
PE1#ping srv6 policy P1 repeat 15
Sending 15 SRV6 Echos to P1 , timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '*' - timeout,
'x' - Retcode 0, 'M' - Malformed Request
Type 'Ctrl+C' to abort
! seq_num = 1 :: 0.63 ms
! seq_num = 2 :: 0.40 ms
! seq_num = 3 :: 0.27 ms
! seq_num = 4 :: 0.38 ms
! seq_num = 5 :: 0.34 ms
! seq_num = 6 :: 0.36 ms
! seq_num = 7 :: 0.50 ms
! seq_num = 8 :: 0.63 ms
! seq_num = 9 :: 0.47 ms
! seq_num = 10 :: 0.53 ms
! seq_num = 11 :: 0.48 ms
! seq_num = 12 :: 0.71 ms
! seq_num = 13 :: 0.70 ms
! seq_num = 14 :: 0.54 ms
! seq_num = 15 :: 0.53 ms
Success Rate is 100.00 percent (15/15)
round-trip min/avg/max = 0.27/0.49/0.71
PE1#
PE1#ping srv6 policy P1 source-ip cafe:1:2::11
Sending 5 SRV6 Echos to P1 , timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '*' - timeout,
'x' - Retcode 0, 'M' - Malformed Request
Type 'Ctrl+C' to abort
! seq_num = 1 :: 0.51 ms
! seq_num = 2 :: 0.48 ms
! seq_num = 3 :: 0.50 ms
! seq_num = 4 :: 0.53 ms
! seq_num = 5 :: 0.35 ms
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.35/0.44/0.53
PE1#
Ping srv6 with SID
PE1#ping srv6 sid cafe:1:2:a22:2002::
Sending 5 SRV6 Echos to cafe:1:2:a22:2002::, timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '*' - timeout,
'x' - Retcode 0, 'M' - Malformed Request
Type 'Ctrl+C' to abort
! seq_num = 1 :: 0.42 ms
! seq_num = 2 :: 0.34 ms
! seq_num = 3 :: 0.40 ms
! seq_num = 4 :: 0.32 ms
! seq_num = 5 :: 0.37 ms
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.32/0.37/0.42
PE1#
PE1#ping srv6 sid cafe:1:2:a22:2002:: interval 20
Sending 5 SRV6 Echos to cafe:1:2:a22:2002::, timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '*' - timeout,
'x' - Retcode 0, 'M' - Malformed Request
Type 'Ctrl+C' to abort
! seq_num = 1 :: 0.67 ms
! seq_num = 2 :: 0.57 ms
! seq_num = 3 :: 0.49 ms
! seq_num = 4 :: 0.50 ms
! seq_num = 5 :: 0.74 ms
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.49/0.62/0.74
PE1#
PE1#ping srv6 sid cafe:1:2:a22:2002:: repeat 20
Sending 20 SRV6 Echos to cafe:1:2:a22:2002::, timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '*' - timeout,
'x' - Retcode 0, 'M' - Malformed Request
Type 'Ctrl+C' to abort
! seq_num = 1 :: 0.71 ms
! seq_num = 2 :: 0.40 ms
! seq_num = 3 :: 0.48 ms
! seq_num = 4 :: 0.52 ms
! seq_num = 5 :: 0.47 ms
! seq_num = 6 :: 0.45 ms
! seq_num = 7 :: 0.39 ms
! seq_num = 8 :: 0.57 ms
! seq_num = 9 :: 0.46 ms
! seq_num = 10 :: 0.56 ms
! seq_num = 11 :: 0.63 ms
! seq_num = 12 :: 0.63 ms
! seq_num = 13 :: 0.52 ms
! seq_num = 14 :: 0.54 ms
! seq_num = 15 :: 0.47 ms
! seq_num = 16 :: 0.53 ms
! seq_num = 17 :: 0.67 ms
! seq_num = 18 :: 0.63 ms
! seq_num = 19 :: 0.47 ms
! seq_num = 20 :: 0.50 ms
Success Rate is 100.00 percent (20/20)
round-trip min/avg/max = 0.39/0.55/0.71
PE1#
PE1#ping srv6 sid cafe:1:2:a22:2002:: source-ip cafe:1:2::11
Sending 5 SRV6 Echos to cafe:1:2:a22:2002::, timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '*' - timeout,
'x' - Retcode 0, 'M' - Malformed Request
Type 'Ctrl+C' to abort
! seq_num = 1 :: 0.56 ms
! seq_num = 2 :: 0.46 ms
! seq_num = 3 :: 0.32 ms
! seq_num = 4 :: 0.40 ms
! seq_num = 5 :: 0.51 ms
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.32/0.44/0.56
PE1#
Ping srv6 with Protocol Origin
PE1#ping srv6 protocol-origin local policy P1
Sending 5 SRV6 Echos to P1 , timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '*' - timeout,
'x' - Retcode 0, 'M' - Malformed Request
Type 'Ctrl+C' to abort
! seq_num = 1 :: 0.44 ms
! seq_num = 2 :: 0.28 ms
! seq_num = 3 :: 0.33 ms
! seq_num = 4 :: 0.35 ms
! seq_num = 5 :: 0.53 ms
Success Rate is 100.00 percent (5/5)
round-trip min/avg/max = 0.28/0.41/0.53
PE1#
PE1#ping srv6 protocol-origin local policy P1 repeat 10
Sending 10 SRV6 Echos to P1 , timeout is 5 seconds
Codes:
'!' - Success, 'Q' - request not sent, '*' - timeout,
'x' - Retcode 0, 'M' - Malformed Request
Type 'Ctrl+C' to abort
! seq_num = 1 :: 0.70 ms
! seq_num = 2 :: 0.24 ms
! seq_num = 3 :: 0.30 ms
! seq_num = 4 :: 0.44 ms
! seq_num = 5 :: 0.42 ms
! seq_num = 6 :: 0.35 ms
! seq_num = 7 :: 0.51 ms
! seq_num = 8 :: 0.62 ms
! seq_num = 9 :: 0.48 ms
! seq_num = 10 :: 0.52 ms
Success Rate is 100.00 percent (10/10)
round-trip min/avg/max = 0.24/0.47/0.70
PE1#
Traceroute
Traceroute srv6 with ipv6
PE1#traceroute srv6 ipv6 cafe:1:2::22
Traceroute to cafe:1:2::22 ( cafe:1:2::22), 30 hops max, 80 byte packets
Type 'Ctrl+C' to abort
1 1000::2 0.73 ms 0.49 ms 0.33 ms
DA: cafe:1:2::22
SRH:(cafe:1:2::22,SL = 0)
2 cafe:1:2::22 0.50 ms 0.51 ms 0.50 ms
DA: cafe:1:2::22
SRH:(cafe:1:2::22,SL = 0)
3 cafe:1:2::22 0.33 ms
PE1#
PE1#traceroute srv6 ipv6 cafe:1:2::22 source-ip cafe:1:2::11
Traceroute to cafe:1:2::22 ( cafe:1:2::22), 30 hops max, 80 byte packets
Type 'Ctrl+C' to abort
1 1000::2 0.80 ms 0.46 ms 0.46 ms
DA: cafe:1:2::22
SRH:(cafe:1:2::22,SL = 0)
2 cafe:1:2::22 0.51 ms 0.56 ms 0.36 ms
DA: cafe:1:2::22
SRH:(cafe:1:2::22,SL = 0)
3 cafe:1:2::22 0.51 ms
PE1#
Traceroute srv6 with Policy
PE1#traceroute srv6 policy P1
Traceroute to P1 ( P1 ), 30 hops max, 80 byte packets
Type 'Ctrl+C' to abort
1 1000::2 0.86 ms 0.50 ms 0.39 ms
DA: cafe:1:2:a22:2001::
SRH:(cafe:1:2:a22:2001::,SL = 0)
2 cafe:1:2:a22:2001:: 0.61 ms 0.41 ms 0.57 ms
3 cafe:1:2:a22:2001:: 0.61 ms
PE1#
PE1#traceroute srv6 policy P1 candidate-path 1
Traceroute to P1 ( P1 ), 30 hops max, 80 byte packets
Type 'Ctrl+C' to abort
1 1000::2 0.80 ms 0.49 ms 0.51 ms
DA: cafe:1:2:a22:2001::
SRH:(cafe:1:2:a22:2001::,SL = 0)
2 cafe:1:2:a22:2001:: 0.73 ms 0.57 ms 0.69 ms
3 cafe:1:2:a22:2001:: 0.49 ms
PE1#
PE1#traceroute srv6 policy P1 source-ip cafe:1:2::11
Traceroute to P1 ( P1 ), 30 hops max, 80 byte packets
Type 'Ctrl+C' to abort
1 1000::2 0.72 ms 0.61 ms 0.62 ms
DA: cafe:1:2:a22:2001::
SRH:(cafe:1:2:a22:2001::,SL = 0)
2 cafe:1:2:a22:2001:: 0.63 ms 0.52 ms 0.49 ms
3 cafe:1:2:a22:2001:: 0.35 ms
PE1#
Traceroute srv6 with Protocol Origin
PE1#traceroute srv6 protocol-origin local policy P1 candidate-path 1
Traceroute to P1 ( P1 ), 30 hops max, 80 byte packets
Type 'Ctrl+C' to abort
1 1000::2 0.73 ms 0.50 ms 0.46 ms
DA: cafe:1:2:a22:2001::
SRH:(cafe:1:2:a22:2001::,SL = 0)
2 cafe:1:2:a22:2001:: 0.50 ms 0.44 ms 0.50 ms
3 cafe:1:2:a22:2001:: 0.52 ms
PE1#
PE1#traceroute srv6 protocol-origin local policy P1 candidate-path 1 source-ip cafe:1:2::11
Traceroute to P1 ( P1 ), 30 hops max, 80 byte packets
Type 'Ctrl+C' to abort
1 1000::2 0.71 ms 0.47 ms 0.49 ms
DA: cafe:1:2:a22:2001::
SRH:(cafe:1:2:a22:2001::,SL = 0)
2 cafe:1:2:a22:2001:: 0.53 ms 0.29 ms 0.36 ms
3 cafe:1:2:a22:2001:: 0.52 ms
PE1#
Traceroute srv6 with SID
PE1#traceroute srv6 sid cafe:1:2:a22:2002::
Traceroute to cafe:1:2:a22:2002:: ( cafe:1:2:a22:2002::), 30 hops max, 80 byte packets
Type 'Ctrl+C' to abort
1 1000::2 0.76 ms 0.66 ms 0.45 ms
DA: cafe:1:2:a22:2002::
SRH:(cafe:1:2:a22:2002::,SL = 0)
2 cafe:1:2:a22:2002:: 0.49 ms 0.52 ms 0.60 ms
3 cafe:1:2:a22:2002:: 0.46 ms
PE1#
PE1#traceroute srv6 sid cafe:1:2:a22:2002:: source-ip cafe:1:2::11
Traceroute to cafe:1:2:a22:2002:: ( cafe:1:2:a22:2002::), 30 hops max, 80 byte packets
Type 'Ctrl+C' to abort
1 1000::2 0.67 ms 0.47 ms 0.36 ms
DA: cafe:1:2:a22:2002::
SRH:(cafe:1:2:a22:2002::,SL = 0)
2 cafe:1:2:a22:2002:: 0.38 ms 0.36 ms 0.66 ms
3 cafe:1:2:a22:2002:: 0.50 ms
PE1#