Object Tracking Using IP SLA
Overview
Object Tracking using IP SLA feature tracks the state of an object for reachability using IP SLA. A client process, such as Virtual Router Redundancy Protocol (VRRP) or RIB, registers itself to track objects and receives notifications when a state change occurs.
IP SLA (Service-Level Assurance Protocol) is a Performance Measurement protocol used to analyze IP service levels for IP applications and services. IP SLA employs active traffic-monitoring technology to monitor network traffic continuously.
IP SLA utilizes Internet Control Message Protocol (ICMP) pings to identify link failures and notify registered clients responsible for tracking.
The Object Tracking feature offers complete separation between tracked objects and the actions taken by clients when a tracked object's state changes. Multiple clients, such as VRRP or RIB, can register their interest in the tracking process, monitor the same object, and take different actions when the object changes state. The Tracking feature is present in OAMD (Object-Action Mapping Database).
Each tracked object is identified by a unique number specified in the tracking CLI. Client processes use this number to monitor a specific object.
The tracking process monitors events from the tracked objects, notes any changes in value, and communicates these changes to interested client processes immediately or after a specified delay. The object values are reported as either up or down.
To configure VRRP Object Tracking, the object is set to have a priority-delta value, which is passed to VRRP when a failure occurs. This decrement in the priority of the Virtual Router on the circuit triggers a transition from VR Master to VR Backup.
Topology
In this example, two routers, ROUTER-1 (R1) and ROUTER-2 (R2), are configured as Master and backup routers, each with different priorities. The priority-delta value is set to be greater than the difference between both priorities.
R1 is configured with a priority of 150, while R2 is assigned a priority of 100. Since R1 has the higher priority, it initially serves as the Virtual Router Master. The priority-delta value is set to 60, which is greater than the difference between their priorities (150 minus 100).
When the external interface xe41 on R1 fails, the Track state changes to DOWN, and R1's priority decreases to 90 (150 minus 60). However, as R2 still maintains a higher priority (100), it assumes the role of VR Master, ensuring uninterrupted packet routing.
Subsequently, when the track state returns to UP, the VR Backup (R1) regains its original priority of 150, reclaiming the position of VR Master. This transition allows for seamless failover and network continuity.
VRRP Object Tracking
R1
(config)#configure terminal | Enter configure mode. |
(config)#bridge 1 protocol rstp vlan-bridge | Create a RSTP VLAN aware bridge with bridge-id. |
(config)#vlan 1001-1002 bridge 1 | Create VLAN 1001,1002 and map it to bridge 1. |
(config)#interface xe29 | Enter interface mode. |
(config-if)#switchport | Configure switch port. |
(config-if)#bridge-group 1 spanning-tree disable | Configure bridge group to L2 interface with spanning-tree disabled. |
(config-if)#switchport mode trunk | Configure switchport mode as trunk. |
(config-if)#switchport trunk allowed vlan add 1001,1002 | Allow VLAN 1001, and 1002 on the interface. |
(config-if)#interface vlan1.1001 | Enter the VLAN interface. |
(config-if)#ip address 10.1.1.2/24 | Configure IPv4 address. |
(config-if)#ipv6 address 1000:1::2/32 | Configure IPv6 address. |
(config-if)#ipv6 router ospf area 0.0.0.0 | Tag OSPFv3 instance on the interface with area 0. |
(config-if)#exit | Exit interface mode. |
(config)#ip sla 1 | Configure IP SLA . |
(config-ip-sla)#icmp-echo ipv4 4.4.4.4 source-interface xe41 | Configure ICMP-echo with a destination IPv4/IPv6 address. |
(config-ip-sla-echo)#exit | Exit IP SLA echo mode. |
(config)#time-range tr1 | Configure a time-range. |
(config-tr)#start-time now | Configure a start-time. |
(config-tr)#commit | Commit the candidate configuration to the running configuration. |
(config-tr)#end-time after 200 | Configure end-time. |
(config-tr)#exit | Exit time-range mode. |
(config)#track 1 ip sla 1 reachability | Configure the track ID for IP SLA. |
(config-object-track)#exit | Exit object track mode. |
(config)#router vrrp 1 vlan1.1001 | Create a router IPv4 VRRP instance for interface vlan1.1001. |
(config-router)#virtual-ip 10.1.1.1 | Set the virtual IP address for the VRRP session. |
(config-router)#priority 150 | Configure the priority to 150. |
(config-router)#track 1 decrement 60 | Configure the priority-delta value to be 60. In case of failover, this priority-delta value is subtracted from the current VR Master. |
(config-router)#v2-compatible | Enable the v2-compatible. |
(config-router)#enable | Enable the VRRP session. |
(config-router)#commit | Commit the configuration on the node. |
(config-router)#exit | Exit the router mode. |
(config)#router ipv6 vrrp 1 vlan1.1001 | Create a router IPv6 VRRP IPv6 instance for interface vlan1.1001. |
(config-router)#virtual-ipv6 fe80::1 | Set the virtual IPv6 address for the VRRP session. |
(config-router)#priority 150 | Configure the priority to 150. |
(config-router)#track 1 decrement 60 | Configure the priority-delta value to be 60. In case of failover, this priority-delta value is subtracted from the current VR Master. |
(config-router)#enable | Enable the VRRP session. |
(config-router)#commit | Commit the configuration on the node |
(config-router)#exit | Exit the router mode |
(config)#interface xe41 | Enter interface mode |
(config-if)#ip address 60.1.1.1/24 | Configure IPv4 address. |
(config-if)#ipv6 address 6000::1/64 | Configure IPv6 address. |
(config-if)#ipv6 router ospf area 0.0.0.0 | Tag OSPFv3 instance on the interface with area 0. |
(config-if)#commit | Commit the configuration on the node. |
(config-if)#exit | Exit interface mode. |
(config)#exit | Exit configure mode. |
R2
(config)#configure terminal | Enter configure mode. |
(config)#bridge 1 protocol rstp vlan-bridge | Create a RSTP VLAN aware bridge with bridge-id. |
(config)#vlan 1001-1002 bridge 1 | Create VLAN 1001,1002 and map it to bridge 1. |
(config)#interface xe31 | Enter interface mode. |
(config-if)#switchport | Configure switchport. |
(config-if)#bridge-group 1 spanning-tree disable | Configure bridge group to L2 interface with spanning-tree disabled. |
(config-if)#switchport mode trunk | Configure switchport mode as trunk. |
(config-if)#switchport trunk allowed vlan add 1001,1002 | Allow VLAN 1001,1002 on the interface. |
(config-if)#interface vlan1.1001 | Enter the VLAN interface. |
(config-if)#ip address 10.1.1.3/24 | Configure IPv4 address. |
(config-if)#ipv6 address 1000:1::3/32 | Configure IPv6 address. |
(config-if)#ipv6 router ospf area 0.0.0.0 | Tag OSPFv3 instance on interface with area 0. |
(config-if)#commit | Commit the configuration on the node. |
(config-if)#exit | Exit interface mode. |
(config)#router vrrp 1 vlan1.1001 | Create a router IPv4 VRRP instance for interface vlan1.1001. |
(config-router)#virtual-ip 10.1.1.1 | Set the virtual IP address for the VRRP session. |
(config-router)#priority 50 | Configure the priority to 50 (less than 150), because R2 is the VR Backup router. |
(config-router)#v2-compatible | Enable the v2-compatible. |
(config-router)#authentication text abcd | Configure the authentication text to specify that as simple text for VRRPv2 packets, accept only 8 characters. |
(config-router)#enable | Enable the VRRP session. |
(config-router)#commit | Commit the configuration on the node. |
(config-router)#exit | Exit the router mode. |
(config)#router ipv6 vrrp 1 vlan1.1001 | Create a router IPv6 VRRP IPv6 instance for interface vlan1.1001. |
(config-router)#virtual-ipv6 fe80::1 | Set the virtual IPv6 address for the VRRP session. |
(config-router)#priority 50 | Configure the priority to 50 (less than 150), because R2 is the VR Backup router. |
(config-router)#commit | Commit the configuration on the node |
(config-router)#exit | Exit the router mode |
(config)#interface xe41 | Enter interface mode |
(config-if)#ip address 80.1.1.1/24 | Configure IPv4 address. |
(config-if)#ipv6 address 8000::1/64 | Configure IPv6 address. |
(config-if)#ipv6 router ospf area 0.0.0.0 | Tag OSPFv3 instance on interface with area 0. |
(config-if)#exit | Exit interface mode. |
(config)#exit | Exit configure mode. |
Validation
R1#show track
TRACK Id: 1
IP SLA 1 reachability
Reachability is UP
2 changes, last change : 2019 Feb 19 07:19:57
R1#show vrrp 1 vlan1.1001
VRRP Version: 3
VMAC enabled
Backward Compatibility disabled Address family IPv4
VRRP Id: 1 on interface: vlan1.1001 State: AdminUp - Master
Virtual IP address: 10.1.1.1 (Not-owner) Virtual MAC address is 0000.5e00.0101 Operational primary IP address: 10.1.1.2 Operational master IP address: 10.1.1.2 Configured priority: 150, Current priority: 150 Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 0 hours 1 minutes 12 seconds (7200 centi sec)
Master uptime: 0 hours 2 minutes 34 seconds (15400 centi sec) Accept mode: TRUE
Preempt mode: TRUE
Monitored circuit: xe41, Priority Delta: 70, Status: UP Monitored circuit: xe50/1, Priority Delta: 10, Status: UP Monitored circuit: xe50/2, Priority Delta: 30, Status: UP
Auth-type: simple text, String: abcd
Multicast membership on IPv4 interface vlan1.1001: JOINED V 2-Compatible: TRUE
R2#show vrrp 1 vlan1.1001
VRRP Version: 3
VMAC enabled
Backward Compatibility disabled Address family IPv4
VRRP Id: 1 on interface: vlan1.1001 State: AdminUp - Backup
Virtual IP address: 10.1.1.1 (Not-owner) Virtual MAC address is 0000.5e00.0101 Operational primary IP address: 10.1.1.3 Operational master IP address: 10.1.1.2 Priority is 100
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 7 hours 52 minutes 53 seconds (2837300 centi sec) Skew time: 80 centi sec
Master Down Interval: 380 centi sec Accept mode: TRUE
Preempt mode: TRUE
Auth-type: simple text, String: abcd
Multicast membership on IPv4 interface vlan1.1001: JOINED V2-Compatible: TRUE
R1#show vrrp ipv6 1 vlan1.1001
VRRP Version: 3
VMAC enabled
Backward Compatibility disabled Address family IPv6
VRRP Id: 1 on interface: vlan1.1001 State: AdminUp - Master
Virtual IP address: fe80::1 (Not-owner) Virtual MAC address is 0000.5e00.0201
Operational primary IP address: fe80::ba6a:97ff:fe3c:de9d Operational master IP address: fe80::ba6a:97ff:fe3c:de9d Configured priority: 150, Current priority: 150 Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 0 hours 3 minutes 54 seconds (23400 centi sec)
Master uptime: 0 hours 2 minutes 34 seconds (15400 centi sec) Accept mode: TRUE
Preempt mode: TRUE
Monitored circuit: xe41, Priority Delta: 70, Status: UP Monitored circuit: xe50/1, Priority Delta: 10, Status: UP Monitored circuit: xe50/2, Priority Delta: 30, Status: UP Multicast membership on IPv6 interface vlan1.1001: JOINED V2-Compatible: FALSE
R2#show vrrp ipv6 1 vlan1.1001
VRRP Version: 3
VMAC enabled
Backward Compatibility disabled Address family IPv6
VRRP Id: 1 on interface: vlan1.1001 State: AdminUp - Backup
Virtual IP address: fe80::1 (Not-owner) Virtual MAC address is 0000.5e00.0201
Operational primary IP address: fe80::82a2:35ff:fe35:135f Operational master IP address: fe80::ba6a:97ff:fe3c:de9d Priority is 100
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 7 hours 55 minutes 11 seconds (2851100 centi sec) Skew time: 80 centi sec
Master Down Interval: 380 centi sec Accept mode: TRUE
Preempt mode: TRUE
Multicast membership on IPv6 interface vlan1.1001: JOINED V2-Compatible: FALSE
After shut down the tracked Object (xe41) in R1:
R1#show track
TRACK Id: 1
IP SLA 1 reachability
Reachability is DOWN
2 changes, last change : 2019 Feb 19 07:19:57
R1#show vrrp 1 vlan1.1001
VRRP Version: 3
VMAC enabled
Backward Compatibility disabled Address family IPv4
VRRP Id: 1 on interface: vlan1.1001 State: AdminUp - Backup
Virtual IP address: 10.1.1.1 (Not-owner)
Virtual MAC address is 0000.5e00.0101 Operational primary IP address: 10.1.1.2 Operational master IP address: 10.1.1.3
Priority is 90 (Configured Priority is 150) Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 0 hours 7 minutes 46 seconds (46600 centi sec) Skew time: 84 centi sec
Master Down Interval: 380 centi sec Accept mode: TRUE
Preempt mode: TRUE
Monitored circuit: xe41, Priority Delta: 70, Status: DOWN Monitored circuit: xe50/1, Priority Delta: 10, Status: DOWN Monitored circuit: xe50/2, Priority Delta: 30, Status: DOWN Auth-type: simple text, String: abcd
Multicast membership on IPv4 interface vlan1.1001: JOINED V2-Compatible: TRUE
R2#show vrrp 1 vlan1.1001
VRRP Version: 3
VMAC enabled
Backward Compatibility disabled Address family IPv4
VRRP Id: 1 on interface: vlan1.1001 State: AdminUp - Master
Virtual IP address: 10.1.1.1 (Not-owner) Virtual MAC address is 0000.5e00.0101 Operational primary IP address: 10.1.1.3 Operational master IP address: 10.1.1.3 Priority is 100
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 7 hours 57 minutes 41 seconds (2866100 centi sec)
Master uptime: 0 hours 2 minutes 34 seconds (15400 centi sec) Accept mode: TRUE
Preempt mode: TRUE
Multicast membership on IPv4 interface vlan1.1001: JOINED V2-Compatible: FALSE
R1#show vrrp ipv6 1 vlan1.1001
VRRP Version: 3
VMAC enabled
Backward Compatibility disabled Address family IPv6
VRRP Id: 1 on interface: vlan1.1001 State: AdminUp - Backup
Virtual IP address: fe80::1 (Not-owner) Virtual MAC address is 0000.5e00.0201
Operational primary IP address: fe80::ba6a:97ff:fe3c:de9d Operational master IP address: fe80::82a2:35ff:fe35:135f Priority is 90 (Configured Priority is 150)
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 0 hours 8 minutes 43 seconds (52300 centi sec) Skew time: 84 centi sec
Master Down Interval: 380 centi sec Accept mode: TRUE
Preempt mode: TRUE
Monitored circuit: xe41, Priority Delta: 70, Status: DOWN Monitored circuit: xe50/1, Priority Delta: 10, Status: DOWN Monitored circuit: xe50/2, Priority Delta: 30, Status: DOWN Multicast membership on IPv6 interface vlan1.1001: JOINED V2-Compatible: FALSE
R2#show vrrp ipv6 1 vlan1.1001
VRRP Version: 3
VMAC enabled
Backward Compatibility disabled Address family IPv6
VRRP Id: 1 on interface: vlan1.1001 State: AdminUp - Master
Virtual IP address: fe80::1 (Not-owner) Virtual MAC address is 0000.5e00.0201
Operational primary IP address: fe80::82a2:35ff:fe35:135f Operational master IP address: fe80::82a2:35ff:fe35:135f Priority is 100
Advertisement interval: 100 centi sec
Master Advertisement interval: 100 centi sec
Virtual router uptime: 7 hours 59 minutes 4 seconds (2874400 centi sec)
Master uptime: 0 hours 2 minutes 34 seconds (15400 centi sec) Accept mode: TRUE
Preempt mode: TRUE
Multicast membership on IPv6 interface vlan1.1001: JOINED V2-Compatible: FALSE