MLAG Active-Standby for VPLS
Overview
The Virtual Private LAN Service (VPLS) architecture provides a multipoint ethernet connection using the Multi-Protocol Label Switching (MPLS) transport. This helps connect multiple devices from different geographical locations to the same virtual network. The Multi-Chassis Link Aggregation (MLAG) provides the redundancy technique in the VPLS architecture, making it failsafe multipoint VPLS connectivity. The redundancy in the network traffic is achieved by dual-homing a Customer Edge (CE) device to two Provider Edge (PE) devices.
A single CE is dual-homed to two PEs for redundancy is shown in the following figure:
Feature Characteristics
The Multi-Chassis Link Aggregation (MLAG) Active-Standby for VPLS feature facilitates implementation of the MLAG Active-Standby between the VPLS PE devices. This facilitates Attachment Circuit (AC) redundancy for the dual-homed Customer Edge (CE) device. This means there is one Active link and another Standby link between a CE device and the PE devices. When an Active link fails, the Standby link becomes Active with the MLAG switch, resulting in a change in topology. The change in topology requires a mac-flush in the peer devices for faster convergence. The feature also facilitates forwarding the automatic mac-flush message to all the peer nodes, reducing the convergence time when a link fails.

The above figure shows a VPLS mesh linked to a dual-homed CE connected to PE1 and PE2. The traffic flows from CE to PE3 through the active MLAG PE1, while PE2 remains a standby MLAG. When PE1 experiences a link failure, the standby MLAG becomes active, and traffic flows through the PE2 device to reach the destination PE3. Configuring the mac flush send on mlag switchover command enables MAC flush PDU tx, and PE2 automatically sends the MAC flush message to all the peer nodes PE1, PE3, and PE4 as depicted by the red arrows, which reduces the convergence time.
Consider the following point while configuring this feature:
• Only Active-Standby MLAG is supported.
• Only flush-all-but-mine MAC-flush approach is supported.
• If multiple Attachment Circuits (ACs) are mapped to the same MLAG interface, the MLAG switch is not triggered when only one or a few AC go down.
• MAC flush on a remote VPLS peer is supported only when LDP signaling (not BGP signaling) is used. A MAC flush message (flush-all-but-mine) will have an empty MAC address list. An empty MAC address list will flush all the MAC addresses and cannot flush any selected MAC addresses.
Benefit
This feature enhances the reliability of VPLS by providing redundancy using MLAG.
Prerequisites
Refer to the
MLAG Configuration section in the
OcNOS Layer 2 Guide.
Configuration
This section shows the configuration of the MLAG VPLS.
Topology
The following topology shows a VPLS mesh. The traffic is flowing from SW to PE3. PE1 has an MLAG configured as Active and PE2 as Standby. When a link failure occurs between SW and PE1 (the Active MLAG node), the link between SW and PE2 becomes Active.
MLAG VPLS configuration topology
MLAG VPLS Configuration
The following steps show the configuration of the MLAG VPLS with automatic MAC flush capability during the MLAG switchover.
Configuring MLAG on PE1 (Active) and PE2 (Standby)
1. Type bridge 1 protocol rstp vlan-bridge to create a bridge and attach it to the RSTP. Type the command vlan database to enter the VLAN configuration mode, and then vlan 100-300 bridge 1 state enable to enable the VLAN 100 to 300 on the bridge 1.
(config)#bridge 1 protocol rstp vlan-bridge
(config)#vlan database
(config-vlan)#vlan 100-300 bridge 1 state enable
2. Type mcec domain configuration to enter the MCEC domain configuration mode and then configure the domain-address to identify the MCEC domain. Type the command domain-system-number 1 to configure the domain system number that uniquely identifies the domain system in MCEC domain and then type the command intra-domain-peer 2.2.2.2 source-address 9.9.9.9 to map an interface as intra domain peer that connects the domain system with its neighbor in a MCEC domain.
(config)#mcec domain configuration
(config-mcec-domain)#domain-address 1111.2222.3333
(config-mcec-domain)#domain-system-number 1
(config-mcec-domain)#intra-domain-peer 2.2.2.2 source-address 9.9.9.9
3. Type the command interface mlag1 and then switchport to configure the interface. Type bridge-group 1 to bind an interface with the bridge group. Type switchport mode trunk to set the interface to the trunk port that allows multiple VLAN configurations in the interface, and then type switchport trunk allowed vlan add 100-150 to configure the required VLAN identifier. Type the command switchover type revertive 2 to return back to initial MLAG after 2 seconds after fail recovery.
(config)#interface mlag1
(config-if)#switchport
(config-if)#bridge-group 1
(config-if)#switchport mode trunk
(config-if)#switchport trunk allowed vlan add 100-150
(config-if)#switchover type revertive 2
4. Type interface po1 to enter the specified port channel, type switchport to configure the interface as Layer 2, and the type mlag 1 to enable the specific MLAG.
(config)#interface po1
(config-if)#switchport
(config-if)#mlag 1
5. Type interface ce5 to configure the interface and then type channel-group 1 mode active to add the interface to the channel group.
(config)#interface ce5
(config-if)#channel-group 1 mode active
Configuring VPLS Session on PE1 (Active MLAG Peer), PE2 (Standby MLAG Peer), and PE3
1. Type mpls vpls vpls1 200 to create an VPLS instance. Type mac-flush-send-on-mlag-switchover to enable the MAC flush PDU tx during the MLAG switchover, type signaling ldp to enter the VPLS signaling mode as only LDP signaling is supported for the MAC flush, and then type vpls-peer 2.2.2.2 and vpls-peer 31.31.31.31 to add a peer to a VPLS domain.
(config)#mpls vpls vpls1 200
(config-vpls)#mac-flush-send-on-mlag-switchover
(config-vpls)#signaling ldp
(config-vpls-sig)#vpls-peer 2.2.2.2
(config-vpls-sig)#vpls-peer 31.31.31.31
(config-vpls-sig)#exit-signaling
(config-vpls)#exit-vpls
2. Type interface po1.200 switchport to create a sub-interface. In the sub-interface, type encapsulation dot1q 200 to select the type of encapsulation as dot1q with the VLAN ID 200. Type access-if-vpls to create a VPLS access port and then mpls-vpls vpls1 to bind the VPLS instance to the subinterface.
(config)#interface po1.200 switchport
(config-if)#encapsulation dot1q 200
(config-if)#access-if-vpls
(config-acc-if-vpls)#mpls-vpls vpls1
Running configurations
PE1:
bridge 1 protocol rstp vlan-bridge
vlan database
vlan 100-300 bridge 1 state enable
mcec domain configuration
domain-address 1111.2222.3333
domain-system-number 1
intra-domain-peer 2.2.2.2 source-address 9.9.9.9
interface mlag1
switchport
bridge-group 1
switchport mode trunk
switchport trunk allowed vlan add 100-150
switchover type revertive 2
interface po1
switchport
mlag 1
mpls vpls vpls1 200
mac-flush-send-on-mlag-switchover
signaling ldp
vpls-peer 2.2.2.2
vpls-peer 31.31.31.31
exit-signaling
exit-vpls
interface po1.200 switchport
encapsulation dot1q 200
access-if-vpls
mpls-vpls vpls1
interface ce5
channel-group 1 mode active
!
PE2:
bridge 1 protocol rstp vlan-bridge
vlan database
vlan 100-300 bridge 1 state enable
mcec domain configuration
domain-address 1111.2222.3333
domain-system-number 1
intra-domain-peer 9.9.9.9 source-address 2.2.2.2
interface mlag1
switchport
bridge-group 1
switchport mode trunk
switchport trunk allowed vlan add 100-150
switchover type revertive 2
interface po1
switchport
mlag 1
mpls vpls vpls1 200
mac-flush-send-on-mlag-switchover
signaling ldp
vpls-peer 9.9.9.9
vpls-peer 31.31.31.31
exit-signaling
exit-vpls
interface po1.200 switchport
encapsulation dot1q 200
access-if-vpls
mpls-vpls vpls1
!
interface ce8
speed 40g
channel-group 1 mode active
!
PE3:
mpls vpls vpls1 200
mac-flush-send-on-mlag-switchover
signaling ldp
ignore-ac-spoke-state
vpls-peer 2.2.2.2
vpls-peer 9.9.9.9
exit-signaling
exit-vpls
!
interface xe8.200 switchport
encapsulation dot1q 200
access-if-vpls
mpls-vpls vpls1
!
Validation
Use the following show commands to verify the configuration.
Verify MLAG Domain summary on PE1 and PE2 to verify the Current MLAG status and MLAG Synchronization
PE1# #show mlag domain summary
------------------------------------
Domain Configuration
------------------------------------
Domain System Number : 1
Domain Address : 1111.2222.3333
Domain Priority : 32768
Source Address : 9.9.9.9
Intra-domain-peer : 2.2.2.2
Domain Adjacency : UP
MCEC PDU local version : 1
MCEC PDU peer version : 1
Domain Sync via : Intra-domain-peer
------------------------------------
MLAG Configuration
------------------------------------
MLAG-1
Mapped Aggregator : po1
Physical properties Digest : 54 a9 3a 2a 2b 50 65 bb 3c bc 3d bd c2 43 d6 22
Total Bandwidth : 40g
Mlag Sync : IN_SYNC
Mode : Active-Standby
Current Mlag state : Active
Switchover-mode : Revertive (2s)
PE2#show mlag domain summary
------------------------------------
Domain Configuration
------------------------------------
Domain System Number : 2
Domain Address : 1111.2222.3333
Domain Priority : 32768
Source Address : 2.2.2.2
Intra-domain-peer : 9.9.9.9
Domain Adjacency : UP
MCEC PDU local version : 1
MCEC PDU peer version : 1
Domain Sync via : Intra-domain-peer
------------------------------------
MLAG Configuration
------------------------------------
MLAG-1
Mapped Aggregator : po1
Physical properties Digest : 54 a9 3a 2a 2b 50 65 bb 3c bc 3d bd c2 43 d6 22
Total Bandwidth : 40g
Mlag Sync : IN_SYNC
Mode : Active-Standby
Current Mlag state : Standby
Switchover-mode : Revertive (2s)
Revert Timer : OFF
Verify VPLS sessions on PE1, PE2, and PE3
PE1#show mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status UpTime Ext-Color
200 2.2.2.2 24323 25608 xe10 25608 2/Up 1 LDP Active 00:20:29 -
200 31.31.31.31 24325 25604 xe10 26885 2/Up 2 LDP Active 00:20:29 -
PE2#show mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status UpTime Ext-Color
200 9.9.9.9 N/A 25608 N/A 25608 0/Dn 3 LDP Standby - -
200 31.31.31.31 N/A 25602 N/A 26890 0/Dn 4 LDP Standby - -
PE3#show mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status UpTime Ext-Color
200 2.2.2.2 N/A 26885 N/A 25604 0/Dn 2 LDP Standby - -
200 9.9.9.9 24320 26890 xe4 25602 2/Up 1 LDP Active 17:35:59 -
Verify VPLS MAC addresses learned on PE1, PE2, and PE3
PE1#show mpls vpls mac-address
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
VPLS-ID MAC address Learned from Vlan-Id Peer address Time-out Move Count
200 0000.2000.0020 xe10 - 31.31.31.31 300 0
200 0010.2000.0020 po1.200
PE2#show mpls vpls mac-address
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
VPLS-ID MAC address Learned from Vlan-Id Peer address Time-out Move Count
200 0000.2000.0020 xe10 - 31.31.31.31 300 0
PE3#show mpls vpls mac-address
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
VPLS-ID MAC address Learned from Vlan-Id Peer address Time-out Move Count
200 0000.2000.0020 xe8.200
200 0010.2000.0020 xe5 - 9.9.9.9 296 0
MLAG Active peer went down (Shutdown Acive MLAG peer interface on PE1 or on switch)
PE1(config)#interface po1
PE1(config-if)#shutdown
PE1(config-if)#commit
PE1(config)#end
Verify MLAG domain summary on PE1 and PE2 to verify the Current MLAG status and MLAG Synchronization
PE1#show mlag domain summary
------------------------------------
Domain Configuration
------------------------------------
Domain System Number : 1
Domain Address : 1111.2222.3333
Domain Priority : 32768
Source Address : 9.9.9.9
Intra-domain-peer : 2.2.2.2
Domain Adjacency : UP
MCEC PDU local version : 1
MCEC PDU peer version : 1
Domain Sync via : Intra-domain-peer
------------------------------------
MLAG Configuration
------------------------------------
MLAG-1
Mapped Aggregator : po1
Physical properties Digest : 54 a9 3a 2a 2b 50 65 bb 3c bc 3d bd c2 43 d6 22
Total Bandwidth : 40g
Mlag Sync : IN_SYNC
Mode : Active-Standby
Current Mlag state : Standby
Switchover-mode : Revertive (2s)
PE2#show mlag domain summary
------------------------------------
Domain Configuration
------------------------------------
Domain System Number : 2
Domain Address : 1111.2222.3333
Domain Priority : 32768
Source Address : 2.2.2.2
Intra-domain-peer : 9.9.9.9
Domain Adjacency : UP
MCEC PDU local version : 1
MCEC PDU peer version : 1
Domain Sync via : Intra-domain-peer
------------------------------------
MLAG Configuration
------------------------------------
MLAG-1
Mapped Aggregator : po1
Physical properties Digest : 54 a9 3a 2a 2b 50 65 bb 3c bc 3d bd c2 43 d6 22
Total Bandwidth : 40g
Mlag Sync : IN_SYNC
Mode : Active-Standby
Current Mlag state : Active
Switchover-mode : Revertive (10s)
Revert Timer : OFF
Verify VPLS sessions on PE1, PE2, and PE3
PE1#show mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status UpTime Ext-Color
200 2.2.2.2 N/A 25608 N/A 25608 0/Dn 1 LDP Standby - -
200 31.31.31.31 N/A 25604 N/A 26885 0/Dn 2 LDP Standby - -
PE2#show mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status UpTime Ext-Color
200 9.9.9.9 24321 25608 ce6 25608 2/Up 3 LDP Active 00:21:54 -
200 31.31.31.31 24325 25602 ce6 26890 2/Up 4 LDP Active 17:35:21 -
PE3#show mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status UpTime Ext-Color
200 2.2.2.2 24320 26890 xe4 25602 2/Up 1 LDP Active 17:45:58 -
200 9.9.9.9 N/A 26885 N/A 25604 0/Dn 2 LDP Standby - -
Verify VPLS MAC addresses learned on PE1, PE2, and PE3
PE1#show mpls vpls mac-address
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
VPLS-ID MAC address Learned from Vlan-Id Peer address Time-out Move Count
200 0000.2000.0020 xe10 - 31.31.31.31 300 0
PE2#show mpls vpls mac-address
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
VPLS-ID MAC address Learned from Vlan-Id Peer address Time-out Move Count
200 0000.2000.0020 xe3 - 31.31.31.31 300 0
200 0010.2000.0020 po1.200
PE3#show mpls vpls mac-address
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
VPLS-ID MAC address Learned from Vlan-Id Peer address Time-out Move Count
200 0000.2000.0020 xe8.200
200 0010.2000.0020 xe4 - 2.2.2.2 296 0
MLAG Active-Standby for VPLS commands
The MLAG Active-Standby for VPLS introduces the following configuration command.
mac flush send on mlag switchover
Use this command to enable the MAC flush PDU tx during the MLAG switchover.
Use the no command to disable the MAC PDU tx flush during the MLAG switchover.
Command Syntax
mac-flush-send-on-mlag-switchover
no mac-flush-send-on-mlag-switchover
Parameters
None
Default
Disabled
Command Mode
VPLS mode
Applicability
Introduced in OcNOS version 6.6.0.
Example
This example shows how to configure mac flush automatically on the peer nodes:
OcNOS#configure terminal
OcNOS(config)#mpls vpls VPLS-102 102
OcNOS(config-vpls)#mac-flush-send-on-mlag-switchover
OcNOS(config-vpls)#commit
OcNOS(config-vpls)#end
Revised CLI Commands
The following command is revised:
switchover type
The revertive time range is revised from
<1-255> to
<1-3600>. For more details, refer to
switchover type command in the
Multi-chassis Link Aggregation Commands chapter in the
Layer 2 Guide.
Glossary
The following provides definitions for key terms or abbreviations and their meanings used throughout this document:
Key Terms/Acronym | Description |
VPLS | Virtual Private Local Area Network Service is a technology that uses a shared Layer 2 Virtual Private Network (L2VPN) to establish communication between different geographical sites as if they are in the same Local Area Network (LAN). |
MPLS | Multi-Protocol Label Switching is a high-performance routing protocol that attaches labels to data packets to efficiently forward and route data in a network. |
CE | Customer Edge is a device that resides at the customer premises and bridges the customer's internal network to the service provider network. |
PE | Provider Edge is a device that resides at the provider's edge, manages traffic from the customer edge, and forwards it to the provider's backbone. |
MLAG | Multi-Chassis Link Aggregation is a network architecture that uses multiple switches or routers to work as a single logical device to increase redundancy and bandwidth. |
AC | Attachment circuit is an interface or link that connects a CE device to the PE device. |
MAC | Media Access Control is a unique identifier of a device's network interface card (NIC) to communicate in a local area network (LAN). |