OcNOS SP : Key Features : Improved Routing : Traffic Steering for Flexible Algorithms
Traffic Steering for Flexible Algorithms
Overview
Traffic Steering for Flexible Algorithms feature integrates BGP On-Demand Next Hop (ODN) policies with Flexible Algorithms to improve the efficiency of path computation. Flexible Algorithms allow for route selection based on specific network constraints such as latency, bandwidth, and other performance metrics. By combining BGP ODN policies with Flexible Algorithms, the network can dynamically compute and adjust optimal paths in real-time, ensuring effective traffic management according to service requirements.
Feature Characteristics
Coloring for Traffic Steering:
The egress PE node assigns colors to MPLS service FTNs.
These colors represent SR-TE SLA requirements and are advertised via BGP UPDATE messages to the ingress PE node.
The ingress node matches the color information with the corresponding ODN policy and steers the traffic accordingly (Traffic Steering).
Integration with Flexible Algorithms:
ODN policies can be combined with Flexible Algorithms to create Flex-Algo-based SR-MPLS BE tunnels (Flex-Algo LSPs).
These tunnels enhance path computation by allowing route selection based on constraints such as latency, bandwidth, and traffic load.
Network operators can customize routing logic to optimize traffic flow and enhance network efficiency.
Support for Multiple MPLS Services:
Flex-Algo LSPs can be used with:
VPLS (Signaling via BGP)
BGP VPNv4
BGP VPNv6
EVPN (ELINE, ELAN, ETREE)
Benefits
This feature offers several key advantages:
Traffic steering based on SR-TE SLA requirements, ensuring optimal path selection.
Customizable routing logic using Flexible Algorithms, tailored to constraints like latency, bandwidth, and traffic load.
Dynamic network adaptation, which reduces the need for manual intervention and minimizes complexity.
Efficient resource utilization through Flex-Algo LSPs, optimizing traffic routing.
Policy-driven traffic steering, enhancing resource allocation and overall network performance.
Real-time path adjustments in response to congestion, failures, or changes in SLA.
Prerequisites
This feature requires the following device capabilities:
OcNOS devices must support:
ISIS-SR Flex-Algo and ECMP
BGP-VPLS and L3VPN/6VPE services
EVPN services
Configuration
The following configuration enables Flex Algo with ISIS-SR.
Topology
This topology represents the application of Flex-Algo in a SR network environment, with three distinct algorithms highlighted: Flex Algo 0, 128, and 129. Each algorithm defines a specific logical topology based on unique constraints and use cases.
Topology Visualization:
Red Lines (Flex Algo 0): Represents the default IGP metric-based paths where all links contribute to general traffic forwarding.
Green Lines (Flex Algo 128): Highlights paths optimized for bandwidth efficiency using GREEN-affinity links, filtering out non-compliant links.
Blue Lines (Flex Algo 129): Displays paths optimized for delay-sensitive traffic using BLUE-affinity links, excluding all others.
Logical Topologies Based on Flexible Algorithms
Configuration for BGP-VPLS Traffic Steering with ODN for FlexAlgo
The following configuration enables BGP-VPLS Traffic Steering with ODN Policy.
The goal is to extend the existing setup used in the Flex Algorithm for ISIS chapter to configure BGP VPLS services over Flex-Algo 128.
ODN policy will be used to automate the steering of VPLS traffic. This ensures that VPLS traffic follows the optimized paths based on Flex-Algo 128 constraints and metrics.
The approach helps in seamless integration of VPLS over an SR-based network while maintaining traffic engineering flexibility.
To configure BGP-VPLS functionality on nodes between RTR1 to RTR3, follow the steps mentioned below:
1. Configure BGP for VPLS Services.
1. Set up BGP in L2VPN address family on RTR1 and RTR2 as below.
RTR1(config)#router bgp 65010
RTR1(config-router)# bgp auto-policy-soft-reset enable
RTR1(config-router)# neighbor 25.0.1.5 remote-as 65010
RTR1(config-router)# neighbor 25.0.1.5 update-source loopback2
RTR1(config-router)# end
 
RTR1(config-router)# address-family l2vpn vpls
RTR1(config-router-af)# neighbor 25.0.1.5 activate
RTR1(config-router-af)# exit-address-family
RTR1(config-router)# end
RTR1(config-router)# exit
 
RTR3(config)#router bgp 65010
RTR3(config-router)# bgp auto-policy-soft-reset enable
RTR3(config-router)# neighbor 25.0.1.5 remote-as 65010
RTR3(config-router)# neighbor 25.0.1.5 update-source loopback2
RTR1(config-router)# end
RTR3(config-router)# exit
 
RTR3(config-router)# address-family l2vpn vpls
RTR3(config-router-af)# neighbor 25.0.1.5 activate
RTR3(config-router-af)# exit-address-family
RTR1(config-router)# end
RTR3(config-router)# exit
2. Set up BGP in L2VPN address family on RTR3 which acts as RR below:
RTR5(config)#router bgp 65010
RTR5(config-router)# bgp auto-policy-soft-reset enable
RTR5(config-router)# no bgp inbound-route-filter
RTR5(config-router)# neighbor 25.0.1.1 remote-as 65010
RTR5(config-router)# neighbor 25.0.1.1 update-source loopback2
RTR5(config-router)# neighbor 25.0.1.3 remote-as 65010
RTR5(config-router)# neighbor 25.0.1.3 update-source loopback2
RTR5(config-router)# !
RTR5(config-router)# address-family l2vpn vpls
RTR5(config-router-af)# neighbor 25.0.1.1 activate
RTR5(config-router-af)# neighbor 25.0.1.1 route-reflector-client
RTR5(config-router-af)# neighbor 25.0.1.3 activate
RTR5(config-router-af)# neighbor 25.0.1.3 route-reflector-client
RTR5(config-router-af)# exit-address-family
RTR5(config-router)# !
RTR5(config-router)# exit
2. Configure VPLS Instance on Between RTR1 and RTR3.
RTR1(config)#mpls vpls BGP-VPLS 1000
RTR1(config-vpls)# signaling bgp
RTR1(config-vpls-sig)# ve-id 1
RTR1(config-vpls-sig)# exit-signaling
RTR1(config-vpls)# exit-vpls
RTR1(config)#end
 
RTR3(config)#mpls vpls BGP-VPLS 1000
RTR3(config-vpls)# signaling bgp
RTR3(config-vpls-sig)# ve-id 1
RTR3(config-vpls-sig)# exit-signaling
RTR3(config-vpls)# exit-vpls
RTR3(config)#end
Note: Each VE-ID must be unique per node within the VPLS instance.
3. Configure the egress side to advertise the color per VPLS instance using a route-map:
1. Egress-side, Color needs to be advertised per vpls instance (as mentioned below).
RTR3(config)#route-map set_color permit 10
RTR3(config-route-map)# set extcommunity color 1000
RTR3(config-route-map)#!
 
RTR3(config)#
RTR3(config)#mpls vpls BGP-VPLS 1000
RTR3(config-vpls)#route-map set_color
RTR3(config-vpls)#exit
RTR3(config)#
 
4. Enable ODN Policy for Traffic Steering on RTR1:
RTR1(config)#segment-routing
RTR1(config-sr)# traffic-engineering
RTR1(config-sr-te)# on-demand-nexthop 1000
RTR1(config-sr-odn)# flex-algo 128
RTR1(config-sr-odn)# exit-sr-odn
RTR1(config-sr-te)# end
RTR1(config-sr-te)# exit-te
RTR1(config-sr)#
5. Configure ACCESS Interface for BGP-VPLS.
RTR1(config)#interface xe15
RTR1(config-if)# mtu 9216
RTR1(config)#interface xe15.1000 switchport
RTR1(config-if)# encapsulation dot1q 1000
RTR1(config-if)# mtu 9216
RTR1(config-if)# access-if-vpls
RTR1(config-acc-if-vpls)# mpls-vpls BGP-VPLS
RTR1(config-acc-if-vpls)#!
 
RTR1(config)#interface xe15
RTR1(config-if)# mtu 9216
RTR1(config)#interface xe19.1000 switchport
RTR1(config-if)# encapsulation dot1q 1000
RTR1(config-if)# mtu 9216
RTR1(config-if)# access-if-vpls
RTR1(config-acc-if-vpls)# mpls-vpls BGP-VPLS
RTR1(config-acc-if-vpls)#!
Configuration Sanapshot:
R1
mpls vpls BGP-VPLS 1000
signaling bgp
ve-id 1
exit-signaling
exit-vpls
 
interface xe15
mtu 9216
 
interface xe15.1000 switchport
encapsulation dot1q 1000
mtu 9216
access-if-vpls
mpls-vpls BGP-VPLS
 
router bgp 65010
bgp auto-policy-soft-reset enable
address-family l2vpn vpls
neighbor 25.0.1.5 activate
exit-address-family
segment-routing
traffic-engineering
on-demand-nexthop 1000
flex-algo 128
exit-sr-odn
!
exit-te
R2
route-map set_color permit 10
set extcommunity color 1000
 
mpls vpls BGP-VPLS 1000
route-map set_color
signaling bgp
ve-id 3
exit-signaling
exit-vpls
 
interface xe19
mtu 9216
 
interface xe19.1000 switchport
encapsulation dot1q 1000
mtu 9216
access-if-vpls
mpls-vpls BGP-VPLS
 
router bgp 65010
bgp auto-policy-soft-reset enable
address-family l2vpn vpls
neighbor 25.0.1.5 activate
exit-address-family
R5
router bgp 65010
no bgp inbound-route-filter
bgp auto-policy-soft-reset enable
address-family l2vpn vpls
neighbor 25.0.1.1 activate
neighbor 25.0.1.1 route-reflector-client
neighbor 25.0.1.3 activate
neighbor 25.0.1.3 route-reflector-client
exit-address-family
!
exit
 
Validation
Verify the bgp vpls summary.
FA-RTR1#show bgp l2vpn vpls summary
BGP router identifier 25.0.1.1, local AS number 65010
BGP table version is 1
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd Desc
25.0.1.5 4 65010 157 160 1 0 0 01:01:15 1
 
Total number of neighbors 1
 
Total number of Established sessions 1
 
FA-RTR1#show bgp l2vpn vpls detail
 
VPLS ID: 1000
VE-ID: 1
Discovered Peers: 1
Route-Target: 65010:1000
Local RD: 65010:1000
All Local Label Blocks:
[LB:81280, VBO:1, VBS:64]
Mesh Peers:
BGP Peer:25.0.1.5/32
VC Nbr Address:25.0.1.3, RD:65010:1000, VE-ID:3
VC Details: VC-ID:13
Local MTU:9216, Remote MTU:9216
Remote (LB:81280,VBO:1,VBS:64) Local (LB:81280,VBO:1,VBS:64)
LB sent on known VEID:Yes
In Label:81282, Out Label:81280
PW Status:Established
VC Installed:Yes
VC Signaled Time: 00:58:21
Extended-Community Color:1000
 
FA-RTR1#
FA-RTR1#show mpls dep-up table
=================================
Route-Node Prefix: 25.0.1.3
=================================
CLIST-INFO:
c_list-Pointer = 3579d30
c_list-Type = CONFIRM_NODE_FTN
c_list-Prefix = 25.0.1.3/32
c_list-Count = 1
---------------------------------
CONFIRM-NODE INFO:
Confirm-Node-Pointer = f4627000
Confirm-Data-Pointer = 30b1550
Confirm-Node-Type = CONFIRM_VPLS_MESH_VC
VPLS Id = 1000
Peer addrss = 25.0.1.3/32
Color = 1000
Parent-FTN-Pointer = ec5d2040
Parent-FTN-Index = 6
Parent-FTN-Name = N/A
Parent-FTN-Owner = ISIS-SR-FA
Parent-FTN-Algo-Num = 128
FA-RTR1#
FA-RTR1#show mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
 
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status UpTime Ext-Color
1000 25.0.1.3 21283 81282 ge2 81280 2/Up 1 BGP Active 00:58:01 1000
FA-RTR1#
FA-RTR1#show mpls vpls detail
Virtual Private LAN Service Instance: BGP-VPLS, ID: 1000
SIG-Protocol: BGP
Route-Distinguisher :65010:1000
Route-Target :65010:1000
VE-ID :1
Attachment-Circuit: UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, Configured MTU: 9216
Description: none
service-tpid: dot1.q
Operating mode: Raw
MAC Withdrawal:
 
Configured interfaces:
Interface: xe15.1000
Status: Up
Subinterface Match Criteria(s) :
dot1q 1000
 
Mesh Peers:
25.0.1.3 (Type: Ethernet) (Negotiated - CW: No, FAT: No) (Up) (UpTime: 00:58:16)
 
 
FA-RTR1#
Verify FlexAlgo FTN entry and corresponding LSP information:
FA-RTR1#show mpls ftn-table 25.0.1.3/32 algorithm 128
Primary FTN entry with FEC: 25.0.1.3/32, id: 6, row status: Active, Tunnel-Policy: N/A, State: Installed
CreateTime: 01:19:25, UpTime: 01:19:25, LastUpdate: N/A
Owner: ISIS-SR-FA, distance: 115, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none, Algorithm Number:128
Tunnel id: 0, Protected LSP id: 0, LSP-type: Primary, Description: N/A, , Color: 0
Cross connect ix: 8, in intf: - in label: 0 out-segment ix: 22 refcount: 1
Owner: ISIS-SR-FA, Persistent: No, Admin Status: Up, Oper Status: Up
State: Active
Out-segment with ix: 22, owner: ISIS-SR-FA, Stale: NO, refcount: 4, out intf: ge2, out label: 21283
Nexthop addr: 11.0.12.2 cross connect ix: 8, op code: Push
 
Cross connect ix: 8, in intf: - in label: 0 out-segment ix: 60 refcount: 1
Owner: ISIS-SR-FA, Persistent: No, Admin Status: Up, Oper Status: Up
State: Active
Out-segment with ix: 60, owner: ISIS-SR-FA, Stale: NO, refcount: 2, out intf: ge6, out label: 21283
Nexthop addr: 11.0.15.5 cross connect ix: 8, op code: Push
 
Dependent service info (count 1):
[VPLS_MESH_VC] VPLS mesh vpls_id 1000 peer 25.0.1.3/32 out_label 81280 in_label 81282 opcode 8 Ext-Color 1000
 
Configuration for L3VPN (VPNv4) Traffic Steering with ODN for FlexAlgo
The following configuration enables L3VPN Traffic Steering with an ODN Policy:
This setup extends the existing configuration from the Flex Algorithm for ISIS chapter to support L3VPN services over Flex-Algo 128.
ODN policy automates the steering of L3VPN traffic, ensuring it follows optimized paths based on the constraints and metrics defined for Flex-Algo 128.
This approach enables seamless integration of L3VPN over an SR-based network while providing traffic engineering flexibility and efficient resource utilization.
1. Configure BGP On RTR1 and RTR3 which are PE routers and RTR5(RR).
1. Set up BGP in Address-Family VPNv4 on RTR1 and RTR2 as below.
RTR1(config)#router bgp 65010
RTR1(config-router)# bgp auto-policy-soft-reset enable
RTR1(config-router)# neighbor 25.0.1.5 remote-as 65010
RTR1(config-router)# neighbor 25.0.1.5 update-source loopback2
RTR1(config-router)# end
RTR1(config-router)# address-family vpnv4 unicast
RTR1(config-router-af)# neighbor 25.0.1.5 activate
RTR1(config-router-af)# exit-address-family
RTR1(config-router)# end
RTR1(config-router)# exit
 
RTR3(config)#router bgp 65010
RTR3(config-router)# bgp auto-policy-soft-reset enable
RTR3(config-router)# neighbor 25.0.1.5 remote-as 65010
RTR3(config-router)# neighbor 25.0.1.5 update-source loopback2
RTR3(config-router)# end
RTR3(config-router)# address-family vpnv4 unicast
RTR3(config-router-af)# neighbor 25.0.1.5 activate
RTR3(config-router-af)# exit-address-family
RTR3(config-router)# end
RTR3(config-router)# exit
 
2. Set up BGP in Address-Family VPNv4 on RTR3 which acts as RR below:
RTR5(config)#router bgp 65010
RTR5(config-router)# bgp auto-policy-soft-reset enable
RTR5(config-router)# no bgp inbound-route-filter
RTR5(config-router)# neighbor 25.0.1.1 remote-as 65010
RTR5(config-router)# neighbor 25.0.1.1 update-source loopback2
RTR5(config-router)# neighbor 25.0.1.3 remote-as 65010
RTR5(config-router)# neighbor 25.0.1.3 update-source loopback2
RTR5(config-router)# end
RTR5(config-router)# address-family vpnv4 unicast
RTR5(config-router-af)# neighbor 25.0.1.1 activate
RTR5(config-router-af)# neighbor 25.0.1.1 route-reflector-client
RTR5(config-router-af)# neighbor 25.0.1.3 activate
RTR5(config-router-af)# neighbor 25.0.1.3 route-reflector-client
RTR5(config-router-af)# exit-address-family
RTR5(config-router)# end
RTR5(config-router)# exit
 
2. Configure VRF on PE Routers (RTR1 and RTR3).
RTR1(config)#ip vrf vrf2000
RTR1(config-vrf)# rd 10:2000
RTR1(config-vrf)# route-target both 10:2000
 
 
RTR3(config)#ip vrf vrf2000
RTR3(config-vrf)# rd 10:2000
RTR3(config-vrf)# route-target both 10:2000
 
3. Enable BGP for VRF and Configure ACCESS-IF:
RTR1(config)#int xe15
RTR1(config-if)# mtu 9216
RTR1(config-if)#exit
 
RTR1(config)#
RTR1(config-if)#interface xe15.2000
RTR1(config-if)# encapsulation dot1q 2000
RTR1(config-if)# ip vrf forwarding vrf2000
RTR1(config-if)# ip address 100.1.1.1/24
RTR1(config-if)# mtu 9216
RTR1(config-if)#exit
 
RTR1(config)#
RTR1(config)#router bgp 65010
RTR1(config-router)# address-family ipv4 vrf vrf2000
RTR1(config-router-af)# redistribute connected
RTR1(config-router-af)# neighbor 100.1.1.2 remote-as 100
RTR1(config-router-af)# neighbor 100.1.1.2 activate
RTR1(config-router-af)# exit-address-family
RTR1(config-router)#end
RTR1(config-router)#commit
 
 
RTR3(config)#
RTR3(config)#int xe19
RTR3(config-if)# mtu 9216
RTR3(config-if)#exit
RTR3(config)#
RTR3(config-if)#interface xe19.2000
RTR3(config-if)# encapsulation dot1q 2000
RTR3(config-if)# ip vrf forwarding vrf2000
RTR3(config-if)# ip address 200.1.1.1/24
RTR3(config-if)# mtu 9216
RTR3(config-if)#exit
RTR3(config)#
RTR3(config)#router bgp 65010
RTR3(config-router)# address-family ipv4 vrf vrf2000
RTR3(config-router-af)# redistribute connected
RTR3(config-router-af)# neighbor 200.1.1.2 remote-as 200
RTR3(config-router-af)# neighbor 200.1.1.2 activate
RTR3(config-router-af)# exit-address-family
RTR3(config-router)#end
RTR3(config-router)#commit
4. Configure the egress side to advertise the color per VRF under address-family using a route-map.
RTR3(config)#
RTR3(config)#route-map set_color_vrf2000 permit 10
RTR3(config-route-map)#set extcommunity color 2000
RTR3(config-if)#exit
 
RTR3(config)#router bgp 65010
RTR3(config-router)# address-family ipv4 vrf vrf2000
RTR3(config-router-af)# redistribute connected route-map set_color_vrf2000
RTR3(config-router-af)# neighbor 200.1.1.2 route-map set_color_vrf2000 in
RTR3(config-router-af)# exit-address-family
RTR3(config-router)#
 
5. Enable ODN Policy for Traffic Steering on RTR1 for L3VPN routes coming from RTR3:
RTR1(config)#
RTR1(config)#segment-routing
RTR1(config-sr)# traffic-engineering
RTR1(config-sr-te)# on-demand-nexthop 2000
RTR1(config-sr-odn)# flex-algo 128
RTR1(config-sr-odn)# exit-sr-odn
RTR1(config-sr-te)# !
RTR1(config-sr-te)# exit-te
RTR1(config-sr)#commit
Configuration Snapshot
RTR1
router bgp 65010
bgp auto-policy-soft-reset enable
neighbor 25.0.1.5 remote-as 65010
neighbor 25.0.1.5 update-source loopback2
!
address-family vpnv4 unicast
neighbor 25.0.1.5 activate
exit-address-family
!
exit
 
ip vrf vrf2000
rd 10:2000
route-target both 10:2000
int xe15
mtu 9216
interface xe15.2000
encapsulation dot1q 2000
ip vrf forwarding vrf2000
ip address 100.1.1.1/24
mtu 9216
!
router bgp 65010
address-family ipv4 vrf vrf2000
redistribute connected
neighbor 100.1.1.2 remote-as 100
neighbor 100.1.1.2 activate
exit-address-family
!
 
segment-routing
traffic-engineering
on-demand-nexthop 2000
flex-algo 128
exit-sr-odn
!
exit-te
RTR3
router bgp 65010
bgp auto-policy-soft-reset enable
neighbor 25.0.1.5 remote-as 65010
neighbor 25.0.1.5 update-source loopback2
!
address-family vpnv4 unicast
neighbor 25.0.1.5 activate
exit-address-family
!
exit
 
ip vrf vrf2000
rd 10:2000
route-target both 10:2000
int xe19
mtu 9216
interface xe19.2000
encapsulation dot1q 2000
ip vrf forwarding vrf2000
ip address 200.1.1.1/24
mtu 9216
!
router bgp 65010
address-family ipv4 vrf vrf2000
redistribute connected
neighbor 200.1.1.2 remote-as 200
neighbor 200.1.1.2 activate
exit-address-family
!
 
route-map set_color_vrf2000 permit 10
set extcommunity color 2000
 
router bgp 65010
address-family ipv4 vrf vrf2000
redistribute connected route-map set_color_vrf2000
neighbor 200.1.1.2 remote-as 200
neighbor 200.1.1.2 activate
neighbor 200.1.1.2 route-map set_color_vrf2000 in
exit-address-family
RTR5
router bgp 65010
bgp auto-policy-soft-reset enable
no bgp inbound-route-filter
neighbor 25.0.1.1 remote-as 65010
neighbor 25.0.1.1 update-source loopback2
neighbor 25.0.1.3 remote-as 65010
neighbor 25.0.1.3 update-source loopback2
!
address-family vpnv4 unicast
neighbor 25.0.1.1 activate
neighbor 25.0.1.1 route-reflector-client
neighbor 25.0.1.3 activate
neighbor 25.0.1.3 route-reflector-client
exit-address-family
!
exit
Validation
Ensure the VPNv4 routes are properly advertised and received across the BGP sessions. Check for correct route attributes and steering behaviors.:
FA-RTR1#show ip bgp vpnv4 all summary
BGP router identifier 25.0.1.1, local AS number 65010
BGP table version is 5
3 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd Desc
25.0.1.5 4 65010 526 538 5 0 0 01:40:52 11
 
Total number of neighbors 1
 
Total number of Established sessions 1
 
BGP VRF vrf2000 Route Distinguisher: 10:2000
BGP table version is 2
3 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd Desc
100.1.1.2 4 100 41 49 2 0 0 00:15:47 10
 
Total number of neighbors 1
 
Total number of Established sessions 1
FA-RTR1#sh ip bgp vpnv4 all
Status codes: s suppressed, d damped, h history, a add-path, b back-up, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 10:2000 (Default for VRF vrf2000)
*> l 100.1.1.0/24 0.0.0.0 0 100 32768 ? -
*> l 101.0.0.0/24 100.1.1.2 0 100 0 100 i -
*> l 101.0.1.0/24 100.1.1.2 0 100 0 100 i -
*> l 101.0.2.0/24 100.1.1.2 0 100 0 100 i -
*> l 101.0.3.0/24 100.1.1.2 0 100 0 100 i -
*> l 101.0.4.0/24 100.1.1.2 0 100 0 100 i -
*> l 101.0.5.0/24 100.1.1.2 0 100 0 100 i -
*> l 101.0.6.0/24 100.1.1.2 0 100 0 100 i -
*> l 101.0.7.0/24 100.1.1.2 0 100 0 100 i -
*> l 101.0.8.0/24 100.1.1.2 0 100 0 100 i -
*> l 101.0.9.0/24 100.1.1.2 0 100 0 100 i -
*>i 200.1.1.0 25.0.1.3 0 100 0 ? 2000
*>i 201.0.0.0 25.0.1.3 0 100 0 200 i 2000
*>i 201.0.1.0 25.0.1.3 0 100 0 200 i 2000
*>i 201.0.2.0 25.0.1.3 0 100 0 200 i 2000
*>i 201.0.3.0 25.0.1.3 0 100 0 200 i 2000
*>i 201.0.4.0 25.0.1.3 0 100 0 200 i 2000
*>i 201.0.5.0 25.0.1.3 0 100 0 200 i 2000
*>i 201.0.6.0 25.0.1.3 0 100 0 200 i 2000
*>i 201.0.7.0 25.0.1.3 0 100 0 200 i 2000
*>i 201.0.8.0 25.0.1.3 0 100 0 200 i 2000
*>i 201.0.9.0 25.0.1.3 0 100 0 200 i 2000
Announced routes count = 11
Accepted routes count = 11
Route Distinguisher: 10:2000
*>i 200.1.1.0 25.0.1.3 0 100 0 ? 2000
*>i 201.0.0.0 25.0.1.3 0 100 0 200 i 2000
*>i 201.0.1.0 25.0.1.3 0 100 0 200 i 2000
*>i 201.0.2.0 25.0.1.3 0 100 0 200 i 2000
*>i 201.0.3.0 25.0.1.3 0 100 0 200 i 2000
*>i 201.0.4.0 25.0.1.3 0 100 0 200 i 2000
*>i 201.0.5.0 25.0.1.3 0 100 0 200 i 2000
*>i 201.0.6.0 25.0.1.3 0 100 0 200 i 2000
*>i 201.0.7.0 25.0.1.3 0 100 0 200 i 2000
*>i 201.0.8.0 25.0.1.3 0 100 0 200 i 2000
*>i 201.0.9.0 25.0.1.3 0 100 0 200 i 2000
Announced routes count = 0
Accepted routes count = 11
FA-RTR1#
FA-RTR1#sh ip route vrf vrf2000
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
ia - IS-IS inter area, E - EVPN,
v - vrf leaked
* - candidate default
 
IP Route Table for VRF "vrf2000"
C 100.1.1.0/24 is directly connected, xe15.2000, installed 00:35:21, last update 00:35:21 ago
B 101.0.0.0/24 [20/0] via 100.1.1.2, xe15.2000, installed 00:16:14, last update 00:16:14 ago
B 101.0.1.0/24 [20/0] via 100.1.1.2, xe15.2000, installed 00:16:14, last update 00:16:14 ago
B 101.0.2.0/24 [20/0] via 100.1.1.2, xe15.2000, installed 00:16:14, last update 00:16:14 ago
B 101.0.3.0/24 [20/0] via 100.1.1.2, xe15.2000, installed 00:16:14, last update 00:16:14 ago
B 101.0.4.0/24 [20/0] via 100.1.1.2, xe15.2000, installed 00:16:14, last update 00:16:14 ago
B 101.0.5.0/24 [20/0] via 100.1.1.2, xe15.2000, installed 00:16:14, last update 00:16:14 ago
B 101.0.6.0/24 [20/0] via 100.1.1.2, xe15.2000, installed 00:16:14, last update 00:16:14 ago
B 101.0.7.0/24 [20/0] via 100.1.1.2, xe15.2000, installed 00:16:14, last update 00:16:14 ago
B 101.0.8.0/24 [20/0] via 100.1.1.2, xe15.2000, installed 00:16:14, last update 00:16:14 ago
B 101.0.9.0/24 [20/0] via 100.1.1.2, xe15.2000, installed 00:16:14, last update 00:16:14 ago
C 127.0.0.0/8 is directly connected, lo.vrf2000, installed 01:38:23, last update 01:38:23 ago
 
Gateway of last resort is not set
Ensure that MPLS label switching follows the path determined by FlexAlgo and ODN.
FA-RTR1#show mpls vrf-forwarding-table
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup, B - BGP FTN
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP or SR ECMP
Ext-Color - Extended-community color advertised by BGP
 
Code FEC FTN-ID VRF-ID Nhlfe-ID Pri Out-Label Out-Intf Nexthop UpTime Ext-Color
B> 200.1.1.0/24 1 2 4 Yes 81344 - 25.0.1.3 00:06:36 2000
B> 201.0.0.0/24 2 2 4 Yes 81344 - 25.0.1.3 00:06:36 2000
B> 201.0.1.0/24 3 2 4 Yes 81344 - 25.0.1.3 00:06:36 2000
B> 201.0.2.0/24 4 2 4 Yes 81344 - 25.0.1.3 00:06:36 2000
B> 201.0.3.0/24 5 2 4 Yes 81344 - 25.0.1.3 00:06:36 2000
B> 201.0.4.0/24 6 2 4 Yes 81344 - 25.0.1.3 00:06:36 2000
B> 201.0.5.0/24 7 2 4 Yes 81344 - 25.0.1.3 00:06:36 2000
B> 201.0.6.0/24 8 2 4 Yes 81344 - 25.0.1.3 00:06:36 2000
B> 201.0.7.0/24 9 2 4 Yes 81344 - 25.0.1.3 00:06:36 2000
B> 201.0.8.0/24 10 2 4 Yes 81344 - 25.0.1.3 00:06:36 2000
B> 201.0.9.0/24 11 2 4 Yes 81344 - 25.0.1.3 00:06:36 2000
FA-RTR1#
FA-RTR1#show mpls dep-up table
=================================
Route-Node Prefix: 25.0.1.3
=================================
CLIST-INFO:
c_list-Pointer = 30b33e0
c_list-Type = CONFIRM_NODE_FTN
c_list-Prefix = 25.0.1.3/32
c_list-Count = 12
---------------------------------
CONFIRM-NODE INFO:
Confirm-Node-Pointer = f4627060
Confirm-Data-Pointer = ec5d4400
Confirm-Node-Type = CONFIRM_VRF
Fec-Prefix = 201.0.0.0/24
Color = 2000
Parent-FTN-Pointer = ec5d2040
Parent-FTN-Index = 6
Parent-FTN-Name = N/A
Parent-FTN-Owner = ISIS-SR-FA
Parent-FTN-Algo-Num = 128
CONFIRM-NODE INFO:
Confirm-Node-Pointer = f4627090
Confirm-Data-Pointer = ec5d4740
Confirm-Node-Type = CONFIRM_VRF
Fec-Prefix = 201.0.1.0/24
Color = 2000
Parent-FTN-Pointer = ec5d2040
Parent-FTN-Index = 6
Parent-FTN-Name = N/A
Parent-FTN-Owner = ISIS-SR-FA
Parent-FTN-Algo-Num = 128
CONFIRM-NODE INFO:
Confirm-Node-Pointer = f46270c0
Confirm-Data-Pointer = ec5d4a80
Confirm-Node-Type = CONFIRM_VRF
Fec-Prefix = 201.0.2.0/24
Color = 2000
Parent-FTN-Pointer = ec5d2040
Parent-FTN-Index = 6
Parent-FTN-Name = N/A
Parent-FTN-Owner = ISIS-SR-FA
Parent-FTN-Algo-Num = 128
CONFIRM-NODE INFO:
Confirm-Node-Pointer = f46270f0
Confirm-Data-Pointer = ec5d4dc0
Confirm-Node-Type = CONFIRM_VRF
Fec-Prefix = 201.0.3.0/24
Color = 2000
Parent-FTN-Pointer = ec5d2040
Parent-FTN-Index = 6
Parent-FTN-Name = N/A
Parent-FTN-Owner = ISIS-SR-FA
Parent-FTN-Algo-Num = 128
CONFIRM-NODE INFO:
Confirm-Node-Pointer = f4627120
Confirm-Data-Pointer = ec5d5100
Confirm-Node-Type = CONFIRM_VRF
Fec-Prefix = 201.0.4.0/24
Color = 2000
Parent-FTN-Pointer = ec5d2040
Parent-FTN-Index = 6
Parent-FTN-Name = N/A
Parent-FTN-Owner = ISIS-SR-FA
Parent-FTN-Algo-Num = 128
CONFIRM-NODE INFO:
Confirm-Node-Pointer = f4627150
Confirm-Data-Pointer = ec5d5440
Confirm-Node-Type = CONFIRM_VRF
Fec-Prefix = 201.0.5.0/24
Color = 2000
Parent-FTN-Pointer = ec5d2040
Parent-FTN-Index = 6
Parent-FTN-Name = N/A
Parent-FTN-Owner = ISIS-SR-FA
Parent-FTN-Algo-Num = 128
CONFIRM-NODE INFO:
Confirm-Node-Pointer = f4627180
Confirm-Data-Pointer = ec5d5780
Confirm-Node-Type = CONFIRM_VRF
Fec-Prefix = 201.0.6.0/24
Color = 2000
Parent-FTN-Pointer = ec5d2040
Parent-FTN-Index = 6
Parent-FTN-Name = N/A
Parent-FTN-Owner = ISIS-SR-FA
Parent-FTN-Algo-Num = 128
CONFIRM-NODE INFO:
Confirm-Node-Pointer = f46271b0
Confirm-Data-Pointer = ec5d5ac0
Confirm-Node-Type = CONFIRM_VRF
Fec-Prefix = 201.0.7.0/24
Color = 2000
Parent-FTN-Pointer = ec5d2040
Parent-FTN-Index = 6
Parent-FTN-Name = N/A
Parent-FTN-Owner = ISIS-SR-FA
Parent-FTN-Algo-Num = 128
CONFIRM-NODE INFO:
Confirm-Node-Pointer = f46271e0
Confirm-Data-Pointer = ec5d5e00
Confirm-Node-Type = CONFIRM_VRF
Fec-Prefix = 201.0.8.0/24
Color = 2000
Parent-FTN-Pointer = ec5d2040
Parent-FTN-Index = 6
Parent-FTN-Name = N/A
Parent-FTN-Owner = ISIS-SR-FA
Parent-FTN-Algo-Num = 128
CONFIRM-NODE INFO:
Confirm-Node-Pointer = f4627210
Confirm-Data-Pointer = ec5d6140
Confirm-Node-Type = CONFIRM_VRF
Fec-Prefix = 201.0.9.0/24
Color = 2000
Parent-FTN-Pointer = ec5d2040
Parent-FTN-Index = 6
Parent-FTN-Name = N/A
Parent-FTN-Owner = ISIS-SR-FA
Parent-FTN-Algo-Num = 128
CONFIRM-NODE INFO:
Confirm-Node-Pointer = f4627030
Confirm-Data-Pointer = ec5d40c0
Confirm-Node-Type = CONFIRM_VRF
Fec-Prefix = 200.1.1.0/24
Color = 2000
Parent-FTN-Pointer = ec5d2040
Parent-FTN-Index = 6
Parent-FTN-Name = N/A
Parent-FTN-Owner = ISIS-SR-FA
Parent-FTN-Algo-Num = 128
 
FA-RTR1#
FA-RTR1#
FA-RTR1#show mpls forwarding-table 25.0.1.3/32 algorithm 128
Codes: > - installed FTN, * - selected FTN, p - stale FTN, ! - using backup
B - BGP FTN, K - CLI FTN, (t) - tunnel, P - SR Policy FTN, (b) - bypass,
L - LDP FTN, R - RSVP-TE FTN, S - SNMP FTN, I - IGP-Shortcut,
U - unknown FTN, O - SR-OSPF FTN, i - SR-ISIS FTN, k - SR-CLI FTN
(m) - FTN mapped over multipath transport, (e) - FTN is ECMP
 
FTN-ECMP LDP: Disabled, SR: Enabled
Code FEC FTN-ID Nhlfe-ID Tunnel-ID Pri Out-Label Out-Intf ELC Nexthop Algo-Num UpTime
i> 25.0.1.3/32 6 61 - (e) - - - - 128 03:52:48
22 0 Yes 21283 ge2 No 11.0.12.2 - -
60 0 Yes 21283 ge6 No 11.0.15.5 - -
FA-RTR1#show mpls ftn-table 25.0.1.3/32 algorithm 128
Primary FTN entry with FEC: 25.0.1.3/32, id: 6, row status: Active, Tunnel-Policy: N/A, State: Installed
CreateTime: 03:52:56, UpTime: 03:52:56, LastUpdate: N/A
Owner: ISIS-SR-FA, distance: 115, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none, Algorithm Number:128
Tunnel id: 0, Protected LSP id: 0, LSP-type: Primary, Description: N/A, , Color: 0
Cross connect ix: 8, in intf: - in label: 0 out-segment ix: 22 refcount: 1
Owner: ISIS-SR-FA, Persistent: No, Admin Status: Up, Oper Status: Up
State: Active
Out-segment with ix: 22, owner: ISIS-SR-FA, Stale: NO, refcount: 4, out intf: ge2, out label: 21283
Nexthop addr: 11.0.12.2 cross connect ix: 8, op code: Push
 
Cross connect ix: 8, in intf: - in label: 0 out-segment ix: 60 refcount: 1
Owner: ISIS-SR-FA, Persistent: No, Admin Status: Up, Oper Status: Up
State: Active
Out-segment with ix: 60, owner: ISIS-SR-FA, Stale: NO, refcount: 2, out intf: ge6, out label: 21283
Nexthop addr: 11.0.15.5 cross connect ix: 8, op code: Push
 
Dependent service info (count 12):
[CONFIRM_VRF] ftn_ix 6 owner BGP prefix 201.0.4.0/24 nhlfe_ix 4 vrf 2 Ext-Color 2000
[CONFIRM_VRF] ftn_ix 3 owner BGP prefix 201.0.1.0/24 nhlfe_ix 4 vrf 2 Ext-Color 2000
[CONFIRM_VRF] ftn_ix 1 owner BGP prefix 200.1.1.0/24 nhlfe_ix 4 vrf 2 Ext-Color 2000
[CONFIRM_VRF] ftn_ix 2 owner BGP prefix 201.0.0.0/24 nhlfe_ix 4 vrf 2 Ext-Color 2000
[CONFIRM_VRF] ftn_ix 4 owner BGP prefix 201.0.2.0/24 nhlfe_ix 4 vrf 2 Ext-Color 2000
[CONFIRM_VRF] ftn_ix 5 owner BGP prefix 201.0.3.0/24 nhlfe_ix 4 vrf 2 Ext-Color 2000
[CONFIRM_VRF] ftn_ix 9 owner BGP prefix 201.0.7.0/24 nhlfe_ix 4 vrf 2 Ext-Color 2000
[CONFIRM_VRF] ftn_ix 7 owner BGP prefix 201.0.5.0/24 nhlfe_ix 4 vrf 2 Ext-Color 2000
[CONFIRM_VRF] ftn_ix 8 owner BGP prefix 201.0.6.0/24 nhlfe_ix 4 vrf 2 Ext-Color 2000
[CONFIRM_VRF] ftn_ix 10 owner BGP prefix 201.0.8.0/24 nhlfe_ix 4 vrf 2 Ext-Color 2000
[CONFIRM_VRF] ftn_ix 11 owner BGP prefix 201.0.9.0/24 nhlfe_ix 4 vrf 2 Ext-Color 2000
Configuration for EVPN Traffic Steering with ODN for FlexAlgo
The following configuration enables EVPN-ELINE Traffic Steering with an ODN Policy:
This setup extends the existing configuration from the Flex Algorithm for ISIS chapter to support EVPN ELINE services over Flex-Algo 129.
The ODN policy dynamically steers EVPN ELINE traffic, ensuring that it follows the most optimal paths based on the constraints and metrics defined for Flex-Algo 129.
This approach facilitates the seamless integration of EVPN ELINE over an SR-based network, enhancing traffic engineering flexibility while optimizing resource utilization.
1. Configure BGP On RTR1 and RTR3 which are PE routers and RTR5(RR).
1. Set up BGP in Address-Family L2VPN EVPN on RTR1 and RTR2 as below.
RTR1(config)#router bgp 65010
RTR1(config-router)# bgp auto-policy-soft-reset enable
RTR1(config-router)# neighbor 25.0.1.5 remote-as 65010
RTR1(config-router)# neighbor 25.0.1.5 update-source loopback2
RTR1(config-router)# end
RTR1(config-router)# address-family l2vpn evpn
RTR1(config-router-af)# neighbor 25.0.1.5 activate
RTR1(config-router-af)# exit-address-family
RTR1(config-router)# end
RTR1(config-router)# exit
 
 
RTR3(config)#router bgp 65010
RTR3(config-router)# bgp auto-policy-soft-reset enable
RTR3(config-router)# neighbor 25.0.1.5 remote-as 65010
RTR3(config-router)# neighbor 25.0.1.5 update-source loopback2
RTR3(config-router)# end
RTR3(config-router)# address-family l2vpn evpn
RTR3(config-router-af)# neighbor 25.0.1.5 activate
RTR3(config-router-af)# exit-address-family
RTR3(config-router)# end
RTR3(config-router)# exit
2. Set up BGP in Address-Family L2VPN EVPN on RTR3 which acts as RR below:
RTR5(config)#router bgp 65010
RTR5(config-router)# bgp auto-policy-soft-reset enable
RTR5(config-router)# no bgp inbound-route-filter
RTR5(config-router)# neighbor 25.0.1.1 remote-as 65010
RTR5(config-router)# neighbor 25.0.1.1 update-source loopback2
RTR5(config-router)# neighbor 25.0.1.3 remote-as 65010
RTR5(config-router)# neighbor 25.0.1.3 update-source loopback2
RTR5(config-router)# !
RTR5(config-router)# address-family l2vpn evpn
RTR5(config-router-af)# neighbor 25.0.1.1 activate
RTR5(config-router-af)# neighbor 25.0.1.1 route-reflector-client
RTR5(config-router-af)# neighbor 25.0.1.3 activate
RTR5(config-router-af)# neighbor 25.0.1.3 route-reflector-client
RTR5(config-router-af)# exit-address-family
RTR5(config-router)# !
RTR5(config-router)# exit
2. Configure MAC-VRF on PE Routers (RTR1 and RTR3):
RTR1(config)#ip vrf vrf2000
RTR1(config-vrf)# rd 10:2000
RTR1(config-vrf)# route-target both 10:2000
 
RTR3(config)#ip vrf vrf2000
RTR3(config-vrf)# rd 10:2000
RTR3(config-vrf)# route-target both 10:2000
3. Configure EVPN ELINE instance:
RTR1(config)#evpn mpls enable
RTR1(config)#evpn mpls vtep-ip-global 25.0.1.1
RTR1(config)#!
RTR1(config)#evpn mpls id 3000 xconnect target-mpls-id 3001
RTR1(config-evpn-mpls)# host-reachability-protocol evpn-bgp ELINE_SH
RTR1(config-evpn-mpls)#!
 
 
RTR3(config)#evpn mpls enable
RTR3(config)#evpn mpls vtep-ip-global 25.0.1.3
RTR3(config)#!
RTR3(config)#evpn mpls id 3001 xconnect target-mpls-id 3000
RTR3(config-evpn-mpls)# host-reachability-protocol evpn-bgp ELINE_SH
RTR3(config-evpn-mpls)#!
4. Configure the egress side to advertise the color per VRF under address-family using a route-map.
RTR3(config)#
RTR3(config)#route-map set_color_ELINE3000 permit 10
RTR3(config-route-map)#set extcommunity color 3000
RTR3(config-if)#exit
 
RTR3(config)#evpn mpls id 3001 xconnect target-mpls-id 3000
RTR3(config-evpn-mpls)# route-map set_color_ELINE3000
RTR3(config-evpn-mpls)#end
5. Enable ODN Policy for Traffic Steering on RTR1 for EVPN routes coming from RTR3
RTR1(config)#
RTR1(config)#segment-routing
RTR1(config-sr)# traffic-engineering
RTR1(config-sr-te)# on-demand-nexthop 3000
RTR1(config-sr-odn)# flex-algo 129
RTR1(config-sr-odn)# exit-sr-odn
RTR1(config-sr-te)# end
RTR1(config-sr-te)# exit-te
RTR1(config-sr)#commit
 
Configuration Snapshot
RTR1
router bgp 65010
bgp auto-policy-soft-reset enable
neighbor 25.0.1.5 remote-as 65010
neighbor 25.0.1.5 update-source loopback2
!
address-family l2vpn evpn
neighbor 25.0.1.5 activate
exit-address-family
!
exit
 
mac vrf ELINE_SH
rd 25.0.1.1:3000
route-target both evpn-auto-rt
evpn mpls enable
 
evpn mpls vtep-ip-global 25.0.1.1
!
evpn mpls id 3000 xconnect target-mpls-id 3001
host-reachability-protocol evpn-bgp ELINE_SH
!
interface xe15
mtu 9216
!
interface xe15.3000 switchport
encapsulation dot1q 3000
access-if-evpn
map vpn-id 3000
 
RTR3
router bgp 65010
bgp auto-policy-soft-reset enable
neighbor 25.0.1.5 remote-as 65010
neighbor 25.0.1.5 update-source loopback2
!
address-family l2vpn evpn
neighbor 25.0.1.5 activate
exit-address-family
!
!
exit
 
mac vrf ELINE_SH
rd 25.0.1.3:3000
route-target both evpn-auto-rt
evpn mpls enable
 
evpn mpls vtep-ip-global 25.0.1.3
!
evpn mpls id 3001 xconnect target-mpls-id 3000
host-reachability-protocol evpn-bgp ELINE_SH
!
interface xe19
mtu 9216
!
interface xe19.3000 switchport
encapsulation dot1q 3000
mtu 9216
access-if-evpn
map vpn-id 3001
 
route-map set_color_ELINE3000 permit 10
set extcommunity color 3000
exit
 
evpn mpls id 3001 xconnect target-mpls-id 3000
route-map set_color_ELINE3000
 
 
RTR5
router bgp 65010
bgp auto-policy-soft-reset enable
no bgp inbound-route-filter
neighbor 25.0.1.1 remote-as 65010
neighbor 25.0.1.1 update-source loopback2
neighbor 25.0.1.3 remote-as 65010
neighbor 25.0.1.3 update-source loopback2
!
address-family l2vpn evpn
neighbor 25.0.1.1 activate
neighbor 25.0.1.1 route-reflector-client
neighbor 25.0.1.3 activate
neighbor 25.0.1.3 route-reflector-client
exit-address-family
!
exit
Validation
Verify BGP EVPN neighbor state and received prefixes:
FA-RTR1#show bgp l2vpn evpn summary
BGP router identifier 25.0.1.1, local AS number 65010
BGP table version is 8
3 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd AD MACIP MCAST ESI PREFIX-ROUTE Desc
25.0.1.5 4 65010 123 113 8 0 0 00:44:41 1 1 0 0 0 0
 
Total number of neighbors 1
 
Total number of Established sessions 1
FA-RTR1#sh bgp l2vpn evpn
BGP table version is 8, local router ID is 25.0.1.1
Status codes: s suppressed, d damped, h history, a add-path, b back-up, * valid, > best, i - internal,
l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Description : Ext-Color - Extended community color
 
[EVPN route type]:[ESI]:[VNID]:[relevent route informantion]
1 - Ethernet Auto-discovery Route
2 - MAC/IP Route
3 - Inclusive Multicast Route
4 - Ethernet Segment Route
5 - Prefix Route
 
Network Next Hop Metric LocPrf Weight Path Peer Encap
 
RD[25.0.1.1:3000] VRF[ELINE_SH]:
*> [1]:[0]:[3000]:[81920]
25.0.1.1 0 100 32768 i - ---------- MPLS
* i [1]:[0]:[3001]:[81280]
25.0.1.3 0 100 0 i 3000 25.0.1.5 MPLS
 
RD[25.0.1.3:3000]
*>i [1]:[0]:[3001]:[81280]
25.0.1.3 0 100 0 i 3000 25.0.1.5 MPLS
Verify dependency resolution for EVPN service steering over FlexAlgo:
FA-RTR1#show mpls dep-up table
=================================
Route-Node Prefix: 25.0.1.3
=================================
CLIST-INFO:
c_list-Pointer = 27d34d0
c_list-Type = CONFIRM_NODE_FTN
c_list-Prefix = 25.0.1.3/32
c_list-Count = 1
---------------------------------
CONFIRM-NODE INFO:
Confirm-Node-Pointer = b6402210
Confirm-Data-Pointer = 27d3e30
Confirm-Node-Type = CONFIRM_EVPN
EVPN-ID = 3000
Destination Peer = 25.0.1.3
Color = 3000
Parent-FTN-Pointer = ae7c0700
Parent-FTN-Index = 13
Parent-FTN-Name = N/A
Parent-FTN-Owner = ISIS-SR-FA
Parent-FTN-Algo-Num = 129
Verify EVPN MPLS tunnel label allocation and underlay path:
FA-RTR1#show evpn mpls xconnect tunnel
EVPN-MPLS Network tunnel Entries
Source Destination Status Up/Down Update local-evpn-id remote-evpn-id
========================================================================================================
25.0.1.1 25.0.1.3 Installed 00:05:12 00:05:12 3000 3001
 
Total number of entries are 1
Verify EVPN MPLS tunnel label allocation and underlay path:
FA-RTR1#show evpn mpls xconnect tunnel label
EVPN-MPLS Network tunnel labels
(*) in Policy - tunnel-policy inherited from mac-vrf
(e) - Service mapped over MPLS Multipath/ECMP
================+===========+=========+=========+===============+=========+=========+============+=========+============+=========
Local Remote Local Remote MPLS-Multipath Underlay
Destination Status VPWS-ID VPWS-ID Policy UC-Label UC-Label Grp-Name NHLFE-ix NW-Intf NW-Label
================+===========+=========+=========+===============+=========+=========+============+=========+============+=========
25.0.1.3 Installed 3000 3001 -- 81920 81280 -- 57 ge2 21293
 
Total number of entries are 1
Verify EVPN cross-connect status and MTU configuration:
FA-RTR1#show evpn mpls xconnect
EVPN Xconnect Info
========================
AC-AC: Local-Cross-connect
AC-NW: Cross-connect to Network
AC-UP: Access-port is up
AC-DN: Access-port is down
NW-UP: Network is up
NW-DN: Network is down
NW-SET: Network and AC both are up
 
Local Remote Connection-Details
================================ ============ ===================================================================================
VPN-ID EVI-Name MTU VPN-ID Source Destination PE-IP MTU Type NW-Status
================================ ============ ===================================================================================
3000 ---- 9216 3001 xe15.3000 --- Single Homed Port --- 25.0.1.3 9216 AC-NW NW-SET
 
Total number of entries are 1
FA-RTR1#
Verify FlexAlgo FTN entry and corresponding LSP information:
FA-RTR1#show mpls ftn-table 25.0.1.3/32 algorithm 129
Primary FTN entry with FEC: 25.0.1.3/32, id: 13, row status: Active, Tunnel-Policy: N/A, State: Installed
CreateTime: 00:45:21, UpTime: 00:45:21, LastUpdate: N/A
Owner: ISIS-SR-FA, distance: 115, Action-type: Redirect to LSP, Exp-bits: 0x0, Incoming DSCP: none, Algorithm Number:129
Tunnel id: 0, Protected LSP id: 0, LSP-type: Primary, Description: N/A, , Color: 0
Cross connect ix: 7, in intf: - in label: 0 out-segment ix: 56 refcount: 1
Owner: ISIS-SR-FA, Persistent: No, Admin Status: Up, Oper Status: Up
State: Active
Out-segment with ix: 56, owner: ISIS-SR-FA, Stale: NO, refcount: 2, out intf: ge2, out label: 21293
Nexthop addr: 11.0.12.2 cross connect ix: 7, op code: Push