BGP Auto-Discovery (AD) for LDP VPLS
Overview
The BGP Auto-Discovery enables automatic discovery of VPLS peers, eliminating the need for manual peer configuration. Once discovered, pseudo-wires (PWs) between peers are established using LDP signaling, streamlining the VPLS setup process.
Note: In BGP AD VPLS, if rd and/or router-target is configured in ASN4:nn format while BGP extended ASN support is disabled or vice-versa then BGP auto-discovery will not work and mesh PW will not come up. In such scenarios user is expected to remove the BGP AD VPLS instance and configure it again with correct rd and route-target config as per the BGP extended ASN support.
Benefits
The BGP Auto-Discovery provides in following aspects:
• Simplifies the VPLS configuration process.
• Enhances network scalability.
• Improves scaling efficiency when used with route reflectors.
Prerequisites
• Define Interfaces and Loopback Addresses:
Configure Layer 2 interfaces, such as port channel interfaces (e.g., po1), and assign IP addresses for identification and routing. Additionally, configure loopback IP addresses to establish key connectivity points. These settings ensure efficient network routing and communication.
!
interface lo
ip address 127.0.0.1/8
ip address 2.2.2.2/32 secondary
ipv6 address ::1/128
interface xe14
ip address 30.1.1.2/24
• Configure IGP for Dynamic Routing:
Enable ISIS to facilitate dynamic routing on all nodes within the net-work. Define ISIS router instances to match loopback IP addresses and add network segments to ISIS areas for proper route distribution.Set up neighbor relationships using loopback IP addresses, ensuring efficient route advertisement and convergence for optimal network performance.
• ISIS Configuration:
router isis 1
is-type level-2-only
metric-style wide
microloop-avoidance level-2
mpls traffic-eng router-id 2.2.2.2
mpls traffic-eng level-2
capability cspf
dynamic-hostname
bfd all-interfaces
net 49.0000.0000.0002.00
passive-interface lo
!
interface xe14
mpls ldp-igp sync isis level-2
isis network point-to-point
ip router isis 1
• OSPF Configuration:
router ospf 1
ospf router-id 2.2.2.2
network 2.2.2.2/32 area 0.0.0.0
network 30.1.1.0/24 area 0.0.0.0!
!
interface xe14
ip ospf network point-to-point
• LDP Configuration:
router ldp
router-id 100.1.1.1
transport-address ipv4 100.1.1.1
• BGP Configuration:
!
router bgp 64000
bgp router-id 100.1.1.1
neighbor BGP-AD peer-group
neighbor BGP-AD remote-as 64000
neighbor BGP-AD update-source lo
neighbor BGP-AD fall-over bfd multihop
neighbor 150.1.1.1 peer-group BGP-AD
neighbor 160.1.1.1 peer-group BGP-AD
neighbor 170.1.1.1 peer-group BGP-AD
!
address-family ipv4 unicast
redistribute connected
neighbor BGP-AD activate
exit-address-family
!
address-family l2vpn vpls
neighbor BGP-AD activate
neighbor BGP-AD route-reflector-client
exit-address-family
!
exit
!
Configuration
Configure various nodes within the topology to set up a H-VPLS session.
Topology
This sample topology provides basic connectivity and routing between the devices.
BGP-A-D LDP VPLS Topology Diagram
Configuring BGP-A-D LDP VPLS
Configure PE5 router as follows:
1. Configure router LDP.
PE5(config)#router ldp
PE5(config-router)# router-id 170.1.1.1
PE5(config-router)# transport-address ipv4 170.1.1.1
PE5(config-router)# pw-status-tlv
2. Configure loopback interface.
PE5(config)#interface lo
PE5(config-af)#ip address 170.1.1.1/32 secondary
3. Enable LDP and label-switching for core interface.
PE5(config)#interface xe24
PE5(config-if)#ip address 80.1.1.2/24
PE5(config-if)#label-switching
PE5(config-if)#mpls ldp-igp sync ospf
PE5(config-if)#ip ospf network point-to-point
PE5(config-if)#enable-ldp ipv4
PE5(config-if)#router ospf 100
PE5(config-if)#network 80.1.1.0/24 area 0.0.0.0
PE5(config-if)#network 170.1.1.1/32 area 0.0.0.0
4. Configure BGP.
PE5(config)#router bgp 64000
PE5(config-router)#bgp router-id 170.1.1.1
PE5(config-router)#neighbor BGP-AD peer-group
PE5(config-router)#neighbor BGP-AD remote-as 64000
PE5(config-router)#neighbor BGP-AD update-source lo
PE5(config-router)#neighbor BGP-AD fall-over bfd multihop
PE5(config-router)#neighbor 100.1.1.1 peer-group BGP-AD
PE5(config-router)#address-family l2vpn vpls
PE5(config-router-af)#neighbor BGP-AD activate
PE5(config-router-af)#exit-address-family
PE5(config-router)#exit
5. Configure VPLS instance.
PE5(config)#mpls vpls vpls2 2
PE5(config-vpls)#signaling ldp
PE5(config-vpls-sig)#bgp-auto-discovery
PE5(config-vpls-ldp-sig-bgp-ad)#l2vpn-id 200:1001
PE5(config-vpls-ldp-sig-bgp-ad)#rd 10.10.10.10:1001
PE5(config-vpls-ldp-sig-bgp-ad)#route-target both 2:100
PE5(config-vpls-ldp-sig-bgp-ad)#exit-bgp-auto-discovery
PE5(config-vpls-sig)#exit-signaling
PE5(config-vpls)#exit-vpls
6. Configure sub-interface and attach vpls-instance to sub-interface.
PE5(config)#interface xe12.2 switchport
PE5(config-if)#encapsulation dot1q 2
PE5(config-if)#access-if-vpls
PE5(config-acc-if-vpls)#mpls-vpls vpls2
PE5(config-acc-if-vpls)#exit
PE5(config-if)#exit
Configure P1 router as follows:
1. Configure router LDP.
P1(config)#router ldp
P1(config-router)#router-id 100.1.1.1
P1(config-router)#transport-address ipv4 100.1.1.1
2. Enable LDP and label-switching for core interface.
P1(config)#interface ce15/1
P1(config-if)#ip address 20.1.1.1/24
P1(config-if)#label-switching
P1(config-if)#mpls ldp-igp sync ospf
P1(config-if)#ip ospf network point-to-point
P1(config-if)#enable-ldp ipv4
3. Configure network interface.
P1(config)#interface ce16/3
P1(config-if)#ip address 60.1.1.1/24
P1(config-if)#label-switching
P1(config-if)#mpls ldp-igp sync ospf
P1(config-if)#ip ospf network point-to-point
P1(config-if)#enable-ldp ipv4
P1(config)#interface ce16/4
P1(config-if)#ip address 80.1.1.1/24
P1(config-if)#label-switching
P1(config-if)#mpls ldp-igp sync ospf
P1(config-if)#ip ospf network point-to-point
P1(config-if)#enable-ldp ipv4
4. Configure loopback interface.
P1(config)#interface lo
P1(config-if)#ip address 100.1.1.1/32 secondary
5. Configure OSPF.
P1(config)#router ospf 100
P1(config-router)#network 20.1.1.0/24 area 0.0.0.0
P1(config-router)#network 60.1.1.0/24 area 0.0.0.0
P1(config-router)#network 80.1.1.0/24 area 0.0.0.0
P1(config-router)#network 100.1.1.1/32 area 0.0.0.0
6. Configure BGP.
P1(config)#router bgp 64000
P1(config-router)#bgp router-id 100.1.1.1
P1(config-router)#neighbor BGP-AD peer-group
P1(config-router)#neighbor BGP-AD remote-as 64000
P1(config-router)#neighbor BGP-AD update-source lo
P1(config-router)#neighbor BGP-AD fall-over bfd multihop
P1(config-router)#neighbor 150.1.1.1 peer-group BGP-AD
P1(config-router)#neighbor 160.1.1.1 peer-group BGP-AD
P1(config-router)#neighbor 170.1.1.1 peer-group BGP-AD
P1(config-router-af)#address-family l2vpn vpls
P1(config-router-af)#neighbor BGP-AD activate
P1(config-router-af)#neighbor BGP-AD route-reflector-client
P1(config-router-af)#exit-address-family
P1(config-router)#exit
Configure PE3 router as follows:
1. Configure router LDP.
PE3(config)#router ldp
PE3(config-router)# router-id 150.1.1.1
PE3(config-router)# transport-address ipv4 150.1.1.1
2. Enable LDP and label-switching for core interface.
PE3(config)#interface ce4/1
PE3(config-if)#ip address 20.1.1.2/24
PE3(config-if)#label-switching
PE3(config-if)#mpls ldp-igp sync ospf
PE3(config-if)#ip ospf network point-to-point
PE3(config-if)#enable-ldp ipv4
PE3(config)#interface ce8/1
PE3(config-if)#ip address 30.1.1.2/24
PE3(config-if)#label-switching
PE3(config-if)#mpls ldp-igp sync ospf
PE3(config-if)#ip ospf network point-to-point
PE3(config-if)#enable-ldp ipv4
3. Configure loopback interface.
PE3(config)#interface lo
PE3(config-if)#ip address 150.1.1.1/32 secondary
4. Configure OSPF.
PE3(config)#router ospf 100
PE3(config-router)#network 20.1.1.0/24 area 0.0.0.0
PE3(config-router)#network 30.1.1.0/24 area 0.0.0.0
PE3(config-router)#network 150.1.1.1/32 area 0.0.0.0
5. Configure BGP.
PE3(config)#router bgp 64000
PE3(config-router)#bgp router-id 150.1.1.1
PE3(config-router)#neighbor BGP-AD peer-group
PE3(config-router)#neighbor BGP-AD remote-as 64000
PE3(config-router)#neighbor BGP-AD update-source lo
PE3(config-router)#neighbor BGP-AD fall-over bfd multihop
PE3(config-router)#neighbor 100.1.1.1 peer-group BGP-AD
PE3(config-router-af)#address-family l2vpn vpls
PE3(config-router-af)#neighbor BGP-AD activate
PE3(config-router-af)#neighbor BGP-AD route-reflector-client
PE3(config-router-af)#exit-address-family
PE3(config-router)#exit
6. Configure an MPLS L2 Circuit.
PE3(config)#mpls l2-circuit vc1 101 200.1.1.1
7. Configure an MPLS VPLS Instance.
PE3(config)#mpls vpls vpls2 2
PE3(config-vpls-spoke)#vpls-vc vc1
PE3(config-vpls-spoke)#exit-spoke
PE3(config-vpls)#signaling ldp
PE3(config-vpls-sig)#bgp-auto-discovery
PE3(config-vpls-ldp-sig-bgp-ad)#l2vpn-id 200:1001
PE3(config-vpls-ldp-sig-bgp-ad)#rd 10.10.10.10:1001
PE3(config-vpls-ldp-sig-bgp-ad)#route-target both 2:100
PE3(config-vpls-ldp-sig-bgp-ad)#exit-bgp-auto-discovery
PE3(config-vpls-sig)#exit-signaling
PE3(config-vpls)#exit-vpls
8. Configure the network Interface.
PE3(config)#interface ce4/2.2 switchport
PE3(config-if)#encapsulation dot1q 2
PE3(config-if)#access-if-vpls
PE3(config-acc-if-vpls)#mpls-vpls vpls2
PE3(config-acc-if-vpls)#exit
PE3(config-if)#exit
Configure PE4 router as follows:
1. Configure router LDP.
PE4(config)#router ldp
PE4(config-router)# router-id 160.1.1.1
PE4(config-router)# transport-address ipv4 160.1.1.1
2. Configure loopback interface.
PE4(config)#interface lo
PE4(config-if)#ip address 160.1.1.1/32 secondary
3. Enable LDP and label-switching for core interface.
PE4(config)#interface xe24
PE4(config-if)#ip address 60.1.1.2/24
PE4(config-if)#label-switching
PE4(config-if)#mpls ldp-igp sync ospf
PE4(config-if)#ip ospf network point-to-point
PE4(config-if)#enable-ldp ipv4
PE4(config)#interface xe25
PE4(config-if)#ip address 70.1.1.2/24
PE4(config-if)#label-switching
PE4(config-if)#mpls ldp-igp sync ospf
PE4(config-if)#ip ospf network point-to-point
PE4(config-if)#enable-ldp ipv4
4. Configure OSPF.
PE4(config)#router ospf 100
PE4(config-router)#network 60.1.1.0/24 area 0.0.0.0
PE4(config-router)#network 70.1.1.0/24 area 0.0.0.0
PE4(config-router)#network 160.1.1.1/32 area 0.0.0.0
5. Configure BGP.
PE4(config)#router bgp 64000
PE4(config-router)#bgp router-id 160.1.1.1
PE4(config-router)#neighbor BGP-AD peer-group
PE4(config-router)#neighbor BGP-AD remote-as 64000
PE4(config-router)#neighbor BGP-AD update-source lo
PE4(config-router)#neighbor BGP-AD fall-over bfd multihop
PE4(config-router)#neighbor 100.1.1.1 peer-group BGP-AD
PE4(config-router-af)#address-family l2vpn vpls
PE4(config-router-af)#neighbor BGP-AD activate
PE4(config-router-af)#exit-address-family
PE4(config-router)#exit
6. Configure an MPLS L2 Circuit.
PE4(config)#mpls l2-circuit vc1001 1101 200.1.1.1
7. Configure an MPLS VPLS Instance.
PE4(config)#mpls vpls vpls2 2
PE4(config-vpls-spoke)#vpls-vc vc1001
PE4(config-vpls-spoke)#exit-spoke
PE4(config-vpls)#signaling ldp
PE4(config-vpls-sig)#bgp-auto-discovery
PE4(config-vpls-ldp-sig-bgp-ad)#l2vpn-id 200:1001
PE4(config-vpls-ldp-sig-bgp-ad)#rd 10.10.10.10:1001
PE4(config-vpls-ldp-sig-bgp-ad)#route-target both 2:100
PE4(config-vpls-ldp-sig-bgp-ad)#exit-bgp-auto-discovery
PE4(config-vpls-sig)#exit-signaling
PE4(config-vpls)#exit-vpls
8. Configure the network Interface.
PE4(config)#interface xe12.2 switchport
PE4(config-if)#encapsulation dot1q 2
PE4(config-if)#access-if-vpls
PE4(config-acc-if-vpls)#mpls-vpls vpls2
PE4(config-acc-if-vpls)#exit
PE4(config-if)#exit
Configure PE2 router as follows:
1. Configure router LDP.
PE4(config)#router ldp
PE4(config-router)# router-id 200.1.1.1
PE4(config-router)# transport-address ipv4 200.1.1.1
2. Enable LDP and label-switching for core interface.
PE4(config)#interface ce2/4
PE4(config-if)#ip address 70.1.1.2/24
PE4(config-if)#label-switching
PE4(config-if)#mpls ldp-igp sync ospf
PE4(config-if)#ip ospf network point-to-point
PE4(config-if)#enable-ldp ipv4
PE4(config)#interface ce8/1
PE4(config-if)#ip address 30.1.1.2/24
PE4(config-if)#label-switching
PE4(config-if)#mpls ldp-igp sync ospf
PE4(config-if)#ip ospf network point-to-point
PE4(config-if)#enable-ldp ipv4
3. Configure loopback interface.
PE4(config)#interface lo
PE4(config-if)#ip address 200.1.1.1/32 secondary
4. Enable LDP and label-switching for core interface.
PE4(config)#interface xe42
PE4(config-if)#ip address 10.1.1.2/24
PE4(config-if)#label-switching
PE4(config-if)#mpls ldp-igp sync ospf
PE4(config-if)#ip ospf network point-to-point
PE4(config-if)#enable-ldp ipv4
5. Configure OSPF.
PE4(config)#router ospf 100
PE4(config-router)#network 10.1.1.0/24 area 0.0.0.0
PE4(config-router)#network 30.1.1.0/24 area 0.0.0.0
PE4(config-router)#network 70.1.1.1/24 area 0.0.0.0
PE4(config-router)#network 200.1.1.1/32 area 0.0.0.0
6. Configure an MPLS L2 Circuit.
PE4(config)#mpls l2-circuit vc1 101 150.1.1.1
PE4(config)#mpls l2-circuit vc1001 1101 160.1.1.1
7. Configure an MPLS VPLS Instance.
PE4(config)#mpls vpls vpls2 2
PE4(config-vpls)#vpls-vc vc1
PE4(config-vpls-spoke)#vpls-vc secondary vc100
PE4(config-vpls-spoke)#exit-spoke
PE4(config-vpls)#exit-vpls
8. Configure the network Interface.
PE4(config)#interface xe38.2 switchport
PE4(config-if)#encapsulation dot1q 2
PE4(config-if)#access-if-vpls
PE4(config-acc-if-vpls)#mpls-vpls vpls2
PE4(config-acc-if-vpls)#exit
PE4(config-if)#exit
Running Configuration on PE1 Router:
LDP:
router ldp
router-id 2.2.2.2
pw-status-tlv
transport-address ipv4 2.2.2.2
!
!
interface xe14
enable-ldp ipv4
!
VPLS:
mpls vpls vpls2000 2000
signaling ldp
bgp-auto-discovery
rd 100.200.100.200:200
route-target both 64000:1
l2vpn-id 64000:2000
exit-bgp-auto-discovery
exit-signaling
BGP:
router bgp 64000
bgp router-id 2.2.2.2
neighbor 3.3.3.3 remote-as 64000
neighbor 5.5.5.5 remote-as 64000
neighbor 3.3.3.3 update-source lo
neighbor 5.5.5.5 update-source lo
!
address-family l2vpn vpls
neighbor 3.3.3.3 activate
neighbor 5.5.5.5 activate
Running Configuration on PE2 Router:
router ldp
router-id 200.1.1.1
transport-address ipv4 200.1.1.1
!
interface ce2/4
ip address 70.1.1.1/24
label-switching
mpls ldp-igp sync ospf
ip ospf network point-to-point
enable-ldp ipv4
!
interface ce8/1
ip address 30.1.1.1/24
label-switching
mpls ldp-igp sync ospf
ip ospf network point-to-point
enable-ldp ipv4
!
interface lo
ip address 127.0.0.1/8
ip address 200.1.1.1/32 secondary
ipv6 address ::1/128
!
interface xe42
ip address 10.1.1.2/24
label-switching
mpls ldp-igp sync ospf
ip ospf network point-to-point
enable-ldp ipv4
!
router ospf 100
network 10.1.1.0/24 area 0.0.0.0
network 30.1.1.0/24 area 0.0.0.0
network 70.1.1.0/24 area 0.0.0.0
network 200.1.1.1/32 area 0.0.0.0
!
mpls l2-circuit vc1 101 150.1.1.1
!
mpls l2-circuit vc1001 1101 160.1.1.1
!
mpls vpls vpls2 2
vpls-vc vc1
secondary vc1001
exit-spoke
exit-vpls
!
interface xe38.2 switchport
encapsulation dot1q 2
access-if-vpls
mpls-vpls vpls2
exit
exit
!
Running Configuration on PE3 Router:
router ldp
router-id 150.1.1.1
transport-address ipv4 150.1.1.1
!
interface ce4/1
ip address 20.1.1.2/24
label-switching
mpls ldp-igp sync ospf
ip ospf network point-to-point
enable-ldp ipv4
!
interface ce8/1
ip address 30.1.1.2/24
label-switching
mpls ldp-igp sync ospf
ip ospf network point-to-point
enable-ldp ipv4
!
interface lo
ip address 127.0.0.1/8
ip address 150.1.1.1/32 secondary
ipv6 address ::1/128
!
router ospf 100
network 20.1.1.0/24 area 0.0.0.0
network 30.1.1.0/24 area 0.0.0.0
network 150.1.1.1/32 area 0.0.0.0
!
router bgp 64000
bgp router-id 150.1.1.1
neighbor BGP-AD peer-group
neighbor BGP-AD remote-as 64000
neighbor BGP-AD update-source lo
neighbor BGP-AD fall-over bfd multihop
neighbor 100.1.1.1 peer-group BGP-AD
!
address-family ipv4 unicast
redistribute connected
neighbor BGP-AD activate
exit-address-family
!
address-family l2vpn vpls
neighbor BGP-AD activate
exit-address-family
!
exit
!
mpls l2-circuit vc1 101 200.1.1.1
!
mpls vpls vpls2 2
vpls-vc vc1
exit-spoke
signaling ldp
bgp-auto-discovery
l2vpn-id 200:1001
rd 10.10.10.10:1001
route-target both 2:100
exit-bgp-auto-discovery
exit-signaling
exit-vpls
!
interface ce4/2.2 switchport
encapsulation dot1q 2
access-if-vpls
mpls-vpls vpls2
exit
exit
!
end
Running Configuration on P1 Router:
router ldp
router-id 100.1.1.1
transport-address ipv4 100.1.1.1
!
interface ce15/1
ip address 20.1.1.1/24
label-switching
mpls ldp-igp sync ospf
ip ospf network point-to-point
enable-ldp ipv4
!
interface ce16/3
ip address 60.1.1.1/24
label-switching
mpls ldp-igp sync ospf
ip ospf network point-to-point
enable-ldp ipv4
!
interface ce16/4
ip address 80.1.1.1/24
label-switching
mpls ldp-igp sync ospf
ip ospf network point-to-point
enable-ldp ipv4
!
interface lo
ip address 127.0.0.1/8
ip address 100.1.1.1/32 secondary
ipv6 address ::1/128
!
router ospf 100
network 20.1.1.0/24 area 0.0.0.0
network 60.1.1.0/24 area 0.0.0.0
network 80.1.1.0/24 area 0.0.0.0
network 100.1.1.1/32 area 0.0.0.0
!
router bgp 64000
bgp router-id 100.1.1.1
neighbor BGP-AD peer-group
neighbor BGP-AD remote-as 64000
neighbor BGP-AD update-source lo
neighbor BGP-AD fall-over bfd multihop
neighbor 150.1.1.1 peer-group BGP-AD
neighbor 160.1.1.1 peer-group BGP-AD
neighbor 170.1.1.1 peer-group BGP-AD
!
address-family ipv4 unicast
redistribute connected
neighbor BGP-AD activate
exit-address-family
!
address-family l2vpn vpls
neighbor BGP-AD activate
neighbor BGP-AD route-reflector-client
exit-address-family
!
exit
!
Running Configuration on PE4 Router:
router ldp
router-id 160.1.1.1
transport-address ipv4 160.1.1.1
!
interface lo
ip address 127.0.0.1/8
ip address 160.1.1.1/32 secondary
ipv6 address ::1/128
!
interface xe24
ip address 60.1.1.2/24
label-switching
mpls ldp-igp sync ospf
ip ospf network point-to-point
enable-ldp ipv4
!
interface xe25
ip address 70.1.1.2/24
label-switching
mpls ldp-igp sync ospf
ip ospf network point-to-point
enable-ldp ipv4
!
router ospf 100
network 60.1.1.0/24 area 0.0.0.0
network 70.1.1.0/24 area 0.0.0.0
network 160.1.1.1/32 area 0.0.0.0
!
router bgp 64000
bgp router-id 160.1.1.1
neighbor BGP-AD peer-group
neighbor BGP-AD remote-as 64000
neighbor BGP-AD update-source lo
neighbor BGP-AD fall-over bfd multihop
neighbor 100.1.1.1 peer-group BGP-AD
!
address-family ipv4 unicast
redistribute connected
neighbor BGP-AD activate
exit-address-family
!
address-family l2vpn vpls
neighbor BGP-AD activate
exit-address-family
!
exit
!
mpls l2-circuit vc1001 1101 200.1.1.1
!
mpls vpls vpls2 2
vpls-vc vc1001
exit-spoke
signaling ldp
bgp-auto-discovery
l2vpn-id 200:1001
rd 10.10.10.10:1001
route-target both 2:100
exit-bgp-auto-discovery
exit-signaling
exit-vpls
!
interface xe12.2 switchport
encapsulation dot1q 2
access-if-vpls
mpls-vpls vpls2
exit
exit
!
end
Running Configuration on PE5 Router:
router ldp
router-id 170.1.1.1
transport-address ipv4 170.1.1.1
!
interface lo
ip address 127.0.0.1/8
ip address 170.1.1.1/32 secondary
ipv6 address ::1/128
!
interface xe24
ip address 80.1.1.2/24
label-switching
mpls ldp-igp sync ospf
ip ospf network point-to-point
enable-ldp ipv4
!
router ospf 100
network 80.1.1.0/24 area 0.0.0.0
network 170.1.1.1/32 area 0.0.0.0
!
router bgp 64000
bgp router-id 170.1.1.1
neighbor BGP-AD peer-group
neighbor BGP-AD remote-as 64000
neighbor BGP-AD update-source lo
neighbor BGP-AD fall-over bfd multihop
neighbor 100.1.1.1 peer-group BGP-AD
!
address-family ipv4 unicast
redistribute connected
neighbor BGP-AD activate
exit-address-family
!
address-family l2vpn vpls
neighbor BGP-AD activate
exit-address-family
!
exit
!
mpls vpls vpls2 2
signaling ldp
bgp-auto-discovery
l2vpn-id 200:1001
rd 10.10.10.10:1001
route-target both 2:100
exit-bgp-auto-discovery
exit-signaling
exit-vpls
!
interface xe12.2 switchport
encapsulation dot1q 2
access-if-vpls
mpls-vpls vpls2
exit
exit
!
Validation
Validate the show output after configuration as shown below.
PE3-Pri-HUB#sh mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status UpTime Ext-Color
2 160.1.1.1 24322 26241 ce4/1 26241 2/Up 0 LDP Active 00:02:28 -
2 170.1.1.1 25612 26242 ce4/1 26240 2/Up 0 LDP Active 00:00:31 -
9600-PE3-Pri-HUB#
9600-PE3-Pri-HUB#
9600-PE3-Pri-HUB#sh mpls vpls detail
Virtual Private LAN Service Instance: vpls2, ID: 2
SIG-Protocol: LDP
Route-Distinguisher :10.10.10.10:1001
Route-Target :2:100
L2 VPN ID :200:1001
Attachment-Circuit: UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, VPLS Type: Ethernet VLAN, Configured MTU: 9000
Description: none
service-tpid: dot1.q
Operating mode: Tagged
Svlan Id: 0
Svlan Tpid: 8100
MAC Withdrawal:
Configured interfaces:
Interface: ce4/2.2
Status: Up
Subinterface Match Criteria(s) :
dot1q 2
Mesh Peers:
160.1.1.1 (Type: Ethernet VLAN) (Negotiated - CW: No, FAT: No) (Up) (UpTime: 00:02:55)
FEC signaling element: FEC129
FEC129 details:
agi : 00 0A 00 C8 00 00 03 E9
saii: 150.1.1.1
taii: 160.1.1.1
170.1.1.1 (Type: Ethernet VLAN) (Negotiated - CW: No, FAT: No) (Up) (UpTime: 00:00:58)
FEC signaling element: FEC129
FEC129 details:
agi : 00 0A 00 C8 00 00 03 E9
saii: 150.1.1.1
taii: 170.1.1.1
Spoke Peers:
vc1 (Up) (UpTime 00:03:28)
9600-PE3-Pri-HUB#sh bgp l2vpn vpls ldp-sig
VPLS-ID Discovered-Peers Route-Distinguisher L2VPN-ID
2 2 10.10.10.10:1001 200:1001
9600-PE3-Pri-HUB#sh bgp l2vpn vpls ldp-sig detail
VPLS-ID: 2
Local L2VPN-ID : 200:1001
Local RD : 10.10.10.10:1001
Local Route-Targets :
Import List : 2:100
Export List : 2:100
Discovered Peers : 2
Mesh Peers :
BGP Peer-1 : 100.1.1.1
Peer L2VPN-ID : 200:1001
Peer Route-Targets :
Export List : 2:100
Peer Up time : 00:02:03
BGP Peer-2 : 100.1.1.1
Peer L2VPN-ID : 200:1001
Peer Route-Targets :
Export List : 2:100
Peer Up time : 00:04:10
9600-PE3-Pri-HUB#
---------------------------------------------------------------------------------------------------------------------------------
7535-6-PE4-Bkp-HUB#sh mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status UpTime Ext-Color
2 150.1.1.1 24325 26241 xe24 26241 2/Up 0 LDP Active 00:02:33 -
2 170.1.1.1 25614 26242 xe24 26241 2/Up 0 LDP Active 00:00:36 -
7535-6-PE4-Bkp-HUB#
7535-6-PE4-Bkp-HUB#
7535-6-PE4-Bkp-HUB#sh mpls vpls detail
Virtual Private LAN Service Instance: vpls2, ID: 2
SIG-Protocol: LDP
Route-Distinguisher :10.10.10.10:1001
Route-Target :2:100
L2 VPN ID :200:1001
Attachment-Circuit: UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, VPLS Type: Ethernet VLAN, Configured MTU: 9000
Description: none
service-tpid: dot1.q
Operating mode: Tagged
Svlan Id: 0
Svlan Tpid: 8100
MAC Withdrawal:
Configured interfaces:
Interface: xe12.2
Status: Up
Subinterface Match Criteria(s) :
dot1q 2
Mesh Peers:
150.1.1.1 (Type: Ethernet VLAN) (Negotiated - CW: No, FAT: No) (Up) (UpTime: 00:03:00)
FEC signaling element: FEC129
FEC129 details:
agi : 00 0A 00 C8 00 00 03 E9
saii: 160.1.1.1
taii: 150.1.1.1
170.1.1.1 (Type: Ethernet VLAN) (Negotiated - CW: No, FAT: No) (Up) (UpTime: 00:01:03)
FEC signaling element: FEC129
FEC129 details:
agi : 00 0A 00 C8 00 00 03 E9
saii: 160.1.1.1
taii: 170.1.1.1
Spoke Peers:
vc1001 (Dn) (Reason: VC on standby)
7535-6-PE4-Bkp-HUB# sh bgp l2vpn vpls ldp-sig
VPLS-ID Discovered-Peers Route-Distinguisher L2VPN-ID
2 2 10.10.10.10:1001 200:1001
7535-6-PE4-Bkp-HUB#sh bgp l2vpn vpls ldp-sig detail
VPLS-ID: 2
Local L2VPN-ID : 200:1001
Local RD : 10.10.10.10:1001
Local Route-Targets :
Import List : 2:100
Export List : 2:100
Discovered Peers : 2
Mesh Peers :
BGP Peer-1 : 100.1.1.1
Peer L2VPN-ID : 200:1001
Peer Route-Targets :
Export List : 2:100
Peer Up time : 00:02:14
BGP Peer-2 : 100.1.1.1
Peer L2VPN-ID : 200:1001
Peer Route-Targets :
Export List : 2:100
Peer Up time : 00:04:25
---------------------------------------------------------------------------------------------------------------------------------
7535-7-PE5#sh mpls vpls mesh
(m) - Service mapped over multipath transport
(e) - Service mapped over LDP ECMP
VPLS-ID Peer Addr Tunnel-Label In-Label Network-Intf Out-Label Lkps/St PW-INDEX SIG-Protocol Status UpTime Ext-Color
2 150.1.1.1 25618 26240 xe24 26242 2/Up 0 LDP Active 00:00:08 -
2 160.1.1.1 25619 26241 xe24 26242 2/Up 0 LDP Active 00:00:08 -
7535-7-PE5#
7535-7-PE5#
7535-7-PE5#
7535-7-PE5#sh mpls vpls detail
Virtual Private LAN Service Instance: vpls2, ID: 2
SIG-Protocol: LDP
Route-Distinguisher :10.10.10.10:1001
Route-Target :2:100
L2 VPN ID :200:1001
Attachment-Circuit: UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, VPLS Type: Ethernet VLAN, Configured MTU: 9000
Description: none
service-tpid: dot1.q
Operating mode: Tagged
Svlan Id: 0
Svlan Tpid: 8100
MAC Withdrawal:
Configured interfaces:
Interface: xe12.2
Status: Up
Subinterface Match Criteria(s) :
dot1q 2
Mesh Peers:
150.1.1.1 (Type: Ethernet VLAN) (Negotiated - CW: No, FAT: No) (Up) (UpTime: 00:00:26)
FEC signaling element: FEC129
FEC129 details:
agi : 00 0A 00 C8 00 00 03 E9
saii: 170.1.1.1
taii: 150.1.1.1
160.1.1.1 (Type: Ethernet VLAN) (Negotiated - CW: No, FAT: No) (Up) (UpTime: 00:00:26)
FEC signaling element: FEC129
FEC129 details:
agi : 00 0A 00 C8 00 00 03 E9
saii: 170.1.1.1
taii: 160.1.1.1
7535-7-PE5#sh bgp l2vpn vpls ldp-sig
VPLS-ID Discovered-Peers Route-Distinguisher L2VPN-ID
2 2 10.10.10.10:1001 200:1001
7535-7-PE5#sh bgp l2vpn vpls ldp-sig detail
VPLS-ID: 2
Local L2VPN-ID : 200:1001
Local RD : 10.10.10.10:1001
Local Route-Targets :
Import List : 2:100
Export List : 2:100
Discovered Peers : 2
Mesh Peers :
BGP Peer-1 : 100.1.1.1
Peer L2VPN-ID : 200:1001
Peer Route-Targets :
Export List : 2:100
Peer Up time : 00:02:30
BGP Peer-2 : 100.1.1.1
Peer L2VPN-ID : 200:1001
Peer Route-Targets :
Export List : 2:100
Peer Up time : 00:02:30
---------------------------------------------------------------------------------------------------------------------------------
7946-74-PE2-SPOKE#sh mpls vpls detail
Virtual Private LAN Service Instance: vpls2, ID: 2
SIG-Protocol: N/A
Attachment-Circuit: UP
Learning: Enabled
Control-Word: Disabled
Flow Label Status: Disabled, Direction: None, Static: No
Group ID: 0, Configured MTU: 9000
Description: none
service-tpid: dot1.q
Operating mode: Raw
MAC Withdrawal:
Configured interfaces:
Interface: xe38.2
Status: Up
Subinterface Match Criteria(s) :
dot1q 2
Spoke Peers:
vc1 (Up) (UpTime 00:04:18)
Secondary: vc1001 (Dn) (Reason: VC on standby)
7946-74-PE2-SPOKE#sh run vpls
!
mpls vpls vpls2 2
vpls-mtu 9000
vpls-vc vc1
secondary vc1001
exit-spoke
exit-vpls
!
!
interface xe38.2 switchport
access-if-vpls
mpls-vpls vpls2
!
7946-74-PE2-SPOKE#sh mpls vpls spoke
VPLS-ID Peer Addr Virtual Circuit Tunnel-Label In-Label Network-Intf Out-Label Lkps/St Secondary
2 150.1.1.1 vc1 0 26240 ce8/1 26240 2/Up vc1001
2 160.1.1.1 vc1001 N/A 26241 N/A 26240 0/Dn ---
7946-74-PE2-SPOKE#
CLI Commands
The BGP Auto-Discovery (AD) introduces the following configuration commands.
bgp-auto-discovery
Use this command to enable BGP Auto-Discovery for LDP peers.
Use no parameter of this command to disable BGP Auto-Discovery for LDP peers.
Command Syntax
bgp-auto-discovery
no bgp-auto-discovery
Parameters
None
Default
Disabled
Command Mode
SIGNALING LDP mode
Applicability
Introduced in OcNOS version 6.6.0.
Example
Explain or describe the example.
#configure terminal
(config)#mpls vpls VPLS100 100
(config-vpls)#signaling ldp
(config-vpls-sig)#bgp-auto-discovery
(config-vpls-ldp-sig-bgp-ad)#exit-bgp-auto-discovery
(config-vpls-sig)#exit
(config-vpls)#exit
l2vpn-id
Use this command to assign a Layer 2 VPN ID for the LDP VPLS.
Use no form command to remove the Layer 2 VPN ID configuration.
Command Syntax
l2vpn-id ASN:nn_or_IP-address:nn
no l2vpn-id ASN:nn_or_IP-address:nn
Parameters
ASN:nn_or_IP-address:nn
AS number and an arbitrary number (for example, 100:1). Otherwise, specify a 32-bit IP address and an arbitrary number (for example, 192.16.10.1:1).
Default
The default value is set to ASN:VPLS ID when BGP external ASN support is disabled and the BGP ASN is less than 65535; otherwise, specifying a value is mandatory.
Command Mode
BGP AUTO DISCOVERY mode
Applicability
This command is introduced in OcNOS version 6.0.0.
Examples
#configure terminal
(config)#mpls vpls VPLS100 100
(config-vpls)#signaling ldp
(config-vpls-sig)#bgp-auto-discovery
(config-vpls-ldp-sig-bgp-ad)#l2vpn-id 3.3.3.3:3333
(config-vpls-ldp-sig-bgp-ad)#exit-bgp-auto-discovery
(config-vpls-sig)#exit
(config-vpls)#exit
rd (route distinguisher)
Use this command to assign a route distinguisher (RD) for the BGP AD VPLS. The route distinguisher value must be unique within all BGP AD VPLS instances on the router.
Note: BGP auto-discovery requires an RD configuration. Once configured, the RD can be modified but not removed individually; you must remove the entire bgp-auto-discovery configuration block.
Command Syntax
rd ASN:nn_or_IP-address:nn
Parameters
ASN:nn_or_IP-address:nn
AS number and an arbitrary number (for example, 100:1). Otherwise, specify a 32-bit IP address and an arbitrary number (for example, 192.16.10.1:1).
Default
None
Command Mode
BGP AUTO DISCOVERY mode
Applicability
This command is introduced in OcNOS version 6.0.0.
Examples
#configure terminal
(config)#mpls vpls VPLS100 100
(config-vpls)#signaling ldp
(config-vpls-sig)#bgp-auto-discovery
(config-vpls-ldp-sig-bgp-ad)#rd 1.1.1.1:1111
(config-vpls-ldp-sig-bgp-ad)#exit-bgp-auto-discovery
(config-vpls-sig)#exit
(config-vpls)#exit
route-target
Use this command to configure a route-target of type both to the BGP AD VPLS.
Note: Only one route-target of type "both" is supported, and once it is configured, it cannot be modified. To change it, the entire bgp-auto-discovery configuration block must be removed.
Command Syntax
route-target (both) (ASN:nn_or_IP-address:nn|)
Parameters
both
Import and export routing information
ASN:nn_or_IP-address:nn
AS number and an arbitrary number (for example, 100:1). Otherwise, specify a 32-bit IP address and an arbitrary number (for example, 192.16.10.1:1).
Default
None
Command Mode
BGP AUTO DISCOVERY mode
Applicability
This command is introduced in OcNOS version 6.0.0.
Examples
#configure terminal
(config)#mpls vpls VPLS100 100
(config-vpls)#signaling ldp
(config-vpls-sig)#bgp-auto-discovery
(config-vpls-ldp-sig-bgp-ad)#route-target both 2.2.2.2:2222
(config-vpls-ldp-sig-bgp-ad)#exit-bgp-auto-discovery
(config-vpls-sig)#exit
(config-vpls)#exit