OcNOS-SP : Key Features : Enhanced Security and Performance : TCP MSS configuration for LDP sessions
TCP MSS configuration for LDP sessions
Overview
Label Distribution Protocol (LDP) uses Transmission Control Protocol (TCP) to establish sessions between the devices. This feature enables the configuration of TCP Maximum Segment Size (MSS) that defines the maximum segment size in a single TCP segment during a communication session.TCP segment is a unit of data transmitted in a TCP connection. TCP uses three-way handshake process for initial establishment of a TCP connection. In the three-way handshake process, the sending host sends a SYN packet. Once the receiving host receives the SYN packet, it acknowledges and sends back a SYN-ACK packet to the sending host. Once the sending host receives the SYN-ACK packet from the receiving host, it sends an ACK packet, establishing a reliable connection. In this three way handshake process, the MSS is negotiated between the LDP neighbors.
Three-way handshake
Feature Characteristics
The configuration of the TCP MSS for LDP neighbors helps the neighbors adjust the MSS value of the TCP SYN packet. Configure the TCP MSS through the CLI and NetConf interface. The configurable MSS range is offered from 560 to 1440. By default, the MTU value for ethernet cable is 1500 bytes. When configuring the highest MSS value that is 1440, the total MSS becomes 1440 bytes (MSS) plus 20 bytes (IP Header Size), 20 bytes (TCP Header), and Ethernet header which does not cross the default path MTU value.
Note: After configuring TCP MSS, use clear ldp session command to apply the MSS for the operational session.
Configuring TCP MSS
Benefits
By default, the interface MTU value determines the MSS value of an LDP packet. When the interface MTU value exceeds the default ethernet path MTU value of 1500 bytes, the MSS value also crosses the default ethernet path MTU value, resulting in packet fragmentation. The configuration of the specific MSS value limits the packet size irrespective of the interface MTU value, preventing packet fragmentation.[
Prerequisites
Requires the knowledge on TCP handshake and the formation of LDP neighbors.
Configuration
This section shows the procedure to configure TCP MSS for LDP session.
Enable Label Switching
Running LDP on a system requires the following tasks:
1. Enabling label-switching on the interface on NSM.
2. Enabling LDP on an interface in the LDP daemon.
3. Running an Internal Gateway Protocol (IGP), for example, Open Shortest Path first (OSPF), to distribute reachability information within the MPLS cloud.
4. Configuring the transport address.
5. Configure the TCP MSS neighbor on peer node (Active node).
Topology
 
Device topology for TCP MSS for LDP
Configuration
The below configuration shows how to configure the TCP MSS value for the LDP neighbors.
R1 - NSM
 
R1#configure terminal
Enter configure mode.
R1(config)#interface xe1
Specify the interface xe1 to be configured.
R1(config-if)#ip address 10.10.10.1/24
Assign IP address 10.10.10.1/24 to interface.
R1(config-if)#label-switching
Enable label switching on interface xe1.
R1(config-if)#exit
Exit interface mode.
R1(config)#interface lo
Specify the loopback interface to be configured.
R1(config-if)#ip address 1.1.1.1/32 secondary
Set the IP address of the loopback interface to 1.1.1.1/32.
R1(config-if)#commit
Commit the transaction.
R1 - LDP
 
R1(config)#router ldp
Enter Router mode for LDP.
R1(config-router)#router-id 1.1.1.1
Set the router ID to IP address 1.1.1.1.
R1(config-router)#transport-address ipv4 1.1.1.1
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface.
Note: It is preferable to use the loopback address as transport address. In addition, use the parameter ipv6 if you are configuring an IPv6 interface.
R1(config-router)#targeted-peer ipv4 3.3.3.3
Configure targeted peer 3.3.3.3.
R1(config-router-targeted-peer)#exit
Exit targeted peer-mode.
R1(config-router)#exit
Exit the router mode and return to the configure mode.
R1(config)#interface xe1
Enter interface mode xe1.
R1(config-if)#enable-ldp ipv4
Enable LDP on xe1.
R1(config-if)#commit
Commit the transaction.
R1 - OSPF
 
R1(config)#router ospf 100
Configure the routing process and specify the process ID 100. The process ID should be a unique positive integer identifying the routing process.
R1(config-router)#network 10.10.10.0/24 area 0
Define the interface 10.10.10.0/24,on which OSPF runs and associate the area ID 0 with the interface.
R1(config-router)#network 1.1.1.1/32 area 0
Define the interface 1.1.1.1/32, on which OSPF runs and associate the area ID 0 with the interface.
R1(config-router)#commit
Commit the transaction.
R2 - NSM
 
R2#configure terminal
Enter configure mode.
R2(config)#interface lo
Specify the loopback interface to be configured.
R2(config-if)#ip address 2.2.2.2/32 secondary
Set the IP address of the loopback interface to 2.2.2.2/32.
R2(config-if)#exit
Exit interface mode.
R2(config)#interface xe1
Specify the interface xe1 to be configured.
R2(config-if)#ip address 20.20.20.1/24
Assign IP address 20.20.20.1/24 to interface.
R2(config-if)#label-switching
Enable label switching on interface xe1.
R2(config-if)#exit
Exit interface mode.
R2(config)#interface xe2
Specify the interface xe2 to be configured.
R2(config-if)#ip address 10.10.10.2/24
Assign IP address 10.10.10.2/24 to interface.
R2(config-if)#label-switching
Enable label switching on interface xe2.
R2(config-if)#commit
Commit the transaction.
R2 - LDP
 
R2(config)#router ldp
Enter Router mode.
R2(config-router)#router-id 2.2.2.2
Set the router ID to IP address 2.2.2.2.
R2(config-router)#transport-address ipv4 2.2.2.2
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface.
Note: It is preferable to use the loopback address as transport address. In addition, use the parameter ipv6 if you are configuring an IPv6 interface.
R2(config-router)#neighbor 1.1.1.1 tcp-mss 600
Configure the TCP MSS value on peer node which have active side only.
R2(config-router)#exit
Exit router mode and return to configure mode.
R2(config)#interface xe1
Specify the interface xe1 to be configured.
R2(config-if)#enable-ldp ipv4
Enable LDP on a specified interface xe1.
R2(config-if)#exit
Exit interface mode.
R2(config)#interface xe2
Specify the interface xe2 to be configured.
R2(config-if)#enable-ldp ipv4
Enable LDP on a specified interface xe2.
R2(config-if)#commit
Commit the transaction.
R2 - OSPF
 
R2(config)#router ospf 100
Configure the routing process and specify the process ID 100. The process ID should be a unique positive integer identifying the routing process.
R2(config-router)#network 10.10.10.0/24 area 0
Define the interfaces 10.10.10.0/24, on which OSPF runs and associate the area ID 0 with them.
R2(config-router)#network 20.20.20.0/24 area 0
Define the interfaces 20.20.20.0/24, on which OSPF runs and associate the area ID 0 with them.
R2(config-router)#network 2.2.2.2/32 area 0
Define the interfaces 2.2.2.2/32, on which OSPF runs and associate the area ID 0 with them.
R2(config-router)#commit
Commit the transaction.
R3 - NSM
 
R3#configure terminal
Enter configure mode.
R3(config)#interface lo
Specify the loopback interface to be configured.
R3(config-if)#ip address 3.3.3.3/32 secondary
Set the IP address of the loopback interface to 3.3.3.3/32.
R3(config-if)#exit
Exit interface mode.
R3(config)#interface xe1
Specify the interface xe1 to be configured.
R3(config-if)#ip address 20.20.20.2/24
Set the IP address of the interface to 20.20.20.2/24.
R3(config-if)#label-switching
Enable label switching on interface xe1.
R3(config-if)#commit
Commit the transaction.
R3 - LDP
 
R3(config)#router ldp
Enter Router mode.
R3(config-router)#router-id 3.3.3.3
Set the router ID for IP address 3.3.3.3.
R3(config-router)#transport-address ipv4 3.3.3.3
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface.
Note: It is preferable to use the loopback address as transport address. In addition, use the parameter ipv6 if you are configuring an IPv6 interface.
R3(config-router)#neighbor 2.2.2.2 tcp-mss 650
Configure the TCP MSS value on peer node which have active side only.
R3(config-router)#targeted-peer ipv4 1.1.1.1
Configure targeted peer.
R3(config-router-targeted-peer)#exit
Exit targeted peer-mode.
R3(config-router)#exit
Exit the router mode and return to the configure mode.
R3(config)#interface xe1
Enter interface mode xe1.
R3(config-if)#enable-ldp ipv4
Enable LDP on xe1.
R3(config-if)#commit
Commit the transaction.
R3 - OSPF
 
R3(config)#router ospf 100
Configure the routing process and specify the Process ID 100. The Process ID should be a unique positive integer identifying the routing process.
R3(config-router)#network 20.20.20.0/24 area 0
Define the interfaces 20.20.20.0/24, on which OSPF runs and associate the area ID 0 with them.
R3(config-router)#network 3.3.3.3/32 area 0
Define the interfaces 3.3.3.3/32, on which OSPF runs and associate the area ID 0 with them.
R3(config-router)#commit
Commit the transaction.
Validation
R3
 
R3#show ldp session
Codes: m - MD5 password is not set/unset.
g - GR configuration not set/unset.
t - TCP MSS not set/unset.
Session has to be cleared manually
 
Code Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.2 xe1 Active OPERATIONAL 30 00:03:06
1.1.1.1 xe1 Active OPERATIONAL 30 00:03:06
R3#show ldp targeted-peer count
-------------------------------------------------
Num Targeted Peers: 1 [UP: 1]
-------------------------------------------------
PE2#show ldp session count
--------------------------------------------
Multicast Peers : 1 [UP: 1]
Targeted Peers : 1 [UP: 1]
Total Sessions : 2 [UP: 2]
--------------------------------------------
R3#show ldp routes
Prefix Addr Nexthop Addr Intf Owner
1.1.1.1/32 20.20.20.1 xe1 ospf
2.2.2.2/32 20.20.20.1 xe1 ospf
3.3.3.3/32 0.0.0.0 lo connected
10.10.10.0/24 20.20.20.1 xe1 ospf
20.20.20.0/24 0.0.0.0 xe1 connected
R3#show ldp fec-ipv4 count
------------------------
Num. IPv4 FEC(s): 5
------------------------
R3#show ldp session 2.2.2.2
Session state : OPERATIONAL
Session role : Active
TCP Connection : Established
IP Address for TCP : 2.2.2.2
Interface being used : xe1
Peer LDP ID : 2.2.2.2:0
Preferred Peer LDP Password : Not Set
Adjacencies : 20.20.20.1
Advertisement mode : Downstream Unsolicited
Label retention mode : Liberal
Graceful Restart : Not Capable
Keepalive Timeout : 30
Reconnect Interval : 15
Configured TCP MSS : 650
Applied TCP MSS : 650
Preferred TCP MSS : NA
Address List received : 2.2.2.2
10.10.10.2
20.20.20.1
Received Labels : Fec Label Maps To
IPV4:20.20.20.0/24 impl-null none
IPV4:10.10.10.0/24 impl-null none
IPV4:2.2.2.2/32 impl-null none
IPV4:1.1.1.1/32 25600 none
Sent Labels : Fec Label Maps To
IPV4:20.20.20.0/24 impl-null none
IPV4:3.3.3.3/32 impl-null none
R2
 
R2#show ldp session
Codes: m - MD5 password is not set/unset.
g - GR configuration not set/unset.
t - TCP MSS not set/unset.
Session has to be cleared manually
Code Peer IP Address IF Name My Role State KeepAlive UpTime
3.3.3.3 xe1 Passive OPERATIONAL 30 00:06:10
1.1.1.1 xe2 Active OPERATIONAL 30 00:06:10
R2#show ldp session count
--------------------------------------------
Multicast Peers : 2 [UP: 2]
Targeted Peers : 0 [UP: 0]
Total Sessions : 2 [UP: 2]
--------------------------------------------
R2#show ldp routes
Prefix Addr Nexthop Addr Intf Owner
1.1.1.1/32 10.10.10.1 xe2 ospf
2.2.2.2/32 0.0.0.0 lo connected
3.3.3.3/32 20.20.20.2 xe1 ospf
10.10.10.0/24 0.0.0.0 xe2 connected
20.20.20.0/24 0.0.0.0 xe1 connected
 
R2#show ldp session 1.1.1.1
Session state : OPERATIONAL
Session role : Active
TCP Connection : Established
IP Address for TCP : 1.1.1.1
Interface being used : xe2
Peer LDP ID : 1.1.1.1:0
Preferred Peer LDP Password : Not Set
Adjacencies : 10.10.10.1
Advertisement mode : Downstream Unsolicited
Label retention mode : Liberal
Graceful Restart : Not Capable
Keepalive Timeout : 30
Reconnect Interval : 15
Configured TCP MSS : 600
Applied TCP MSS : 600
Preferred TCP MSS : NA
Address List received : 1.1.1.1
10.10.10.1
48.48.48.48
Received Labels : Fec Label Maps To
IPV4:10.10.10.0/24 impl-null none
IPV4:1.1.1.1/32 impl-null 25600
Sent Labels : Fec Label Maps To
IPV4:20.20.20.0/24 impl-null none
IPV4:10.10.10.0/24 impl-null none
IPV4:3.3.3.3/32 25601 impl-null
IPV4:2.2.2.2/32 impl-null none
R1
 
R1#show ldp session
Codes: m - MD5 password is not set/unset.
g - GR configuration not set/unset.
t - TCP MSS not set/unset.
Session has to be cleared manually
 
Code Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.2 xe1 Passive OPERATIONAL 30 00:07:12
3.3.3.3 xe1 Passive OPERATIONAL 30 00:07:12
R1#show ldp session count
--------------------------------------------
Multicast Peers : 1 [UP: 1]
Targeted Peers : 1 [UP: 1]
Total Sessions : 2 [UP: 2]
--------------------------------------------
R1#show ldp targeted-peer count
-------------------------------------------------
Num Targeted Peers: 1 [UP: 1]
-------------------------------------------------
R1#show ldp routes
Prefix Addr Nexthop Addr Intf Owner
1.1.1.1/32 0.0.0.0 lo connected
2.2.2.2/32 10.10.10.2 xe1 ospf
3.3.3.3/32 10.10.10.2 xe1 ospf
10.10.10.0/24 0.0.0.0 xe1 connected
20.20.20.0/24 10.10.10.2 xe1 ospf
R1#show ldp fec
LSR codes : E/N - LSR is egress/non-egress for this FEC,
L - LSR received a label for this FEC,
> - LSR will use this route for the FEC
FEC Code Session Out Label ELC Nexthop Addr
1.1.1.1/32 E > non-existent none No connected
2.2.2.2/32 NL> 2.2.2.2 impl-null No 10.10.10.2
3.3.3.3/32 NL> 2.2.2.2 25601 No 10.10.10.2
10.10.10.0/24 NL 2.2.2.2 impl-null No connected
E > non-existent none No connected
20.20.20.0/24 NL> 2.2.2.2 impl-null No 10.10.10.2
48.48.48.48/32 E > non-existent none No connected
Configure TCP MSS on ALL neighbor
R1 - NSM
 
R1#configure terminal
Enter configure mode.
R1(config)#interface xe1
Specify the interface xe1 to be configured.
R1(config-if)#ip address 10.10.10.1/24
Assign IP address 10.10.10.1/24 to interface.
R1(config-if)#label-switching
Enable label switching on interface xe1.
R1(config-if)#exit
Exit interface mode.
R1(config)#interface lo
Specify the loopback interface to be configured.
R1(config-if)#ip address 1.1.1.1/32 secondary
Set the IP address of the loopback interface to 1.1.1.1/32.
R1(config-if)#commit
Commit the transaction.
R1 - LDP
 
R1(config)#router ldp
Enter Router mode for LDP.
R1(config-router)#router-id 1.1.1.1
Set the router ID to IP address 1.1.1.1.
R1(config-router)#transport-address ipv4 1.1.1.1
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface.
Note: It is preferable to use the loopback address as transport address. In addition, use the parameter ipv6 if you are configuring an IPv6 interface.
R1(config-router)#targeted-peer ipv4 3.3.3.3
Configure targeted peer.
R1(config-router)#neighbor all tcp-mss 700
Configure the TCP MSS value with all neighbor.
R1(config-router-targeted-peer)#exit
Exit-targeted-peer-mode.
R1(config-router)#exit
Exit the Router mode and return to the Configure mode.
R1(config)#interface xe1
Enter interface mode xe1.
R1(config-if)#enable-ldp ipv4
Enable LDP on xe1.
R1(config-if)#commit
Commit the transaction.
R1 - OSPF
 
R1(config)#router ospf 100
Configure the routing process and specify the process ID (100). The process ID should be a unique positive integer identifying the routing process.
R1(config-router)#network 10.10.10.0/24 area 0
Define the interface 10.10.10.0/24, on which OSPF runs and associate the area ID (0) with the interface.
R1(config-router)#network 1.1.1.1/32 area 0
Define the interface 1.1.1.1/32, on which OSPF runs and associate the area ID (0) with the interface.
R1(config-router)#commit
Commit the transaction.
R2 - NSM
 
R2#configure terminal
Enter configure mode.
R2(config)#interface lo
Specify the loopback (lo) interface to be configured.
R2(config-if)#ip address 2.2.2.2/32 secondary
Set the IP address of the loopback interface to 2.2.2.2/32.
R2(config-if)#exit
Exit interface mode.
R2(config)#interface xe1
Specify the interface xe1 to be configured.
R2(config-if)#ip address 20.20.20.1/24
Assign IP address 20.20.20.1/24 to interface.
R2(config-if)#label-switching
Enable label switching on interface xe1.
R2(config-if)#exit
Exit interface mode.
R2(config)#interface xe2
Specify the interface xe2 to be configured.
R2(config-if)#ip address 10.10.10.2/24
Assign IP address 10.10.10.2/24 to interface.
R2(config-if)#label-switching
Enable label switching on interface xe2.
R2(config-if)#commit
Commit the transaction.
R2 - LDP
 
R2(config)#router ldp
Enter Router mode.
R2(config-router)#router-id 2.2.2.2
Set the router ID to IP address 2.2.2.2.
R2(config-router)#transport-address ipv4 2.2.2.2
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface.
Note: It is preferable to use the loopback address as transport address. In addition, use the parameter ipv6 if you are configuring an IPv6 interface.
R2(config-router)#neighbor all tcp-mss 710
Configure the TCP MSS value with all neighbor.
R2(config-router)#exit
Exit Router mode and return to configure mode.
R2(config)#interface xe1
Specify the interface xe1 to be configured.
R2(config-if)#enable-ldp ipv4
Enable LDP on a specified interface xe1.
R2(config-if)#exit
Exit interface mode.
R2(config)#interface xe2
Specify the interface xe2 to be configured.
R2(config-if)#enable-ldp ipv4
Enable LDP on a specified interface xe2.
R2(config-if)#commit
Commit the transaction.
R2 - OSPF
 
R2(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
R2(config-router)#network 10.10.10.0/24 area 0
Define the interfaces 10.10.10.0/24, on which OSPF runs and associate the area ID (0) with them.
R2(config-router)#network 20.20.20.0/24 area 0
Define the interfaces 20.20.20.0/24, on which OSPF runs and associate the area ID (0) with them.
R2(config-router)#network 2.2.2.2/32 area 0
Define the interfaces 2.2.2.2/32, on which OSPF runs and associate the area ID (0) with them.
R2(config-router)#commit
Commit the transaction.
R3 - NSM
 
R3#configure terminal
Enter configure mode.
R3(config)#interface lo
Specify the loopback interface to be configured.
R3(config-if)#ip address 3.3.3.3/32 secondary
Set the IP address of the loopback interface to 3.3.3.3/32.
R3(config-if)#exit
Exit interface mode.
R3(config)#interface xe1
Specify the interface xe1 to be configured.
R3(config-if)#ip address 20.20.20.2/24
Set the IP address of the interface to 20.20.20.2/24.
R3(config-if)#label-switching
Enable label switching on interface xe1.
R3(config-if)#commit
Commit the transaction.
R3 - LDP
 
R3(config)#router ldp
Enter Router mode.
R3(config-router)#router-id 3.3.3.3
Set the router ID for IP address 3.3.3.3.
R3(config-router)#transport-address ipv4 3.3.3.3
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface.
Note: It is preferable to use the loopback address as transport address. In addition, use the parameter ipv6 if you are configuring an IPv6 interface.
R3(config-router)#neighbor all tcp-mss 720
Configure the TCP MSS value with all neighbor.
R3(config-router)#targeted-peer ipv4 1.1.1.1
Configure targeted peer.
R3(config-router-targeted-peer)#exit
Exit-targeted-peer-mode.
R3(config-router)#exit
Exit the Router mode and return to the Configure mode.
R3(config)#interface xe1
Enter interface mode.
R3(config-if)#enable-ldp ipv4
Enable LDP on xe1.
R3(config-if)#commit
Commit the transaction.
R3 - OSPF
 
R3(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
R3(config-router)#network 20.20.20.0/24 area 0
Define the interfaces 20.20.20.0/24, on which OSPF runs and associate the area ID (0) with them.
R3(config-router)#network 3.3.3.3/32 area 0
Define the interfaces 3.3.3.3/32, on which OSPF runs and associate the area ID (0) with them.
R3(config-router)#commit
Commit the transaction.
Validation
R1
 
R1#show ldp session
Codes: m - MD5 password is not set/unset.
g - GR configuration not set/unset.
t - TCP MSS not set/unset.
Session has to be cleared manually
Code Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.2 xe1 Passive OPERATIONAL 30 00:11:22
3.3.3.3 xe1 Passive OPERATIONAL 30 00:11:22
R1#show ldp session 2.2.2.2
Session state : OPERATIONAL
Session role : Passive
TCP Connection : Established
IP Address for TCP : 2.2.2.2
Interface being used : xe1
Peer LDP ID : 2.2.2.2:0
Preferred Peer LDP Password : Not Set
Adjacencies : 10.10.10.2
Advertisement mode : Downstream Unsolicited
Label retention mode : Liberal
Graceful Restart : Not Capable
Keepalive Timeout : 30
Reconnect Interval : 15
Configured TCP MSS : 700
Applied TCP MSS : 700
Preferred TCP MSS : NA
Address List received : 2.2.2.2
10.10.10.2
20.20.20.1
Received Labels : Fec Label Maps To
IPV4:20.20.20.0/24 impl-null none
IPV4:10.10.10.0/24 impl-null none
IPV4:3.3.3.3/32 25601 none
IPV4:2.2.2.2/32 impl-null none
Sent Labels : Fec Label Maps To
IPV4:10.10.10.0/24 impl-null none
IPV4:1.1.1.1/32 impl-null none
R1#show ldp session 3.3.3.3
Session state : OPERATIONAL
Session role : Passive
TCP Connection : Established
IP Address for TCP : 3.3.3.3
Interface being used : xe1
Peer LDP ID : 3.3.3.3:0
Preferred Peer LDP Password : Not Set
Adjacencies : 3.3.3.3
Advertisement mode : Downstream Unsolicited
Label retention mode : Liberal
Graceful Restart : Not Capable
Keepalive Timeout : 30
Reconnect Interval : 15
Configured TCP MSS : 700
Applied TCP MSS : 700
Preferred TCP MSS : NA
Address List received : 3.3.3.3
20.20.20.2
Received Labels : Fec Label Maps To
Sent Labels : Fec Label Maps To
R2
 
R2#show ldp session
Codes: m - MD5 password is not set/unset.
g - GR configuration not set/unset.
t - TCP MSS not set/unset.
Session has to be cleared manually
Code Peer IP Address IF Name My Role State KeepAlive UpTime
3.3.3.3 xe1 Passive OPERATIONAL 30 00:13:39
1.1.1.1 xe2 Active OPERATIONAL 30 00:13:39
R2#show ldp session 3.3.3.3
Session state : OPERATIONAL
Session role : Passive
TCP Connection : Established
IP Address for TCP : 3.3.3.3
Interface being used : xe1
Peer LDP ID : 3.3.3.3:0
Preferred Peer LDP Password : Not Set
Adjacencies : 20.20.20.2
Advertisement mode : Downstream Unsolicited
Label retention mode : Liberal
Graceful Restart : Not Capable
Keepalive Timeout : 30
Reconnect Interval : 15
Configured TCP MSS : 710
Applied TCP MSS : 710
Preferred TCP MSS : NA
Address List received : 3.3.3.3
20.20.20.2
Received Labels : Fec Label Maps To
IPV4:20.20.20.0/24 impl-null none
IPV4:3.3.3.3/32 impl-null 25601
Sent Labels : Fec Label Maps To
IPV4:20.20.20.0/24 impl-null none
IPV4:10.10.10.0/24 impl-null none
IPV4:2.2.2.2/32 impl-null none
IPV4:1.1.1.1/32 25600 impl-null
R2#show ldp session 1.1.1.1
Session state : OPERATIONAL
Session role : Active
TCP Connection : Established
IP Address for TCP : 1.1.1.1
Interface being used : xe2
Peer LDP ID : 1.1.1.1:0
Preferred Peer LDP Password : Not Set
Adjacencies : 10.10.10.1
Advertisement mode : Downstream Unsolicited
Label retention mode : Liberal
Graceful Restart : Not Capable
Keepalive Timeout : 30
Reconnect Interval : 15
Configured TCP MSS : 710
Applied TCP MSS : 700
Preferred TCP MSS : NA
Address List received : 1.1.1.1
10.10.10.1
Received Labels : Fec Label Maps To
IPV4:48.48.48.48/32 impl-null none
IPV4:10.10.10.0/24 impl-null none
IPV4:1.1.1.1/32 impl-null 25600
Sent Labels : Fec Label Maps To
IPV4:20.20.20.0/24 impl-null none
IPV4:10.10.10.0/24 impl-null none
IPV4:3.3.3.3/32 25601 impl-null
IPV4:2.2.2.2/32 impl-null none
R3
 
R3#show ldp session 2.2.2.2
Session state : OPERATIONAL
Session role : Active
TCP Connection : Established
IP Address for TCP : 2.2.2.2
Interface being used : xe1
Peer LDP ID : 2.2.2.2:0
Preferred Peer LDP Password : Not Set
Adjacencies : 20.20.20.1
Advertisement mode : Downstream Unsolicited
Label retention mode : Liberal
Graceful Restart : Not Capable
Keepalive Timeout : 30
Reconnect Interval : 15
Configured TCP MSS : 720
Applied TCP MSS : 710
Preferred TCP MSS : NA
Address List received : 2.2.2.2
10.10.10.2
20.20.20.1
Received Labels : Fec Label Maps To
IPV4:20.20.20.0/24 impl-null none
IPV4:10.10.10.0/24 impl-null none
IPV4:2.2.2.2/32 impl-null none
IPV4:1.1.1.1/32 25600 none
Sent Labels : Fec Label Maps To
IPV4:20.20.20.0/24 impl-null none
IPV4:3.3.3.3/32 impl-null none
R3#show ldp session 1.1.1.1
Session state : OPERATIONAL
Session role : Active
TCP Connection : Established
IP Address for TCP : 1.1.1.1
Interface being used : xe1
Peer LDP ID : 1.1.1.1:0
Preferred Peer LDP Password : Not Set
Adjacencies : 1.1.1.1
Advertisement mode : Downstream Unsolicited
Label retention mode : Liberal
Graceful Restart : Not Capable
Keepalive Timeout : 30
Reconnect Interval : 15
Configured TCP MSS : 720
Applied TCP MSS : 700
Preferred TCP MSS : NA
Address List received : 1.1.1.1
10.10.10.1
Received Labels : Fec Label Maps To
Sent Labels : Fec Label Maps To
Configuration of TCP MSS with Auto-targeted
R1 - NSM
 
R1#configure terminal
Enter configure mode.
R1(config)#interface xe1
Specify the interface xe1 to be configured.
R1(config-if)#ip address 10.10.10.1/24
Assign IP address 10.10.10.1/24 to interface.
R1(config-if)#label-switching
Enable label switching on interface xe1.
R1(config-if)#exit
Exit interface mode.
R1(config)#interface lo
Specify the loopback interface to be configured.
R1(config-if)#ip address 1.1.1.1/32 secondary
Set the IP address of the loopback interface to 1.1.1.1/32.
R1(config-if)#commit
Commit the transaction.
R1 - LDP
 
R1(config)#router ldp
Enter Router mode for LDP.
R1(config-router)#router-id 1.1.1.1
Set the router ID to IP address 1.1.1.1.
R1(config-router)#transport-address ipv4 1.1.1.1
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface.
Note: It is preferable to use the loopback address as transport address. In addition, use the parameter ipv6 if you are configuring an IPv6 interface.
R1(config-router)#targeted-peer ipv4 3.3.3.3
Configure targeted peer.
R1(config-router-targeted-peer)#exit
Exit-targeted-peer-mode.
R1(config-router)#exit
Exit the Router mode and return to the configure mode.
R1(config)#interface xe1
Enter interface mode.
R1(config-if)#enable-ldp ipv4
Enable LDP on xe1.
R1(config-if)#commit
Commit the transaction.
R1 - OSPF
 
R1(config)#router ospf 100
Configure the routing process and specify the process ID (100). The process ID should be a unique positive integer identifying the routing process.
R1(config-router)#network 10.10.10.0/24 area 0
Define the interface 10.10.10.0/24, on which OSPF runs and associate the area ID (0) with the interface.
R1(config-router)#network 1.1.1.1/32 area 0
Define the interface 1.1.1.1/32, on which OSPF runs and associate the area ID (0) with the interface.
R1(config-router)#commit
Commit the transaction.
R2 - NSM
 
R2#configure terminal
Enter configure mode.
R2(config)#interface lo
Specify the loopback interface to be configured.
R2(config-if)#ip address 2.2.2.2/32 secondary
Set the IP address of the loopback interface to 2.2.2.2/32.
R2(config-if)#exit
Exit interface mode.
R2(config)#interface xe1
Specify the interface xe1 to be configured.
R2(config-if)#ip address 20.20.20.1/24
Assign IP address 20.20.20.1/24 to interface.
R2(config-if)#label-switching
Enable label switching on interface xe1.
R2(config-if)#exit
Exit interface mode.
R2(config)#interface xe2
Specify the interface xe2 to be configured.
R2(config-if)#ip address 10.10.10.2/24
Assign IP address 10.10.10.2/24 to interface.
R2(config-if)#label-switching
Enable label switching on interface xe2.
R2(config-if)#commit
Commit the transaction.
R2 - LDP
 
R2(config)#router ldp
Enter Router mode.
R2(config-router)#router-id 2.2.2.2
Set the router ID to IP address 2.2.2.2.
R2(config-router)#transport-address ipv4 2.2.2.2
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface.
Note: It is preferable to use the loopback address as transport address. In addition, use the parameter ipv6 if you are configuring an IPv6 interface.
R2(config-router)#neighbor auto-targeted tcp-mss 800
Configure the TCP MSS value on all auto-targeted neighbors.
R2(config-router)#exit
Exit Router mode and return to configure mode.
R2(config)#interface xe1
Specify the interface xe1 to be configured.
R2(config-if)#enable-ldp ipv4
Enable LDP on a specified interface xe1.
R2(config-if)#exit
Exit interface mode.
R2(config)#interface xe2
Specify the interface xe2 to be configured.
R2(config-if)#enable-ldp ipv4
Enable LDP on a specified interface xe2.
R2(config-if)#commit
Commit the transaction.
R2 - OSPF
 
R2(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
R2(config-router)#network 10.10.10.0/24 area 0
Define the interfaces 10.10.10.0/24, on which OSPF runs and associate the area ID (0) with them.
R2(config-router)#network 20.20.20.0/24 area 0
Define the interfaces 20.20.20.0/24, on which OSPF runs and associate the area ID (0) with them.
R2(config-router)#network 2.2.2.2/32 area 0
Define the interfaces 2.2.2.2/32, on which OSPF runs and associate the area ID (0) with them.
R2(config-router)#commit
Commit the transaction.
R3 - NSM
 
R3#configure terminal
Enter configure mode.
R3(config)#interface lo
Specify the loopback interface to be configured.
R3(config-if)#ip address 3.3.3.3/32 secondary
Set the IP address of the loopback interface to 3.3.3.3/32.
R3(config-if)#exit
Exit interface mode.
R3(config)#interface xe1
Specify the interface xe1 to be configured.
R3(config-if)#ip address 20.20.20.2/24
Set the IP address of the interface to 20.20.20.2/24.
R3(config-if)#label-switching
Enable label switching on interface xe1.
R3(config-if)#commit
Commit the transaction.
R3 - LDP
 
R3(config)#router ldp
Enter Router mode.
R3(config-router)#router-id 3.3.3.3
Set the router ID for IP address 3.3.3.3.
R3(config-router)#transport-address ipv4 3.3.3.3
Configure the transport address to be used for a TCP session over which LDP will run on an IPv4 interface.
Note: It is preferable to use the loopback address as transport address. In addition, use the parameter ipv6 if you are configuring an IPv6 interface.
R3(config-router)#neighbor auto-targeted tcp-mss 810
Configure the TCP MSS value on all auto-targeted neighbors.
R3(config-router)#targeted-peer ipv4 1.1.1.1
Configure targeted peer.
R3(config-router-targeted-peer)#exit
Exit-targeted-peer-mode.
R3(config-router)#exit
Exit the Router mode and return to the configure mode.
R3(config)#interface xe1
Enter interface mode xe1.
R3(config-if)#enable-ldp ipv4
Enable LDP on xe1.
R3(config-if)#commit
Commit the transaction.
R3 - OSPF
 
R3(config)#router ospf 100
Configure the routing process and specify the Process ID (100). The Process ID should be a unique positive integer identifying the routing process.
R3(config-router)#network 20.20.20.0/24 area 0
Define the interfaces 20.20.20.0/24, on which OSPF runs and associate the area ID (0) with them.
R3(config-router)#network 3.3.3.3/32 area 0
Define the interfaces 3.3.3.3/32, on which OSPF runs and associate the area ID (0) with them.
R3(config-router)#commit
Commit the transaction.
Validation
R1
 
R1#show ldp session
Codes: m - MD5 password is not set/unset.
g - GR configuration not set/unset.
t - TCP MSS not set/unset.
Session has to be cleared manually
Code Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.2 xe1 Passive OPERATIONAL 30 00:00:03
3.3.3.3 xe1 Passive OPERATIONAL 30 00:00:03
R1#show ldp targeted-peers
IP Address Interface
3.3.3.3 xe1
R1#show ldp session 3.3.3.3
Session state : OPERATIONAL
Session role : Passive
TCP Connection : Established
IP Address for TCP : 3.3.3.3
Interface being used : xe1
Peer LDP ID : 3.3.3.3:0
Preferred Peer LDP Password : Not Set
Adjacencies : 3.3.3.3
Advertisement mode : Downstream Unsolicited
Label retention mode : Liberal
Graceful Restart : Not Capable
Keepalive Timeout : 30
Reconnect Interval : 15
Configured TCP MSS : Not configured
Applied TCP MSS : 810
Preferred TCP MSS : NA
Address List received : 3.3.3.3
20.20.20.2
Received Labels : Fec Label Maps To
IPV4:20.20.20.0/24 25604 none
IPV4:3.3.3.3/32 25603 none
IPV4:10.10.10.0/24 25602 none
IPV4:2.2.2.2/32 25601 none
IPV4:1.1.1.1/32 25600 none
Sent Labels : Fec Label Maps To
IPV4:10.10.10.0/24 25604 none
IPV4:1.1.1.1/32 25603 none
IPV4:20.20.20.0/24 25602 impl-null
IPV4:3.3.3.3/32 25601 25601
IPV4:2.2.2.2/32 25600 impl-null
R2
 
R2#show ldp session
Codes: m - MD5 password is not set/unset.
g - GR configuration not set/unset.
t - TCP MSS not set/unset.
Session has to be cleared manually
Code Peer IP Address IF Name My Role State KeepAlive UpTime
3.3.3.3 xe1 Passive OPERATIONAL 30 00:00:04
1.1.1.1 xe2 Active OPERATIONAL 30 00:00:04
R2#show ldp targeted-peers
R2#show ldp session 3.3.3.3
Session state : OPERATIONAL
Session role : Passive
TCP Connection : Established
IP Address for TCP : 3.3.3.3
Interface being used : xe1
Peer LDP ID : 3.3.3.3:0
Preferred Peer LDP Password : Not Set
Adjacencies : 20.20.20.2
Advertisement mode : Downstream Unsolicited
Label retention mode : Liberal
Graceful Restart : Not Capable
Keepalive Timeout : 30
Reconnect Interval : 15
Configured TCP MSS : Not configured
Applied TCP MSS : 1460
Preferred TCP MSS : NA
Address List received : 3.3.3.3
20.20.20.2
Received Labels : Fec Label Maps To
IPV4:20.20.20.0/24 impl-null none
IPV4:3.3.3.3/32 impl-null 25601
Sent Labels : Fec Label Maps To
IPV4:20.20.20.0/24 impl-null none
IPV4:10.10.10.0/24 impl-null none
IPV4:2.2.2.2/32 impl-null none
IPV4:1.1.1.1/32 25600 impl-null
R3
 
R3#show ldp session
Codes: m - MD5 password is not set/unset.
g - GR configuration not set/unset.
t - TCP MSS not set/unset.
Session has to be cleared manually
Code Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.2 xe1 Active OPERATIONAL 30 00:02:15
1.1.1.1 xe1 Active OPERATIONAL 30 00:02:15
R3#show ldp targeted-peers
IP Address Interface
1.1.1.1 xe1
PE2#show ldp session 1.1.1.1
Session state : OPERATIONAL
Session role : Active
TCP Connection : Established
IP Address for TCP : 1.1.1.1
Interface being used : xe1
Peer LDP ID : 1.1.1.1:0
Preferred Peer LDP Password : Not Set
Adjacencies : 1.1.1.1
Advertisement mode : Downstream Unsolicited
Label retention mode : Liberal
Graceful Restart : Not Capable
Keepalive Timeout : 30
Reconnect Interval : 15
Configured TCP MSS : 810
Applied TCP MSS : 810
Preferred TCP MSS : NA
Address List received : 1.1.1.1
10.10.10.1
Received Labels : Fec Label Maps To
IPV4:10.10.10.0/24 25604 none
IPV4:1.1.1.1/32 25603 none
IPV4:20.20.20.0/24 25602 none
IPV4:3.3.3.3/32 25601 none
IPV4:2.2.2.2/32 25600 none
Sent Labels : Fec Label Maps To
IPV4:20.20.20.0/24 25604 none
IPV4:3.3.3.3/32 25603 none
IPV4:10.10.10.0/24 25602 impl-null
IPV4:2.2.2.2/32 25601 impl-null
IPV4:1.1.1.1/32 25600 25600
New CLI Command
neighbor tcp-mss
Use this command to set the TCP MSS for an LDP session. MSS is a TCP parameter that defines the maximum amount of data in a TCP segment that can be transmitted.
Use the no command to remove the TCP MSS from an LDP session.
Command Syntax
neighbor (A.B.C.D| auto-targeted | all) tcp-mss <560-1440>
no neighbor (A.B.C.D | auto-targeted | all) tcp-mss
Parameters
A.B.C.D
To set MSS for the specific peer.
auto-targeted
To set MSS for auto-targeted LDP peer. Auto-targeted LDP sessions automatically establish the TCP connection with neighboring routers and do not require the manual configuration of each peer.
all
To set MSS for all LDP peers
<560-1440>
Configure the TCP MSS between this range.
Default
By default, neighbor tcp-mss is disabled and the MSS value is 1460 bytes.
Command Mode
Router LDP mode.
Applicability
This command was introduced in OcNOS version 6.4.1.
Examples
OcNOS(config)#router ldp
OcNOS(config-router)#neighbor 2.2.2.2 tcp-mss 900
OcNOS(config-router)#neighbor all tcp-mss 1000
OcNOS(config-router)#neighbor auto-targeted tcp-mss 800
OcNOS(config-router)#commit
Abbreviations
The following are some key abbreviations and their meanings relevant to this document:
 
Acronym
Description
ACK
Acknowledgment
IGP
Interior Gateway Protocol
LDP
Label Distribution Protocol
MSS
Maximum Segment Size
MTU
Maximum Transmission Unit
OSPF
Open Short Path First
SYN
Synchronize
TCP
Transmission Control Protocol
Glossary
The following provides definitions for key terms used throughout this document:
 
LDP
LDP is a routing protocol that manages and distributes the labels to the route in a Multiprotocol Label Switching (MPLS) network. Adding a label to a route helps to control the flow of network traffic and increases the forwarding speed, ensuring a smooth and optimized data transmission.
LDP session
LDP session is the connection established between LDP routers in an MPLS network.
MSS
MSS is a TCP parameter that defines the maximum amount of data in a TCP segment that can be transmitted.
TCP
TCP is one of the main protocols in the Internet Protocol (IP) suite. It offers a secure and reliable connection between two devices.
TCP segment
TCP segment is a unit of data transmitted in a TCP connection. The segment consists of header and payload. The header contains the control information to manage the transmission, and the payload contains the actual data that needs to be transmitted.