OcNOS-SP : Quality of Service Guide : Quality of Service Configuration Guide : Hierarchical Traffic Policing
Hierarchical Traffic Policing
Basic traffic policing is explained in Chapter 3, Traffic Policing, which covers single-level policing. The Qumran device support two level hierarchical policing in addition to single level traffic policing (Hierarchical policing is also in compliance with RFC 2697 and RFC 4115).
Hierarchical policing ensures traffic policing in two levels in serial mode. Traffic is policed with a “child policer” configuration first, and then policed at a second level, the “parent policer” configuration. Thus, traffic is treated with two levels of policing.
Hierarchical policing will be useful when traffic to be policed per service and additionally to be policed per customers of that particular service. Hierarchical policing is useful when multiple streams (such as voice, data) of customer traffic to be policed and additionally, traffic to be policed per customer. Configuration considerations for hierarchical policing are same as mentioned in Chapter 3, Traffic Policing.
Configuring Hierarchical Traffic Policing
Command to configure policing on a class remains same as explained in Chapter 3, Traffic Policing.
In addition to the commands explained in Chapter 1, Quality of Service and Chapter 2, Configuring a QoS Policy-map, binding a child policy-map to a parent class is done using the following command:
service-policy NAME
Notice that NAME represents the name of the child qos policy-map. This command is configurable on the class mode as shown in the example below:
(config)#policy-map Pmap-Parent-1
(config-pmap-qos)#class Cmap-Parent-1
(config-pmap-c-qos)#service-policy Pmap-Child-1
(config-pmap-c-qos)#exit
An example of creating parent and child class-maps and policy-maps, and configuring them for hierarchical policing is shown below:
Note: the qos-policer TCAM group must be enabled before binding a parent policy-map to an interface. For more information about the hardware filter groups, see the hardware-profile filter and show hardware-profile filters commands in the System Management Guide.
In the following example, traffic streams on VLAN ID 10, where one stream with CoS value 1 and another stream with CoS value 2 (received on interface xe1) are policed to a total of 40 mbps with 10 mbps of traffic being marked green for stream1 at 20 mbps, and traffic marked green for stream2. The remaining 10 mbps of traffic from stream1 and stream2 is marked yellow. Any remaining traffic will be dropped at ingress.
(config)#qos enable
(config)#class-map CUST-10
(config-cmap-qos)#match vlan 10
(config-cmap-qos)#exit
(config)#class-map CUST-10-C1
(config-cmap-qos)#match cos 1
(config-cmap-qos)#exit
(config)#class-map CUST-10-C2
(config-cmap-qos)#match cos 2
(config-cmap-qos)#exit
(config)#policy-map PC-CUST-10
(config-pmap-qos)#class CUST-10-C1
(config-pmap-c-qos)#police cir 10 mbps eir 30 mbps
(config-pmap-c-qos)#exit
(config-pmap-qos)#class CUST-10-C2
(config-pmap-c-qos)#police cir 20 mbps eir 20 mbps
(config-pmap-c-qos)#exit
(config-pmap-qos)#class class-default
(config-pmap-c-qos)#police cir 10 mbps eir 30 mbps
(config-pmap-c-qos)#exit
(config-pmap-qos)#exit
(config)#policy-map P-CUST-10
(config-pmap-qos)#class CUST-10
(config-pmap-c-qos)#police cir 40 mbps
(config-pmap-c-qos)#service-policy PC-CUST-10
(config-pmap-c-qos)#exit
(config-pmap-qos)#exit
(config)#hardware-profile filter qos-policer enable
(config)#interface xe1
(config-if)#service-policy type qos input P-CUST-10
(config-if)#exit
Configuring Hierarchical Policing per Attachment Circuit
In this section, a configuration example is provided for the use-case of configuring traffic policing per attachment circuit with additional traffic policing based on the class of traffic. The configuration helps in providing overall traffic policing per attachment circuit and additionally ensures that different classes of traffic are policed. Total CIR configurations for child classes must be ensured to match the police rate of parent and EIR values for child can be configured to take the available bandwidth when one or more child traffic is not received at any point in time.
Topology
Topology for per-AC hierarchical policing
PE1
 
PE1#configure terminal
Enter configure terminal mode
PE1(config)#hardware-profile filter ingress-ipv6 enable
Enabling Ingress IPv6 group for IPv6 feature support
PE1(config)#hardware-profile filter qos-policer enable
Enabling Ingress extended QOS group for hierarchical policer
PE1(config)#qos enable
Enabling QoS
PE1(config)#qos statistics
Enabling Qos statistics
PE1(config)#mpls l2-circuit VPWS-VLAN-200 2000200 21.21.21.21 agi abc saii xyz taii mmm
Create an instance of an MPLS layer 2 virtual circuit
(config-pseudowire)#exit
Exit pseudowire config mode.
PE1(config)#mpls l2-circuit VPWS-VLAN-300 2000300 21.21.21.21
Create an instance of an MPLS layer 2 virtual circuit
(config-pseudowire)#exit
Exit pseudowire config mode.
PE1(config)#mpls lsp-model uniform
Configure the MPLS LSP model as Uniform.
PE1(config)#service-template VPWS-Vlan200-Service
Enabling Service Template
PE1(config-svc)#match outer-vlan 200
Match outer vlan 200
PE1(config-svc)#rewrite ingress translate 100 outgoing-tpid dot1.q
Enabling command to configure a match VLAN action for a service template
PE1(config-svc)#exit
Exit mode
PE1(config)#service-template VPWS-Vlan300-Service
Enabling Service Template
PE1(config-svc)#match outer-vlan 300
Match outer vlan 300<null>
PE1(config-svc)#rewrite ingress translate 4000 outgoing-tpid dot1.q
Enabling command to configure a match VLAN action for a service template
PE1(config-svc)#exit
Exit mode
PE1(config)#class-map c0
Enter Class-map mode
PE1(config-cmap-qos)#match cos 0
Matching cos value inside class map
PE1(config-cmap-qos)#exit
Exit mode
PE1(config)#class-map c1
Enter Class-map mode
PE1(config-cmap-qos)#match cos 1
Matching cos value inside class map
PE1(config-cmap-qos)#exit
Exit mode
PE1(config)#class-map c2
Enter Class-map mode
PE1(config-cmap-qos)#match cos 2
Matching cos value inside class map
PE1(config-cmap-qos)# exit
Exit mode
PE1(config)#class-map c3
Enter Class-map mode
PE1(config-cmap-qos)#match cos 3
Matching cos value inside class map
PE1(config)#class-map cp1
Enter Class-map mode
PE1(config-cmap-qos)#match vlan 200
Matching vlan inside class map
PE1(config-cmap-qos)#exit
Exit mode
PE1(config)#class-map cp2
Enter Class-map mode
PE1(config-cmap-qos)#match vlan 300
Matching vlan inside class map
PE1(config-cmap-qos)#exit
Exit mode
PE1(config)#policy-map child
Enter policy-map mode
PE1(config-pmap-qos)#class c0
Assign Class c0 to Policy-map child
PE1(config-pmap-c-qos)#police cir 50 mbps eir 150 mbps
Police packets @ Committed information rate 50 mbps
PE1(config-pmap-c-qos)#exit
Exit mode
PE1(config-pmap-qos)#class c1
Assign Class c1 to Policy-map child
PE1(config-pmap-c-qos)#police cir 50 mbps eir 150 mbps
Police packets @ Committed information rate 50 mbps
PE1(config-pmap-c-qos)#exit
Exit mode
PE1(config-pmap-qos)#class c2
Assign Class c2 to Policy-map child
PE1(config-pmap-c-qos)#police cir 50 mbps eir 150 mbps
Police packets @ Committed information rate 50 mbps
PE1(config-pmap-c-qos)#exit
Exit mode
PE1(config-pmap-qos)#class c3
Assign Class c3 to Policy-map child
PE1(config-pmap-c-qos)#police cir 50 mbps eir 150 mbps
Police packets @ Committed information rate 50 mbps
PE1(config-pmap-c-qos)#exit
Exit mode
PE1(config-pmap-qos)#policy-map parent
Enter policy-map mode
PE1(config-pmap-qos)#class cp1
Assign Class cp1 to Policy-map parent
PE1(config-pmap-c-qos)#police cir 200 mbps
Police packets @ Committed information rate 200 mbps
PE1(config-pmap-c-qos)#service-policy child
Attaching child policy to Parent
PE1(config-pmap-c-qos)#exit
Exit mode
PE1(config-pmap-qos)#class cp2
Assign Class cp2 to Policy-map child
PE1(config-pmap-c-qos)#police cir 200 mbps
Police packets @ Committed information rate 200 mbps
PE1(config-pmap-c-qos)#service-policy child
Attaching child policy to Parent
PE1(config-pmap-c-qos)#exit
Exit mode
PE1(config-pmap-qos)#exit
Exit from Policy Map
PE1(config)#router ldp
Enter the Router LDP mode.
PE1(config-router)#targeted-peer ipv4 21.21.21.21
Configure targeted peer
PE1(config-router-targeted-peer)#<null>exit-targeted-peer-mode
Exit Targeted Peer Mode
PE1(config-router)#transport-address ipv4 11.11.11.11
Configure transport address
PE1(config-router)#exit
Exit mode
PE1(config)#interface ce45
Entering Interface Mode
PE1(config-if)#ip address 1.1.1.1/24
Assigning IP Address to interface
PE1(config-if)#label-switching
Enabling Label Switching on the interface.
PE1(config-if)#enable-ldp ipv4
Enabling LDP
PE1(config-if)#exit
Exit mode
PE1(config)#interface lo
Entering loopback Interface Mode
PE1(config-if)#ip address 11.11.11.11/32 secondary
Assigning IP Address to interface
PE1(config-if)#exit
Exit mode
PE1(config)#interface xe2
Entering Interface Mode
PE1(config-if)#switchport
Enabling the Interface as Switchport
PE1(config-if)#mpls-l2-circuit VPWS-VLAN-200 service-template VPWS-Vlan200-Service
Bind the interface to the VC and add the service-template.
PE1(config-if)#mpls-l2-circuit VPWS-VLAN-300 service-template VPWS-Vlan300-Service
Bind the interface to the VC and add the service-template.
PE1(config-if)#service-policy type qos input parent
Assign service-policy to interface on in-direction
PE1(config-if)#exit
Exit mode
PE1(config)#router ospf
Configure the routing process and The Process ID should be a unique positive integer identifying the routing process
PE1(config-router)#network 1.1.1.0/24 area 0.0.0.0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
PE1(config-router)#network 11.11.11.11/32 area 0.0.0.0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
PE1(config-router)#exit
Exit Router Ospf MOde
PE2 Configuration
 
PE2#configure terminal
Enter configure terminal mode
PE2(config)#hardware-profile filter ingress-ipv6 enable
Enabling Ingress IPv6 group for IPv6 feature
PE2(config)#hardware-profile filter qos-policer enable
Enabling Ingress extended QOS group for hierarchical policer
PE2(config)#qos enable
Enabling QoS
PE2(config)#qos statistics
Enabling Qos statistics
PE2(config)#mpls l2-circuit VPWS-VLAN-200 2000200 11.11.11.11 agi abc saii xyz taii mmm
Create an instance of an MPLS layer 2 virtual circuit
(config-pseudowire)#exit
Exit pseudowire config mode.
PE2(config)#mpls l2-circuit VPWS-VLAN-300 2000300 11.11.11.11
Create an instance of an MPLS layer 2 virtual circuit
(config-pseudowire)#exit
Exit pseudowire config mode.
PE2(config)#mpls lsp-model uniform
Configure the MPLS LSP model as Uniform.
PE2(config)#service-template VPWS-Vlan200-Service
Enabling Service Template
PE2(config-svc)#match outer-vlan 200
Match outer vlan 200
PE2(config-svc)#rewrite ingress translate 100 outgoing-tpid dot1.q
Enabling command to configure a match VLAN action for a service template
PE2(config-svc)#exit
Exit mode
PE2(config)#service-template VPWS-Vlan300-Service
Enabling Service Template
PE2(config-svc)#match outer-vlan 300
Match outer vlan 300
PE2(config-svc)#rewrite ingress translate 4000 outgoing-tpid dot1.q
Enabling command to configure a match VLAN action for a service template
PE2(config-svc)#exit
Exit mode
PE2(config)#class-map c0
Enter Class-map mode
PE2(config-cmap-qos)# match cos 0
Matching cos value inside class map
PE2(config-cmap-qos)#exit
Exit mode
PE2(config)#class-map c1
Enter Class-map mode
PE2(config-cmap-qos)#match cos 1
Matching cos value inside class map
PE2(config-cmap-qos)#exit
Exit mode
PE2(config)#class-map c2
Enter Class-map mode
PE2(config-cmap-qos)#match cos 2
Matching cos value inside class map
PE2(config-cmap-qos)#exit
Exit mode
PE2(config)#class-map c3
Enter Class-map mode
PE2(config-cmap-qos)#match cos 3
Matching cos value inside class map
PE2(config-cmap-qos)#exit
Exit mode
PE2(config)#class-map cp1
Enter Class-map mode
PE2(config-cmap-qos)#match vlan 200
Matching vlan inside class map
PE2(config-cmap-qos)#exit
Exit mode
PE2(config)#class-map cp2
Enter Class-map mode
PE2(config-cmap-qos)#match vlan 300
Matching vlan inside class map
PE2(config-cmap-qos)#exit
Exit mode
PE2(config)#policy-map child
Enter policy-map mode
PE2(config-pmap-qos)#class c0
Assign Class c0 to Policy-map child
PE2(config-pmap-c-qos)#police cir 50 mbps eir 150 mbps
Police packets @ Committed information rate 50 mbps
PE2(config-pmap-c-qos)#exit
Exit mode
PE2(config-pmap-qos)#class c1
Assign Class c1 to Policy-map child
PE2(config-pmap-c-qos)#police cir 50 mbps eir 150 mbps
Police packets @ Committed information rate 50 mbps
PE2(config-pmap-c-qos)#exit
Exit mode
PE2(config-pmap-qos)#class c2
Assign Class c2 to Policy-map child
PE2(config-pmap-c-qos)#police cir 50 mbps eir 150 mbps
Police packets @ Committed information rate 50 mbps
PE2(config-pmap-c-qos)#exit
Exit mode
PE2(config-pmap-qos)#class c3
Assign Class c3 to Policy-map child
PE2(config-pmap-c-qos)#police cir 50 mbps eir 150 mbps
Police packets @ Committed information rate 50 mbps
PE2(config-pmap-c-qos)#exit
Exit mode
PE2(config-pmap-qos)#policy-map parent
Enter policy-map mode
PE2(config-pmap-qos)#class cp1
Assign Class cp1 to Policy-map parent
PE2(config-pmap-c-qos)#police cir 200 mbps
Police packets @ Committed information rate 200 mbps
PE2(config-pmap-c-qos)#service-policy child
Attaching child policy to Parent
PE2(config-pmap-c-qos)#exit
Exit mode
PE2(config-pmap-qos)#class cp2
Assign Class cp2 to Policy-map child
PE2(config-pmap-c-qos)#police cir 200 mbps
Police packets @ Committed information rate 200 mbps
PE2(config-pmap-c-qos)#service-policy child
Attaching child policy to Parent
PE2(config-pmap-c-qos)#exit
Exit mode
PE2(config-pmap-qos)#exit
Exit from Policy Map
PE2(config)#router ldp
Enter the Router LDP mode
PE2(config-router)#targeted-peer ipv4 11.11.11.11
Configure targeted peer
PE2(config-router-targeted-peer)#exit-targeted-peer-mode
Exit Targeted Peer Mode
PE2(config-router)# transport-address ipv4 21.21.21.21
Configure transport address
PE2(config-router)#exit
Exit mode
PE2(config)#interface ce45
Entering Interface Mode
PE2(config-if)#ip address 1.1.1.2/24
Assigning IP Address to interface
PE2(config-if)#label-switching
Enabling Label Switching on the interface.
PE2(config-if)#enable-ldp ipv4
Enabling LDP
PE2(config-if)#exit
Exit mode
PE2(config)#interface lo
Entering loopback Interface Mode
PE2(config-if)#ip address 21.21.21.21/32 secondary
Assigning IP Address to interface
PE2(config-if)#exit
Exit interface mode
PE2(config)#interface xe1
Entering Interface Mode
PE2(config-if)#switchport
Enabling the Interface as Switch port
PE2(config-if)#mpls-l2-circuit VPWS-VLAN-200 service-template VPWS-Vlan200-Service
Bind the interface to the VC and add the service-template.
PE2(config-if)#mpls-l2-circuit VPWS-VLAN-300 service-template VPWS-Vlan300-Service
Bind the interface to the VC and add the service-template.
PE2(config-if)#service-policy type qos input parent
Assign service-policy to interface on in-direction
PE2(config-if)#exit
Exit interface mode
PE2(config)#router ospf
Configure the routing process and The Process ID should be a unique positive integer identifying the routing process
PE2(config-router)#network 1.1.1.0/24 area 0.0.0.0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
PE2(config-router)#network 21.21.21.21/32 area 0.0.0.0
Define the interface on which OSPF runs and associate the area ID (0) with the interface.
PE2(config-router)#exit
Exit Router OSPF mode
Validation
PE1
Validate LDP session using following show command:
PE1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
21.21.21.21 ce45 Passive OPERATIONAL 30 00:05:40
 
Validate virtual circuit status using following command:
PE1#show mpls vc-table
VC-ID VID Inner-VID Ac-Intf Nw-Intf Out Label Tunnel-Label Nexthop Status
2000200 N/A N/A xe2 ce45 24320 3 21.21.21.21 Active
2000300 N/A N/A xe2 ce45 24321 3 21.21.21.21 Active
 
 
Validate QoS configuration and statistics using below commands:
PE1#show policy-map interface xe2
 
Interface xe2
Type QoS statistics status : enabled
 
Service-policy (qos) input: parent
----------------------------
Class-map (qos): cp1 (match all)
match vlan 200
police cir 200 mbps
shape 0 kbps (inherited)
 
Child Service-policy (qos) : child
----------------------------
Class-map (qos): c0 (match all)
match cos 0
police cir 50 mbps eir 150 mbps
matched : 168530 packets, 252795000 bytes
transmitted : 85295 packets, 127942500 bytes
dropped : 83235 packets, 124852500 bytes
 
Class-map (qos): c1 (match all)
match cos 1
police cir 50 mbps eir 150 mbps
matched : 168523 packets, 252784500 bytes
transmitted : 85286 packets, 127929000 bytes
dropped : 83237 packets, 124855500 bytes
 
Class-map (qos): c2 (match all)
match cos 2
police cir 50 mbps eir 150 mbps
matched : 168558 packets, 252837000 bytes
transmitted : 85320 packets, 127980000 bytes
dropped : 83238 packets, 124857000 bytes
 
Class-map (qos): c3 (match all)
match cos 3
police cir 50 mbps eir 150 mbps
matched : 168550 packets, 252825000 bytes
transmitted : 85310 packets, 127965000 bytes
dropped : 83240 packets, 124860000 bytes
 
Class-map (qos): class-default (match any)
 
Class-map (qos): cp2 (match all)
match vlan 300
police cir 200 mbps
shape 0 kbps (inherited)
 
Child Service-policy (qos) : child
----------------------------
Class-map (qos): c0 (match all)
match cos 0
police cir 50 mbps eir 150 mbps
matched : 168597 packets, 252895500 bytes
transmitted : 85336 packets, 128004000 bytes
dropped : 83261 packets, 124891500 bytes
 
Class-map (qos): c1 (match all)
match cos 1
police cir 50 mbps eir 150 mbps
matched : 168589 packets, 252883500 bytes
transmitted : 85327 packets, 127990500 bytes
dropped : 83262 packets, 124893000 bytes
 
Class-map (qos): c2 (match all)
match cos 2
police cir 50 mbps eir 150 mbps
matched : 168625 packets, 252937500 bytes
transmitted : 85358 packets, 128037000 bytes
dropped : 83267 packets, 124900500 bytes
 
Class-map (qos): c3 (match all)
match cos 3
police cir 50 mbps eir 150 mbps
 
Class-map (qos): class-default (match any)
matched : 168589 packets, 252883500 bytes
transmitted : 85333 packets, 127999500 bytes
dropped : 83256 packets, 124884000 bytes
 
Service-policy (queuing) output: default-out-policy
Interface Bandwidth 1000000 kbps
-----------------------------------
Class-map (queuing): q0
shape 1000000 kbps (inherited)
priority level 0
queue-limit 1048576 bytes/8 ms (default)
 
Class-map (queuing): q1
shape 1000000 kbps (inherited)
priority level 1
queue-limit 1048576 bytes/8 ms (default)
 
Class-map (queuing): q2
shape 1000000 kbps (inherited)
priority level 2
queue-limit 1048576 bytes/8 ms (default)
 
Class-map (queuing): q3
shape 1000000 kbps (inherited)
priority level 3
queue-limit 1048576 bytes/8 ms (default)
 
Class-map (queuing): q4
shape 1000000 kbps (inherited)
priority level 4
queue-limit 1048576 bytes/8 ms (default)
 
Class-map (queuing): q5
shape 1000000 kbps (inherited)
priority level 5
queue-limit 1048576 bytes/8 ms (default)
 
Class-map (queuing): q6
shape 1000000 kbps (inherited)
priority level 6
queue-limit 1048576 bytes/8 ms (default)
 
Class-map (queuing): q7
shape 1000000 kbps (inherited)
priority level 7
queue-limit 1048576 bytes/8 ms (default)
 
 
PE1#show policy-map statistics
Type qos class-map statistics:
+---------------+----------------+----------------+----------------+------------------+
| Class-map | Match pkts | Match bytes | Dropped pkts | Dropped Bytes |
+---------------+----------------+----------------+----------------+------------------+
xe2
cp1
c0 231860 347790000 114528 171792000
c1 231854 347781000 114531 171796500
c2 231891 347836500 114533 171799500
c3 231884 347826000 114534 171801000
cp2
c0 231933 347899500 114557 171835500
c1 231926 347889000 114558 171837000
c2 231963 347944500 114563 171844500
class-default 231930 347895000 114555 171832500
 
Type queuing class-map statistics:
+---------------+----------------+----------------+----------------+------------------+
| Class-map | Total pkts | Total bytes | Dropped pkts | Dropped Bytes |
+---------------+----------------+----------------+----------------+------------------+
ce45
q0 5595949 8393932500 229131 343705500
q1 5596049 8394085500 229228 343851000
q2 5596147 8394232500 229327 343999500
q3 2798111 4197172500 114702 172057500
q4 2798195 4197300000 114762 172147500
q6 23 1886 0 0
q7 249 21339 0 0
PE2
Validate LDP session using following show command:
PE2#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
11.11.11.11 ce45 Active OPERATIONAL 30 00:06:59
 
Validate virtual circuit status using following command:
PE2#show mpls vc-table
VC-ID VID Inner-VID Ac-Intf Nw-Intf Out Label Tunnel-Label Nexthop Status
2000200 N/A N/A xe1 ce45 24320 3 11.11.11.11 Active
2000300 N/A N/A xe1 ce45 24321 3 11.11.11.11 Active
 
Validate QoS configuration and statistics using below commands:
PE2#show policy-map interface xe1
 
Interface xe1
Type QoS statistics status : enabled
 
Service-policy (queuing) output: default-out-policy
Interface Bandwidth 1000000 kbps
-----------------------------------
Class-map (queuing): q0
shape 1000000 kbps (inherited)
priority level 0
queue-limit 1048576 bytes/8 ms (default)
Output
Total : 6205481 packets, 9419929266 bytes
Green : 6205548 packets, 9420032490 bytes
Yellow : 0 packets, 0 bytes
 
Class-map (queuing): q1
shape 1000000 kbps (inherited)
priority level 1
queue-limit 1048576 bytes/8 ms (default)
Output
Total : 6205580 packets, 9420081066 bytes
Green : 6205651 packets, 9420188844 bytes
Yellow : 0 packets, 0 bytes
 
Class-map (queuing): q2
shape 1000000 kbps (inherited)
priority level 2
queue-limit 1048576 bytes/8 ms (default)
Output
Total : 6205681 packets, 9420260190 bytes
Green : 6205798 packets, 9420410472 bytes
Yellow : 0 packets, 0 bytes
 
Class-map (queuing): q3
shape 1000000 kbps (inherited)
priority level 3
queue-limit 1048576 bytes/8 ms (default)
Output
Total : 3102900 packets, 4710206754 bytes
Green : 3102934 packets, 4710258366 bytes
Yellow : 0 packets, 0 bytes
 
Class-map (queuing): q4
shape 1000000 kbps (inherited)
priority level 4
queue-limit 1048576 bytes/8 ms (default)
Output
Total : 3102984 packets, 4710337302 bytes
Green : 3103019 packets, 4710388914 bytes
Yellow : 0 packets, 0 bytes
 
Class-map (queuing): q5
shape 1000000 kbps (inherited)
priority level 5
queue-limit 1048576 bytes/8 ms (default)
 
Class-map (queuing): q6
shape 1000000 kbps (inherited)
priority level 6
queue-limit 1048576 bytes/8 ms (default)
 
Class-map (queuing): q7
shape 1000000 kbps (inherited)
priority level 7
queue-limit 1048576 bytes/8 ms (default)
 
 
PE2#show policy-map statistics
Type qos class-map statistics:
+---------------+----------------+----------------+----------------+------------------+
| Class-map | Match pkts | Match bytes | Dropped pkts | Dropped Bytes |
+---------------+----------------+----------------+----------------+------------------+
 
Type queuing class-map statistics:
+---------------+----------------+----------------+----------------+------------------+
| Class-map | Total pkts | Total bytes | Dropped pkts | Dropped Bytes |
+---------------+----------------+----------------+----------------+------------------+
ce45
q6 29 2378 0 0
q7 295 25051 0 0
xe1
q0 6339725 9623710140 0 0
q1 6339793 9623811846 0 0
q2 6339857 9623908998 0 0
q3 3169947 4811984100 0 0
q4 3170018 4812088842 0 0