OcNOS-SP : Key Features : Improved Management : DHCP Server Group
DHCP Server Group
Overview
Dynamic Host Control Protocol (DHCP) Group provides the capability to specify multiple DHCP servers as a group on the DHCP relay agent and to correlate a relay agent interface with the server group. When the interface receives request messages from clients, the relay agent forwards the message to all the DHCP servers of the group. One or multiple DHCP servers in the group process the request and respond with an offer to the client. The client reviews the offer and sends the request message to the chosen server to obtain the network configuration that includes an IP address. The illustration below shows a DHCP client sending a request message to a DHCP relay agent that forwards the message to the three servers in the DHCP server group to get their network configuration. The DHCP client and DHCP relay agent run OcNOS, but the DHCP servers can be OcNOS or Linux devices.
DHCP server group
Feature Characteristics
This feature enables the configuration of the DHCP server group and attaches it to a DHCP relay agent through the CLI and the NetConf interface. A DHCP server group can be attached with multiple DHCP relay uplink interfaces, but at a given time, a single DHCP relay uplink interface is allowed to be attached with a single DHCP server group. The attachment of the DHCP relay uplink interface to another DHCP server group dissociates its attachment with the earlier attached DHCP server group.
This feature helps to configure DHCP IPv4 and IPv6 groups and attach server IP addresses to the group. Creating a maximum of 32 IPv4 and 32 IPv6 groups per VRF is allowed, and configuring 8 DHCP servers is permitted for each DHCP server group.
Benefits
The DHCP relay agent forwards the request message from the DHCP client to multiple DHCP servers in the group. Forwarding the request message to multiple DHCP servers increases the reliability of obtaining the network configuration.
Configuration
Before configuring the DHCP client and the DHCP relay agent, make sure that DHCP server is configured and the dhcpd service is running in the DHCP server.
Topology
In the below example, DHCP server1 and DHCP server2 (OcNOS or Linux devices) are connected to the DHCP relay agent (an OcNOS device), and the DHCP relay is connected to a DHCP client (an OcNOS device). The DHCP client sends discover message to the DHCP servers through the DHCP relay agent.
DHCP server group topology
DHCP Server-1 Configuration for IPv4
This section shows how to configure the DHCPv4 Server-1.
DHCPv4 Server-1
 
OcNOS#configure terminal
Enter configure mode.
OcNOS(config)ip dhcp server pool DHCP-Server-1
Configure DHCP server group for server in global mode.
OcNOS(dhcp-config)#network 10.10.10.0 netmask 255.255.255.0
Configure network 10.10.10.0 and netmask 255.255.255.0.
OcNOS(dhcp-config)#address range low-address 10.10.10.1 high-address 10.10.10.254
Configure address range from 10.10.10.1 to 10.10.10.254.
OcNOS(dhcp-config)#dns-server 192.2.2.2
Configure the DNS server 192.2.2.2.
OcNOS(dhcp-config)#commit
Commit the candidate configuration to the running configuration.
OcNOS(dhcp-config)#exit
Exit DHCP config mode.
OcNOS(config)#ip dhcp server pool DHCP-SER
Configure DHCP server group for client in global mode.
OcNOS(dhcp-config)#network 20.20.20.0 netmask 255.255.255.0
Configure network 20.20.20.0 and netmask 255.255.255.0.
OcNOS(dhcp-config)#address range low-address 20.20.20.1 high-address 20.20.20.30
Configure address range from 20.20.20.1 to 20.20.20.30.
OcNOS(dhcp-config)#commit
Commit the candidate configuration to the running configuration.
OcNOS(dhcp-config)#exit
Exit dhcp config mode.
OcNOS(config)#interface xe8
Enter interface mode xe8.
OcNOS(config-if)#ip address 10.10.10.2/24
Configure IP address on the interface xe8.
OcNOS(config-if)#ip dhcp server
Server should be configured on the interface while connected to the relay.
OcNOS(config-if)#commit
Commit the candidate configuration to the running configuration.
OcNOS(config-if)#exit
Exit interface mode.
OcNOS(config)#ip route 20.20.20.0/24 10.10.10.3
Configure static route of 20.20.20.0/24 by next hop interface 10.10.10.3.
OcNOS(config)#commit
Commit the candidate configuration to the running configuration.
OcNOS(config)#exit
Exit config mode.
Validation
The below shows the running configuration of the DHCPv4 Server-1 node:
OcNOS#show running-config dhcp
interface eth0
ip address dhcp
!
!
 
ip dhcp server pool DHCP-Server-1
network 10.10.10.0 netmask 255.255.255.0
address range low-address 10.10.10.1 high-address 10.10.10.254
dns-server 192.2.2.2
ip dhcp server pool DHCP-SER
network 20.20.20.0 netmask 255.255.255.0
address range low-address 20.20.20.1 high-address 20.20.20.30
interface xe8
ip dhcp server
!
OcNOS#
DHCP Server-2 Configuration for IPv4
This section shows how to configure the DHCPv4 Server-2.
DHCPv4 Server-2
 
OcNOS#configure terminal
Enter configure mode.
OcNOS(config)#ip dhcp server pool DHCP-Server-2
Configure DHCP server group for server in global mode.
OcNOS(dhcp-config)#network 40.10.10.0 netmask 255.255.255.0
Configure network 40.10.10.0 and netmask 255.255.255.0.
OcNOS(dhcp-config)#address range low-address 40.10.10.1 high-address 40.10.10.254
Configure address range from 40.10.10.1 to 40.10.10.254.
OcNOS(dhcp-config)#dns-server 192.2.2.2
Configure DNS server 192.2.2.2.
OcNOS(dhcp-config)#ip dhcp server pool DHCP-SER
Configure DHCP server group for client in global mode.
OcNOS(dhcp-config)#network 20.20.20.0 netmask 255.255.255.0
Configure network 20.20.20.0 and netmask 255.255.255.0.
OcNOS(dhcp-config)#address range low-address 20.20.20.1 high-address 20.20.20.30
Configure address range from 20.20.20.1 to 20.20.20.30.
OcNOS(dhcp-config)#commit
Commit the candidate configuration to the running configuration.
OcNOS(dhcp-config)#exit
Exit DHCPv6 config mode.
OcNOS(config)#interface xe11
Enter interface mode xe11.
OcNOS(config-if)#ip address 40.10.10.2/24
Configure IP address 40.10.10.2/24 on the interface xe11.
OcNOS(config-if)#ip dhcp server
Server should be configured on the interface while connected to the relay.
OcNOS(config-if)#commit
Commit the candidate configuration to the running configuration.
OcNOS(config-if)#exit
Exit interface mode.
OcNOS(config)#ip route 20.20.20.0/24 40.10.10.3
Configure static route 20.20.20.0/24 by next hop interface 40.10.10.3.
OcNOS(config)#commit
Commit the candidate configuration to the running configuration.
OcNOS(config)#exit
Exit config mode.
Validation
The below shows the running configuration of the DHCPv4 Server-2 node:
OcNOS#show running-config dhcp
interface eth0
ip address dhcp
!
!
 
ip dhcp server pool DHCP-Server-2
network 40.10.10.0 netmask 255.255.255.0
address range low-address 40.10.10.1 high-address 40.10.10.254
dns-server 192.2.2.2
ip dhcp server pool DHCP-SER
network 20.20.20.0 netmask 255.255.255.0
address range low-address 20.20.20.1 high-address 20.20.20.30
interface xe11
ip dhcp server
!
OcNOS#
DHCP Relay Agent Configuration for IPv4
This section shows how to configure the DHCPv4 relay agent.
DHCPv4 Relay Agent
 
OcNOS#configure terminal
Enter configure mode.
OcNOS(config)#ip dhcp relay server-group dhcp-relay-gp
Configure relay server-group group name in global mode.
OcNOS(dhcp-relay-group)#server 10.10.10.2
Configure server 10.10.10.2.
OcNOS(dhcp-relay-group)#exit
Exit DHCP relay group.
OcNOS(config)#interface xe15
Enter interface mode xe15.
OcNOS(config-if)#ip address 20.20.20.2/24
Configure IPv4 address 20.20.20.2 on the interface xe15.
OcNOS(config-if)#ip dhcp relay
Relay should be configured on the interface connecting to the client.
OcNOS(config-if)#commit
Commit the candidate configuration to the running configuration.
OcNOS(config-if)#exit
Exit interface mode.
OcNOS(config)#interface xe8
Enter interface mode xe8.
OcNOS(config-if)#ip address 10.10.10.3/24
Configure IPv4 address 10.10.10.3 on the interface xe8.
OcNOS(config-if)#ip dhcp relay uplink
Configure relay uplink on the device connecting the server.
OcNOS(config-if)#ip dhcp relay server-select dhcp-relay-gp
Configure relay server-select group name on the device connected to the server.
OcNOS(config-if)#commit
Commit the candidate configuration to the running configuration.
OcNOS(config-if)#exit
Exit interface mode.
OcNOS(config)#ip dhcp relay server-group dhcp-relay-gp
Configure relay server-group group name in global mode.
OcNOS(dhcp-relay-group)#server 40.10.10.2
Configure IPv4 DHCP server address 40.10.10.2 on the server group.
OcNOS(dhcp-relay-group)#commit
Commit the candidate configuration to the running configuration.
OcNOS(dhcp-relay-group)#exit
Exit DHCP relay group.
OcNOS(config)#interface xe11
Enter interface mode xe11.
OcNOS(config-if)#ip address 40.10.10.3/24
Configure IPv4 address 40.10.10.3 on the interface xe11.
OcNOS(config-if)#ip dhcp relay uplink
Configure relay uplink on the device connecting the server.
OcNOS(config-if)#ip dhcp relay server-select dhcp-relay-gp
Configure relay server-select group name on the device connected to the server.
OcNOS(config-if)#commit
Commit the candidate configuration to the running configuration.
OcNOS(config-if)#exit
Exit interface mode.
Validation
The below shows the running configuration of the DHCPv4 relay agent node:
OcNOS#show running-config dhcp
interface eth0
ip address dhcp
!
!
 
ip dhcp relay server-group dhcp-relay-gp
server 10.10.10.2
server 40.10.10.2
interface xe8
ip dhcp relay uplink
ip dhcp relay server-select dhcp-relay-gp
!
interface xe11
ip dhcp relay uplink
ip dhcp relay server-select dhcp-relay-gp
!
interface xe15
ip dhcp relay
!
OcNOS#
OcNOS#
OcNOS#show ip dhcp relay
DHCP relay service is Enabled.
VRF Name: default
Option 82: Disabled
Interface Uplink/Downlink
--------- -------------
xe8 Uplink
xe11 Uplink
xe15 Downlink
Interface Group-Name Server
--------- ------------- ------
xe11 dhcp-relay-gp 10.10.10.2,40.10.10.2
Incoming DHCPv4 packets which already contain relay agent option are FORWARDED u
nchanged.
OcNOS#
DHCP Client Configuration for IPv4
This section shows how to configure the DHCPv4 Client.
DHCPv4 Client
 
OcNOS#configure terminal
Enter configure mode.
OcNOS(config)#feature dhcp
Enable the feature DHCP. This will be enabled by default.
OcNOS(config)#int xe15
Enter interface mode xe15.
OcNOS(config-if)#ip address dhcp
The client requests for the IP address to the server, once it receives the acknowledgment from the server, it assigns the IP address to the interface in which this command is enabled.
OcNOS(config-if)#commit
Commit the candidate configuration to the running configuration.
OcNOS(config-if)#exit
Exit interface mode.
Validation
The below shows the running configuration of the DHCPv4 client node:
OcNOS#show running-config dhcp
interface eth0
ip address dhcp
!
interface xe15
ip address dhcp
 
OcNOS#show ip interface brief
 
'*' - address is assigned by dhcp client
 
Interface IP-Address Admin-Status Link-Status
cd1 unassigned up down
cd3 unassigned up down
ce0 unassigned up down
ce2 unassigned up down
eth0 *10.12.121.156 up up
lo 127.0.0.1 up up
lo.management 127.0.0.1 up up
xe4 unassigned up down
xe5 unassigned up down
xe6 unassigned up down
xe7 unassigned up down
xe8 unassigned up down
xe9 unassigned up down
xe10 unassigned up down
xe11 unassigned up down
xe12 unassigned up down
xe13 unassigned up down
xe14 unassigned up down
xe15 *20.20.20.1 up up
xe16 unassigned up down
xe17 unassigned up down
xe18 unassigned up down
xe19 unassigned up down
xe20 unassigned up down
xe21 unassigned up down
xe22 unassigned up down
xe23 unassigned up down
xe24 unassigned up down
xe25 unassigned up down
xe26 unassigned up down
xe27 unassigned up down
OcNOS#--
OcNOS#
OcNOS#show ip int xe15 br
 
'*' - address is assigned by dhcp client
 
Interface IP-Address Admin-Status Link-Status
xe15 *20.20.20.1 up up
OcNOS#
DHCP Server-1 Configuration for IPv6
This section shows how to configure the DHCPv6 Server-1.
DHCPv6 Server-1
 
OcNOS#configure terminal
Enter configure mode.
OcNOS(config)#ipv6 dhcp server pool DHCPv6-Server-1
Configure DHCP server group for server in global mode.
OcNOS(dhcp6-config)#network 2001:: netmask 64
Configure network 2001:: and netmask 64.
OcNOS(dhcp6-config)#address range low-address 2001::1 high-address 2001::124
Configure address range from 2001::1 to 2001::124.
OcNOS(dhcp6-config)#ipv6 dhcp server pool DHCPv6-SER
Configure DHCP server group for client in global mode.
OcNOS(dhcp6-config)#network 3001:: netmask 64
Configure network 3001:: and netmask 64.
OcNOS(dhcp6-config)#address range low-address 3001::1 high-address 3001::124
Configure address range from 3001::1 to 3001::124.
OcNOS(dhcp6-config)#commit
Commit the candidate configuration to the running configuration.
OcNOS(dhcp6-config)#exit
Exit DHCPv6 config mode.
OcNOS(config)#interface xe8
Enter interface mode xe8.
OcNOS(config-if)#ipv6 address 2001::2/64
Configure IPv6 address 2001::2/64 on the interface xe8.
OcNOS(config-if)#ipv6 dhcp server
Server should be configured on the interface while connected to the relay.
OcNOS(config-if)#commit
Commit the candidate configuration to the running configuration.
OcNOS(config-if)#exit
Exit interface mode.
OcNOS(config)#ipv6 route 3001::/64 2001::3
Configure static route 3001::/64 by next hop interface 2001::3.
OcNOS(config)#commit
Commit the candidate configuration to the running configuration.
OcNOS(config)#exit
Exit config mode.
Validation
The below shows the running configuration of the DHCPv6 Server-1 node:
OcNOS#show running-config dhcp
interface eth0
ip address dhcp
!
!
 
ipv6 dhcp server pool DHCPv6-Server-1
network 2001:: netmask 64
address range low-address 2001::1 high-address 2001::124
ipv6 dhcp server pool DHCPv6-SER
network 3001:: netmask 64
address range low-address 3001::1 high-address 3001::124
interface xe8
ipv6 dhcp server
!
OcNOS#
DHCP Server-2 Configuration for IPv6
This section shows how to configure the DHCPv6 Server-2.
DHCPv6 Server-2
 
OcNOS#configure terminal
Enter configure mode.
OcNOS(config)#ipv6 dhcp server pool DHCPv6-Server-2
Configure dhcp server group for server in global mode.
OcNOS(dhcp6-config)#network 4001:: netmask 64
Configure network 4001:: and netmask 64.
OcNOS(dhcp6-config)#address range low-address 4001::1 high-address 4001::124
Configure address range from 4001::1 to 4001::124.
OcNOS(dhcp6-config)#ipv6 dhcp server pool DHCPv6-SER
Configure DHCP server group for client in global mode.
OcNOS(dhcp6-config)#network 3001:: netmask 64
Configure network 3001:: and netmask 64.
OcNOS(dhcp6-config)#address range low-address 3001::1 high-address 3001::124
Configure address range from 3001::1 to 3001::124.
OcNOS(dhcp6-config)#commit
Commit the candidate configuration to the running configuration.
OcNOS(dhcp6-config)#exit
Exit DHCPv6 config mode.
OcNOS(config)#interface xe11
Enter interface mode xe11.
OcNOS(config-if)#ipv6 address 4001::2/64
Configure IPv6 address on the interface xe11.
OcNOS(config-if)#ipv6 dhcp server
Server should be configured on the interface while connected to the relay.
OcNOS(config-if)#commit
Commit the candidate configuration to the running configuration.
OcNOS(config-if)#exit
Exit interface mode.
OcNOS(config)#ipv6 route 3001::/64 4001::3
Configure static route 3001::/64 by next hop interface 4001::3.
OcNOS(config)#commit
Commit the candidate configuration to the running configuration.
OcNOS(config)#exit
Exit config mode.
Validation
The below shows the running configuration of the DHCPv6 Server-2 node:
OcNOS#show running-config dhcp
interface eth0
ip address dhcp
!
!
 
ipv6 dhcp server pool DHCPv6-Server-2
network 4001:: netmask 64
address range low-address 4001::1 high-address 4001::124
ipv6 dhcp server pool DHCPv6-SER
network 3001:: netmask 64
address range low-address 3001::1 high-address 3001::124
interface xe11
ipv6 dhcp server
!
OcNOS#
DHCP Relay Agent Configuration for IPv6
This section shows how to configure the DHCPv6 relay agent.
DHCPv6 Relay Agent
 
OcNOS#configure terminal
Enter configure mode.
OcNOS(config)#ipv6 dhcp relay server-group dhcpv6-relay-gp
Configure relay server-group group name in global mode.
OcNOS(dhcp6-relay-group)#server 2001::2
Configure server address 2001::2.
OcNOS(dhcp6-relay-group)#commit
Commit the candidate configuration to the running configuration.
OcNOS(dhcp6-relay-group)#exit
Exit DHCPv6 relay group.
OcNOS(config)#interface xe8
Enter interface mode xe8.
OcNOS(config-if)#ipv6 address 2001::3/64
Configure IPv6 address 2001::3/64 on the interface xe8.
OcNOS(config-if)#ipv6 dhcp relay uplink
Configure relay uplink on the device connecting the server.
OcNOS(config-if)#ipv6 dhcp relay server-select dhcpv6-relay-gp
Configure relay server-select group name on the device connected to the server.
OcNOS(config-if)#commit
Commit the candidate configuration to the running configuration.
OcNOS(config-if)#exit
Exit interface mode.
OcNOS(config)#interface xe15
Enter interface mode.
OcNOS(config-if)#ipv6 address 3001::2/64
Configure IPv6 address on the interface xe15.
OcNOS(config-if)#ipv6 dhcp relay
By default, this will be enabled. This command starts the IPv6 dhcp relay service.
OcNOS(config-if)#commit
Commit the candidate configuration to the running configuration.
OcNOS(config-if)#exit
Exit interface mode.
OcNOS(config)#ipv6 dhcp relay server-group dhcpv6-relay-gp
Configure relay server-group group name in global mode.
OcNOS(dhcp6-relay-group)#server 4001::2
Configure server address 4001::2.
OcNOS(dhcp6-relay-group)#commit
Commit the candidate configuration to the running configuration.
OcNOS(dhcp6-relay-group)#exit
Exit DHCPv6 relay group.
OcNOS(config)#interface xe11
Enter interface mode.
OcNOS(config-if)#ipv6 address 4001::3/64
Configure IPv6 4001::3/64 address on the interface xe11.
OcNOS(config-if)#ipv6 dhcp relay uplink
Configure relay uplink on the device connecting the server.
OcNOS(config-if)#ipv6 dhcp relay server-select dhcpv6-relay-gp
Configure relay server-select group name on the device connected to the server.
OcNOS(config-if)#commit
Commit the candidate configuration to the running configuration.
OcNOS(config-if)#exit
Exit interface mode.
Validation
The below shows the running configuration of the DHCPv6 relay agent node:
OcNOS#show running-config dhcp
interface eth0
ip address dhcp
!
!
 
ipv6 dhcp relay server-group dhcpv6-relay-gp
server 2001::2
server 4001::2
interface xe8
ipv6 dhcp relay uplink
ipv6 dhcp relay server-select dhcpv6-relay-gp
!
interface xe11
ipv6 dhcp relay uplink
ipv6 dhcp relay server-select dhcpv6-relay-gp
!
interface xe15
ipv6 dhcp relay
OcNOS#show ipv6 dhcp relay
IPv6 DHCP relay service is Enabled.
VRF Name: default
DHCPv6 IA_PD Route injection: Disabled
Interface Uplink/Downlink
--------- -------------
xe8 Uplink
xe11 Uplink
xe15 Downlink
Interface Group-Name Server
--------- ------------- ------
xe11 dhcpv6-relay-gp 2001::2,4001::2
OcNOS#
DHCP Client Configuration for IPv6
This section shows how to configure the DHCPv6 client.
DHCPv6 client
 
OcNOS#configure terminal
Enter configure mode.
OcNOS (config)#feature dhcp
Enable the feature dhcp. This is enabled by default.
OcNOS(config)#int xe15
Enter interface mode xe15.
OcNOS(config-if)#ipv6 address dhcp
The client requests for the IPv6 address to the server. Once it receives the acknowledgment from the server, it assigns the IPv6 address to the interface in which this command is enabled.
OcNOS(config-if)#commit
Commit the candidate configuration to the running configuration.
OcNOS(config-if)#exit
Exit interface mode.
Validation
The below shows the running configuration of the DHCPv6 client node:
OcNOS#show running-config dhcp
interface eth0
ip address dhcp
!
interface xe15
ipv6 address dhcp
 
OcNOS#show ipv6 int br
Interface IPv6-Address Admin-Sta
tus
cd1 unassigned [up/down]
 
cd3 unassigned [up/down]
 
ce0 unassigned [up/down]
 
ce2 unassigned [up/down]
 
eth0 fe80::d277:ceff:fe9f:4500 [up/up]
 
lo ::1 [up/up]
 
lo.management ::1 [up/up]
 
xe4 unassigned [up/down]
 
xe5 unassigned [up/down]
 
xe6 unassigned [up/down]
 
xe7 unassigned [up/down]
 
xe8 unassigned [up/down]
 
xe9 unassigned [up/down]
 
xe10 unassigned [up/down]
 
xe11 unassigned [up/down]
 
xe12 unassigned [up/down]
 
xe13 unassigned [up/down]
 
xe14 unassigned [up/down]
 
xe15 *3001::124
fe80::d277:ceff:feda:4511 [up/up]
 
xe16 unassigned [up/down]
 
xe17 unassigned [up/down]
 
xe18 unassigned [up/down]
 
xe19 unassigned [up/down]
 
xe20 unassigned [up/down]
 
xe21 unassigned [up/down]
 
xe22 unassigned [up/down]
 
xe23 unassigned [up/down]
 
xe24 unassigned [up/down]
 
xe25 unassigned [up/down]
 
xe26 unassigned [up/down]
 
xe27 unassigned [up/down]
 
OcNOS#
OcNOS#
OcNOS#
OcNOS#
OcNOS#
 
OcNOS#show ipv6 int xe15 br
Interface IPv6-Address Admin-Sta
tus
xe15 *3001::124
fe80::d277:ceff:feda:4511 [up/up]
New CLI Commands
ip dhcp relay server-group
Use this command to create the DHCP IPv4 server group. This group lists the servers to which DHCP Relay forwards the DHCP client requests.
Use the no form of this command to unconfigure the DHCP IPv4 server group.
Command Syntax
ip dhcp relay server-group GROUP_NAME
no ip dhcp relay server-group GROUP_NAME
Parameters
GROUP_NAME
Name of the DHCP server group (specify a maximum 63 alphanumeric characters).
Command Mode
Configure mode and VRF mode. In the configure mode, the DHCP IPv4 server group is created in the default VRF. In the configure-vrf mode, the DHCP IPv4 server group is created in the user-defined VRF.
Applicability
This command was introduced in OcNOS version 6.4.1.
Examples
The example below shows the creation of DHCP IPv4 server groups.
OcNOS(config)#ip vrf vrf1
OcNOS(config-vrf)#ip dhcp relay server-group Group1
OcNOS(dhcp-relay-group)#end
OcNOS#configure terminal
OcNOS(config)#ip dhcp relay server-group Group2
ip dhcp relay server-select
Use this command to attach the DHCP IPv4 server group to the DHCP relay uplink interface.
Use the no form of this command to remove the DHCP IPv4 server group attached to the DHCP relay interface.
Note: Attach the groups only to the DHCP relay uplink interfaces.
Command Syntax
ip dhcp relay server-select GROUP_NAME
no ip dhcp relay server-select
Parameters
GROUP_NAME
Name of the DHCP server group (specify a maximum 63 alphanumeric characters).
Command Mode
Interface mode.
Applicability
This command was introduced in OcNOS version 6.4.1.
Examples
The below example shows attaching the DHCP IPv4 server group to the DHCP relay uplink interface:
OcNOS#configure terminal
OcNOS(config)#interface xe1
OcNOS(config-if)#ip dhcp relay server-select group1
ipv6 dhcp relay server-group
Use this command to create the DHCP IPv6 server group. This group lists the servers to which DHCP relay forwards the DHCP client requests.
Use the no form of this command to unconfigure the DHCP IPv6 server group.
Command Syntax
ipv6 dhcp relay server-group GROUP_NAME
no ipv6 dhcp relay server-group GROUP_NAME
Parameters
GROUP_NAME
Name of the DHCP server group (specify a maximum of 63 alphanumeric characters).
Command Mode
Configure mode and VRF mode. In the configure mode, the DHCP IPv6 server group is created in the default VRF. In the configure-vrf mode, the DHCP IPv6 server group is created in the user-defined VRF.
Applicability
This command was introduced in OcNOS version 6.4.1.
Examples
The example below shows the creation of DHCP IPv6 server groups:
OcNOS#configure terminal
OcNOS(config)#ip vrf vrf1
OcNOS(config-vrf)#ipv6 dhcp relay server-group Group1
OcNOS(dhcp relay server-group)#end
OcNOS#configure terminal
OcNOS(config)#ipv6 dhcp relay server-group Group2
ipv6 dhcp relay server-select
Use this command to attach the DHCP IPv6 group to the DHCP relay uplink interface.
Use the no form of this command to remove the DHCP IPv6 group attached to the interface.
Note: Attach the groups only to the DHCP relay uplink interfaces.
Command Syntax
ipv6 dhcp relay server-select GROUP_NAME
no ipv6 dhcp relay server-select
Parameters
GROUP_NAME
Name of the DHCP server group (specify a maximum of 63 alphanumeric characters).
Command Mode
Interface mode.
Applicability
This command was introduced in OcNOS version 6.4.1.
Examples
The below example shows how to attach the DHCP IPv6 server group to the DHCP relay uplink interface:
#configure terminal
(config)#interface xe1
(config-if)#ipv6 dhcp relay server-select group1
server A.B.C.D
Use this command to add the DHCP IPv4 servers to the DHCP server group.
Use the no form of this command to remove the DHCP IPv4 servers from the DHCP server Group.
Note: A maximum of eight servers can be added to a DHCP group.
Command Syntax
server A.B.C.D
no server A.B.C.D
Parameters
A.B.C.D
DHCP IPv4 Relay group server address to be added in the DHCP server group.
Command Mode
DHCP Relay Group Mode.
Applicability
This command was introduced in OcNOS version 6.4.1.
Examples
The below example shows the addition of DHCP IPv4 servers to a DHCP server group:
OcNOS#configure terminal
OcNOS(config)#ip vrf vrf1
OcNOS(config-vrf)#ip dhcp relay server-group group
OcNOS(dhcp-relay-group)#server 10.12.23.205
OcNOS(dhcp-relay-group)#end
OcNOS#configure terminal
OcNOS(config)#ip dhcp relay server-group group1
OcNOS(dhcp-relay-group)#server 10.12.33.204
server X:X::X:X
Use this command to add the DHCP IPv6 servers to the DHCP server group.
Use the no form of this command to remove the DHCP IPv6 servers from the DHCP server group.
Note: A maximum of eight servers can be added to a DHCP group.
Command Syntax
server X:X::X:X
no server X:X::X:X
Parameters
X:X::X:X
DHCP IPv6 Relay Group server address to be added in the DHCP server group.
Command Mode
DHCPv6 Relay Group Mode.
Applicability
This command was introduced in OcNOS version 6.4.1.
Examples
The below example shows the addition of DHCP IPv6 servers to a DHCP server group:
OcNOS#configure terminal
OcNOS(config)#ip vrf vrf1
OcNOS(config-vrf)#ipv6 dhcp relay server-group group
OcNOS(dhcp6-relay-group)#server 2003::1
OcNOS(dhcp6-relay-group)#end
 
OcNOS#configure terminal
OcNOS(config)#ipv6 dhcp relay server-group group1
OcNOS(dhcp-relay-group)#server 2001::1
OcNOS(dhcp6-relay-group)end
Abbreviations
The following are some key abbreviations and their meanings relevant to this document:
 
Acronym
Description
DHCP
Dynamic Host Configuration Protocol
VRF
Virtual Routing and Forwarding
Glossary
The following provides definitions for key terms used throughout this document:
 
DHCP Client
A DHCP client is a hardware device or software that uses DHCP to get the network configuration information from a DHCP Server.
 
 
VRF: VRF creates a logically isolated routing table within a single physical network device. Each VRF instance works as an independent routing instance that enables separate network traffic, maintains different routing tables, and provides network isolation.
DHCP Server
A DHCP server is a hardware device or software that leases a dynamic IP address to the DHCP client.
DHCP relay agent
A DHCP relay forwards the request from a DHCP client to the DHCP server group and takes the response from the DHCP server group to the DHCP client.
VRF
VRF creates a logically isolated routing table within a single physical network device. Each VRF instance works as an independent routing instance that enables separate network traffic, maintains different routing tables, and provides network isolation.