OcNOS-SP : Layer 3 Guide : Layer 3 Unicast Configuration Guide : BGP4+ Additional Paths Configuration
BGP4+ Additional Paths Configuration
Overview
The Border Gateway Protocol (BGP) ADDPATH feature allows the advertisement of multiple paths through the same peering session for a given prefix without the new paths implicitly replacing any previous paths. This behavior promotes path diversity and reduces the severity of a network failure, thereby improving the control plane convergence in case of network failures.
Normal BGP Behavior
By default, all BGP routers and Route-Reflectors propagate only their best paths over their sessions. In case they advertise any route with the same NLRI as a previously advertised route, the latest one implicitly replaces the previous advertisement, which is known as an Implicit Withdraw. The Implicit Withdraw can achieve better scaling, but at the cost of path diversity.
The use of route-reflectors (or confederations), thus has significant effect on redundancy by hiding alternate paths. Using full-mesh is not an option, so a mechanism is needed to allow the propagation of multiple alternate paths in an RR/Confederation environment. Such mechanism is already available in BGP/MPLS VPN scenarios, where multiple point of attachments for CE sites could utilize different RD values to differentiate the same routes advertised from different connection points. However, a generic solution is required, allowing for advertising multiple alternate paths with IPv4 or any other address-family.
The “Advertisement of Multiple Paths in BGP” or “BGP Add-Path” as the feature is usually called is a BGP extension that allows the advertisement of multiple paths for the same address prefix without the new paths implicitly replacing any previously advertised ones.
BGP Behavior with Additional Paths
The advertisement of multiple paths in BGP is made possible by aending a BGP OPEN message to the neighbor with a BGP capability code of 69, which identifies the BGP ADD-PATH Capability.
Address Family Identifier(AFI)
2 octets
Subsequent Address Family Identifier(SAFI)
1 octet
Send/Receive
1 octet
The send/receive field in the BGP Capability TLV indicates whether for a given <AFI, SAFI>, the sender is able to:
Receive multiple paths from its peer (value 1)
Send multiple paths to its peer (value 2), or
both (value 3)
Each alternate path is identified by a Path Identifier in addition to the address prefix
Path Identifier
4 octets
Length
1 octet
Prefix
variable
In the event of a next-hop failure, the BGP Add-Path feature hence improves the BGP control plane convergence
Topology
BGP4+ additional paths
R1
 
#configure terminal
Enter the Configure mode.
(config)#interface eth2
Enter interface mode for interface eth2
(config-if)#ipv6 address 1001::1/64
Configure IPv6 address for the interface eth2
(config-if)#exit
Exit the interface mode
(config)#interface eth3
Enter interface mode for interface eth3
(config-if)#ipv6 address 1002::1/64
Configure IPv6 address for the interface eth3
(config-if)#exit
Exit the interface mode
(config)#interface eth4
Enter interface mode for interface eth4
(config-if)#ipv6 address 1003::1/64
Configure IPv6 address for the interface eth4
(config-if)#exit
Exit the interface mode
(config)#interface eth5
Enter interface mode for interface eth5
(config-if)#ipv6 address 1004::1/64
Configure IPv6 address for the interface eth5
(config-if)#exit
Exit the interface mode
(config)#interface lo
Enter interface mode for loopback lo
(config-if)#ipv6 address 1090::1/64
Configure IPv6 address for Loopback interface lo
(config-if)#exit
Exit the interface mode
(config)#router bgp 200
Enter the router bgp mode
(config-router)#neighbor 1001::2 remote-as 100
Specify a neighbor router with peer address and remote-as for BGP peering.
(config-router)#neighbor 1002::2 remote-as 100
Specify a neighbor router with peer address and remote-as for BGP peering.
(config-router)#neighbor 1004::2 remote-as 100
Specify a neighbor router with peer address and remote-as for BGP peering.
(config-router)#neighbor 1003::2 remote-as 100
Specify a neighbor router with peer address and remote-as for BGP peering.
(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
(config-router-af)#neighbor 1001::2 activate
Activate the neighbor router with peer address.
(config-router-af)#neighbor 1002::2 activate
Activate the neighbor router with peer address.
(config-router-af)#neighbor 1003::2 activate
Activate the neighbor router with peer address.
(config-router-af)#neighbor 1004::2 activate
Activate the neighbor router with peer address.
(config-router-af)#network 1090::/64
Activate the neighbor router with peer address.
(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
(config-router)#exit
Exit the router BGP mode and enter the config mode
(config)#commit
Apply commit
(config)#exit
Exit the config mode
R2
 
#configure terminal
Enter the Configure mode.
(config)#interface eth1
Enter interface mode for interface eth1
(config-if)#ipv6 address 3001::1/64
Configure IPv6 address for the interface eth1
(config-if)#ipv6 router ospf area 0
Enable OSPFv3 routing on an interface, and assign the Area ID 0.
(config-if)#exit
Exit the interface mode
(config)#interface eth2
Enter interface mode for interface eth2
(config-if)#ipv6 address 1001::2/64
Configure IPv6 address for the interface eth2
(config-if)#exit
Exit the interface mode
(config)#interface eth3
Enter interface mode for interface eth3
(config-if)#ipv6 address 1002::2/64
Configure IPv6 address for the interface eth3
(config-if)#exit
Exit the interface mode
(config)#interface eth4
Enter interface mode for interface eth4
(config-if)#ipv6 address 1003::2/64
Configure IPv6 address for the interface eth4
(config-if)#exit
Exit the interface mode
(config)#interface eth5
Enter interface mode for interface eth5
(config-if)#ipv6 address 1004::2/64
Configure IPv6 address for the interface eth5
(config-if)#exit
Exit the interface mode
(config)#router bgp 100
Enter the router bgp mode
(config-router)#neighbor 3001::2 remote-as 100
Specify a neighbor router with peer address and remote-as for BGP peering.
(config-router)#neighbor 1001::1 remote-as 200
Specify a neighbor router with peer address and remote-as for BGP peering.
(config-router)#neighbor 1002::1 remote-as 200
Specify a neighbor router with peer address and remote-as for BGP peering.
(config-router)#neighbor 1003::1 remote-as 200
Specify a neighbor router with peer address and remote-as for BGP peering.
(config-router)#neighbor 1004::1 remote-as 200
Specify a neighbor router with peer address and remote-as for BGP peering.
(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
(config-router-af)#neighbor 1001::1 activate
Activate the neighbor router with peer address.
(config-router-af)#neighbor 1002::1 activate
Activate the neighbor router with peer address.
(config-router-af)#neighbor 1003::1 activate
Activate the neighbor router with peer address.
(config-router-af)#neighbor 1004::1 activate
Activate the neighbor router with peer address.
(config-router-af)#neighbor 3001::2 activate
Activate the neighbor router with peer address.
(config-router-af)#exit-address-family
Exit address family mode.
(config-router)#exit
Exit the router BGP mode and enter the config mode
(config)#router ipv6 ospf
Enter Router OSPFv3 mode.
(config-router)#redistribute connected
Configure Redistribution of Connected networks into OSPF
(config-router)#exit
Exit the router ospf mode and enter the config mode
(config)#commit
Apply commit
(config)#exit
Exit the config mode
R3
 
#configure terminal
Enter the Configure mode.
(config)#interface eth1
Enter interface mode for interface eth1
(config-if)#ipv6 address 3001::2/64
Configure IPv6 address for the interface eth1
(config-if)#ipv6 router ospf area 0
Enable OSPFv3 routing on an interface, and assign the Area ID 0.
(config-if)#exit
Exit the interface mode
(config)#interface eth2
Enter interface mode for interface eth2
(config-if)#ipv6 address 2001::2/64
Configure IPv6 address for the interface eth2
(config-if)#exit
Exit the interface mode
(config)#interface eth3
Enter interface mode for interface eth3
(config-if)#ipv6 address 2002::2/64
Configure IPv6 address for the interface eth3
(config-if)#exit
Exit the interface mode
(config)#interface eth4
Enter interface mode for interface eth4
(config-if)#ipv6 address 2003::2/64
Configure IPv6 address for the interface eth4
(config-if)#exit
Exit the interface mode
(config)#interface eth5
Enter interface mode for interface eth5
(config-if)#ipv6 address 2004::2/64
Configure IPv6 address for the interface eth5
(config-if)#exit
Exit the interface mode
(config)#router bgp 100
Enter the router bgp mode
(config-router)#neighbor 3001::1 remote-as 100
Specify a neighbor router with peer address and remote-as for BGP peering.
(config-router)#neighbor 2001::1 remote-as 300
Specify a neighbor router with peer address and remote-as for BGP peering.
(config-router)#neighbor 2002::1 remote-as 300
Specify a neighbor router with peer address and remote-as for BGP peering.
(config-router)#neighbor 2003::1 remote-as 300
Specify a neighbor router with peer address and remote-as for BGP peering.
(config-router)#neighbor 2004::1 remote-as 300
Specify a neighbor router with peer address and remote-as for BGP peering.
(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
(config-router-af)#neighbor 2001::1 activate
Activate the neighbor router with peer address.
(config-router-af)#neighbor 2002::1 activate
Activate the neighbor router with peer address.
(config-router-af)#neighbor 2003::1 activate
Activate the neighbor router with peer address.
(config-router-af)#neighbor 2004::1 activate
Activate the neighbor router with peer address.
(config-router-af)#neighbor 3001::1 activate
Activate the neighbor router with peer address.
(config-router-af)#exit-address-family
Exit address family mode.
(config-router)#exit
Exit Router BGP mode
(config)#router ipv6 ospf
Enter Router OSPFv3 mode.
(config-router)#redistribute connected
Configure Redistribution of Connected networks into OSPF
(config-router)#exit
Exit the router ospf mode and enter the config mode
(config)#commit
Apply commit
(config)#exit
Exit the config mode
R4
 
#configure terminal
Enter the Configure mode.
(config)#interface eth2
Enter interface mode for interface eth2
(config-if)#ipv6 address 2001::1/64
Configure IPv6 address for the interface eth2
(config-if)#exit
Exit the interface mode
(config)#interface eth3
Enter interface mode for interface eth3
(config-if)#ipv6 address 2002::1/64
Configure IPv6 address for the interface eth3
(config-if)#exit
Exit the interface mode
(config)#interface eth4
Enter interface mode for interface eth4
(config-if)#ipv6 address 2003::1/64
Configure IPv6 address for the interface eth4
(config-if)#exit
Exit the interface mode
(config)#interface eth5
Enter interface mode for interface eth5
(config-if)#ipv6 address 2004::1/64
Configure IPv6 address for the interface eth5
(config-if)#exit
Exit the interface mode
(config)#interface lo
Enter interface mode for loopback lo
(config-if)#ipv6 address 9999::1/64
Configure IPv6 address for Loopback interface lo
(config-if)#exit
Exit the interface mode
(config)#router bgp 300
Enter the router bgp mode
(config-router)#neighbor 2001::2 remote-as 100
Specify a neighbor router with peer address and remote-as for BGP peering.
(config-router)#neighbor 2002::2 remote-as 100
Specify a neighbor router with peer address and remote-as for BGP peering.
(config-router)#neighbor 2003::2 remote-as 100
Specify a neighbor router with peer address and remote-as for BGP peering.
(config-router)#neighbor 2004::2 remote-as 100
Specify a neighbor router with peer address and remote-as for BGP peering.
(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
(config-router-af)#neighbor 2001::2 activate
Activate the neighbor router with peer address.
(config-router-af)#neighbor 2002::2 activate
Activate the neighbor router with peer address.
(config-router-af)#neighbor 2003::2 activate
Activate the neighbor router with peer address.
(config-router-af)#neighbor 2004::2 activate
Activate the neighbor router with peer address.
(config-router-af)#network 9999::/64
Activate the neighbor router with peer address.
(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
(config-router)#exit
Exit the router BGP mode and enter the config mode
(config)#commit
Apply commit
(config)#exit
Exit the config mode
Additional Paths at the Global Level
R2
 
#configure terminal
Enter the Configure mode.
(config)#router bgp 100
Enter BGP router mode
(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
(config-router-af)#bgp additional-paths send
Configure R2 to send additional paths to all iBGP neighbors
(config-router-af)#bgp additional-paths select all
Configure R2 to select all available paths to send to all iBGP neighbors
(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
(config-router)#exit
Exit the router BGP mode and enter the config mode
(config)#commit
Apply commit
(config)#exit
Exit the config mode
R3
 
#configure terminal
Enter the Configure mode.
(config)#router bgp 100
Enter BGP router mode
(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
(config-router-af)#bgp additional-paths receive
Configure R3 to receive additional paths from all iBGP neighbors
(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
(config-router)#exit
Exit the router BGP mode and enter the config mode
(config)#commit
Apply commit
(config)#exit
Exit the config mode
Additional Paths at the Neighbor Level
R2
 
#configure terminal
Enter the Configure mode.
(config)#router bgp 100
Enter BGP router mode
(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
(config-router-af)#neighbor 3001::2 additional-paths send
Configure R2 to send additional paths to all iBGP neighbors
(config-router-af)#neighbor 3001::2 advertise additional-paths all
Configure R2 to select all available paths to send to all iBGP neighbors
(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
(config-router)#exit
Exit the router BGP mode and enter the config mode
(config)#commit
Apply commit
(config)#exit
Exit the config mode
R3
 
#configure terminal
Enter the Configure mode.
(config)#router bgp 100
Enter BGP router mode
(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
(config-router-af)#neighbor 3001::1 additional-paths receive
Configure R3 to receive additional paths from all iBGP neighbors
(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
(config-router)#exit
Exit the router BGP mode and enter the config mode
(config)#commit
Apply commit
(config)#exit
Exit the config mode
Validation
R2
#show bgp ipv6 neighbors 3001::2
BGP neighbor is 3001::2, remote AS 100, local AS 100, internal link
BGP version 4, remote router ID 10.12.5.92
BGP state = Established, up for 00:14:55
Last read 00:14:55, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family IPv6 Unicast: advertised and received
Received 536 messages, 50 notifications, 0 in queue
Sent 611 messages, 3 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 5, Offset 0, Mask 0x20
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: IPv6 Unicast
BGP table version 38, neighbor version 38
Index 5, Offset 0, Mask 0x20
AF-dependant capabilities:
Add-Path Send Capability : advertised
Add-Path Receive Capability : received
Community attribute sent to this neighbor (both)
1 accepted prefixes
4 announced prefixes
 
Connections established 3; dropped 2
Local host: 3001::1, Local port: 38451
Foreign host: 3001::2, Foreign port: 179
Nexthop: 10.12.5.93
Nexthop global: 3001::1
Nexthop local: fe80::5054:ff:fe19:1758
BGP connection: shared network
Last Reset: 00:15:00, due to BGP Notification received
Notification Error Message: (Cease/Other Configuration Change.)
 
#show bgp ipv6 summary
BGP router identifier 10.12.5.93, local AS number 100
BGP table version is 38
2 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
1001::1 4 200 517 532 38 0 0 04:13:51 1
1002::1 4 200 520 533 38 0 0 04:13:51 1
1003::1 4 200 519 532 38 0 0 04:13:51 1
1004::1 4 200 518 532 38 0 0 04:13:51 1
3001::2 4 100 588 616 38 0 0 00:15:42 1
 
Total number of neighbors 5
 
Total number of Established sessions 5
 
#show bgp ipv6
BGP table version is 38, local router ID is 10.12.5.93
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
*> 1090::/64 1001::1(fe80::5054:ff:fe9c:b7e6)
0 100 0 200 i
* 1002::1(fe80::5054:ff:fe0d:f5e)
0 100 0 200 i
* 1003::1(fe80::5054:ff:fec7:1940)
0 100 0 200 i
* 1004::1(fe80::5054:ff:fe62:70d8)
0 100 0 200 i
*>i 9999::/64 2001::1 0 100 0 300 i
 
Total number of prefixes 2
 
#show bgp ipv6 1090::/64
BGP routing table entry for 1090::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
1002::1 1003::1 1004::1
200
1001::1(fe80::5054:ff:fe9c:b7e6) from 1001::1 (10.12.5.144)
(fe80::5054:ff:fe9c:b7e6)
Origin IGP, metric 0, localpref 100, valid, external, best
rx path_id: -1 tx path_id: 0
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:53:54 2017
 
200
1002::1(fe80::5054:ff:fe0d:f5e) from 1002::1 (10.12.5.144)
(fe80::5054:ff:fe0d:f5e)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 1
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:54:01 2017
 
200
1003::1(fe80::5054:ff:fec7:1940) from 1003::1 (10.12.5.144)
(fe80::5054:ff:fec7:1940)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 2
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:53:52 2017
 
200
1004::1(fe80::5054:ff:fe62:70d8) from 1004::1 (10.12.5.144)
(fe80::5054:ff:fe62:70d8)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 3
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:53:48 2017
 
R3
#show bgp ipv6 neighbors 3001::1
BGP neighbor is 3001::1, remote AS 100, local AS 100, internal link
BGP version 4, remote router ID 10.12.5.93
BGP state = Established, up for 00:29:37
Last read 00:29:37, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family IPv6 Unicast: advertised and received
Received 518 messages, 2 notifications, 0 in queue
Sent 520 messages, 1 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 5, Offset 0, Mask 0x20
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: IPv6 Unicast
BGP table version 268, neighbor version 268
Index 1, Offset 0, Mask 0x2
AF-dependant capabilities:
Add-Path Send Capability : received
Add-Path Receive Capability : advertised
Community attribute sent to this neighbor (both)
4 accepted prefixes
1 announced prefixes
 
Connections established 4; dropped 3
Local host: 3001::2, Local port: 179
Foreign host: 3001::1, Foreign port: 38451
Nexthop: 10.12.5.92
Nexthop global: 3001::2
Nexthop local: fe80::5054:ff:fe5d:bb79
BGP connection: shared network
Last Reset: 00:29:37, due to BGP Notification sent
Notification Error Message: (Cease/Other Configuration Change.)
#show bgp ipv6 summary
BGP router identifier 10.12.5.92, local AS number 100
BGP table version is 268
2 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
2001::1 4 300 533 537 268 0 0 04:16:42 1
2002::1 4 300 533 536 268 0 0 04:16:42 1
2003::1 4 300 537 538 268 0 0 04:16:42 1
2004::1 4 300 520 521 268 0 0 04:16:38 1
3001::1 4 100 520 521 268 0 0 00:29:41 4
 
Total number of neighbors 5
 
Total number of Established sessions 5
 
#show bgp ipv6
BGP table version is 268, local router ID is 10.12.5.92
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
*>i 1090::/64 1001::1 0 100 0 200 i
* i 1004::1 0 100 0 200 i
* i 1003::1 0 100 0 200 i
* i 1002::1 0 100 0 200 i
*> 9999::/64 2001::1(fe80::5054:ff:fe46:f549)
0 100 0 300 i
* 2004::1(fe80::5054:ff:feb5:9a71)
0 100 0 300 i
* 2003::1(fe80::5054:ff:fe0d:b565)
0 100 0 300 i
* 2002::1(fe80::5054:ff:fed2:4666)
0 100 0 300 i
 
Total number of prefixes 2
 
R3#show bgp ipv6 1090::/64
BGP routing table entry for 1090::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
2001::1 2002::1 2003::1 2004::1
200
1001::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal, best
rx path_id: 0 tx path_id: 0
Not advertised to any peer
Last update: Wed Jan 11 04:08:51 2017
 
200
1004::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 3 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 04:09:43 2017
 
200
1003::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 2 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 04:09:43 2017
 
200
1002::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 1 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 04:09:43 2017
Additional Paths Send and Receive at Address-family level
R2
 
#configure terminal
Enter the Configure mode.
(config)#router bgp 100
Enter BGP router mode
(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
(config-router-af)#bgp additional-paths send-receive
Configure R2 to send additional paths to and receive additional paths from all iBGP neighbors
(config-router-af)#bgp additional-paths select all
Configure R2 to select all available paths to send to all iBGP neighbors
(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
(config-router)#exit
Exit the router BGP mode and enter the config mode
(config)#commit
Apply commit
(config)#exit
Exit the config mode
R3
 
#configure terminal
Enter the Configure mode.
(config)#router bgp 100
Enter BGP router mode
(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
(config-router-af)#bgp additional-paths send-receive
Configure R3 to send additional paths to and receive additional paths from all iBGP neighbors
(config-router-af)#bgp additional-paths select all
Configure R3 to select all available paths to send to all iBGP neighbors
(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
(config-router)#exit
Exit the router BGP mode and enter the config mode
(config)#commit
Apply commit
(config)#exit
Exit the config mode
Additional Paths at the Neighbor Level
R2
 
#configure terminal
Enter the Configure mode.
(config)#router bgp 100
Enter BGP router mode
(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
(config-router-af)#neighbor 3001::2 additional-paths send-receive
Configure R2 to send-receive additional paths to the iBGP neighbor R3
(config-router-af)#neighbor 3001::2 advertise additional-paths all
Configure R2 to advertise all available paths to the iBGP neighbor R3
(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
(config-router)#exit
Exit the router BGP mode and enter the config mode
(config)#commit
Apply commit
(config)#exit
Exit the config mode
R3
 
#configure terminal
Enter the Configure mode.
(config)#router bgp 100
Enter BGP router mode
(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
(config-router-af)#neighbor 3001::1 additional-paths send-receive
Configure R3 to receive additional paths from the iBGP neighbor R2
(config-router-af)#neighbor 3001::1 advertise additional-paths all
Configure R2 to advertise all available paths to the iBGP neighbor R3
(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
(config-router)#exit
Exit the router BGP mode and enter the config mode
(config)#commit
Apply commit
(config)#exit
Exit the config mode
Validation
R2
#show bgp ipv6 neighbors 3001::2
BGP neighbor is 3001::2, remote AS 100, local AS 100, internal link
BGP version 4, remote router ID 10.12.5.92
BGP state = Established, up for 00:00:29
Last read 00:00:29, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family IPv6 Unicast: advertised and received
Received 588 messages, 51 notifications, 0 in queue
Sent 664 messages, 4 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 5, Offset 0, Mask 0x20
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: IPv6 Unicast
BGP table version 64, neighbor version 64
Index 5, Offset 0, Mask 0x20
AF-dependant capabilities:
Add-Path Send Capability : advertised and received
Add-Path Receive Capability : advertised and received
Community attribute sent to this neighbor (both)
4 accepted prefixes
4 announced prefixes
 
Connections established 5; dropped 4
Local host: 3001::1, Local port: 179
Foreign host: 3001::2, Foreign port: 39326
Nexthop: 10.12.5.93
Nexthop global: 3001::1
Nexthop local: fe80::5054:ff:fe19:1758
BGP connection: shared network
Last Reset: 00:00:29, due to BGP Notification sent
Notification Error Message: (Cease/Other Configuration Change.)
 
#show bgp ipv6 summary
BGP router identifier 10.12.5.93, local AS number 100
BGP table version is 64
2 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
1001::1 4 200 561 578 64 0 0 04:35:32 1
1002::1 4 200 564 579 64 0 0 04:35:32 1
1003::1 4 200 563 578 64 0 0 04:35:32 1
1004::1 4 200 562 578 64 0 0 04:35:32 1
3001::2 4 100 640 669 64 0 0 00:00:35 4
 
Total number of neighbors 5
 
Total number of Established sessions 5
 
#show bgp ipv6
BGP table version is 64, local router ID is 10.12.5.93
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
*> 1090::/64 1001::1(fe80::5054:ff:fe9c:b7e6)
0 100 0 200 i
* 1002::1(fe80::5054:ff:fe0d:f5e)
0 100 0 200 i
* 1003::1(fe80::5054:ff:fec7:1940)
0 100 0 200 i
* 1004::1(fe80::5054:ff:fe62:70d8)
0 100 0 200 i
*>i 9999::/64 2001::1 0 100 0 300 i
* i 2002::1 0 100 0 300 i
* i 2003::1 0 100 0 300 i
* i 2004::1 0 100 0 300 i
 
Total number of prefixes 2
 
#show bgp ipv6 1090::/64
BGP routing table entry for 1090::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
1002::1 1003::1 1004::1
200
1001::1(fe80::5054:ff:fe9c:b7e6) from 1001::1 (10.12.5.144)
(fe80::5054:ff:fe9c:b7e6)
Origin IGP, metric 0, localpref 100, valid, external, best
rx path_id: -1 tx path_id: 0
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:53:54 2017
 
200
1002::1(fe80::5054:ff:fe0d:f5e) from 1002::1 (10.12.5.144)
(fe80::5054:ff:fe0d:f5e)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 1
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:54:01 2017
 
200
1003::1(fe80::5054:ff:fec7:1940) from 1003::1 (10.12.5.144)
(fe80::5054:ff:fec7:1940)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 2
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:53:52 2017
 
200
1004::1(fe80::5054:ff:fe62:70d8) from 1004::1 (10.12.5.144)
(fe80::5054:ff:fe62:70d8)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 3
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:53:48 2017
 
#show bgp ipv6 9999::/64
BGP routing table entry for 9999::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
1001::1 1002::1 1003::1 1004::1
300
2001::1 (metric 20) from 3001::2 (10.12.5.92)
Origin IGP, metric 0, localpref 100, valid, internal, best
rx path_id: 0 tx path_id: 0
Not advertised to any peer
Last update: Wed Jan 11 04:45:39 2017
 
300
2002::1 (metric 20) from 3001::2 (10.12.5.92)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 1 tx path_id: 1
Not advertised to any peer
Last update: Wed Jan 11 04:45:53 2017
 
300
2003::1 (metric 20) from 3001::2 (10.12.5.92)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 2 tx path_id: 2
Not advertised to any peer
Last update: Wed Jan 11 04:45:53 2017
 
300
2004::1 (metric 20) from 3001::2 (10.12.5.92)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 3 tx path_id: 3
Not advertised to any peer
Last update: Wed Jan 11 04:45:53 2017
R3
#show bgp ipv6 1090::/64
BGP routing table entry for 1090::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
2001::1 2002::1 2003::1 2004::1
200
1001::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal, best
rx path_id: 0 tx path_id: 0
Not advertised to any peer
Last update: Wed Jan 11 04:45:39 2017
 
200
1002::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 1 tx path_id: 1
Not advertised to any peer
Last update: Wed Jan 11 04:45:42 2017
 
200
1003::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 2 tx path_id: 2
Not advertised to any peer
Last update: Wed Jan 11 04:45:42 2017
 
200
1004::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 3 tx path_id: 3
Not advertised to any peer
Last update: Wed Jan 11 04:45:42 2017
 
R3#show bgp ipv6 9999::/64
BGP routing table entry for 9999::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
2002::1 2003::1 2004::1
300
2001::1(fe80::5054:ff:fe46:f549) from 2001::1 (10.12.5.90)
(fe80::5054:ff:fe46:f549)
Origin IGP, metric 0, localpref 100, valid, external, best
rx path_id: -1 tx path_id: 0
Advertised to non peer-group peers:
3001::1
Last update: Wed Jan 11 03:52:32 2017
 
300
2002::1(fe80::5054:ff:fed2:4666) from 2002::1 (10.12.5.90)
(fe80::5054:ff:fed2:4666)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 1
Advertised to non peer-group peers:
3001::1
Last update: Wed Jan 11 03:52:27 2017
 
300
2003::1(fe80::5054:ff:fe0d:b565) from 2003::1 (10.12.5.90)
(fe80::5054:ff:fe0d:b565)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 2
Advertised to non peer-group peers:
3001::1
Last update: Wed Jan 11 03:52:37 2017
 
300
2004::1(fe80::5054:ff:feb5:9a71) from 2004::1 (10.12.5.90)
(fe80::5054:ff:feb5:9a71)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 3
Advertised to non peer-group peers:
3001::1
Last update: Wed Jan 11 03:52:44 2017
 
#show bgp ipv6
BGP table version is 283, local router ID is 10.12.5.92
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
*>i 1090::/64 1001::1 0 100 0 200 i
* i 1002::1 0 100 0 200 i
* i 1003::1 0 100 0 200 i
* i 1004::1 0 100 0 200 i
*> 9999::/64 2001::1(fe80::5054:ff:fe46:f549)
0 100 0 300 i
* 2002::1(fe80::5054:ff:fed2:4666)
0 100 0 300 i
* 2003::1(fe80::5054:ff:fe0d:b565)
0 100 0 300 i
* 2004::1(fe80::5054:ff:feb5:9a71)
0 100 0 300 i
 
Total number of prefixes 2
 
#show bgp ipv6 summary
BGP router identifier 10.12.5.92, local AS number 100
BGP table version is 283
2 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
2001::1 4 300 556 562 282 0 0 04:28:07 1
2002::1 4 300 556 560 283 0 0 04:28:07 1
2003::1 4 300 560 563 282 0 0 04:28:07 1
2004::1 4 300 543 546 283 0 0 04:28:03 1
3001::1 4 100 551 553 283 0 0 00:04:18 4
 
Total number of neighbors 5
 
Total number of Established sessions 5
 
#show bgp ipv6 neighbors 3001::1
BGP neighbor is 3001::1, remote AS 100, local AS 100, internal link
BGP version 4, remote router ID 10.12.5.93
BGP state = Established, up for 00:05:02
Last read 00:05:02, hold time is 90, keepalive interval is 30 seconds
Neighbor capabilities:
Route refresh: advertised and received (old and new)
Address family IPv4 Unicast: advertised and received
Address family IPv6 Unicast: advertised and received
Received 550 messages, 3 notifications, 0 in queue
Sent 553 messages, 2 notifications, 0 in queue
Route refresh request: received 0, sent 0
Minimum time between advertisement runs is 5 seconds
For address family: IPv4 Unicast
BGP table version 1, neighbor version 1
Index 5, Offset 0, Mask 0x20
Community attribute sent to this neighbor (both)
0 accepted prefixes
0 announced prefixes
 
For address family: IPv6 Unicast
BGP table version 283, neighbor version 283
Index 1, Offset 0, Mask 0x2
AF-dependant capabilities:
Add-Path Send Capability : advertised and received
Add-Path Receive Capability : advertised and received
Community attribute sent to this neighbor (both)
4 accepted prefixes
4 announced prefixes
 
Connections established 6; dropped 5
Local host: 3001::2, Local port: 39326
Foreign host: 3001::1, Foreign port: 179
Nexthop: 10.12.5.92
Nexthop global: 3001::2
Nexthop local: fe80::5054:ff:fe5d:bb79
BGP connection: shared network
Last Reset: 00:05:07, due to BGP Notification received
Notification Error Message: (Cease/Other Configuration Change.)
Selection of all Additional Paths at the Address-family Level
R2
 
#configure terminal
Enter the Configure mode.
(config)#router bgp 100
Enter BGP router mode
(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
(config-router-af)#bgp additional-paths send-receive
Configure R2 to send additional paths to and receive additional paths from all iBGP neighbors
(config-router-af)#bgp additional-paths select all
Configure R2 to select all available paths to send to all iBGP neighbors
(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
(config-router)#exit
Exit the router BGP mode and enter the config mode
(config)#commit
Apply commit
(config)#exit
Exit the config mode
Selection of all Additional Paths at the Neighbor Level
R2
 
#configure terminal
Enter the Configure mode.
(config)#router bgp 100
Enter BGP router mode
(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
(config-router-af)#neighbor 3001::2 additional-paths send
Configure R2 to send additional paths to and receive additional paths from all iBGP neighbors
(config-router-af)#neighbor 3001::2 advertise additional-paths all
Configure R2 to select all available paths to send to all iBGP neighbors
(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
(config-router)#exit
Exit the router BGP mode and enter the config mode
(config)#commit
Apply commit
(config)#exit
Exit the config mode
Validation
R2
#show bgp ipv6 1090::/64
BGP routing table entry for 1090::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
1002::1 1003::1 1004::1
200
1001::1(fe80::5054:ff:fe9c:b7e6) from 1001::1 (10.12.5.144)
(fe80::5054:ff:fe9c:b7e6)
Origin IGP, metric 0, localpref 100, valid, external, best
rx path_id: -1 tx path_id: 0
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:53:54 2017
 
200
1002::1(fe80::5054:ff:fe0d:f5e) from 1002::1 (10.12.5.144)
(fe80::5054:ff:fe0d:f5e)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 1
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:54:01 2017
 
200
1003::1(fe80::5054:ff:fec7:1940) from 1003::1 (10.12.5.144)
(fe80::5054:ff:fec7:1940)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 2
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:53:52 2017
 
200
1004::1(fe80::5054:ff:fe62:70d8) from 1004::1 (10.12.5.144)
(fe80::5054:ff:fe62:70d8)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 3
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 03:53:48 2017
R3
#show bgp ipv6 1090::
BGP routing table entry for 1090::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
2001::1 2002::1 2003::1 2004::1
200
1001::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal, best
rx path_id: 0 tx path_id: 0
Not advertised to any peer
Last update: Wed Jan 11 05:52:01 2017
 
200
1004::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 3 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 05:52:43 2017
 
200
1003::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 2 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 05:52:43 2017
 
200
1002::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 1 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 05:52:43 2017
Selection of Best 2 Additional Paths at AF Level
R2
 
#configure terminal
Enter the Configure mode.
(config)#router bgp 100
Enter BGP router mode
(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
(config-router-af)#bgp additional-paths send
Configure R2 to send additional paths to the iBGP neighbor R3
(config-router-af)#bgp additional-paths select best 2
Configure R2 to select best 2 out of all available paths to all iBGP neighbors
(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
(config-router)#exit
Exit the router BGP mode and enter the config mode
(config)#commit
Apply commit
(config)#exit
Exit the config mode
Selection of Best 2 Additional Paths at the Neighbor Level
R2
 
#configure terminal
Enter the Configure mode.
(config)#router bgp 100
Enter BGP router mode
(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
(config-router-af)#neighbor 3001::2 additional-paths send
Configure R2 to send additional paths to the iBGP neighbor R3
(config-router-af)#neighbor 3001::2 advertise additional-paths best 2
Configure R2 to advertise best 2 out of all available paths to R3
(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
(config-router)#exit
Exit the router BGP mode and enter the config mode
(config)#commit
Apply commit
(config)#exit
Exit the config mode
Validation
R2
#show bgp ipv6 1090::/64
BGP routing table entry for 1090::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
1002::1 1003::1 1004::1
200
1001::1(fe80::5054:ff:fe9c:b7e6) from 1001::1 (10.12.5.144)
(fe80::5054:ff:fe9c:b7e6)
Origin IGP, metric 0, localpref 100, valid, external, best
rx path_id: -1 tx path_id: 0
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 06:34:49 2017
 
200
1002::1(fe80::5054:ff:fe0d:f5e) from 1002::1 (10.12.5.144)
(fe80::5054:ff:fe0d:f5e)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 1
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 06:34:49 2017
 
200
1003::1(fe80::5054:ff:fec7:1940) from 1003::1 (10.12.5.144)
(fe80::5054:ff:fec7:1940)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 06:34:49 2017
 
200
1004::1(fe80::5054:ff:fe62:70d8) from 1004::1 (10.12.5.144)
(fe80::5054:ff:fe62:70d8)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 06:34:49 2017
 
R3
#show bgp ipv6 1090::
BGP routing table entry for 1090::/64
Paths: (2 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
2001::1 2002::1 2003::1 2004::1
200
1001::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal, best
rx path_id: 0 tx path_id: 0
Not advertised to any peer
Last update: Wed Jan 11 06:34:49 2017
 
200
1002::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 1 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 06:34:49 2017
#show bgp ipv6
BGP table version is 407, local router ID is 10.12.5.92
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
*>i 1090::/64 1001::1 0 100 0 200 i
* i 1002::1 0 100 0 200 i
*> 9999::/64 2001::1(fe80::5054:ff:fe46:f549)
0 100 0 300 i
* 2002::1(fe80::5054:ff:fed2:4666)
0 100 0 300 i
* 2003::1(fe80::5054:ff:fe0d:b565)
0 100 0 300 i
* 2004::1(fe80::5054:ff:feb5:9a71)
0 100 0 300 i
 
Total number of prefixes 2
Selection of Best 3 Additional Paths at the AF Level
R2
 
#configure terminal
Enter the Configure mode.
(config)#router bgp 100
Enter BGP router mode
(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
(config-router-af)#bgp additional-paths send
Configure R2 to send additional paths to the iBGP neighbor R3
(config-router-af)#bgp additional-paths select best 3
Configure R2 to select best 3 out of all available paths to all iBGP neighbors
(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
(config-router)#exit
Exit the router BGP mode and enter the config mode
(config)#commit
Apply commit
(config)#exit
Exit the config mode
Selection of Best 3 Additional Paths at the Neighbor Level
R2
 
#configure terminal
Enter the Configure mode.
(config)#router bgp 100
Enter BGP router mode
(config-router)#address-family ipv6 unicast
Enter address-family mode for neighbor router session to activate.
(config-router-af)#neighbor 3001::2 additional-paths send
Configure R2 to send additional paths to the iBGP neighbor R3
(config-router-af)#neighbor 3001::2 advertise additional-paths best 3
Configure R2 to advertise best 3 out of all available paths to R3
(config-router-af)#exit-address-family
Exit Address Family mode and return to Router mode.
(config-router)#exit
Exit the router BGP mode and enter the config mode
(config)#commit
Apply commit
(config)#exit
Exit the config mode
Validation
R2
#show bgp ipv6 1090::/64
BGP routing table entry for 1090::/64
Paths: (4 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
1002::1 1003::1 1004::1
200
1001::1(fe80::5054:ff:fe9c:b7e6) from 1001::1 (10.12.5.144)
(fe80::5054:ff:fe9c:b7e6)
Origin IGP, metric 0, localpref 100, valid, external, best
rx path_id: -1 tx path_id: 0
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 06:34:49 2017
 
200
1002::1(fe80::5054:ff:fe0d:f5e) from 1002::1 (10.12.5.144)
(fe80::5054:ff:fe0d:f5e)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 1
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 06:34:49 2017
 
200
1003::1(fe80::5054:ff:fec7:1940) from 1003::1 (10.12.5.144)
(fe80::5054:ff:fec7:1940)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: 2
Advertised to non peer-group peers:
3001::2
Last update: Wed Jan 11 06:34:49 2017
 
200
1004::1(fe80::5054:ff:fe62:70d8) from 1004::1 (10.12.5.144)
(fe80::5054:ff:fe62:70d8)
Origin IGP, metric 0, localpref 100, valid, external
rx path_id: -1 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 06:34:49 2017
R3
#show bgp ipv6 1090::/64
BGP routing table entry for 1090::/64
Paths: (3 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
2001::1 2002::1 2003::1 2004::1
200
1001::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal, best
rx path_id: 0 tx path_id: 0
Not advertised to any peer
Last update: Wed Jan 11 06:36:11 2017
 
200
1003::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 2 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 06:36:53 2017
 
200
1002::1 (metric 20) from 3001::1 (10.12.5.93)
Origin IGP, metric 0, localpref 100, valid, internal
rx path_id: 1 tx path_id: -1
Not advertised to any peer
Last update: Wed Jan 11 06:36:53 2017
 
#show bgp ipv6
BGP table version is 410, local router ID is 10.12.5.92
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, l - labeled
S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
*>i 1090::/64 1001::1 0 100 0 200 i
* i 1003::1 0 100 0 200 i
* i 1002::1 0 100 0 200 i
*> 9999::/64 2001::1(fe80::5054:ff:fe46:f549)
0 100 0 300 i
* 2002::1(fe80::5054:ff:fed2:4666)
0 100 0 300 i
* 2003::1(fe80::5054:ff:fe0d:b565)
0 100 0 300 i
* 2004::1(fe80::5054:ff:feb5:9a71)
0 100 0 300 i
 
Total number of prefixes 2