OcNOS-SP : Layer 3 Guide : Layer 3 Unicast Configuration Guide : BGP MPLS Next Hop Tracking Configuration
BGP MPLS Next Hop Tracking Configuration
MPLS nexthop tracking is used to track the registered next-hop in the NSM. It helps to notify the client when the LSP operational status changes, so that clients can take action accordingly.
BGP shall do lookup with NSM for LSP reachability, if lookup is successful, BGP marks the nexthop as reachable and register with NSM for the LSP tracking. Further proceeds for FTN/ILM installation and route advertisement. If it is down or does not exist, BGP will mark it as in-valid, route advertisement will not happen until LSP is reachable, BGP query NSM for every rib scan.
Note: QOS should be enabled in all devices for this feature.
Topology
BGP MPLS Next Hop Tracking
Configuration
PE1
 
#configure terminal
Enter the Configure mode.
(config)#interface lo
Enter interface mode
(config-if)#ip address 1.1.1.1/32 secondary
Configure the IP address of the interface loopback
(config-if)#exit
Exit interface mode
(config)# commit
Committing the configuration to apply in running configuration
(config)# router ldp
Configure Router LDP instance
(config)# commit
Committing the configuration to apply in running configuration
(config)# bfd interval 3 minrx 3 multiplier 3
Configure BFD single-hop sessions timer and reception interval in millisecond and the Hello multiplier.
(config)# commit
Committing the configuration to apply in running configuration
(config)#interface xe4
Enter interface mode
(config-if)#ip address 20.20.40.40/31
Configure the IP address on the interface
(config-if)#label-switching
Enable label-switching on interface
(config-if)# enable-ldp ipv4
Enable LDP process on interface
(config-if)#exit
Exit interface mode.
(config)# commit
Committing the configuration to apply in running configuration
(config)#router ospf 1
Configure the routing process OSPF with process id
(config-router)# bfd all-interfaces
Enable BFD for all neighbors.
(config-router)#network 1.1.1.1/32 area 0
Define the interface on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area).
(config-router)#network 20.20.40.40/31 area 0
Define the interface on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area).
(config-router)#exit
Exit from router ospf mode
(config)# commit
Committing the configuration to apply in running configuration
(config)#bgp nexthop-trigger enable
Enable Nexthop tracking.
(config)# commit
Committing the configuration to apply in running configuration
(config)#router bgp 100
Enter Router BGP mode
(config-router)# mpls-nexthop-tracking
Enable MPLS Next Hop tracking
(config-router)#allocate-label all
Allocate labels for all IPv4 prefixes advertised
(config-router)#neighbor 4.4.4.4 remote-as 100
Add loopback ip of PE2 as neighbor with neighbor AS
(config-router)#neighbor 4.4.4.4 update- source lo
Update the source for that particular neighbor as loopback interface
(config-router)#neighbor 2.2.2.2 remote-as 100
Add loopback ip of ABR1 as neighbor with neighbor AS
(config-router)#neighbor 2.2.2.2 update- source lo
Update the source for that particular neighbor as loopback interface
(config-router)# neighbor 2.2.2.2 fall-over bfd multihop
Enabling BFD at BGP level for particular neighbor.
(config-router)# address-family ipv4 unicast
Enter address-family ipv4 unicast mode
(config-router-af)# network 1.1.1.1/32
Advertise a route via iBGP connection.
(config-router-af)#exit-address-family
Exit from address family IPv4 unicast
(config-router)#address-family ipv4 labeled- unicast
Enter into labeled-unicast address family
(config-router-af)#neighbor 2.2.2.2 activate
Activate the neighbor inside labeled-unicast address family
(config-router-af)#exit-address-family
Exit from address family IPv4 labeled unicast
(config-router)#address-family vpnv4 unicast
Enter into vpnv4 unicast address family
(config-router-af)#neighbor 4.4.4.4 activate
Activate the neighbor inside vpnv4 address family
(config-router-af)#exit-address-family
Exit from address family vpnv4
(config-router)#exit
Exit from router BGP mode
(config)# commit
Committing the configuration to apply in running configuration
(config)#end
Exit from config mode into privilege mode
 
 
ABR1
 
#configure terminal
Enter the Configure mode.
(config)#interface lo
Enter interface mode
(config-if)#ip address 2.2.2.2/32 Secondary
Configure the IP address of the interface loopback
(config-if)#exit
Exit interface mode
(config)# commit
Committing the configuration to apply in running configuration
(config)# router ldp
Configure Router LDP instance
(config)# commit
Committing the configuration to apply in running configuration
(config)# bfd interval 3 minrx 3 multiplier 3
Configure BFD single-hop sessions timer and reception interval in millisecond and the Hello multiplier.
(config)# commit
Committing the configuration to apply in running configuration
(config)#interface xe4
Enter interface mode
(config-if)#ip address 20.20.40.41/31
Configure the IP address on the interface
(config-if)#label-switching
Enable label-switching on interface
(config-if)# enable-ldp ipv4
Enable LDP process on interface
(config-if)#exit
Exit interface mode.
(config)#interface xe10
Enter interface mode
(config-if)#ip address 20.20.40.48/31
Configure the IP address on the interface
(config-if)#label-switching
Enable label-switching on interface
(config-if)# enable-ldp ipv4
Enable LDP process on interface
(config-if)#exit
Exit interface mode.
(config)# commit
Committing the configuration to apply in running configuration
(config)# enable ext-ospf-multi-inst
Enable multiple-instance capability.
(config)# commit
Committing the configuration to apply in running configuration
(config)#router ospf 1
Configure the routing process OSPF with process id
(config)# bfd all-interfaces
Enable BFD for all neighbors.
(config-router)#network 2.2.2.2/32 area 0
Define the interface on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area).
(config-router)#network 20.20.40.40/31 area 0
Define the interface on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area).
(config-router)#exit
Exit from router ospf mode
(config)#router ospf 2
Configure the routing process OSPF with process id
(config)# bfd all-interfaces
Enable BFD for all neighbors.
(config)# redistribute connected
Redistribute connected routes.
(config-router)#network 2.2.2.2/32 area 0 instance-id 2
Advertise the network in Area 0 with an instance ID of 2.
(config-router)#network 20.20.40.48/31 area 0
Define the interface on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area).
(config-router)#exit
Exit from router ospf mode
(config)# commit
Committing the configuration to apply in running configuration
(config)#bgp nexthop-trigger enable
Enable Nexthop tracking.
(config)# commit
Committing the configuration to apply in running configuration
(config)#router bgp 100
Enter Router BGP mode
(config-router)# mpls-nexthop-tracking
Enable MPLS Next Hop tracking
(config-router)#allocate-label all
Allocate labels for all IPv4 prefixes advertised
(config-router)#neighbor 1.1.1.1 remote-as 100
Add loopback ip of PE1 as neighbor with neighbor AS
(config-router)#neighbor 1.1.1.1 update- source lo
Update the source for that particular neighbor as loopback interface
(config-router)# neighbor 1.1.1.1 fall-over bfd multihop
Enabling BFD at BGP level for particular neighbor.
(config-router)#neighbor 3.3.3.3 remote-as 100
Add loopback ip of ABR2 as neighbor with neighbor AS
(config-router)#neighbor 3.3.3.3 update- source lo
Update the source for that particular neighbor as loopback interface
(config-router)# neighbor 3.3.3.3 fall-over bfd multihop
Enabling BFD at BGP level for particular neighbor.
(config-router)# address-family ipv4 unicast
Enter address-family ipv4 unicast mode
(config-router-af)# network 2.2.2.2/32
Advertise a route via iBGP connection.
(config-router-af)#exit-address-family
Exit from address family IPv4 unicast
(config-router)#address-family ipv4 labeled- unicast
Enter into labeled-unicast address family
(config-router-af)#neighbor 1.1.1.1 activate
Activate the neighbor inside labeled-unicast address family
(config-router-af)# neighbor 1.1.1.1 route-reflector-client
Configure the router as Route-reflector (RR) and Neighbor router as its client.
(config-router-af)# neighbor 1.1.1.1 next-hop-self
Enable next hop self for the particular neighbor inside address family IPv4 labeled unicast.
(config-router-af)#neighbor 3.3.3.3 activate
Activate the neighbor inside labeled-unicast address family
(config-router-af)# neighbor 3.3.3.3 route-reflector-client
Configure the router as Route-reflector (RR) and Neighbor router as its client.
(config-router-af)# neighbor 3.3.3.3 next-hop-self
Enable next hop self for the particular neighbor inside address family IPv4 labeled unicast.
(config-router-af)#exit-address-family
Exit from address family IPv4 labeled unicast
(config-router)#exit
Exit from router BGP mode
(config)# commit
Committing the configuration to apply in running configuration
(config)#end
Exit from config mode into privilege mode
ABR2
 
#configure terminal
Enter the Configure mode.
(config)#interface lo
Enter interface mode
(config-if)#ip address 3.3.3.3/32
Configure the IP address of the interface loopback
(config-if)#exit
Exit interface mode
(config)# commit
Committing the configuration to apply in running configuration
(config)# router ldp
Configure Router LDP instance
(config)# commit
Committing the configuration to apply in running configuration
(config)# bfd interval 3 minrx 3 multiplier 3
Configure BFD single-hop sessions timer and reception interval in millisecond and the Hello multiplier.
(config)# commit
Committing the configuration to apply in running configuration
(config)#interface xe5
Enter interface mode
(config-if)#ip address 20.20.40.38/31
Configure the IP address on the interface
(config-if)#label-switching
Enable label-switching on interface
(config-if)# enable-ldp ipv4
Enable LDP process on interface
(config-if)#exit
Exit interface mode.
(config)#interface xe10
Enter interface mode
(config-if)#ip address 20.20.40.49/31
Configure the IP address on the interface
(config-if)#label-switching
Enable label-switching on interface
(config-if)# enable-ldp ipv4
Enable LDP process on interface
(config-if)#exit
Exit interface mode.
(config)# commit
Committing the configuration to apply in running configuration
(config)# enable ext-ospf-multi-inst
Enable multiple-instance capability.
(config)# commit
Committing the configuration to apply in running configuration
(config)#router ospf 2
Configure the routing process OSPF with process id
(config)# bfd all-interfaces
Enable BFD for all neighbors.
(config)# redistribute connected
Redistribute connected routes.
(config-router)#network 3.3.3.3/32 area 0
Define the interface on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area).
(config-router)#network 20.20.40.48/31 area 0
Define the interface on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area).
(config-router)#exit
Exit from router ospf mode
(config)#router ospf 3
Configure the routing process OSPF with process id
(config)# bfd all-interfaces
Enable BFD for all neighbors.
(config-router)#network 2.2.2.2/32 area 0 instance-id 3
Advertise the network in Area 0 with an instance ID of 2.
(config-router)#network 20.20.40.38/31 area 0
Define the interface on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area).
(config-router)#exit
Exit from router ospf mode
(config)# commit
Committing the configuration to apply in running configuration
(config)#bgp nexthop-trigger enable
Enable Nexthop tracking.
(config)# commit
Committing the configuration to apply in running configuration
(config)#router bgp 100
Enter Router BGP mode
(config-router)# mpls-nexthop-tracking
Enable MPLS Next Hop tracking
(config-router)#allocate-label all
Allocate labels for all IPv4 prefixes advertised
(config-router)#neighbor 4.4.4.4 remote-as 100
Add loopback ip of PE2 as neighbor with neighbor AS
(config-router)#neighbor 4.4.4.4 update- source lo
Update the source for that particular neighbor as loopback interface
(config-router)# neighbor 4.4.4.4 fall-over bfd multihop
Enabling BFD at BGP level for particular neighbor.
(config-router)#neighbor 2.2.2.2 remote-as 100
Add loopback ip of ABR1 as neighbor with neighbor AS
(config-router)#neighbor 2.2.2.2 update- source lo
Update the source for that particular neighbor as loopback interface
(config-router)# neighbor 2.2.2.2 fall-over bfd multihop
Enabling BFD at BGP level for particular neighbor.
(config-router)# address-family ipv4 unicast
Enter address-family ipv4 unicast mode
(config-router-af)# network 2.2.2.2/32
Advertise a route via iBGP connection.
(config-router-af)#exit-address-family
Exit from address family IPv4 unicast
(config-router)#address-family ipv4 labeled- unicast
Enter into labeled-unicast address family
(config-router-af)#neighbor 2.2.2.2 activate
Activate the neighbor inside labeled-unicast address family
(config-router-af)# neighbor 2.2.2.2 route-reflector-client
Configure the router as Route-reflector (RR) and Neighbor router as its client.
(config-router-af)# neighbor 2.2.2.2 next-hop-self
Enable next hop self for the particular neighbor inside address family IPv4 labeled unicast.
(config-router-af)#neighbor 4.4.4.4 activate
Activate the neighbor inside labeled-unicast address family
(config-router-af)# neighbor 4.4.4.4 route-reflector-client
Configure the router as Route-reflector (RR) and Neighbor router as its client.
(config-router-af)# neighbor 4.4.4.4 next-hop-self
Enable next hop self for the particular neighbor inside address family IPv4 labeled unicast.
(config-router-af)#exit-address-family
Exit from address family IPv4 labeled unicast
(config-router)#exit
Exit from router BGP mode
(config)# commit
Committing the configuration to apply in running configuration
(config)#end
Exit from config mode into privilege mode
PE2
 
#configure terminal
Enter the Configure mode.
(config)#interface lo
Enter interface mode
(config-if)#ip address 4.4.4.4/32 secondary
Configure the IP address of the interface loopback
(config-if)#exit
Exit interface mode
(config)# commit
Committing the configuration to apply in running configuration
(config)# router ldp
Configure Router LDP instance
(config)# commit
Committing the configuration to apply in running configuration
(config)# bfd interval 3 minrx 3 multiplier 3
Configure BFD single-hop sessions timer and reception interval in millisecond and the Hello multiplier.
(config)# commit
Committing the configuration to apply in running configuration
(config)#interface xe5
Enter interface mode
(config-if)#ip address 20.20.40.39/31
Configure the IP address on the interface
(config-if)#label-switching
Enable label-switching on interface
(config-if)# enable-ldp ipv4
Enable LDP process on interface
(config-if)#exit
Exit interface mode.
(config)# commit
Committing the configuration to apply in running configuration
(config)#router ospf 3
Configure the routing process OSPF with process id
(config)# bfd all-interfaces
Enable BFD for all neighbors.
(config-router)#network 3.3.3.3/32 area 0
Define the interface on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area).
(config-router)#network 20.20.40.38/31 area 0
Define the interface on which OSPF runs, and associate the area ID (0) with the interface (area ID 0 specifies the backbone area).
(config-router)#exit
Exit from router ospf mode
(config)# commit
Committing the configuration to apply in running configuration
(config)#bgp nexthop-trigger enable
Enable Nexthop tracking.
(config)# commit
Committing the configuration to apply in running configuration
(config)#router bgp 100
Enter Router BGP mode
(config-router)# mpls-nexthop-tracking
Enable MPLS Next Hop tracking
(config-router)#allocate-label all
Allocate labels for all IPv4 prefixes advertised
(config-router)#neighbor 1.1.1.1 remote-as 100
Add loopback ip of PE1 as neighbor with neighbor AS
(config-router)#neighbor 1.1.1.1 update- source lo
Update the source for that particular neighbor as loopback interface
(config-router)# neighbor 1.1.1.1 fall-over bfd multihop
Enabling BFD at BGP level for particular neighbor.
(config-router)#neighbor 3.3.3.3 remote-as 100
Add loopback ip of ABR2 as neighbor with neighbor AS
(config-router)#neighbor 3.3.3.3 update- source lo
Update the source for that particular neighbor as loopback interface
(config-router)# neighbor 3.3.3.3 fall-over bfd multihop
Enabling BFD at BGP level for particular neighbor.
(config-router)# address-family ipv4 unicast
Enter address-family ipv4 unicast mode
(config-router-af)# network 4.4.4.4/32
Advertise a route via iBGP connection.
(config-router-af)#exit-address-family
Exit from address family IPv4 unicast
(config-router)#address-family ipv4 labeled- unicast
Enter into labeled-unicast address family
(config-router-af)#neighbor 3.3.3.3 activate
Activate the neighbor inside labeled-unicast address family
(config-router-af)#exit-address-family
Exit from address family IPv4 labeled unicast
(config-router)#address-family vpnv4 unicast
Enter into vpnv4 unicast address family
(config-router-af)#neighbor 1.1.1.1 activate
Activate the neighbor inside vpnv4 address family
(config-router-af)#exit-address-family
Exit from address family vpnv4
(config-router)#exit
Exit from router BGP mode
(config)# commit
Committing the configuration to apply in running configuration
(config)#end
Exit from config mode into privilege mode
 
Validation
PE1
PE1#show ip bgp labeled-unicast summary
BGP router identifier 1.1.1.1, local AS number 100
BGP table version is 3
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
2.2.2.2 4 100 90 89 3 0 0 00:36:22 3
 
Total number of neighbors 1
 
Total number of Established sessions 1
 
 
PE1#show bgp nexthop-tracking
Configured NHT: ENABLED
NHT Delay time-interval : 5
Configured MPLS NHT: ENABLED
BGP VRF: (Default) VRF_ID 0
BGP Instance: (Default), AS: 100, router-id 1.1.1.1
NHT is Enabled
Recvd Msg count from RIB: 0
NHT delay-timer remaining seconds: 0
BGP nexthop(s):
2.2.2.2 Registered (MPLS also Registered)
Total number of IPV4 nexthops : 1
Total number of IPV6 nexthops : 0
 
PE1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.2 xe4 Passive OPERATIONAL 30 00:38:06
 
PE1#show ip bgp vpnv4 all summary
BGP router identifier 1.1.1.1, local AS number 100
BGP table version is 1
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
4.4.4.4 4 100 92 93 1 0 0 00:38:49 0
 
Total number of neighbors 1
 
Total number of Established sessions 1
 
PE1#show ip ospf neighbor
 
Total number of full neighbors: 1
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
2.2.2.2 1 Full/Backup 00:00:34 20.20.40.41 xe4 0
 
PE1#show ip route
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
ia - IS-IS inter area, E - EVPN,
v - vrf leaked
* - candidate default
 
IP Route Table for VRF "default"
C 1.1.1.1/32 is directly connected, lo, 00:59:57
O 2.2.2.2/32 [110/2] via 20.20.40.41, xe4, 00:40:05
B 3.3.3.3/32 [200/0] via 2.2.2.2 (recursive via 20.20.40.41), 00:36:31
B 4.4.4.4/32 [200/0] via 2.2.2.2 (recursive via 20.20.40.41), 00:36:31
C 20.20.40.40/31 is directly connected, xe4, 00:58:24
C 127.0.0.0/8 is directly connected, lo, 01:06:14
 
Gateway of last resort is not set
 
PE2
 
PE2#show ip bgp labeled-unicast summary
BGP router identifier 4.4.4.4, local AS number 100
BGP table version is 3
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Dow
n State/PfxRcd
3.3.3.3 4 100 103 102 3 0 0 00:41:58
3
 
Total number of neighbors 1
 
Total number of Established sessions 1
PE2#show bgp nexthop-tracking
Configured NHT: ENABLED
NHT Delay time-interval : 5
Configured MPLS NHT: ENABLED
BGP VRF: (Default) VRF_ID 0
BGP Instance: (Default), AS: 100, router-id 4.4.4.4
NHT is Enabled
Recvd Msg count from RIB: 0
NHT delay-timer remaining seconds: 0
BGP nexthop(s):
3.3.3.3 Registered (MPLS also Registered)
Total number of IPV4 nexthops : 1
Total number of IPV6 nexthops : 0
 
PE2#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
3.3.3.3 xe5 Active OPERATIONAL 30 00:42:33
PE2#show bgp vpn
PE2#show ip bgp vpnv4 all summary
BGP router identifier 4.4.4.4, local AS number 100
BGP table version is 1
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Dow
n State/PfxRcd
1.1.1.1 4 100 99 99 1 0 0 00:41:48
0
 
Total number of neighbors 1
 
Total number of Established sessions 1
PE2#show ip ospf neighbor
 
Total number of full neighbors: 1
OSPF process 3 VRF(default):
Neighbor ID Pri State Dead Time Address Interface
Instance ID
3.3.3.3 1 Full/Backup 00:00:35 20.20.40.38 xe5
0
PE2#show ip route
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
ia - IS-IS inter area, E - EVPN,
v - vrf leaked
* - candidate default
 
IP Route Table for VRF "default"
B 1.1.1.1/32 [200/0] via 3.3.3.3 (recursive via 20.20.40.38), 00:42:1
7
B 2.2.2.2/32 [200/0] via 3.3.3.3 (recursive via 20.20.40.38), 00:42:1
7
O 3.3.3.3/32 [110/2] via 20.20.40.38, xe5, 00:44:10
C 4.4.4.4/32 is directly connected, lo, 01:05:50
C 20.20.40.38/31 is directly connected, xe5, 01:01:12
C 127.0.0.0/8 is directly connected, lo, 01:11:16
 
Gateway of last resort is not set
ABR1
 
ABR1#show ip ospf neighbor
 
Total number of full neighbors: 1
OSPF process 1 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
1.1.1.1 1 Full/DR 00:00:34 20.20.40.40 xe4 0
 
Total number of full neighbors: 1
OSPF process 2 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
3.3.3.3 1 Full/Backup 00:00:37 20.20.40.49 xe10 0
ABR1#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
1.1.1.1 xe4 Active OPERATIONAL 30 00:46:10
3.3.3.3 xe10 Passive OPERATIONAL 30 00:43:55
ABR1#sh ip bgp vpnv4 all summary
ABR1#sh ip bgp labeled-unicast summary
BGP router identifier 2.2.2.2, local AS number 100
BGP table version is 2
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
1.1.1.1 4 100 113 113 2 0 0 00:46:44 1
3.3.3.3 4 100 109 111 2 0 0 00:45:10 2
 
Total number of neighbors 2
 
Total number of Established sessions 2
ABR1#show ip route
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
ia - IS-IS inter area, E - EVPN,
v - vrf leaked
* - candidate default
 
IP Route Table for VRF "default"
O 1.1.1.1/32 [110/2] via 20.20.40.40, xe4, 00:47:19
C 2.2.2.2/32 is directly connected, lo, 01:07:16
O 3.3.3.3/32 [110/2] via 20.20.40.49, xe10, 00:45:26
B 4.4.4.4/32 [200/0] via 3.3.3.3 (recursive via 20.20.40.49), 00:43:51
O E2 20.20.40.38/31 [110/20] via 20.20.40.49, xe10, 00:45:26
C 20.20.40.40/31 is directly connected, xe4, 00:58:36
C 20.20.40.48/31 is directly connected, xe10, 00:58:23
C 127.0.0.0/8 is directly connected, lo, 01:14:00
 
Gateway of last resort is not set
 
ABR1#show bgp nexthop-tracking
Configured NHT: ENABLED
NHT Delay time-interval : 5
Configured MPLS NHT: ENABLED
BGP VRF: (Default) VRF_ID 0
BGP Instance: (Default), AS: 100, router-id 2.2.2.2
NHT is Enabled
Recvd Msg count from RIB: 0
NHT delay-timer remaining seconds: 0
BGP nexthop(s):
1.1.1.1 Registered (MPLS also Registered)
3.3.3.3 Registered (MPLS also Registered)
Total number of IPV4 nexthops : 2
Total number of IPV6 nexthops : 0
 
ABR2
 
ABR2#show ip ospf neighbor
 
Total number of full neighbors: 1
OSPF process 2 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
2.2.2.2 1 Full/DR 00:00:37 20.20.40.48 xe10 0
 
Total number of full neighbors: 1
OSPF process 3 VRF(default):
Neighbor ID Pri State Dead Time Address Interface Instance ID
4.4.4.4 1 Full/DR 00:00:36 20.20.40.39 xe5 0
ABR2#
ABR2#show ldp session
Peer IP Address IF Name My Role State KeepAlive UpTime
2.2.2.2 xe10 Active OPERATIONAL 30 00:46:31
4.4.4.4 xe5 Passive OPERATIONAL 30 00:47:20
ABR2#show ip bgp labeled-unicast summary
BGP router identifier 3.3.3.3, local AS number 100
BGP table version is 2
1 BGP AS-PATH entries
0 BGP community entries
 
Neighbor V AS MsgRcv MsgSen TblVer InQ OutQ Up/Down State/PfxRcd
2.2.2.2 4 100 115 114 2 0 0 00:47:21 2
4.4.4.4 4 100 114 115 2 0 0 00:47:21 1
 
Total number of neighbors 2
 
Total number of Established sessions 2
ABR2#show ip route
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
ia - IS-IS inter area, E - EVPN,
v - vrf leaked
* - candidate default
 
IP Route Table for VRF "default"
B 1.1.1.1/32 [200/0] via 2.2.2.2 (recursive via 20.20.40.48), 00:46:06
O 2.2.2.2/32 [110/2] via 20.20.40.48, xe10, 00:47:51
C 3.3.3.3/32 is directly connected, lo, 01:09:37
O 4.4.4.4/32 [110/2] via 20.20.40.39, xe5, 00:47:51
C 20.20.40.38/31 is directly connected, xe5, 00:48:33
O E2 20.20.40.40/31 [110/20] via 20.20.40.48, xe10, 00:47:51
C 20.20.40.48/31 is directly connected, xe10, 00:48:44
C 127.0.0.0/8 is directly connected, lo, 01:15:15
 
Gateway of last resort is not set
ABR2#show bgp nexthop-tracking
Configured NHT: ENABLED
NHT Delay time-interval : 5
Configured MPLS NHT: ENABLED
BGP VRF: (Default) VRF_ID 0
BGP Instance: (Default), AS: 100, router-id 3.3.3.3
NHT is Enabled
Recvd Msg count from RIB: 0
NHT delay-timer remaining seconds: 0
BGP nexthop(s):
2.2.2.2 Registered (MPLS also Registered)
4.4.4.4 Registered (MPLS also Registered)
Total number of IPV4 nexthops : 2
Total number of IPV6 nexthops : 0