OcNOS-SP : Layer 3 Guide : Layer 3 Unicast Configuration Guide : IS-IS IPv6 Configuration
IS-IS IPv6 Configuration
This chapter contains basic IS-IS (Intermediate System to Intermediate System) on IPv6 configuration examples.
Enable IS-ISv6 on an Interface
This example shows the minimum configuration required for enabling IS-IS on IPv6 on an interface. R1 and R2 are two routers in the ABC instance connecting to the network 1000::/64. After enabling IS-IS on an interface, create a routing instance, and specify the Network Entity Title (NET). IS-IS explicitly specifies a NET to begin routing. NET is comprised of the area address and the system ID of the router.
Note: ISISv6 session will come up even if IPv6 address is not configured, as it will use the link local address present on the interfaces.
 
Figure 4-46: Basic IS-IS v6 Topology
Configuration
R1
 
#configure terminal
Enter configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-ISv6 routing on an interface for area 49(ABC).
(config-if)#ipv6 address 1000::1/64
Configure IPv6 address on interface.
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#is-type level-2-only
Configure instance as level-2-only routing.
(config-router)#net 49.0005.0000.0000.0001.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#commit
Commit candidate configuration to the running configuration
R2
 
#configure terminal
Enter configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-ISv6 routing on an interface for area 49(ABC).
(config-if)#ipv6 address 1000::2/64
Configure IPv6 address on interface.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#is-type level-2-only
Configure instance as level-2-only routing.
(config-router)#net 49.0005.0000.0000.0002.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#commit
Commit candidate configuration to the running configuration
Validation
R1#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 1
Total number of adjacencies: 1
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0002 eth1 b86a.97c4.31c5 Up 27 L2 IS-IS
 
R2#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 1
Total number of adjacencies: 1
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0001 eth1 b86a.97cb.3ec5 Up 7 L2 IS-IS
R2#
 
R1#show ipv6 isis route
 
Codes: C - connected, E - external, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, D - discard, e - external metric
 
Tag ABC: VRF : default
C 1000::/64 [10]
via ::, eth1
 
R1#
 
R2#show ipv6 isis route
 
Codes: C - connected, E - external, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, D - discard, e - external metric
 
Tag ABC: VRF : default
C 1000::/64 [10]
via ::, eth1
 
R2#
 
R1#
R1#show ipv6 isis topology
 
Tag ABC: VRF : default
IS-IS paths to level-2 routers
System Id Metric Next-Hop Interface SNPA
0000.0000.0001 --
0000.0000.0002 10 0000.0000.0002 eth1 b86a.97c4.31c5
 
R1#
 
R2#show ipv6 isis topology
 
Tag ABC: VRF : default
IS-IS paths to level-2 routers
System Id Metric Next-Hop Interface SNPA
0000.0000.0001 10 0000.0000.0001 eth1 b86a.97cb.3ec5
0000.0000.0002 --
Set Priority
This example describes how to set the priority for an interface. Set a high priority for a router to make it the Designated IS (DIS). Router R3 is configured to have a priority of 70, this is higher than the default priority (64) of R1 and R2. This makes R3 the DIS.
 
Set IS-IS Priority
Configuration
R1
 
#configure terminal
Enter configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-ISv6 routing on an interface for area 49(ABC).
(config-if)#ipv6 address 1000::1/64
Configure IPv6 address on interface.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#is-type level-2-only
Configure instance as level-2-only routing.
(config-router)#net 49.0005.0000.0000.0001.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#commit
Commit candidate configuration to the running configuration
R2
 
#configure terminal
Enter configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-ISv6 routing on an interface for area 49(ABC).
(config-if)#ipv6 address 1000::2/64
Configure IPv6 address on interface.
(config-if)#isis priority 125
Specify the router priority to a higher priority (125) to make R2 the designated IS (DIS).
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#is-type level-2-only
Configure instance as level-2-only routing.
(config-router)#net 49.0005.0000.0000.0002.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#commit
Commit candidate configuration to the running configuration
Validation
R1#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 1
Total number of adjacencies: 1
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0002 eth1 b86a.97c4.31c5 Up 8 L2 IS-IS
R1#
 
R2#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 1
Total number of adjacencies: 1
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0001 eth1 b86a.97cb.3ec5 Up 26 L2 IS-IS
R2#
 
 
R1#show clns is-neighbors
 
Tag ABC: VRF : default
System Id Interface State Type Priority Circuit Id
0000.0000.0002 eth1 Up L2 125 0000.0000.0002.01
R1#
 
R2#show clns is-neighbors
 
Tag ABC: VRF : default
System Id Interface State Type Priority Circuit Id
0000.0000.0001 eth1 Up L2 64 0000.0000.0002.01
R2#
 
 
R1#show isis interface
eth1 is up, line protocol is up
Routing Protocol: IS-IS (ABC)
Network Type: Broadcast
Circuit Type: level-1-2
Local circuit ID: 0x01
Extended Local circuit ID: 0x00002722
Local SNPA: b86a.97cb.3ec5
IP interface address:
IPv6 interface address:
1000::1/64
fe80::ba6a:97ff:fecb:3ec5/64
Level-2 Metric: 10/10, Priority: 64, Circuit ID: 0000.0000.0002.01
Number of active level-2 adjacencies: 1
Level-2 LSP MTU: 1492
Next IS-IS LAN Level-2 Hello in 0 milliseconds
R1#
 
R2#show isis interface
eth1 is up, line protocol is up
Routing Protocol: IS-IS (ABC)
Network Type: Broadcast
Circuit Type: level-1-2
Local circuit ID: 0x01
Extended Local circuit ID: 0x00002722
Local SNPA: b86a.97c4.31c5
IP interface address:
IPv6 interface address:
1000::2/64
fe80::ba6a:97ff:fec4:31c5/64
Level-2 Metric: 10/10, Priority: 125, Circuit ID: 0000.0000.0002.01
Number of active level-2 adjacencies: 1
Level-2 LSP MTU: 1492
Next IS-IS LAN Level-2 Hello in 1 seconds
R2#
Dynamic hostname
This example shows how to configure Dynamic Hostname for an ISIS IPv6 instance. Dynamic hostname is the method of mapping name-to-systemID. It allows the routing protocol to advertise symbolic names in the IS-IS PDUs. This is done by the addition of a new TLV which allows the IS-IS routers to include the name-to-systemID mapping data in their LSPs. This allows for simple and reliable transport of name mapping across IS-IS networks.
Dynamic hostname can be either the hostname of the node or the tag of the configured ISISv6 instance.
Note: Dynamic-hostname has to be configured on all nodes for it to take effect.
 
Basic dynamic hostname topology
Configuration
R1
 
#configure terminal
Enter configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-ISv6 routing on an interface for area 49(ABC).
(config-if)#ipv6 address 1000::1/64
Configure IPv6 address on interface.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#is-type level-2-only
Configure instance as level-2-only routing.
(config-router)#net 49.0005.0000.0000.0001.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#dynamic-hostname
Configure the hostname to be advertised for an ISIS instance.
(config-router)#commit
Commit candidate configuration to the running configuration
(config-router)#end
Exit the current mode and enter privilege mode.
R2
 
#configure terminal
Enter configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-ISv6 routing on an interface for area 49(ABC).
(config-if)#ipv6 address 1000::2/64
Configure IPv6 address on interface.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#is-type level-2-only
Configure instance as level-2-only routing.
(config-router)#net 49.0005.0000.0000.0002.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#dynamic-hostname
Configure the hostname to be advertised for an ISIS instance.
(config-router)#commit
Commit candidate configuration to the running configuration
(config-router)#end
Exit the current mode and enter privilege mode.
Validation
R1#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 1
Total number of adjacencies: 1
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
R2 eth1 b86a.97c4.31c5 Up 20 L2 IS-IS
R1#
 
R2#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 1
Total number of adjacencies: 1
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
R1 eth1 b86a.97cb.3ec5 Up 8 L2 IS-IS
R2#
 
 
 
R1#show isis database
Tag ABC: VRF : default
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R1.00-00 * 0x00000008 0xFB86 1144 0/0/0
R1.01-00 * 0x00000005 0x19BD 1141 0/0/0
R2.00-00 0x00000007 0x245C 1140 0/0/0
 
R1#
 
R2#show isis database
Tag ABC: VRF : default
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R1.00-00 0x00000008 0xFB86 1144 0/0/0
R1.01-00 0x00000005 0x19BD 1140 0/0/0
R2.00-00 * 0x00000007 0x245C 1140 0/0/0
R2.01-00 * 0x00000002 0xE710 0 (1132) 0/0/0
 
R2#
 
 
 
R1#show ipv6 isis topology
 
Tag ABC: VRF : default
IS-IS paths to level-2 routers
System Id Metric Next-Hop Interface SNPA
R1 --
R2 10 R2 eth1 b86a.97c4.31c5
 
R1#
 
R2#show ipv6 isis topology
 
Tag ABC: VRF : default
IS-IS paths to level-2 routers
System Id Metric Next-Hop Interface SNPA
R1 10 R1 eth1 b86a.97cb.3ec5
R2 --
 
R2#
Redistribute Routes into IS-IS
In this example, the configuration causes OSPFv3 routes to be imported into the IS-ISv6 routing table, and advertised into the ABC instance.
 
Topology
Redistribute Routes into IS-IS
Configuration
R1
 
#configure terminal
Enter configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-ISv6 routing on an interface for area 49(ABC).
(config-if)#ipv6 address 1000::1/64
Configure IPv6 address on interface.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#is-type level-2-only
Configure instance as level-2-only routing.
(config-router)#net 49.0005.0000.0000.0001.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#commit
Commit candidate configuration to the running configuration
R2
 
#configure terminal
Enter configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-ISv6 routing on an interface for area 49(ABC).
(config-if)#ipv6 address 1000::2/64
Configure IPv6 address on interface.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#interface eth2
Enter interface mode.
(config-if)#ipv6 router ospf area 0
Enable OSPFv3 routing on an interface and assign the Area ID 0.
(config-if)#ipv6 address 2000::1/64
Configure IPv6 address on interface.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#is-type level-2-only
Configure instance as level-2-only routing.
(config-router)#net 49.0005.0000.0000.0002.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#address-family ipv6
Enter 'address-family ipv6' mode, where users can configure IPv6 routing specific configuration
(config-router-af)#redistribute ospf
Enable redistribution of routes from ospf into the ISIS routing table.
(config-router-af)# exit-address-family
Exit address family mode.
(config-router)#commit
Commit candidate configuration to the running configuration
(config-router)#exit
Exit router mode.
(config)#router ipv6 ospf
Create an OSPFv3 routing instance.
(config-router)#router-id 2.2.2.2
Specify a Router ID (2.2.2.2) for the OSPFv3 routing process.
(config-router)#end
Exit the current mode and enter privilege mode.
R3
#configure terminal
Enter configure mode.
(config)#interface eth2
Enter interface mode.
(config-if)#ipv6 router ospf area 0
Enable OSPFv3 routing on an interface and assign the Area ID 0.
(config-if)#ipv6 address 2000::2/64
Configure IPv6 address on interface.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router ipv6 ospf
Create an OSPFv3 routing instance.
(config-router)#router-id 3.3.3.3
Specify a Router ID (3.3.3.3) for the OSPFv3 routing process.
(config-router)#commit
Commit candidate configuration to the running configuration
(config-router)#end
Exit the current mode and enter privilege mode.
Validation
R1#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 1
Total number of adjacencies: 1
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0002 eth1 b86a.97c4.31c5 Up 27 L2 IS-IS
R1#
 
R2#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 1
Total number of adjacencies: 1
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0001 eth1 b86a.97cb.3ec5 Up 8 L2 IS-IS
R2#
 
R2#show ipv6 ospf neighbor
 
Total number of full neighbors: 1
OSPFv3 Process (*null*)
Neighbor ID Pri State Dead Time Interface Instance ID
3.3.3.3 1 Full/DR 00:00:34 eth2 0
R2#
 
 
R1#show ipv6 route isis
IP Route Table for VRF "default"
i L2 2000::/64 [115/10] via fe80::ba6a:97ff:fec4:31c5, eth1, 00:21:19
R1#
 
 
R1#show ipv6 route
IPv6 Routing Table
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
IA - OSPF inter area, E1 - OSPF external type 1,
E2 - OSPF external type 2, E - EVPN N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type 2, i - IS-IS, B - BGP
Timers: Uptime
 
IP Route Table for VRF "default"
C ::1/128 via ::, lo, 01:33:07
C 1000::/64 via ::, eth1, 01:13:36
i L2 2000::/64 [115/10] via fe80::ba6a:97ff:fec4:31c5, eth1, 00:21:29
C fe80::/64 via ::, xe8, 00:39:44
R1#
Interface Metric
You can make a route the preferred route by changing its metric. In this example, the cost has been configured to make R3 the next hop for R1.
The default metric for each interface is 10. Interface eth2 on R2 has a metric of 20, and Interface eth2 on R3 has a metric of 30. The total cost to reach 9999::/64 (R4) through R2 and R3 is computed as follows: R2: 10+20 = 30 R3: 10+30 = 40
In this topology, R1 chooses R2 as its next hop for destination 9999::/64.
Note: Below configuration is applicable for narrow (non-wide) metric-style. Wide metric can be configured by using the CLI's "metric-style wide" under isis instance and "isis wide-metric < 1-16777214>" under interface mode.
gy
Configure IS-IS Metric
Configuration
R1
 
#configure terminal
Enter configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-IS routing on an interface for area 49(ABC).
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#interface eth2
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-IS routing on an interface for area 49(ABC).
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#is-type level-2-only
Configure instance as level-2-only routing.
(config-router)#net 49.0100.0000.0000.0001.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#commit
Commit candidate configuration to the running configuration
(config-router)#end
Exit current mode and enter privilege mode.
R2
 
(config)#interface eth2
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-IS routing on an interface for area 49 (ABC).
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#interface eth3
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-IS routing on an interface for area 49 (ABC).
(config-if)#isis metric 20
Set the value of IS-IS metric (on eth2) to 20.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#is-type level-2-only
Configure instance as level-2-only routing.
(config-router)#net 49.0100.0000.0000.0002.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#commit
Commit candidate configuration to the running configuration
R3
 
(config)#interface eth1
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-IS routing on an interface for area 49 (ABC).
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#interface eth2
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-IS routing on an interface for area 49 (ABC).
(config-if)#isis metric 30
Set the value of IS-IS metric (on eth2) to 30.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#is-type level-2-only
Configure instance as level-2-only routing.
(config-router)#net 49.0100.0000.0000.0003.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#commit
Commit candidate configuration to the running configuration
R4
 
(config)#interface eth1
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-IS routing on an interface for area 49 (ABC).
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#interface eth2
Enter interface mode.
(config-if)#ipv6 address 9999::1/64
Configure ipv6 address in eth2
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#interface eth3
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-IS routing on an interface for area 49 (ABC).
(config-if)#ipv6 address 2000::2/64
Configure IPv6 address on interface.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#is-type level-2-only
Configure instance as level-2-only routing.
(config-router)#net 49.0100.0000.0000.0004.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#address-family ipv6
Enter ipv6 address family.
(config-router-af)#redistribute connected
Enable redistribution of connected routes into ISIS process
(config-router-af)#commit
Commit candidate configuration to the running configuration
(config-router-af)#end
Exit current mode and enter privilege mode
Validation
R1#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 2
Total number of adjacencies: 2
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0002 eth2 b86a.97c4.31c5 Up 25 L2 IS-IS
0000.0000.0003 eth1 b86a.97c9.3cc5 Up 26 L2 IS-IS
R1#
 
 
R2#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 2
Total number of adjacencies: 2
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0004 eth3 b86a.97c7.32c5 Up 7 L2 IS-IS
0000.0000.0001 eth2 b86a.97cb.3ec5 Up 6 L2 IS-IS
R2#
 
R3#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 2
Total number of adjacencies: 2
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0004 eth2 b86a.97c7.32c5 Up 22 L2 IS-IS
0000.0000.0001 eth1 b86a.97cb.3ec5 Up 7 L2 IS-IS
R3#
 
R4#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 2
Total number of adjacencies: 2
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0002 eth3 b86a.97c4.31c5 Up 22 L2 IS-IS
0000.0000.0003 eth1 b86a.97c9.3cc5 Up 7 L2 IS-IS
R4#
 
 
R1#show ipv6 isis route
 
Codes: C - connected, E - external, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, D - discard, e - external metric
 
Tag ABC: VRF : default
C 1000::/64 [10]
via ::, ce0
L2 2000::/64 [30]
via fe80::ce37:abff:fe87:3a74, ce0
C 3000::/64 [10]
via ::, xe14
L2 4000::/64 [40]
via fe80::ba6a:97ff:fecf:3ad4, xe14
via fe80::ce37:abff:fe87:3a74, ce0
L2 9999::/64 [30]
via fe80::ce37:abff:fe87:3a74, ce0
R1#
Route Summarization
Route summarization makes the routing table smaller, but still allows complete IP connectivity.
The following example consists of a three-router topology, in which R2 is doing the summarization. In this example, R1 is the L1 router, R2 is the L1/L2 router doing the summarization, and R3 is the L2 router. The following configuration is given only for R2, assuming that the adjacencies with R1 and R3 are already up, and the route tables with the appropriate routes are already populated.
Topology
 
Route Summarization Topology
Configuration
R1
 
#configure terminal
Enter configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-ISv6 routing on an interface for area 49(ABC).
(config-if)#ipv6 address 1000::1/64
Configure IPv6 address on interface.
(config-if)#isis circuit-type level-1
Set the circuit type as level-1 for the interface.
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)# is-type level-1
Configure instance as level-1 routing.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-router)#net 49.0001.0000.0000.0001.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#commit
Commit candidate configuration to the running configuration
R2
 
#configure terminal
Enter configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-ISv6 routing on an interface for area 49(ABC).
(config-if)#ipv6 address 1000::2/64
Configure IPv6 address on interface.
(config-if)#isis circuit-type level-1
Set the circuit type as level-1 for the interface.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#interface eth2
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-ISv6 routing on an interface for area 49(ABC).
(config-if)#ipv6 address 2000::1/64
Configure IPv6 address on interface.
(config-if)#isis circuit-type level-2-only
Set the circuit type as level-2-only for the interface.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#net 49.0001.0000.0000.0002.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#address-family ipv6
Enter 'address-family ipv6' mode, where users can configure IPv6 routing specific configuration.
(config-router-af)#redistribute isis level-2 into level-1
Enable redistribution of isis routes from level-2 into level-1
(config-router-af)#summary-prefix 11:1:1:1::/64 level-1 metric 58
Configure the summary prefix to summarize IPv6 reachability information.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-router-af)#exit-address-family
Exit address family mode.
(config-router)#exit
Exit router mode.
R3
 
#configure terminal
Enter configure mode.
(config)#ipv6 route 11:1:1:1:1:1::/96 eth2
Configure ipv6 static route.
(config)#ipv6 route 11:1:1:1:2:1::/96 eth2
Configure ipv6 static route.
(config)#ipv6 route 11:1:1:1:3:1::/96 eth2
Configure ipv6 static route.
(config)#interface eth2
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-ISv6 routing on an interface for area 49(ABC).
(config-if)#ipv6 address 2000::2/64
Configure IPv6 address on interface.
(config-if)#isis circuit-type level-2-only
Set the circuit type as level-2-only for the interface.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#net 49.0001.0000.0000.0003.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)# is-type level-2-only
Configure instance as level-2 -onlyrouting.
(config-router)#address-family ipv6
Enter 'address-family ipv6' mode, where users can configure IPv6 routing specific configuration.
(config-router-af)#redistribute static
Enable redistribution of static routes into ISIS instance.
(config-router-af)#commit
Commit candidate configuration to the running configuration
(config-router-af)#end
Exit the current mode and enter privilege mode.
Validation
R1#show clns neighbors
 
Total number of L1 adjacencies: 1
Total number of L2 adjacencies: 0
Total number of adjacencies: 1
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0002 eth1 b86a.97c4.31c5 Up 21 L1 IS-IS
 
R2#show clns neighbors
 
Total number of L1 adjacencies: 1
Total number of L2 adjacencies: 1
Total number of adjacencies: 2
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0003 eth2 b86a.97c7.32c5 Up 8 L2 IS-IS
0000.0000.0001 eth1 b86a.97cb.3ec5 Up 8 L1 IS-IS
 
R3#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 1
Total number of adjacencies: 1
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0002 eth2 b86a.97c4.31c5 Up 20 L2 IS-IS
 
R1#show ipv6 route isis
IP Route Table for VRF "default"
i ia 11:1:1:1::/64 [115/68] via fe80::eac5:7aff:fe6b:732e, eth1, 00:00:25
i ia 2000::/64 [115/20] via fe80::eac5:7aff:fe6b:732e, eth1, 00:01:15
R1#
 
R2#show ipv6 route isis
IP Route Table for VRF "default"
i 11:1:1:1::/64 [115/0] via ::, Null, 00:01:56
i L2 11:1:1:1:1:1::/96 [115/10] via fe80::eac5:7aff:fe7d:5332, eth2, 00:01:56
i L2 11:1:1:1:2:1::/96 [115/10] via fe80::eac5:7aff:fe7d:5332, eth2, 00:01:56
i L2 11:1:1:1:3:1::/96 [115/10] via fe80::eac5:7aff:fe7d:5332, eth2, 00:01:56
R2#
 
R3#show ipv6 route isis
IP Route Table for VRF "default"
i L2 1000::/64 [115/20] via fe80::eac5:7aff:fe6b:7332, eth2, 00:02:08
 
R1#show ipv6 isis route
 
Codes: C - connected, E - external, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, D - discard, e - external metric
 
Tag ABC: VRF : default
ia 11:1:1:1::/64 [68]
via fe80::eac5:7aff:fe6b:732e, eth1
C 1000::/64 [10]
via ::, xe16
ia 2000::/64 [20]
via fe80::eac5:7aff:fe6b:732e, eth1
R2#show ipv6 isis route
 
Codes: C - connected, E - external, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, D - discard, e - external metric
 
Tag ABC: VRF : default
D 11:1:1:1::/64 [0]
via ::
L2 11:1:1:1:1:1::/96 [10]
via fe80::eac5:7aff:fe7d:5332, eth2
L2 11:1:1:1:2:1::/96 [10]
via fe80::eac5:7aff:fe7d:5332, eth2
L2 11:1:1:1:3:1::/96 [10]
via fe80::eac5:7aff:fe7d:5332, eth2
C 1000::/64 [10]
via ::, xe16
C 2000::/64 [10]
via ::, xe20
 
R3#show ipv6 isis route
 
Codes: C - connected, E - external, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, D - discard, e - external metric
 
Tag ABC: VRF : default
E 11:1:1:1:1:1::/96 [0]
via ::
E 11:1:1:1:2:1::/96 [0]
via ::
E 11:1:1:1:3:1::/96 [0]
via ::
L2 1000::/64 [20]
via fe80::eac5:7aff:fe6b:7332, eth2
C 2000::/64 [10]
via ::, eth2
 
R1# show isis database verbose
Tag ABC: VRF : default
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0000.0001.00-00* 0x00000002 0x4755 686 0/0/0
Area Address: 49.0001
NLPID: 0x8E
IPv6 Address: 1000::1
Metric: 10 IS 0000.0000.0002.01
Metric: 10 IPv6 1000::/64
0000.0000.0002.00-00 0x00000004 0x4A36 713 0/0/0
Area Address: 49.0001
NLPID: 0x8E
IPv6 Address: 1000::2
Metric: 10 IS 0000.0000.0002.01
Metric: 10 IPv6 1000::/64
Metric: 10 IPv6-Interarea 2000::/64
Metric: 58 IPv6-Interarea 11:1:1:1::/64
0000.0000.0002.01-00 0x00000001 0x0ECB 685 0/0/0
Metric: 0 IS 0000.0000.0002.00
Metric: 0 IS 0000.0000.0001.00
 
R2#show isis database verbose
Tag ABC: VRF : default
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0000.0001.00-00 0x00000002 0x4755 657 0/0/0
Area Address: 49.0001
NLPID: 0x8E
IPv6 Address: 1000::1
Metric: 10 IS 0000.0000.0002.01
Metric: 10 IPv6 1000::/64
0000.0000.0002.00-00* 0x00000004 0x4A36 686 0/0/0
Area Address: 49.0001
NLPID: 0x8E
IPv6 Address: 1000::2
Metric: 10 IS 0000.0000.0002.01
Metric: 10 IPv6 1000::/64
Metric: 10 IPv6-Interarea 2000::/64
Metric: 58 IPv6-Interarea 11:1:1:1::/64
0000.0000.0002.01-00* 0x00000001 0x0ECB 658 0/0/0
Metric: 0 IS 0000.0000.0002.00
Metric: 0 IS 0000.0000.0001.00
 
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0000.0002.00-00* 0x00000004 0x67A6 676 0/0/0
Area Address: 49.0001
NLPID: 0x8E
IPv6 Address: 2000::1
Metric: 10 IS 0000.0000.0003.01
Metric: 10 IPv6 2000::/64
Metric: 10 IPv6 1000::/64
0000.0000.0003.00-00 0x00000002 0xC118 675 0/0/0
Area Address: 49.0001
NLPID: 0x8E
IPv6 Address: 2000::2
Metric: 10 IS 0000.0000.0003.01
Metric: 10 IPv6 2000::/64
Metric: 0 IPv6 11:1:1:1:1:1::/96
Metric: 0 IPv6 11:1:1:1:2:1::/96
Metric: 0 IPv6 11:1:1:1:3:1::/96
0000.0000.0003.01-00 0x00000001 0x2DA9 671 0/0/0
Metric: 0 IS 0000.0000.0003.00
Metric: 0 IS 0000.0000.0002.00
 
R3#show isis database verbose
Tag ABC: VRF : default
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0000.0002.00-00 0x00000004 0x67A6 605 0/0/0
Area Address: 49.0001
NLPID: 0x8E
IPv6 Address: 2000::1
Metric: 10 IS 0000.0000.0003.01
Metric: 10 IPv6 2000::/64
Metric: 10 IPv6 1000::/64
0000.0000.0003.00-00* 0x00000002 0xC118 606 0/0/0
Area Address: 49.0001
NLPID: 0x8E
IPv6 Address: 2000::2
Metric: 10 IS 0000.0000.0003.01
Metric: 10 IPv6 2000::/64
Metric: 0 IPv6 11:1:1:1:1:1::/96
Metric: 0 IPv6 11:1:1:1:2:1::/96
Metric: 0 IPv6 11:1:1:1:3:1::/96
0000.0000.0003.01-00* 0x00000001 0x2DA9 602 0/0/0
Metric: 0 IS 0000.0000.0003.00
Metric: 0 IS 0000.0000.0002.00
Passive Interface
In ISP and large enterprise networks, many of the distribution routers have more than 200 interfaces. Before the Default Passive-Interface feature, there were two possibilities for obtaining routing information from tall of these interfaces:
• Configure a routing protocol on the backbone interfaces and redistribute connected interfaces.
• Configure the routing protocol on all interfaces and manually set most of them as passive, which was time consuming.
The solution to this problem was to configure the routing protocol on all interfaces and manually set the passive interface command on the interfaces where adjacency was not desired. In certain networks, this meant coding 200 or more passive-interface statements. With the Default Passive Interface feature, this problem is solved by allowing all interfaces to be set as passive by default using a single passive-interface default command, then configuring individual interfaces in which adjacencies are desired using the no passive-interface command.
Usage
1. When a specific interface is configured as passive using the passive-interface command:
• The interface loses its adjacency on that interface, for example, eth1.
• The interface (eth1) is still advertised by other IS-IS speaking interfaces to their neighbors.
2. When a specific interface is configured as passive using passive-interface command followed by removing the configuration using no passive-interface command:
• The interface is IS-IS disabled and must be enabled using the ipv6 router isis command (for example, ipv6 router isis 1).
• The interface (for example, eth1) is not advertised by other IS-IS speaking interfaces to their neighbors.
3. When an interface is configured with the passive interface command:
• All interfaces lose their adjacency, except the interface with the higher index number. (For example: If eth1, eth2, eth3, and eth4 are the router interfaces, eth4 has the highest index number.)
• All interfaces are advertised by the active IS-IS speaking interface to its neighbors.
4. When an interface is configured with the no passive interface command:
• All interfaces are IS-IS disabled, except the interface that was active, and all interfaces must enable IS-IS on these interfaces using the ipv6 router isis command (for example, ipv6 router isis 1).
• All interfaces are not advertised by the active IS-IS speaking interface to its neighbors.
Topology
 
IS-ISv6 Passive Interface
Configuration
R1
 
#configure terminal
Enter configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-ISv6 routing on an interface for area 49(ABC).
(config-if)#ipv6 address 1000::1/64
Configure IPv6 address on interface.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#is-type level-2-only
Configure instance as level-2-only routing.
(config-router)#net 49.0005.0000.0000.0001.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-router)#end
Exit the current mode and enter privilege mode.
R2
 
#configure terminal
Enter configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-ISv6 routing on an interface for area 49(ABC).
(config-if)#ipv6 address 1000::2/64
Configure IPv6 address on interface.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#interface eth2
Enter interface mode.
(config-if)# ipv6 router isis ABC
Enable OSPFv3 routing on an interface and assign the Area ID 0.
(config-if)#ipv6 address 2000::1/64
Configure IPv6 address on interface.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#is-type level-2-only
Configure instance as level-2-only routing.
(config-router)#net 49.0005.0000.0000.0002.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#passive-interface eth1
Configure interface eth1 as a passive-interface.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-router)#end
Exit the current mode and enter privilege mode.
R3
 
#configure terminal
Enter configure mode.
(config)#interface eth2
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-ISv6 routing on an interface for area 49(ABC).
(config-if)#ipv6 address 2000::2/64
Configure IPv6 address on interface.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#is-type level-2-only
Configure instance as level-2-only routing.
(config-router)#net 49.0005.0000.0000.0003.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-if)#commit
Commit candidate configuration to the running configuration
(config-router)#end
Exit the current mode and enter privilege mode.
Validation
R1#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 0
Total number of adjacencies: 0
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
R1#
 
 
R2#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 1
Total number of adjacencies: 1
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0003 eth2 b86a.97c7.32c5 Up 7 L2 IS-IS
R2#
 
 
R3#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 1
Total number of adjacencies: 1
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0002 eth2 b86a.97c4.31c5 Up 24 L2 IS-IS
R3#
 
 
R1#show ipv6 isis route
 
Codes: C - connected, E - external, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, D - discard, e - external metric
 
Tag ABC: VRF : default
C 1000::/64 [10]
via ::, eth1
 
R1#
 
 
R2#show ipv6 isis route
 
Codes: C - connected, E - external, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, D - discard, e - external metric
 
Tag ABC: VRF : default
C 1000::/64 [0]
via ::, eth1
C 2000::/64 [10]
via ::, eth2
 
R2#
 
R3#show ipv6 isis route
 
Codes: C - connected, E - external, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, D - discard, e - external metric
 
Tag ABC: VRF : default
L2 1000::/64 [10]
via fe80::ba6a:97ff:fec4:31c5, eth2
C 2000::/64 [10]
via ::, eth2
 
R3#
 
 
R1#show isis database verbose
Tag ABC: VRF : default
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0000.0001.00-00* 0x0000000E 0x0E19 931 0/0/0
Area Address: 49.0005
NLPID: 0x8E
IPv6 Address: 1000::1
Metric: 10 IPv6 1000::/64
0000.0000.0001.01-00* 0x00000009 0xE110 0 (931) 0/0/0
0000.0000.0002.00-00 0x00000011 0xABC7 440 0/0/0
Area Address: 49.0005
NLPID: 0x8E
IPv6 Address: 1000::2
Metric: 10 IS 0000.0000.0001.01
Metric: 10 IS 0000.0000.0003.01
Metric: 10 IPv6 1000::/64
Metric: 10 IPv6 2000::/64
0000.0000.0003.00-00 0x00000002 0x9ED3 439 0/0/0
Area Address: 49.0005
NLPID: 0x8E
IPv6 Address: 2000::2
Metric: 10 IS 0000.0000.0003.01
Metric: 10 IPv6 2000::/64
0000.0000.0003.01-00 0x00000001 0x2DA9 436 0/0/0
Metric: 0 IS 0000.0000.0003.00
Metric: 0 IS 0000.0000.0002.00
 
R1#
R1#
 
R2#show isis database verbose
Tag ABC: VRF : default
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0000.0001.00-00 0x0000000D 0x2666 879 0/0/0
Area Address: 49.0005
NLPID: 0x8E
IPv6 Address: 1000::1
Metric: 10 IS 0000.0000.0001.01
Metric: 10 IPv6 1000::/64
0000.0000.0001.01-00 0x00000009 0x11C1 821 0/0/0
Metric: 0 IS 0000.0000.0001.00
Metric: 0 IS 0000.0000.0002.00
0000.0000.0002.00-00* 0x00000012 0x669F 906 0/0/0
Area Address: 49.0005
NLPID: 0x8E
IPv6 Address: 2000::1
Metric: 10 IS 0000.0000.0003.01
Metric: 0 IPv6 1000::/64
Metric: 10 IPv6 2000::/64
0000.0000.0003.00-00 0x00000002 0x9ED3 439 0/0/0
Area Address: 49.0005
NLPID: 0x8E
IPv6 Address: 2000::2
Metric: 10 IS 0000.0000.0003.01
Metric: 10 IPv6 2000::/64
0000.0000.0003.01-00 0x00000001 0x2DA9 436 0/0/0
Metric: 0 IS 0000.0000.0003.00
Metric: 0 IS 0000.0000.0002.00
 
R2#
 
R3#show isis database verbose
Tag ABC: VRF : default
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0000.0001.00-00 0x0000000D 0x2666 879 0/0/0
Area Address: 49.0005
NLPID: 0x8E
IPv6 Address: 1000::1
Metric: 10 IS 0000.0000.0001.01
Metric: 10 IPv6 1000::/64
0000.0000.0001.01-00 0x00000009 0x11C1 821 0/0/0
Metric: 0 IS 0000.0000.0001.00
Metric: 0 IS 0000.0000.0002.00
0000.0000.0002.00-00 0x00000012 0x669F 905 0/0/0
Area Address: 49.0005
NLPID: 0x8E
IPv6 Address: 2000::1
Metric: 10 IS 0000.0000.0003.01
Metric: 0 IPv6 1000::/64
Metric: 10 IPv6 2000::/64
0000.0000.0003.00-00* 0x00000002 0x9ED3 440 0/0/0
Area Address: 49.0005
NLPID: 0x8E
IPv6 Address: 2000::2
Metric: 10 IS 0000.0000.0003.01
Metric: 10 IPv6 2000::/64
0000.0000.0003.01-00* 0x00000001 0x2DA9 437 0/0/0
Metric: 0 IS 0000.0000.0003.00
Metric: 0 IS 0000.0000.0002.00
 
R3#
Enable BFD over IS-ISv6
This example shows how to configure Bidirectional Forwarding Detection with ISISv6 instance
Topology
 
Basic BFD over IS-ISv6 Topology
Configuration
R1
 
#configure terminal
Enter configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-ISv6 routing on an interface for area 49(ABC).
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#is-type level-2-only
Configure instance as level-2-only routing.
(config-router)#net 49.0005.0000.0000.0001.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#bfd all-interfaces
Enable the Bidirectional Forwarding Detection (BFD) feature on the interfaces enabled with this ISIS instance.
(config-router)#commit
Commit candidate configuration to the running configuration
(config-router)#end
Exit current mode and enter privilege mode.
R2
 
#configure terminal
Enter configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-ISv6 routing on an interface for area 49(ABC).
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#is-type level-2-only
Configure instance as level-2-only routing.
(config-router)#net 49.0005.0000.0000.0002.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#bfd all-interfaces
Enable the Bidirectional Forwarding Detection (BFD) feature on the interfaces enabled with this ISIS instance.
(config-router)#commit
Commit candidate configuration to the running configuration
(config-router)#end
Exit current mode and enter privilege mode.
Validation
R1#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 1
Total number of adjacencies: 1
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0002 eth1 b86a.97c4.31c5 Up 24 L2 IS-IS
R1#
 
R1#show bfd session
 
BFD process for VRF: (DEFAULT VRF)
=====================================================================================
Sess-Idx Remote-Disc Lower-Layer Sess-Type Sess-State UP-Time Interface Down-Reason Remote-Addr
256 256 IPv6 Single-Hop Up 00:04:26 eth1 NA fe80::ba6a:97ff:fec4:31c5/128
Number of Sessions: 1
R1#
R1#show bfd session detail
 
BFD process for VRF: (DEFAULT VRF)
====================================================================================
 
Session Interface Index : 10018 Interface name :eth1
Session Index : 256
Lower Layer : IPv6 Version : 1
Session Type : Single Hop Session State : Up
Local Discriminator : 256 Local Address : fe80::ba6a:97ff:fecb:3ec5/128
Remote Discriminator : 256 Remote Address : fe80::ba6a:97ff:fec4:31c5/128
Local Port : 49152 Remote Port : 3784
Options :
 
Diagnostics : None
 
Timers in Milliseconds :
Min Tx: 250 Min Rx: 250 Multiplier: 3
Neg Tx: 250 Neg Rx: 250 Neg detect mult: 3
Min echo Tx: 1000 Min echo Rx: 1000 Neg echo intrvl: 0
Storage type : 2
Sess down time : 00:00:00
Sess Down Reason : NA
Bfd GTSM Disabled
Bfd Authentication Disabled
 
Counters values:
Pkt In : n/a Pkt Out : n/a
Pkts Drop : 00000000000000000000 Auth Pkts Drop : 00000000000000000000
Echo Out : 00000000000000000000 IPv6 Echo Out : 00000000000000000000
IPv6 Pkt In : 00000000000000001231 IPv6 Pkt Out : 00000000000000001233
UP Count : 1 UPTIME : 00:04:30
 
Protocol Client Info:
ISIS-> Client ID: 6 Flags: 4
----------------------------------------------------------
Number of Sessions: 1
R1#
Originate Default Route to ISISv6 Neighbors
This example shows how to originate default route present to ISISv6 neighbors.
Note: To get a default route in ISIS, we should have it (said default route) in the routing table first otherwise we can use the CLI "default information originate always" which advertises default route.
Topology
 
Basic IS-ISv6 Topology
Configuration
R1
 
#configure terminal
Enter configure mode.
(config)#ipv6 route ::/0 2345::2
Configure default route.
(config)#interface eth1
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-ISv6 routing on an interface for area 49(ABC).
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#interface eth2
Enter interface mode.
(config-if)#ipv6 address 2345::1/64
Configure IPv6 address on interface.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#is-type level-2-only
Configure instance as level-2-only routing.
(config-router)#net 49.0001.0000.0000.0001.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)# address-family ipv6
Enter ipv6 address family.
(config-router-af)#default-information originate
Originate reachability information to Default destination into LSP.
(config-router-af)#commit
Commit candidate configuration to the running configuration
(config-router-af)#end
Exit all modes and enter privilege mode.
R2
 
#configure terminal
Enter configure mode.
(config)#interface eth1
Enter interface mode.
(config-if)#ipv6 router isis ABC
Enable IS-ISv6 routing on an interface for area 49(ABC).
(config-if)#commit
Commit candidate configuration to the running configuration
(config-if)#exit
Exit interface mode.
(config)#router isis ABC
Create an IS-IS routing instance for area 49 (ABC).
(config-router)#is-type level-2-only
Configure instance as level-2-only routing.
(config-router)#net 49.0005.0000.0000.0002.00
Set a Network Entity Title for this instance, specifying the area address and the system ID.
(config-router)#commit
Commit candidate configuration to the running configuration
(config-router)#end
Exit current mode and enter privilege mode
Validation
R1#sh clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 1
Total number of adjacencies: 1
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0002 eth1 cc37.ab87.3a74 Up 23 L2 IS-IS
 
R2#show clns neighbors
 
Total number of L1 adjacencies: 0
Total number of L2 adjacencies: 1
Total number of adjacencies: 1
Tag ABC: VRF : default
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0001 eth1 b86a.97cb.3ec5 Up 6 L2 IS-IS
R2#
 
R1#show ipv6 route isis
IP Route Table for VRF "default"
R1#
 
R1#show ipv6 isis route
 
Codes: C - connected, E - external, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, D - discard, e - external metric
 
Tag ABC: VRF : default
E ::/0 [0]
via ::
R1#
 
R2#show ipv6 route isis
IP Route Table for VRF "default"
i L2 ::/0 [115/10] via fe80::ba6a:97ff:fecb:3ec5, eth1, 00:09:12
R2#
 
R2#show ipv6 isis route
 
Codes: C - connected, E - external, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, D - discard, e - external metric
 
Tag ABC: VRF : default
L2 ::/0 [10]
via fe80::ba6a:97ff:fecb:3ec5, eth1
 
R2#
 
R2#show isis database verbose
Tag ABC: VRF : default
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0000.0001.00-00 0x00000006 0x5FA4 1033 0/0/0
Area Address: 49.0001
NLPID: 0x8E
Metric: 10 IS 0000.0000.0001.01
Metric: 0 IPv6 ::/0
0000.0000.0001.01-00 0x00000001 0x21B9 628 0/0/0
Metric: 0 IS 0000.0000.0001.00
Metric: 0 IS R2.00
R2.00-00 * 0x00000002 0xFBED 633 0/0/0
Area Address: 49.0001
NLPID: 0x8E
Hostname: R2
Metric: 10 IS 0000.0000.0001.01